IP : Protocolo IP multicast

Multicast sobre um túnel GRE

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para multicasting em um túnel de Generic Routing Encapsulation (GRE).

Em muitos cenários de rede você quer configurar sua rede para usar túneis GRE para enviar a transmissão múltipla independente de protocolo (PIM) e o tráfego multicast entre o Roteadores. Tipicamente, isto ocorre quando o origem de transmissão múltipla e o receptor são separados por uma nuvem IP que não esteja configurada para o roteamento IP Multicast. Em tais cenários de rede, configurar um túnel através de uma nuvem IP com o PIM permitido transporta pacotes de transmissão múltipla para o receptor. Este documento descreve a configuração, a verificação, e os problemas relacionados que referem-se multicasting sobre um túnel GRE.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Enquanto o diagrama da rede mostra, o origem de transmissão múltipla (10.1.1.1) está conectado ao R102 e configurado para o grupo de transmissão múltipla 239.1.1.20. O receptor de transmissão múltipla (10.2.2.3) é conectado ao R104 e configurado para receber pacotes de transmissão múltipla para o grupo 239.1.1.20. Separar o R102 e o R104 é uma nuvem IP, que não seja configurada para o roteamento de transmissão múltipla.

Um túnel é configurado entre o R102 ao R104 originado com suas interfaces de loopback. O comando ip pim sparse-dense mode é configurado em interfaces de túnel e o roteamento de transmissão múltipla é permitido no R102 e no R104. a configuração de modo Escasso-densa nas interfaces de túnel permite os pacotes do modo escasso ou do modo denso a ser enviados sobre o túnel segundo a configuração do ponto de reunião (RP) para o grupo.

Nota:  Para o modo denso — Com o modo denso de PIM configurado sobre o túnel, um comando do tunnel0 de 10.1.1.0 255.255.255.0 do mrouter IP é configurado no R104 assegurar um RPF bem sucedido para o endereço de origem de transmissão múltipla 10.1.1.1. (10.1.1.1, 239.1.1.20) os pacotes de transmissão múltipla entrantes sobre o tunnel0 (Tu0) são verificados para ver se há o encaminhamento de caminho reverso (RPF) que usa esta instrução mroute. Depois que uma verificação bem sucedida, os pacotes de transmissão múltipla está enviada às relações da lista de interface enviada (ÓLEO).

Nota:  Para o modo escasso — Com o modo escasso de PIM configurado sobre o túnel, assegure-se de que estes pontos estejam endereçados:

  • Para uma verificação de RPF bem-sucedida do fluxo de tráfego multicast sobre a árvore compartilhada (*, G) do RP, um comando nexthop do RP-endereço do mrouter IP precisa de ser configurado para o endereço RP, esse aponta à interface de túnel.

    Com a suposição que o R102 é o RP (endereço 2.2.2.2 RP) neste caso, a seguir o mrouter é o comando do tunnel0 de 2.2.2.2 255.255.255.255 do mrouter IP, que assegura uma verificação RPF bem sucedida para o tráfego que flui sobre a árvore compartilhada.

  • Para uma verificação de RPF bem-sucedida do Multicast (S, G) fluxo de tráfego sobre a árvore de caminho mais curta (SPT), um comando nexthop do fonte-endereço do mrouter IP precisa de ser configurado para o origem de transmissão múltipla, apontando à interface de túnel.

    Neste caso, quando o tráfego SPT está fluindo sobre a interface de túnel um comando do tunnel0 de 10.1.1.0 255.255.255.0 do mrouter IP é configurado no R104 assegurar uma verificação de RPF bem-sucedida para (10.1.1.1, 239.1.1.20) pacotes de transmissão múltipla entrantes sobre a relação Tu0.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/43584/mcast-gre2.gif

Configurações

Este documento utiliza as seguintes configurações:

Configurar o roteador 102 de acordo com este arquivo de configuração running:

R102
version 12.2
!hostname r102
!
!ip subnet-zero
no ip domain-lookup

!--- It stops IP domain lookup, which improves 
!--- the show command response time.

!
ip multicast-routing

!--- Enables IP multicast routing.

!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 
!--- Tunnel Source interface.

!
interface Tunnel0

!--- Tunnel interface configured for PIM and carrying 
!--- multicast packets to R104.

 ip address 192.168.24.1 255.255.255.252
 ip pim sparse-dense-mode
 tunnel source Loopback0
 tunnel destination 4.4.4.4
!
interface Ethernet0/0

!--- Interface connected to Source.

 ip address 10.1.1.2 255.255.255.0
 ip pim sparse-dense-mode
!
!
interface Serial8/0
 ip address 192.168.23.1 255.255.255.252

!--- Note IP PIM sparse-dense mode is 
!--- not configured on Serial interface.

!router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 10.1.1.0 0.0.0.255 area 0
 network 192.168.23.0 0.0.0.255 area 0
!
ip classless
ip pim bidir-enable
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Configurar o roteador 104 de acordo com este arquivo de configuração running:

R104
r104#
version 12.2
!
hostname r104
!
!
ip subnet-zero
no ip domain-lookup

!--- It stops IP domain lookup, which improves 
!--- the show command response time.

!
ip multicast-routing

!--- Enables IP multicast routing.

!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255

!--- Tunnel Source interface.

!
interface Tunnel0
 ip address 192.168.24.2 255.255.255.252

!--- Tunnel interface configured for PIM 
!--- and carrying multicast packets.

 ip pim sparse-dense-mode
 tunnel source Loopback0
 tunnel destination 2.2.2.2
!
interface Ethernet0/0
 ip address 10.2.2.2 255.255.255.0
 ip pim sparse-dense-mode
!
interface Serial9/0
 ip address 192.168.34.1 255.255.255.252

!--- Note IP PIM sparse-dense mode is not 
!--- configured on Serial interface.

!
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 10.2.2.0 0.0.0.255 area 0
 network 192.168.34.0 0.0.0.255 area 0
!
ip classless
no ip http server
ip pim bidir-enable
ip mroute 10.1.1.0 255.255.255.0 Tunnel0


!--- This mroute ensures a successful RPF check 
!--- for packets flowing from the source.
!--- 10.1.1.1 over Shared tree in case of Dense 
!--- more and SPT in case of Sparse mode.

!
ip mroute 2.2.2.2 255.255.255.255 tunnel 0


!--- This mroute is required for RPF check when 
!--- Sparse mode multicast traffic is 
!--- flowing from RP (assuming R102 with 2.2.2.2 as RP)
!--- towards receiver via tunnel  
!--- before the SPT switchover.

line con 0
line aux 0
line vty 0 4
 login
!
end

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • mostre o grupo de IGMP IP — Verifica que o receptor enviou seu IGMP se junta ao pedido da sociedade para o grupo 239.1.1.20 ao R104.

    r104#show ip igmp groups 
    IGMP Connected Group Membership
    Group Address    Interface          Uptime    Expires   Last Reporter
    239.1.1.20       Ethernet0/0        00:00:04  00:02:55  10.2.2.3
  • mostre o endereço de grupo do mrouter IP — Verifica que quando a fonte 10.1.1.1 começar multicasting pacotes para o grupo 239.1.1.20, o R102 instala (*,239.1.1.20) e (10.1.1.1, 239.1.1.20) entradas na tabela de mroute R102.

    Nota: (10.1.1.1, 239.1.1.20) na entrada, o ÓLEO é tunnel0.

    r102#show ip mroute 239.1.1.20
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report
    Outgoing interface flags: H - Hardware switched
    Timers: Uptime/Expires
    Interface state: Interface, Next-Hop or VCD, State/Mode
    
    (*, 239.1.1.20), 00:00:09/00:02:59, RP 0.0.0.0, flags: D
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Tunnel0, Forward/Sparse-Dense, 00:00:09/00:00:00
        Ethernet0/0, Forward/Sparse-Dense, 00:00:09/00:00:00
    
    (10.1.1.1, 239.1.1.20), 00:00:09/00:02:58, flags: T
      Incoming interface: Ethernet0/0, RPF nbr 0.0.0.0
      Outgoing interface list:
        Tunnel0, Forward/Sparse-Dense, 00:00:09/00:00:00
  • mostre o endereço de grupo do mrouter IP — Verifica que o R104 tem (*,239.1.1.20) e (10.1.1.1, 239.1.1.20) entradas quando for pacotes de transmissão múltipla de encaminhamento para o grupo 239.1.1.20 originado de 10.1.1.1.

    Nota: Em (10.1.1.1, 239.1.1.20), a interface de entrada é tunnel0 e o vizinho de RPF é 192.168.24.1 — a extremidade principal do túnel no R102. A verificação RPF é feita com base no mrouter configurado no R104, e os pacotes de transmissão múltipla são eliminados ao ÓLEO ao receptor conectado na relação do Ethernet0/0.

    r104#show ip mroute 239.1.1.20
    IP Multicast Routing Table
    Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
           L - Local, P - Pruned, R - RP-bit set, F - Register flag,
           T - SPT-bit set, J - Join SPT, M - MSDP created entry,
           X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
           U - URD, I - Received Source Specific Host Report
    Outgoing interface flags: H - Hardware switched
    Timers: Uptime/Expires
    Interface state: Interface, Next-Hop or VCD, State/Mode
    
    (*, 239.1.1.20), 00:07:10/00:00:00, RP 0.0.0.0, flags: DCL
      Incoming interface: Null, RPF nbr 0.0.0.0
      Outgoing interface list:
        Tunnel0, Forward/Sparse-Dense, 00:07:10/00:00:00
        Ethernet0/0, Forward/Sparse-Dense, 00:07:10/00:00:00
    
    (10.1.1.1, 239.1.1.20), 00:01:13/00:02:24, flags: CLT
      Incoming interface: Tunnel0, RPF nbr 192.168.24.1, Mroute
      Outgoing interface list:
        Ethernet0/0, Forward/Sparse-Dense, 00:01:13/00:00:00
  • mostre o IP address IP rpf — Execute uma verificação de RPF de pacotes originados de 10.1.1.1. O exemplo seguinte confirma que o RPF para 10.1.1.1 é através do tunnel0, em que nós estamos recebendo o Multicast (S, G) pacotes.

    r104>show ip rpf 10.1.1.1
    RPF information for ? (10.1.1.1)
      RPF interface: Tunnel0
      RPF neighbor: ? (192.168.24.1)
      RPF route/mask: 10.1.1.1/24
      RPF type: static
      RPF recursion count: 0
      Doing distance-preferred lookups across tables

Troubleshooting

Use esta seção para resolver problemas de configuração.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

Se seu Multicast sobre o túnel GRE não está trabalhando, um destes pode ser a causa:

  • UP/UP do túnel não — O origem e destino do túnel não combina em cada extremidade do túnel. Por exemplo, se o destino de túnel no R102 foi mudado ao endereço IP 10.2.2.2 em vez de 2.2.2.2 quando a configuração no R104 permaneceu a mesma, o túnel não viria acima.

    Emita o comando show interface tunnel 0 a fim verificar o estado do túnel.

  • Os pacotes de transmissão múltipla são deixados cair devido à falha de RPF.

    Emita o comando show ip mroute count. Um exemplo de saída deste comando e de seus contadores crescentes para a falha de RPF é mostrado nesta saída:

    r104#show ip mroute count
    IP Multicast Statistics
    3 routes using 1642 bytes of memory
    2 groups, 0.50 average sources per group
    Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
    Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
    
    Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
    
    Group: 239.1.1.20, Source count: 1, Packets forwarded: 11, Packets received: 45
      Source: 10.1.1.1/32, Forwarding: 11/0/100/0, Other: 25/14/0
    
    
    !--- After some time, the show ip mroute count command 
    !--- is issued again. You can see the RPF failed counter increasing:
    
    r104#show ip mroute count
    IP Multicast Statistics
    3 routes using 1642 bytes of memory
    2 groups, 0.50 average sources per group
    Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
    Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
    
    Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
    
    Group: 239.1.1.20, Source count: 1, Packets forwarded: 11, Packets received: 50
      Source: 10.1.1.1/32, Forwarding: 11/0/100/0, Other: 30/19/0
    r104#

    Você pode igualmente emitir o comando source da mostra IP rpf. Assegure-se de que a relação RPF seja a mesma que aquela em que os pacotes de transmissão múltipla da fonte são recebidos — tunnel0 neste exemplo. Refira o guia de Troubleshooting de IP Multicast para obter mais informações sobre das falhas de RPF.

  • Vizinhos de PIM — O roteador R102 não está enviando sobre a relação do tunnel0 porque não está considerando um vizinho R104 PM.

    Execute estes comandos:

    • mostre o vizinho do pim IP — Você pode usar o comando show ip pim neighbor no R102 mostrar o vizinho R104 sobre o túnel.

    • mostre o pim int IP — Você pode igualmente usar o comando show ip pim int mostrar que há um vizinho.

    • sparse-dense-mode do pim IP — Verifique que o comando ip pim sparse-dense-mode do nível de interface está configurado no ambas as extremidades do túnel e que o roteamento de transmissão múltipla IP está permitido.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 43584