Banda larga a cabo : Gerenciamento de cabo e serviços

Configurando a terminação de PPPoE em um uBR7100 CMTS com tunelamento de L2TP

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo da terminação do Point-to-Point Protocol sobre Ethernet (PPPoE) em uma rede de Banda larga a cabo usando o cable modem termination system (CMTS) do Cisco uBR7100 como o concentrador do acesso local (LAC). Neste documento, a sessão de PPPoE é iniciada por um Cisco 1600 Router como o PPPoE Client, e transmite o tráfego PPP através de uma conexão de túnel segura do protocolo layer two tunneling (L2TP) ao L2TP Network Server (LNS). O roteador LNS encerra o túnel L2TP do Cisco CMTS e pode encaminhar o tráfego para a rede corporativa.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Os leitores deste documento devem estar familiarizados com o RFC 2516, que descreve as regras que governam o PPPoE, bem como o protocolo DOCSIS (Data-over-Cable Service Interface Specifications).leavingcisco.com Este documento não descreve como definir a rede física de Banda Larga a Cabo. Antes de tentar configurar uma solução PPPoE, o Modems a cabo do em conformidade com DOCSIS deve ser em linha e operando-se no modo de Bridging. Para obter mais informações sobre solução de problemas de CMS, consulte Troubleshooting uBR Cable Modems Not Coming Online (Solucionando problemas de modems a cabo uBR que não ficam on-line).

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • O recurso de terminação PPPoE é suportado somente em Roteadores de Banda Larga Universais (uBR) da série Cisco uBR7100 e Cisco uBR7246VXR.

  • O roteador do Cisco CMTS deve executar a liberação 12.2(4)BC1a de Cisco IOS� ou uma liberação mais atrasada. Além, para apoiar a característica da terminação de PPPoE, o nome da imagem do software deve incluir o conjunto de recursos IP+ (as letras “eu” e “s” devem aparecer no nome da imagem do software).

  • Para suportar a terminação PPPoE em interfaces de cabo de pacote, o roteador Cisco CMTS deve estar executando o Cisco IOS versão 12.2(8)BC2 ou posterior.

  • O software cliente deve suportar o protocolo de terminação de PPPoE. Se o sistema operacional do computador não inclui tal apoio, o usuário pode usar o software do cliente tal como WinPoet. Este documento usa um Cisco 1600 como o cliente PPPoE.

A informação nesta instalação de laboratório particular é baseada nas versões de software e hardware abaixo.

  • O Cisco uBR7111 CMTS é o Cisco IOS Release running uBR7100-ik8s-mz.122-11.BC1.

  • O Cisco 1600 Router é Cisco IOS Release running Cisco 1600-sy-mz.122-11.T8.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Material de Suporte

O PPPoE fornece a capacidade de conectar uma rede de hosts via um dispositivo de acesso de Bridging simples com um concentrador de acesso remoto. O PPPoE pode permitir a conexão direta com interfaces de cabo. O apoio do PPPoE em interfaces de cabo do Cisco uBR7100 e do Roteadores do uBR7200 Series permite que o Customer Premises Equipment (CPE) atrás do modem a cabo use o PPP como um mecanismo para obter seus endereços IP de Um ou Mais Servidores Cisco ICM NT e para usá-los para todo o tráfego de dados subsequentes, similar a um cliente PPP do tratamento por imagens. Em uma sessão do tratamento por imagens PPP, a sessão de PPPoE é autenticada e o endereço IP de Um ou Mais Servidores Cisco ICM NT é negociado entre o PPPoE Client e o server, que poderiam ser um roteador do Cisco CMTS ou um Home Gateway. Com este modelo, cada host utiliza sua própria pilha de PPP. Portanto, o controle de acesso, conta e tipo de serviço podem ser melhor realizados por usuário do que por local. Os fornecedores de serviço podem suportar clientes PPPoE e hosts baseados em DHCP (Protocolo de configuração de host dinâmico) atrás do mesmo CM.

O PPPoE tem duas estágios diferentes, um estágio de descoberta e um estágio de sessão PPP. Quando um host deseja iniciar uma sessão de PPPoE, deve primeiramente executar a descoberta para identificar o endereço MAC de Ethernet do par e para estabelecer um PPPoE SESSION_ID. Quando o PPP definir um relacionamento peer-to-peer, a descoberta é inerentemente um relacionamento cliente/servidor. No processo de descobrimento, um host (o cliente) descobre um concentrador de acessos (o servidor). Com base na topologia da rede, haverá mais de um concentrador de acesso com o qual o host poderá se comunicar. O estágio de descoberta permite que o host descubra todos os concentradores de acesso e selecione um. Quando a descoberta é concluída com êxito, tanto o host como o concentrador de acesso selecionado têm as informações que serão usadas para criar sua conexão ponto a ponto com a Ethernet. Uma vez iniciada a sessão de PPPoE, os dados de PPP são enviados como em qualquer outro encapsulamento de PPP.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/43241/pppoe_ubr7200.gif

Configurações

Este documento utiliza as configurações mostradas abaixo.

Cisco 1600 Router (PPPoE Client)
PPPoE_client#show running-config 
Building configuration...

Current configuration : 1099 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname PPPoE_client
!
no logging console
enable password cisco
!

username LAC password 0 cisco


!--- Cmts-user name/password sent to LNS to create the L2TP tunnel. 


username LNS password 0 cisco


!--- Lns-user name/password used by LNS to authenticate tunnel creation. 


username user@surf.org


!--- Specifies a username and password for each user to be granted PPPoE access.

!--- This can be configured on the RADIUS authentication servers.


ip subnet-zero
no ip domain lookup
ip domain name surf.org
!
vpdn enable
!
vpdn-group 1
 request-dialin
  protocol pppoe
!
!
!
!
interface Ethernet0
 no ip address
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface Virtual-Template1
 no ip address
 ip mtu 1492
 no peer default ip address
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname user@surf.org
 ppp chap password 0 cisco
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
!
access-list 1 permit any
!
!
line con 0
line vty 0 4
 password cisco
 login
!
end

Cisco uBR7100 CMTS (LAC)
LAC#show running-config 
Building configuration...

Current configuration : 2442 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname "LAC"
!
no logging console
enable password cisco
!

!--- Cmts-user name/password sent to LNS to create the L2TP tunnel. 


username LAC password 0 cisco


!--- Lns-user name/password used by LNS to authenticate tunnel creation.

username LNS password 0 cisco


!--- Specifies a username and password for each user to be granted PPPoE access.

!--- This can be configured on the RADIUS authentication servers.

username user@surf.org

no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp
!
ip subnet-zero
!
!
no ip domain lookup
!
ip dhcp pool pppoe
   network 10.1.4.0 255.255.255.0
   bootfile platinum.cm
   next-server 10.1.4.1
   default-router 10.1.4.1
   option 7 ip 10.1.4.1
   option 4 ip 10.1.4.1
   option 2 hex ffff.8f80
   lease 7 0 10
!
ip dhcp pool pppoe_clients
   network 172.16.29.0 255.255.255.224
   next-server 172.16.29.1
   default-router 172.16.29.1
   domain-name surf.org
   lease 7 0 10
!

!--- Enables Virtual Private Dial-Up Networking (VPDN). 

vpdn enable

vpdn logging


!--- VPDN group 1 configures the router to accept PPPoE connections.
!--- Specifies the virtual template used for the virtual interfaces that are created 
!--- for each PPPoE session. 


!
vpdn-group 1
 accept-dialin
  protocol pppoe
  virtual-template 1


!--- VPDN group 2 configures the group to be used for the L2TP tunnel to the LNS. 
!--- PPPoE sessions will be initiated from clients using the domain surf.org.


vpdn-group 2
 request-dialin
  protocol l2tp
  domain surf.org
 initiate-to ip 1.1.1.8
 local name LAC


!--- Disables authentication for creation of L2TP tunnel. 


 no l2tp tunnel authentication
!
!
!
!
interface FastEthernet0/0
 ip address 2.2.2.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 1.1.1.6 255.255.255.0
 ip broadcast-address 1.1.1.255
 no ip route-cache
 no ip mroute-cache
 duplex auto
 speed 10
!
interface Cable1/0
 ip address 172.16.29.1 255.255.255.224 secondary
 ip address 10.1.4.1 255.255.255.0
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 471000000
 cable downstream channel-id 0
 no cable downstream rf-shutdown
 cable downstream rf-power 51
 cable upstream 0 frequency 32000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable dhcp-giaddr policy 


!--- pppoe enable must be configured on the cable 
!--- interface accepting PPPoE sessions.
!--- This is not necessary on subinterfaces. 

 pppoe enable
!
interface Virtual-Template1
 ip unnumbered FastEthernet0/1
 ip mtu 1492

ppp authentication chap
!

ip classless
no ip http server
!
!
cdp run
!
snmp-server community private RW
snmp-server enable traps tty
alias exec scm show cable modem
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
line vty 5 15
 login
!
end

Cisco 2500 (LNS)
hostname "LNS"
!
!

!--- Lns-user name/password for the LNS itself. 


username LNS password 0 cisco


!--- Cmts-user name/password for the Cisco CMTS. 


username LAC password 0 cisco


!--- Username and password for the PPPoE client. 
!--- This can be configured on the RADIUS authentication servers.


username user@surf.org password 0 cisco
! 
vpdn enable 
!

!--- Creates a VPDN group and starts VPDN group configuration mode.

vpdn-group 1
accept-dialin


!--- Configures VPDN group for L2TP protocol so that it 
!--- can access the PPPoE server.


protocol l2tp


!--- Specifies the virtual-template number to be used when 
!--- configuring a PPPoE session. 


virtual-template 1


!--- This group terminates L2TP tunnels from the specified CMTS hostname.


terminate-from hostname LAC 


!--- This is the local hostname of the LNS.


local name LNS


!--- Disables authentication for creation of L2TP tunnel. 


no l2tp tunnel authentication
!
!
!
interface Virtual-Template1
ip unnumbered FastEthernet0/1
ip mtu 1492


!--- Surf is used as the pool name, and  
!--- the router will use an address from the 100-net.
 

!--- If a test cannot be found, it will search for the pool with the name default.


peer default ip address pool surf
ppp authentication chap
!
ip local pool surf 100.0.0.1 100.0.0.10

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Procedimentos

Para verificar se um endereço IP está sendo enviado de um conjunto LNS, siga as etapas abaixo.

  1. Emita o comando show ip local pool do LNS. Verifique a saída do comando.

    LNS#show ip local pool 
    
     Pool                    Begin              End                   Free     In use 
     surf                    100.0.0.1          100.0.0.10             9         1 
    
  2. Para identificar o chamador bem-sucedido, emita o comando show caller ip do LNS.

    LNS#show caller ip 
    
      Line           User                        IP Address      Local Number    Remote Number   <-> 
      Vi29           user@surf.org               100.0.0.1            -                -          in
  3. Para verificar a sessão VPDN no LNS, emita o comando show vpdn session.

    LNS#show vpdn session 
    
    L2TP Session Information Total tunnels 1 sessions 1 
    
    LocID RemID TunID Intf          Username                  State    Last Chg  Fastswitch 
    30    299   23629 Vi29          user@surf.org             est      00:16:03  enabled 
    
    %No active L2F tunnels 
    
    %No active PPTP tunnels 
    
    %No active PPPoE tunnels 
    

Use as etapas abaixo para verificar o número da interface de molde virtual que está sendo usado por um PPPoE Client.

  1. Emita o comando show vpdn session do LAC. Verifique a saída do comando.

    LAC# show vpdn session
    L2TP Session Information Total tunnels 1 sessions 1 
    LocID RemID TunID    Intf       Username                 State      Last Chg  Fastswitch 
    299   30    26280    Vi1        user@surf.org            est        00:31:19  enabled 
    
    %No active L2F tunnels 
    
    %No active PPTP tunnels 
    
    PPPoE Session Information Total tunnels 1 sessions 1 
    
    PPPoE Session Information 
    SID       RemMAC              LocMAC           Intf     VASt    OIntf  VLAN/VP/VC 
    1         0030.9413.0556      0008.a328.831c   Vi1       UP     Ca1/0
    
  2. Para exibir usuários que se registraram no Cisco CMTS utilizando PPPoE, emita o comando show interface cable modem.

    LAC#show interface cable 1/0 modem 0 
    SID Priv bits     Type       State          IP address        method            MAC address 
    1 00                 modem    up             10.1.4.2          dhcp            0010.9526.2f57 
    2 00                 modem    up             10.1.4.3          dhcp            0007.0e03.a7e5 
    2 00                 host   unknown          172.16.29.2       static          0007.0e03.a7e4 
    3 00                 modem    up             10.1.4.4          dhcp            0007.0e02.c893 
    3 00                 host   unknown                            pppoe           0030.9413.0556 
    4 00                 modem    up             10.1.4.5          dhcp            0007.0e03.5075 
  3. Para exibir os domínios de VPDN atuais, emita o comando show vpdn domain.

    LAC#show vpdn domain 
    Tunnel VPDN Group 
    ------ ---------- 
    domain:surf.org2 (L2TP) 
    

Troubleshooting

Procedimento de Troubleshooting

Use as instruções abaixo para pesquisar defeitos sua configuração.

  1. Verifique o LAC para ver o status das interfaces ao emitir o comando show ip interface brief.

    Se algumas das relações estão para baixo, verifique o cabo físico e certifique-se que as relações não estão administrativamente para baixo.

    LAC#show ip interface brief 
    Interface                 IP-Address        OK?     Method         Status        Protocol 
    FastEthernet0/0            2.2.2.2          YES     NVRAM            up             up 
    
    FastEthernet0/1            1.1.1.6          YES     NVRAM            up             up 
    
    Cable1/0                   10.1.4.1         YES     NVRAM            up             up 
    
    Virtual-Access1            1.1.1.6          YES     TFTP             up             up 
    
    Virtual-Template1          1.1.1.6          YES     unset           down           down 
    
    
  2. Verifique a relação no PPPoE_client para verificar que a interface do discador está ascendente e tem um endereço IP de Um ou Mais Servidores Cisco ICM NT do pool LNS.

    PPPoE_client#show ip interface brief  
    Interface                  IP-Address      OK? Method       Status                Protocol 
    Dialer1                    100.0.0.1         YES BOOTP        up                    up 
    
    Ethernet0                  unassigned        YES NVRAM        up                    up 
    
    Serial0                    unassigned        YES NVRAM        up                    up 
    
    Serial1                    unassigned        YES NVRAM        up                    up 
    
    Virtual-Access1            unassigned        YES unset        up                    up 
  3. Verifique se você pode executar o ping do LNS a partir do cliente PPPoE.

    PPPoE_client#ping 1.1.1.8 
    
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 1.1.1.8, timeout is 2 seconds: 
    !!!!!  Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/16 ms 
    
  4. Se você estiver com problemas em iniciar o L2TP, tente emitir o comando lcp renegotiation on-mismatch configurado no grupo VPDN do LNS.

    LNS#config t 
    Enter configuration commands, one per line.  End with CNTL/Z. 
    LNS(config)#vpdn-group 1 
    LNS(config-vpdn)#lcp renegotiation on-mismatch 

    Nota: O protocolo de controle de link (LCP) dos proxys LAC quando o PPP começar. Quando o LNS percebe o PPP encaminhado, ele analisa o LCP e, se não for o que ela havia negociado com o cliente, ele reclama. O comando lcp renegotiation on-mismatch força o LNS a renegociar o LCP com o cliente. Nem todos os clientes negociarão LCP, entretanto, a maioria o faz.

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

  • debugar a negociação ppp — Emitir este comando no LNS permite que você ver as transações da negociação de PPP para identificar o problema ou para encená-lo quando o erro ocorre e desenvolve uma definição. É imperativo, no entanto, que você entenda o comando debug ppp negotiation. Entender a saída do comando debug ppp negotiation, fornece um método compreensivo para a leitura e o Troubleshooting do PPP.

  • debugar erros do vpdn 12x-packet — Iissuing este comando indica os erros de protocolo L2F e L2TP que impedem o estabelecimento de túnel ou a operação normal

  • debug vpdn 12x-packet events— A emissão deste comando no LNS exibe eventos L2TP que fazem parte do estabelecimento de túnel ou desligamento.

  • debug vpdn packet [controle | data] [detail] - a emissão deste comando no LNS ou no LAC exibe informações de cabeçalho de pacote específicas de protocolo, como números de seqüência (se houver), flags e comprimento.

  • debug vpdn event [protocolo | controlo de fluxo] — emitindo este comando no LNS ou os eventos do LAC exibe erro VPN e os básicos dentro do protocolo e dos erros L2TP associados com o controle de fluxo onde o peer remoto recebe o indicador é configurado para um valor maior de zero.

  • debugar ppp {rachadura | pap} — emitir este comando indica o protocolo de autenticação de cumprimento do desafio (RACHADURA) e o protocolo password authentication (PAP) que é construído no PPP.

  • debug ip udp— A emissão deste comando no LNS verifica na saída se estão sendo recebidos pacotes do host pppoe.

  • debugar o aaa por usuário — Emitindo este comando dos indicadores LNS que atributos estão aplicados a cada usuário enquanto o usuário autentica.

  • debugar o raio — Emitir este comando indica a informação associada quando os usuários autenticam usando um servidor Radius.

Perguntas mais freqüentes

Q. Cisco CMTS apoia o encaminhamento de PPPoE?

R. Não. Os roteadores do Cisco CMTS não apoiam o encaminhamento de PPPoE, que os recebe pacotes de PPPoE de uma interface de entrada e para a frente para fora em uma interface enviada. O Roteadores da Cisco UBR 7100 Series envia automaticamente o tráfego PPPoE quando configurado para o modo de Bridging MxU (que é apoiado somente no Cisco IOS Release 12.1 EC), contudo, isto é uma consequência da configuração de Bridging e não devido a todo o Suporte PPPoE. Para fornecer a claridade, o encaminhamento de PPPoE não é apoiado em nenhum Cisco CMTS.

Q. Posso eu ter PPPoE Client e clientes regulares do protocolo de configuração dinâmica host (DHCP) ao mesmo tempo na mesma planta DOCSIS?

R. Sim. O recurso de terminação de PPPoE suporta ao uso simultâneo de clientes PPPoE e clientes DHCP atrás dos mesmos CMs. Os assinantes podem usar o PPPoE para logon inicial na rede a cabo e, em seguida, usar o DHCP para permitir que os outros PCs e outros hosts obtenham endereços IP para acesso a rede.

Q. Há suporte PPPoE para NPE-300 e NPE-400 nas plataformas CMTS Cisco uBR7200VXR?

R. Sim. O processador NPE-300 encerrado dia 15 de agosto de 2001, no entanto.

Q. O PPPoE é suportado na plataforma Cisco uBR10k CMTS?

R. Não. O recurso de terminação PPPoE somente é suportado em Cisco uBR7100 Series Routers ou Cisco uBR7246VXR Router, usando o Cisco IOS Release 12.2(4)BC1a, ou posterior. Ele não é suportado no roteador Cisco uBR10012.

Q. Quantas sessões de PPPoE posso eu executar na plataforma Cisco CMTS?

R. A plataforma uBR herda um limite de IDB de 10000 da plataforma cisco 7200 o qual oferece suporte a sessões 4000 PPPoE com um NPE-225 e um NPE-300, enquanto as sessões 8000 PPPoE são suportadas com um NPE-400. A plataforma uBR7100 que não precisa ter NPEs suporta as sessões 4000 PPPoE. Estes são limites teóricos. Você deve considerar que o número máximo de sessões PPPoE simultâneas e ativas é menor, dependendo da quantidade de memória instalada na placa do processador, o tipo de placas de interface de cabo sendo usado, a largura de banda sendo consumida por cada usuário e a configuração do roteador.

Q. Que liberação do Cisco IOS é terminação de PPPoE apoiou no trem EC?

R. A característica da terminação de PPPoE não é apoiada em nenhum roteador do Cisco CMTS ao usar o Cisco IOS Release 12.1 EC.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 43241