Voz e comunicações unificadas : Cisco Unified Communications Manager (CallManager)

Configurando a porta de comunicação MGCP Cisco IOS

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (3 Abril 2008) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento:

  • Guia-o com uma configuração simples do Media Gateway Control Protocol (MGCP)

  • Apresenta somente os comandos required mínimos construir uma configuração que trabalhe para um roteador com duas duas da estação de câmbio internacional (FXO) portas do escritório de câmbio internacional (FXO) e

Nota: As instruções neste documento trabalham para um cisco voice gateway 200 (VG200) e os Cisco 2600 e 3600 Series Router que executam o Software Release 12.1(5)T e Mais Recente de Cisco IOS�. Refira a documentação do Cisco IOS Software para liberações de software suportado de outros gateways MGCP do Cisco IOS.

Sintomas:

Você pode potencialmente encontrar esta lista de sintomas quando você configura o CallManager da Cisco com os gateways MGCP do Cisco IOS com portas FXO analógicos e FXS:

  • O gateway MGCP não se registra com CallManager da Cisco. Refira a falha de registro do gateway MGCP com CallManager da Cisco.

  • O ID de chamada não trabalha em portas FXO. Isto é porque o ID de chamada não é apoiado com portas FXO quando configurado para o MGCP. Configurar o gateway no modo de H.323 pelo contrário.

  • A paginação aérea trava acima portas FXO durante o hookflash a menos que os usuários forem completamente fora-gancho. Shut seguiu pelo nenhum fechado restaura a porta. Isto é relacionado à identificação de bug Cisco CSCef62275 (clientes registrados somente) quando fixado no Cisco IOS Software Release 12.3(14)T e Mais Recente.

Este documento é a parte 2 de um grupo de seis documentos:

Pré-requisitos

Requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • Um Cisco IOS gateway que execute um Cisco IOS Software Release que apoie o MGCP com CallManager da Cisco

  • Cisco VG200

Nota: Há outros trens de Cisco IOS Software Release que apoiam o MGCP em roteadores Cisco. O Cisco IOS Software Release 12.1XM é um exemplo.

cuidado Cuidado: A sintaxe para alguns dos comandos mgcp é diferente em outros Cisco IOS Software Release. Refira a documentação para sua configuração para determinar a sintaxe que é exigida.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • 1 * X Cisco VG200/2 X FXS/2 FXO/1 Fast Ethernet 10/100 de porta; Cisco IOS Software Release 12.1(5)T

  • 1 * CallManager da Cisco 3.0(5a) que é executado em um MCS7835

  • 2 * Aparelhos de telefone analógico

  • 2 * Telefones IP do Cisco 7960

Refira Cisco unificou o CME e a matriz de compatibilidade de versão do Cisco IOS Software para software release recomendados da compatibilidade entre o CallManager da Cisco e o Cisco IOS gateway.

Nota: O Cisco IOS Software Release 12.2(11)T e Mais Recente é recomendado com base nos realces do comando ccm-manager. O comando ccm-manager exige o Cisco IOS Software Release 12.1(5)XM e mais tarde todo o Roteadores (2600 e 3600) e o VG200.

Apoio MGCP dos Cisco 2600 e 3600 Router se executam o Cisco IOS Software Release 12.1(3)T e Mais Recente. Os software release que você exige são baseados nas características que você precisa de permitir. O servidor do CallManager da Cisco deve executar o Software Release 3.0(5)a ou Mais Recente. A configuração de roteador é a mesma para todos os tipos de Roteadores. A configuração do CallManager da Cisco é igualmente a mesma para todos os tipos de Roteadores.

Apoio do Cisco IOS Software Release 12.1(5)XM1 e Mais Recente o VG200. Os software release que você exige são baseados nas características que você precisa de permitir. Use o Software Release 3.0(5)a e Mais Recente mesmo que o VG200 seja apoiado em umas liberações de Software do CallManager da Cisco mais adiantadas.

Nota: Há outros trens de Cisco IOS Software Release que apoiam o MGCP em roteadores Cisco. O Cisco IOS Software Release 12.1XM é um exemplo.

cuidado Cuidado: A sintaxe para alguns dos comandos mgcp é diferente em outros Cisco IOS Software Release. Refira a documentação para sua configuração para determinar a sintaxe exigida.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Tarefas executar

Conclua estes passos:

  1. Configurar um endereço IP de Um ou Mais Servidores Cisco ICM NT na interface Ethernet do Cisco IOS gateway.

  2. Atribua um nome exclusivo ao Cisco IOS gateway.

  3. Configurar o Cisco IOS gateway para executar o MGCP como um protocolo de sinalização.

  4. Configurar o endereço IP de Um ou Mais Servidores Cisco ICM NT ou o nome do Domain Name System (DNS) para o servidor do CallManager da Cisco.

  5. Selecione o tipo de codec e a função de relay multifrequency do tom dual (DTMF).

  6. Diga ao Cisco IOS gateway que se comunica com um servidor do CallManager da Cisco.

  7. Ligue o aplicativo de MGCP às portas de voz.

  8. Permita as portas de voz.

  9. Permita a conectividade IP.

Passo a passo

Nota: O restante deste documento refere o VG200. O VG200 começa com uma configuração padrão, porque vem enviado.

Conclua estes passos:

  1. Configurar um endereço IP de Um ou Mais Servidores Cisco ICM NT na interface Ethernet VG200 e permita a relação.

    router(config)#interface fastethernet 0/0
    router(config-if)#ip address 172.16.1.206 255.255.255.0
    router(config-if)#no shut
    
  2. Atribua um nome exclusivo ao VG200. Isto permite que o servidor do CallManager da Cisco identifique-o.

    router(config)#hostname VG200A 
    
    /* This is how CallManager keeps track of the MGCP network */
    /* devices it is communicating with. This name must be     */
    /* unique.                                                 */
  3. Configurar o VG200 para executar o MGCP como um protocolo de sinalização.

    VG200A(config)#mgcp
    
  4. Configurar o endereço IP de Um ou Mais Servidores Cisco ICM NT ou o nome de DNS para o servidor do CallManager da Cisco.

    VG200A(config)#mgcp call-agent 172.16.1.252
    
    VG200A(config)#ccm-manager config server 172.16.1.252
    
    VG200A(config)#ccm-manager config
    

    O comando mgcp call-agent é usado configurar o endereço e o protocolo do agente do atendimento para pontos finais de MGCP em um gateway de mídia. Este comando pode ser usado para especificar a versão do protocolo usado. Para mais informação, refira o atendimento-agente do mgcp.

    O comando ccm-manager config server é usado especificar o servidor TFTP de que o gateway do Media Gateway Control Protocol (MGCP) transfere arquivos de configuração do CallManager da Cisco XML.

    O comando ccm-manager config é exigido permitir a transferência de arquivos de configuração do CallManager da Cisco XML.

    Nota: Emita estes comandos configurar CallManagers redundantes de Cisco no Cluster do CallManager daCisco:

    VG200(config)#ccm-manager redundant-host [ip-address |
      dns-name] [ip-address | dns-name] 
    VG200(config)#ccm-manager switchback {graceful | immediate
      |schedule-time hh:mm | uptime-delay minutes} 
  5. Selecione o tipo de codec e a função do relé DMTF.

    VG200A(config)#mgcp dtmf-relay codec all mode out-of-band
    
  6. Emita este comando permitir o apoio para o CallManager da Cisco dentro do MGCP:

    VG200A(config)#ccm-manager mgcp
    
  7. Ligue o aplicativo de MGCP às portas de voz.

    Nota: Emita o comando show voice port determinar o tipo de portas que o VG200 tem e em que ordem são instalados.

    VG200A(config)#dial-peer voice 1 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/0
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 2 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/1
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 3 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/0
    
    /* FXS port */
    
    VG200A(config)#dial-peer voice 4 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/1
    
    /* FXS port */

    Nota: O comando application MGCPAPP é diferenciando maiúsculas e minúsculas em alguns Cisco IOS Software Release. Emita sempre este comando no uppercase a menos que você souber que seu software release não é diferenciando maiúsculas e minúsculas. Olhe a saída do comando show running-config a fim verificar se seu software release seja diferenciando maiúsculas e minúsculas. O Cisco IOS Software Release 12.1(5)T não é diferenciando maiúsculas e minúsculas.

  8. Assegure que as portas de voz estejam permitidas.

    Nota: Os comandos shutdown and no shutdown afetam ambas as portas em uma placa de interface de voz (VIC). Emita o comando em somente uma destas portas.

    VG200A(config)#voice-port 1/0/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXO port */
    
    VG200A(config)#voice-port 1/1/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXS port */s
  9. Permita a conectividade IP.

    Permita Roteamento IP se alguns dos dispositivos voip com que o VG200 se comunica são ficados situados em sub-redes diferentes ou em VLANS. Você igualmente precisa de criar uma rede padrão, ou o Gateway of Last Resort. Esta etapa mostra como executar ambas as tarefas:

    VG200A(config)#ip routing
    VG200A(config)#ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway
    
    

    Nota: O VG200 não é um roteador IP. Você não pode executar protocolos de IP Routing tais como o protocolo do Routing Information Protocol (RIP), do Interior Gateway Routing Protocol (IGRP), ou do Open Shortest Path First (OSPF) nele. Comporta-se mais como uma estação final (cliente) tanto quanto a conectividade IP.

    Nota: Você pode configurar um protocolo de roteamento em vez das rotas estáticas nos outros Cisco IOS gateway, que são essencialmente Roteadores com interfaces de voz. A edição importante é assegurar a conectividade IP entre dispositivos voip.

    Nota: O comando ip routing não aparece na configuração porque está normalmente em à revelia quando você permite Roteamento IP. Os comandos default não aparecem geralmente em uma configuração de roteador Cisco. As imagens IOS Cisco VG200 cancelam este comportamento padrão codificando o comando no ip routing na configuração inicial. Esta configuração é criada quando a imagem é carreg:

    • Em uma plataforma onde o comando write erase cancelasse a configuração

    • Em um VG200 que fosse configurado nunca

    O comando ip_address_of_gateway de 0.0.0.0 0.0.0.0 da rota IP faz com que o VG200 instale um Gateway of Last Resort na tabela de roteamento. O comando show ip route confirma este. O endereço IP de Gateway é 172.16.1.1 neste exemplo:

    VG200A#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 172.16.1.1 to network 0.0.0.0
    
    C    172.16.0.0/16 is directly connected, FastEthernet0/0
    S*   0.0.0.0/0 [1/0] via 172.16.1.1
    VG200A#

    Nota: O comando ip classless é exigido igualmente para que este Gateway of Last Resort seja eficaz. O comando ip classless é permitido à revelia. Este comando é um de poucos comandos default do Cisco IOS Software que aparece em uma configuração quando permitido e igualmente aparece em nenhum formulário quando desabilitado. Emita o comando ip classless permitir o IP sem classe se sua configuração inclui a linha nenhum IP sem classe.

cuidado Cuidado: O CallManager da Cisco controla todos os elementos de configuração plano-relacionados do seletor. Não configurar estes elementos no gateway MGCP para valores-limite MGCP-controlados (aqueles com o comando application mgcpapp na indicação do dial peer). Não configurar qualqueras um funções:

  • Sob dial peer

    • destino-teste padrão

    • destino de sessão

  • Sob portas de voz

    • conexão {plar | linha tie | tronco}

Resumo

O VG200 está agora pronto para comunicar-se com o servidor do CallManager da Cisco. O VG200 manda periodicamente mensagens na tentativa de estabelecer uma conexão. A conexão estabelece-se automaticamente quando a configuração do servidor do CallManager da Cisco está completa. Você não tem que fazer para promover mudanças no VG200.

Nota: Restaure as portas de gateway depois que você termina a configuração, porque este exemplo mostra:

router(config)#voice-port 1/0/0
router(config-voiceport)#shutdown
Both ports are out of service
router(config-voiceport)#no shutdown

Configurações

Esta tabela contém a configuração completa do VG200A para este documento:

Configuração VG200A
VG200A#show running-config           
Building configuration...

Current configuration : 1244 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname VG200A
!
boot system flash
boot system rom
boot system tftp vg200 172.16.1.253
no logging buffered
logging rate-limit console 10 except errors
no logging console
enable secret #####
enable password #####
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
mgcp
mgcp call-agent 172.16.1.252
mgcp dtmf-relay codec all mode out-of-band
mgcp sdp simple
call rsvp-sync
!
!
!
!
!
ccm-manager mgcp
!
!
interface FastEthernet0/0
 ip address 172.16.1.206 255.255.0.0
 no ip mroute-cache
 speed auto
 full-duplex
!
ip default-gateway 172.16.1.1
ip classless
no ip http server
!
snmp-server engineID local 000000090200000196983000
snmp-server community public RO
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0/0
!
dial-peer voice 2 pots
 application mgcpapp
 port 1/0/1
!
dial-peer voice 3 pots
 application mgcpapp
 port 1/1/0
!
dial-peer voice 4 pots
 application mgcpapp
 port 1/1/1
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login
!
end

VG200A#

Informação de versão VG200A
VG200A>show version
Cisco Internetwork Operating System Software
IOS (tm) VG200 Software (VG200-I6S-M), Version 12.1(5)T,  
RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by Cisco Systems, Inc.
Compiled Sat 11-Nov-00 10:33 by ccai
Image text-base: 0x80008088, data-base: 0x807D4784

ROM: System Bootstrap, Version 12.1(1r) [phanguye 1r], RELEASE 
SOFTWARE (fc1)

VG200A uptime is 19 hours, 37 minutes
System returned to ROM by reload
System image file is "flash:vg200"

cisco VG200 (MPC860) processor (revision 0x102) with 28672K/
4096K bytes of memory
y.
Processor board ID JAB0414058X (0)
M860 processor: part number 0, mask 49
1 FastEthernet/IEEE 802.3 interface(s)
2 Voice FXO interface(s)
2 Voice FXS interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

VG200A>

Pesquisando defeitos o gateway de IOS MGCP

Uma falha de chamada da maneira, na chamada externa ou nas chamadas recebidas individualmente, pode ocorrer em um gateway de IOS MGCP. A fim resolver esta edição, reconfigure o gateway MGCP. Geralmente, isto envolve uma reconfiguração das relações PRI e/ou de relações FXO. Então, um reinício do protocolo do mgcp no gateway não emitindo nenhum comando ios do mgcp e comando mgcp no modo de configuração global.

Não pode fazer atendimentos de um telefone analógico conectado ao Gateway de IOS MGCP. Um tom de ocupado é recebido.

Execute este procedimento a fim resolver este problema:

  1. Certifique-se que o comando application mgcpapp está configurado na porta aplicável.

  2. Requisite novamente o dial peers do serviço de telefonia tradicional (POTS) para alistar o dial peers CallManager-gerado Cisco primeiramente na lista do dial-peer. Assegure-se de que o Controle de chamadas interno e externo aquele esteja segurado pelo dial-peer correto sob o controle MGCP.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 42105