IP : Serial Tunnel (STUN)

Protocolos da escavação de um túnel Assíncrono no exemplo de configuração BSTUN

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Os protocolos dedicados e nativos do async não são apoiados diretamente com nenhuma implementação Cisco. Contudo, o tunelamento genérico de ASYNC do túnel serial do bloco (BSTUN) pode fornecer a habilidade limitada escavar um túnel estes dados.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware:

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Informações de Apoio

Os protocolos de Assíncrono tais como o TC500 de Diebold a comunicar-se ao dinheiro ATM ou ao HyperTerminal do Tunelamento de um PC a um outro PC não têm nenhuma suporte direto ou aplicação no ½ do ¿  do Cisco IOS ïÂ. Porque o nome implica, esta é uma implementação genérica que tenha alguma capacidade de levar este tipo de dados. Isto é sabido como o BSTUN genérico assíncrono, e exige o IBM ou o conjunto de recursos da empresa IO.

O BSTUN genérico assíncrono foi projetado originalmente levar pacotes unidirecionais, pequenos dos dispositivos de segurança a um dispositivo de relatório. O BSTUN genérico assíncrono, contudo, pode levar o tráfego interativo. Essencialmente, os diplomatas desta aplicação ao nativo, dispositivos assíncronos e recebem os dados na interface serial e então em um buffer de memória. Periodicamente, os dados protegidos então são encapsulados em um pacote de TCP e enviados ao bstun peer onde é descapsulado e enviados ao dispositivo assíncrono anexado no local remoto.

O BSTUN genérico assíncrono é uma operação simplista. O roteador não tem nenhuma capacidade para ser configurada para ter o conhecimento do começo do quadro (SOF), da extremidade do quadro (EOF), ou do esquema do endereçamento do protocolo do async. Se a porção de endereço do quadro é em cada quadro, é um byte por muito tempo, e é o mesmo lugar no quadro, a seguir o comando asp address-offset pode ser emitido para especificar ao roteador onde encontrar o endereço no quadro, como exampled mais tarde neste documento. Em muitas situações, contudo, não haverá uma porção de endereço contida no protocolo. Não ter nenhum conhecimento da construção de protocolo do async significa que o roteador é incapaz de distinguir pacotes individuais de outro se não são separados em um período de tempo. A Senhora aproximadamente 40 é exigida entre quadros em 9600 bit/segundo fornecer a quantidade de tempo adequada do roteador para distinguir corretamente um pacote de outro. O roteador vê simplesmente que um fluxo de dados nele é interface serial e envolve então estes dados no TCP. Não há nenhuma possibilidade que o roteador pode faz decisões de roteamento baseou em todo o aspecto individual do frame de entrada. Assim, o BSTUN genérico assíncrono deve ser diplomatas fisicamente projetados de tão somente um dispositivo à relação de roteador serial. Não há nenhuma característica do reconhecimento local. O BSTUN apoia o Local-ack para o protocolo bissíncrono IBM3270 somente.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

/image/gif/paws/41983/bstun_41983-A.gif

Ambos os PC usam o HyperTerminal de Microsoft ou no lugar de um dos PC poderia ser uma conexão na porta de Console de um roteador Cisco. Estas configurações de amostra representam as configurações executadas do Roteadores configurado não previamente em um cenário de laboratório, e mostram as porções relevantes da configuração necessária. Estes são configurados que supõem uns 9600 mordidos/segundo, a conexão 8N1.

Configurações

Este documento usa as configurações mostradas nesta seção.

  • Roteador principal (Cisco 1700 Router)

  • Roteador remoto (Cisco 3640 Router)

  • Roteador principal (Cisco 3600 Router)

  • #1 remoto (Cisco 1700 Router)

  • #2 remoto (Cisco 1700 Router)

Roteador principal (Cisco 1700 Router)
main#show running-config 
Building configuration...
.
.
.
ip subnet-zero
bstun peer-name 10.1.1.1
bstun protocol-group 1 async-generic
interface loopback0
   ip address 10.1.1.1 255.0.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 1
   bstun route all tcp 30.1.1.1
interface serial1
   ip address 20.1.1.1 255.0.0.0
ip route 0.0.0.0 0.0.0.0 20.1.1.2
line 1
   speed 9600
   databits 8
   parity none
   stopbits 1
.
.
.
!
end

Roteador remoto (Cisco 3640 Router)
REMOTE#show running-config 
Building configuration...
bstun peer-name 30.1.1.1.
bstun protocol-group 1 async-generic
interface loopback 0
   ip address 30.1.1.1
interface ethernet1/0
   shutdown
interface serial 2/0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 1
   bstun route all tcp 10.1.1.1
   
interface serial 2/1
   ip address 20.1.1.2 255.0.0.0
ip route 0.0.0.0 0.0.0.0 20.1.1.1
line 65
   speed 9600
   parity none
   databits 8
   stopbits 1
.
.
!
end

Nota: Quando você emite o comando physical-layer async na interface serial, uma linha TTY está atribuída à interface serial. Esta definição de linha TTY é o lugar onde os databits, os stopbits, a paridade, e a velocidade são configurados. Esta é a fórmula para determinar que linha corresponde com que interface serial.

line#= (slot- x 32) + interface# + 1

A linha da mostra na saída da configuração de roteador remoto indica na coluna do extrema direita o número de linha de correspondência. O Serial2/0 é representado pela linha 65 e as definições física para este link são configuradas sob a linha 65

REMOTE#sh line 
   Tty Typ     Tx/Rx        A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int 
*    0 CTY                      -        -          -        -        -          0           0         0/0           - 
    65 TTY   9600/9600  -        -          -        -        -      0           0         0/0     Se2/0 
   129 AUX 9600/9600  -        -          -        -        -        0           0         0/0       - 
   130 VTY                     -        -          -        -        -          0           0         0/0       - 
   131 VTY                     -        -          -        -        -          0           0         0/0       - 
   132 VTY                     -        -          -        -        -          0           0         0/0       - 
   133 VTY                     -        -          -        -        -          0           0         0/0       - 
   134 VTY                     -        -          -        -        -          0           0         0/0       - 

Line(s) not in async mode -or- with no hardware support: 
1-64, 66-128 

Nesta encenação, um Tandem comunica-se com os dispositivos ATM remotos. Nesta configuração de exemplo, o protocolo do async executa um protocolo 4800 7E2 e o roteador principal conectado ao TANDEM é um 3600 Series Router aos 1700 Series Router remotos. Veja este diagrama da rede.

bstun_41983-B.gif

Roteador principal (Cisco 3600 Router)
main#show running-config 
Building configuration...
bstun peer-name 10.1.1.1.
bstun protocol-group 1 async-generic
bstun protocol-group 2 async-generic
interface loopback 0
   ip address 10.1.1.1
interface serial1/0
   encapsulation frame-relay
interface serial 1/0.1 point-to-point
   ip address 20.1.1.1 255.255.255.0
   frame-relay interface-dlci 100
interface serial 1/0.2 point-to-point
   ip address 20.2.1.1 255.255.255.0
   frame-relay interface-dlci 200
interface serial 2/0
   physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 1
   bstun route all tcp 30.1.1.1
   
interface serial 2/1
 physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 2
   bstun route all tcp 30.2.1.1
   
ip route 30.2.1.0 255.255.0.0 20.2.1.2
ip route 0.0.0.0 0.0.0.0 20.1.1.2
line 65
   speed 4800
   parity even
   databits 7
   stopbits 1
.
line 66
   speed 4800
   parity even
   databits 7
   stopbits 1
.
!
end

#1 remoto (Cisco 1700 Router)
REMOTE1#show running-config 
Building configuration...
bstun peer-name 30.1.1.1
bstun protocol-group 1 async-generic
interface loopback0
   ip address 30.1.1.1 255.255.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 1
   bstun route all tcp 10.1.1.1
interface serial1
   encapsulation frame-relay
interface serial1.1 point-to-point
   ip address 20.1.1.2 255.255.255.0
   frame-relay interface-dlci 100
ip route 0.0.0.0 0.0.0.0 20.1.1.1
line 1
   speed 4800
   databits 7
   parity even
   stopbits 2
.
.
.
!
end

#2 remoto (Cisco 1700 Router)
REMOTE2#show running-config
Building configuration...
bstun peer-name 30.2.1.1
bstun protocol-group 2 async-generic
interface loopback0
   ip address 30.2.1.1 255.255.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 2
   bstun route all tcp 10.1.1.1
interface serial1
   encapsulation frame-relay
interface serial1.1 point-to-point
   ip address 20.2.1.2 255.255.255.0
   frame-relay interface-dlci 100
ip route 0.0.0.0 0.0.0.0 20.2.1.1
line 1
   speed 4800
   databits 7
   parity even
   stopbits 2
.
.
.
!
end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

O BSTUN recebe um pacote na interface serial, encapsular-lo, e envia-o este pacote de TCP ao roteador remoto quando o comando bstun route all tcp é emitido. O pacote de TCP é recebido no roteador remoto e é descapsulado. Os dados são mandados na interface serial. Se esta conexão não trabalha, os dados de entrada devem primeiramente ser verificados com o pacote asp debugar. Você vê os dados recebidos pelo roteador na interface serial. Desde que o roteador não tem nenhuma construção de protocolo e a varia de acordo com o protocolo do async, a amostra debuga não é fornecida. O fluxo de dados visto pelo roteador deve combinar o que é enviado pelo dispositivo. Se não combina, mais do que provavelmente, a velocidade, os databits, a paridade, ou os stopbits não estão configurados para combinar o dispositivo. Este pode ser o caso também se nenhum dados é recebido.

Se os dados são recebidos na interface serial, emita o comando show bstun a fim mostrar se a conexão é aberta ou fechado. O estado em aberto com somente os pacotes transmitidos indica que o TCP está enviado ao bstun peer remoto. Neste momento, um teste de ping do endereço IP de Um ou Mais Servidores Cisco ICM NT do par-nome local BSTUN ao endereço IP de Um ou Mais Servidores Cisco ICM NT remoto do par-nome BSTUN verifica se o IP é configurado e de trabalho corretamente. Se o teste ping é bem sucedido, a seguir no telecontrole, emita o comando debug asp packet a fim determinar se o pacote é recebido e enviado na interface serial ao dispositivo assíncrono.

Termine estas etapas a fim pesquisar defeitos.

  1. Verifique que os dados estão recebidos no roteador host com o comando debug asp packet.

  2. Assegure a conectividade IP com sibilos da fonte do teste de ping do endereço IP de Um ou Mais Servidores Cisco ICM NT do par-nome do bstun ao endereço IP remoto do par-nome remoto BSTUN.

  3. No telecontrole, verifique que os pacotes estão enviados ao dispositivo remoto com o comando debug asp packet.

  4. Se o protocolo do async tem um endereço contido nos pacotes enviados ao roteador, pode ser benéfico emitir o comando asp offset-address sob a relação com o número apropriado do byte que corresponde a onde o endereço é contido no pacote. O valor padrão para este é 0. por exemplo, se o pacote é 01C1ABCDEF, onde o C1 é o endereço, a interface serial pode ser configurado com o comando asp offset-address 01. Em alguns casos, isto permite que o roteador identifique um pacote e aumenta a probabilidade que o roteador segura os dados como um pacote moldado e não apenas como um fluxo de dados.


Informações Relacionadas


Document ID: 41983