IP : Protocolo IP multicast

Como executar uma política de filtragem para pontos de reunião

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (27 Abril 2015) | Feedback


Índice


Introdução

Este documento explica como executar uma política de filtragem para os pontos de reunião (RP) no agente de mapeamento RP em um ambiente do Multicast onde uma configuração de RP dinâmica seja aplicada (Auto-RP).

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Compreensão básica da transmissão múltipla independente de protocolo (PIM)

Componentes Utilizados

Use este diagrama como uma referência durante todo este documento:

/image/gif/paws/41680/rp_announce_02.gif

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Auto-RP

O Auto-RP é uma maneira dinâmica aprender a informação RP para cada roteador na rede. Isto é conseguido quando você distribui toda a informação do grupo para RP através do Protocolo IP multicast.

Todo o Roteadores PIM-permitido se junta automaticamente ao grupo da descoberta de Cisco RP (224.0.1.40) que permite que recebam toda a informação de mapeamento do grupo para RP. Esta informação é distribuída por uma entidade chamada agente de mapeamento RP. Os agentes de mapeamento eles mesmos juntam-se a um outro grupo — Cisco RP anuncia o grupo (224.0.1.39). Todo o candidato que os RP se anunciam em mensagens de transmissão múltipla periódicos visou o RP anuncia o endereço de grupo.

O agente de mapeamento escuta todos os candidatos a anúncios RP e constrói uma tabela com a informação. Se diversos RP se anunciam para um alcance de grupo de transmissão múltipla, o agente de mapeamento escolhe somente um — o RP com o endereço IP de Um ou Mais Servidores Cisco ICM NT o mais alto. Anuncia então o RP a todos os roteadores de PIM na rede usando um mensagem de descoberta RP. Os agentes de mapeamento enviam a esta informação cada 60 segundos (a configuração padrão).

Endereços de filtração RP

Você pode usar o comando ip pim rp-announce-filter rp-list access-list group-list access-list filtrar com certeza determinados grupos de transmissão múltipla RP.

O comando ip pim rp-announce-filter rp-list access-list group-list access-list tem somente o significado se é configurado no agente de mapeamento. A lista de acesso da lista RP define uma lista de acesso do candidato RP que, se permitido, é aceitado para as escalas do Multicast especificadas no comando group-list access-list.

Nota: Use este comando com cuidado. Os RP que são combinados pela lista RP (permitida por uma indicação da licença) têm seus grupos de transmissão múltipla filtrados pela lista de grupos. Os RP que são negados (por um explícito ou implícito negam) não são sujeitos à filtração de seus grupos de transmissão múltipla e são aceitados “cegamente” como o candidato RP para todos seus grupos. Ou seja somente os RP que são permitidos pela lista RP têm seus grupos de transmissão múltipla filtrados pela lista de grupos. Todos RP restantes são aceitados sem exame.

Um RP adicional anuncia que o filtro está precisado de filtrar eficazmente os RP que são aceitados sem exame. A seção de filtração do exemplo esclarece este procedimento.

Exemplo de filtração

No diagrama na seção usada componentes, o R2 e o R4 anunciam-se como o candidato RP para estes grupos (que anunciam esta informação através dos mensagens de descoberta RP):

  • 224.1.0.1

  • 224.1.0.2

  • 224.1.0.3

O R3 é configurado como um agente de mapeamento e recolhe esta informação, constrói sua tabela, e envia somente um endereço RP ao R6, que é somente um roteador PIM-permitido. O Intermediate System-to-Intermediate System (IS-IS) é usado neste exemplo como o protocolo de roteamento de unicast, mas todo o outro protocolo trabalharia também. O modo PIM sparseDense é precisado de receber a informação do Multicast para grupos 224.0.1.39 e 224.0.1.40 sem ter um RP configurado para aqueles grupos. Ou seja o modo sparseDense trabalha como o modo denso se não há nenhum RP conhecido. Quando um RP é sabido, o modo sparseDense está usado para os grupos para que o RP se anuncia.

Configuração R2

hostname R2

ip multicast-routing

interface Loopback0
 ip address 50.0.0.2 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Serial3/0
 ip address 10.2.0.2 255.255.255.0
 ip router isis
 ip pim sparse-dense mode

router isis 
 net 49.0002.0000.0000.0002.00

ip pim send-rp-announce Loopback0 scope 16 group-list groupB
!         
!         
ip access-list standard groupB
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

Configuração R4

hostname R4

ip multicast-routing

interface Loopback0
 ip address 50.0.0.4 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Serial3/0
 ip address 10.3.0.4 255.255.255.0
 ip router isis
 ip pim sparse-dense mode

router isis 
 net 49.0002.0000.0000.0004.00

ip pim send-rp-announce Loopback0 scope 16 group-list groupA
!         
!         
ip access-list standard groupA
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

Configuração R3

hostname R3

ip multicast-routing

interface Loopback0
 ip address 50.0.0.3 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

interface Serial2/0
 ip address 10.2.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

interface Serial3/0
 ip address 10.3.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

router isis 
 net 49.0002.0000.0000.0003.00

Configuração R6

hostname R6

ip multicast-routing

interface Loopback0
 ip address 50.0.0.6 255.255.255.255
 ip router isis
 
interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.6 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

router isis 
 net 49.0002.0000.0000.0006.00

Se você quer filtrar o R4 porque um RP possível para alguns daqueles grupos e tem somente o R2 como um RP de trabalho, configurar um RP anunciam o filtro no R3:

ip pim rp-announce-filter rp-list filtering-RP group-list filtering-group
!         
!         
ip access-list standard filtering-RP
 permit 50.0.0.2
 deny    50.0.0.4


!--- ACL "filtering-RP" specifically allows R2 and explicitly denies R4.


ip access-list standard filtering-group
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

Então, para cancelar as associações atuais do grupo para RP, emita o comando clear ip pim rp-mapping no R3 e no R6.

Contudo, se você vê o R6, você pode ver que a informação não é o que você espera:

R6#show ip pim rp mapping 
PIM Group-to-RP Mappings

Group(s) 224.1.0.1/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55
Group(s) 224.1.0.2/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55
Group(s) 224.1.0.3/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55

Se você vê o R3, você pode ver que nenhuma filtração está sendo executada realmente:

R3# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is an RP-mapping agent

!--- This line confirms that R3 is configured as the mapping agent.


Group(s) 224.1.0.1/32
  RP 50.0.0.4 (?), v2v1

!--- No filtering has taken effect.

    Info source: 50.0.0.4 (?), elected via Auto-RP

!--- R4 is elected because it has a higher IP address.

         Uptime: 00:09:06, expires: 00:02:53
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:27
Group(s) 224.1.0.2/32
  RP 50.0.0.4 (?), v2v1
    Info source: 50.0.0.4 (?), elected via Auto-RP
         Uptime: 00:09:06, expires: 00:02:51
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:27
Group(s) 224.1.0.3/32
  RP 50.0.0.4 (?), v2v1
    Info source: 50.0.0.4 (?), elected via Auto-RP
         Uptime: 00:09:06, expires: 00:02:51
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:28

O endereço do R4 é negado especificamente, e não é sujeito a nenhuma filtração de seus grupos de transmissão múltipla — é aceitado “cegamente” pelo agente de mapeamento. O agente de mapeamento seleciona um RP baseado no endereço IP de Um ou Mais Servidores Cisco ICM NT o mais alto (neste exemplo, 50.0.0.4) e então para a frente nesta informação ao R6.

Configurar um outro RP anunciam o filtro que permite o R4 e nega todos seus grupos a fim filtrar eficazmente o endereço R4:

ip pim rp-announce-filter rp-list filtering-R4 group-list filtering-groupR4

ip access-list standard filtering-R4
 permit 50.0.0.4
ip access-list standard filtering-groupR4
 deny   any

Se você vê o R3 e permite o comando debug ip pim auto-rp assim que você receber um RP anuncia a mensagem do R4, você pode ver estas mensagens:

R3#
*Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4

Então, quando você vê a tabela do grupo para RP, você pode somente ver o R2:

R3#show ip pim rp mapping 
PIM Group-to-RP Mappings
This system is an RP-mapping agent

Group(s) 224.1.0.1/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:52
Group(s) 224.1.0.2/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:54
Group(s) 224.1.0.3/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:55

Finalmente, se você quer ter o R2 como o RP para 224.1.0.1, e R4 como o RP para 224.1.0.2 e 224.1.0.3, você tem esta configuração no R3:

hostname R3

ip multicast-routing

interface Loopback0
 ip address 50.0.0.3 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

interface Serial2/0
 ip address 10.2.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

interface Serial3/0
 ip address 10.3.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

router isis
 net 49.0002.0000.0000.0003.00

ip pim rp-announce-filter rp-list filtering-RP2 group-list filtering-group2
ip pim rp-announce-filter rp-list filtering-RP4 group-list filtering-group4
!        
!        
ip access-list standard filtering-RP2
 permit 50.0.0.2

ip access-list standard filtering-RP4
 permit 50.0.0.4

ip access-list standard filtering-group2
 permit 224.1.0.1

ip access-list standard filtering-group4
 permit 224.1.0.2
 permit 224.1.0.3

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 41680