Switches de LAN : Roteamento Inter-Vlan

Configuração do Roteamento entre VLANs com Switches Catalyst 3750/3560/3550 Series

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (3 Abril 2008) | Inglês (6 Outubro 2015) | Feedback


Índice


Introdução

Este documento explica como configurar o roteamento de interVLAN com os switches da série Cisco Catalyst 3750/3560/3550. O original fornece uma configuração de exemplo para o roteamento de interVLAN com um switch da série Catalyst 3550 que executa o software multilayer image (EMI) em um cenário típico de rede. O documento usa um switch da série Catalyst 2950 e um switch Catalyst 2948G como switches de gabinete da Camada 2 (L2) que se conectam ao Catalyst 3550. A configuração do Catalyst 3550 também tem uma rota padrão para todo o tráfego que vai à Internet quando o salto seguinte aponta para um roteador Cisco 7200VXR. É possível substituir um firewall ou outros roteadores para o roteador Cisco 7200VXR.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Catalizador 3550-48 que executa o Software Release 12.1(12c)EA1 EMI do ½ do ¿  de Cisco IOSïÂ

  • Catalizador 2950G-48 que executa o Cisco IOS Software Release 12.1(12c)EA1 EI

  • Catalyst 2948G que executa a versão 6.3(10) do OS do catalizador (Cactos)

Nota: A configuração do Cisco 7200VXR não é relevante, assim que este documento não mostra a configuração.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Produtos Relacionados

Esta configuração também pode ser utilizada com estas versões de hardware e software:

  • Algum interruptor do catalizador 3750/3560/3550 que executar o software EMI ou o Cisco IOS Software Release 12.1(11)EA1 e Mais Recente da imagem de multicamada padrão (S I)

  • Algum modelo do Catalyst 2900XL/3500XL/2950/3550 ou do switch Cactos, usado como o switch de camada de acesso

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Material de Suporte

Em uma rede comutada, os VLANs separam os dispositivos em domínios de colisão diferentes e em sub-redes de camada 3 (L3). Os dispositivos dentro de um VLAN podem comunicar-se um com o otro sem a necessidade para distribuir. Os dispositivos nos VLAN separados exigem um dispositivo de roteamento comunicar-se um com o outro.

O Switches L2-only exige um dispositivo de roteamento L3. O dispositivo é externo ao interruptor ou em um outro módulo no mesmo chassi. Uma raça nova do Switches incorpora a potencialidade de roteamento dentro do interruptor. Um exemplo é os 3550. O interruptor recebe um pacote, determina que o pacote pertence a um outro VLAN, e envia o pacote à porta apropriada no outro VLAN.

Um projeto de rede típica segmenta o baseado na rede no grupo ou na função a que o dispositivo pertence. Por exemplo, o VLAN de planejamento tem somente os dispositivos que se relacionam ao departamento de engenharia, e a finança VLAN tem somente os dispositivos que se relacionam para financiar. Se você permite o roteamento, os dispositivos em cada VLAN podem falar a um outro sem a necessidade para que todos os dispositivos estejam no mesmo domínio de transmissão. Tal projeto VLAN igualmente tem um benefício adicional. O projeto permite que o administrador restrinja uma comunicação entre vlans com uso das Listas de acesso. No exemplo neste documento, você pode usar Listas de acesso para restringir o VLAN de planejamento do acesso aos dispositivos na finança VLAN.

O interruptor não distribui pacotes não-IP entre VLAN e portas roteada. Você pode enviar estes pacotes não-IP com construção de uma ponte sobre da reserva. A fim usar esta característica, você deve ter a imagem dos Serviços IP, conhecida anteriormente como a imagem multilayer aumentada (EMI), instalada em seu interruptor.

Está aqui um link a um vídeo (disponível na comunidade do apoio de Ciscoleavingcisco.com ) que demonstre como configurar o roteamento de interVLAN em um Catalyst 3550 Series Switch:

Como configurar o roteamento InterVLAN nos Switches de camada 3 leavingcisco.com

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

189-a.gif

Neste diagrama, um exemplo de rede pequeno com o Catalyst 3550 fornece o roteamento de interVLAN entre os vários segmentos. À revelia, o Catalyst 3550 Switch atua como um dispositivo L2 com incapacidade de Roteamento IP. A fim fazer a função de switch como um dispositivo L3 e fornecer o roteamento de interVLAN, você deve permitir Roteamento IP globalmente.

Estes VLAN são os três VLAN que o usuário define:

  • VLAN 2 - VLAN de usuário

  • VLAN 3 - servidor VLAN

  • VLAN 10 – VLAN de gerenciamento

A configuração de gateway de voz padrão em cada server e dispositivo host deve ser o endereço IP de Um ou Mais Servidores Cisco ICM NT da interface de VLAN que corresponde nos 3550. Por exemplo, para servidores, o gateway padrão é 10.1.3.1. Os switch de camada de acesso, que são o Catalyst 2950 e os 2948G, são em tronco ao Catalyst 3550 Switch.

A rota padrão para o Catalyst 3550 aponta ao Cisco 7200VXR Router. O Catalyst 3550 utiliza essa rota padrão para rotear tráfego destinado à Internet. Consequentemente, o tráfego para que os 3550 não tem uma entrada de tabela de roteamento para a frente ao 7200VXR para o processo.

Dicas práticas

  • Certifique-se de que o VLAN nativo para um tronco 802.1q é o mesmo nas duas extremidades no enlace do tronco. Se uma VLAN nativa em uma extremidade do tronco for diferente da VLAN nativa na outra extremidade, o tráfego de VLANs nativas em ambos os lados não poderá ser transmitido corretamente no tronco. Essa falha em transmitir corretamente pode implicar em alguns problemas de conectividade em sua rede.

  • Separe o VLAN de gerenciamento do usuário ou do vlan do servidor, como neste diagrama. O VLAN de gerenciamento é diferente do usuário ou do vlan do servidor. Com esta separação, alguns transmitem/tempestades de pacote de informação que ocorre no usuário ou o vlan do servidor não afeta o Gerenciamento do Switches.

  • Não use o VLAN1 para o Gerenciamento. Todas as portas nos Catalyst Switches optam o VLAN1, e todos os dispositivos que conectarem às portas nonconfigured estão no VLAN1. O uso do VLAN1 para o Gerenciamento pode causar problemas potenciais para o Gerenciamento do Switches, porque a segunda ponta explica.

  • Use uma porta (roteado) da camada 3 para conectar à porta do gateway padrão. Neste exemplo, você pode facilmente substituir um Cisco 7200VXR Router com um Firewall que conecte ao Internet Gateway Router.

  • Não execute um protocolo de roteamento entre o Catalyst 3550 e o Internet Gateway Router. Este exemplo configura uma rota padrão estática nos 3550 pelo contrário. Esta instalação é a melhor se há somente uma rota ao Internet. Certifique-se configurar as rotas estáticas, resumidas preferivelmente, no gateway router (7200VXR) para as sub-redes que podem ser alcançadas pelo Catalyst 3550. Esta etapa é muito importante porque esta configuração não usa protocolos de roteamento.

  • Se você tem dois Catalyst 3550 Switch em sua rede, você pode dual conecta os switch de camada de acesso a ambos os 3550 Switch. Execute o Hot Standby Router Protocol (HSRP) entre o Switches para fornecer a Redundância na rede. Para obter mais informações sobre da configuração do HSRP, refira a seção configurando HSRP de configurar Serviços IP.

  • Se você precisar de largura de banda adicional para as portas do uplink, poderá configurar o EtherChannel. O EtherChannel igualmente fornece a redundância de link no caso de uma falha do link.

Configurações

Este documento utiliza as seguintes configurações:

Catalyst 3550 (Catalyst 3550-48 Switch)
Cat3550#show running-config 
Building configuration...

Current configuration : 3092 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
!
ip subnet-zero

!--- Enable IP routing for interVLAN routing.

ip routing
!!
!
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
 no ip address
!

!--- Output suppressed.

!
interface FastEthernet0/5
 description to SERVER_1

!--- Configure the server port to be in the server VLAN, VLAN 3.

switchport access vlan 3

!--- Configure the port to be an access port to prevent trunk negotiation delays.

 switchport mode access
 no ip address

!--- Configure PortFast for initial Spanning Tree Protocol (STP) delay. Refer to
!--- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays
!--- for more information.

spanning-tree portfast
!

!--- Output suppressed.

!
interface FastEthernet0/48
 description To Internet_Router

!--- The port that connects to the router converts into a routed (L3) port.

no switchport

!--- Configure the IP address on this port. 

ip address 200.1.1.1 255.255.255.252
!
interface GigabitEthernet0/1
 description To 2950

!--- Configure IEEE 802.1 (dot1q) trunking, with negotiation, on the L2 switch.
!--- If there is not support for Dynamic Trunking Protocol (DTP) on the far switch, 
!--- issue the switchport mode trunk command to force the switch port to trunk mode.
!--- Note: The default trunking mode is dynamic auto. If you establish a trunk link 
!--- with the default trunking mode, the trunk does not appear
!--- in the configuration, even though a trunk has been established on 
!--- the interface. Use the show interfaces trunk command to verify the 
!--- establishment of the trunk. 

switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 description To 2948G
 switchport trunk encapsulation dot1q
 no ip address
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description USER_VLAN

!--- This IP address is the default gateway for users.

 ip address 10.1.2.1 255.255.255.0
!
interface Vlan3
 description SERVER_VLAN

!--- This IP address is the default gateway for servers.

ip address 10.1.3.1 255.255.255.0
!
interface Vlan10
 description MANAGEMENT_VLAN

!--- This IP address is the default gateway for other L2 switches.

 ip address 10.1.10.1 255.255.255.0
!
ip classless

!--- This route statement allows the 3550 to send Internet traffic to 
!--- the default router which, in this case, is the 7200VXR (Fe 0/0 interface).

ip route 0.0.0.0 0.0.0.0 200.1.1.2
ip http server
!
!
!
line con 0
line vty 5 15
!
end

Nota: Desde que os 3550 têm a configuração como um server do protocolo VLAN Trunk (VTP), o interruptor não indica a configuração de VTP. Este comportamento é padrão. Este interruptor usa estes comandos criar um servidor VTP com os três VLAN esses o definido pelo utilizador do modo de configuração global:

Cat3550(config)#vtp domain cisco
Cat3550(config)#vtp mode server
Cat3550(config)#vlan 2
Cat3550(config-vlan)#name USER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 3
Cat3550(config-vlan)#name SERVER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 10
Cat3550(config-vlan)#name MANAGEMENT
Catalyst 2950 (interruptor do catalizador 2950G-48)
Cat2950#show running-config 
Building configuration...

Current configuration : 2883 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
!
ip subnet-zero
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 no ip address
!

!--- Output suppressed.

interface FastEthernet0/16
 no ip address
!
interface FastEthernet0/17
 description SERVER_2
 switchport access vlan 3
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Output suppressed.

!
interface FastEthernet0/33
 description HOST_1

!--- Configure HOST_1 to be the user VLAN, VLAN 2.

 
 switchport access vlan 2
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Output suppressed.

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan10
 description MANAGEMENT

!--- This IP address manages this switch. 

ip address 10.1.10.2 255.255.255.0
 no ip route-cache
!

!--- Configure the default gateway so that the switch is reachable from other
!--- VLANs/subnets. The gateway points to the VLAN 10 interface on the 3550.

ip default-gateway 10.1.10.1
ip http server
!
!
line con 0
line vty 5 15
!
end

Nota: Desde que o Catalyst 2950 tem a configuração como um vtp client, o interruptor não indica a configuração de VTP. Este comportamento é padrão. A 2950 adquire a informação de VLAN do servidor VTP, que é os 3550. Este 2950 Switch usa estes comandos fazer ao interruptor um vtp client no VTP domain Cisco do modo de configuração global:

Cat2950(config)#vtp domain cisco
Cat2950(config)#vtp mode client
Catalyst 2948G Switch
Cat2948G> (enable) show config 
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
...........

..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Fri Jun 30 1995, 05:04:47 
!
#version 6.3(10)
!
!
#system web interface version(s)
!
#test
!
#system
set system name  Cat2948G
!       
#frame distribution method
set port channel all distribution mac both
!
#vtp

!--- Configure the VTP domain to be the same as the 3550, the VTP server.

set vtp domain cisco

!--- Choose the VTP mode as client for this switch.

set vtp mode client
!
#ip

!--- Configure the management IP address in VLAN 10.

set interface sc0 10 10.1.10.3/255.255.255.0 10.1.10.255

set interface sl0 down
set interface me1 down

!--- Define the default route so that the switch is reachable.

set ip route 0.0.0.0/0.0.0.0         10.1.10.1      
!
#set boot command
set boot config-register 0x2
set boot system flash bootflash:cat4000.6-3-10.bin
!
#module 1 : 0-port Switching Supervisor
!
#module 2 : 50-port 10/100/1000 Ethernet

!--- Configure HOST_2 and SERVER_3 ports in respective VLANs.

set vlan 2    2/2
set vlan 3    2/23
set port name       2/2  To HOST_2
set port name       2/23 to SERVER_3

!--- Configure trunk to 3550 with dot1q encapsulation.

set trunk 2/49 desirable dot1q 1-1005
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração funciona adequadamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Catalyst 3550

  • show vtp status

    Cat3550#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 1005
    Number of existing VLANs        : 8
    VTP Operating Mode              : Server
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49 
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    Local updater ID is 10.1.2.1 on interface Vl2 (lowest numbered VLAN interface found)
  • show interfaces trunk

    Cat3550#show interfaces trunk 
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    Gi0/2     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    Gi0/2     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    Gi0/2     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    
    Gi0/1     1-3,10
    Gi0/2     1-3,10
    
  • show ip route

    Cat3550#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 200.1.1.2 to network 0.0.0.0
    
         200.1.1.0/30 is subnetted, 1 subnets
    C       200.1.1.0 is directly connected, FastEthernet0/48
         10.0.0.0/24 is subnetted, 3 subnets
    C       10.1.10.0 is directly connected, Vlan10
    C       10.1.3.0 is directly connected, Vlan3
    C       10.1.2.0 is directly connected, Vlan2
    S*   0.0.0.0/0 [1/0] via 200.1.1.2
    

Catalyst 2950

  • show vtp status

    Cat2950#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 250
    Number of existing VLANs        : 8
    VTP Operating Mode              : Client
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49 
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    
  • show interfaces trunk

    Cat2950#show interfaces trunk  
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    Gi0/1     1-3,10
    

Catalyst 2948G

  • show vtp domain

    Cat2948G> (enable) show vtp domain 
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           client      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    8          1023             3               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    200.1.1.1       disabled disabled 2-1000
  • show trunk

    Cat2948G> (enable) show trunk 
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     2/49     desirable    dot1q          trunking      1
    
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     2/49     1-1005
    
    Port      Vlans allowed and active in management domain 
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    

Troubleshooting

Use esta seção para resolver problemas de configuração.

Procedimento de Troubleshooting

Siga estas instruções:

  1. Se você não pode sibilar dispositivos dentro do mesmo VLAN, verifique a atribuição de VLAN das portas de origem e de destino para certificar-se de que a fonte e o destino estão no mesmo VLAN.

    A fim verificar a atribuição de VLAN, emita o comando show port mod/port para Cactos ou o comando show interface status para o Cisco IOS Software.

    Se a fonte e o destino não estão no mesmo interruptor, certifique-se de que você configurou o entroncamento corretamente. A fim verificar a configuração, emita o comando show trunk para Cactos ou o comando show interfaces trunk para o Cisco IOS Software. Também, certifique-se do VLAN nativo combine de cada lado. Certifique-se de que a máscara de sub-rede combina entre os dispositivos de origem e de destino.

  2. Se você não pode sibilar dispositivos em VLAN diferentes, certifique-se de que você pode sibilar o gateway padrão respectivo.

    Nota: Veja etapa 1.

    Também, certifique-se de que o gateway padrão do dispositivo aponta ao endereço IP de Um ou Mais Servidores Cisco ICM NT correto da interface de VLAN. Certifique-se de que a máscara de sub-rede combina.

  3. Se você não pode alcançar o Internet, certifique-se de que a rota padrão nos 3550 pontos ao endereço IP de Um ou Mais Servidores Cisco ICM NT correto, e de que o endereço de sub-rede combina o Internet Gateway Router.

    A fim verificar, emita o comando show ip interface interface-id e o comando show ip route. Verifique se o roteador do gateway de Internet tem rotas para a Internet e as redes internas.


Informações Relacionadas


Document ID: 41260