IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Configuração de IS-IS em OPv6

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece um exemplo de configuração IS-IS (Intermediate System-to-Intermediate System) através do IPv6 (IP versão 6). Discute também como verificar e solucionar problemas de configuração.

Pré-requisitos

Requisitos

Antes de você tentar esta configuração, verifique se estes requisitos são atendidos:

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • 12.2(13)T com conjunto de recursos de empreendimento

  • Plataforma Cisco 7200

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/40262/ipv6_sample_config.gif

Configurações

Este documento utiliza as configurações mostradas abaixo.

c7200-1
c7200-1# show run

ipv6 unicast-routing 
! Enable the forwarding of IPv6 unicast datagrams
!
interface Loopback0
 no ip address
 ipv6 address 2000:1::1/96
 circuit-type level-2-only
 address-family ipv6 unicast
!

!--- If the sole purpose of the loopback is a router ID, 
!--- a /128 is preferred. 
!--- A /96 is used here to advertise this route through IS-IS.
!--- Last two commands for getting advertised in the LSP


 ipv6 router isis alpha

!--- Enables IS-IS on the interface for area "alpha."

!
interface FastEthernet3/0
 ip address 172.16.88.51 255.255.255.224
 duplex half
 ipv6 address 1000:1:1:1:1:1:1:1/112
 ipv6 router isis alpha
!
router isis alpha

!--- Enables the IS-IS routing process for area "alpha."

 net 49.1111.2220.3330.4440.00

!--- Defines the area addresses for the IS-IS area and the system ID
!--- of the router. 49.1111 is the area id SysID is 2220.3330.4440.

!
end

c7200-2
c7200-2# show run
ipv6 unicast-routing
!
interface Loopback0                                                  
 no ip address
 ipv6 address 3000:1::1/96
 ipv6 router isis alpha
!
interface FastEthernet0/0
 ip address 172.16.88.50 255.255.255.224
 duplex auto
 speed auto
 ipv6 address 1000:1:1:1:1:1:1:2/112
 ipv6 router isis alpha
!
 router isis alpha
 net 49.1111.2222.3333.4444.00
 !
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • show clns interface- Utilizado para listar informações específicas de CLNS (Serviço de Rede sem Conexão), referentes à interface.

    c7200-1# show clns int fa3/0 
    FastEthernet3/0 is up, line protocol is up 
      Checksums enabled, MTU 1497, Encapsulation SAP 
      ERPDUs enabled, min. interval 10 msec. 
      CLNS fast switching enabled 
      CLNS SSE switching disabled 
    
      DEC compatibility mode OFF for this interface 
      Next ESH/ISH in 43 seconds 
      Routing Protocol: IS-IS 
        Circuit Type: level-1-2 
        Interface number 0x0, local circuit ID 0x1 
        Level-1 Metric: 10, Priority: 64, Circuit ID: c7200-1.01      
        Number of active level-1 adjacencies: 1 
        Level-2 Metric: 10, Priority: 64, Circuit ID: c7200-1.01      
        Number of active level-2 adjacencies: 1 
        Next IS-IS LAN Level-1 Hello in 1 seconds 
        Next IS-IS LAN Level-2 Hello in 1 seconds
  • mostre vizinhos dos clns - Usado para mostrar aos vizinhos de CLNS o estado.

    c7200-1# show clns neighbors
    System Id      Interface   SNPA                     State  Holdtime  Type Protocol 
    c7200-2        Fa3/0       0004.281e.e008           Up      25        L1L2 IS-IS
  • show ipv6 route - Usado para verificar se existe uma rota no IPv6.

    c7200-1# show ipv6 route 
         IPv6 Routing Table - 7 entries 
         Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
                U - Per-user Static route 
                I1 - ISIS L1, I2 - ISIS L2, IA - ISIS      interarea 
         L   1000:1:1:1:1:1:1:1/128 [0/0] 
              via ::, FastEthernet3/0 
         C   1000:1:1:1:1:1:1:0/112 [0/0] 
              via ::, FastEthernet3/0 
         L   2000:1::1/128 [0/0] 
              via ::, Loopback0 
         C   2000:1::/96 [0/0] 
              via ::, Loopback0 
         I1  3000:1::/96 [115/20] 
              via FE80::204:28FF:FE1E:E008, FastEthernet3/0 
         L   FE80::/10 [0/0] 
              via ::, Null0 
         L   FF00::/8 [0/0] 
              via ::, Null0
    
    c7200-1# show ipv6 route 3000:1::1 
         IPv6 Routing Table - 7 entries 
         Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
                U - Per-user Static route 
                I1 - ISIS L1, I2 - ISIS L2, IA - ISIS      interarea 
         I1  3000:1::/96 [115/20] 
              via FE80::204:28FF:FE1E:E008, FastEthernet3/0 
  • show isis database detail – Usado para mostrar os detalhes do banco de dados IS-IS.

    c7200-1# show isis database detail
    IS-IS Level-1 Link State Database: 
         LSPID                      LSP Seq Num  LSP Checksum  LSP Holdtime           ATT/P/OL 
         c7200-1.00-00       * 0x000000DB        0xC383        1103                   0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-1 
           IPv6 Address: 2000:1::1 
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 10         IPv6 2000:1::/96      
           Metric: 10         IS c7200-1.01      
         c7200-1.01-00       * 0x000000D8        0x5C9A        1078                   0/0/0 
           Metric: 0          IS      c7200-1.00 
           Metric: 0          IS      c7200-2.00 
         c7200-2.00-00         0x000000DD        0x0219        757                    0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-2 
           IPv6 Address: 3000:1::1 
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 10         IPv6 3000:1::/96      
           Metric: 10         IS c7200-1.01      
         IS-IS Level-2 Link State Database: 
         LSPID                      LSP Seq Num  LSP Checksum  LSP Holdtime           ATT/P/OL 
         c7200-1.00-00       * 0x000000DC        0x2569        893                    0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-1 
           IPv6 Address: 2000:1::1 
           Metric: 10         IS c7200-1.01      
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 10         IPv6 2000:1::/96      
           Metric: 20         IPv6 3000:1::/96      
         c7200-1.01-00       * 0x000000D9        0xE994        773                    0/0/0 
           Metric: 0          IS      c7200-1.00 
           Metric: 0          IS      c7200-2.00 
         c7200-2.00-00         0x000000DF        0x88E8        937                    0/0/0 
           Area Address: 49.1111 
           NLPID:        0x8E 
           Hostname: c7200-2 
           IPv6 Address: 3000:1::1 
           Metric: 10         IS c7200-1.01      
           Metric: 10         IPv6 1000:1:1:1:1:1:1:0/112      
           Metric: 20         IPv6 2000:1::/96      
           Metric: 10         IPv6 3000:1::/96
  • ping – Usado para determinar se um host remoto está ativo ou inativo e o retardo de round-trip na comunicação com o host.

    7200-2# ping 1000:1:1:1:1:1:1:1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 1000:1:1:1:1:1:1:1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

  • debug isis adj-packets - Utilizado para mostrar os pacotes IS-IS Hello (IIH) passando por vizinhos do CLNS.

Procedimento de Troubleshooting

A seguir, estão informações relevantes sobre Troubleshooting para essa configuração. Se o IPv6 IS-IS não estiver funcionando apropriadamente, siga as instruções abaixo para resolver o problema de configuração.

  1. Faça o ping do vizinho e certifique-se de que os pings funcionam. Se falhar, verifique se os endereços estão na mesma sub-rede e verifique também a Camada 1 e a Camada 2. É útil ter um endereço do IPv4 em cada relação. Verifique se os pings IPv4 funcionam e isso o ajudará a eliminar qualquer problema das Camadas 1 e 2.

  2. Verifique para ver se a configuração está correta. Consulte os exemplos de configuração na seção Configurations deste documento. Se a configuração se mostrar correta, emita um comando debug clns adj-packets.

    Você deve ver pacotes IIH seguindo em ambas as direções, conforme mostrado neste exemplo de saída de depuração:

    Nota: Antes de emitir comandos debug em uma rede de produção, consulte Informações importantes sobre comandos debug.

    c7200-1# debug isis adj-packets 
    IS-IS Adjacency related packets debugging is on 
    
    5d23h: ISIS-Adj: Sending L1 LAN IIH on FastEthernet3/0, length 1497 
    5d23h: ISIS-Adj: Sending L2 LAN IIH on Loopback0, length 1514n 
    5d23h: ISIS-Adj: Sending L2 LAN IIH on FastEthernet3/0, length 1497 
    5d23h: ISIS-Adj: Rec L1 IIH from 0004.281e.e008 (FastEthernet3/0), cir type L1L2,
     cir id 2220.3330.4440.01, length 1497
  3. Se os vizinhos do IPv6 IS-IS não estão ligando, verifique para ver se há um ID de sistema duplicado.

Para mais detalhes ao configurar o IS-IS sobre o IPv6, refira a biblioteca de configurações do IPv6 do Cisco IOS.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 40262