Serviços de rede de aplicativos : Mecanismos de conteúdo Cisco 500 Series

Configurando a versão de WCCP 2 no Catalyst 3550

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para a versão 2 do Protocolo de Comunicação de Cache da Web (WCCP) no Catalyst 3550 o Cisco Content Engine 560.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Esta configuração foi desenvolvida e testada usando a seguinte versão de software e hardware.

  • Software Release 12.1(11)EA1a sendo executado de Cisco IOS� do Cisco catalyst 3550

  • Aplicativo Cisco do Cisco Content Engine 560 & liberação running 4.2.3 do Content Networking Software (ACNS)

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/29461/diagram.jpg

Configurações

Este documento utiliza as configurações mostradas abaixo.

  • Catalyst 3550

  • Content Engine 560

Catalyst 3550
GIULIO#sh run
Building configuration...
Current configuration : 3426 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
!
hostname GIULIO
!
enable password ww
!
ip subnet-zero
ip routing



!--- Only TCP port 80 may be redirected.
!--- You need to issue the sdm prefer extended-match command
!--- on the switch. Refer to the Verify and Troubleshoot section for 
!--- further information.


ip wccp web-cache
!
!
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
�no switchport
�ip address 10.48.66.217 255.255.254.0
!
interface FastEthernet0/2
�no ip address
!
interface FastEthernet0/3
�no ip address
!
interface FastEthernet0/4
�no ip address
!
interface FastEthernet0/5
�no ip address
!
interface FastEthernet0/6
�no ip address
!���������
interface FastEthernet0/7
�no ip address
!
interface FastEthernet0/8
�no ip address
!
interface FastEthernet0/9
�no ip address
!
interface FastEthernet0/10
�no ip address
!
interface FastEthernet0/11
�no ip address
!
interface FastEthernet0/12
�no ip address
!
interface FastEthernet0/13
�no ip address
!
interface FastEthernet0/14
�no ip address
!
interface FastEthernet0/15
�no ip address
!
interface FastEthernet0/16
�no switchport
�ip address 33.33.33.33 255.255.255.0
�duplex full
�speed 100
!
interface FastEthernet0/17
�no ip address
!
interface FastEthernet0/18
�no ip address
!���������
interface FastEthernet0/19
�no ip address
!
interface FastEthernet0/20
�no ip address
!
interface FastEthernet0/21
�no ip address
!
interface FastEthernet0/22
�no ip address
!
interface FastEthernet0/23
�no ip address
!
interface FastEthernet0/24
�no ip address
!
interface FastEthernet0/25
�no ip address
!
interface FastEthernet0/26
�no ip address
!
interface FastEthernet0/27
�no ip address
!
interface FastEthernet0/28
�no ip address
!
interface FastEthernet0/29
�no ip address
!
interface FastEthernet0/30
�no ip address
!
interface FastEthernet0/31
�no ip address
!
interface FastEthernet0/32
�no ip address
!
interface FastEthernet0/33
�no ip address
!
interface FastEthernet0/34
�no ip address
!
interface FastEthernet0/35
�no ip address
!
interface FastEthernet0/36
�no ip address
!
interface FastEthernet0/37
�no ip address
!
interface FastEthernet0/38
�no ip address
!
interface FastEthernet0/39
�no ip address
!
interface FastEthernet0/40
�no ip address
!
interface FastEthernet0/41
�no ip address
!
interface FastEthernet0/42
�no ip address
!
interface FastEthernet0/43
�no ip address
!
interface FastEthernet0/44
�no ip address
!
interface FastEthernet0/45
�no ip address
!
interface FastEthernet0/46
�no ip address
!
interface FastEthernet0/47
�no ip address
!
interface FastEthernet0/48


!--- On this WCCP implementation, only input redirection is allowed.


�no switchport
�ip address 1.1.1.1 255.255.255.0
�ip wccp web-cache redirect in
!
interface GigabitEthernet0/1
�no ip address
!
interface GigabitEthernet0/2
�no ip address
!
!



!--- This access list 100, if associated as 'in' to Fa0/48, 
!--- can show if packets are reaching the Catalyst from the PC client.


access-list 100 permit tcp any eq www any log
access-list 100 permit tcp any any eq www log

access-list 100 permit any any any log

ip default-gateway 10.48.66.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.48.66.1
ip http server
!
!
!
!
line con 0
�exec-timeout 0 0
�password cisco
line vty 0 4
�exec-timeout 0 0
�password ww
�login
line vty 5 15
�login
!
end

GIULIO#

Content Engine 560
agra#sh run 
  hostname agra 
  ! 
  ! 
  ! 
  ! 
  ! 


!--- The Standby feature on the Content Engine  is optional in the 
!--- implementation, but it works fine with the Catalyst.

  interface FastEthernet 0/0 
  �ip address 122.122.122.1 255.255.255.0 
  �standby 1 ip 33.33.33.31 255.255.255.0
  �standby 1 priority 120 
  �no autosense 
  �bandwidth 100 
  �full-duplex 
  �exit 
  interface FastEthernet 0/1 
  �ip address 122.122.123.1 255.255.255.0 
  �standby 1 ip 33.33.33.31 255.255.255.0  
  �standby 1 priority 80 
  �no autosense 
  �bandwidth 100 
  �full-duplex 
  �exit 
  ! 
  ! 
  ip default-gateway 33.33.33.33 
  ! 
  primary-interface FastEthernet 0/0 
  ! 
  ! 
  ! 
  ! 


!--- The logging console is only used for troubleshooting, as it may cause 
!-- high CPU on the Content Engine in production.
� 
  logging console enable 
  logging console priority debug 
  ! 
  ! 
  ! 
  ! 
  ! 
  ! 
  ! 
  
  wccp router-list 1 33.33.33.33 
  wccp web-cache router-list-num 1 l2-redirect 

!--- The assign-method-strict is not necessary.

  wccp version 2 


!--- Catalyst 3550 implementation of WCCP allows only Layer 2 redirection, 
!--- and not generic routing encapsulation (GRE). In addition, only TCP 
!--- port 80 may be redirected. 

  ! 
  ! 
  username admin password 1 bVmDmMMmZAPjY 
  username admin privilege 15 
  ! 
  ! 
  ! 
  ! 
  authentication login local enable primary 
  authentication configuration local enable primary 
  ! 
  !               

agra#

Verificar e solucionar problemas

Esta seção fornece a informação que você pode se usar para confirmar que sua configuração está trabalhando corretamente e para o pesquisar defeitos mais.

  • A fim permitir o redirecionamento de WCCP no Catalyst Switch, você precisa de emitir o comando sdm prefer extended-match (e para recarregar o interruptor). Emitindo o comando show sdm prefer, você pode ver a configuração real do hardware TCAM/ASIC no interruptor.

  • Enquanto a aplicação do WCCP no Catalyst 3550 é limitada, emitir o comando show ip wccp não mostra o número de pacotes que estão sendo reorientados. Este deslocamento predeterminado permanece em 0. Também, o mesmo catalizador pode ter o Content Engine múltiplo no farm de cache, mas somente um catalyst WCCP é permitido. A saída do comando show ip wccp no catalizador é mostrada abaixo.

    GIULIO#sh ip wccp 
    
    Global WCCP information: 
      ��� Router information: 
      ������� Router Identifier:������������������  33.33.33.33 
      ������� Protocol Version:�������������������  2.0 
    
    ��� Service Identifier: web-cache 
      ������� Number of Cache Engines:�������������  1 
      ������� Number of routers:���������������������1 
      ������� Total Packets Redirected:��������������0 
      ������� Redirect access-list:����������������  -none- 
      ������� Total Packets Denied Redirect:�������  0 
      ������� Total Packets Unassigned:��������������0 
      ������� Group access-list:�������������������  -none- 
      ������� Total Messages Denied to Group:���     0 
      ������� Total Authentication failures:���������0 
      �
                                  Statistics - Requests
                                                    Total             % of Requests
                                ---------------------------------------------------
         Total Received Requests:                       4                         -
                  Forced Reloads:                       0                       0.0
                   Client Errors:                       0                       0.0
                   Server Errors:                       0                       0.0
             URL Blocked (Reset):                       0                       0.0
                     URL Blocked:                       0                       0.0
          Sent to Outgoing Proxy:                       0                       0.0
    Failures from Outgoing Proxy:                       0                       0.0
    Excluded from Outgoing Proxy:                       0                       0.0
                 ICP Client Hits:                       0                       0.0
                 ICP Server Hits:                       0                       0.0
                   If-Range Hits:                       0                       0.0
               HTTP 0.9 Requests:                       4                     100.0
               HTTP 1.0 Requests:                       0                       0.0
               HTTP 1.1 Requests:                       0                       0.0
           HTTP Unknown Requests:                       0                       0.0
               Non HTTP Requests:                       0                       0.0
              Non HTTP Responses:                       0                       0.0
          Chunked HTTP Responses:                       0                       0.0
            Http Miss Due To DNS:                       0                       0.0
         Http Deletes Due To DNS:                       0                       0.0
    
    
    agra#sho stat http savings 
                             Statistics - Savings
                            Requests                          Bytes
             -----------------------------------------------------------
      Total:                       4                           3132
       Hits:                       3                           2349
       Miss:                       1                            783
    Savings:                    75.0 %                         75.0 %
    
    
    agra#sho stat netstat 
    Active Internet connections (w/o servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State      
    tcp        0      0 33.33.33.31:8999        10.48.66.123:2011       ESTABLISHED 
    
    udp        0      0 127.0.0.1:10000         127.0.0.1:32346         ESTABLISHED 
    
    udp        0      0 127.0.0.1:10001         127.0.0.1:32347         ESTABLISHED 
    
    udp        0      0 127.0.0.1:10002         127.0.0.1:32345         ESTABLISHED
  • Se a lista de acessos 100 é aplicada ao tráfego de entrada nos FastEthernet 0/48, uma mensagem similar ao seguinte deve ser enviada ao console para cada pacote de HTTP enviado pelo navegador cliente ao Internet:

    *Mar� 1 04:19:09: %SEC-6-IPACCESSLOGP: list 109 permitted tcp 1.1.1.2(1828)    -> 10.48.66.125(80), 1 packet �    
    
    
  • No Content Engine, os comandos seguintes permitem que você considere o número de pacotes enviados pelo Content Engine:

    • show statistics http requests

    • mostre o netstat das estatísticas

    • mostre economias HTTP da estatística

    Todos os pacotes mandados ao Internet têm um endereço IP de origem idêntico ao Content Engine, exceto quando o Content Engine reage do modo de desvio e os pedidos estão enviados pelo endereço IP de origem do PC cliente pelo contrário.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 29461