Banda larga a cabo : Cable Modem Termination Systems (CMTS)

configuração completa do uBR7100 no modo de Bridge

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para um cable modem termination system (CMTS) do Cisco uBR7100 que atue como um protocolo de configuração dinâmica host (DHCP), uma hora (ToD), e um servidor TFTP. Igualmente explica como construiu o arquivo de configuração do Data-over-Cable Service Interface Specifications (DOCSIS) usando o comando line interface(cli) no CMTS. Esta configuração está sabida como a “configuração completa para Cisco CMTS” quando o CMTS for configurado no modo de Bridging. Presentemente a plataforma do uBR7100 é a única plataforma CMTS que apoia a construção de uma ponte sobre.

Pré-requisitos

Requisitos

O leitor deste documento deve ter uma compreensão básica da construção de uma ponte sobre, o DOCSIS, o DHCP, o ToD, e os protocolos TFTP.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Sistema da extremidade do cable modem do Cisco uBR7100

  • Modens a cabo em conformidade com DOCSIS

  • Software Release 12.1(7)EC ou Mais Recente de Cisco IOS�

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Descrição

Um modem a cabo em conformidade com DOCSIS exige o acesso a três tipos de server a fim vir com sucesso em linha.

A maioria de Cisco Network Registrar do uso dos operadores de cabo (CNR) como o DHCP, o Domain Name Server (DNS), e os servidores TFTP. O servidor ToD não é parte do CNR. O servidor ToD que é usado depende em cima da plataforma do sistema do operador de cabo. O ToD deve ser RFC-868leavingcisco.com - complacente. Para sistemas Unix, é incluído em Solaris; é somente necessário certificar-se de que o arquivo inetd.conf no diretório de /etc contém estas linhas:

# Time service is used for clock synchronization.
#
time    stream  tcp     nowait  root    internal
time    dgram   udp     wait    root    internal

Para Windows, o software o mais de uso geral é Greywareleavingcisco.com .

Esta tabela mostra os Cisco IOS Software Release em que as potencialidades de servidor diferentes foram adicionadas ao CMTS:

Recursos do servidor Versão do Cisco IOS Software
DHCP 12.0(1)T
ToD 12.0(4)XI
TFTP 11.0 (para todas as plataformas)

Este documento explica cada um destas características. A configuração no CMTS que contém todas estas capacidades é chamada a “configuração completa para o CMTS.” Com esta configuração, você não precisa nenhuns server adicionais de testar suas plantas de cabos e de fornecer o acesso à internet de alta velocidade.

Também é possível também configurar um arquivo de configuração DOCSIS que esteja no CMTS, e não no servidor TFTP. De acordo com as notas de release, é necessário pelo menos o Cisco IOS Software Release12.1(2)EC1 para poder usar este recurso.

Embora esta “configuração completa” seja muito conveniente para ambientes de laboratório, exame inicial, disposições pequenas, e pesquisa de defeitos, não é escalável apoiar muito um número grande de Modems a cabo. Assim não se recomenda que você usa esta configuração em plantas de cabos operacionais com grandes disposições de Modems a cabo.

Os engenheiros de suporte técnico de Cisco usam frequentemente esta configuração para eliminar variáveis ao pesquisar defeitos problemas de cabo.

Roteamento e operação de Bridging

O Roteadores da Cisco UBR 7100 Series apoia este o modo de operação:

  • Modo de roteamento — Distribuir a operação é o modo padrão típico para roteadores do Cisco CMTS. Fornecem um espectro amplo de recursos de roteamento do Cisco IOS Software, tais como um servidor DHCP e o controle sobre que os pacotes são enviados sobre cada relação.

  • Modo do Bridging transparente — A operação de Bridging entre a interface de cabo e as interfaces de adaptador de porta não é usada tipicamente nas instalações do DOCSIS CMTS devido ao desempenho potencial e aos problemas de segurança. Construir uma ponte sobre é muito eficaz, contudo, nos ambientes CMTS com um número limitado de dispositivos do equipamento da premissa do cliente (CPE) — como em um ambiente da unidade de residência múltipla típica (MDU) ou da unidade multi-tenant (MTU) — especialmente se o CMTS está substituindo uma rede de construção de uma ponte sobre existente.

Integrated Routing and Bridging (IRB)

A operação do Integrated Routing and Bridging (IRB) reserva construir uma ponte sobre dentro de um segmento específico das redes ou dos anfitriões, contudo igualmente permite que aqueles anfitriões conectem aos dispositivos em outro, redes roteada sem ter que usar um roteador separado para interconectar as duas redes.

Nota: O Bridging transparente e a operação de IRB são apoiados somente ao usar o Cisco IOS Software Release 12.1(7)EC e Mais Recente. Para detalhes completos no Bridging transparente e a operação de IRB, veja os capítulos de construção de uma ponte sobre no Cisco IOS que constroem uma ponte sobre e manual de configuração das Redes IBM, Versão 12.1, disponíveis no cisco.com e no cd-rom de documentação.

Bridge-Group Virtual Interface

ubr7100_config_bridge_1.gif

Porque construir uma ponte sobre se opera na camada de link de dados e distribuir se opera na camada de rede, seguem modelos diferentes da configuração de protocolo. Tomando o modelo básico IP como um exemplo, todas as interfaces interligada pertenceriam à mesma rede, quando cada interface roteada representar uma rede distinta.

No IRB, o Bridge-Group Virtual Interface está introduzido para evitar confundir o modelo da configuração de protocolo quando um protocolo específico é construído uma ponte sobre e distribuído em um grupo de bridge.

O Bridge-Group Virtual Interface é uma interface roteada normal que não apoie a construção de uma ponte sobre, mas representa seu grupo de bridge correspondente à interface roteada. Tem todos os atributos da camada de rede (tais como um endereço de camada de rede e filtros) que se aplicam ao grupo de bridge correspondente. O número de interface atribuído a esta interface virtual corresponde ao grupo de bridge que esta interface virtual representa. Este número é o link entre a interface virtual e o grupo de bridge.

Quando você permite o roteamento para um protocolo dado no Bridge-Group Virtual Interface, os pacotes que vêm de uma interface roteada mas destinados para um host em um domínio interligado estão distribuídos ao Bridge-Group Virtual Interface e enviados à interface interligada correspondente. Todo o tráfego distribuído ao Bridge-Group Virtual Interface é enviado ao grupo de bridge correspondente como o tráfego interligado. Todo o tráfego do roteável recebido em uma interface interligada é distribuído a outras interfaces roteada como se está vindo diretamente do Bridge-Group Virtual Interface.

Para receber os pacotes roteável que chegam em uma interface interligada mas destinados para uma interface roteada ou receber pacotes roteado, o Bridge-Group Virtual Interface deve igualmente ter os endereços apropriados. Os endereços e os endereços de rede MAC são atribuídos ao Bridge-Group Virtual Interface desse modo:

  • O Bridge-Group Virtual Interface “pede” o MAC address de uma das interfaces interligada no grupo de bridge associado com o Bridge-Group Virtual Interface.

  • Para distribuir e construir uma ponte sobre um protocolo dado no mesmo grupo de bridge, você deve configurar os atributos da camada de rede do protocolo no Bridge-Group Virtual Interface.

  • Nenhum atributo do protocolo deve ser configurado nas interfaces interligada, e nenhum atributo de construção de uma ponte sobre pode ser configurado no Bridge-Group Virtual Interface.

Porque pode haver somente um Bridge-Group Virtual Interface que representa um grupo de bridge — e o grupo de bridge pode ser composto dos tipos de mídia diferentes configurados para diversos métodos de encapsulamento diferentes — você pode precisar de configurar o Bridge-Group Virtual Interface com os métodos de encapsulamento particulares exigidos para comutar corretamente pacotes.

O serviço do Cisco IOS DHCP em um CMTS

Os roteadores Cisco que executam o Cisco IOS Software Release 12.0(1)T ou Mais Recente têm a capacidade de agir como servidores DHCP. Este serviço DHCP pode ser configurado para fornecer aluguéis de DHCP ao Modems a cabo e ao CPE, tal como PC e estações de trabalho.

Há um ajuste mínimo das opções de DHCP que o Modems a cabo exige tipicamente a fim vir em linha:

  • Um endereço IP (O campo yiaddr no cabeçalho do pacote de DHCP)

  • Uma máscara de sub-rede (opção de DHCP 1)

  • O offset de horário local do horário de Greenwich (GMT) nos segundos (opção de DHCP 2)

  • Um roteador padrão (opção de DHCP 3)

  • O endereço IP de um servidor ToD (opção de DHCP 4)

  • O servidor de registro (DHCP opção 7)

  • O endereço IP de um servidor TFTP (o campo siaddr no cabeçalho do pacote DHCP)

  • O nome de um arquivo de configuração DOCSIS (o campo “file” no cabeçalho do pacote DHCP)

  • Um tempo de concessão de DHCP em segundos (opção DHCP 51)

No roteador, aquelas opções podem ser configuradas com estes comandos:

!
ip dhcp pool cm-platinum
 network 10.1.4.0 255.255.255.0
 bootfile platinum.cm
 next-server 10.1.4.1
 default-router 10.1.4.1
 option 7 ip 10.1.4.1
 option 4 ip 10.1.4.1
 option 2 hex ffff.8f80
 lease 7 0 10
!

Estas são explicações de cada um daqueles comandos:

  • pool DHCP — Define o nome do espaço do modem a cabo (cm-platinum).

  • rede — Fornece o endereço IP de Um ou Mais Servidores Cisco ICM NT e a máscara de sub-rede (opção de DHCP 1).

  • bootfile — Fornece o nome de arquivo da bota que, neste caso, é platinum.cm.

  • seguinte-server — Especifica o endereço IP do servidor de TFTP que, neste caso, é o endereço IP primário no c4/0 da relação.

  • padrão-roteador — Define o gateway padrão que, neste caso, é o c4/0 do endereço IP principal de interface (opção de DHCP 3).

  • opção 7 — Define a opção de DHCP do server do log.

  • opção 4 — Fornece o endereço IP de Um ou Mais Servidores Cisco ICM NT do servidor ToD (c4/0 do endereço IP principal de interface).

  • opção 2 — Fornece a opção offset tempo para o GMT – 8 horas (– 8 horas de iguais – 28800 segundos, que iguala ffff.8f80 nos números hexadecimais).

    Nota: Para aprender mais sobre como converter um valor decimal do tempo do offset no hexadecimal, refira como calcular o valor hexadecimal para a opção de DHCP 2 (deslocamento de tempo).

  • aluguer — Ajusta o Lease Time (dias 7, 0 horas, minutos 10).

Para dispositivos CPE, estas opções são o mínimo exigido para operar-se com sucesso:

  • Um endereço IP (O campo yiaddr no cabeçalho do pacote de DHCP)

  • Uma máscara de sub-rede (opção de DHCP 1)

  • Um roteador padrão (opção de DHCP 3)

  • O endereço IP de Um ou Mais Servidores Cisco ICM NT de uns ou vários DNS (opção de DHCP 6)

  • Um nome de domínio (opção DHCP 15)

  • Um tempo de concessão de DHCP em segundos (opção DHCP 51)

No roteador, aquelas opções podem ser configuradas com estes comandos:

! 
ip dhcp pool pcs-irb

!--- The scope for the hosts.

   network 172.16.29.0 255.255.255.224

!--- The IP address and mask for the hosts.

   next-server 172.16.29.1

!--- TFTP server; in this case, the secondary address is used.

   default-router 172.16.29.1
   dns-server 172.16.30.2

!--- DNS server (which is not configured on the CMTS).

   domain-name cisco.com
   lease 7 0 10
!

Outras funcionalidades do servidor de DHCP

Estes são alguns outros recursos que podem ser usados do servidor DHCP do Cisco IOS Software:

  • sibilo DHCP IP — Sibilo antes da função do aluguer, que se assegura de que o servidor DHCP não emita alugueres para os endereços IP de Um ou Mais Servidores Cisco ICM NT que são já dentro uso.

  • banco de dados DHCP IP — Uma função que armazene emperramentos DHCP em um banco de dados externo a fim manter relacionamentos do MAC-endereço-à-IP-endereço durante um ciclo da potência CMTS.

  • mostre o DHCP IP — Um conjunto de comandos que possa ser usado para monitorar o funcionamento do servidor DHCP.

  • debugar o ip dhcp server — Um conjunto de comandos que possa ser usado para pesquisar defeitos o funcionamento do servidor DHCP.

Todas estas funções e características extra são descritas nas notas de versão de recurso do servidor DHCP do Cisco IOS Software no documento do servidor de DHCP IOS Cisco.

O serviço TFTP do Cisco IOS

Após um modem a cabo tentar entrar em contato com um servidor ToD, ele prossegue para entrar em contato com um servidor TFTP para baixar um arquivo de configuração DOCSIS. Se um arquivo binário de configuração de DOCSIS puder ser copiado em um dispositivo flash de um Cisco CMTS, o roteador pode agir como servidor de TFTP desse arquivo.

Este é o procedimento para transferir um arquivo de configuração DOCSIS no flash:

  1. Emita este comando ping assegurar-se de que o CMTS possa alcançar o server onde o arquivo de configuração DOCSIS é encontrado.

    Ubr7111# ping 172.16.30.2
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.30.2, timeout is 2 seconds:
    
    !--- Output suppressed.
    
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
  2. Copie o arquivo (neste caso, é chamado silver.cm) no flash do CMTS.

    Ubr7111# copy tftp flash
    
    Address or name of remote host []? 172.16.30.2
    Source filename []? silver.cm
    Destination filename [silver.cm]?
    
    Accessing tftp://172.16.30.2/silver.cm...
    Loading silver.cm from 172.16.30.2 (via Ethernet2/0): !
    [OK - 76/4096 bytes]
    
    76 bytes copied in 0.152 secs
  3. Verifique o flash e verifique que o tamanho do arquivo está correto, usando o comando dir.

    Ubr7111# dir
    
    Directory of disk0:/
    
       1  -rw-          74   Feb 13 2001 16:14:26  silver.cm
       2  -rw-    10035464   Feb 14 2001 15:44:20  ubr7100-ik1s-mz.121-11b.EC.bin
    
    47890432 bytes total (17936384 bytes free)
  4. Para permitir o serviço TFTP no CMTS, emita este comando no modo de configuração global:

    tftp-server slot0:silver.cm alias silver.cm
    
  5. Confirme etapa 4 verificando para ver se há estas linhas na configuração:

    !
    tftp-server slot0:silver.cm alias silver.cm
    tftp-server server
    !

Para obter mais informações sobre da configuração de um servidor TFTP em um roteador, refira o documento adicional dos comandos function de transferência de arquivo.

O serviço de ToD do Cisco IOS

Depois que um modem a cabo adquire com sucesso um aluguel de DHCP, tenta então contactar um servidor ToD. Produtos Cisco CMTS executando o Cisco IOS Software versão 12.0(4)XI ou posterior são capazes de fornecer um serviço de RFC 868 ToD.leavingcisco.com

Uma concepção errada comum é que o serviço de ToD que o Modems a cabo precisa de usar para vir em linha é o mesmo que o serviço do Network Time Protocol (NTP) que é configurado geralmente em roteadores Cisco. O serviço NTP e o serviço ToD são incompatíveis. O Modems a cabo não pode falar a um servidor de NTP. Quando o Modems a cabo dever tentar contactar parte de um servidor ToD como o processo de vinda em linha, o em conformidade com modems com as revisões as mais atrasadas da especificação das interferências de radiofreqüência do DOCSIS 1.0 (RFI) ainda continua vir em linha mesmo se um servidor ToD não pode ser alcançado.

De acordo com as versões mais recentes da especificação, se um modem a cabo não puder contatar um servidor ToD, ele poderá continuar com o processo de ficar on-line. Deve, contudo, periodicamente tentar contactar o servidor ToD até que esteja bem sucedido. As versões anterior da especificação de RFI do DOCSIS 1.0 encarregaram-se de que, se um modem a cabo não poderia contactar um servidor ToD, a seguir o modem não poderia vir em linha. É importante saber que os cable modems que executam firmware mais antigo devem atender a essa versão mais antiga da especificação.

Nota: O Modems a cabo de alguns vendedores não interopera com o serviço de ToD do Cisco IOS Software. Se esses modems forem compatíveis com as versões mais recentes da especificação DOCSIS 1.0 RFI, eles deverão continuar a ficar on-line independentemente. Esta questão de interoperabilidade está sendo endereçada pela identificação de bug Cisco CSCdt24107 (clientes registrados somente).

Para configurar ToD em Cisco CMTS, emita estes comandos global:

service udp-small-servers max-servers no-limit
!
cable time-server
!

O gerador do arquivo de configuração DOCSIS interno

Os produtos Cisco CMTS que executam a versão 12.1(2)EC ou posterior do Cisco IOS (na versão de treinamento EC) podem ser configurados para gerar e armazenar internamente arquivos de configuração DOCSIS. Fazer assim é útil porque leva embora a exigência de ter o acesso a uma ferramenta externo da geração de arquivo de configuração DOCSIS. Quando um arquivo de configuração DOCSIS é criado usando a ferramenta de configuração interna, o arquivo transforma-se automaticamente TFTP direto disponível. Além disso, somente o Modems a cabo diretamente em relações do cabo conectado pode transferir estes arquivos de configuração.

Estes exemplos de configuração mostram a criação de dois arquivos de configuração DOCSIS.

O primeiro é chamado disable.cm, que permite um modem a cabo venha em linha mas impede que os dispositivos CPE conectados alcancem a rede do provedor de serviços. Neste caso, há um comando access-denied. Observe que as velocidades a jusante e ascendentes são neste caso os kbps 1, e o tamanho de intermitência máxima é 1600 bytes.

cable config-file disable.cm
   access-denied
   service-class 1 max-upstream 1
   service-class 1 max-downstream 1600
   timestamp
!

Um operador de cabo usa este arquivo de configuração DOCSIS de disable.cm para negar o acesso ao CPE atrás do modem a cabo ao ainda permitir que o modem a cabo venha em linha. Esta é uma maneira de mais eficiente de negar um serviço CPE do que usando a opção da exclusão no CNR, que não permite que o modem a cabo venha em linha: o modem a cabo repetidamente tenta vir em linha e desperdiça a largura de banda.

O Modems a cabo com este arquivo de configuração DOCSIS mostra esta saída, quando o comando show cable modem é emitido:

Cable1/0/U0 10  online(d)  2287  0.50  6  0  10.1.4.65  0010.7bed.9b45

Os dicas de verificação para a seção de configuração avançada deste documento dão mais detalhes sobre esta saída. O estado em linha (d) significa que o Modems a cabo é em linha mas o acesso está negado.

No segundo exemplo, um arquivo de configuração DOCSIS chamado platinum.cm é criado. Neste caso, o valor ascendente do máximo é 1 Mbps, o valor ascendente garantido é 100 kbps, o downstream máximo é 10 Mbps, e permite que até 30 dispositivos CPE sejam conectados.

cable config-file platinum.cm
   service-class 1 max-upstream 1000
   service-class 1 guaranteed-upstream 100
   service-class 1 max-downstream 10000
   service-class 1 max-burst 1600
   cpe max 30
   timestamp
!

Observe que, ao configurar o arquivo de configuração DOCSIS no CMTS, você não precisa o server slot0:platinum.cm aliás platinum.cm de tftp da indicação porque não há nenhum arquivo de .cm armazenado na memória; reside dentro da configuração.

Uns detalhes mais adicionais na ferramenta interna do arquivo de configuração DOCSIS podem ser encontrados nos comandos de configuração de CMTS de Cisco do documento.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Uma topologia típica da instalação de laboratório é mostrada nesta imagem:

/image/gif/paws/29243/ubr7100_config_bridge_2.gif

Configurações

Este documento utiliza as seguintes configurações:

Esta configuração é apoiada somente em plataformas CMTS do uBR7100.

O Cisco IOS Software Release que apoia a configuração completa, incluindo a configuração do arquivo de configuração DOCSIS, é Cisco IOS Software Release 12.1(2)EC e as liberações subsequentes do trem EC. O trem de Cisco IOS Software que foi usado nesta configuração é ubr7100-ik1s-mz.121-11b.EC.bin.

Configuração básica completa

Esta configuração resume todas as partes explicadas até agora. Tem dois escopos de DHCP: um para o Modems a cabo e outro para os anfitriões atrás do Modems a cabo.

Um arquivo de configuração DOCSIS é criado, chamado platinum.cm. Esse arquivo é aplicado ao conjunto de DHCP chamado cm-platinum. O outro arquivo de configuração DOCSIS, chamado disabled.cm, não é aplicado a qualquer coisa neste momento.

Os comentários estão no azul, após os comandos relacionados. Os comandos de configuração completa estão em negrito.

Configuração básica completa
ubr7100# show run
Building configuration...
 
Current configuration : 3511 bytes
!
! Last configuration change at 01:12:37 PST Mon Sep 3 2001
!
version 12.1
no service pad
service timestamps debug datetime msec localtime

!--- Provides useful timestamps on all log messages.

service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit

!--- Supports a large number of modems or hosts attaching quickly.

 
!
hostname ubr7111
!
boot system flash disk0:ubr7100-ik1s-mz.121-11b.EC.bin
!
cable spectrum-group 3 frequency 40800000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable timeserver

!---  Allows cable modems to obtain ToD from the uBR7100.

!
cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 8
 timestamp
!
clock timezone PST -9
clock calendar-valid
ip subnet-zero
no ip routing

!--- Disables routing on the CMTS.

no ip domain-lookup

!--- Prevents the CMTS from looking up domain names or attempting 
!--- to connect to machines (for example, when mistyping commands).

ip host ubr7111 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
no ip dhcp relay information check
 
ip dhcp excluded-address 10.45.50.1 10.45.50.5
!
ip dhcp pool cm-platinum

!--- Name of the DHCP pool. This scope is for the cable modems attached 
!--- to interface cable 4/0.

   network 10.1.4.0 255.255.255.0

!--- Pool of addresses for scope modems-c1/0.

   bootfile platinum.cm

!--- DOCSIS configuration file name associated with this pool.

   next-server 10.1.4.1

!--- IP address of the TFTP server which sends the boot file.

   default-router 10.1.4.1

!--- Default gateway for cable modems; necessary to get DOCSIS files.

   option 7 ip 10.1.4.1

!--- Log Server DHCP option.

   option 4 ip 10.1.4.1

!--- ToD server IP address.

   option 2 hex ffff.8f80

!--- Time offset for ToD, in seconds (HEX), from GMT.
!--- Pacific Standard Time offset from GMT = –28,000 seconds = ffff.8f80

   lease 7 0 10

!--- Lease 7 days 0 hours 10 minutes.

! 
ip dhcp pool pcs-irb

!--- Name of the DHCP pool. This scope is for the CPE attached to
!--- the cable modems that are connected to interface cable 1/0.

   network 172.16.29.0 255.255.255.0

!--- Pool of addresses for scope pcs-c4 (associated with the secondary address).

   next-server 172.16.29.1
   default-router 172.16.29.1
   dns-server 172.16.29.1
   domain-name cisco.com
   lease 7 0 10
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
!
!
!
bridge irb
!
!
interface FastEthernet0/0
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 no keepalive
 duplex half
 speed auto
 no cdp enable
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0/1
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 shutdown
 duplex auto
 speed 10
 no cdp enable
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Cable1/0
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no keepalive
 cable packet-cache
 cable downstream annex B
 cable downstream modulation 256qam
 cable downstream interleave-depth 32
 cable downstream frequency 525000000
 no cable downstream rf-shutdown
 cable downstream rf-power 55
 cable upstream 0 frequency 17808000
 cable upstream 0 power-level 0
 cable upstream 0 channel-width 3200000
 no cable upstream 0 shutdown
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 10.1.4.1 255.255.255.0
!
ip default-gateway 14.66.1.1
ip classless
no ip http server
!
no cdp run
bridge 1 protocol ieee
 bridge 1 route ip
alias exec scm show cable modem
!
line con 0
 exec-timeout 0 0
 privilege level 15
 length 0
line aux 0
line vty 0 4
 privilege level 15
 no login
line vty 5 15
 login
!
end

Dicas de verificação para a configuração básica

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  1. Certifique-se de que os comandos estão apoiados no Cisco IOS Software Release emitindo um comando show version.

  2. Verifique que o arquivo de configuração DOCSIS está no flash.

    Ubr7111# dir
    
    Directory of disk0:/
     
        1  -rw-          74   Feb 13 2001 16:14:26  silver.cm
        2  -rw-    10035464   Feb 14 2001 15:44:20  ubr7100-ik1s-mz.121-11b.EC.bin
     
    47890432 bytes total (17936384 bytes free)

    Nota: O arquivo silver.cm foi construído usando a ferramenta do DOCSIS CPE Configurator. Para o arquivo do platinum.cm que foi construído na configuração de CMTS, você não precisa o server slot0:platinum.cm aliás platinum.cm de tftp da indicação porque não há nenhum arquivo de .cm; reside dentro da configuração.

  3. Verifique que o Modems a cabo é em linha emitindo o comando show cable modem.

    Ubr7111# show interface cable 1/0 modem 0
    
    SID   Priv bits  Type      State     IP address    method    MAC address
    75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
    75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
    76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
    77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
    77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
    78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
    79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
    80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

    Observe que todo o Modems a cabo é em linha. Esses conectados ao cabo de interface 1/0/U0 estão na rede 10.1.4.0. Você pode ver da configuração que seus endereços IP de Um ou Mais Servidores Cisco ICM NT estão tomados do conjunto de DHCP chamado cm-platinum.

    Igualmente observe que o Modems a cabo com endereços 0010.7bed.9b23 e 0010.7bed.9b45 MAC tem um CPE atrás deles. Esses modems a cabo entram no modo on-line com a configuração de Bridging padrão. Aqueles PC são configurados com DHCP de modo que possam obter seus endereços IP de Um ou Mais Servidores Cisco ICM NT da rede.

    Ubr7111# show interface cable 1/0 modem 0
    
    SID   Priv bits  Type      State     IP address    method    MAC address
    75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
    75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
    76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
    77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
    77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
    78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
    79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
    80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

    Este screen shot mostra que aqueles PC obtêm um endereço IP de Um ou Mais Servidores Cisco ICM NT das associações chamadas pcs-c4.

    ubr7100_config_bridge_3.gif

    Você pode igualmente ver deste PC que os ajustes TCP/IP estão ajustados para obter automaticamente o endereço IP de Um ou Mais Servidores Cisco ICM NT.

    ubr7100_config_bridge_4.gif

Configuração completa avançada

Esta seção fornece um exemplo de configuração mais sofisticado que envolva a funcionalidade de hierarquia dos conjuntos de DHCP. Os trabalhos da hierarquia do conjunto de DHCP da maneira são que todo o conjunto de DHCP com um network number que seja um subconjunto do network number de uma outra associação herda todas as características desse outro pool. Isso salva a repetição na configuração do servidor DHCP. Se, contudo, a mesma especificação é feita com um parâmetro diferente, a seguir o parâmetro overwritten. Este exemplo mostra um conjunto geral com um arquivo da bota chamado platinum.cm e um subconjunto deste pool com um arquivo da bota chamado disable.cm.

Além do que os conjuntos de DHCP criados no exemplo básico, há uns requisitos especiais para dois Modems a cabo.

Primeiramente, o modem a cabo 0010.7bed.9b45 é negado o acesso; concede-se um endereço IP de Um ou Mais Servidores Cisco ICM NT mas não vem em linha. Crie este pool:

ip dhcp pool cm-0010.7bed.9b45
   host 10.1.4.65 255.255.255.0
   client-identifier 0100.107b.ed9b.45
   bootfile disable.cm

A maioria de recursos notáveis deste exemplo de configuração são a seção onde você especifica os conjuntos de DHCP especiais que correspondem aos endereços do Cable Modem individual MAC. Tal especificação permite que o servidor DHCP envie opções de DHCP originais a este Modems. Para especificar um cable modem particular, o parâmetro do cliente-identificador é usado. O cliente-identificador deve ser ajustado a 01, seguido pelo MAC address do dispositivo a que a entrada corresponde. Os 01 corresponde aos Ethernet para o tipo de hardware DHCP.

Nota: Ao mudar arquivos de configuração para um modem, você deve executar estas etapas para assegurar-se de que o modem a cabo obtenha manualmente os parâmetros configurados:

  1. Cancele a tabela de ligação IP DHCP emitindo o comando clear ip dhcp binding ip address.

  2. Restaure o modem a cabo na pergunta emitindo o comando clear cable modem mac address res.

Em segundo, o modem a cabo 0010.7bed.9b23 igualmente tem um requisito especial: obtém um Qualidade de Serviço (QoS) diferente. Consequentemente, um arquivo diferente da bota é associado ao espaço, segundo as indicações desta configuração parcial:

ip dhcp pool cm-0010.7bed.9b23
   host 10.1.4.66 255.255.255.0
   client-identifier 0100.107b.ed9b.23
   bootfile silver.cm
!

Ao configurar conjuntos de DHCP para o Modems a cabo específico, é sempre uma boa prática dar um nome relevante. Também, porque um endereço IP de Um ou Mais Servidores Cisco ICM NT específico é atribuído ao pool usando o comando host, você deve emitir o comando global o DHCP IP que exclui 10.1.4.60 10.1.4.70. Este comando diz o DHCP para não usar endereços nesta escala.

Dicas de verificação para configuração avançada

A verificação desta configuração centra-se sobre os serviços que o Modems a cabo está obtendo, especialmente 0010.7bed.9b45 e 0010.7bed.9b23. Você deve ser certo que estão obtendo os endereços com que foram configurados manualmente e o serviço.

A primeira coisa a testar é que 0010.7bed.9b45 vem em linha, mas que o serviço está negado. Emita o comando show cable modem.

7246VXR# show cable modem

Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable4/0/U0 7    online     2813    0.00  7   0   10.1.4.7        0002.1685.b5db
Cable4/0/U0 8    online     2809    0.25  7   0   10.1.4.10       0002.fdfa.0a63
Cable4/0/U0 9    online     2288   -0.25  5   1   10.1.4.66       0010.7bed.9b23
Cable4/0/U0 10   online(d)  2287    0.50  6   0   10.1.4.65       0010.7bed.9b45
Cable4/0/U0 11   online     2809   -0.50  7   0   10.1.4.6        0001.64ff.e47d
Cable4/0/U0 12   online     2812   -0.50  7   0   10.1.4.9        0004.2752.ddd5

Observe estes fatos:

  • O modem a cabo 0010.7bed.9b23 obteve o endereço IP 10.4.1.66, como especificado no espaço cm-0010.7bed.9b23. Há um computador conectado a ele e este obtém seu endereço IP do pcs-c4 do conjunto.

  • O modem a cabo 0010.7bed.9b23 possui uma QoS diferente.

  • O modem a cabo 0010.7bed.9b45 obteve o endereço IP 10.1.4.65, como especificado no espaço cm-0010.7bed.9b45. Há um computador anexado a ele; o valor CPE, contudo, é 0 porque aquele o serviço é negado.

  • O estado on-line de 0010.7bed.9b45 é em linha (d), assim que significam que o modem a cabo vem em linha mas o acesso à rede de cabo está negado.

    Considere esta saída do comando debug cable mac log verbose emitido no modem a cabo:

    21:52:16:  78736.550 CMAC_LOG_RESET_RANGING_ABORTED              
    21:52:16:  78736.554 CMAC_LOG_STATE_CHANGE                       reset_interface_state
    21:52:16:  78736.558 CMAC_LOG_STATE_CHANGE                       reset_hardware_state
    21:52:17:  78737.024 CMAC_LOG_STATE_CHANGE                       wait_for_link_up_state
    21:52:17:  78737.028 CMAC_LOG_DRIVER_INIT_IDB_RESET              0x082B9CA8
    21:52:17:  78737.032 CMAC_LOG_LINK_DOWN                          
    21:52:17:  78737.034 CMAC_LOG_LINK_UP                            
    21:52:17:  78737.040 CMAC_LOG_STATE_CHANGE                       ds_channel_scanning_state
    21:52:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to down
    21:52:18:  78738.386 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:19:  78739.698 CMAC_LOG_DS_64QAM_LOCK_ACQUIRED             747000000
    21:52:19:  78739.702 CMAC_LOG_DS_CHANNEL_SCAN_COMPLETED          
    21:52:19:  78739.704 CMAC_LOG_STATE_CHANGE                       wait_ucd_state
    21:52:20:  78740.368 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:22:  78742.396 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:22:  78742.398 CMAC_LOG_ALL_UCDS_FOUND                     
    21:52:22:  78742.402 CMAC_LOG_STATE_CHANGE                       wait_map_state
    21:52:22:  78742.406 CMAC_LOG_FOUND_US_CHANNEL                   1
    21:52:24:  78744.412 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:24:  78744.416 CMAC_LOG_UCD_NEW_US_FREQUENCY               39984000
    21:52:24:  78744.420 CMAC_LOG_SLOT_SIZE_CHANGED                  8
    21:52:24:  78744.500 CMAC_LOG_UCD_UPDATED                        
    21:52:24:  78744.560 CMAC_LOG_MAP_MSG_RCVD                       
    21:52:24:  78744.564 CMAC_LOG_INITIAL_RANGING_MINISLOTS          41
    21:52:24:  78744.566 CMAC_LOG_STATE_CHANGE                       ranging_1_state
    21:52:24:  78744.570 CMAC_LOG_RANGING_OFFSET_SET_TO              9610
    21:52:24:  78744.574 CMAC_LOG_POWER_LEVEL_IS                     55.0  dBmV (commanded)
    21:52:24:  78744.578 CMAC_LOG_STARTING_RANGING                   
    21:52:24:  78744.580 CMAC_LOG_RANGING_BACKOFF_SET                0
    21:52:24:  78744.586 CMAC_LOG_RNG_REQ_QUEUED                     0
    21:52:24:  78744.622 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:24:  78744.626 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:24:  78744.628 CMAC_LOG_RNG_RSP_SID_ASSIGNED               10
    21:52:24:  78744.632 CMAC_LOG_ADJUST_RANGING_OFFSET              2286
    21:52:24:  78744.636 CMAC_LOG_RANGING_OFFSET_SET_TO              11896
    21:52:24:  78744.638 CMAC_LOG_STATE_CHANGE                       ranging_2_state
    21:52:24:  78744.644 CMAC_LOG_RNG_REQ_QUEUED                     10
    21:52:25:  78745.654 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:25:  78745.658 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:25:  78745.660 CMAC_LOG_RANGING_SUCCESS                    
    21:52:25:  78745.680 CMAC_LOG_STATE_CHANGE                       dhcp_state
    21:52:25:  78745.820 CMAC_LOG_DHCP_ASSIGNED_IP_ADDRESS           10.1.4.65
    21:52:25:  78745.824 CMAC_LOG_DHCP_TFTP_SERVER_ADDRESS           10.1.4.1
    21:52:25:  78745.826 CMAC_LOG_DHCP_TOD_SERVER_ADDRESS            10.1.4.1
    21:52:25:  78745.830 CMAC_LOG_DHCP_SET_GATEWAY_ADDRESS           
    21:52:25:  78745.834 CMAC_LOG_DHCP_TZ_OFFSET                     -28800
    21:52:25:  78745.836 CMAC_LOG_DHCP_CONFIG_FILE_NAME              disable.cm
    21:52:25:  78745.840 CMAC_LOG_DHCP_ERROR_ACQUIRING_SEC_SVR_ADDR  
    21:52:25:  78745.846 CMAC_LOG_DHCP_COMPLETE                      
    21:52:25:  78745.968 CMAC_LOG_STATE_CHANGE                       establish_tod_state
    21:52:25:  78745.978 CMAC_LOG_TOD_REQUEST_SENT                   
    21:52:26:  78746.010 CMAC_LOG_TOD_REPLY_RECEIVED                 3192525217
    21:52:26:  78746.018 CMAC_LOG_TOD_COMPLETE                       
    21:52:26:  78746.020 CMAC_LOG_STATE_CHANGE                       security_association_state
    21:52:26:  78746.024 CMAC_LOG_SECURITY_BYPASSED                  
    21:52:26:  78746.028 CMAC_LOG_STATE_CHANGE                       configuration_file_state
    21:52:26:  78746.030 CMAC_LOG_LOADING_CONFIG_FILE                disable.cm
    21:52:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to up
    21:52:27:  78747.064 CMAC_LOG_CONFIG_FILE_PROCESS_COMPLETE       
    21:52:27:  78747.066 CMAC_LOG_STATE_CHANGE                       registration_state
    21:52:27:  78747.070 CMAC_LOG_REG_REQ_MSG_QUEUED                 
    21:52:27:  78747.076 CMAC_LOG_REG_REQ_TRANSMITTED                
    21:52:27:  78747.080 CMAC_LOG_REG_RSP_MSG_RCVD                   
    21:52:27:  78747.082 CMAC_LOG_COS_ASSIGNED_SID                   1/10
    21:52:27:  78747.088 CMAC_LOG_RNG_REQ_QUEUED                     10
    21:52:27:  78747.090 CMAC_LOG_NETWORK_ACCESS_DENIED
    21:52:27:  78747.094 CMAC_LOG_REGISTRATION_OK                    
    21:52:27:  78747.096 CMAC_LOG_STATE_CHANGE                       establish_privacy_state
    21:52:27:  78747.100 CMAC_LOG_PRIVACY_NOT_CONFIGURED             
    21:52:27:  78747.102 CMAC_LOG_STATE_CHANGE                       maintenance_state
    21:52:31:  78751.122 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:31:  78751.124 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:37:  78757.164 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:37:  78757.168 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:43:  78763.206 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:43:  78763.210 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:49:  78769.250 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:49:  78769.252 CMAC_LOG_RNG_RSP_MSG_RCVD

    A saída desse comando debug mostra a mensagem: Network Access is DENIED.

Ubr7100# show cable modem detail

Interface   SID  MAC address    Max CPE  Concatenation  Rx SNR
Cable1/0/U0 7    0002.1685.b5db 10       yes            33.52
Cable1/0/U0 8    0002.fdfa.0a63 10       yes            33.24
Cable1/0/U0 9    0010.7bed.9b23 1        no             33.29
Cable1/0/U0 10   0010.7bed.9b45 1        no             33.23
Cable1/0/U0 11   0001.64ff.e47d 10       yes            33.20
Cable1/0/U0 12   0004.2752.ddd5 10       yes            33.44

Observe que o CPE máximo para o Modems a cabo com escopos especiais é 1 e o resto são 10. Se você vê o platinum.cm da configuração de escopo, tem 10 CPE especificado; por outro lado, o espaço disable.cm tem somente 1 CPE especificado. O arquivo de configuração DOCSIS PRE-configurado silver.cm tem igualmente somente 1 CPE especificado.

Ubr7111# show interface cable 1/0 modem 0

SID   Priv bits  Type      State     IP address    method    MAC address
7     00         modem     up        10.1.4.7      dhcp      0002.1685.b5db
8     00         modem     up        10.1.4.10     dhcp      0002.fdfa.0a63
9     00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
9     00         modem     up        10.1.4.66     dhcp      0010.7bed.9b23
10    00         modem     up        10.1.4.65     dhcp      0010.7bed.9b45
11    00         modem     up        10.1.4.6      dhcp      0001.64ff.e47d
12    00         modem     up        10.1.4.9      dhcp      0004.2752.ddd5

Para verificar que o Modems a cabo está obtendo o nível correto do serviço, emita o comando show cable qos profile.

Ubr7111# show cable qos profile

ID  Prio Max       Guarantee Max        Max   TOS  TOS   Create  B     IP prec.
         upstream  upstream  downstream tx    mask value by      priv  rate
         bandwidth bandwidth bandwidth  burst                    enab  enab
1   0    0         0         0          0     0x0  0x0   cmts(r) no    no
2   0    64000     0         1000000    0     0x0  0x0   cmts(r) no    no
3   7    31200     31200     0          0     0x0  0x0   cmts    yes   no
4   7    87200     87200     0          0     0x0  0x0   cmts    yes   no
5   4    64000     0         512000     0     0x0  0x0   cm      no    no
6   0    1000      0         1600000    0     0x0  0x0   cm      no    no
7   0    128000    10000     10000000   1600  0x0  0x0   cm      no    no
8   0    0         0         0          0     0x0  0x0   mgmt    no    no
10  0    0         0         0          0     0x0  0x0   mgmt    no    no
12  0    0         100000000 0          0     0x0  0x0   mgmt    no    no

Observe que o ID de QoS 7 combina a configuração no platinum.cm:

cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp

O mesmo acontece com a configuração DOCSIS de disable.cm:

Ubr7111# show ip dhcp binding

IP address       Hardware address        Lease expiration        Type
10.1.4.6         0100.0164.ffe4.7d       Mar 08 2001 07:58 AM    Automatic
10.1.4.7         0100.0216.85b5.db       Mar 08 2001 07:58 AM    Automatic
10.1.4.9         0100.0427.52dd.d5       Mar 08 2001 07:58 AM    Automatic
10.1.4.10        0100.02fd.fa0a.63       Mar 08 2001 08:36 AM    Automatic
10.1.4.65        0100.107b.ed9b.45       Infinite                Manual
10.1.4.66        0100.107b.ed9b.23       Infinite                Manual

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 29243