Multiprotocol Label Switching (MPLS) : MPLS

Suporte multicast para o exemplo de configuração do MPLS VPNs

15 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Esse documento fornece uma configuração de exemplo e as diretrizes gerais para configurar o suporte de transmissão múltipla para VPNs MPLS (arquitetura de switching de rótulo multiprotocolo). Esta característica foi introduzida no ½ 12.2(13)T do ¿  do andï do Software Release 12.0(23)S do½ do¿Â do Cisco IOSïÂ.

Pré-requisitos

Requisitos

Antes de tentar esta configuração, verifique se estes requisitos são atendidos:

  • Os provedores de serviços devem ter um núcleo Multicast-permitido a fim usar a característica do VPN multicast de Cisco.

Componentes Utilizados

As informações neste documento são baseadas no Cisco IOS Software Release 12.2(13)T.

Nota: Para obter informações atualizadas sobre suporte de plataforma a esse recurso, use o Software Advisor (apenas clientes registrados). O Software Advisor atualiza dinamicamente a lista de plataformas suportadas enquanto o suporte a plataforma novo é adicionado para a característica.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

Para a informações de fundo, refira a documentação dos novos recursos do Cisco IOS Software Release 12.2(13)T para o apoio do Protocolo IP multicast para o MPLS VPNs.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

/image/gif/paws/29220/config_mpls_vpn1.gif

Configurações

O diagrama da rede representa o backbone de um provedor de serviços. Isto consiste no Roteadores R2, R3, e R4. O backbone está configurado para suportar MPLS VPN. R2 e R4 são roteadores de extremidade de provedor (PE), enquanto R3 é um roteador provedor (P). R1 e R5 representam roteadores CE (Edge de cliente) que pertencem à mesma instância amarela VRF (VPN Routing and Forwarding).

A fim proporcionar serviços de transmissão múltipla, o backbone deve ser configurado para executar o roteamento de transmissão múltipla. O protocolo de multicast selecionado para esse objetivo é o PIM (Multicast independente de protocolo) e o R3 está configurado como o RP (Ponto de reunião). O R2 e o R4 são configurados igualmente para executar o roteamento de transmissão múltipla no amarelo VRF. O modo escasso-denso PIM é configurado como o protocolo de roteamento de transmissão múltipla entre os PE e os CE. O R2 foi configurado para ser o RP para o amarelo VRF.

A fim testar a Conectividade do Multicast, a relação s0/0 do R5 é configurada para juntar-se ao grupo de transmissão múltipla 224.2.2.2. São enviados pings do endereço de loopback de R1 para 224.2.2.2. O eco do protocolo ICMP (Protocolo de mensagem de controle da Internet) é um pacote de multicast, enquanto a resposta ICMP é um pacote unicast, pois seu endereço IP de destino é o endereço de loopback R1.

As configurações apresentadas neste documento incluem estes:

r1-(CE)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
!
clock timezone CET 1
ip subnet-zero
no ip domain lookup
!
ip multicast-routing 

!--- Enable multicast routing.

!
!
interface Loopback0
 ip address 100.0.0.1 255.255.255.255
!
interface Serial0/0
 ip address 10.1.0.1 255.255.255.0
 ip pim sparse-dense-mode

!--- PIM sparce-dense mode is used between the PE and CE.
!--- PIM sparce-dense mode is the multicast routing protocol.

 
!
router rip
 version 2
 network 10.0.0.0
 network 100.0.0.0
 no auto-summary
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!         
end

r2-(PE)
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
!
clock timezone CET 1
ip subnet-zero
no ip domain lookup
!
ip vrf yellow
 rd 2:200
 route-target export 2:200
 route-target import 2:200
 mdt default 239.1.1.1

!--- Configure the default Multicast Distribution Tree (MDT) 
!--- for VRF yellow.

 mdt data 239.2.2.0 0.0.0.255 threshold 1

!--- Configure the range global addresses for 
!--- data MDTs and the threshold.

ip multicast-routing 

!--- Enable global multicast routing.

ip multicast-routing vrf yellow 

!--- Enable multicast routing in VRF yellow.

ip cef
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
!
!
interface Loopback0
 ip address 50.0.0.2 255.255.255.255
 ip pim sparse-dense-mode


!--- Multicast needs to be enabled on loopback 
!--- interface. This is used as a source  
!--- for MPBGP sessions between PE routers that participate in MVPN.


!
interface Loopback100
 ip vrf forwarding yellow
 ip address 100.0.0.2 255.255.255.255
 ip pim sparse-dense-mode
!

!--- This router needs to be RP for 
!--- multicast in VRF yellow. Therefore, multicast
!--- needs to be enabled on the interface which is used as RP.


!
interface Serial1/0
 ip vrf forwarding yellow
 ip address 10.1.0.2 255.255.255.0
 ip pim sparse-dense-mode

!--- Multicast is enabled on PE-CE interfaces in VRF.


!         
interface Serial2/0
 ip address 10.2.0.2 255.255.255.0
 ip pim sparse-dense-mode

!--- Service provider core needs to run multicast
!--- to support MVPN services,
!--- so multicast is enabled on PE-P links.


 tag-switching ip        
!         
router ospf 1
 router-id 50.0.0.2
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.0.0.255 area 0
!
router rip
 version 2
 no auto-summary
 !
 address-family ipv4 vrf yellow
 version 2
 redistribute bgp 1
 network 10.0.0.0
 network 100.0.0.0
 default-metric 5
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 redistribute rip
 neighbor 50.0.0.4 remote-as 1
 neighbor 50.0.0.4 update-source Loopback0
 neighbor 50.0.0.4 activate
 neighbor 50.0.0.6 remote-as 1
 neighbor 50.0.0.6 update-source Loopback0
 neighbor 50.0.0.6 activate
 no auto-summary
 !
 address-family ipv4 vrf yellow
 redistribute connected
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 50.0.0.4 activate
 neighbor 50.0.0.4 send-community extended
 neighbor 50.0.0.6 activate
 neighbor 50.0.0.6 send-community extended
 no auto-summary
 exit-address-family
!         
ip classless
no ip http server
ip pim bidir-enable
ip pim vrf yellow send-rp-announce Loopback100 scope 100
ip pim vrf yellow send-rp-discovery Loopback100 scope 100

!--- Configure auto-RP. The R2's loopback 
!--- 100 is the RP in VRF yellow.

!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

R3-(P)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R3 
! 
! 
clock timezone CET 1 
ip subnet-zero 
! 
ip multicast-routing  

!--- Enable global multicast routing.
 
ip cef 
mpls label protocol ldp 
tag-switching tdp router-id Loopback0 
! 
! 
! 
interface Loopback0 
 ip address 50.0.0.3 255.255.255.255 
 ip pim sparse-dense-mode 
! 
! 
interface Serial1/0 
 ip address 10.2.0.3 255.255.255.0 
 ip pim sparse-dense-mode

!--- Enable multicast on links to PE routers 
!--- which have MVPNs configured.

 
 tag-switching ip 
! 
interface Serial2/0 
 ip address 10.3.0.3 255.255.255.0 
 ip pim sparse-dense-mode 
 tag-switching ip 
! 
router ospf 1 
 router-id 50.0.0.3 
 log-adjacency-changes 
 network 10.0.0.0 0.255.255.255 area 0 
 network 50.0.0.0 0.0.0.255 area 0 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
ip pim send-rp-announce Loopback0 scope 100 
ip pim send-rp-discovery Loopback0 scope 100 

!--- R3 is configured to announce itself as 
!--- the RP through auto-RP.
 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login  
! 
end

R4-(PE)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R4 
! 
! 
clock timezone CET 1 
ip subnet-zero 
no ip domain lookup 
! 
ip vrf yellow 
 rd 2:200 
 route-target export 2:200 
 route-target import 2:200 
 mdt default 239.1.1.1 

!--- Configure the default MDT address.
 
 mdt data 238.2.2.0 0.0.0.255 threshold 1 

!--- Configure the data MDT range and threshold.
 
! 
ip multicast-routing  

!--- Enable global multicast routing.
 
ip multicast-routing vrf yellow  

!--- Enable multicast routing in VRF yellow.
 
ip cef 
mpls label protocol ldp 
tag-switching tdp router-id Loopback0 
! 
! 
! 
interface Loopback0 
 ip address 50.0.0.4 255.255.255.255 
 ip pim sparse-dense-mode 
! 
interface Loopback100 
 ip vrf forwarding yellow 
 ip address 100.0.0.4 255.255.255.255 
 ip pim sparse-dense-mode 
! 
interface Serial1/0 
 ip address 10.3.0.4 255.255.255.0 
 ip pim sparse-dense-mode 
 tag-switching ip 
! 
interface Serial2/0 
 ip vrf forwarding yellow 
 ip address 10.4.0.4 255.255.255.0 
 ip pim sparse-dense-mode 

!--- Enable the PIM toward the CE.
 
! 
router ospf 1 
 router-id 50.0.0.4 
 log-adjacency-changes 
 network 10.0.0.0 0.255.255.255 area 0 
 network 50.0.0.0 0.0.0.255 area 0 
! 
router rip 
 version 2 
 no auto-summary 
 ! 
 address-family ipv4 vrf yellow 
 version 2 
 redistribute bgp 1 
 network 10.0.0.0 
 network 100.0.0.0 
 default-metric 5 
 no auto-summary 
 exit-address-family 
! 
router bgp 1 
 no synchronization 
 no bgp default ipv4-unicast 
 bgp log-neighbor-changes 
 redistribute rip 
 neighbor 50.0.0.2 remote-as 1 
 neighbor 50.0.0.2 update-source Loopback0 
 neighbor 50.0.0.2 activate 
 no auto-summary 
 ! 
 address-family ipv4 vrf yellow 
 redistribute connected 
 redistribute rip 
 no auto-summary 
 no synchronization 
 exit-address-family 
 ! 
 address-family vpnv4 
 neighbor 50.0.0.2 activate 
 neighbor 50.0.0.2 send-community extended 
 no auto-summary 
 exit-address-family 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
! 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login 
! 
end

R5-(CE)
version 12.2 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
! 
hostname R5 
! 
! 
clock timezone CET 1 
ip subnet-zero 
no ip domain lookup 
! 
ip multicast-routing  

!--- Enable global multicast routing in the CE.
 
! 
! 
interface Loopback0 
 ip address 100.0.0.5 255.255.255.255 
! 
interface Serial0/0 
 ip address 10.4.0.5 255.255.255.0 
 ip pim sparse-dense-mode 
 ip igmp join-group 224.2.2.2 
! 
router rip 
 version 2 
 network 10.0.0.0 
 network 100.0.0.0 
 no auto-summary 
! 
ip classless 
no ip http server 
ip pim bidir-enable 
! 
! 
! 
! 
! 
line con 0 
 exec-timeout 0 0 
line aux 0 
line vty 0 4 
 login 
!          
end

Dicas de projeto

  • O Multicast para o MPLS VPNs (MVPN) é configurado sobre a configuração de VPN. A rede do MPLS VPN precisa de ser projetada com cuidado, observar primeiramente todas as recomendações para redes do MPLS VPN.

  • O provedor do serviço principal deve ser configurado para serviço de multicast nativo. O núcleo deve ser configurado para o modo PIM escasso (PIM-SM), Multicast de origem específica (PIM-SSM) ou PIM Bidirectional (PIM-BIDIR). O PIM de modo denso (PIM-DM) não é apoiado como o protocolo do núcleo nas configurações MVPN. É possível configurar uma mistura de protocolos suportados no núcleo do fornecedor. Isto pode ser feito quando alguns grupos de transmissão múltipla estão tratados por um modo de PIM e alguns outros grupos estão tratados por outros modo de PIM apoiado.

  • Todos os protocolos de transmissão múltipla são apoiados dentro do Multicast VRF. Isto é, dentro do VRF de multicast é possível usar MSDP e PIM-DM além de PIM-SM, PIM-SSM e PIM-BIDIR

  • O serviço MVPN pode ser adicionado separadamente para cada VRF. Isto é, um roteador de PE pode ter configurados VRFs com capacidade de transmissão múltipla e VRFs somente de envio único.

  • Não todos os locais de um único unicast VRF devem ser configurados para o Multicast. É possível ter alguns locais (e mesmo relações do roteador de PE MVPN) onde o Multicast não é permitido. Você deve assegurar-se de que as rotas estejam calculadas nunca para apontar às interfaces ativada do NON-Multicast. Caso contrário, o encaminhamento multicast será interrompido.

  • Mais de um VRF pode pertencer ao mesmo domínio de transmissão múltipla de MVPN. O endereçamento de IP deve ser original dentro de um domínio do Multicast. O escape das rotas e/ou dos pacotes entre domínios do Multicast ou em uma tabela de roteamento de transmissão múltipla global não é atualmente possível.

  • Uma configuração padrão MDT é imperativa para que o MVPN trabalhe. Configurar os dados MDT é opcional. É altamente recomendado ajustar o ponto inicial para os dados MDT se você escolhe configurar um.

  • O endereço IP do MDT padrão determina a qual domínio de multicast o VRF pertence. Portanto, é possível ter o mesmo endereço MDT padrão para mais de um VRF. Contudo, compartilharão de pacotes de transmissão múltipla entre eles e devem observar outras exigências em domínios do Multicast (tais como o esquema de endereçamento de IP original).

  • Os dados MDT puderam ou não puderam ser configurados com a mesma escala dos endereços IP de Um ou Mais Servidores Cisco ICM NT em roteadores de PE diferentes. Isso depende do modo PIM que é usado no centro de um provedor. Se o núcleo do provedor de serviços está usando o sparse mode PIM, a seguir cada roteador de PE deve usar um intervalo exclusivo dos endereços IP de Um ou Mais Servidores Cisco ICM NT para grupos dos dados MDT. Se o núcleo do provedor de serviços está usando o Source-Specific Multicast, a seguir todos os roteadores de PE puderam ser configurados com a mesma escala dos endereços IP de Um ou Mais Servidores Cisco ICM NT para os dados MDT de cada domínio do Multicast.

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre grupos de IGMP IP — Indica os grupos de transmissão múltipla com receptores que são conectados diretamente ao roteador e que eram instruídos com o Internet Group Management Protocol (IGMP).

  • mostre o BGP do mdt do pim IP — Os indicadores detalharam a propaganda do Border Gateway Protocol (BGP) do distinguidor de rota (RD) para o grupo padrão MDT.

  • o mdt do <vrf-name> do vrf do pim da mostra IP envia — indica as propagandas dos dados MDT que o roteador fez no VRF especificado.

  • o mdt do <vrf-name> do vrf do pim da mostra IP recebe — indica as propagandas dos dados MDT recebidas pelo roteador no VRF especificado.

  • show ip mroute-Exibe o conteúdo da tabela de roteamento de transmissão múltipla no centro do provedor.

  • mostre o <vrf-name> do vrf do mrouter IP — Indica a tabela de roteamento de transmissão múltipla no VRF do cliente.

Termine estas etapas para verificar que sua configuração está trabalhando corretamente.

  1. Certifique-se dos PE se juntem ao grupo de IGMP para o túnel do padrão MDT.

    Se é configurado depois que o comando default-mdt está emitido sob a configuração de VRF, o PE pôde não se junta ao grupo do padrão MDT. Depois de configurado o circuito fechado, remova e recoloque o comando mdt do VRF para solucionar o problema.

    • Para o PE-R2, emita o comando show ip igmp groups.

      IGMP Connected Group Membership
      Group Address  Interface   Uptime     Expires   Last Reporter
      224.0.1.40     Serial2/0   02:21:23   stopped   10.2.0.2
      239.1.1.1      Loopback0   02:36:59   stopped   0.0.0.0
    • Para o PE-R4, emita o comando show ip igmp groups.

      IGMP Connected Group Membership 
      Group Address  Interface    Uptime    Expires   Last Reporter
      224.0.1.40     Loopback0    02:51:48  00:02:39  50.0.0.4
      239.1.1.2      Loopback0    02:51:45  stopped   0.0.0.0
      239.1.1.1      Loopback0    02:51:45  stopped   0.0.0.0
      239.2.2.0      Loopback0    01:40:03  stopped   0.0.0.0 
  2. Verifique o anúncio de BGP recebido para ver se há cada PE.

    Nota: Para este exemplo, verifique o MDTs originário do par PE PE-R2 e PE-R4.

    • Para o PE-R2, emita o comando show ip pim mdt bgp.

      MDT-default group 239.1.1.1 
      rid: 50.0.0.4 next_hop: 50.0.0.4 
       
      WAVL tree nodes
      
      MDT-default: 239.1.1.1  Tunnel0     source-interface: Loopback0
    • Para o PE-R4 emita o comando show ip pim mdt bgp

      MDT-default group 239.1.1.1 
      rid: 50.0.0.2 next_hop: 50.0.0.2 
       
      WAVL tree nodes
      
      MDT-default: 239.1.1.1  Tunnel0     source-interface: Loopback0 
      MDT-data   : 239.2.2.0  Tunnel0     source-interface: Loopback0 
  3. Verifique os dados MDT.

    Nota: Para este exemplo, verifique os dados MDT originado ou juntados pelo PE-R2 e pelo PE-R4.

    • Para o PE-R2, emita o comando show ip pim vrf yellow mdt send.

      MDT-data send list for VRF: yellow 
        (source, group)                     MDT-data group      ref_count 
        (100.0.0.1, 224.2.2.2)              239.2.2.0           1 
    • Para o PE-R2, emita o comando show ip pim vrf yellow mdt receive.

      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group
      Joined MDT-data groups for VRF: yellow 
        group: 239.2.2.0 source: 0.0.0.0 ref_count: 1 
    • Verifique a tabela de roteamento de transmissão múltipla global para ver se há o padrão MDT.

      Nota: Observe esta informação:

      1. A lista de interface enviada é amarelo MVRF nos PE.

      2. O roteador P vê o grupo como um grupo de transmissão múltipla regular.

      3. Cada PE é uma fonte para o padrão MDT, e está somente nos roteadores de PE.

      4. Uma bandeira nova, Z, indica que este é um túnel do Multicast.

    • Para o PE-R2, emita o comando de 239.1.1.1 do mrouter da mostra IP.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:37:16/stopped, RP 50.0.0.3, flags: SJCFZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:21:26/00:00:28 
      
      (50.0.0.2, 239.1.1.1), 02:37:12/00:03:29, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:36:09/00:02:33 
      (
      50.0.0.4, 239.1.1.1), 02:36:02/00:02:59, flags: JTZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:21:26/00:00:28
    • Para o P-R3, emita o comando de 239.1.1.1 do mrouter da mostra IP.

       
      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:50:24/stopped, RP 50.0.0.3, flags: S 
        Incoming interface: Null, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:34:41/00:03:16 
          Serial2/0, Forward/Sparse-Dense, 02:49:24/00:02:37 
      
      (50.0.0.2, 239.1.1.1), 02:49:56/00:03:23, flags: T 
        Incoming interface: Serial1/0, RPF nbr 10.2.0.2 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:49:24/00:02:37 
      
      (50.0.0.4, 239.1.1.1), 02:49:47/00:03:23, flags: T 
        Incoming interface: Serial2/0, RPF nbr 10.3.0.4 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:34:41/00:03:16 
    • Para o PE-R4, emita o comando de 239.1.1.1 do mrouter da mostra IP.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.1.1.1), 02:51:06/stopped, RP 50.0.0.3, flags: SJCFZ 
        Incoming interface: Serial1/0, RPF nbr 10.3.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:51:06/00:00:48 
      
      (50.0.0.2, 239.1.1.1), 02:50:06/00:02:58, flags: JTZ 
        Incoming interface: Serial1/0, RPF nbr 10.3.0.3 
        Outgoing interface list: 
          MVRF yellow, Forward/Sparse-Dense, 02:50:06/00:00:48 
      
      (50.0.0.4, 239.1.1.1), 02:51:00/00:03:10, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial1/0, Forward/Sparse-Dense, 02:35:24/00:03:00 
  4. Verifique a tabela de roteamento de transmissão múltipla global para ver se há dados MDT.

    Nota: Para o PE-R2, observe que a interface enviada é tunnel0.

    • Para o PE-R2, onde a fonte é encontrada (lado VRF), emita o comando de 224.2.2.2 do amarelo do vrf do mrouter da mostra IP.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 224.2.2.2), 2d01h/stopped, RP 100.0.0.2, flags: S 
        Incoming interface: Null, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Tunnel0, Forward/Sparse-Dense, 2d01h/00:02:34 
      
      (100.0.0.1, 224.2.2.2), 00:05:32/00:03:26, flags: Ty 
        Incoming interface: Serial1/0, RPF nbr 10.1.0.1 
        Outgoing interface list: 
          Tunnel0, Forward/Sparse-Dense, 00:05:37/00:02:34
    • Para o PE-R2, onde a fonte é encontrada (rota de transmissão múltipla global), emita o comando de 239.2.2.0 do mrouter da mostra IP.

      IP Multicast Routing Table 
      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
             L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
             T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
             X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
             U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
             Y - Joined MDT-data group, y - Sending to MDT-data group 
      Outgoing interface flags: H - Hardware switched 
       Timers: Uptime/Expires 
       Interface state: Interface, Next-Hop or VCD, State/Mode 
      
      (*, 239.2.2.0), 02:13:27/stopped, RP 50.0.0.3, flags: SJPFZ 
        Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
        Outgoing interface list: Null 
      
      (50.0.0.2, 239.2.2.0), 02:13:27/00:03:22, flags: FTZ 
        Incoming interface: Loopback0, RPF nbr 0.0.0.0 
        Outgoing interface list: 
          Serial2/0, Forward/Sparse-Dense, 02:13:27/00:03:26

    Nota: Somente o roteador PE com o qual a origem multicast que se conectou aparece como origem do tráfego multicast do endereço do grupo MDT de dados.

Troubleshooting

  • Emita o comando show ip pim vrf neighbor certificar-se dos roteadores de PE estabeleçam um relacionamento do vizinho de PIM através da relação do túnel dinâmico. Se fizeram, a seguir o padrão MDT opera-se corretamente.

  • Se o padrão MDT não funciona, emita o comando show ip pim mdt bgp certificar-se dos laços de retorno dos roteadores de PE remotos que participam no MVPN estejam sabidos pelo roteador local. Se não são, verifique que o PIM está permitido nas interfaces de loopback usadas como uma fonte de sessões de BGP MP

  • Certifique-se do núcleo SP esteja configurado corretamente para entregar o Multicast entre roteadores de PE. Para propósitos de teste você pôde configurar o juntar-grupo do igmp IP na interface de loopback de um roteador de PE e fazer o sibilo do Multicast originado do laço de retorno de um outro roteador de PE.


Informações Relacionadas


Document ID: 29220