Banda larga a cabo : Cable Modem Termination Systems (CMTS)

Configurando serviços DHCP, ToD e TFTP em CMTS da Cisco: Configuração completa

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento mostra uma configuração no CMTS (Cable Modem Termination System) da Cisco que funciona como protocolo DHCP, ToD e servidor de TFTP. Ele também explica como construir o arquivo de configuração de DOCSIS utilizando CLI no CMTS. Essa configuração é conhecida como “configuração completa do CMTS da Cisco”.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

O leitor deve ter um conhecimento básico do protocolo DOCSIS e da linha de comando do Cisco IOS em uBR Series Routers.

Componentes Utilizados

O hardware usado neste documento foi do Cisco uBR7200, uBR7100 ou uBR10k CMTS e modems a cabo compatíveis com DOCSIS.

Descrição

Um cable modem DOCSIS compatível requer acesso a três tipos de servidores para ser colocado on-line com êxito.

  • O primeiro é um servidor DHCP, que fornece ao modem a cabo um endereço IP, uma máscara de sub-rede e outros parâmetros relacionados a IP.

  • A segunda é um servidor ToD (servidor de hora do DIA) compatível com o RFC868. Um cable modem precisa saber o horário, a fim de incluir adequadamente os rótulos de tempo exatos nesse registro de eventos.

  • O terço é um server do Trivial File Transfer Protocol (TFTP) de que um modem a cabo pode transferir um arquivo de configuração DOCSIS que contém parâmetros operacionais do específico do modem a cabo.

A maioria dos operadores de cabo usa o CNR (Cisco Network Registrar) como os servidores de DHCP, DNS e TFTP. O servidor ToD não faz parte do CNR. O servidor ToD que é usado depende em cima da plataforma de seu sistema. O ToD deve ser RFC868 complacente. Para sistemas UNIX, ele é incluído no Solaris, e basta assegurar que o arquivo "inetd.conf" residente no diretório "/etc" contenha as seguintes linhas:

# Time service is used for clock synchronization.
#
time��� stream� tcp���� nowait� root��� internal
time��� dgram�� udp���� wait��� root��� internal

Para Windows, a maioria de software comum que é usado é Greywareleavingcisco.com .

A tabela a seguir mostra os Software Release Version de Cisco IOS� em que as potencialidades de servidor diferentes foram adicionadas ao CMTS.

Recursos do servidor Versão do Cisco IOS Software
DHCP 12.0(1)T
ToD 12.0(4)XI�
TFTP 11.0 (para todas as plataformas)

Este documento explicará cada um desses recursos. A configuração no CMTS que contém todas estas capacidades é o que nós chamamos “configuração completa para os cmts”. Com essa configuração, não é necessário usar servidores adicionais para testar suas plantas de cabos de forma a proporcionar acesso à Internet de alta velocidade.

Também é possível também configurar um arquivo de configuração DOCSIS que esteja no CMTS, e não no servidor TFTP. De acordo com as notas de release, é necessário pelo menos o Cisco IOS Software Release12.1(2)EC1 para poder usar este recurso.

Embora esta “configuração completa” seja muito conveniente para o ambiente de laboratório, o exame inicial, disposições pequenas, e pesquisa de defeitos, não é escalável apoiar muito um número grande de Modems a cabo. Assim não se recomenda usar esta configuração em plantas de cabos operacionais com grandes disposições de Modems a cabo.

Os engenheiros da TAC usam essa configuração com freqüência para conseguir eliminar variáveis durante o Troubleshooting de cabo.

O serviço DHCP (Dynamic Host Configuration Protocol) do Cisco IOS em um CMTS

Os Cisco routers que estiverem executando o Cisco IOS Software Release 12.0(1)T ou posterior possuem a capacidade de agir como servidores DHCP. Este serviço DHCP pode ser configurado para fornecer aluguéis de DHCP ao Modems a cabo e ao equipamento da premissa do cliente (CPE) como PC e estações de trabalho.

Há um conjunto mínimo de opções DHCP que os modems a cabo geralmente exigem para entrar no modo online. Estas são:

  • Um endereço IP (O campo yiaddr no cabeçalho do pacote de DHCP)

  • Uma máscara de sub-rede (opção de DHCP 1)

  • Deslocamento de tempo local do GMT em segundos (DHCP Opção 2)

  • Um roteador padrão (opção de DHCP 3)

  • O endereço IP de um servidor ToD (opção de DHCP 4)

  • O servidor de registro (DHCP opção 7)

  • O endereço IP de um servidor TFTP (o campo siaddr no cabeçalho do pacote DHCP)

  • O nome de um arquivo de configuração DOCSIS (o campo “file” no cabeçalho do pacote DHCP)

  • Um tempo de concessão de DHCP em segundos (opção DHCP 51)

No roteador isso pode ser configurado da seguinte maneira:

!
ip dhcp pool cm-platinum
�� network 10.1.4.0 255.255.255.0
�� bootfile platinum.cm
�� next-server 10.1.4.1�
�� default-router 10.1.4.1�
�� option 7 ip 10.1.4.1�
�� option 4 ip 10.1.4.1�
�� option 2 hex ffff.8f80
�� lease 7 0 10
!

A explicação de cada comando é como segue:

  • O comando dhcp pool define o nome do escopo (cm-platinum, que significa serviço platinum para modems a cabo).

  • A rede fornece o endereço IP e o disfarce da subrede (DHCP opção 1).

  • O bootfile fornece o nome de arquivo de inicialização, que no caso é platinum.cm.

  • O comando next-server especifica o endereço IP do servidor TFTP (nesse caso é o endereço IP principal da interface c4/0).

  • O padrão-roteador é o gateway padrão, que é neste caso o c4/0 do endereço IP principal de interface (option3).

  • A opção 7 é a opção DHCP do server do log.

  • A opção 4 é o endereço IP do servidor ToD (endereço IP primário da interface c4/0).

  • A Opção 2 é a opção de compensação de tempo para GMT - 8 h (-8 hr = -28800 sec = ffff.8f80 in hex).

  • O Lease Time é os dias 7 0 horas de minutos 10.

Nota: Para saber mais sobre como converter um valor decimal de tempo de compensação em hexadecimal, leia Tech Tip How to Calculate the Hexadecimal Value for DHCP Option 2 (time offset).

Para dispositivos CPE as seguintes opções são as mínimas a fim poder operar-se com sucesso.

  • Um endereço IP (O campo yiaddr no cabeçalho do pacote de DHCP)

  • Uma máscara de sub-rede (opção de DHCP 1)

  • Um roteador padrão (opção de DHCP 3)

  • O endereço IP de um ou mais Domain Name Servers (DHCP Opção 6)

  • Um nome de domínio (opção DHCP 15)

  • Um tempo de concessão de DHCP em segundos (opção DHCP 51)

!
ip dhcp pool pcs-c4�

! -- the scope for the hosts

    network 172.16.29.0 255.255.255.224

! -- the ip address and mask for the hosts

��� next-server 172.16.29.1

! -- tftp server, in this case we put the secondary add.

��� default-router 172.16.29.1
��� dns-server 172.16.30.2

! -- dns server (which is not configured on the cmts)

��� domain-name cisco.com
��� lease 7 0 10
!

Ao configurar as associações DHCP, é importante incluir o comando cable dhcp-giaddr policy na configuração da interface de cabo. Esse comando tem o efeito de direcionar o servidor DHCP para atribuir arrendamentos a modems a cabo correspondentes ao número de rede primária na interface de cabo e arrendamentos a CPE correspondentes ao número de rede secundária na interface de cabo. Se este comando falta então todos os aluguéis de DHCP virão do pool que corresponde ao número de rede principal na interface de cabo. Além disso, na configuração parcial da interface abaixo veremos o scope cm-platinum associado ao endereço primário definido no cabo de interface 4/0 e o scope pcs-c4 na rede do endereço secundário.

!
interface Cable4/0
�� ip address 172.16.29.1 255.255.255.224 secondary

! -- CPE network

�� ip address 10.1.4.1 255.255.255.0

! -- Cable Modem Network

�� cable dhcp-giaddr policy
!

Observe que não há nenhum comando cable helper-address ou ip helper address sob a interface de cabo. Isso ocorre porque as solicitações DHCP não precisam ser encaminhadas para um servidor externo quando o servidor DHCP IOS interno é utilizado. Se este comando for adicionado sob a interface e houver um servidor de DHCP externo configurado, os modems a cabo serão registrados com a configuração do DHCP externo.

Outras funcionalidades do servidor de DHCP

Estes são os outros recursos que podem ser utilizados com o servidor DHCP do Cisco IOS:

  • ip dhcp ping: Sibilo antes que função do aluguer que se assegura de que o servidor DHCP não emita alugueres para os endereços IP de Um ou Mais Servidores Cisco ICM NT que são já dentro uso.

  • ip dhcp database: Armazenamento de associações de DHCP em um banco de dados externo para manter as relações entre o endereço MAC e o endereço IP após a reinicialização do CMTS.

  • mostre o DHCP IP: Um conjunto de comandos que pode ser utilizado para monitorar a operação do servidor DHCP.

  • debug ip dhcp server: Um conjunto de comandos que podem ser usados para resolver problemas da operação do servidor DHCP.

Todas estas funções e características extra são descritas nos Release Note dos recursos do servidor de DHCP IOS Cisco situados no documento do servidor de DHCP IOS Cisco.

O serviço Time of Day (ToD) do Cisco IOS

Depois que um Cable Modem adquire uma concessão DHCP com êxito, ele continua para tentar entrar em contato com um servidor ToD. Os produtos Cisco CMTS em execução na versão do Cisco IOS Software 12.0(4)XI ou mais recente são capazes de fornecer serviço RFC868 ToD.

Uma concepção errônea comum é a de que o serviço ToD que os cable modems precisam utilizar comparte do processo de entrada on-line equivale ao serviço Network Time Protocol (NTP), que é comumente configurado em Cisco routers. O serviço NTP e o serviço ToD são incompatíveis. Os modems a cabo não se comunicam com um servidor de NTP. Quando o Modems a cabo dever tentar contactar parte de um servidor de hora do DIA como o processo de vinda em linha, o em conformidade com modems com as revisões as mais atrasadas da especificação de RFI do DOCSIS 1.0 ainda continuará vir em linha mesmo se um servidor ToD não pode ser alcançado.

De acordo com as versões mais recentes da especificação, se um modem a cabo não puder contatar um servidor ToD, ele poderá continuar com o processo de ficar on-line. Entretanto, deve continuar tentando, periodicamente, entrar em contato com o servidor ToD até conseguir. Versões mais antigas da especificação DOCSIS 1.0 RFI determinavam que, se um cable modem não conseguisse entrar em contato com um servidor ToD, o modem não poderia entrar on-line. É importante saber que os cable modems que executam firmware mais antigo devem atender a essa versão mais antiga da especificação.

Nota: O Modems a cabo de algum vendedor não interopera com Time of Day do IOS Cisco o serviço. Se esses modems forem compatíveis com as versões mais recentes da especificação DOCSIS 1.0 RFI, eles deverão continuar a ficar on-line independentemente. Esse problema de interoperabilidade está sendo resolvido pela identificação de bug Cisco CSCdt24107.

Nota: Para configurar o ToD em um CMTS da Cisco são necessários somente dois comandos globais:

service udp-small-servers max-servers no-limit
!
cable time-server
!

O serviço Trivial File Transfer Protocol (TFTP) do Cisco IOS

Após um modem a cabo tentar entrar em contato com um servidor ToD, ele prossegue para entrar em contato com um servidor TFTP para baixar um arquivo de configuração DOCSIS. Se um arquivo binário de configuração de DOCSIS puder ser copiado em um dispositivo flash de um Cisco CMTS, o roteador pode agir como servidor de TFTP desse arquivo.

O procedimento para download de um arquivo de configuração do DOCSIS em flash é o seguinte:

Primeiramente, certifique-se que o CMTS pode alcançar o server onde o arquivo de configuração DOCSIS vive:

7246VXR#ping 172.16.30.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.2, timeout is 2 seconds:
!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Em seguida, copie o arquivo (neste caso, silver.cm) para o flash do CTMS.

7246VXR#copy tftp flash
Address or name of remote host []? 172.16.30.2
Source filename []? silver.cm
Destination filename [silver.cm]?�

Accessing tftp://172.16.30.2/silver.cm...
Loading silver.cm from 172.16.30.2 (via Ethernet2/0): !
[OK - 76/4096 bytes]

76 bytes copied in 0.152 secs

Finalmente, é sempre uma boa idéia verificar a memória flash e confirmar se o tamanho do arquivo está correto. Para isso, execute show flash.

7246VXR#show flash
-#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name
1�� .. unknown� 2D6C7818�� 200CC��� 9������ 74 Feb 28 2001 7:39:09 silver.cm
2�� .. unknown� 1CB785DC�� 20258��� 7������ 62 Feb 20 2001 15:44:11 test.cm
3�� .. image��� 4350A04F� 7A0CC8�� 24� 7866864 Feb 27 2001 09:36:40 ubr7200-ik1s-mz.121-4.EC
4�� .. unknown� 36E5D6D3� 7A0D94��� 7������ 76 Feb 28 2001 07:23:12 gold.cm

8516204 bytes available (7867796 bytes used)

Para permitir o serviço TFTP no CMTS lá que nós precisamos somente de incluir o comando seguinte no modo de config global.

tftp-server slot0:silver.cm alias silver.cm

Uma vez inserido o comando, o item a seguir será mostrado depois na configuração:

!
tftp-server slot0:silver.cm alias silver.cm
tftp-server server��
!

Para obter mais informações sobre a configuração do servidor TFTP em um roteador, consulte o documento Additional File Transfer Commands (Comandos adicionais de transferência de arquivos).

O gerador do arquivo de configuração DOCSIS interno

Os produtos Cisco CMTS que executam a versão 12.1(2)EC ou posterior do Cisco IOS (na versão de treinamento EC) podem ser configurados para gerar e armazenar internamente arquivos de configuração DOCSIS. Isso é útil porque elimina o requisito de ter acesso a uma ferramenta externa de geração de arquivo de configuração DOCSIS. Quando um arquivo de configuração DOCSIS é criado utilizando a ferramenta de configuração interna, o arquivo fica automaticamente disponível via TFTP. Além disso, apenas modems a cabo em interfaces a cabo diretamente conectadas conseguem fazer o download desses arquivos de configuração.

O exemplo de configuração a seguir mostra a criação de dois arquivos de configuração DOCSIS.

O primeiro é chamado disable.cm e permite que um modem a cabo fique on-line, mas impede que dispositivos CPEs conectados acessem a rede do provedor de serviços. Nesse caso, vemos o comando "access-denied". Observe que as velocidades de Downstream e de Upstream nesse caso são de 1Kbps, o tamanho de intermitência máximo é de 1600 bytes.

cable config-file disable.cm
�access-denied
�service-class 1 max-upstream 1
�service-class 1 max-downstream 1600
�timestamp
!

O motivo para um operador de cabo ter esse arquivo de configuração DOCSIS "disable.cm" é porque ele quer negar acesso ao CPE atrás dos modems a cabo, mas permitir que o modem a cabo fique online. Essa é a forma mais eficiente de negar o serviço CPEs do que utilizar a opção "exclude" no CNR, o que não permitirá que o modem de cabo esteja on-line e, portanto, o modem de cabo tentará ficar on-line sempre, o que desperdiçará mais largura de banda.

Modems a cabo obtendo esse arquivo de configuração DOCSIS terão essa aparência com o comando show cable modem:

Cable4/0/U0 10�� online(d)� 2287��� 0.50� 6�� 0�� 10.1.4.65������ 0010.7bed.9b45

(|| adicionar o link quando disponível) dá abaixo mais detalhes nesta saída. O status "online" significa que os modems a cabo estão online, mas o acesso é negado.

No segundo exemplo, um nome de arquivo de configuração DOCSIS está sendo criado, chamado "platinum.cm". Nesse caso, o valor máximo de upstream é de 1Mbps, o upstream garantido é de 100Kpbs, o downstream máximo é de 10Mbps e permite a conexão de até 30 dispositivos CPE.

cable config-file platinum.cm
�service-class 1 max-upstream 1000
�service-class 1 guaranteed-upstream 100
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 30
�timestamp
!

Observe que durante a configuração do arquivo de configuração DOCSIS no CMTS não precisamos da instrução "tftp server slot0:platinum.cm alias platinum.cm", pois não há um arquivo ".cm" armazenado na memória, esse arquivo está inserido na configuração. Detalhes adicionais sobre a ferramenta do arquivo de configuração DOCSIS interno podem ser encontrados no documento de comandos do sistema de terminação de Cable Modem.

Exemplo de diagrama

Uma topologia típica de configuração de laboratório é descrita na figura.

/image/gif/paws/28990/all_in_one_config1.gif

Configurações

Esta configuração é suportada em todas as plataformas CMTS da Cisco. Isto inclui uBR7200, uBR7246VXR, uBR7100, e uBR10000.

O Cisco IOS Software Release que apoia tudo em uma configuração, incluindo a configuração do arquivo de configuração DOCSIS, é Cisco IOS Software Release 12.1(2)EC e as liberações subsequentes do trem EC.

As seguintes configurações foram feitas em um uBR7246 VXR usando a versão 12.1(4)EC do software Cisco IOS com um NPE300. Em primeiro lugar, uma configuração básica é apresentada e, em seguida, uma configuração mais avançada será mostrada.

Configuração básica completa

A configuração abaixo resume todos os tópicos que explicamos no documento. Possui dois escopos dhcp, um para os modems a cabo e outro para os hosts subordinados aos modems a cabo.

Um arquivo de configuração DOCSIS foi criado chamou o platinum.cm. Esse arquivo é aplicado ao conjunto de DHCP chamado cm-platinum. O outro arquivo de configuração DOCSIS, denominado disabled.cm, não está aplicado a nenhum item no momento.

Existem dois pools DHCP configurados nesse exemplo, um para cable modems e outro para os PCs atrás dos cable modems.

Nota:  Os comandos de configuração completa estão em negrito.

"Configuração completa" 7246VXR básica
7246VXR#show run

version 12.1
no service pad
service timestamps debug datetime msec localtime

! -- provides nice timestamps on all log messages

service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit

! -- supports a large number of modems / hosts attaching quickly

!
hostname 7246VXR
!
logging buffered 1000000 debugging
enable password cable
!
cable qos profile 8
cable qos profile 10
cable qos profile 10 grant-size 1500
cable qos profile 12 guaranteed-upstream 100000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server

! --� permits cable modems to obtain Time of Day (ToD) from uBR7246VXR

!
cable config-file disable.cm
�access-denied
�service-class 1 max-upstream 1
�service-class 1 max-downstream 1600
�cpe max 1
�timestamp
!
cable config-file platinum.cm
�service-class 1 max-upstream 128
�service-class 1 guaranteed-upstream 10
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 10
�timestamp
!
clock timezone PDT -8
clock summer-time PDT recurring
clock calendar-valid
ip subnet-zero
ip cef

! -- Turn on cef switching / routing, anything but process� switching (no ip route-cache)

ip cef accounting per-prefix�
no ip finger
ip tcp synwait-time 5
no ip domain-lookup

! -- Prevents cmts from looking up domain names / attempting�
! -- to connect to machines when mistyping commands

ip host vxr 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
no ip dhcp relay information check
!
!
!��
ip dhcp pool cm-platinum

! -- name of the dhcp pool. This scope is for the cable modems attached�
! -- to interface cable 4/0

�� network 10.1.4.0 255.255.255.0

! -- pool of addresses for scope modems-c4/0

�� bootfile platinum.cm

! -- DOCSIS config file name associated with this pool

�� next-server 10.1.4.1

! -- IP address of TFTP server which sends bootfile

�� default-router 10.1.4.1

! -- default gateway for cable modems, necessary to get DOCSIS files

�� option 7 ip 10.1.4.1

! -- Log Server DHCP option

�� option 4 ip 10.1.4.1

! -- ToD server IP address

�� option 2 hex ffff.8f80

! -- Time offset for ToD, in seconds, HEX, from GMT, -28,000 = PST = ffff.8f80

�� lease 7 0 10

! -- lease 7 days 0 hours 10 minutes

!�
ip dhcp pool pcs-c4

! -- name of the dhcp pool. This scope is for the CPEs� attached�
! -- the cable modems that are connected to interface cable 4/0

�� network 172.16.29.0 255.255.255.224

! -- pool of addresses for scope pcs-c4 (associated with the secondary address)

�� next-server 172.16.29.1�
�� default-router 172.16.29.1
�� dns-server 172.16.30.2�
�� domain-name cisco.com�
�� lease 7 0 10������
!
!
interface Ethernet2/0
�ip address 172.16.30.4 255.255.255.192
�no ip mroute-cache
�half-duplex
!
interface Cable4/0
�ip address 172.16.29.1 255.255.255.224 secondary

! -- used for the scope pcs-c4 so that PC's get an ip address on this network
ip address 10.1.4.1 255.255.255.0

! -- used for the scope modems-c4/0 so that cable modems get an ip address from this network

�no ip route-cache cef
�no keepalive
�cable downstream rate-limit token-bucket shaping
�cable downstream annex B
�cable downstream modulation 64qam
�cable downstream interleave-depth 32
�cable downstream frequency 555000000
�cable upstream 0 frequency 40000000
�cable upstream 0 power-level 0
�no cable upstream 0 shutdown
�cable upstream 1 shutdown
�cable upstream 2 shutdown
�cable upstream 3 shutdown
�cable upstream 4 shutdown
�cable upstream 5 shutdown
�cable dhcp-giaddr policy

! -- Used to� modify the GIADDR field of DHCPDISCOVER and DHCPREQUEST packets with a
! -- Relay IP address before they are forwarded to the DHCP server

!���������
!���������
router eigrp 202
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
�no eigrp log-neighbor-changes
!���������
router rip
�version 2
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
!���������
ip default-gateway 172.16.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
ip route 172.16.30.0 255.255.255.0 Ethernet2/0
ip http server
ip http authentication local
!���������
snmp-server engineID local 00000009020000E01ED77E40
snmp-server community public RO
snmp-server community private RW
tftp-server server

! -- enable the cmts to act as a tftp server

tftp-server slot0:silver.cm alias silver.cm

! -- get the DOCSIS config file called silver.cm that is pre-downloaded to flash.
! -- this DOCSIS config file is built using DOCSIS CPE Configurator.��

!���������
line con 0
�exec-timeout 0 0
�transport input none
line aux 0
�speed 19200
line vty 0 4
�session-timeout 60�
�login
!
ntp clock-period 17179977
ntp server 172.16.135.51
end

Dicas de verificação para a configuração básica

Primeiramente, é necessário ter certeza de que os comandos são suportados na versão do Cisco IOS Software. Para isto, é possível utilizar o comando show version.

7246VXR#show version
Cisco Internetwork Operating System Software�
IOS (tm) 7200 Software (UBR7200-IK1S-M), Version 12.1(4)EC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Fri 08-Dec-00 17:35 by ninahung
Image text-base: 0x60008950, data-base: 0x612AA000

ROM: System Bootstrap, Version 12.0(19990210:195103) [12.0XE 105], DEVELOPMENT SOFTWARE
BOOTFLASH: 7200 Software (UBR7200-BOOT-M), Version 12.0(7)T,� RELEASE SOFTWARE (fc2)

7246VXR uptime is 9 minutes
System returned to ROM by reload at 09:47:00 PDT Tue Feb 27 2001
System restarted at 09:48:26 PDT Tue Feb 27 2001
System image file is "slot0:ubr7200-ik1s-mz.121-4.EC"

cisco uBR7246VXR (NPE300) processor (revision C) with 253952K/40960K bytes of memory.
Processor board ID SAB03500058
R7000 CPU at 262Mhz, Implementation 39, Rev 1.0, 256KB L2, 2048KB L3 Cache
6 slot VXR midplane, Version 2.0

Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
4 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
5 Cable Modem network interface(s)
125K bytes of non-volatile configuration memory.

16384K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102

Nós precisamos de verificar que o arquivo de configuração DOCSIS está no flash.

7246VXR#show flash
-#- ED --type-- --crc--- -seek-- nlen -length- -----date/time------ name
1�� .. unknown� 2D6C7818�� 200CC��� 9������ 74 Feb 28 2001 7:39:09 silver.cm
2�� .. unknown� 1CB785DC�� 20258��� 7������ 62 Feb 20 2001 15:44:11 test.cm
3�� .. image��� 4350A04F� 7A0CC8�� 24� 7866864 Feb 27 2001 09:36:40 ubr7200-ik1s-mz.121-4.EC
4�� .. unknown� 36E5D6D3� 7A0D94��� 7������ 76 Feb 28 2001 07:23:12 gold.cm

8516204 bytes available (7867796 bytes used)

Observe que o arquivo “silver.cm” esteve construído usando a ferramenta configuradora DOCSISCPE. Para o arquivo platunum.cm criado na configuração do CMTS, não é necessário usar a instrução "tftp server slot0:platinum.cm alias platinum.cm" porque não há arquivo "Cm", ele reside na configuração.

A próxima etapa é verificar que o Modems a cabo é em linha. Podemos conseguir isso com o comando show cable modem.

7246VXR#show cable modem
Interface�� Prim Online���� Timing Rec��� QoS CPE IP address����� MAC address
����������� Sid� State����� Offset Power
Cable4/0/U0 75�� online���� 2290��� 0.00� 5�� 1�� 10.1.4.2������� 0010.7bed.9b23
Cable4/0/U0 76�� online���� 2809��� 0.00� 5�� 0�� 10.1.4.3������� 0002.fdfa.0a63
Cable4/0/U0 77�� online���� 2288��� 0.25� 5�� 1�� 10.1.4.5������� 0010.7bed.9b45
Cable4/0/U0 78�� online���� 2810��� 0.50� 5�� 0�� 10.1.4.4������� 0004.2752.ddd5
Cable4/0/U0 79�� online���� 2813��� 0.25� 5�� 0�� 10.1.4.6������� 0002.1685.b5db
Cable4/0/U0 80�� online���� 2812�� -0.50� 5�� 0�� 10.1.4.7������� 0001.64ff.e47d


Note que todos os modems de cabo estão on-line. Os conectados ao cabo de interface 4/0/U0 estão na rede 10.1.4.0. Podemos observar na configuração que seus endereços IP foram obtidos a partir do conjunto de DHCP chamado "cm-platinum".

Observe também que os modems a cabo com endereços Mac 0010.7bed.9b23 e 0010.7bed.9b45, respectivamente, têm um CPE subordinado. Esses modems a cabo entram no modo on-line com a configuração de Bridging padrão. Esses PCs estão configurados com o DHCP de modo que eles possam obter seu endereço IP da rede.

7246VXR#show interface cable 4/0 modem 0
SID�� Priv bits� Type����� State���� IP address��� method��� MAC address
75��� 00�������� host����� unknown�� 172.16.29.2�� static��� 00c0.4f97.61c5
75��� 00�������� modem���� up������� 10.1.4.2����� dhcp����� 0010.7bed.9b23
76��� 00�������� modem���� up������� 10.1.4.3����� dhcp����� 0002.fdfa.0a63
77��� 00�������� host����� unknown�� 172.16.29.3�� dhcp����� 00a0.243c.eff5
77��� 00�������� modem���� up������� 10.1.4.5����� dhcp����� 0010.7bed.9b45
78��� 00�������� modem���� up������� 10.1.4.4����� dhcp����� 0004.2752.ddd5
79��� 00�������� modem���� up������� 10.1.4.6����� dhcp����� 0002.1685.b5db
80��� 00�������� modem���� up������� 10.1.4.7����� dhcp����� 0001.64ff.e47d

As figuras a seguir mostram que esses PCs obtêm um endereço IP dos conjuntos chamados “pcs-c4”.

all_in_one_config2.gif

Nesse PC, podemos ver também que as configurações de TCP/IP destinam-se a obter o endereço IP automaticamente.

all_in_one_config3.gif

Configuração completa avançada

Esta seção fornece um exemplo de configuração mais sofisticado que envolva a funcionalidade de hierarquia de associações DHCP. Os trabalhos da hierarquia do conjunto de DHCP da maneira são que todo o conjunto de DHCP com um network number que seja um subconjunto do network number de uma outra associação herda todas as características desse outro pool. Isso salva a repetição na configuração do servidor DHCP. Contudo, se a mesma especificação é feita com um parâmetro diferente então o parâmetro overwritten. Esse exemplo mostrará um conjunto geral com um arquivo de inicialização chamado platinum.cm, e um subconjunto desse conjunto terá um arquivo de inicialização chamado disable.cm.

Além do que os conjuntos de DHCP criados no exemplo básico, nós temos requisitos especiais para dois Modems a cabo.

O modem a cabo 0010.7bed.9b45 será negado o acesso. Isto significa que o modem a cabo estará concedido um endereço IP de Um ou Mais Servidores Cisco ICM NT mas não virá em linha. Para isso criaremos o seguinte conjunto:

ip dhcp pool cm-0010.7bed.9b45
�� host 10.1.4.65 255.255.255.0
�� client-identifier 0100.107b.ed9b.45
�� bootfile disable.cm

A maioria de recursos notáveis deste exemplo de configuração são a seção onde os conjuntos de DHCP especiais que correspondem aos endereços do Cable Modem individual MAC são especificados. Isso ocorre dessa forma para que o servidor DHCP possa enviar opções exclusivas de DHCP para esses modems. Para especificar um modem a cabo em particular, o parâmetro “client-identifier” é usado. O “identificador de cliente” deve ser configurado para 01, seguido pelo endereço MAC do dispositivo a que a entrada corresponde. Os 01 corresponde ao tipo de hardware de Ethernet para o DHCP.

Nota: Ao mudar arquivos de configuração para um modem é necessário fazer o seguinte de modo que o modem a cabo obtenha manualmente os parâmetros configurados:

  • Limpe a tabela ip dhcp binding, utilizando o comando clear ip dhcp binding <ip address> ."

  • Restaure o modem a cabo na pergunta usando o comando clear cable modem <mac address > res.

O modem a cabo 0010.7bed.9b23 igualmente tem um requisito especial. Isso resultará em uma qualidade de serviço diferente. Portanto, um arquivo de inicialização diferente é associado ao escopo. Consulte a configuração parcial abaixo:

ip dhcp pool cm-0010.7bed.9b23
�� host 10.1.4.66 255.255.255.0
�� client-identifier 0100.107b.ed9b.23
�� bootfile silver.cm

!

Ao configurar conjuntos de DHCP para modems a cabo específicos, sempre é uma boa prática fornecer um nome relevante. Também, desde que um endereço IP de Um ou Mais Servidores Cisco ICM NT específico é atribuído ao pool usando o comando host, nós precisamos de adicionar o comando global o DHCP IP que exclui 10.1.4.60 10.1.4.70. Esse comando diz ao DHCP para não distribuir endereços que pertençam a esse intervalo.

Configuração completa avançada 7246VXR
7246VXR# show run

version 12.1
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit
!
hostname 7246VXR
!
logging buffered 1000000 debugging
!
cable qos profile 8
cable qos profile 10
cable qos profile 10 grant-size 1500
cable qos profile 12 guaranteed-upstream 100000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file disable.cm
�access-denied
�service-class 1 max-upstream 1
�service-class 1 max-downstream 1600
�cpe max 1
�timestamp
!
cable config-file platinum.cm
�service-class 1 max-upstream 128
�service-class 1 guaranteed-upstream 10
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 10
�timestamp
!
clock timezone PDT -8
clock summer-time PDT recurring
clock calendar-valid
ip subnet-zero
no ip finger
no ip domain-lookup
ip host vxr 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
ip dhcp excluded-address 10.1.4.60 10.1.4.70
!
ip dhcp pool cm-platinum
�� network 10.1.4.0 255.255.255.0
�� bootfile platinum.cm
�� next-server 10.1.4.1�
�� default-router 10.1.4.1�
�� option 7 ip 10.1.4.1�
�� option 4 ip 10.1.4.1�
�� option 2 hex ffff.8f80
�� lease 7 0 10
!
ip dhcp pool pcs-c4
�� network 172.16.29.0 255.255.255.224
�� next-server 172.16.29.1�
�� default-router 172.16.29.1�
�� dns-server 172.16.30.2�
�� domain-name cisco.com
�� lease 7 0 10
!
ip dhcp pool cm-0010.7bed.9b45
�� host 10.1.4.65 255.255.255.0
�� client-identifier 0100.107b.ed9b.45
�� bootfile disable.cm
!
ip dhcp pool cm-0010.7bed.9b23
�� host 10.1.4.66 255.255.255.0
�� client-identifier 0100.107b.ed9b.23
�� bootfile silver.cm
!
!
interface Ethernet2/0
�ip address 172.16.30.4 255.255.255.192
�no ip mroute-cache
�half-duplex
!
interface Cable4/0
�ip address 172.16.29.1 255.255.255.224 secondary
�ip address 10.1.4.1 255.255.255.0
�no keepalive
�cable downstream rate-limit token-bucket shaping
�cable downstream annex B
�cable downstream modulation 64qam
�cable downstream interleave-depth 32
�cable downstream frequency 555000000
�cable upstream 0 frequency 40000000
�cable upstream 0 power-level 0
�no cable upstream 0 shutdown
�cable upstream 1 shutdown
�cable upstream 2 shutdown
�cable upstream 3 shutdown
�cable upstream 4 shutdown
�cable upstream 5 shutdown
�cable dhcp-giaddr policy
!
router eigrp 202
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
�no eigrp log-neighbor-changes
!
router rip
�version 2
�redistribute connected
�redistribute static
�network 10.0.0.0
�network 172.16.0.0
�no auto-summary
!
ip default-gateway 172.16.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.30.1
ip route 172.16.30.0 255.255.255.0 Ethernet2/0
ip http server
ip http authentication local
!
access-list 188 permit tcp any any eq www log
access-list 188 permit ip any any
route-map docsis permit 10
!
snmp-server engineID local 00000009020000E01ED77E40
snmp-server community public RO
snmp-server community private RW
tftp-server slot0:silver.cm alias silver.cm
tftp-server server

line con 0
�exec-timeout 0 0
�transport input none
line aux 0
�speed 19200
line vty 0 4
�session-timeout 60�
�exec-timeout 0 0
�login
!
ntp clock-period 17179973
end

Dicas de verificação para configuração avançada

A verificação desta configuração concentra-se nos serviços que os modems a cabo recebem, especialmente 0010.7bed.9b45 e 0010.7bed.9b23. Devemos ter certeza de que os endereços manualmente configurados e o serviço estão sendo obtidos.

A primeira coisa a testar é que 0010.7bed.9b45 virá em linha mas o serviço estará negado. Para isto nós deixamos-nos olhar o comando show cable modem:

7246VXR#show cable modem
Interface�� Prim Online���� Timing Rec��� QoS CPE IP address����� MAC address
����������� Sid� State����� Offset Power
Cable4/0/U0 7��� online���� 2813��� 0.00� 7�� 0�� 10.1.4.7������� 0002.1685.b5db
Cable4/0/U0 8��� online���� 2809��� 0.25� 7�� 0�� 10.1.4.10������ 0002.fdfa.0a63
Cable4/0/U0 9��� online���� 2288�� -0.25� 5�� 1�� 10.1.4.66������ 0010.7bed.9b23
Cable4/0/U0 10�� online(d)� 2287��� 0.50� 6�� 0�� 10.1.4.65������ 0010.7bed.9b45
Cable4/0/U0 11�� online���� 2809�� -0.50� 7�� 0�� 10.1.4.6������� 0001.64ff.e47d
Cable4/0/U0 12�� online���� 2812�� -0.50� 7�� 0�� 10.1.4.9������� 0004.2752.ddd5

Há vários pontos a serem observados aqui:

  • O modem a cabo 0010.7bed.9b23 obteve o endereço IP 10.4.1.66 como especificado no espaço cm-0010.7bed.9b23. Há um computador anexado a ele e obtém seu endereço IP de Um ou Mais Servidores Cisco ICM NT do pool pcs-c4.

  • O modem a cabo 0010.7bed.9b23 possui uma QoS diferente.

  • O modem a cabo 0010.7bed.9b45 obteve o endereço IP 10.1.4.65, conforme especificado no escopo cm-0010.7bed.9b45. Há um computador anexado a ele, porém o valor CPE é 0. A razão é que o serviço está negado.

  • O estado online do 0010.7bed.9b45 é online(d), o que significa que o modem a cabo pode ir online, mas o acesso à rede de cabos ser negado. Consulte a saída de debug cable mac log verbose do modem a cabo.

21:52:16:� 78736.550 CMAC_LOG_RESET_RANGING_ABORTED��������������
21:52:16:� 78736.554 CMAC_LOG_STATE_CHANGE���������������������� reset_interface_state
21:52:16:� 78736.558 CMAC_LOG_STATE_CHANGE���������������������� reset_hardware_state
21:52:17:� 78737.024 CMAC_LOG_STATE_CHANGE���������������������� wait_for_link_up_state
21:52:17:� 78737.028 CMAC_LOG_DRIVER_INIT_IDB_RESET������������� 0x082B9CA8
21:52:17:� 78737.032 CMAC_LOG_LINK_DOWN��������������������������
21:52:17:� 78737.034 CMAC_LOG_LINK_UP����������������������������
21:52:17:� 78737.040 CMAC_LOG_STATE_CHANGE���������������������� ds_channel_scanning_state
21:52:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to down
21:52:18:� 78738.386 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:19:� 78739.698 CMAC_LOG_DS_64QAM_LOCK_ACQUIRED������������ 747000000
21:52:19:� 78739.702 CMAC_LOG_DS_CHANNEL_SCAN_COMPLETED����������
21:52:19:� 78739.704 CMAC_LOG_STATE_CHANGE���������������������� wait_ucd_state
21:52:20:� 78740.368 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:22:� 78742.396 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:22:� 78742.398 CMAC_LOG_ALL_UCDS_FOUND���������������������
21:52:22:� 78742.402 CMAC_LOG_STATE_CHANGE���������������������� wait_map_state
21:52:22:� 78742.406 CMAC_LOG_FOUND_US_CHANNEL������������������ 1
21:52:24:� 78744.412 CMAC_LOG_UCD_MSG_RCVD���������������������� 1
21:52:24:� 78744.416 CMAC_LOG_UCD_NEW_US_FREQUENCY�������������� 39984000
21:52:24:� 78744.420 CMAC_LOG_SLOT_SIZE_CHANGED����������������� 8
21:52:24:� 78744.500 CMAC_LOG_UCD_UPDATED������������������������
21:52:24:� 78744.560 CMAC_LOG_MAP_MSG_RCVD�����������������������
21:52:24:� 78744.564 CMAC_LOG_INITIAL_RANGING_MINISLOTS��������� 41
21:52:24:� 78744.566 CMAC_LOG_STATE_CHANGE���������������������� ranging_1_state
21:52:24:� 78744.570 CMAC_LOG_RANGING_OFFSET_SET_TO������������� 9610
21:52:24:� 78744.574 CMAC_LOG_POWER_LEVEL_IS�������������������� 55.0� dBmV (commanded)
21:52:24:� 78744.578 CMAC_LOG_STARTING_RANGING�������������������
21:52:24:� 78744.580 CMAC_LOG_RANGING_BACKOFF_SET��������������� 0
21:52:24:� 78744.586 CMAC_LOG_RNG_REQ_QUEUED�������������������� 0
21:52:24:� 78744.622 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:24:� 78744.626 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:24:� 78744.628 CMAC_LOG_RNG_RSP_SID_ASSIGNED�������������� 10
21:52:24:� 78744.632 CMAC_LOG_ADJUST_RANGING_OFFSET������������� 2286
21:52:24:� 78744.636 CMAC_LOG_RANGING_OFFSET_SET_TO������������� 11896
21:52:24:� 78744.638 CMAC_LOG_STATE_CHANGE���������������������� ranging_2_state
21:52:24:� 78744.644 CMAC_LOG_RNG_REQ_QUEUED�������������������� 10
21:52:25:� 78745.654 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:25:� 78745.658 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:25:� 78745.660 CMAC_LOG_RANGING_SUCCESS��������������������
21:52:25:� 78745.680 CMAC_LOG_STATE_CHANGE���������������������� dhcp_state
21:52:25:� 78745.820 CMAC_LOG_DHCP_ASSIGNED_IP_ADDRESS���������� 10.1.4.65
21:52:25:� 78745.824 CMAC_LOG_DHCP_TFTP_SERVER_ADDRESS���������� 10.1.4.1
21:52:25:� 78745.826 CMAC_LOG_DHCP_TOD_SERVER_ADDRESS����������� 10.1.4.1
21:52:25:� 78745.830 CMAC_LOG_DHCP_SET_GATEWAY_ADDRESS�����������
21:52:25:� 78745.834 CMAC_LOG_DHCP_TZ_OFFSET�������������������� -28800
21:52:25:� 78745.836 CMAC_LOG_DHCP_CONFIG_FILE_NAME������������� disable.cm
21:52:25:� 78745.840 CMAC_LOG_DHCP_ERROR_ACQUIRING_SEC_SVR_ADDR��
21:52:25:� 78745.846 CMAC_LOG_DHCP_COMPLETE����������������������
21:52:25:� 78745.968 CMAC_LOG_STATE_CHANGE���������������������� establish_tod_state
21:52:25:� 78745.978 CMAC_LOG_TOD_REQUEST_SENT�������������������
21:52:26:� 78746.010 CMAC_LOG_TOD_REPLY_RECEIVED���������������� 3192525217
21:52:26:� 78746.018 CMAC_LOG_TOD_COMPLETE�����������������������
21:52:26:� 78746.020 CMAC_LOG_STATE_CHANGE���������������������� security_association_state
21:52:26:� 78746.024 CMAC_LOG_SECURITY_BYPASSED������������������
21:52:26:� 78746.028 CMAC_LOG_STATE_CHANGE���������������������� configuration_file_state
21:52:26:� 78746.030 CMAC_LOG_LOADING_CONFIG_FILE��������������� disable.cm
21:52:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to up
21:52:27:� 78747.064 CMAC_LOG_CONFIG_FILE_PROCESS_COMPLETE�������
21:52:27:� 78747.066 CMAC_LOG_STATE_CHANGE���������������������� registration_state
21:52:27:� 78747.070 CMAC_LOG_REG_REQ_MSG_QUEUED�����������������
21:52:27:� 78747.076 CMAC_LOG_REG_REQ_TRANSMITTED����������������
21:52:27:� 78747.080 CMAC_LOG_REG_RSP_MSG_RCVD�������������������
21:52:27:� 78747.082 CMAC_LOG_COS_ASSIGNED_SID������������������ 1/10
21:52:27:� 78747.088 CMAC_LOG_RNG_REQ_QUEUED�������������������� 10
21:52:27:� 78747.090 CMAC_LOG_NETWORK_ACCESS_DENIED��������������
21:52:27:� 78747.094 CMAC_LOG_REGISTRATION_OK��������������������
21:52:27:� 78747.096 CMAC_LOG_STATE_CHANGE���������������������� establish_privacy_state
21:52:27:� 78747.100 CMAC_LOG_PRIVACY_NOT_CONFIGURED�������������
21:52:27:� 78747.102 CMAC_LOG_STATE_CHANGE���������������������� maintenance_state
21:52:31:� 78751.122 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:31:� 78751.124 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:37:� 78757.164 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:37:� 78757.168 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:43:� 78763.206 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:43:� 78763.210 CMAC_LOG_RNG_RSP_MSG_RCVD�������������������
21:52:49:� 78769.250 CMAC_LOG_RNG_REQ_TRANSMITTED����������������
21:52:49:� 78769.252 CMAC_LOG_RNG_RSP_MSG_RCVD

A saída desta debuga mostra que o acesso de rede está negado.

7246VXR#show cable modem detail
Interface�� SID� MAC address��� Max CPE� Concatenation� Rx SNR
Cable4/0/U0 7��� 0002.1685.b5db 10������ yes����������� 33.52
Cable4/0/U0 8��� 0002.fdfa.0a63 10������ yes����������� 33.24
Cable4/0/U0 9��� 0010.7bed.9b23 1������� no������������ 33.29
Cable4/0/U0 10�� 0010.7bed.9b45 1������� no������������ 33.23
Cable4/0/U0 11�� 0001.64ff.e47d 10������ yes����������� 33.20
Cable4/0/U0 12�� 0004.2752.ddd5 10������ yes����������� 33.44

Observe que o CPE máximo para o Modems a cabo com escopos especiais é 1 e o resto são 10. Se você vê o platinum.cm da configuração de escopo, tem 10 CPE especificado, por outro lado, o espaço disable.cm tem somente 1 CPE. O arquivo de configuração DOCSIS predefinida silver.cm também tem apenas um CPE especificado.

7246VXR#show interface cable 4/0 modem 0
SID�� Priv bits� Type����� State���� IP address��� method��� MAC address
7���� 00�������� modem���� up������� 10.1.4.7����� dhcp����� 0002.1685.b5db
8���� 00�������� modem���� up������� 10.1.4.10���� dhcp����� 0002.fdfa.0a63
9���� 00�������� host����� unknown�� 172.16.29.2�� static��� 00c0.4f97.61c5
9���� 00�������� modem���� up������� 10.1.4.66���� dhcp����� 0010.7bed.9b23
10��� 00�������� modem���� up������� 10.1.4.65���� dhcp����� 0010.7bed.9b45
11��� 00�������� modem���� up������� 10.1.4.6����� dhcp����� 0001.64ff.e47d
12��� 00�������� modem���� up������� 10.1.4.9����� dhcp����� 0004.2752.ddd5

Para verificar se os modems a cabo estão obtendo o nível correto de serviço, nós examinamos a saída do comando show cable qos profile.

7246VXR#show cable qos profile
ID� Prio Max������ Guarantee Max������� Max�� TOS� TOS�� Create� B���� IP prec.
�������� upstream� upstream� downstream tx��� mask value by����� priv� rate
�������� bandwidth bandwidth bandwidth� burst������������������� enab� enab
1�� 0��� 0�������� 0�������� 0��������� 0���� 0x0� 0x0�� cmts(r) no��� no������
2�� 0��� 64000���� 0�������� 1000000��� 0���� 0x0� 0x0�� cmts(r) no��� no������
3�� 7��� 31200���� 31200���� 0��������� 0���� 0x0� 0x0�� cmts��� yes�� no������
4�� 7��� 87200���� 87200���� 0��������� 0���� 0x0� 0x0�� cmts��� yes�� no������
5�� 4��� 64000���� 0�������� 512000���� 0���� 0x0� 0x0�� cm����� no��� no������
6�� 0��� 1000����� 0�������� 1600000��� 0���� 0x0� 0x0�� cm����� no��� no������
7�� 0��� 128000��� 10000���� 10000000�� 1600� 0x0� 0x0�� cm����� no��� no������
8�� 0��� 0�������� 0�������� 0��������� 0���� 0x0� 0x0�� mgmt��� no��� no������
10� 0��� 0�������� 0�������� 0��������� 0���� 0x0� 0x0�� mgmt��� no��� no������
12� 0��� 0�������� 100000000 0��������� 0���� 0x0� 0x0�� mgmt��� no��� no

Observe que qos ID 7 corresponde à configuração em platinum.cm:

cable config-file platinum.cm
�service-class 1 max-upstream 128
�service-class 1 guaranteed-upstream 10
�service-class 1 max-downstream 10000
�service-class 1 max-burst 1600
�cpe max 10
�timestamp

O mesmo acontece com a configuração DOCSIS do disable.cm.

7246VXR#show ip dhcp binding
IP address������ Hardware address������� Lease expiration������� Type
10.1.4.6�������� 0100.0164.ffe4.7d������ Mar 08 2001 07:58 AM��� Automatic
10.1.4.7�������� 0100.0216.85b5.db������ Mar 08 2001 07:58 AM��� Automatic
10.1.4.9�������� 0100.0427.52dd.d5������ Mar 08 2001 07:58 AM��� Automatic
10.1.4.10������� 0100.02fd.fa0a.63������ Mar 08 2001 08:36 AM��� Automatic
10.1.4.65������� 0100.107b.ed9b.45������ Infinite��������������� Manual
10.1.4.66������� 0100.107b.ed9b.23������ Infinite��������������� Manual

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 28990