Serviços de rede de aplicativos : Cisco LocalDirector 400 Series

Troubleshooting de Balanceamento de Carga de Conteúdo no LocalDirector 4.1.1

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Cisco anunciou a fim--venda para o Cisco LocalDirector. Para mais informação, refira o fim da vida útil do 400 Series de LocalDirector e as observações e os boletins de produto da Fim--venda.


Índice


Introdução

Este documento fornece uma configuração de exemplo e comandos adicionais pesquisar defeitos a característica do equilíbrio de carga de conteúdo disponível no Cisco LocalDirector 416 (versão 4.1.1).

Nota: Diversas edições com Balanceamento de carga satisfeito foram corrigidas na maioria de versões recentes do código para o LocalDirector. Recomenda-se fortemente que você usa a versão 4.2.4 ou mais recente. Refira a página de download de software (clientes registrados somente) para mais informação.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Essa configuração foi desenvolvida e testada usando estas versões de software e de hardware:

  • LocalDirector 416 (versão 4.1.1), com os clientes que executam o servidor do Windows 2000, o pacote de serviços 4.0 do Windows NT 4.0, e o Windows 98

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Diagrama de Rede

/image/gif/paws/28847/load_balancing.jpg

Configuração

A solicitação de um cliente para páginas /index.htm vai para o servidor 172.18.124.205 ou 172.18.124.207. Obtenha requisitos com /rtp/local-director e vá para o servidor 172.18.124.101. Todas as outras solicitações vão para 172.18.124.206.

LocalDirector 416 (Versão 4.1.1.)
Current configuration:
 syslog output 20.3
 no syslog console
 enable password 000000000000000000000000000000 encrypted
 hostname 38-ld416
 no shutdown ethernet 0
 no shutdown ethernet 1
 no shutdown ethernet 2
 interface ethernet 0 auto
 interface ethernet 1 auto
 interface ethernet 2 auto
 mtu 0 1500
 mtu 1 1500
 mtu 2 1500
 multiring all
 no secure  0
 no secure  1
 no secure  2
 ping-allow 0
 ping-allow 1
 no ping-allow 2
 ip address 172.18.124.209 255.255.255.0
 route 0.0.0.0 0.0.0.0 172.18.124.1 1
 arp timeout 30
 no rip passive
 rip version 1
 failover ip address 0.0.0.0
 no failover
 failover hellotime 30
 password cisco
 snmp-server enable traps
 snmp-server community public
 no snmp-server contact
 no snmp-server location
 no dns-boomerang enable
 content-rule nsteam depth 1024 "/index*.htm*"
 content-rule jahrule depth 1024 "/rtp/local-director/*"
 virtual 172.18.124.219:80:0:tcp:jahrule is
 virtual 172.18.124.219:80:0:tcp is
 virtual 172.18.124.219:80:0:tcp:nsteam is
 service 172.18.124.219:80:0:tcp clb-close
 real 172.18.124.205:80:0:tcp is
 real 172.18.124.101:80:0:tcp is
 real 172.18.124.206:80:0:tcp is
 real 172.18.124.207:80:0:tcp is
 bind 172.18.124.219:80:0:tcp:jahrule 172.18.124.101:80:0:tcp
 bind 172.18.124.219:80:0:tcp 172.18.124.206:80:0:tcp
 bind 172.18.124.219:80:0:tcp:nsteam 172.18.124.205:80:0:tcp
 bind 172.18.124.219:80:0:tcp:nsteam 172.18.124.207:80:0:tcp
end

Exemplo de saída do comando show

show real

Verifique o status do Servidor REAL.

LocalDirector# show real
  Real Machines:  
                                                       No Answer  TCP Reset   DataIn   Machine

                            Connect  State Thresh   Reassigns  Reassigns   Conns  
 172.18.124.205:80:0:tcp       0      IS      8         0          0         0
 172.18.124.101:80:0:tcp       0      IS      8         0          0         0
 172.18.124.206:80:0:tcp       0      IS      8         0          0         0
 172.18.124.207:80:0:tcp       0      IS      8         0          0         0

show server

Verifique a configuração de serviço.

LocalDirector# show service
  Virtual Machine(s)              Service
 172.18.124.219:80:0:tcp         clb-close

show rule

Exiba as regras.

LocalDirector# show rule
  Name            Depth           Content-String
  nsteam          1024            "/index*.htm*"
  jahrule         1024            "/rtp/local-director/*"

Visualize a regra específica.

LocalDirector# show rule jahrule

  Name            Depth           Content-String
  jahrule         1024            "/rtp/local-director/*"

show bind

Verificar associações.

LocalDirector# show bind

 Virtual Machine(s)                      Real Machines/Urls
 172.18.124.219:80:0:tcp:jahrule(IS)
 172.18.124.101:80:0:tcp (IS)
 172.18.124.219:80:0:tcp (IS)
 172.18.124.206:80:0:tcp (IS)
 172.18.124.219:80:0:tcp:nsteam(IS)
 172.18.124.205:80:0:tcp (IS)
 172.18.124.207:80:0:tcp (IS)

Editando regras

  1. Desconecte utilizando o comando no bind.

  2. Desabilite os servidores virtuais que usam regras utilizando o comando no-inservice.

  3. Remova os servidores virtuais usando o comando no virtual.

  4. Edite a regra, digitando o comando no rule.


Informações Relacionadas


Document ID: 28847