Serviços de rede de aplicativos : Software Cisco Application and Content Networking System

Como configurar um mecanismo de cache para armazenamento em cache de proxy reverso usando o WCCP

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback



Índice


Introdução

Este documento descreve como configurar o Cisco Cache Engine para o cache reverse proxy usando o protocolo web cache coordination (WCCP).

Versão de hardware e software

Esta configuração foi desenvolvida e testada utilizando as versões de software e hardware abaixo.

  • Software Cisco Cache versão 2.3 do Cisco Cache Engine 560 e versão de ACNS 4.0 e ACNS running 5.0 em um ambiente de laboratório com configurações esclarecida.

  • Cisco 2600 Router que executa o Software Release 12.1(2) de Cisco IOS®.
As informações apresentadas neste documento foram criadas utilizando-se equipamentos em ambiente de laboratório. Os dispositivos ligados com uma configuração esclarecida (PADRÃO). Caso esteja trabalhando em uma rede ativa, verifique se compreendeu o possível impacto de um comando antes de utilizá-lo.

Diagrama de Rede


Configurações

Motor 560 do esconderijo (liberação de software em cache 2.3 ou liberação de software de ACNS 4.0 ou 5.0)
Current configuration:
!
!
user add admin uid 0 
password 1 "eeSdy9dcy" 
capability admin-access
!
!
!
hostname ce
!
interface ethernet 0
 ip address 10.0.0.2 255.255.255.0
!--- Important: If you configure the Cache Engine
!--- with a private address, it must get translated
!--- to a public address.
 ip broadcast-address 10.0.0.255 exit ! interface ethernet 1 exit ! ip default-gateway 10.0.0.1 ip name-server 171.70.168.183 ip domain-name cisco.com ip route 0.0.0.0 0.0.0.0 10.0.0.1 cron file /local/etc/crontab ! wccp router-list 1 10.0.0.1 wccp reverse-proxy router-list-num 1 wccp version 2 ! authentication login local enable authentication configuration local enable rule no-cache url-regex .*cgi-bin.* rule no-cache url-regex .*aw-cgi.* ! !

Roteador Cisco 2600 [Software Cisco IOS versão 12.1(2)]
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2611-5
!
enable secret 5 $1$9VQ.$BTPbq8xlE2dsKwKPDDmpL/
!
!
ip subnet-zero
ip wccp 99
!
!
interface Ethernet0/0
 description Interface to the Internet 
 ip address 172.17.63.194 255.255.255.192
 no ip redirects
!
interface Serial0/0
 no ip address
 no ip mroute-cache
 shutdown
!
interface Ethernet0/1
 ip address 10.0.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 10.1.0.1 255.255.255.0
 ip wccp 99 redirect out
!
interface Ethernet1/1
 no ip address
 shutdown
 full-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.63.193
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

comandos debug e show

Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

Comandos debug e show do Cache Engine:

  • show wccp cache - Mostre a informação WCCP CE
  • show wccp flows - Mostre fluxos do pacote de WCCP
  • show wccp routers - Mostre a lista do roteador WCCP
  • show wccp services - Show wccp services configurado
  • show wccp slowstart - Mostre a WCCP o começo lento
  • show wccp status - Mostre o status de execução do WCCP
  • show statistics http savings - Estatísticas salvas dos indicadores HTTP
  • debug wccp all - O WCCP gira sobre toda a eliminação de erros
  • debug wccp events - Eventos WCCP
  • debug wccp packets - Informação relacionada ao pacote WCCP
Comandos debug and show do roteador:
  • show ip wccp 99 detail - Este comando indica estatísticas do motor e do roteador WCCP do esconderijo para um grupo de serviço.
  • show ip wccp 99 view - Informação da opinião do grupo de serviço
  • debugar eventos WCCP IP - Eventos WCCP
  • debugar pacotes do wccp IP - Informação relacionada ao pacote WCCP

Verificação

Verifique que pôr em esconderijo do proxy reverso está trabalhando com estes comandos.

Emita este comando verificar o estado do esconderijo/Content Engine WCCP:

 
router#sh ip wccp 99 detail 
WCCP Cache-Engine information: 
       IP Address:            10.0.0.2 
       Protocol Version:      2.0 
       State:                 Usable                              
	   !--- This cache is active.
       Initial Hash Info:     00000000000000000000000000000000 
                              00000000000000000000000000000000 
       Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                              FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
       Hash Allotment:        256 (100.00%) 
       Packets Redirected:    93 
       Connect Time:          00:15:27

Emita este comando verificar o redirecionamento reverso transparente de WCCP no roteador:

 
router#sh ip wccp 99 
Global WCCP information: 
    Router information: 
        Router Identifier:                   172.17.63.194 
        Protocol Version:                    2.0 
    Service Identifier: 99 
        Number of Cache Engines:             1 
        Number of routers:                   1 
        Total Packets Redirected:            93                   
		!--- The router is redirecting.
        Redirect access-list:                -none- 
        Total Packets Denied Redirect:       0 
        Total Packets Unassigned:            0 
        Group access-list:                   -none- 
        Total Messages Denied to Group:      0 
        Total Authentication failures:       0


Emita este comando verificar estatísticas de HTTP no esconderijo/Content Engine:

 
cache#sh statistic http request 
                              Statistics - Requests 
                                                Total             % of Requests 
                            --------------------------------------------------- 
     Total Received Requests:                      23                         - 
              Forced Reloads:                       2                       8.7 
               Client Errors:                       0                       0.0 
               Server Errors:                       0                       0.0 
         URL Blocked (Reset):                       0                       0.0 
                 URL Blocked:                       0                       0.0 
      Sent to Outgoing Proxy:                       0                       0.0 
Failures from Outgoing Proxy:                       0                       0.0 
Excluded from Outgoing Proxy:                       0                       0.0 
             ICP Client Hits:                       0                       0.0 
             ICP Server Hits:                       0                       0.0 
               If-Range Hits:                       0                       0.0 
           HTTP 0.9 Requests:                       0                       0.0 
           HTTP 1.0 Requests:                       0                       0.0 
           HTTP 1.1 Requests:                      23                     100.0 
       HTTP Unknown Requests:                       0                       0.0 
           Non HTTP Requests:                       0                       0.0 
          Non HTTP Responses:                       0                       0.0 
      Chunked HTTP Responses:                       0                       0.0 
        Http Miss Due To DNS:                       0                       0.0 
     Http Deletes Due To DNS:                       0                       0.0 
  Objects cached for min ttl:                       4                      17.4

Emita este comando verificar pôr em esconderijo dos pedidos:

 
cache#sh stat http sav 
                         Statistics - Savings 
                        Requests                          Bytes 
         ----------------------------------------------------------- 
  Total:                      23                          16481 
   Hits:                       6                           2205 
   Miss:                      17                          14276 
Savings:                    25.0 %                         13.4 %

Resumo de comandos

Estes comandos cache engine foram usados nesta configuração.
  • versão do wccp {1 | 2}
  • wccp router-list number ip-address
  • número router-list-num do wccp
Estes comandos router foram usados nesta configuração.
  • wccp IP {cache de web | número do serviço}
  • wccp IP {cache de web | o número do serviço} reorienta para fora
  • versão 2 do wccp IP


Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas



Document ID: 28832