Discar e acessar : """Integrated Services Digital Networks (ISDN), Channel-Associated Signaling (CAS)"""

Usando um adaptador de terminal ADTRAN com Cisco Routers

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Os adaptadores terminal de ISDN ADTRAN (TA) podem ser usados para fornecer a Conectividade do Basic Rate Interface (BRI) ao Roteadores sem as interfaces BRI. O TA (conectado à porta serial) termina o atendimento BRI e transmite os dados ao roteador como um córrego de dados síncronos.

Esboços deste documento como a ADTRAN ISU™ TA trabalhar com roteadores Cisco. Nós recomendamos que você refere a documentação do produto no siteleavingcisco.com ADTRAN antes da continuação.

Pré-requisitos

Requisitos

Verifique que os circuitos de BRI estão funcionando corretamente. Você pode desejar usar o circuito em um roteador com uma porta BRI para testar o circuito antes de distribui-lo nesta configuração. Igualmente verifique e teste o dispositivo de peer para assegurar-se de que funcione corretamente.

Para alguns aplicativos, o ADTRAN ISU deve apoiar o Multilink PPP síncrono (MPPP). Os ISU que apoiam o MP síncrono incluem o ISU expresso (part numbers 1200.081L5, 1200.081L6, e 1202.081 L6), ISU 2x64 (1200.051L1 e 1200.051L2), e a segunda geração ISU 128 (1202.029L2 e 1202.029L3.)

Para usar o MPPP em um roteador Cisco, a revisão do software do ISU deve ser atualizada. Uma lista de revisões mínimas de software é apresentada o subproduto na tabela abaixo:

Unidade Número da peça Revisão do software
ISU 128 1202.029 E.00
ISU 2x64 1200.051 D.00 ou G.00
ISU L6 expresso 1200.081L6 K.28
ISU L6 expresso 1202.081L6 D.43

Nota: Desde que as exigências podem mudar, verifique os requisitos de firmware com utilização de ADTRAN ISU com roteadores Ciscoleavingcisco.com .

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Um roteador com uma interface serial síncrona. A interface serial pode ser incorporado ou em um módulo WIC/Network.

  • Não há nenhuma restrição de software de Cisco IOS� para esta configuração.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Método de discagem

Há três métodos que podem ser usados para iniciar um seletor pelo TA:

  • Discar V.25 ou de V.25bis

  • Discar do dados do terminal prontos (DTR)

  • Discar do teclado numérico

Discagem V.25 ou V.25bis

Usando este método, o roteador envia um número de telefone ao TA. Este método permite que o roteador coloque e receba chamadas ISDN. Para ativar V.25/V,.25bis que disca, você deve configurar o comando dialer in-band na interface do roteador. Por exemplo:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast 5551212&5551213
   ppp authentication chap
   dialer-group 1

Você deve configurar o ISU para discar de V.25bis e MPPP.

Quando o roteador recebe o tráfego interessante, aumenta o DTR e o Request To Send (RTS), que faz com que o TA inicie um seletor no primeiro canal B. Contudo, o roteador não pede o TA para iniciar a segunda conexão do canal B. Neste caso, o ADTRAN deve ser programado para discar o segundo canal B ou para ter o segundo número passado dentro da mesma corda do dialer. A relação de roteador serial é uma interface Point-to-Point e não tem nenhuma ideia do número de canais B configurados no ADTRAN.

Não configurar o comando ppp multilink no roteador, desde que o TA segura realmente a conexão multilink, quando o processo da necessidade do roteador somente o fluxo síncrono do TA.

Nota: Usar mapas do discador múltiplo (porque nós em interfaces BRI) não ajuda para esta edição do multilink.

Discagem DTR

Usando este método, o roteador pode somente colocar atendimentos a um número de telefone particular, ele não pode receber chamadas recebidas. Com este método, os números de telefone do local remoto devem ser armazenados na memória do TA. Quando o TA vê o DTR ir altamente, disca o número que é armazenado no TA. Isto exige o comando dialer dtr sob a interface serial. Por exemplo:

Exemplo:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer dtr
   dialer idle-timeout 300
   ppp authentication chap

O ADTRAN deve ser configurado para o discagem DTR, Multilink PPP, e assim por diante, e tem o número de telefone de destino programado.

Ambos os canais B são discados pelo ADTRAN.

Discagem com teclado numérico

Alguns TA têm teclados numéricos neles a permitir o discagem interativa diretamente do TA. Com este método, o usuário deve entrar o número para discar no teclado Ta cada vez que uma conexão deve ser feita. Este método é usado primeiramente para que os propósitos testando verifiquem a Conectividade. A configuração de roteador exigida é mostrada abaixo:

interface Serial0
   ip address 172.25.254.97 255.255.255.252
   encapsulation ppp
   dialer in-band
   dialer idle-timeout 300
   dialer map ip 172.25.254.98 name Remote broadcast
   ppp authentication chap

Cabeamento

Para conectar a porta serial do roteador ao uso TA um cabo DTE V.35 (com porta serial DB-60 ou smart serial em um lado). O seguinte diagrama mostra um cabo da amostra:

adtran_ta1.gif

Se o TA tem somente uma porta RS-232, a seguir você igualmente precisa um V.35 (DB-25) ao cabo RS-232 além do que o cabo mostrado acima. Alternadamente, você pode usar apenas um cabo DB-60-to-DB-25 RS-232.

Refira seções do catálogo de produto em cabos serial para obter mais informações sobre da expedição de cabogramas.

Exemplo de configuração usando V.25bis

Esta seção mostra o exemplo de configuração usando v.25bis.

/image/gif/paws/28080/adtran_ta2.gif

Configuração de ADTRAN ISU

Esta seção inclui algumas pontas em configurar o ADTRAN ISU. Contudo, consulte por favor o site ADTRANleavingcisco.com antes de configurar o TA, como a funcionalidade, características e os parâmetros de configuração podem ter mudado.

  1. Conecte o ADTRAN TA a um PC. Esta etapa é necessária de modo que você possa alcançar o TA e configurar os vários parâmetros antes do enganchar até o roteador.

    Anexe um “terminal marcado adaptador” do RJ-45-to-DB-9 à porta das comunicações (COM) do PC. Na extremidade RJ-45 do adaptador, conecte um cabo RJ-45 enrolado e liso de cetim (número da peça CAB-500RJ= ), que é fornecido com cada roteador Cisco para conexões de console. Você igualmente precisa um RJ-45 ao “MODEM DB-25 marcado adaptador” (part number CAB-25AS-MMOD) de conectar o cabo enrolado à porta DB-25 etiquetada RS-232 na parte de trás do ADTRAN.

  2. Entre EM! V (ou se conectado à porta RS366/Maintenance, uso! V) para obter o menu principal. Pressione então o Ctrl+C para incorporar o menu de configuração.

    Você deve ver o menu similar a esse abaixo (este pode variar segundo o modelo TA):

     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
                             ISU 128 Configuration Menu
    
     1) Netw. options = Dial Line           17) RTS Options = 1 ms delay
     2) Switch Protocl = National ISDN1     18) CTS Options = Forced CTS
     3) Call type = Data 64Kbps             19) CD Options = Normal
     4) SPID 1 = 51255511110101             20) DTR Options = Idle when Off
     5) SPID 2 = 51255511120101             21) DSR Options = OFF Idle+Test
     6) LDN 1 = 5551111                     22) Transmit Clock = Normal
     7) LDN 2 = 5551112                     23) Protocol = PPP asyn-sync
     8) Dial options = V.25                 24) Method = Multilink
     9) V.25 = V.25 HDLC FLAGS              25) Quick setup
    10) Auto answer = Enabled
    11) Answer tone = No Answer tone
    12) Connect Timout = 30 sec (def)
    13) Call Screening = Answer any
    14) DTE options = Synchronous
    15) Bit Rate = 128000
    16) Connector Type = RS-232
    ____________________________________________________________________________
    
    Select =                                    Enter SELECT    Esc NO CHANGE
    ____________________________________________________________________________
    
     Ctl-V STATUS   Ctl-T TEST   Ctl-C CONFIG   Ctl-D DIAL   Ctl-X EXIT
  3. Use os números de correspondência para incorporar o modo de configuração para os vários atributos.

    Os seguintes atributos (em um mínimo) devem ser configurados:

    • Protocolo do interruptor: O tipo de switch especificado pelo telco.

    • Tipo de chamada: Especifique 64 dados k ou 56K (segundo o tipo de circuito).

    • SPID1, SPID2, LDN1, LDN2: Se aplicável, atribua os SPID e os LDN fornecidos pelo telco.

    • Opções do seletor: V.25.

    • V.25: V.25 HDLC (se usando a série de sincronização) ou V.25 ASSÍNCRONO (se usando a série do async).

    • Opções de DTE: Síncrono (se usando a série de sincronização) ou assíncrono (se usando a série do async).

    • Taxa de bits: 128000 (ou 112000 para os atendimentos 56K).

    • Protocolo: Asyn-sincronização PPP.

    • Método: Multilink.

    Nós recomendamos que você refere a folha de dados/manuais ISU no site ADTRANleavingcisco.com para as opções possíveis para cada parâmetro. O exemplo mostrado acima deve trabalhar para a maioria de situações.

Configuração e teste do roteador

Use o seguinte procedimento para configurar e testar o roteador.

  1. Conecte um cabo DTE V.35 ou RS-232 à porta de roteador serial. Refira a seção que cabografa para obter mais informações sobre dos tipos de cabo que você deve se usar.

  2. Use o controlador x de série da mostra (que indica que o tipo de cabo o roteador está conectado a) para verificar que o cabo no lado do roteador é DTE. Por exemplo:

    Router#show controller serial 1
    HD unit 1, idb = 0xCF6E8, driver structure at 0xD4A30
    buffer size 1524  HD unit 1, RS-232 DTE cable
    cpb = 0xE3, eda = 0x940, cda = 0x800
    ...
    ...

    Você deve igualmente verificar que a configuração de tipo de conector no ADTRAN (opção 16 no exemplo acima) combina a expedição de cabogramas usada.

  3. Configurar o roteador como segue:

    username peer password 0 cisco
    !
    interface Serial1 
    ip address 192.168.180.2 255.255.255.0 
    encapsulation ppp 
    dialer in-band
     
    !--- Enable V.25bis dialing. 
    
    dialer map ip 192.168.180.22 name peer 5551111&5551112
     
    !--- Dialer map for the peer. 
    !--- Note the multiple numbers separated by "&"
     
    dialer-group 1 
    pulse-time 1 
    ppp authentication chap
    !
    ip classless
    ip route 192.168.180.22 255.255.255.255 Serial1
    dialer-list 1 protocol ip permit

    Nota: Para que o TA traga acima ambos os canais, você tem que armazenar o segundo número no ADTRAN, ou use [phonenumber1]&[phonenumber2] na instrução de mapa de discador de Cisco (recomendada). A interface serial é apenas uma interface Point-to-Point, assim que ter mapas do discador múltiplo não afeta conexões multilink.

    O ADTRAN disca o primeiro número, negocia e autentica, e então disca imediatamente o segundo. Observe que o comando ppp multilink não está configurado no roteador, desde que o TA segura o multilink

    Nota: Se você deseja usar a interface serial no modo assíncrono, use o comando physical-layer async sob a configuração de interface serial. Contudo, algum hardware da interface serial não apoia uma comunicação assíncrona. Para conectar um modem a essa interface, consulte Configuração de Discagem Usando um Modem na Porta Auxiliar (AUX). Este documento usa a porta auxiliar (AUX). Contudo, as configurações são muito similares.

  4. Inicie um sibilo ao roteador remoto. O roteador envia as cordas do dialer ao TA, que inicia então o enlace de ISDN. Uma vez que o enlace de ISDN está acima, o Roteadores negocia o PPP e e a autenticação ocorre. Você deve poder passar neste tempo o tráfego.

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

  • debug dialer - Para indicar a informação sobre debugging sobre os pacotes recebidos em uma relação capaz do discador. Quando o Dial-on-Demand Routing (DDR) é permitido na relação, a informação a respeito da causa de todo o atendimento (chamado a causa de discagem) está indicada igualmente. Para obter mais informações, consulte as informações sobre debug dialer na documentação Comandos debug.

  • debug interface serial - Use o comando debug serial interface exec ao Exibir informação em uma falha de conexão serial. Para mais informação, veja a informação do debug interface serial na documentação dos comandos Debug.

  • debug ppp negotiation – Exibe informações no tráfego PPP e alterações enquanto negocia componentes de PPP, incluindo o protocolo de controle de link (LCP), autenticação e protocolo de controle de rede (NCP). Uma negociação de PPP bem-sucedida primeiramente abrirá o estado LCP, a seguir autentica, e negocia finalmente o NCP. Para obter mais informações sobre da leitura debugar saídas de negociação ppp referem por favor a compreensão do documento debugam saídas de negociação ppp.

  • debug ppp authentication – Exibe mensagens de protocolo de autenticação PPP, incluindo intercâmbios de pacote de Protocolo de Autenticação de Desafio (CHAP) e intercâmbios de Protocolo de Autenticação de Senha (PAP). Consulte o seguinte documento para obter mais informações: Pesquisando defeitos a autenticação PPP (RACHADURA ou PAP).

Saída de depurações

Ative o debug dialer e debugar a negociação ppp, a seguir inicie um sibilo ao par. O roteador deve tentar discar. Uma vez que a conexão ISDN é estabelecida a negociação de PPP deve começar. O seguinte resultado do debug mostra uma chamada bem sucedida.

Router#show debug
Dial on demand:  Dial on demand events debugging is on
PPP:  
  PPP authentication debugging is on  
  PPP protocol negotiation debugging is on
Router#ping 192.168.180.22
  Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 192.168.180.22, timeout is 2 seconds:
 Serial1: Dialing cause ip (s=192.168.180.2,d=192.168.180.22)

!--- Dialing cause is ping to 192.168.180.22.

   Serial1: Attempting to dial 5551111&5551112
   
!--- Call is dialed out using Serial1 
   !---(which is connected to the ADTRAN).
   !--- Remember that ADTRAN handles the ISDN L1-L3, so ISDN messages
   !--- will not be visible on the router.

   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet.
   Se1 UNKNOWN(0x00FF): LCP not open, discarding packet
   Se1 LCP: I CONFREQ [Closed] id 49 len 15

!--- PPP Negotiation begins.

   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: Lower layer not up, discarding packet
   %LINK-3-UPDOWN: Interface Serial1, changed state to up.
   Se1 PPP: Treating connection as a callout
   Se1 PPP: Phase is ESTABLISHING, Active Open
   Se1 LCP: O CONFREQ [Closed] id 47 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFACK [REQsent] id 48 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x048333B0 (0x0506048333B0)
   Se1 LCP: I CONFREQ [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: O CONFACK [ACKrcvd] id 50 len 15
   Se1 LCP: AuthProto CHAP (0x0305C22305)
   Se1 LCP: MagicNumber 0x65FF6351 (0x050665FF6351)
   Se1 LCP: State is Open
   Se1 PPP: Phase is AUTHENTICATING, by both
   Se1 CHAP: O CHALLENGE id 11 len 42 from "Router"
   Se1 CH.AP: I CHALLENGE id 11 len 30 from "peer"
   Se1 CHAP: O RESPONSE id 11 len 42 from "Router"
   Se1 CHAP: I SUCCESS id 11 len 4
   Se1 CHAP: I RESPONSE id 11 len 30 from "peer"
   Se1 CHAP: O SUCCESS id 11 len 4 
   
!--- Authentication is successful.

   Se1 PPP: Phase is UP
   Se1 IPCP: O CONFREQ [Closed] id 16 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFREQ [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   Se1 IPCP: O CONFACK [REQsent] id 1 len 10
   Se1 IPCP: Address 192.168.180.22 (0x0306CF12B416)
   %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, 
   changed state to up
   Se1 IPCP: TIMEout: Time 0x476F808 State ACKsent
   Se1 IPCP: O CONFREQ [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: I CONFACK [ACKsent] id 17 len 10
   Se1 IPCP: Address 192.168.180.2 (0x0306CF12B402)
   Se1 IPCP: State is Open
   Se1 IPCP: Install route to 192.168.180.22
   dialer Protocol up for Se1

Nota: Para obter mais informações sobre da leitura debugar saídas de negociação ppp, referem por favor a compreensão do documento debugam saídas de negociação ppp.

Procedimento de Troubleshooting

Esta seção inclui alguns procedimentos de Troubleshooting comuns. Se você encontra edições em qualquer etapa para referir a documentação técnica ADTRAN para mais informação:

  1. Verifique que o indicador na parte dianteira do ADTRAN lê como segue:

    Adtran ISU 128
    [Switch-type] Ready

    Isto assegura-se de que a configuração ISDN, tal como os tipos de switch, os identificadores do perfil de serviços (SPID) e o número de diretório local (LDN) corretamente foi configurado e aceitado pelo telco.

  2. Inicie uma conexão de teste ao par que usa o teclado numérico no ADTRAN. Isto pode ajudar a assegurar-se de que os circuitos de ISDN, e a configuração relacionada ISDN no TA estejam corretos.

  3. Inicie um sibilo ao par. Você deve ver o seguinte no indicador do painel dianteiro do ADTRAN: “CHAMANDO [PHONENUMBER”. Isto indica que pelo menos V.25bis está trabalhando corretamente. Se você não vê a mensagem, tente trocar cabos e mesmo TA. Isto pode ajudar a isolar cabos e as relações V.35 ruins no TA.

  4. Ative o debug dialer. Inicie um sibilo. Verifique que você vê o seguinte no resultado do debug:

    Serial1: Dialing cause ip (s=192.168.180.2, d=192.168.180.22)
    Serial1: Attempting to dial 5551111&5551112

    Se você não vê a mensagem, a seguir a edição é DDR-relacionada. Verifique que a configuração de roteador é como mostrado acima. Certifique-se de que o roteamento e a definição de tráfego interessante estão configurados também.

  5. Activate debuga a interface serial, inicia um sibilo e verifica que o TA levanta o conjunto de dados pronto (DSR).

    Somente quando o roteador detecta um DSR alto, a tentativa do roteador de negociar o PPP. Se o DSR não vai acima, a seguir nós devemos pesquisar defeitos uma camada mais baixa tal como o ISDN, o hardware e a expedição de cabogramas.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 28080