IP : Open Shortest Path First (OSPF)

Roteamento subótimo ao redistribuir entre processos de OSPF

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento demonstra o problema de roteamento abaixo do ideal na redistribuição entre processos de Open Shortest Path First (OSPF) e oferece soluções.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Problema

Ao redistribuir entre diferentes processos de OSPF em vários pontos da rede, é possível colocar um circuito de roteamento em situações de roteamento subobtimal ou até pior, um circuito de roteamento.

Na topologia abaixo temos os processos OSPF 1 e OSPF 2. O roteador 1 (R1) e o roteador 2 (R2) estão redistribuindo de OSPF 1 para OSPF 2.

/image/gif/paws/28025/2ospf-redis-1.jpg

As configurações para o r1 do Roteadores e o R2 são mostradas abaixo.

R1
hostname r1  
!  
ip subnet-zero  
!  
interface Loopback0  
 ip address 10.255.255.1 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.1 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.1 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.1 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.1  
 log-adjacency-changes  
 passive-interface Loopback0  
network 10.0.0.0 0.0.0.255 area 0
 network 10.255.255.1 0.0.0.0 area 0 
!  
router ospf 2  
 router-id 192.168.255.1  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal
 
!--- Redistributing OSPF 1 into OSPF 2.
 
 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.1 0.0.0.0 area 0  
!  
ip classless  
!  
end

R2
hostname r2  
!  
ip subnet-zero  
!  
 
interface Loopback0  
 ip address 10.255.255.2 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.2 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.2 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.2 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.2  
 log-adjacency-changes  
 passive-interface Loopback0  
network 10.0.0.0 0.0.0.255 area 0 
 network 10.255.255.2 0.0.0.0 area 0  
!  
router ospf 2  
 router-id 192.168.255.2  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal

!--- Redistributing OSPF 1 into OSPF 2. 

 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.2 0.0.0.0 area 0  
!  
ip classless  
 
end

Na topologia acima, o E1/0 do R4 está na área 1 e o E0/0 está na área 0. Portanto, o R4 é um Roteador de borda de área (ABR) anunciando a rede 10.0.1.0/24 como a rota interárea (IA) para o R1 e o R2. O r1 e o R2 estão redistribuindo esta informação no OSPF2. Os comandos redistribute configuration são destacados nas configurações acima do r1 e do R2. Consequentemente, o r1 e o R2 estão indo aprender aproximadamente 10.0.1.0/24 como o IA através do OSPF1 e como o tipo-2 externo (E2) através do OSPF2 porque os anúncios de estado de link externos (LSA) são propagados durante todo o domínio OSPF2.

Desde que as rotas IA são preferidas sempre sobre as rotas E1 ou E2, a expectativa é considerar, na tabela de roteamento do r1 e do R2, que 10.0.1.0/24 são uma rota IA com salto seguinte R4. Contudo, ao ver suas tabelas de roteamento, algo diferente é considerado - no r1, 10.0.1.0/24 são uma rota IA com salto seguinte R4 mas no R2, 10.0.1.0/24 são uma rota E2 com r1 do salto seguinte.

Esta é a saída do comando do comando show ip route para o r1.

r1#show ip route 
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of the last resort is not set.
 
 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
O E2    10.255.255.2/32 [110/1] via 192.168.0.2, 00:24:21, Ethernet1/0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O IA    10.0.1.0/24 [110/20] via 10.0.0.4, 00:23:49, Ethernet0/0 
C       10.255.255.1/32 is directly connected, Loopback0 
O IA    10.255.255.4/32 [110/11] via 10.0.0.4, 00:23:49, Ethernet0/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:26:09, Ethernet1/0 
O       192.168.255.2 [110/11] via 192.168.0.2, 00:26:09, Ethernet1/0 
C       192.168.255.1 is directly connected, Loopback1 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:26:09, Ethernet1/0 

Esta é a saída do comando do comando show ip route para o R2.

r2#show ip route 
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of last resort is not set. 

 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
C       10.255.255.2/32 is directly connected, Loopback0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O E2    10.0.1.0/24 [110/20] via 192.168.0.1, 00:25:34, Ethernet1/0 
O E2    10.255.255.1/32 [110/1] via 192.168.0.1, 00:25:34, Ethernet1/0 
O E2    10.255.255.4/32 [110/11] via 192.168.0.1, 00:25:34, Ethernet1/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:26:45, Ethernet1/0 
C       192.168.255.2 is directly connected, Loopback1 
O       192.168.255.1 [110/11] via 192.168.0.1, 00:26:45, Ethernet1/0 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:26:45, Ethernet1/0 

Por que ocorre este problema?

Ao permitir processos de OSPF múltiplos em um roteador, da perspectiva do software, os processos são independentes. O protocolo de OSPF, dentro de um processo de OSPF, prefere sempre a rota interna sobre a rota externa. Contudo, o OSPF não faz nenhuma seleção da rota de OSPF entre processos (por exemplo, as métricas de OSPF e os tipos da rota não são levados em consideração, ao decidir a rota de que o processo deve ser instalado na tabela de roteamento).

Não há nenhum processo de OSPF diferente da interação entre, e o tiebreaker é a distância administrativa. Assim, desde que ambos os processos de OSPF têm uma distância administrativa padrão de 110, o primeiro processo que tenta instalar que a rota o faz na tabela de roteamento. Consequentemente, a distância administrativa para rotas dos processos de OSPF diferentes deve ser configurada, de modo que as rotas de determinados processos de OSPF sejam preferidas sobre rotas de um outro processo pela intenção propositada, e não como uma matéria da possibilidade.

Para obter mais informações sobre da distância administrativa, refira o que é distância administrativa. Para obter mais informações sobre de como um roteador Cisco seleciona que distribua para colocar na tabela de roteamento, refira a seleção de rota nos roteadores Cisco.

Soluções

Solução 1

Desde que nós sabemos que no caso acima, o Roteadores está selecionando a melhor ruta baseada na distância administrativa, a maneira lógica impedir este comportamento é aumentar a distância administrativa das rotas externas no OSPF2. Esta maneira, as rotas aprendidas através do OSPF1 será preferida sempre sobre as rotas externas redistribuídas do OSPF1 no OSPF2. Isto é feito usando o <value> externo OSPF da distância do comando sub-router configuration segundo as indicações das configurações abaixo.

R1
hostname r1  
!  
ip subnet-zero  
!  
interface Loopback0  
 ip address 10.255.255.1 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.1 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.1 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.1 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.1  
 log-adjacency-changes  
 passive-interface Loopback0  
 network 10.0.0.0 0.0.0.255 area 0  
 network 10.255.255.1 0.0.0.0 area 0  
!  
router ospf 2  
 router-id 192.168.255.1  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal  
 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.1 0.0.0.0 area 0  
 distance ospf external 115  

!--- Increases the administrative distance of external 
!--- routes to 115. 

!  
ip classless  
!  
end 

R2
hostname r2  
!  
ip subnet-zero  
!  
interface Loopback0  
 ip address 10.255.255.2 255.255.255.255  
!  
interface Loopback1  
 ip address 192.168.255.2 255.255.255.255  
!  
interface Ethernet0/0  
 ip address 10.0.0.2 255.255.255.0  
!  
interface Ethernet1/0  
 ip address 192.168.0.2 255.255.255.0  
!  
router ospf 1  
 router-id 10.255.255.2  
 log-adjacency-changes  
 passive-interface Loopback0  
 network 10.0.0.0 0.0.0.255 area 0  
 network 10.255.255.2 0.0.0.0 area 0  
!  
router ospf 2  
 router-id 192.168.255.2  
 log-adjacency-changes  
 redistribute ospf 1 subnets match internal  
 passive-interface Loopback1  
 network 192.168.0.0 0.0.0.255 area 0  
 network 192.168.255.2 0.0.0.0 area 0  
 distance ospf external 115  

!--- Increases the administrative distance of 
!--- external routes to 115. 

!  
ip classless  
!  
end 

A tabela de roteamento resultante quando mudar a distância administrativa das rotas externas no OSPF2 for mostrada abaixo.

Esta é a saída do comando do comando show ip route para o r1.

r1#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of the last resort is not set.

 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
O       10.255.255.2/32 [110/11] via 10.0.0.2, 00:00:35, Ethernet0/0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O IA    10.0.1.0/24 [110/20] via 10.0.0.4, 00:00:35, Ethernet0/0 
C       10.255.255.1/32 is directly connected, Loopback0 
O       10.255.255.4/32 [110/11] via 10.0.0.4, 00:00:35, Ethernet0/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:00:35, Ethernet1/0 
O       192.168.255.2 [110/11] via 192.168.0.2, 00:00:35, Ethernet1/0 
C       192.168.255.1 is directly connected, Loopback1 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:00:35, Ethernet1/0 

Esta é a saída do comando do comando show ip route para o R2.

r2#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 
 

!--- The gateway of the last resort is not set. 

 
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks 
C       10.255.255.2/32 is directly connected, Loopback0 
C       10.0.0.0/24 is directly connected, Ethernet0/0 
O       10.255.255.1/32 [110/11] via 10.0.0.1, 00:01:28, Ethernet0/0 
O IA    10.0.1.0/24 [110/20] via 10.0.0.4, 00:01:28, Ethernet0/0 
O       10.255.255.4/32 [110/11] via 10.0.0.4, 00:01:28, Ethernet0/0 
     192.168.255.0/32 is subnetted, 3 subnets 
O       192.168.255.3 [110/11] via 192.168.0.3, 00:01:28, Ethernet1/0 
C       192.168.255.2 is directly connected, Loopback1 
O       192.168.255.1 [110/11] via 192.168.0.1, 00:01:28, Ethernet1/0 
C    192.168.0.0/24 is directly connected, Ethernet1/0 
O    192.168.1.0/24 [110/20] via 192.168.0.3, 00:01:28, Ethernet1/0 

É importante notar que em alguns casos, quando há igualmente uma redistribução do OSPF2 no OSPF1 e há outros protocolos de roteamento que estão sendo redistribuídos em OSPF2 ([RIP] do protocolo de informação de roteamento protocolo de informação de roteamento, estatísticas do Enhanced Interior Gateway Routing Protocol (EIGRP), e assim por diante), este pode conduzir ao roteamento subótimo no OSPF2 para aquelas rotas externas.

Solução 2

Se a razão final executar dois processos de OSPF diferentes é filtrar determinadas rotas, há uns novos recursos no OSPF ABR type 3 LSA filtering chamado Software Release 12.2(4)T do ½ do ¿  de Cisco IOSï que permitam que você faça o filtragem de rota no ABR.

Em vez de configurar um segundo processo de OSPF, os links que são parte de OSPF2, no exemplo acima, poderiam ser configurados como uma outra área dentro do OSPF1. Então, você pode executar o filtragem de rota exigido no r1 e o R2 com estes novos recursos. Para obter mais informações sobre esse recurso, consulte a Filtragem LSA OSPF ABR Tipo 3.


Informações Relacionadas


Document ID: 28025