IP : Border Gateway Protocol (BGP)

Especificando um endereço IP de Um ou Mais Servidores Cisco ICM NT do salto seguinte para rotas estáticas

16 Agosto 2014 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (3 Abril 2008) | Inglês (28 Maio 2014) | Feedback


Índice


Introdução

Este documento introduz conceitos básicos sobre rotas estáticas. Este documento usa um cenário de problemas para demonstrar as circunstâncias nas quais é desejável a especificação da interface, pela qual o endereço IP do próximo salto, ao se configurar uma rota estática, pode ser atingido.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Material de Suporte

A capacidade para configurar uma rota estática foi introduzida na liberação 10.0 do Cisco IOS ® Software. As rotas estáticas estão usadas por vários motivos e são usadas frequentemente quando não há nenhuma rota dinâmica ao destino, ou quando você é executado um protocolo de roteamento dinâmico não é praticável.

À revelia, as rotas estáticas têm uma distância administrativa de uma, que lhes dá a precedência sobre rotas dos protocolos de roteamento dinâmico. Quando você aumenta a distância administrativa a um valor maior do que aquele de um protocolo de roteamento dinâmico, a rota estática pode ser uma rede de segurança caso o roteamento dinâmico falhar. Por exemplo, Interior Gateway Routing Protocol (IGRP) - as rotas derivadas têm uma distância administrativa padrão de 100. A fim configurar uma rota estática que seja cancelada por uma rota IGRP, especifique uma distância administrativa maior de 100 para a rota estática.

Este tipo da rota estática é chamado estática “de flutuação”. Está instalado na tabela de roteamento somente quando a rota preferida desaparece. Por exemplo, rota 172.31.10.0 255.255.255.0 10.10.10.2 101 IP.

Nota: Uma distância administrativa de 255 é considerada inacessível e as rotas estáticas com uma distância administrativa de 255 são incorporadas nunca à tabela de roteamento.

Se você aponta uma rota estática a uma interface de transmissão, a rota está introduzida na tabela de roteamento somente quando a interface de transmissão está acima. Esta configuração não é recomendada porque quando o salto seguinte de uma rota estática aponta a uma relação, o roteador considera cada um dos anfitriões dentro da escala da rota ser conectado diretamente através dessa relação. Por exemplo, ethernet0 de 0.0.0.0 0.0.0.0 da rota IP.

Com este tipo de configuração, um roteador executa o Address Resolution Protocol (ARP) nos Ethernet para cada destino que o roteador encontra através da rota padrão porque o roteador considera todos estes destinos como conectado diretamente ao ethernet0.

Este tipo da rota padrão, especialmente se é usado por muitos pacotes a muitas sub-rede de destino diferentes, pode causar a utilização de processador alta e um cache ARP muito grande (junto com falhas de alocação de memória assistentes).

Especificar um salto seguinte numérico diretamente em uma interface conectada impede o roteador do ARP de execução ou do cada endereço de destino. Contudo, se a relação com o salto seguinte vai para baixo e o salto seguinte numérico é alcançável através de uma rota recursiva, você deve especificar o endereço IP de Um ou Mais Servidores Cisco ICM NT do salto seguinte e a relação através de que o salto seguinte deve ser encontrado. Por exemplo, série 3/3 192.168.20.1 de 0.0.0.0 0.0.0.0 da rota IP.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Problema

Neste diagrama da rede, há duas rotas estáticas ao mesmo destino (172.31.10.0/24). Uma rota é uma estática flutuante, é o “backup” ou caminho redundante à rede de destino no LAN. O problema na encenação é que a Rota estática flutuante nunca obtém instalada na tabela de roteamento quando o link principal é fechado.

O r1 tem uma rota padrão esses pontos ao roteador de provedor de serviço do Internet (ISP) para o acesso ao Internet. O r1 tem dois links ao R2. O T1 é o link principal e o 56K é o link de backup. O r1 tem uma rota estática para 172.31.10.0/24 que aponte ao endereço IP de Um ou Mais Servidores Cisco ICM NT do Serial 0 R2 (10.10.10.2) como o salto seguinte. O r1 igualmente tem uma Rota estática flutuante para 172.131.10.0/24 que aponte ao endereço IP de Um ou Mais Servidores Cisco ICM NT R2 Serial1 (192.168.20.2), a distância administrativa para a Rota estática flutuante é 250. A ideia é para que os pacotes fluam sobre o 56K Line nos ambos sentidos somente se o link principal falha.

/image/gif/paws/27082/ip_static_routes_01.gif

Este exemplo mostra a configuração do r1:

R1
hostname R1

!
ip subnet-zero
no ip domain-lookup
!
controller E1 2/0
!
controller E1 2/1
!
interface Serial3/0
 description ISP Link
 ip address 192.168.10.1 255.255.255.252
 clockrate 64000
!
interface Serial3/1
 no ip address
 shutdown
!
interface Serial3/2
 description Primary Link to R2
 ip address 10.10.10.1 255.255.255.252
!
interface Serial3/3
 description Backup Link to R2
 ip address  192.168.20.1 255.255.255.252
 clockrate 64000
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial3/0

!---This is the default route to ISP router.

ip route 172.31.10.0 255.255.255.0 10.10.10.2

!---This is the preferred route to the LAN.

ip route 172.31.10.0 255.255.255.0 192.168.20.2 250

!---This is the floating route to the LAN.

Este exemplo mostra a tabela de roteamento do r1:

Tabela de roteamento do r1
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial3/2
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2

!--- The preferred static route to the LAN through the T1.

S*   0.0.0.0/0 is directly connected, Serial3/0

!--- The static default route to the Internet.

Este exemplo mostra a configuração R2:

R2
hostname R2
!
enable password ww
!
!
!
!
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
!
!
interface Ethernet0
 description Local LAN
 ip address 172.31.10.2 255.255.255.0
!
interface Serial0
 description Primary Link to R1
 ip address 10.10.10.2 255.255.255.252
 clockrate 56000
!
interface Serial1
 description Backup Link to R1
 ip address 192.168.20.2 255.255.255.252
!
interface TokenRing0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1

!--- This is the primary default route.

ip route 0.0.0.0 0.0.0.0 192.168.20.1 250

!--- The floating default route to be used if the T1 fails.

no ip http server
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login
!
end

O R2 têm a rota padrão instalada com 10.10.10.1 e quando você usa o comando traceroute do R2 ao roteador ISP, os pacotes usam o link T1. O R2 pode enviar sibilos ao host de Internet 192.168.30.1 originado de 172.31.10.2. A rota a 192.168.30.1 é através da rota padrão 0.0.0.0 0.0.0.0.

Tabela de roteamento R2
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.10.10.1 to network 0.0.0.0

     172.31.0.0/24 is subnetted, 1 subnets
C       172.31.10.0 is directly connected, Ethernet0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial1
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.10.10.0/30 is directly connected, Serial0
S*   0.0.0.0/0 [1/0] via 10.10.10.1

!--- This is the primary default route.

R2#traceroute 192.168.10.2

Type escape sequence to abort.
Tracing the route to 192.168.10.2

  1 10.10.10.1 16 msec 20 msec 16 msec
  2 192.168.10.2 32 msec *  32 msec

R2#ping
Protocol [ip]:
Target IP address: 192.168.30.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

Se você fecha a série 3/2 no r1 para testar o Failover, você deve esperar o r1 instalar a Rota estática flutuante ao LAN local 172.31.10.0 e para que o R2 instale a Rota estática flutuante a 0.0.0.0 com 192.168.20.1. Você esperaria o tráfego fluir sobre o link 56K.

R1
R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual up                    up
Serial3/3              192.168.20.1    YES manual up                    up


R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s3/2
R1(config-if)#shut
R1(config-if)#end
2d21h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to down
2d21h: %LINK-5-CHANGED: Interface Serial3/2, changed state to administratively down

R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up&                   up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual administratively down down
Serial3/3              192.168.20.1    YES manual up                    up


R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2

!--- The static route through the T1 remains in the routing table.
!--- This is not what was expected to happen when Serial 3/2 was shut.

S*   0.0.0.0/0 is directly connected, Serial3/0

!--- The static default route to the Internet.

R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.20.1 to network 0.0.0.0

     172.31.0.0/24 is subnetted, 1 subnets
C       172.31.10.0 is directly connected, Ethernet0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial1
S*   0.0.0.0/0 [250/0] via 192.168.20.1

!--- It is no longer possible to ping the Internet host 192.168.20.1 if the ping 
!--- is sourced from the LAN on R2 because R1 tries to send the replies
!--- via the Serial 3/2, which is down.

R2#ping
Protocol [ip]:
Target IP address: 192.168.30.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

A Rota estática flutuante não foi instalada no r1 e a rota estática preliminar está ainda na tabela de roteamento do r1 mesmo que o link da série 3/2 seja fechado. A razão que esta acontece é porque as rotas estáticas são recursivos na natureza. Você mantém sempre a rota estática na tabela de roteamento enquanto você tem uma rota ao salto seguinte. Neste caso, o r1 pensa que pode obter a 10.10.10.2 com 192.168.10.2 porque 192.168.10.2 é o salto seguinte para 0.0.0.0 0.0.0.0.

A rota a um salto seguinte pode ser uma mais específica, uma menos específica, ou uma rota padrão. Neste cenário do problema, você pensaria que desde que o link é abaixo de você não deve ter uma rota a 10.10.10.2, mas se você olha a tabela de roteamento no r1, você vê que há uma rota padrão estática que aponta ao roteador ISP. O r1, acredita consequentemente que pode alcançar o salto seguinte (10.10.10.2) para 172.31.10.0/24 através desta rota padrão, assim que a rota estática a 172.31.10.0/24 com 10.10.10.2 permanece na tabela de roteamento e a Rota estática flutuante nunca obtém instalada.

Há uma maneira melhor de configurar as rotas estáticas que permitiriam que você evitasse este problema. Se você especifica a relação através de que o salto seguinte deve ser encontrado, você instalará a Rota estática flutuante somente se o endereço IP de Um ou Mais Servidores Cisco ICM NT do salto seguinte é alcançável através da interface especificada. Antes que a solução a este problema esteja apresentada, você trará à série 3/2 de relação no apoio do r1 outra vez.

R1
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s 3/2
R1(config-if)#no shut
R1(config-if)#end
R1#
2d22h: %LINK-3-UPDOWN: Interface Serial3/2, changed state to up
2d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to up
2d22h: %SYS-5-CONFIG_I: Configured from console by console


R1#show ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0&             192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual up                    up
Serial3/3              192.168.20.1    YES manual up                    up


R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial3/2
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2
S*   0.0.0.0/0 is directly connected, Serial3/0
R1#

Solução

A solução é remover as rotas estáticas velhas ao LAN (172.31.10.0) e configurar rotas estáticas novas, esta vez que especifica a relação através de que o salto seguinte deve ser alcançado. Isto permite que a Rota estática flutuante no r1 obtenha instalada quando a relação da série 3/2 é fechada.

R1
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#no ip route 172.31.10.0 255.255.255.0 10.10.10.2
R1(config)#no ip route 172.31.10.0 255.255.255.0 192.168.20.2 250
R1(config)#ip route 172.31.10.0 255.255.255.0 Serial3/2 10.10.10.2
R1(config)#ip route 172.31.10.0 255.255.255.0 Serial3/3 192.168.20.2 250
R1(config)#end
R1#
2d22h: %SYS-5-CONFIG_I: Configured from console by console

A rota estática a 172.31.10.0 com 10.10.10.2 está instalada na tabela de roteamento do r1 se 10.10.10.2 é visto com a série 3/2. Se esta circunstância não é estada conforme, a rota estática com 10.10.10.2 está removida da tabela de roteamento e a Rota estática flutuante a 172.31.10.0 com a série 3/3 com salto seguinte 192.168.20.2 é instalada.

A fim testar como isto trabalha e derrube o link T1, feche a série 3/2 e veja se a Rota estática flutuante obtém instalada na tabela de roteamento.

R1
R1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s 3/2
R1(config-if)#shut
R1(config-if)#end
R1#
3d00h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to down
3d00h: %SYS-5-CONFIG_I: Configured from console by console
3d00h: %LINK-5-CHANGED: Interface Serial3/2, changed state to administratively down

R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual administratively down down
Serial3/3              192.168.20.1    YES manual up                    up

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [250/0] via 192.168.20.2, Serial3/3
S*   0.0.0.0/0 is directly connected, Serial3/0
R1#

Agora o r1 pode sibilar o host de Internet 192.168.20.1 com os pacotes com origem do LAN.

R2
R2#ping
Protocol [ip]:
Target IP address: 192.168.20.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

A Rota estática flutuante obtém instalada como esperado.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 27082