Long Reach Ethernet (LRE) e Digital Subscriber Line (xDSL) : Symmetrical High-Data-Rate DSL (G.SHDSL)

Configurando o CPE back-to-back por meio das portas G.SHDSL

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para dois roteadores back-to-back através de portas Multirate Symmetric High-Speed Digital Subscriber Line (G.SHDSL). Descreve como um roteador G.SHDSL Cisco� pode ser configurado para trabalhar o dispositivo DSL da sede (cia.) do as�a que termina uma conexão de um outro dispositivo CPE remoto G.SHDSL.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • 828 Software Release 12.2(8)T1 sendo executado de Cisco IOS� do Customer Premises Equipment (CPE)

  • Cisco IOS Software Release 12.2(8)T running do 2612 Router

  • 2612 Router que usa um WAN Interface Card (WIC)-1SHDSL

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/25900/dsl_cpe_config1.gif

Configurações

Este documento utiliza as seguintes configurações:

Nota: Nesta configuração o 828A é configurado com o tipo de equipamento “CO,” que simula a sinalização do CO. Quando os 2612 com o G.SHDSL WIC forem configurados com o tipo de equipamento “CPE.”

DSL5-828A(Cisco 828 CPE que atua como um CO)
DSL5-828A#show run
Building configuration...

Current configuration : 769 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DSL5-828A
!
!
ip subnet-zero
!
!
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CO
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Dialer0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!         
dialer-list 1 protocol ip permit
!
line con 0
 stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end

DSL4-2612A (Cisco 2612 Router que atua como o CPE)
dsl4-2612a#show run
Building configuration...

Current configuration : 927 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname dsl4-2612a
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface ATM0/0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Ethernet0/0
 ip address 172.16.1.2 255.255.255.0
 shutdown
 half-duplex
!         
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface Dialer0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!
dialer-list 1 protocol ip permit
!
call rsvp-sync
!
!
mgcp profile default
!         
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Referência de comando

Esta seção documenta comandos alterados. Todos comandos restantes usados com esta característica são documentados nas publicações da referência de comando do Cisco IOS Software Release 12.2.

Comandos alterados

  • tipo de equipamento dsl

  • dsl linerate

  • modo operacional dsl (g.shdsl)

tipo de equipamento dsl

Emita o comando dsl equipment-type no modo da interface ATM configurar a interface ATM DSL para funcionar como o equipamento CO ou o CPE. Não use nenhum formulário deste comando restaurar o tipo de equipamento do padrão.

  • tipo de equipamento dsl {co | cpe}

  • nenhum tipo de equipamento dsl

As descrições da sintaxe para estes comandos são:

  • co — Configura a interface ATM DSL para funcionar como o equipamento CO.

  • cpe — Configura a interface ATM DSL para funcionar como o CPE.

Defaults

As funções da interface ATM DSL como o CPE.

Modo de comando interface

A interface ATM para o G.SHDSL WIC foi integrada nestes Cisco IOS Software Release:

  • 12.2(4)XL — nos Cisco 2600 Series Router

  • 12.2(8)T — no Cisco 2600 Series e nos Cisco 3600 Series Router

Diretrizes de uso

Este comando configuration aplica-se a uma interface ATM específica. Você deve especificar a interface ATM antes que você emita este comando. A interface ATM deve igualmente estar no estado de fechamento antes que você emita este comando. Este exemplo mostra como configurar a interface ATM 1/1 DSL para funcionar como o equipamento CO.

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 1/1 
Router(config-if)#dsl equipment-type co 

Router(config-if)#end 
Router# clear interface atm 0/1 

Router#

Comandos relacionados

  • taxa de linha dsl — Especifica uma linha taxa para a interface ATM DSL.

  • modo operacional dsl (g.shdsl) — Especifica um modo operacional da interface ATM DSL.

dsl linerate

Emita o comando dsl linerate no modo da interface ATM especificar uma linha taxa para a interface ATM DSL. Não use nenhum formulário deste comando restaurar a taxa da linha padrão.

  • taxa de linha dsl {kbps | automóvel}

  • nenhuma taxa de linha dsl

As descrições da sintaxe para estes comandos são:

  • kbps — Especifica uma linha taxa nos kilobits por segundo para a interface ATM DSL. As entradas permitida são 72, 136, 200, 264, 392, 520, 776, 1032, 1160, 1544, 2056, e 2312.

  • auto — Configura a interface ATM DSL para treinar automaticamente para uma linha ótima taxa negociando com o multiplicador de acesso de DSL da ponta oposta (DSLAM) ou o WIC.

Defaults

A interface ATM DSL sincroniza automaticamente sua linha taxa com a ponta oposta DSLAM ou WIC.

Modo de comando interface

A interface ATM para o G.SHDSL WIC foi integrada nestes Cisco IOS Software Release:

  • 12.2(4)XL — nos Cisco 2600 Series Router

  • 12.2(8)T — no Cisco 2600 Series e nos Cisco 3600 Series Router

Diretrizes de uso

Este comando configuration aplica-se a uma interface ATM específica. Você deve especificar a interface ATM antes que você emita este comando. A interface ATM deve igualmente estar no estado de fechamento antes que você emita este comando. Este exemplo mostra como configurar a interface ATM 0/1 DSL para operar-se a uma taxa de linha de 1040 kbps:

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/1 
Router(config-if)#dsl linerate 1040 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router# 

Comandos relacionados

  • tipo de equipamento dsl — Configura a interface ATM DSL para funcionar como o equipamento CO ou o CPE.

  • modo operacional dsl (g.shdsl) — Especifica um modo operacional da interface ATM DSL. Use o noform deste comando restaurar o modo operacional do padrão.

modo operacional dsl (g.shdsl)

Emita o comando da interface ATM do modo operacional dsl especificar um modo operacional do DSL para uma interface ATM. Não use nenhum formulário deste comando restaurar o modo operacional do padrão.

  • anexo simétrico do gshdsl do modo operacional dsl {A | B}

  • nenhum modo operacional dsl

As descrições da sintaxe para estes comandos são:

  • gshdsl — Configura a interface ATM DSL para operar-se no modo de alta velocidade do multirate por ITU G.991.2.

  • simétrico — Configura a interface ATM DSL para operar-se no modo simétrico por ITU G.991.2.

  • anexo {A | B} — especifica os parâmetros operacionais regionais. Incorpore A para America do Norte e B para Europa. O padrão é A.

Defaults

O modo operacional do padrão é anexo A simétrico G.SHDSL.

Modo de comando interface

A interface ATM para o G.SHDSL WIC foi introduzida no Cisco IOS Software Release 12.1(3)X, e integrada nestes Cisco IOS Software Release.

  • 12.2(2)T — nos Cisco 1700 Series Router

  • 12.2(4)XL — nos Cisco 2600 Series Router

  • 12.2(8)T — no Cisco 2600 Series e nos Cisco 3600 Series Router

Diretrizes de uso

Este comando configuration aplica-se a uma interface ATM específica. Você deve especificar a interface ATM antes que você emita este comando. A interface ATM deve igualmente estar no estado de fechamento antes que você incorpore este comando. Este exemplo mostra como configurar a interface ATM 0/0 DSL para operar-se no modo G.SHDSL.

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/0 
Router(config-if)#dsl operating-mode gshdsl symmetric annex A 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router#

Comandos relacionados

  • tipo de equipamento dsl — Configura a interface ATM DSL para funcionar como o equipamento CO ou o CPE.

  • taxa de linha dsl — Especifica uma linha taxa para a interface ATM DSL.

Verificar

Você deve ver esta saída ir através da sessão de console. Emita o comando term mon, se você é em telnet no Roteadores, ver os mensagens do console.

00:51:25: %GSI-6-RESET: Interface ATM0/0, bringing up the line. 
It may take several seconds for the line to be active. 
00:52:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
00:52:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
00:52:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
00:52:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
00:52:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up 

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • executar-configuração da mostra — Verifica a configuração atual, e vê o estado para todos os controladores.

  • mostre a controladores o slot /porta ATM — Estatísticas do controlador das vistas ATM.

  • mostre atm vc — Verifica o estado dos Circuitos Virtuais Permanentes (PVC).

  • mostre a relação atm dsl — Vê o estado do modem G.SHDSL

  • mostre a relação atm — Vê o estado da interface ATM.

Esta é saídas de exemplo do comando show atm vc. Certifique-se de que os PVC ativos estão acima.

dsl4-2612a#show atm vc 
           VCD /                                        Peak  Avg/Min Burst 
Interface  Name         VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells  Sts 
0/0        1              0    35  PVC    SNAP     UBR    2304                UP 
0/0        2              8    35  PVC    MUX      UBR    2304                UP

Esta é saídas de exemplo do comando show dsl interface atm. Se a linha está para baixo, a linha não é ativa. Alguns dos valores não podem ser exatos. a indicação aparece. Você pode igualmente verificar se a configuração do tipo de equipamento e do modo operacional está correta para seu aplicativo.

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Data (0x1) 
 Received SNR:           39 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5 

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

Line is not active. Some of the values printed may not be accurate. 
 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Idle (0x0) 
 Received SNR:           38 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5

Se você é incapaz de sibilar através do circuito ATM, verifique que a interface ATM é UP/UP emitindo o comando show interface para a interface ATM em ambo o Roteadores. Emita o comando show interface atm ver o estado da interface ATM. Certifique-se de que o entalhe ATM, a porta, e o protocolo de linha estão acima, porque este exemplo mostra.

DSL5-828A#show interfaces atm0 
ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Globespan G.SHDSL module) 
  MTU 1500 bytes, sub MTU 1500, BW 2312 Kbit, DLY 80 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation ATM, loopback not set 
  Encapsulation(s): AAL5, PVC mode 
  10 maximum active VCs, 2 current VCCs 
  VC idle disconnect time: 300 seconds 
  Last input never, output 00:00:08, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: None 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     261 packets input, 11170 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     264 packets output, 11388 bytes, 0 underruns 
     0 output errors, 0 collisions, 2 interface resets 
     0 output buffer failures, 0 output buffers swapped out

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • debugar eventos atm — Identifica eventos relacionados ATM enquanto são gerados.

  • debugar erros atm — Indica que relações têm o problema.

Esta é amostra debuga a informação de uma interface ATM, ser executado debuga listado nesta seção, e na vinda em linha (mantenha na mente que pôde tomar a 30 segundos ou a mais para que o circuito venha acima).

01:07:15: ATM0/0 dslsar_1a_reset: PLIM type is 19, Rate is 2304Mbps 
01:07:15: ATM0/0 dslsar_1a_shutdown: state=4 
01:07:15: dslsar disable ATM0/0 

01:07:15: %GSI-6-RESET: Interface ATM0/0, bringing up the line.
It may take several seconds for the line to be active. 
01:07:15: Resetting ATM0/0 
01:07:15:  dslsar_1a_config(ATM0/0) 
01:07:15:  dslsar_1a_enable(ATM0/0) 
01:07:15: ATM0/0: dslsar_init(825AD084,FALSE) 
01:07:15: dslsar disable ATM0/0 

01:07:16: ATM0/0 dslsar_init: DSLSAR TXRX disabled 

01:07:16: ATM0/0 dslsar_1a_enable: restarting VCs: 0 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 1, vc = 0x82A17BE0adb->flags = 0x4800C 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 2, vc = 0x82A1863Cadb->flags = 0x4800C 
dsl4-2612a# 
dsl4-2612a# 
01:07:16: %SYS-5-CONFIG_I: Configured from console by console 
01:07:19: dslsar disable ATM0/0 

01:08:03: ATM0/0 dslsar_MatchSARTxToLineSpeed(): usbw 2304, clkPerCell 6360 prev_clkPerCell 9702 
01:08:03: ATM0/0 dslsar_update_us_bandwidth(): upstream bw =2304 Kbps 
01:08:09:  dslsar_periodic: ENABLING DSLSAR 

01:08:09: dslsar enable ATM0/0 

01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:1 vpi:0 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 1, vpi 0, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 2304, tbds_per_tsi = 15, max_pkt_len = 4470, 
max_tx_time = 1862ATM0/0 last_address 0x12E14 

01:08:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:2 vpi:8 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 2, vpi 8, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
01:08:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
01:08:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
01:08:11:  dslsar_atm_lineaction(ATM0/0): state=4 
01:08:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
01:08:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 25900