IP : Open Shortest Path First (OSPF)

Os efeitos do endereço de encaminhamento na seleção de caminho de LSA tipo 5

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

A finalidade deste documento é demonstrar o comportamento de seleção do caminho Open Shortest Path First (OSPF) quando um roteador recebe dois anúncios link state (LSA) do tipo 5 para uma determinada rede externa. Neste exemplo, um LSA tem endereço de encaminhamento definido como zero (0.0.0.0) e o outro LSA tem esse mesmo tipo de endereço definido como não-zero.

Pré-requisitos

Requisitos

Os leitores deste documento devem estar cientes da seguinte informação:

  • General IP Routing

  • Conceitos e termos do OSPF routing protocol

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Componentes Utilizados

As informações neste documento são baseadas nas versões de software e hardware abaixo.

  • Cisco 2503 Routers

  • Software Release 12.2(24a) do � do Cisco IOS que é executado em todo o Roteadores

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Como os endereços de encaminhamento LSA tipo 5 podem afetar a seleção de caminhos

Encaminhando endereços não definidos em ambos os LSAs

A topologia mostrada a seguir é usada para demonstrar como o endereço de encaminhamento em um LSA OSPF tipo 5 pode afetar a seleção de caminho do LSA tipo 5.

/image/gif/paws/25493/type5_lsa_01.gif

No diagrama acima, todo o Roteadores, a não ser o roteador 8, está executando o OSPF na área 0. a fim este documento, as configurações do roteador 3 e Roteador4 são os mais importantes porque é o roteador de limite de sistema autônomo (ASBR) que gera o tipo 5 LSA. Conforme mostrado abaixo, o Roteador 3 e o Roteador 4 têm uma rota estática para a rede 200.200.200.0 255.255.255.0, que está sendo redistribuída para o OSPF.

Roteador 3
interface Ethernet0
 ip address 172.16.3.3 255.255.255.0
 ip ospf cost 15
!
interface Serial0
 ip address 172.16.2.3 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.2.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

Roteador 4
interface Ethernet0
 ip address 172.16.3.4 255.255.255.0
!
interface Serial0
 ip address 172.16.7.4 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.7.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

Nota: O roteador3 e Roteador4 não incluem a rede 172.16.3.0 255.255.255.0 no processo de OSPF; consequentemente, o tipo 5 LSA gerado por ambo o Roteadores tem os endereços de encaminhamento ajustados a 0.0.0.0

Neste exemplo, o roteador 5 pode ser usado para ver o LSAs externo. Para ver o LSAs externo, emita o comando show ip ospf database external no roteador 5. A saída desse comando é mostrada abaixo.

Roteador 5
router-5# show ip ospf database external

            OSPF Router with ID (172.16.6.5) (Process ID 7)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 1514
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.3.3
  LS Seq Number: 80000030
  Checksum: 0x93C0
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 1922
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.7.4
  LS Seq Number: 80000027
  Checksum: 0x83D4
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

router-5#

O que você pode ver acima é que os endereços de encaminhamento para os LSAs de tipo 5 gerados pelos Roteadores 3 e 4 são definidos como 0.0.0.0. Neste caso, o LSA a ser instalado na tabela de roteamento do Router 5 é determinado via comparação de métricas nos ASBRs que geram os LSAs. Emitindo o comando show ip ospf border-routers no roteador 5, você pode ver o medidor que o roteador 5 tem para os ASBR. A saída desse comando é mostrada abaixo.

Roteador 5
router-5# show ip ospf border-routers

OSPF Process 7 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 14
i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 14
router-5#

Como mostrado acima, 64 são a métrica do roteador 5 para alcançar ASBR 172.16.3.3, quando a métrica para alcançar ASBR 172.16.7.4 for 74; consequentemente, o roteador 5 escolhe o LSA gerado por ASBR 172.16.3.3 para colocar em sua tabela de roteamento (mostrada abaixo).

Roteador 5
router-5# 
show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.200.200.0/24 [110/20] via 172.16.2.3, 19:59:25, Serial0
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.6.0 is directly connected, Ethernet0
O       172.16.7.0 [110/74] via 172.16.6.6, 19:59:25, Ethernet0
C       172.16.2.0 is directly connected, Serial0
router-5#

Encaminhando endereço definido para um LSA mas não para outro

Uma topologia igual à descrita acima é usada para esta parte do documento. A configuração do Roteador 4 também permanece inalterada, mas a configuração do Roteador 3 foi alterada para incluir a rede 172.16.3.0 255.255.255.0 na área 0 do processo OSPF. A configuração do roteador3 é mostrada abaixo com a mudança destacada em corajoso.

Roteador 3
interface Ethernet0
 ip address 172.16.3.3 255.255.255.0
 ip ospf cost 15
!
interface Serial0
 ip address 172.16.2.3 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.2.0 0.0.0.255 area 0
 network 172.16.3.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

O resultado da alteração da configuração acima é que o LSA tipo 5 gerado pelo Roteador 3 agora tem o endereço de encaminhamento definido para o endereço do Roteador 8, conforme mostrado na saída do banco de dados retirada do Roteador 5 abaixo.

Roteador 5
router-5# show ip ospf database external

            OSPF Router with ID (172.16.6.5) (Process ID 7)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 270
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.3.3
  LS Seq Number: 80000033
  Checksum: 0x5138
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 172.16.3.8
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 258
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.7.4
  LS Seq Number: 80000029
  Checksum: 0x7FD6
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

router-5#

Você pode ver acima que o tipo 5 LSA gerado pelo Roteador 3 agora tem o endereço de encaminhamento definido como 172.16.3.8, enquanto o tipo 5 LSA gerado pelo Roteador 4 ainda tem o endereço de encaminhamento de 0.0.0.0.

Neste caso, o LSA a ser instalado na tabela de roteamento do roteador 5 é determinado comparando a métrica do roteador 5 ao ASBR (Roteador4) que gerou o LSA com um endereço de encaminhamento de 0.0.0.0 à métrica do roteador 5 para alcançar o endereço de encaminhamento de 172.16.3.8, que foi ajustado para o LSA gerado pelo ASBR (roteador3).

Para ver o medidor aos ASBR, emita o comando da beira OSPF da mostra IP no roteador 5. A saída é exibida abaixo.

Roteador 5
router-5# show ip ospf border-routers

OSPF Process 7 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 15
i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 15
router-5#

Na saída acima, a métrica a Roteador4 é 74. Isto é comparado à métrica do roteador 5 para alcançar o endereço de encaminhamento de 172.16.3.8, que pode ser considerado usar o comando de 172.16.3.8 da rota da mostra IP. A saída desse comando é mostrada abaixo.

Roteador 5
router-5# show ip route 172.16.3.8
Routing entry for 172.16.3.0/24
  Known via "ospf 7", distance 110, metric 79, type intra area
  Last update from 172.16.2.3 on Serial0, 00:30:49 ago
  Routing Descriptor Blocks:
  * 172.16.2.3, from 172.16.3.3, 00:30:49 ago, via Serial0
      Route metric is 79, traffic share count is 1

router-5#

Assim, a métrica para alcançar o roteador ASBR 4, que é 74, é comparada à métrica para alcançar o endereço de encaminhamento de 172.16.3.8 (gerado pelo roteador3), que é 79. Consequentemente, o LSA instalado na tabela de roteamento é o LSA gerado por Roteador4, segundo as indicações da saída do roteador 5 da rota da mostra IP abaixo.

Roteador 5
router-5# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.200.200.0/24 [110/20] via 172.16.6.6, 00:35:14, Ethernet0
     172.16.0.0/24 is subnetted, 4 subnets
C       172.16.6.0 is directly connected, Ethernet0
O       172.16.7.0 [110/74] via 172.16.6.6, 00:35:14, Ethernet0
C       172.16.2.0 is directly connected, Serial0
O       172.16.3.0 [110/79] via 172.16.2.3, 00:35:14, Serial0
router-5#

Quando a métrica da rota redistribuída dos ASBR múltiplos é igual como ilustrado no documento, o endereço de encaminhamento muda o comportamento do tipo seleção de trajeto 5 LSA. Quando um roteador recebe dois o tipo 5 LSA ao mesmo destino com os endereços de encaminhamento ajustados em ambos os LSA, o roteador faz uma comparação baseada na métrica aos endereços de encaminhamento. O LSA com um endereço de encaminhamento que ofereça a métrica menor é colocado na tabela de roteamento.

Se a métrica das rotas redistribuída é diferente, o Roteadores prefere a rota com a mais baixa métrica e não a mais baixa métrica ao endereço de encaminhamento.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 25493