IP : IP versão 6

Túnel do IPv6 através de uma rede do IPv4

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (11 Novembro 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para envio do Routing Information Protocol (RIP) do IPv6 e uma rede e tráfego de Border Gateway Protocol (BGP) de IPv6 através de uma rede pré-existente IPv4. Esta técnica permite que você conecte locais de IPv6 no backbone de IPv4 existente.

O Tunelamento da folha de prova encapsula pacotes do IPv6 em uns pacotes IPv4 para a entrega através de uma infraestrutura do IPv4. Isto é similar a como você cria um túnel de encapsulamento de roteamento genérico (GRE) para transportar o tráfego das Trocas de Pacote Entre Redes IPX (IPX) através de uma rede IP. Na extremidade principal do túnel, um pacote do IPv6 é encapsulado no pacote IPv4 e enviado ao destino de túnel remoto. Isto é o lugar aonde o encabeçamento de pacote IPv4 é descascado, e o pacote original do IPv6 é enviado mais em uma nuvem do IPv6.

Estes são os cinco métodos do tráfego do IPv6 do Tunelamento:

  • Túneis de IPv6 manual

  • Túneis compatíveis com IPv4 automáticos

  • GRE

  • Túneis 6to4 automáticos

  • Túneis do protocolo do endereçamento do túnel automático do Intra-local (ISATAP)

A diferença principal nestas técnicas de tunelamento é o método em que o origem e destino do túnel é determinado. Neste documento, os tipos de túnel compatíveis do IPv4 manual e automático são descritos. Refira a aplicação do Tunelamento para o IPv6 para obter informações sobre de outras técnicas de tunelamento e de suas características.

Nota: Os túneis da folha de prova reduzem a unidade de transmissão máxima (MTU) de uma relação por 20 octetos. Isto supõe que o encabeçamento de pacote IPv4 básico não contém campos opcionais. Uma rede que use túneis da folha de prova é difícil de pesquisar defeitos. Consequentemente, os túneis overlay que conectam redes isoladas do IPv6 não devem ser considerados como uma arquitetura de rede final do IPv6. O uso de túneis da folha de prova deve ser considerado como uma técnica de transição para uma rede que apoie as pilhas de protocolos do IPv4 e do IPv6, ou apenas a pilha de protocolos do IPv6.

Pré-requisitos

Requisitos

Cisco recomenda que você tem o conhecimento do IPv6 antes que você tente esta configuração. Refira a aplicação do endereçamento e da conectividade básica do IPv6 para obter informações sobre do IPv6.

Componentes Utilizados

A informação neste documento é baseada nos Cisco 36xx Series Router que executam o Software Release 12.3(13) do½ do¿Â do Cisco IOSïÂ.

Nota: Toda a plataforma de hardware que apoiar o Cisco IOS Software Releases 12.2(2)T ou 12.0(21)ST e mais atrasado igualmente apoia o IPv6.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/25156/ipv6tunnel.gif

Configurações (modo IPv6 manual)

A configuração manualmente de túneis configurados para o IPv6 é evidente. Exige a especificação definitiva da fonte do IPv4 do túnel e do destino do IPv4 do túnel. O único inconveniente de quando você usa esta técnica é a quantidade da administração que você deve executar quando o número de túneis cresce.

Este documento usa estas configurações para o modo manual do IPv6:

R1-IPv6 (Cisco 3640 Router)
R1-ipv6#show run
Building configuration...
 
Current configuration : 916 bytes
!
version 12.3
hostname R1-ipv6
!
boot system flash 
logging buffered 4096 debugging
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 ipv6 address 2000:1:1:1:1:1:1:1112/112
 ipv6 rip 6bone enable
!
!
ip classless
!
ipv6 router rip 6bone 
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
!
end

R2-IPv6-IPv4 (Cisco 3640 Router)
R2-ipv6-ipv4#show run
Building configuration...
 
Current configuration : 1079 bytes
!
version 12.3
!
hostname R2-ipv6-ipv4
!
ip subnet-zero
!
!
ipv6 unicast-routing
!
!
interface Tunnel0
 no ip address
 ipv6 address 3000::1/112
 ipv6 rip 6bone enable
 tunnel source Serial0/0
tunnel destination 192.34.1.4
tunnel mode ipv6ip

!--- Configures Manual tunnel.


!--- In some cases, user would require a Data License  
!--- in order to issue "tunnel mode ipv6ip"


!
!
interface Serial0/0
 ip address 192.23.1.2 255.255.255.0
 clockrate 64000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
!
ip classless
!
ipv6 router rip 6bone
!
!
line con 0
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!
!
end

R3-IPv4 (Cisco 2621 Router)
R3-ipv4#show run
Building configuration...
 
Current configuration : 865 bytes
!
version 12.3
!
hostname R3-ipv4
!
!
memory-size iomem 15
ip subnet-zero
!
!
interface Serial0/0
 ip address 192.23.1.3 255.255.255.0
!
interface Serial0/1
 ip address 192.34.1.3 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
 network 192.34.1.0 0.0.0.255 area 0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
!
!
end

R4-Ipv4-Ipv6 (Cisco 3640 Router)
R4-ipv4-ipv6#show run
Building configuration...
 
Current configuration : 1413 bytes
!
version 12.3
!
hostname R4-ipv4-ipv6
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 no ip address
 ipv6 address 3000::2/112
 ipv6 rip 6bone enable
 tunnel source Serial1/5
tunnel destination 192.23.1.2
tunnel mode ipv6ip

!--- Configures Manual tunnel.


!
!
interface Serial1/5
 ip address 192.34.1.4 255.255.255.0
 clockrate 64000
!
!
interface Ethernet3/0
 no ip address
 half-duplex
 ipv6 address 4000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.34.1.0 0.0.0.255 area 0
!
ip classless
!
ipv6 router rip 6bone
!         
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

R5-IPv6 (Cisco 7500 Router)
R5-ipv6#show run
Building configuration...
 
Current configuration : 1001 bytes
!
version 12.3
!
hostname R5-ipv6
!
ip subnet-zero
ip cef distributed
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Ethernet1/2
 no ip address
 ipv6 address 4000:1:1:1:1:1:1:1112/112
 ipv6 rip 6bone enable
!
!
ip classless
!
ipv6 router rip 6bone
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Configurações (modo compatível com IPv4 automático)

As configurações para o r1, o R3, e o R5 são as mesmas que os exemplos manuais do modo do IPv6. Somente as configurações de R2 e R4 são alteradas. Quando você configura o túnel IPv4-compatible, não especifique explicitamente o endereço do IPv4 do destino de túnel. O destino de túnel é calculado automaticamente do endereço de próximo salto do IPv6 da rota do IPv6. A fim fornecer a rota sobre tal túnel, o protocolo de roteamento a definição de endereço do vizinho explícito, tal como o BGP ou estático, é exigido. Neste caso, você precisa de usar um endereço compatível do IPv6 do IPv4 como o endereço do IPv6 do vizinho de BGP ou o endereço de próximo salto da rota estática.

Estes exemplos usam a interface serial no R2 e no R4 como o endereço do IPv6 IPv4-compatible. A mesma série é o origem de túnel. Por exemplo, o endereço 192.23.1.2 do IPv4 em R2 S0/0 é convertido a:: 192.23.1.2 na notação do IPv6. Este endereço é usado como o endereço do IPv6 do bgp peer e o salto seguinte BGP. Apesar de tudo, as rotas de BGP do IPv6 são redistribuídas no RASGO do IPv6 de modo que as extremidades remotas da rede recebam a informação.

Esta técnica de tunelamento é suplicada atualmente. Cisco recomenda que você usa a técnica de tunelamento do IPv6 ISATAP. Refira túneis ISATAP para obter mais informações sobre desta técnica.

Nota: Não há nenhuma necessidade de configurar um destino de túnel com o modo IPv6 automático.

R2-IPv6-IPv4 (Cisco 3640 Router)
R2-ipv6-ipv4#show run
Building configuration...
Current configuration : 1394 bytes
!
version 12.3
!
hostname R2-ipv6-ipv4
!
!
ip subnet-zero
!
!
!
ipv6 unicast-routing
!
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 rip 6bone enable
 tunnel source Serial0/0
tunnel mode ipv6ip auto-tunnel

!--- Configures Automatic IPv4 compatible tunnel.


!
!
interface Serial0/0
 ip address 192.23.1.2 255.255.255.0
 clockrate 64000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor ::192.34.1.4 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor ::192.34.1.4 activate
 neighbor ::192.34.1.4 next-hop-self
 network 2000:1:1:1:1:1:1:0/112
bgp redistribute-internal

!--- The show run command along with the 
!--- redistribute bgp command allows BGP to redistribute the
!--- IPv6 routes learned through the tunnel from the other site.


 exit-address-family
!         
ip classless
!
ipv6 router rip 6bone
redistribute bgp 100 metric 2
!
!
line con 0
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!
!
end

R4-Ipv4-Ipv6 (Cisco 3640 Router)
R4-ipv4-ipv6#show run
Building configuration...
 
Current configuration : 1697 bytes
!
version 12.3
!
hostname R4-ipv4-ipv6
!
ip subnet-zero
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 rip 6bone enable
 tunnel source Serial1/5
tunnel mode ipv6ip auto-tunnel

!--- Configures Automatic IPv4 compatible tunnel.


!
!
interface Serial1/5
 ip address 192.34.1.4 255.255.255.0
 clockrate 64000
!
!
interface Ethernet3/0
 no ip address
 half-duplex
 ipv6 address 4000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.34.1.0 0.0.0.255 area 0
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor ::192.23.1.2 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor ::192.23.1.2 activate
 neighbor ::192.23.1.2 next-hop-self
 network 4000:1:1:1:1:1:1:0/112
bgp redistribute-internal

!--- The show run command along with the 
!--- redistribute bgp command allows BGP to redistribute the
!--- IPv6 routes learned through the tunnel from the other site.


 exit-address-family
!
ip classless
!
ipv6 router rip 6bone
redistribute bgp 100 metric 2
!
!
!         
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

  • sibilo — Determina se um host remoto é ativo ou inativo, e o retardo round trip na comunicação com o host.

  • show ipv6 route — Verifica se uma rota existe no IPv6.

  • show bgp ipv6 — Verifica se o BGP está sendo executado.

  • show bgp ipv6 summary – Exibe informações resumidas sobre o BGP sendo executado no IPv6.

  • show ipv6 int tunnel 0 — Verifica que o túnel está acima no IPv6, e verifica o MTU configurado na relação.

Saída do comando de verificação para modo IPV6 manual

Do r1, sibile o endereço do IPv6 no R5 para verificar se o túnel transporta o IPv6 através da rede do IPv4.

R1-ipv6#ping ipv6 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms 
R1-ipv6#ping 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms 
R1-ipv6#

Do R5, sibile o endereço do IPv6 no r1.

R5-ipv6#ping  2000:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 
R5-ipv6#ping ipv6 2000:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 
R5-ipv6#

Saída do comando de verificação para modo IPv6 automático

Execute um ping na rede Ipv6 remota para verificar a conectividade através do túnel.

R1-ipv6#ping 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/69/72 ms 
R1-ipv6# 
R5-ipv6#ping ipv6 2000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/70/72 ms 
R5-ipv6#

Se o sibilo falha, olhe a tabela de roteamento do IPv6 para verificar se a rota existe. Verifique a tabela de roteamento no outro lado também. A rota no roteador da extremidade, tal como o R5 e o r1, deve ser aprendida como uma rota RIP. Esta rota é redistribuída do BGP no RASGO no R2 e no R4. O R2 e o R4 são onde o túnel termina e espreitar BGP é configurado.

R5-ipv6#show ipv6 route 
IPv6 Routing Table - 6 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
R   ::/96 [120/2] 
     via FE80::230:80FF:FEF3:4731, Ethernet1/2
R   2000:1:1:1:1:1:1:0/112 [120/3]
     via FE80::230:80FF:FEF3:4731, Ethernet1/2
L   4000:1:1:1:1:1:1:1112/128 [0/0] 
     via ::, Ethernet1/2
C   4000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet1/2
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R5-ipv6#

Se a rede remota do IPv6 não está no roteador da extremidade, verifique o roteador onde o túnel termina.

R4-ipv4-ipv6#show ipv6 route 
IPv6 Routing Table - 7 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   ::192.34.1.4/128 [0/0] 
     via ::, Tunnel0
C   ::/96 [0/0] 
     via ::, Tunnel0
B   2000:1:1:1:1:1:1:0/112 [200/0]
     via ::192.23.1.2, Null
L   4000:1:1:1:1:1:1:1111/128 [0/0] 
     via ::, Ethernet3/0
C   4000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet3/0
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R4-ipv4-ipv6#

Como você está utilizando o BGP IPv6 para compartilhar informações entre as duas redes IPv6 diferentes, verifique se o BGP está ativo e em execução.

R4-ipv4-ipv6#show bgp ipv6 
BGP table version is 3, local router ID is 192.34.1.4 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure 
Origin codes: i - IGP, e - EGP, ? - incomplete 
   Network          Next Hop            Metric LocPrf Weight Path 
*>i2000:1:1:1:1:1:1:0/112 
                    ::192.23.1.2                  100      0 i 
*> 4000:1:1:1:1:1:1:0/112 
                    ::                                 32768 i 
R4-ipv4-ipv6#show bgp ipv6 summary 
BGP router identifier 192.34.1.4, local AS number 100 
BGP table version is 3, main routing table version 3 
2 network entries and 2 paths using 394 bytes of memory 
2 BGP path attribute entries using 120 bytes of memory 
0 BGP route-map cache entries using 0 bytes of memory 
0 BGP filter-list cache entries using 0 bytes of memory 
BGP activity 2/8 prefixes, 2/0 paths, scan interval 60 secs 
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
::192.23.1.2    4   100      24      24        3    0    0 00:19:00        1 
R4-ipv4-ipv6# 
R4-ipv4-ipv6#show ipv6 int tunnel 0 
Tunnel0 is up, line protocol is up 
  IPv6 is enabled, link-local address is FE80::C022:104 
  Global unicast address(es): 
    ::192.34.1.4, subnet is ::/96 
  Joined group address(es): 
    FF02::1 
    FF02::2 
    FF02::9 
    FF02::1:FF22:104 
  MTU is 1480 bytes 
  ICMP error messages limited to one every 100 milliseconds 
  ICMP redirects are enabled 
  ND DAD is not supported 
  ND reachable time is 30000 milliseconds 
  Hosts use stateless autoconfig for addresses. 
R4-ipv4-ipv6#

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • show ipv6 route — Verifica se uma rota existe no IPv6.

  • show ip ospf neighbor - Exibe a identificação do roteador, a prioridade e o estado do roteador vizinho. Também, este comando indica a quantidade de tempo que permanece que o roteador espera para receber um pacote Hello do Open Shortest Path First (OSPF) do vizinho antes de declarar o vizinho para baixo. Igualmente indica o endereço IP de Um ou Mais Servidores Cisco ICM NT da relação a que este vizinho é conectado diretamente e da relação em que o vizinho de OSPF forma a adjacência.

  • show ipv6 interface brief — Verifica que a interface de túnel está acima.

  • show interfaces tunnel 0 — Verifica que o destino de túnel configurado está sabido na tabela de roteamento.

  • show ipv6 rip — Informação do RASGO do IPv6 dos indicadores.

  • show ipv6 protocols — Indica o estado do protocolo de roteamento do IPv6.

Se o sibilo à rede remota do IPv6 falha, verifique que as rotas do IPv6 são instruídas através do RASGO do IPv6.

R1-ipv6#show ipv6 route 
IPv6 Routing Table - 6 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   2000:1:1:1:1:1:1:1112/128 [0/0] 
     via ::, Ethernet0/1
C   2000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet0/1
R   3000::/112 [120/2]
     via FE80::202:B9FF:FECB:D281, Ethernet0/1
R   4000:1:1:1:1:1:1:0/112 [120/3] 
     via FE80::202:B9FF:FECB:D281, Ethernet0/1
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R1-ipv6#

No R2, verifique se as rotas IPv6 RIP são aprendidas pela interface Tunnel0.

R2-ipv6-ipv4#show ipv6 route 
IPv6 Routing Table - 7 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   2000:1:1:1:1:1:1:1111/128 [0/0] 
     via ::, FastEthernet0/1
C   2000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, FastEthernet0/1
L   3000::1/128 [0/0] 
     via ::, Tunnel0
C   3000::/112 [0/0] 
     via ::, Tunnel0
R   4000:1:1:1:1:1:1:0/112 [120/2]
     via FE80::230:80FF:FEF3:4701, Tunnel0
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R2-ipv6-ipv4#

Se há umas edições com Conectividade, verifique primeiramente que a rede do IPv4 é intacto. Também, verifique o adjacenciesand do vizinho de OSPF que há rotas ao endereço do IPv4, que é o origem de túnel da interface de túnel remota. Verifique então que você pode sibilar entre origens de túnel com sibilo do IPv4.

R2-ipv6-ipv4#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
192.23.1.3        1   FULL/  -        00:00:36    192.23.1.3      Serial0/0 
R2-ipv6-ipv4# 
R3-ipv4#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
1.1.1.1           1   FULL/  -        00:00:30    192.34.1.4      Serial0/1 
192.23.1.2        1   FULL/  -        00:00:35    192.23.1.2      Serial0/0 
R3-ipv4# 
R4-ipv4-ipv6#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
192.23.1.3        1   FULL/  -        00:00:35    192.34.1.3      Serial1/5 
R4-ipv4-ipv6#

No R2, verifique que a interface de túnel do IPv6 é ascendente e que você pode sibilo do IPv6 o origem de túnel remoto com o endereço do IPv6 IPv4-compatible. Se a interface de túnel está para baixo, verifique que o destino de túnel configurado está sabido na tabela de roteamento. Esse é um problema na parte IPv4 da rede, pois o destino do túnel não é a tabela de roteamento.

R2-ipv6-ipv4#show ipv6 interface brief 
FastEthernet0/0            [up/up] 
    unassigned 
Serial0/0                  [up/up] 
    unassigned 
FastEthernet0/1            [up/up] 
    2000:1:1:1:1:1:1:1111 
Tunnel0                    [up/up] 
    3000::1 
R2-ipv6-ipv4# 
R2-ipv6-ipv4#show interfaces tunnel 0 
Tunnel0 is up, line protocol is up 
  Hardware is Tunnel 
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation TUNNEL, loopback not set 
  Keepalive not set 
  Tunnel source 192.23.1.2 (Serial0/0), destination 192.34.1.4 
  Tunnel protocol/transport IPv6/IP, key disabled, sequencing disabled 
  Tunnel TTL 255 
  Checksumming of packets disabled 
  Last input 00:00:09, output 00:00:19, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: fifo 
  Output queue :0/0 (size/max) 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     3119 packets input, 361832 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     3117 packets output, 361560 bytes, 0 underruns 
     0 output errors, 0 collisions, 0 interface resets 
     0 output buffer failures, 0 output buffers swapped out 
R2-ipv6-ipv4#

Se há ainda umas edições com as rotas do IPv6 e a rede do IPv4 está verificada, você precisa de verificar a configuração RIP do IPv6.

R2-ipv6-ipv4#show ipv6 rip 
RIP process "6bone", port 521, multicast-group FF02::9, pid 111 
     Administrative distance is 120.  Routing table is 0 
     Updates every 30 seconds, expire after 180 
     Holddown lasts 180 seconds, garbage collect after 120 
     Split horizon is on; poison reverse is off 
     Default routes are not generated 
     Periodic updates 176, trigger updates 1 
R2-ipv6-ipv4# 
R2-ipv6-ipv4#show ipv6 protocols 
IPv6 Routing Protocol is "connected" 
IPv6 Routing Protocol is "static" 
IPv6 Routing Protocol is "rip 6bone" 
  Interfaces: 
    FastEthernet0/1 
    Tunnel0 
  Redistribution: 
    Redistributing protocol rip 6bone

Certifique-se de que os temporizadores sejam os mesmos caso as configurações padrão não sejam usadas. Neste exemplo, o padrão é usado em todo o Roteadores do RASGO do IPv6. Verifique a configuração para assegurar que todas as interfaces habilitadas para RIP estejam configuradas corretamente. Também, verifique que o mesmo nome de processo do RASGO é consistente durante todo a rede. Se necessário, verifique a saída do comando debug ipv6 rip. Como com tudo debuga, o cuidado deve ser usado para não sobrecarregar o buffer CPU e de logging de console.

Resumo

Este documento demonstra como os túneis podem ser usados para que o IPv6 e o IPv4 coexista na mesma rede. Isto pôde ser necessário em período da transição. Uma coisa a recordar sobre as configurações do IPv6 é aquela com RASGO do IPv6, instruções de rede não é usada. O RASGO do IPv6 é permitido globalmente e cada relação participa no RASGO, e é permitida para o RASGO do IPv6. No exemplo de BGP IPv6, a seção de Túnel Automático requer o uso do comando address-family ipv6 definido de forma a inserir instruções BGP.


Informações Relacionadas


Document ID: 25156