Voz : H.323

Configuração e Troubleshooting do Serviço de Telefonia Cisco IOS (ITS)

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (12 Novembro 2015) | Feedback


Índice


Introdução

O Serviço de Telefonia Cisco IOS (ITS), conhecido anteriormente como IP Keyswitch, é uma solução do Processamento de chamadas da Telefonia IP integrada no software do � do Cisco IOS que cabe na arquitetura Cisco para a Voz, o vídeo, e os dados integrados (AVVID). O conceito básico é fornecer o mínimo de funcionalidade de PBX/key-switch a um número pequeno de telefones IP diretamente ligados ao gateway de voz. O Cisco ITS pode ser distribuído em instâncias onde um escritório filial não possua WAN ou possua conectividade de WAN através de links satélite.

O Cisco ITS faz o sentido nas situações onde um cliente gostaria de adicionar um serviço de telefonia em tal local sem necessariamente exigir todos os recursos de telefonia encontrados no CallManager da Cisco. Este documento descreve um exemplo de implantação do recurso de ITS em uma rede de exemplo

Nota: O Cisco ITS não é o mesmo, nem são as características o mesmos, como a característica do Survivable Remote Site Telephony (SRST) que é usada conjuntamente com o CallManager da Cisco.

Pré-requisitos

Requisitos

Antes de tentar utilizar esta configuração, verifique se os seguintes pré-requisitos são atendidos:

  • Familiaridade com a versão 2.01 do Cisco IOS Telephony Service.

  • Uma compreensão básica de fundamentos TCP/IP, tais como o endereçamento de IP, o DHCP, o Network Time Protocol (NTP), o TFTP, e o HTTP

  • Uma compreensão básica de fundamentos do Cisco IOS Software, tais como a configuração do comando line interface(cli)

  • Uma compreensão básica da Voz sobre fundamentos IP (VoIP), tais como configurar o dial peers, as portas de voz, e o Qualidade de Serviço (QoS)

Componentes Utilizados

As informações deste documento são baseadas nas seguintes versões de software e de hardware:

  • Cisco IOS Software Release 12.2(8)T ou Mais Recente, com um mínimo de conjunto de recursos do IP Plus (sinal de adição IP/VOX no 1700 Series). Este documento admite suporte Cisco ITS 2.0 no software Cisco IOS.

  • O gateway do Cisco 3660 com IOS Software release 12.2(11)T com o conjunto de recursos do IP PLUS é usado no exemplo de configuração, embora a maioria IAD2400, 1700, 2600, 3600, e de 3700 Series Router sejam atualmente aplicáveis. Verifique por favor as notas de Cisco IOS Software Release para ver se há a versão atual e a informação de suporte de software.

  • O pacote do software do Cisco ITS 2.0.3 foi usado neste exemplo. Você pode transferir este pacote do download do software: CallManager da Cisco Express/ITS e SRST (clientes registrados somente).

  • Para apoiar o Cisco ITS, recomenda-se que você tem a quantidade máxima de memória para cada plataforma, especialmente se o número máximo de telefones e os nomes destacados (DN) para a plataforma devem ser configurados.

  • Neste exemplo, um Catalyst 3500 Series XL switch é usado como o interruptor do escritório filial. Configurar VLAN separados para a Voz e dados para a qualidade e os motivos de segurança.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/25100/config_troubleshoot_its1.gif

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

A tabela abaixo especifica a informação sobre a Voz e a transferência de dados com os VLAN separados. Igualmente especifica a rede e os endereços e as portas da relação.

Propósito VLAN Rede Interface Endereço de interface
Dados 50 10.1.50.0/24 Fa0/0.50 10.1.50.1/24
Voz 150 10.1.150.0/24 Fa0/0.150 10.1.150.1/24

O roteador do Cisco ITS é um Cisco IOS Software Release 12.2(11)T 3660 running com o conjunto de recursos do IP Plus. Os arquivos do Cisco ITS devem ser transferidos em .tar ou no formato do .zip do download do software: CallManager da Cisco Express/ITS e SRST (clientes registrados somente).

Uma vez que extraído, cada arquivo deve ser transferido ao flash do roteador com o TFTP. Não apague o flash sempre que um arquivo individual for copiado. O seguinte é uma lista dos arquivos encontrados no Cisco ITS 2.0.3 (não todos estes arquivos são necessários).

nome do arquivo Descrição
P003G302.bin A carga do telefone a ser usada com Cisco ITS para o telefone IP do Cisco 7910. A carga de telefone possui uma nota de versão separada que explica algumas das correções das versões anteriores. (obrigatório)
P004G302.bin A carga do telefone a ser usada com Cisco ITS para o telefone IP do Cisco 7960. A carga de telefone possui uma nota de versão separada que explica algumas das correções das versões anteriores. (obrigatório)
admin_user.html A página da web do administrador para configurar o sistema
ephone_admin.html A página da Web de administração do telefone.
normal_user.html O página da web (não-administrador) do usuário para administrar telefones para a transmissão e os outros recursos.
telephony_service.html O página da web nível mais alto que cada usuário visita para configurar telefones ou para configurar o sistema como um administrador. (Opcional)
logohome.gif
en_dest_busy.au Um exemplo de prompt de áudio para uma extensão ocupada. Utilizado pelo script its_Cisco.2.0.0.tcl.
en_dest_unreachable.au Um exemplo de prompt de áudio para uma extensão inalcançável. Utilizado pelo script its_Cisco.2.0.0.tcl.
en_disconnect.au Um prompt de áudio da amostra para um desligado ou uma extensão não registrada. Utilizado pelo script its_Cisco.2.0.0.tcl.
en_enter_dest.au Um prompt de áudio de amostra para o usuário digitar um destino. Utilizado pelo script its_Cisco.2.0.0.tcl.
en_reenter_dest.au Um prompt de amostra de áudio para o usuário digitar novamente o destino. Utilizado pelo script its_Cisco.2.0.0.tcl.
en_welcome.au Um exemplo de alerta de áudio para a saudação do usuário. Utilizado pelo script its_Cisco.2.0.0.tcl.
its_Cisco.2.0.0.tcl O script TCL para um exemplo de Automated Attendant que pode rotear chamadas para uma extensão. Usa os arquivos do .au da amostra para cumprimentar o usuário, para alertá-lo para um número, e para distribuir o atendimento ao destino desejado.
music-on-hold.au Um exemplo de arquivo de áudio usado para música em espera.

O seguinte arquivo é igualmente parte do arquivo de Cisco ITS-2.0.3.zip, mas não precisa de ser colocado no flash de SEU roteador.

nome do arquivo Descrição
CiscoIOSTSP.zip Este provedor de serviços do telephony application programming interface (tapi) (TSP) foi desenvolvido para o Cisco ITS e atua como uma relação entre TAPI (parte do sistema operacional do Windows 2000) e o SEU. O TSP permite aplicativos TAPI-baseados tais como o discador e o ATO do telefone! software para fornecer o Controle de chamadas aos Telefones IP no Cisco ITS. A implementação TAPI no Cisco ITS é uma não pilha completa TAPI, mas “uma aplicação TAPI Lite”. Apoia as seguintes características:
  • Endereços múltiplos em uma linha única.
  • Colocando atendimentos usando o catálogo de endereços que disca do aplicativo.
  • Respondendo ou rejeitando a atendimentos do aplicativo.
  • Guardando atendimentos usando pop de tela.
  • Fazendo a informação de identificador de chamada disponível ao aplicativo.
  • Colocar chama a posse e comutando no meio chama endereços diferentes da mesma linha.
O TSP fornece uma relação que permita o controle remoto linear de um telefone IP. Embora múltiplo os TSP podem ser executado no mesmo computador, simplesmente um telefone IP pode ser associado com cada TSP. Como o MSP (Provedor de Serviços de Mídia) não é suportado por este TSP, aplicativos como o Cisco SoftPhone não são suportados.

Nota: O TSP que acompanha o Cisco CallManager não é suportado com esse ITS.

Configurações

Configuração de VLAN no Catalyst 3500XL

O Cisco ITS é executado no LAN onde os Telefones IP e os CallManagers de Cisco são conectados ao Gateways de voz com os Catalyst Switches. É muito importante configurar corretamente estes dispositivos no que diz respeito aos VLANS que levam os dados de voz. Esta seção fornece uma vista geral da configuração do Catalyst 3500XL e a conexão de LAN correspondente no 3660 Router do gateway de voz.

  1. A Voz e o VLAN de dados devem estabelecer-se com um interruptor do desconfigurado, segundo as indicações do exemplo seguinte:

    Cat3500BranchSwitch# vlan database
    Cat3500BranchSwitch(vlan)# vlan 50 name corporate-data-vlan
    VLAN 50 added:
    Name: corporate-data-vlan
    Cat3500BranchSwitch(vlan)# vlan 150 name corporate-voice-vlan
    VLAN 150 added:
    Name: corporate-voice-vlan
    Cat3500BranchSwitch(vlan)#
    Cat3500BranchSwitch(vlan)# exit
    APPLY completed.
    Exiting....
    Cat3500BranchSwitch#
  2. O exemplo seguinte é uma configuração de exemplo da relação entre o Catalyst 3500XL e o 3660 Router:

    interface FastEthernet0/1
     description Port to 3660 (supports Dot1q)
     duplex full
     speed 100
     switchport trunk native 50
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,50,150,1002-1005
     switchport mode trunk
    !
    
  3. O exemplo seguinte é uma porta a ser usada para uma conexão telefônica:

    interface FastEthernet0/2
     description DOT1Q port to IP Phone
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 50
     switchport mode trunk
     switchport voice vlan 150
     spanning-tree portfast
    !
    

Para mais informações, refira o Catalyst 2900 series XL e os Catalyst 3500 Series XL switch.

Configuração de VLAN no roteador do Cisco ITS

Siga as etapas abaixo para configurar VLAN no roteador do Cisco ITS.

  1. A primeira etapa é configurar parâmetros de QoS e VLAN na relação 3660, como mostrado abaixo.

    ! 
    class-map match-all L3-to-L2_VoIP-Cntrl
     match ip dscp af31 
    class-map match-all L3-to-L2_VoIP-RTP
     match ip dscp ef 
    !
    !
    policy-map output-L3-to-L2
     class L3-to-L2_VoIP-RTP
      set cos 5
     class L3-to-L2_VoIP-Cntrl
      set COs 3
    !
    
  2. Agora aplique estas políticas à relação e crie os VLAN.

    interface FastEthernet0/0
     description Catalyst 3500 Branch Office Switch
     no ip address
     no ip mroute-cache
     load-interval 30
     speed 100
     full-duplex
    !
    interface FastEthernet0/0.50
     encapsulation dot1Q 50
     ip address 10.1.50.1 255.255.255.0
     service-policy output output-L3-to-L2
    !
    interface FastEthernet0/0.150
     description native subnet 10.1.150.0 voice
     encapsulation dot1Q 150
     ip address 10.1.150.1 255.255.255.0
     service-policy output output-L3-to-L2
    !
    

Para mais informações, refira o Catalyst 2900 series XL e os Catalyst 3500 Series XL switch.

Configuração do servidor de DHCP no roteador do Cisco ITS

A seguinte etapa é necessária para configurar um servidor DHCP no 3660 Router. Você precisa esta etapa somente se você tem um servidor de DHCP externo, não se seus endereços IP de Um ou Mais Servidores Cisco ICM NT estão configurados estaticamente. O exemplo abaixo mostra um escopo de DHCP para os Telefones IP e para outros dispositivos no outro VLAN.

ip dhcp excluded-address 10.1.50.1 10.1.50.10
ip dhcp excluded-address 10.1.150.1 10.1.150.10
!
ip dhcp pool ip-phones
 network 10.1.150.0 255.255.255.0  

!--- This defines the range of IP addresses to be assigned.

 default-router 10.1.150.1
 option 150 ip 10.1.150.1   

!--- This must be the IP address of the ITS router.  

!
ip dhcp pool Data-clients
 network 10.1.50.0 255.255.255.128
 default-router 10.1.50.1 
 domain-name cisco.com
 dns-server 10.1.50.100 
 netbios-name-server 10.1.50.100 
!

Nota: Se você quer permitir o DHCP somente para dispositivos específicos, você pode criar um escopo de DHCP com o comando host (em vez de um comando network, como mostrado acima). Você deve igualmente configurar um cliente-identificador e um endereço do hardware para o telefone IP que você deseja dar um endereço IP de Um ou Mais Servidores Cisco ICM NT a. Para o identificador de cliente, é necessário especificar 01 + endereço MAC do telefone, e o endereço do hardware deve conter o endereço MAC do telefone como parâmetro.

Para mais informações, refira o servidor de DHCP IOS Cisco.

Cronometre a configuração no roteador do Cisco ITS

Se os telefones IP receberem sua configuração de data/hora do Cisco ITS Router, é importante assegurar que o relógio do roteador seja ajustado corretamente. É altamente recomendado que você configura o NTP, se possível. Especifique a zona de hora (fuso horário) e, caso necessário, o tempo do horário de verão, e configurar o servidor de NTP. Um exemplo é mostrado abaixo.

its-router(config)# clock time EST -5
its-router(config)# clock summer-time EST recurring 
its-router(config)# ntp server 172.18.106.15

Para obter mais informações sobre NTP, consulte Performing Basic System Management.

Configuração do Cisco ITS nos 3660

Configuração básica

A seguinte configuração deve ser incorporada para configurar o Cisco ITS nos 3660:

telephony-service
 load 7910 P004G302       

!--- This is the load file minus the .bin extension. 
!--- Only the 7910, 7940/7960, and 7935 IP Phones are supported.


 load 7960-7940 P003G302  

!--- This is the load file minus the .bin extension.

 ip source-address 10.1.150.1 port 2000  

!--- This is the ip address of the Cisco ITS router on the voice subnet.

 max-ephones 48  

!--- This is the total number of phones that will be allowed to register.
!--- The maximum varies by platform and sometimes by software level.


 max-dn 192      

!--- This is the maximum number of directory numbers that can be configured 
!--- on this gateway (maximum varies by platform and sometimes by software level).

 voicemail 52222 

!--- This is the number that will be dialed when the "Messages" 
!--- button is pressed on the phone (optional).

!

A maioria dos comandos remaining são opcionais. Únicos imperativos são as indicações da “carga” (não que são necessários para todos os telefones), que são os comandos ip source-address, max-ephones, e max-dn.

Nota: O roteador do Cisco ITS é projetado trabalhar mais cedo com arquivos da carga das versões do CallManager da Cisco de 3.1; por exemplo, arquivos da carga que obtêm sua configuração do arquivo do SEPDEFAULT.cnf, um pouco do que de um arquivo XML. Certifique-se que este comando está na configuração:

tftp-server 
  flash:XMLDefault.cnf.xml

Outras opções do telefonia-serviço são mostradas no exemplo seguinte:

Its-router(config-telephony)# telephony-service
its-router(config-telephony)# ? 
  Cisco IOS Telephony Service configuration commands:
  admin-password      define password for admin user
  admin-username      define username for admin user
  date-format         Set date format for IP Phone display 
  default             Set a command to its defaults
  dialplan-pattern    Define E.164 telephone number prefix
  directory           Define directory naming order
  dn-webedit          enable Edit DN through Web
  exit                Exit from telephony-service configuration mode
  ip                  Define IP address and port for Telephony-Service/Fallback
  keepalive           Define keepalive timeout period to unregister IP phones
  load                Select the IP phone firmware load file
  max-conferences     Define max number of 3 party G.711 conferences
  max-dn              Maximum directory numbers supported 
  max-ephones         Define max number of IP phones
  moh                 Define music-on-hold filename
  mwi                 Define IP address and port for MWI Server
  no                  Negate a command or set its defaults
  reset               reset ethernet phone
  time-format         Set time format for IP Phone display 
  time-webedit        enable Edit Time through Web
  timeouts            Define timeout value for IP phone
  transfer-pattern    Define valid call transfer destinations
  url                 Define Ephone URL's
  voicemail           Set the voicemail access number called when the MESSAGES IP
                      phone button is pressed

its-router(config-telephony)#

cuidado Cuidado: Muitas das mudanças ao serviço de telefonia, tal como a mudança da data ou do formato de período, exigem os telefones restaurar. Algumas opções, tais como a mudança dos MAX-ephones ou dos ajustes do dn máx, exigem um recarregamento de roteador completo. Para restaurar todos os telefones, digite o seguinte:

its-router(config-telephony)# telephony-service
its-router(config-telephony)# reset all

Algumas destas opções serão discutidas nas seguintes seções; outro podem ser encontrados com referência à versão 2.01 do Cisco IOS Telephony Service.

Configuração de TFTP em SEU roteador

Siga as etapas abaixo para configurar o TFTP em SEU roteador.

  1. Certifique-se de que todos os arquivos estiveram transferidos corretamente ao flash do roteador. Pelo menos, os arquivos P003G302.bin da carga e P004G302.bin devem ser carregados. Uma vez que carregado, o flash deve assemelhar-se ao exemplo seguinte:

    Its-router# show flash
    System flash directory:
    File Length    Name/status
    1    16084816  c3660-is-mz.122-11.T 
    2    229542    admin_user.html 
    3    42484     en_dest_busy.au 
    4    26376     en_dest_unreachable.au 
    5    14352     en_disconnect.au 
    6    19512     en_enter_dest.au 
    7    17167     en_reenter_dest.au 
    8    17486     en_welcome.au 
    9    4152      ephone_admin.html 
    10   5968      its_Cisco.2.0.0.0.tcl 
    11   29092     logohome.gif 
    12   496521    music-on-hold.au 
    13   35138     normal_user.html 
    14   268008    P003G302.bin 
    15   258360    P004G302.bin 
    16   522       telephony_service.html 
    17   54        SEPDEFAULT.cnf     
    
    !--- This file will not show up until telephony-service is configured.
    
    18   249       XMLDefault.cnf.xml 
    
    !--- This file will not show up until telephony-service is configured.
    
    [17551227 bytes used, 49033349 available, 66584576 total]
    65536K bytes of processor board System flash (Read/Write)
    
    its-router#
    
  2. Na configuração, você deve permitir que os Telefones IP transfiram os arquivos da carga pelo TFTP do roteador do Cisco ITS. Observe que esses nomes de arquivo fazem distinção entre letras maiúsculas e minúsculas.

    tftp-server flash:P003G302.bin
    tftp-server flash:P004G302.bin
    tftp-server flash:SEPDEFAULT.cnf
    tftp-server flash:XMLDefault.cnf.xml
    
  3. Os arquivos do SEPDEFAULT.cnf e do XMLDefault.cnf.xml são criados automaticamente uma vez que o commandsare do telefonia-serviço e do fonte-endereço IP emitiu.

  4. O arquivo do XMLDefault.cnf.xml contém o endereço IP de Um ou Mais Servidores Cisco ICM NT de uma das portas Ethernet do roteador a que o adaptador ATA deve se registrar. Estes arquivos são específicos ao roteador e não podem ser compartilhados por roteadores múltiplos.

Configuração de telefone IP em SEU roteador

Siga as etapas abaixo para configurar Telefones IP em SEU roteador.

  1. Nesse ponto, se os telefones IP estiverem conectados e tiverem recebido um endereço DHCP, eles poderão ser registrados com o roteador Cisco ITS. Eles não terão nenhuma linha configurada. Você pode verificar que os telefones estão registrados emitindo o comando show ephone e olhando a saída, que deve se assemelhar ao seguinte:

    its-router# show ephone
    ephone-1 Mac:0006.D74B.0F46 TCP socket:[1] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.10 50568 Telecaster 7960 keepalive 889 max_line 6
    
    
    ephone-2 Mac:0006.D74B.1361 TCP socket:[2] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.11 52397 Telecaster 7960 keepalive 872 max_line 6
    
    
    ephone-3 Mac:0006.D74B.107C TCP socket:[3] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.12 51116 Telecaster 7960 keepalive 871 max_line 6
    
    
    ephone-4 Mac:0008.E31B.7A8A TCP socket:[5] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.13 50321 Telecaster 7960 keepalive 867 max_line 6
    
    its-router#
  2. Você pode agora configurar estes telefones com o CLI ou com a administração de web. (Refira a administração de web configurando da seção de roteador do Cisco ITS deste documento.) Alguma informação de configuração especial está disponível para o telefone IP do Cisco 7910 na configuração do Cisco ITS para a seção de 7910 telefones IP.

    !
    ephone-dn 1
     number 1000
     name George P Burdell
     call-forward noan 52222 timeout 10
     no huntstop
    !
    ! 
    ephone-dn 2
     number 1000
     name George P Burdell
     preference 1
     call-forward busy 52222
     call-forward noan 52222 timeout 10
    !
    !
    ephone-dn 10
     number 1111
     name Helpdesk
     no huntstop
    !
    !
    ephone-dn 11
     number 1111
     name Helpdesk
     preference 1
    !
    !
    ephone-dn 12
     number 1111
     name Helpdesk
     preference 2
    !
    !
    ephone-dn 13
     number 1111
     name Helpdesk
     preference 3
    !
    
  3. Cada ephone-dn representa uma linha. Você pode atribuir as linhas aos telefones múltiplos, se desejado. Neste exemplo, um usuário foi configurado quem tem a extensão 1000 em duas linhas. Uma linha do serviço de informações, que fosse um grupo de buscas de quatro linhas, foi adicionada também. Agora, configure os ephones, que designam as linhas para os dispositivos telefônicos reais.

    !
    ephone 1
     username "gpburdell" password letmein
     mac-address 0006.D74B.0F46
     button 1:10 2:11 3:12 4:13 5:1 6:2
    !
    !
    !
    ephone 2
     Mac-address 0006.D74B.1361
     button 1:15 2:10 3:11 4:12 5:13
     speed-dial 1 1000
    !
    
  4. As etiquetas do botão consultam de volta às etiquetas do ephone-dn. A saída do comando show ephone deve assemelhar-se à saída abaixo.

    its-router# show ephone
    ephone-1 Mac:0006.D74B.0F46 TCP socket:[3] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.14 52311 Telecaster 7960 keepalive 6 max_line 6
    button 1: dn 10 number 1111 IDLE 
    button 2: dn 11 number 1111 IDLE 
    button 3: dn 12 number 1111 IDLE 
    button 4: dn 13 number 1111 IDLE 
    button 5: dn 1 number 1000 IDLE 
    button 6: dn 2 number 1000 IDLE 
    Username: gpburdell Password: letmein 
    
    
    ephone-2 Mac:0006.D74B.1361 TCP socket:[2] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.11 50512 Telecaster 7960 keepalive 7 max_line 6
    button 1: dn 15 number 1001 IDLE 
    button 2: dn 10 number 1111 IDLE 
    button 3: dn 11 number 1111 IDLE 
    button 4: dn 12 number 1111 IDLE 
    button 5: dn 13 number 1111 IDLE 
    speed dial 1:1000
    
    its-router#
    Ephone 1 Ephone 2
    Linha 1 1111 Linha 1 1001
    Linha 2 1111 Linha 2 1111
    Linha 3 1111 Linha 3 1111
    Linha 4 1111 Linha 4 1111
    Linha 5 1000 Linha 5 1111
    Linha 6 1000 Linha 6 George P Burdell

  5. Quando um atendimento entra a 1111, soa até que alguém o pegare (nenhum encaminhamento de chamada configurado). Se o ephone-dn 10 (linha 1 no ephone 1 ou linha 2 no ephone 2) está no uso, a seguir o atendimento seguinte a 1111 vai automaticamente ao ephone-dn 10, porque nenhum huntstop é configurado e a preferência é mais alta (a preferência do padrão é 0). Se as preferências eram as mesmas, a seguir ambas as linhas soariam.

  6. Se um atendimento está colocado a 1000 e ninguém pegara, rolará ao correio de voz (extensão 5222 neste encaminhamento de chamada setup). Se o ephone-dn 1 está no uso, o atendimento seguinte obtém roteado ao ephone-dn 2. Isto é devido ao roteamento de dial peer regular e ao fato de que nenhum huntstop está configurado. Não é necessário ter uma configuração de encaminhamento se ocupado neste caso, a menos que você quiser o atendimento enviar completamente a um DN diferente quando ocupado (por exemplo, se 1000 são ocupados, envie então a 1001). No ephone-dn 2, você deve configurar o encaminhamento de chamada para ocupado e sem resposta, porque não há nenhuma outra extensão 1000 com uma preferência maior a distribuir a (mesmo se havia, você tem o huntstop configurado implicitamente, assim que o atendimento terminaria lá).

Para obter mais informações sobre do roteamento normal de dial peer, refira o apoio de tecnologia de voz.

Ephone 1 igualmente tem um nome de usuário e senha para o “gpburdell.” Isto permitirá que o usuário alcance e o início de uma sessão ao mesmo página da web de telephony_service.html e mude sua transmissão (ocupada, sem resposta, tudo) e seletores da velocidade, assim como executa pesquisas de diretório local.

Ephone 2 tem um seletor da velocidade na linha 6. Se esse botão é pressionado, 1001 disca 1000. O comando speed-dial próprio não especifica o lugar do botão. Diz, neste caso, que a primeira linha livre será um seletor da velocidade para numerar 1000. O fato de que é a linha 6 não está diretamente configurado. Se um outro seletor da velocidade foi configurado (a “velocidade disca 2 1004," por exemplo), não geraria um erro, mas não indicaria, tampouco.

Alguns outros comandos configuration para o Ephone-dns alistado abaixo.

its-router(config-ephone-dn)# ?
Ephone DN configuration commands:
  application   The selected application
  call-forward  Define E.164 telephone number for call forwarding
  caller-id     Configure port caller id parameters
  cor           Class of Restriction on dial-peer for this dn
  default       Set a command to its defaults
  description   dn desc, for DN Qualified Display Name
  exit          Exit from ephone-dn configuration mode
  hold-alert    Set Call On-Hold timeout alert parameters
  huntstop      Stop hunting on Dial-Peers
  intercom      Define intercom/auto-call extension number
  loopback-dn   Define dn-tag to create loopback dn pair with this ephone-dn
  mwi           set message waiting indicator options (mwi)
  name          Define dn user name
  no            Negate a command or set its defaults
  number        Define E.164 telephone number 
  paging        set audio paging mode
  preference    Preference for the attached dial-peer for the primary dn number
  translate     Translation rule

its-router(config-ephone-dn)#

Abaixo estão exibidos outros comandos de configurações para ephones.

Its-router(config-ephone-dn)# ephone 1
its-router(config-ephone)# ?
Ethernet phone configuration commands:
  button        define button to dn map
  default       Set a command to its defaults
  exit          Exit from ephone configuration mode
  Mac-address   define ethernet phone MAC address
  no            Negate a command or set its defaults
  paging-dn     set audio paging dn group for phone
  reset         reset ethernet phone
  speed-dial    Define ip-phone speed-dial number
  username      define username to access ethernet phone from Web
  vm-device-id  define voice-mail id string

its-router(config-ephone)#

cuidado Cuidado: Após toda a mudança ao ephone ou ao ephone-dn, os telefones a que as mudanças se aplicam deve ser restaurado. Isto pode ser feito sob o ephone próprio com o comando reset, ou globalmente sob o menu de configuração do telefonia-serviço como descrito mais cedo.

Configuração do Cisco ITS para o telefone IP 7910

Ao contrário do telefone IP 7960, os 7910 têm somente um botão Line Button. À espera e à transferência de chamada de suporte neste telefone, duas linhas são exigidas. Então, para esse telefone, você precisa configurar duas linhas com o mesmo DN, como a seguir:

ephone-dn  20
 number 1020
 no huntstop
!
!
ephone-dn 21
 number 1020
 preference 1
!
...
ephone 10
 button 1:20 2:21
!

Mesmo que estas sejam duas aparências de linha, não é possível colocar ao mesmo tempo both of these linhas na posse. Quando a linha principal está suspensa, pressionar o botão de linha seleciona a segunda linha, e uma segunda chamada pode ser feita (ou respondida). Quando a segunda chamada estiver conectada, o pressionamento do botão hold a colocará em espera e reconectará a linha principal. Pressionar o botão de suspensão novamente alternará entre as linhas principais e secundárias. Pressionar o botão Line Button outra vez desligará o partido atualmente conectado.

Configurando a administração de web do roteador do Cisco ITS

Para administrar corretamente o server do Cisco ITS com a Web, assim como permitir que os utilizadores finais administrem seus telefones com a Web, a seguinte obrigação dos arquivos esta presente no flash:

  • admin_user.html

  • ephone_admin.html

  • logohome.gif

  • normal_user.html

  • telephony_service.html

Para permitir a administração dos página da web com a Web, os seguintes comandos global configuration devem ser inscritos:

ip http server
  ip http path flash

Outros comandos devem ser incorporados sob a seção de configuração do telefonia-serviço.

telephony-service
 admin-username administrator 

 !--- This sets up the administrator account used to access the web page.

 admin-password cisco  

 !--- This sets up the password for the admin account.

 dn-webedit    

 !--- (optional) This permits the editing of DNs through the web interface.

 time-webedit  

 !--- (optional) This permits editing of the system time through the web interface.

!

Para alcançar o roteador do Cisco ITS com a Web, aponte seu navegador à seguinte URL:

http://ITSrouter_ipaddr/telephony_service.html

A URL é a mesma para todos. Outros arquivos de .html são considerados os arquivos internos chamados pelo página da web de telephony-service.html. Chamar outros arquivos diretamente pode conduzir aos erros de javascript. Os usuários que devem usar o página da web devem ser configurados primeiramente no ephone, como mostrado abaixo.

ephone 1
 username "gpburdell" password letmein

O usuário (nestes exemplo, “gpburdell”) pode entrar e mudar sua informação de encaminhamento, executa pesquisas de diretório, e configura mesmo seus próprios ajustes do seletor da velocidade. Há uma ajuda online disponível, também.

Os administradores podem executar o telefone ou o DN adiciona, supressões, e mudanças, assim como algumas alterações de sistema. Note que pode haver uns problemas se você configura com a Web assim como pela linha de comando, porque o página da web não vota a configuração de Cisco IOS Software periodicamente, nem faz o botão Refresh Button na atualização do navegador esta informação. De facto, ao tentar refrescar nessa maneira, você será registrado fora da página GUI e para considerar a “alteração de configuração falhada, a alteração de configuração não é permitida” a caixa de Mensagem de Erro. Somente o botão Update (Atualizar) no menu principal recupera as últimas alterações do roteador Cisco ITS.

Do página da web, o botão da configuração de sistema da escrita faz com que as mudanças sejam escritas imediatamente ao NVRAM. Contudo, para usuários regulares, as mudanças são escritas os minutos cada 10 enquanto não há nenhuma sessão ativa em vty, o console, e linhas auxiliares.

Nota: Para que a atualização trabalhe, para satisfazer certifique-se de que pelo menos quatro linhas vty livres estão disponíveis no Cisco ITS, mesmo que uma linha vty livre seja bastante para mudanças de configuração normal.

As informações do Histórico de Chamada também estão disponíveis para os administradores. Primeiramente deve ser permitida configurando como segue:

call-history-mib retain-timer 500
call-history-mib max-size 500

No máximo, 500 entradas e 500 minutos do histórico da chamada são retidos na tabela MIB.

Você pode ver os registros de chamada escolhendo a configuração de sistema da vista do GUI após a abertura, e então escolhendo a informação de histórico de chamada da vista.

Configurando a conexão de PSTN no roteador Cisco ITS

Supondo que SEU roteador tem placas de interface de voz, você quererá agora configurar aqueles cartões de modo que os atendimentos possam ser colocados a e dos Telefones IP. Isto não é significativamente diferente do que outras conexões de voz em um roteador. Você pode pensar dos ephones com os números que foram atribuídos a cada ephone-dn como portas da estação de câmbio internacional (FXO) no Roteadores.

Configurando outros recursos de ITS

Configuração dos recursos de contenção

Um recurso adicional para chamadores exteriores é música na posse (MoH) /Tone na posse (ToH). ToH é sempre sobre à revelia e não pode ser desabilitado. MoH pode ser fornecido à rede telefônica pública comutada (PSTN) ou às chamadas on-net de G.711 que são colocadas na posse. Chama do telefone IP ao telefone IP em mesmo SEU roteador que é colocado na posse ouve sempre somente o sinal acústico de ToH. Para MoH, após ter-se certificado de que o arquivo de áudio existe no flash, configurar como segue:

telephony-service
 moh music-on-hold.au

O .au ou o arquivo do .WAV jogado para MoH precisam de estar no G.711u-law ou no formato do a-law. A fim distinguir a espera de chamada do ToH, o tom de espera de chamada é ouvido como sinais acústicos periódicos, com um intervalo dos segundos 10 entre sinais acústicos. Se há umas múltiplas linhas de espera de chamada, simplesmente um tom está enviado os segundos cada 10. O ToH, contudo, é ouvido em intervalos periódicos de cada 8 segundos e consiste em três sinais acústicos (um único tom repetido três vezes). ToH toma a precedência superior do que o tom de espera de chamada. Se ambos os tons forem jogados exatamente no mesmo tempo, um usuário ouvirá o ToH primeiramente, então em 8 segundos, em um outro ToH, e finalmente em dois mais segundos, um tom de espera de chamada.

Os atendimentos são colocados uma vez na posse, lá são diversas opções, mostradas abaixo, para enviar notificações audíveis aos usuários que um atendimento é ainda sobre posse.

Its-router(config-ephone-dn)# hold-alert 15 ?
  idle        alert on-hold originator only if idle
  originator  alert on-hold originator always
  shared      alert all phones that share the line

Um alerta do anel do segundo no intervalo configurado (cada 15 a 300 segundos) pode ser configurado para ser enviado sempre ao partido que colocou a posse chamar, ou para ser enviado somente se esse partido é inativo. Uma outra opção é configurar o alerta a ser enviado a todos os telefones que compartilham da mesma linha. A configuração padrão é para não alerta, não importa como um atendimento tem estado por muito tempo na posse.

Configuração da Conferência

As Conferências tripartidos estão apoiadas enquanto os partidos são todos os usuários de G.711 e os recursos de conferência estão disponíveis. Os recursos de conferência são configurados como segue:

telephony-service
 max-conferences 10

Se um dos partidos em uma conferência pressiona a posse, outros dois partidos ouvirão o MoH ou o ToH. Contudo, igualmente poderão falar entre si, com a música ou o tom que jogam no fundo.

Configuração de transferência

A função de transferir chamadas recebidas normalmente exige configuração adicional. Por padrão, os telefones IP registrados no Cisco ITS podem transferir outros telefones IP registrados no mesmo roteador ITS. Outras transferências, ao PSTN ou aos destinos voip, são negadas. Para permitir estes tipos de transferências, os transferência-testes padrões devem ser configurados sob o telefonia-serviço como segue:

Telephony-service
 transfer-pattern 9.......

Agora, supondo que há um dial-peer dos potenciômetros para distribuir os atendimentos ao PSTN, um telefone IP pode agora transferir atendimentos a todo o número da sete dígitos discando 9 primeiramente. Não há opção de toque de discagem secundário com o ITS.

cuidado Cuidado: Seja especialmente cauteloso quando as chamadas de transferência que entraram por uma porta do escritório de câmbio internacional (FXO) em SEU roteador e saíram por uma outra porta FXO, porque esta pode fazer com que ambas as portas permaneçam no uso mesmo depois que ambos os partidos penduraram acima. Refira a compreensão do problema da disconexão FXO. Se seu fornecedor não pode apoiar um formulário da supervisão de desconexão com FXO, a seguir não permita transferências de volta ao PSTN.

Para transferir/encaminhar as chamadas que são recebidas de outro destino VoIP (como um outro roteador ITS), um loopback-dn é necessário. Este é um tópico avançado fora do âmbito deste documento.

Configuração de intercomunicação

A característica do intercomunicador permite uma característica da imprensa-à-conversa entre dois Telefones IP. Não é suportado em linhas compartilhados, o que significa que um ephone-dn configurado para operação de intercom deve estar associado apenas a um telefone IP.

!
ephone-dn 30
number A1234
name "Intercom"
intercom A4321 label "Office A"
!
!
ephone-dn 31
number A4321
name "Intercom"
intercom A1234 label "Office B"
!
...
!
ephone 3
Mac-address 0006.D74B.107C
button 1:16 6:30
!
!
!
ephone 4
Mac-address 0008.E31B.7A8A
button 1:17 6:31
!

Agora, quando o ephone 4 pressiona a linha 6, um atendimento é colocado para alinhar 6 do ephone 3 (por exemplo, chama o A1234 automaticamente). À revelia, se o telefone de destino é em-gancho, a seguir vai fora-gancho, vai ao modo do orador, e abafa seu microfone. As outras opções do comando intercom são barge-in e no-auto-answer. A opção do interceptar permite que a chamada de intercomunicação de entrada force uma chamada existente no estado de posse. O telefone responde então à chamada de intercomunicação imediatamente. A opção do No-auto-answer faz com que a chamada de intercomunicação soe simplesmente, em vez automaticamente de ser pegarado.

Com todas as chamadas de intercomunicação, a etiqueta configurada com a declaração de intercomunicação aparece no lado direito do indicador, bem como um seletor da velocidade. Sem a opção de rótulo, o nome (se configurado no ephone-dn) aparece no lado esquerdo da linha exibida, enquanto o número intercom é exibido à direita.

Nota: Cisco não recomenda o uso do Cisco 7910 para a funcionalidade de intercomunicação, porque o telefone não tem um microfone e o orador não pode ser unmuted, assim que o monofone deve ser escolhido até a resposta.

Paginando a configuração

A característica da paginação trabalha bem como a característica do intercomunicador descrita previamente, salvo que fornece somente um córrego da voz de sentido único sem a opção da imprensa-à-resposta. Somente os telefones inativos são alcançados paginando; os telefones no uso não receberão a página. Paginar apoia a distribuição audio usando o unicast, o Multicast (até dez dispositivos), ou ambos (de modo que o áudio pode alcançar os telefones que não podem ser alcançados com o Multicast). A paginação do Multicast é recomendada. Cada extensão da paginação exige um endereço IP Multicast original.

Por exemplo, diga que três grupos de paginação estão criados: “Pessoa fresco,” “pessoas ultrapassadas,” e “todas as pessoas,” que é simplesmente a soma dos primeiros dois grupos. O Multicast é o método de entrega audio, assim que você configuraria o seguinte:

!
ephone-dn 40
 number 4001
 name "Cool People"
 paging ip 239.0.1.20 port 2000
!
!
ephone-dn 41
 number 4002
 name "Uncool People"
 paging ip 239.0.1.21 port 2000
! 
!
ephone-dn 42
 number 4000
 name "All People"
 paging ip 239.0.1.22 port 2000
 paging group 40,41
!

Nota: Os Telefones IP não apoiam o Multicast nos endereços 224.x.x.x.

Agora configurar e atribua cada ephone a um DN de paginação como mostrado abaixo (configuração adicional em cada ephone omitido). Recorde que cada telefone IP pode pertencer a somente um grupo de paginação. Também, o ephone-dn configurado paginando não deve ser atribuído a um botão Phone Button.

!
ephone 1
 paging-dn 40
!
ephone 2
 paging-dn 40
!
ephone 3
 paging-dn 41
!
ephone 4
 paging-dn 41
!
ephone 5
 paging-dn 42
!

Com esta configuração, você atribuiu a paginação número 4001 (“povos frescos”) aos ephones 1 e 2, a paginação número 4002 (“pessoas ultrapassadas”) aos ephones 3 e 4, e a paginação número 4000 (“todas as pessoas”) aos ephones 1 ao 5.

Qualquer atendimento a 4001 conecta aos ephones 1 e 2 (se não são ocupados) por exemplo.

Nota: O paging é suportado em no máximo um salto de roteador de distância do roteador de ITS.

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Os comandos show telephony-service alistados abaixo (especialmente tudo) d-lhe-ão um instantâneo da configuração.

its-router# show telephony-service ?
  admin        Show telephony-service admin username and password
  all          Show telephony-service details
  dial-peer    Show telephony-service dialpeers 
  ephone       Show ephone configuration
  ephone-dn    Show ephone-dn configuration
  voice-port   Show telephony-service voice ports
  |            Output modifiers
<cr>

Os comandos show ephone alistados abaixo dão-lhe o estado atual dos Telefones IP. Na maior parte do tempo, é suficiente mostrar o próprio ephone.

Its-router# show ephone ?
  7910              7910 phone status
  7940              7940 phone status
  7960              7960 phone status
  H.H.H             mac address
  dn                Dn with tag assigned
  offhook           Offhook phone status
  registered        Registered ephone status
  remote            non-local phones (with no arp entry)
  ringing           Ringing phone status
  summary           Summary of all ephone
  tapiclients       Ephone status of tapi client
  telephone-number  Telephone number assigned
  unregistered      Unregistered ephone status
  |                 Output modifiers
  <cr>

A saída do comando show ephone-dn olhará muito similar à saída do comando show voice port. Para problemas mais comuns, este comando não é tão útil quanto algumas das outras ferramentas.

Its-router# show ephone-dn ? 
  <1-960>   dn tag
  loopback  Show ephone-dn in loopback mode
  summary   Summary of all ephone-dn
  |         Output modifiers
  <cr>

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos debug, consulte Informações importantes sobre comandos debug.

O Cisco ITS tem alguns comandos adicionais de Troubleshooting e depurações que podem facilitar a coleta de informações.

Há alguns debuga que podem ser úteis ao pesquisar defeitos problemas. O comando debug ephone é o único comando Seu-específico de Cisco no que respeita.

Its-router# debug ephone ?
  alarm       Enable ephone alarm message debugging
  detail      Enable ephone detail debugging
  error       Enable ephone error debugging
  keepalive   Enable ephone keepalive debugging
  loopback    Enable ephone loopback debugging
  moh         Enable ephone music-on-hold debugging
  mwi         Enable ephone mwi debugging
  pak         Enable ephone packet debugging
  raw         Enable ephone raw protocol debugging
  register    Enable ephone registration debugging
  state       Enable ephone state debugging
  statistics  Enable ephone statistics debugging

Para a maioria de situações, ao pesquisar defeitos um problema entre um ou dois telefones, é útil emitir os comandos debug ephone error e debug ephone state, a menos que o problema envolver especificamente o registo, o indicador de espera de mensagem (MWI), ou o MoH. Se houver muitos telefones, o recomendável é limitar a saída só aos endereços MAC importantes. Por exemplo:

its-router# debug ephone state Mac-address 0009.433C.E5EC
EPHONE state debugging is enabled for phone 0009.433C.E5EC

Os problemas tais como a chamada de destinos do voip remoto podem exigir os comandos debug adicionais que são mais gerais a VoIP em roteadores Cisco, tais como os comandos debug voip ccapi inout e debug vtsp all. Os específicos para pesquisar defeitos a sinalização pstn e outros artigos da específica de implementação não são cobertos neste documento. Para obter mais informações, consulte os seguintes documentos:

Está aqui uma saída do comando debug ephone state da amostra para um atendimento desde 1004 a 1002. A porção relevante da saída do comando show ephone é mostrada abaixo.

ephone-3 Mac:0006.D74B.107C TCP socket:[5] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:10.1.150.12 51718 Telecaster 7960 keepalive 92 max_line 6
button 1: dn 16 number 1002 IDLE 


ephone-4 Mac:0008.E31B.7A8A TCP socket:[2] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:10.1.150.13 50396 Telecaster 7960 keepalive 96 max_line 6
button 1: dn 17 number 1004 IDLE

Agora você pode examinar debugar. O mensagem OFFHOOK é considerado, o atendimento é colocado (você não vê os dígitos individuais capturados neste traço), e responde-se. Os mensagens OpenReceive channel são enviados a cada telefone e reconhecidos mais tarde; um mensagem de StartMedia diz a cada telefone que endereço IP de Um ou Mais Servidores Cisco ICM NT e porta para enviar o áudio. No final, a mensagem ONHOOK (No gancho) é exibida.

Its-router# debug ephone state
EPHONE state debugging is enabled
its-router#
Sep 26 18:39:40.837: ephone-4[2]:OFFHOOK
Sep 26 18:39:40.837: ephone-4[2]:SIEZE on activeline 0
Sep 26 18:39:40.837: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsOffHook
Sep 26 18:39:40.837: DN 17 Voice_Mode
Sep 26 18:39:40.837: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=33:DtInsideDialTone onoff=1 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=33:DtInsideDialTone onoff=1 pid=113
Sep 26 18:39:42.349: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:42.853: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.105: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.609: ephone-4[2]:Skinny-to-Skinny call DN 17 to DN 16 instance 1
Sep 26 18:39:43.609: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsRingOut
Sep 26 18:39:43.609: ephone-4[2]:Call Info DN 17 line 1 ref 52 called 1002 calling 1004 
origcalled calltype 2
Sep 26 18:39:43.609: ephone-4[2]: John Doe calling 
Sep 26 18:39:43.609: ephone-4[2]: Jane Doe
Sep 26 18:39:43.609: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.609: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsRingIn
Sep 26 18:39:43.613: ephone-3[5]:Call Info DN 16 line 1 ref 53 called 1002 calling 1004 
origcalled calltype 1
Sep 26 18:39:43.613: ephone-3[5]: John Doe calling 
Sep 26 18:39:43.613: ephone-3[5]: Jane Doe
Sep 26 18:39:43.613: ephone-3[5]:Ringer Inside Ring On
Sep 26 18:39:43.613: dn_tone_control DN=17 tonetype=36:DtAlertingTone onoff=1 pid=113
Sep 26 18:39:51.926: ephone-3[5]:OFFHOOK
Sep 26 18:39:51.926: ephone-3[5]:Ringer Off
Sep 26 18:39:51.926: ephone-3[5]:ANSWER call
Sep 26 18:39:51.926: ephone-3[5]:Answer Incoming call from ephone-(4) DN 17
Sep 26 18:39:51.926: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsConnected
Sep 26 18:39:51.926: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsConnected
Sep 26 18:39:51.926: ephone-4[2]:OpenReceive DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:51.926: ephone-3[5]:OpenReceive DN 16 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:51.926: dn_tone_control DN=16 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:51.930: DN 17 End Voice_Mode
Sep 26 18:39:51.930: DN 17 Voice_Mode
Sep 26 18:39:51.930: DN 16 Voice_Mode
Sep 26 18:39:51.930: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:52.182: ephone-4[2]:OpenReceiveChannelAck:IP 10.1.150.13, port=23094, 
dn_index=17, dn=17
Sep 26 18:39:52.182: ephone-3[5]:StartMedia 10.1.150.13 port=23094
Sep 26 18:39:52.182: DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:52.182: ephone-3[5]:OpenReceiveChannelAck:IP 10.1.150.12, port=22778, 
dn_index=16, dn=16
Sep 26 18:39:52.182: ephone-4[2]:StartMedia 10.1.150.12 port=22778
Sep 26 18:39:52.182: DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:40:01.254: ephone-3[5]:ONHOOK
Sep 26 18:40:01.254: ephone-4[2]:CloseReceive
Sep 26 18:40:01.254: ephone-4[2]:StopMedia
Sep 26 18:40:01.254: ephone-3[5]:call clean up this DN 16 was called by other DN 17
Sep 26 18:40:01.254: this ephone-3 other ephone-(4) other DN state CONNECTED
Sep 26 18:40:01.254: ephone-3[5]:CloseReceive
Sep 26 18:40:01.254: ephone-3[5]:StopMedia
Sep 26 18:40:01.254: DN 16 End Voice_Mode
Sep 26 18:40:01.254: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsOnHook
Sep 26 18:40:01.254: ephone-3[5]:SpeakerPhoneOnHook
Sep 26 18:40:01.254: DN 17 End Voice_Mode
Sep 26 18:40:01.254: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsOnHook
Sep 26 18:40:01.254: ephone-4[2]:SpeakerPhoneOnHook
Sep 26 18:40:01.258: ephone-3[5]:SpeakerPhoneOnHook
Sep 26 18:40:01.354: DN 16 Voice_Mode
Sep 26 18:40:01.354: DN 16 End Voice_Mode
Sep 26 18:40:01.354: dn_tone_control DN=16 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:40:01.366: SkinnyReportDnState DN 17 ONHOOK
Sep 26 18:40:01.366: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 25100