IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Usos da sobrecarga mordida com IS-IS

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento apresenta o comando de configuração IS-IS set-overload-bit Intermediate System-to-Intermediate System (IS-IS) e como e quando usá-lo com o wait-for-bgp e as palavras-chave de supressão. Ao longo desse documento, o termo Sistema Intermediário (IS) e roteador podem ser alternados.

Pré-requisitos

Requisitos

Os leitores deste documento devem ter um conhecimento básico de:

  • Border Gateway Protocol (BGP) e protocolos de roteamento IS-IS.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 12.1(9) do ½ do ¿  de Cisco IOSïÂ

  • Cisco 2500 e 3600 Series Router

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Uso tradicional do bit de sobrecarga

Quando um roteador ficar sem recursos do sistema (memória ou CPU), ele não conseguirá armazenar o banco de dados de estados de link nem conseguirá executar o Shortest Path First (SPF). Nessa situação, o roteador deve alertar os outros roteadores de sua área, configurando um determinado bit em seus pacotes de link-state (LSP). Quando outros roteadores detectam que esse bit já foi definido, eles não usam esse roteador para o tráfego em trânsito, mas o usam para pacotes destinados às redes e aos prefixos IP conectados diretamente ao roteador sobrecarregado.

No IS-IS, um roteador inunda imediatamente seu próprio LSP antes mesmo de enviar pacotes de PDUs de número de seqüência completo (CSNP). O bit de sobrecarga é, portanto, utilizado para aconselhar o resto da rede para não rotear o tráfego de trânsito por meio do roteador recém-recarregado.

Para cada LSP, o ISO/IEC 10589:1992leavingcisco.com define um bit especial chamado bit da sobrecarga do base de dados LSP. O rascunho menciona a condição sobrecarregada (na seção 7.3.19): Como resultado de erro de configuração da rede ou de determinadas condições transitórias, é possível que haja recursos de memória insuficientes disponíveis para armazenar um PDU de Estado de Link recebido. Quando isso ocorrer, um IS precisará tomar certar medidas para garantir que, se o banco de dados ficar inconsistente com os outros ISs, esses ISs não dependerão do encaminhamento de caminhos por meio do IS sobrecarregado."

Quando um IS está nessa condição, ele define esse bit no fragmento LSP do não pseudonó que ele gera.

Além disso, no rascunho, a seção 7.2.8.1 faz uma nota de que outros ISs não devem usar o IS sobrecarregado IS como roteador em trânsito, mas podem atingir sistemas finais (ESs) diretamente conectados. Durante esse tempo as interfaces conectadas diretamente, bem como os prefixos IP, ainda são alcançáveis. O Cisco IOS não usa a sobrecarga mordida para esta funcionalidade, embora a capacidade para ajustar permanentemente o sobrecarga-bit seja introduzida em IO com identificação de bug Cisco CSCdj18100. Na implementação da Cisco, quando o bit de carga adicional estiver definido, será possível acessar os prefixos IP/interfaces diretamente conectadas.

Uso expandido do bit de sobrecarga

A técnica do bit da sobrecarga IS-IS foi expandida com identificação de bug Cisco CSCdp01872 (clientes registrados somente). Você pode configurar um roteador de forma a anunciar seu LSP com o bit de sobrecarga para uma quantidade especifica de tempo após uma recarga. Quando o temporizador expira, o bit da sobrecarga está cancelado e o LSP re-é inundado.

Essa nova funcionalidade é útil para ISPs (Provedores de serviço da Internet) que executam o BGP (Protocolo de gateway de borda) e o IS-IS para evitar alguns cenários de "buraco negro". A definição do bit de sobrecarga para um intervalo de tempo fixo logo após uma recarga, garante que o roteador não receba tráfego de trânsito enquanto o Routing Protocol ainda for convergente.

A técnica para definição desse bit por um certo período de tempo após um recarregamento é implementada com o uso do comando a seguir. Este comando leva um intervalo de tempo de 5 a 86.400 segundos para o bit de sobrecarga permanecer configurado após a recarga.

router isis
set-overload-bit [on-startup [<timeout> | wait-for-bgp] ]

Por exemplo:

Router(config-router)#set-overload-bit on-startup 3500 wait-for-bgp

!--- Set the overload bit for 5 minutes (default is 10 minutes).

Esta característica igualmente tornou possível configurar um roteador para desabilitar automaticamente a sobrecarga mordida quando o BGP convirgiu. Para mais informações sobre do BGP de espera, veja por favor a fuga de buraco negro transitório do Intermediate System to Intermediate System do RFC3277 (IS-IS)leavingcisco.com .

De acordo com a especificação do BGP, um roteador BGP não precisa enviar manutenções de atividades durante o envio de atualizações. Assim, as manutenções de atividade serão enviadas apenas após todas as atualizações. O BGP está considerado ter convirgido quando o Keepalives é recebido de todos os vizinhos de BGP.

Se as manutenções de atividade de BGP não forem recebidas de todos os vizinhos de BGP, e se wait-for-bgp for configurado, IS-IS desabilitará o bit de sobrecarga depois de 10 minutos.

Os ISP podem querer suprimir determinados prefixos IP do anúncio em próprios LSP do roteador quando o grupo-sobrecarga-bit é configurado. Por exemplo, pode não ser conveniente permitir a propagação de prefixos de IP do Nível 1 para o Nível 2, o que faria do roteador um nó de trânsito para o tráfego de IP.

A identificação de bug Cisco CSCdr98046 (clientes registrados somente) dá mais controle sobre o que acontece quando o o bit da sobrecarga está sendo usado em sua capacidade expandida. Esse aprimoramento permite que um roteador IS-IS Nível 1 - Nível 2 (L1L2) que esteja redistribuindo rotas IP do Nível 1 ao Nível 2 ou do Nível 2 ao Nível 1 continue a anunciar essas rotas distribuídas em seu LSP quando o bit de sobrecarga tiver sido definido.

Usando a palavra-chave da supressão, você pode configurar um roteador L1L2 para redistribuir e anunciar rotas IP do nível 1 no nível 2 ou vice versa mesmo quando o grupo-sobrecarga-bit é configurado. A sintaxe do comando é:

[no] set-overload-bit [on-startup [<n> | wait-for-bgp]] | [suppress [interlevel | external]]

As palavras-chave de internível da supressão dizem o roteador para não anunciar os prefixos IP aprendidos de um outro nível IS-IS se o bit da sobrecarga é ajustado. A palavra-chave externa da supressão diz o roteador para não anunciar os prefixos IP aprendidos de outros protocolos se o bit da sobrecarga é ajustado. O padrão não é suprimir e manter o comportamento da identificação de bug Cisco CSCdp01872 (clientes registrados somente).

A opção suprimir tem efeito apenas quando seu próprio bit de sobrecarga está definido, e não quando ele é recebido ou configurado (por exemplo, você poderia ter definido o bit de sobrecarga na inicialização e o bit não estar definido).

router isis
set-overload-bit on-startup 40 suppress interlevel

No caso acima, o bit da sobrecarga não é ajustado realmente até que o roteador esteja recarregado, e assim que você deve continuar a escapar prefixos IP entre níveis. Quando você recarrega e ajusta realmente o bit, você deve suprimir os anúncios de nível intermediário.

Exemplo de configuração

O diagrama de rede a seguir é utilizado para demonstrar o comando set-overload-bit e as opções wait-for-bgp e suppress.

/image/gif/paws/24509/TOPO.gif

Aqui está a configuração contendo a opção wait-for-bgp no Roteador 2.

Configuração do roteador 2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0/0
ip address 135.8.1.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet0/0 
!--- and enables IS-IS for IP on the interface.

!
!
interface Ethernet1/0
ip address 135.8.2.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet1/0 
!--- and enables IS-IS for IP on the interface.

!
!
router isis
passive-interface Loopback0
net 12.0020.0200.2002.00
set-overload-bit on-startup wait-for-bgp
!

!--- Enables the IS-IS process on the router.
!--- Makes loopback interface passive 
!--- (does not send IS-IS packets on interface).
!--- Assigns area and system ID to router.
!--- Sets the overload bit on startup to wait for BGP
!--- using the default timeout of 10 minutes.

O roteador foi recentemente recarregado e antes que o eBGP convirja, você pode ver que o bit sobrecarregado é configurado no LSP do roteador 2 no banco de dados de nível 1 de IS-IS.

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
r2.00-00              0x00000017   0x2372        284               0/0/1

Abaixo, vemos na saída da atualização de debug isis que o BFP convergiu no roteador 2:

*Mar 1 00:00:51.015 UTC: BGP(0): Revise route installing 1.1.1.1/32 
-> 135.8.1.1 to main IP table

O Roteador 2 agora reconstrói seu LSP Nível 1 porque o BGP foi convergido e o bit de sobrecarga foi limpo. É por isso que você vê "Campos importantes alterados" na saída de debug isis update abaixo.

*Mar 1 00:00:51.087 UTC: ISIS-Upd: Building L1 LSP
*Mar 1 00:00:51.087 UTC: ISIS-Upd: Important fields changed
*Mar 1 00:00:51.087 UTC: ISIS-Upd: Full SPF required

Agora, podemos ver que o Roteador 2 concluiu a sessão de atualização do BGP com o vizinho:

*Mar 1 00:00:52.127 UTC: BGP: 135.8.1.1 initial update completed

Quando olharmos o LSP nível 1 do roteador 2 novamente, veremos que o roteador 2 eliminou o bit de sobrecarga (porque BGP foi convergido) e que o campo LSP Seq Num foi aumentado em 1 (porque um novo LSP foi criado):

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
r2.00-00              0x00000018   0xAD87        287               0/0/0

Eis a configuração do roteador 2 com vazamento de rota L1L2 configurado e o bit de sobrecarga limpo.

Configuração do roteador 2
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255

!--- Creates loopback interface and assigns
!--- IP address to interface Loopback0.

!
interface Ethernet0/0
ip address 135.8.1.1 255.255.255.0
ip router isis 

!--- Assigns IP address to interface Ethernet0/0 
!--- and enables IS-IS for IP on the interface.

!
!
!
interface Ethernet1/0
ip address 135.8.2.1 255.255.255.0
ip router isis 
!

!--- Assigns IP address to interface Ethernet1/0 
!--- and enables IS-IS for IP on the interface.

!
!
router isis 
redistribute static ip metric 11 level-1
redistribute isis ip level-2 into level-1 distribute-list 100
passive-interface Loopback0
net 12.0020.0200.2002.00
!

!--- Enables the IS-IS process on the router.
!--- Configured L2 to L1 route leaking
!--- Makes loopback interface passive
!--- (does not send IS-IS packets on interface).
!--- Assigns area and system ID to router.

!
ip route 200.200.200.200 255.255.255.255 loopback0 

!--- Static route to 200.200.200.200 via loopback0.

access-list 100 permit ip any any

!--- Access list 100 is used to control which route
!--- gets leaked from Level 2 to Level 1.

Observe que o banco de dados de Nível 1 do Roteador 2 mostra que o bit de sobrecarga está limpo no LSP de Nível 1 do Roteador 2.

IS-IS Level-1 LSP r2.00-00        
LSPID       LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL        
r2.00-00 * 0x0000005D   0xC252        180           0/0/0        
Area Address: 12        
NLPID: 0xCC         
Hostname: r2
IP Address: 2.2.2.2
Metric: 10 IP 135.8.2.0 255.255.255.0
Metric: 10 IP 135.8.1.0 255.255.255.0
Metric:  0 IP 2.2.2.2 255.255.255.255
Metric: 10 IS r2.02
Metric: 10 IS r3.01
Metric: 11 IP-External 200.200.200.200 255.255.255.255
Metric:138 IP-Interarea 1.1.1.1 255.255.255.255

Quando observamos as rotas de IP que o roteador 3 está obtendo, vemos que ele obteve o endereço 1.1.1.1 de loopback do roteador 1 da distribuição de rotas L2L1. Observe igualmente que o roteador3 igualmente está recebendo a rota estática redistribuída 200.200.200.0/32.

r3#show ip route isis
200.200.200.0/32 is subnetted, 1 subnets
i L1 200.200.200.200 [115/21] via 135.8.2.2, Ethernet0/0
1.0.0.0/32 is subnetted, 1 subnets
i ia 1.1.1.1 [115/148] via 135.8.2.2, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/10] via 135.8.2.2, Ethernet0/0
135.8.0.0/24 is subnetted, 2 subnets
i L1 135.8.1.0 [115/20] via 135.8.2.2, Ethernet0/0

Agora vamos configurar set-overload-bit no Roteador 2 com a opção de supressão. Nós estaremos suprimindo ambas as rotas internas e externas. Veja abaixo a seqüência dos comandos:

[no] set-overload-bit [on-startup [<n> | wait-for-bgp]] | [suppress [interlevel | external]]

suprima o interlevel impede o roteador dos prefixos da propaganda aprendidos do nível 2. suprimem externo impede a redistribução.

r2(config-router)#set-overload-bit suppress interlevel external

Observando o banco de dados de Nível do Roteador 2, podemos ver que o bit de sobrecarga está agora definido no LSP do Nível 1 do Roteador 2. Tanto o 200.200.200.200/32 e 1.1.1.1/32 foram ultrapassados. Eles não são injetados no banco de dados de Nível 1.

IS-IS Level-1 LSP r2.00-00
LSPID       LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
r2.00-00 * 0x0000005F   0x23C6       266            0/0/1
Area Address: 12
NLPID: 0xCC 
Hostname: r2
IP Address: 2.2.2.2
Metric: 10 IP 135.8.2.0 255.255.255.0
Metric: 10 IP 135.8.1.0 255.255.255.0
Metric: 0 IP 2.2.2.2 255.255.255.255
Metric: 10 IS r2.02
Metric: 10 IS r3.01

Ao habilitar o comando debug isis update-packets no roteador 2, vemos a mensagem "important fields changed" na saída quando são construídos os LSPs de camada 1 e camada 2. Isso indica que o conteúdo do LSP foi alterado. Em outras palavras, recebemos um LSP que tem o bit de sobrecarga definido. Um LSP novo exige um SPF completo ser executado.

*Mar 1 03:16:08.987 UTC: ISIS-Upd: Building L1 LSP
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Important fields changed
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Full SPF required
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Building L2 LSP
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Important fields changed
*Mar 1 03:16:08.987 UTC: ISIS-Upd: Full SPF required
*Mar 1 03:16:09.035 UTC: ISIS-Upd: Sending L1 LSP 0020.0200.2002.00-00, seq 61, ht 299 on Ethernet0/0
*Mar 1 03:16:09.095 UTC: ISIS-Upd: Sending L2 LSP 0020.0200.2002.00-00, seq 65, ht 299 on Ethernet1/0

A tabela de roteamento atualizada do Roteador 3 não inclui mais as redes IP 200.200.200.200 e 1.1.1.1.

r3#show ip route isis
2.0.0.0/32 is subnetted, 1 subnets
i L1 2.2.2.2 [115/10] via 135.8.2.2, Ethernet0/0
135.8.0.0/24 is subnetted, 2 subnets
i L1 135.8.1.0 [115/20] via 135.8.2.2, Ethernet0/0

Informações de DDTS

  • Identificação de bug Cisco CSCdj18100 (clientes registrados somente) - Introduziu a capacidade para ajustar a sobrecarga mordida manualmente.

  • Identificação de bug Cisco CSCdp01872 (clientes registrados somente) - Introduziu a capacidade para ajustar a sobrecarga mordida na partida. Espere até que o BGP sinalize a convergência ou ajuste um temporizador para cancelar o bit da sobrecarga.

  • Identificação de bug Cisco CSCdr98046 (clientes registrados somente) - Um roteador IS-IS L1L2 que esteja redistribuindo rotas IP do nível 1 no nível 2 ou no nível 2 no nível 1 pode continuar a anunciar estas rotas redistribuída em seu LSP quando o bit da sobrecarga foi ajustado.


Informações Relacionadas


Document ID: 24509