Voz : H.323

Compreendendo o Cisco IOS Gatekeeper Call Routing

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (22 Maio 2008) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Os gatekeepers Cisco são usados para agrupar gateways em zonas lógicas e para executar o roteamento de chamada entre elas. Os gateways são responsáveis por decisões do roteamento de borda entre a Rede Telefônica Pública Comutada (PSTN) e a rede H.323. Os gatekeepers Cisco executam o roteamento de chamada central entre dispositivos na rede H.323 e fornecem a administração centralizada do plano de discagem. Sem um gatekeeper Cisco, os endereços IP explícitos para cada gateway de destino teriam que ser configurados no gateway de origem e combinados para um dial-peer de Voz sobre IP (VoIP). Com um gatekeeper Cisco, os gateways consultam o gatekeeper ao tentarem estabelecer chamadas de VoIP com gateways VoIP remotos.

Por exemplo, quando apresentado com um atendimento, o gateway determina se enviá-lo ao trecho de telefonia ou ao pé IP de acordo com seu Plano de discagem. No caso do pé IP, o gateway pergunta o gatekeeper Cisco para selecionar o melhor valor-limite. Então, o gatekeeper Cisco determina se o valor-limite chamado é um dispositivo dentro de sua zona local ou está ficado situado em uma zona remota controlada por um gatekeeper Cisco remoto.

Pré-requisitos

Requisitos

Cisco recomenda que você tem o conhecimento da compreensão H.323 gatekeepers.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco2500, 2600, 3600, 3700, 7200, e Roteadores do MC3810 Series

  • Este documento não é específico a nenhuma versão do ½ do ¿  de Cisco IOSïÂ. Contudo, as configurações neste documento foram testadas no Cisco IOS Software Release 12.2(19). Refira o Software Advisor (clientes registrados somente) para confirmar o conjunto de características do IOS Cisco necessário apoiar a funcionalidade de gatekeeper de H.323.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Mensagens ARQ e LRQ

O pedido de admissão (ARQ) e o Location Request (LRQ) são o registro dois H.225, admissão, as mensagens do estado (RAS) que provocam um porteiro para iniciar o processo de decisão de roteamento de chamada.

  • ARQ — Mensagens da zona local que são enviadas por valores-limite de H.323 (geralmente gateways) ao gatekeeper Cisco. Os porteiros recebem ARQ de um valor-limite se:

    • Um valor-limite da zona local inicia um atendimento. OU

    • Uma permissão do pedido do valor-limite da zona local admitir uma chamada recebida.

    Os porteiros respondem aos mensagens de ARQ com um Admission Confirm (ACF) ou uma mensagem do Admission Reject (ARJ). Se o gatekeeper Cisco é configurado para admitir o atendimento, responde com um mensagem de ACF (que inclui a informação tal como o endereço IP de Um ou Mais Servidores Cisco ICM NT do gateway de destino). Se não, responde com um mensagem de ARJ.

  • LRQ — Estas mensagens são trocadas entre porteiros e usadas para atendimentos da inter-zona (zona remota). Por exemplo, o porteiro A recebe um ARQ de um gateway da zona local que pede a admissão de chamada para um dispositivo da zona remota. O porteiro A envia então um mensagem de LRQ ao porteiro B. Porteiro B que as respostas ao mensagem de LRQ com um lugar a mensagem confirmam (LCF) ou das Location Reject (LRJ), que depende sobre se está configurada para admitir ou rejeitar o pedido da chamada entre áreas e se o recurso pedido está registrado.

Refira a compreensão H.323 gatekeepers: Gatekeeper para fluxo de chamadas de gateway para mais informação.

Mensagens RAS H.225 relacionados
ARQ Pedido de admissão LRQ Location Request
ACF Admission Confirm LCF O lugar confirma
ARJ Admission Reject LRJ Location Reject

Conceitos de configuração importantes: Prefixo de zona e tecnologia

A fim compreender o processo de decisão de roteamento de chamada do gatekeeper Cisco, é essencial compreender a zona e os prefixos de tecnologia. Geralmente (com algumas exceções), o prefixo de zona determina o roteamento a uma zona, visto que o prefixo de tecnologia determina o gateway nessa zona.

Prefixos de zona

Um prefixo de zona é parte do número chamado que identifica a zona a que desconectares de um atendimento. Os prefixos de zona são usados geralmente para associar um código de área a uma zona configurada.

O gatekeeper Cisco determina se um atendimento é distribuído a uma zona remota ou segurado localmente. Por exemplo, de acordo com este excerto de configuração, o porteiro (GK) A para a frente 214 ....... chama ao GK-B. Os atendimentos ao código de área (512) são segurados localmente.

gatekeeper
     zone local GK-A abc.com
     zone remote GK-B abc.com 172.22.2.3 1719
	
!--- The IP address configured above should be the RAS 
 !--- address of the remote gatekeeper.    
 !--- and should be reachable from the local gateway. 
 !--- In order to find out the RAS address on the remote gatekeeper,
 !--- issue the 
show gatekeeper zone status
 command 
 !--- on the remote gateway.
 
     zone prefix GK-B 214.......
     zone prefix GK-A 512.......

Prefixos de tecnologia

Um prefixo de tecnologia é uma característica com base em padrões opcional de H.323, apoiada por Cisco gateway e por porteiros, que permita mais flexibilidade no roteamento de chamada dentro de uma rede voip de H.323. O gatekeeper Cisco usa prefixos de tecnologia para agrupar junto valores-limite do mesmo tipo. Os prefixos de tecnologia podem igualmente ser usados para identificar um tipo, uma classe, ou um pool dos gateways.

Os prefixos de tecnologia do uso dos gatekeeperes Cisco para distribuir atendimentos quando não há nenhum (por um gateway) esse E.164 registrado endereços combinam o número chamado. De fato, este é um cenário comum porque a maioria de Cisco IOS gateway registram somente seu H.323 ID (a menos que têm portas da estação de câmbio internacional (FXO) configuradas). Sem endereços E.164 registrados, o gatekeeper Cisco confia em duas opções para fazer a decisão de roteamento de chamada:

  • Com a opção dos fósforos do prefixo de tecnologia, o gatekeeper Cisco usa o prefixo de tecnologia adicionado no número chamado para selecionar o gateway de destino ou a zona.

  • Com a opção dos prefixos de tecnologia do padrão, o gatekeeper Cisco atribui o gateway padrão distribuindo endereços da chamada não resolvidos. Esta atribuição é baseada no prefixo de tecnologia registrado dos gateways.

Esta tabela resume opções de configuração disponíveis:

No gateway
Interface de voip Este comando registra o Cisco gateway com o prefixo de tecnologia definido. A informação de registro do prefixo de tecnologia é enviada ao gatekeeper Cisco na mensagem da solicitação de registro (RRQ) RAS. Por exemplo:
GWY-B1(config)#interface ethernet 0/0
GWY-B1(config-if)#h323-gateway voip tech-prefix ?
     WORD: A technology prefix that the interface will register
     with the Gatekeeper.
VoIP dial-peer Este comando prepends um prefixo de tecnologia ao número chamado combinado pelo dial-peer. Não é usado para o registro, mas para a configuração de chamada com o gatekeeper Cisco. Por exemplo, o número chamado 5551010 transforma-se 1#5551010.
GWY-B1(config)#dial-peer voice 2 voip
GWY-B1(config-dial-peer)#tech-prefix ?
     WORD: A string.

Nota: O número chamado alterado é enviado igualmente ao gateway de terminação na configuração de chamada. Assegure-se de que o dial peers do serviço de telefonia tradicional (POTS) do gateway de terminação esteja atualizado para terminar o atendimento.

No porteiro
Prefixo de tecnologia do padrão do porteiro Este os conjuntos de comandos registraram gateways com o prefixo de tecnologia especificado como o padrão para os endereços de chamada de roteamento que são não resolvidos. Por exemplo, se a maioria de gateways em sua zona distribuem o mesmo tipo de atendimentos e estão registrados com prefixo de tecnologia 1#, você pode configurar o gatekeeper Cisco para usar 1# como o prefixo de tecnologia do padrão. Consequentemente, é já não necessário que os gateways de origem prepend o número chamado com 1#. Os números chamados sem um prefixo de tecnologia válido são distribuídos a um dos gateways registrados com 1#.
GK-B(config)#gatekeeper
GK-B(config-gk)#gw-type-prefix 1# default-technology

Nota: Se há mais de um gateway padrão, você pode afetar o uso de prioridade de gateway com o comando da GW-prioridade <0-10> do <gk_id> <e.164_pattern> do prefixo de zona.

Zona da desconexão do porteiro As configurações da desconexão são usadas para cancelar a seleção do prefixo de zona e para forçar o atendimento para ser hopped-offed a uma zona especificada, apesar do prefixo de zona do número chamado. Por exemplo, com esta configuração, todos os atendimentos com prefixo de tecnologia 2# serão enviados à zona do GK-A.
GK-B(config)#gatekeeper 
GK-B(config-gk)#gw-type-prefix 2# hopoff GK-A
Registro do prefixo de tecnologia do gateway Estático de Gatekeeper Usado para registrar estaticamente um prefixo de tecnologia para um gateway. Realiza os mesmos resultados no porteiro como a configuração da interface de voip do gateway consegue no gateway. Recomenda-se configurar este nos gateways se você tem um grande número gateways. Geralmente, é mais fácil configurar cada gateway com um prefixo de tecnologia do que para configurar o porteiro com todos os prefixos de tecnologia para cada gateway.
GK-B(config)#gatekeeper 
GK-B(config-gk)#gw-type-prefix 1# gw ipaddr ?
     A.B.C.D  Gateway's call signaling IP address

O algoritmo do Gatekeeper Call Routing / Processo de Decisão

Estes diagramas indicam o processo de decisão do roteamento de chamada de gatekeeper após ter recebido o ARQ e os mensagens de LRQ nos Cisco IOS Software Release antes de 12.4:

gk-call-routing-1.gif

gk-call-routing-2.gif

Roteamento de chamada Pseudônimo-baseado

O roteamento de chamada de gatekeeper mudou no Cisco IOS Software Release 12.4 e Mais Recente. H.323-ID e a harmonização baseada email-ID são executados antes de processar os números do destino E.164 (DNIS). Se qualquer valor-limite é encontrado para ter registrado o H.323-ID/email-ID especificado, a seguir o ACF está enviado. Este diagrama explica o processo de roteamento de chamada pseudônimo-baseado novo:

/image/gif/paws/24462/gk-call-routing-2a.gif

As funções da infraestrutura e do aplicativo de The Voice (ATRAVÉS DE) são melhoras de software à imagem existente do gatekeeper Cisco. Com este realce, o gatekeeper Cisco pode reconhecer dois trechos de chamada na mesma plataforma (gateway IP-à-IP) e igualmente no tráfego do balanceamento de carga através dos gateways IP-à-IP múltiplos, que são incluídos (gateways e porteiros) no predefinido ATRAVÉS da zona. Estes porteiros sentam-se na borda da rede do provedor de serviços da telefonia pelo Internet (ITSP) e são-se como um ponto de transferência de VoIP, ou a zona do trânsito, onde o tráfego voip é canalizado completamente na maneira ao destino da zona remota. Os gateways IP-à-IP no ATRAVÉS da zona terminam chamadas recebidas e reoriginate eles para seus destinos finais. Refira o telecontrole à rede local com os recursos de gateway IP-à-IP multisserviços de Cisco para obter mais informações sobre ATRAVÉS da zona.

/image/gif/paws/24462/gk-call-routing-2b.gif

Nota: Se a invia ou a zona especificada da outvia não estão encontradas nas configurações (isto é não está definida como um local ou a zona remota), a seguir um mensagem de ARJ está enviado.

A fim selecionar um IP-IP GW registrado ao viazone selecionado este algoritmo é usado:

  1. Se um tecnologia-prefixo está encontrado (na harmonização pseudônimo-baseada), olhe através da lista de gateways no viazone especificado que registraram este tecnologia-prefixo.

  2. Se nenhum tecnologia-prefixo é encontrado, olhe através da lista inteira de gateways registrados ao viazone especificado.

  3. Selecione o primeiro IP-IP GW encontrado em etapa 1 ou 2 que tem os recursos disponíveis.

  4. Se todo o IP-IP GW na lista é fora dos recursos, selecione o primeiro IP-IP GW que é encontrado (mesmo que pôde ser fora dos recursos).

  5. Se nenhum IP-IP GW é encontrado, retorne a falha.

Exemplos de chamada de zona local

Nos exemplos fornecidos nesta seção, os dois gateways registram-se com o gatekeeper Cisco com seu H.323 respectivo ID. Além, o A2 do gateway (GWY) registra-se com um endereço E.164. Este diagrama é usado para todos os exemplos nesta seção:

gk-call-routing-3.gif

As três encenações nesta seção explicam o processo de decisão passo a passo os usos do porteiro distribuir atendimentos basearam nos mensagens de ARQ.

Nota: Somente a saída relevante é mostrada nestas captações da configuração.

Cenário 1: Não há prefixos de tecnologia configurados

GK-A
!
gatekeeper
zone local GK-A abc.com
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718 

!--- The IP address configured here should 
!--- be the RAS address of GK-A
!--- and should be reachable from the gateway. 
!--- In order to find out the RAS address,
!--- issue the 
show gatekeeper zone status
 
!--- command on GK-A.
 
h323-gateway voip h323-id GW-A1@abc.com 
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512

!--- On outgoing calls through POTS dial-peers,
!--- all explicit digit matches are dropped, 
!--- which is the reason
!--- for adding the prefix 512. This has nothing to  
!--- do with technology prefixes.

!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras

!--- Uses RAS messages (GK) to get 
!--- call setup information.


!
gateway
!
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718

!--- The IP address configured here  
!--- should be the RAS address of GK-A.
!--- and should be reachable from the gateway. 
!--- In order to find out the RAS address,
!--- issue the 
show gatekeeper zone status

!--- command on GK-A.
 
h323-gateway voip h323-id GW-A2@abc.com
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0

!--- This is the FXS port.

!
gateway
!

Esta saída capturada no GK-A indica os registros reais. A observação GWY-A2 igualmente registra o E.164 ID da porta FXS.

GK-A#show gatekeeper endpoints
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr  Port  RASSignalAddr   Port  Zone Name         Type    F
--------------- ----- --------------- ----- ---------         ----    --
172.22.1.1      1720  172.22.1.1      49317 GK-A              VOIP-GW
    H323-ID: GW-A1@abc.com
172.22.1.2      1720  172.22.1.2      58196 GK-A              VOIP-GW
    E164-ID: 9725551010
    H323-ID: GW-A2@abc.com
Total number of active registrations = 2

Ação da primeira chamada: A2 do usuário dos atendimentos do A1 do usuário em 972-555-1010. Use o diagrama ARQ para terminar o processo de decisão.

O GK-A recebe o ARQ do GWY-A1.

  1. O prefixo de tecnologia combina? Não

  2. O prefixo de zona combina? Não

  3. O comando arq reject-unknown-prefix é ajustado? Não, zona de destino iguala a zona local.

  4. É a zona de destino local? Sim

  5. Um prefixo de tecnologia foi encontrado em etapa 1? Não

  6. O endereço do alvo é registrado? Sim. Envie o ACF.

Configuração de chamada bem sucedida.

Nota: O GWY-A2 tem o destino E.164 ID registrado (porta FXS). Consequentemente, o porteiro podia admitir o atendimento.

Ação da segunda chamada: O A2 do usuário disca 512-555-1212 para chamar o A1 do usuário.

O GK-A recebe o ARQ do GWY-A2.

  1. O prefixo de tecnologia combina? Não

  2. O prefixo de zona combina? Não

  3. O comando arq reject-unknown-prefix é ajustado? Não, a zona de destino iguala a zona local.

  4. É a zona de destino local? Sim

  5. Um prefixo de tecnologia foi encontrado em etapa 1? Não

  6. O endereço do alvo é registrado? Não

  7. O prefixo de tecnologia do padrão é ajustado? Não Envie o ARJ.

Configuração de chamada falhada.

Nota: A encenação 2 explica como fixar este problema do roteamento de chamada com prefixos de tecnologia.

Cenário 2: Prefixos de tecnologia configurados

Nesta encenação, estas alterações de configuração são feitas:

  • GWY-A1 — Adicionou o comando h323-gateway voip tech-prefix 1-. O GWY-A1 registra-se ao GK-A com prefixo de tecnologia 1#.

  • GWY-A1 — Adicionou um POTS dial peer com um comando destination-pattern que combina o número chamado entrante do GWY-A2 com o prefixo de tecnologia 1#.

  • GK-A — Adicionou o comando do GK-A do prefixo de zona. Define os prefixos que da zona local o GK-A controla.

  • GK-A — Adicionou o comando arq reject-unknown-prefix. Isto reforça o GK-A para aceitar somente atendimentos ARQ para prefixos de zona que controla. Na encenação 1, isto não foi configurado. Consequentemente, a zona do alvo foi ajustada à zona local como o padrão.

  • GWY-A2 — Adicionou o comando do tecnologia-prefixo 1# sob a configuração do VoIP dial-peer. Esta maneira, GWY-A2 prepends os dígitos 1# às chamadas VoIP que parte. O GK-A identifica o teste padrão 1# para selecionar o GWY-A1 como o gateway de destino.

GK-A
gatekeeper
zone local GK-A abc.com
zone prefix GK-A 512.......
zone prefix GK-A 972.......
arq reject-unknown-prefix
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1# 
!
dial-peer voice 3 pots
incoming called-number 972.......
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
!
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
tech-prefix 1#
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
!

Esta saída capturada no GK-A indica os prefixos de tecnologia registrados:

GK-A#show gatekeeper gw-type-prefix
        
        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#*
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

Nota: Em vez de configurar GW-A1 com o comando h323-gateway voip tech-prefix 1-, pode ser realizada a mesma maneira manualmente configurando esta informação no GK-A com o comando.

GK-A(config-gk)#gw-type-prefix 1#* gw ipaddr 172.22.1.1

Ação do atendimento: O A2 do usuário disca 512-555-1212 para chamar o A1 do usuário.

O GK-A recebe o ARQ do GWY-A2.

  1. O prefixo de tecnologia combina? Sim

    Nota: Após o fósforo do prefixo de tecnologia, o porteiro descasca-o para analisar o prefixo de zona. Esta tira é executada somente pela análise de gatekeeper. O gateway de origem ainda adiciona-a na configuração de chamada ao gateway de terminação.

  2. O prefixo de zona combina? Sim. Ajuste a zona de destino para igualar a zona local.

  3. Faz o fósforo do nome de pseudônimo (após a tecnologia de descascamento prefixam) com algum GW registrado? Não (se sim, envie o ACF).

  4. É a zona de destino local? Sim

  5. Um prefixo de tecnologia foi encontrado em etapa 1? Sim

  6. Um gateway local com um prefixo de tecnologia foi encontrado? Sim. Envie o ACF.

    Sucesso da configuração de chamada.

Este comando debug do GK-A ilustra o comportamento acima.

Nota: Este comando debug é um útil, mas hidden, debugar. Consequentemente, o parser não mostra debugar.

GK-A#debug gatekeeper main 5
      
    *Jun 19 09:50:10.086: gk_rassrv_arq: arqp=0x631CC400, crv=0x82, answerCall=0
    *Jun 19 09:50:10.086: gk_dns_locate_gk(): No Name servers
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Matched tech-prefix 1#
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Matched zone prefix 512
    *Jun 19 09:50:10.118: gk_rassrv_arq: arqp=0x631CC400, crv=0x1A, answerCall=1

Nota: Esta é uma configuração alternativa que possa ser mais intuitiva:

  • Emita o comando do tecnologia-prefixo 512 do h323-gateway voip a fim configurar o GWY-A1 para registrar-se com prefixo de tecnologia 512.

  • Esta maneira, GWY-A2 não tem que passar o prefixo no trecho de chamada do VoIP dial-peer porque o destino-teste padrão já inclui 512. , Remova consequentemente o comando do tecnologia-prefixo 1# na configuração GWY-A2 e igualmente remova 1# do destino-teste padrão sob o dial peer dos potenciômetros no GWY-A1.

Cenário 3: Prefixos padrão de tecnologia configurados

Nesta encenação, o GWY-A1 registra-se com prefixo de tecnologia 1# e GK-A é configurado para distribuir atendimentos sem um fósforo do prefixo de tecnologia aos gateways do prefixo de tecnologia do padrão. Consequentemente, o GWY-A2 não precisa de ser configurado para passar o prefixo de tecnologia do destino.

GK-A
!
gatekeeper
zone local GK-A abc.com
zone prefix GK-A 512.......
zone prefix GK-A 972.......
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix 
no shutdown
!
GWY-A1 GWY-A2
!
interface Ethernet0/0 
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com 
h323-gateway voip tech-prefix 1# 
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
!
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
!

Esta saída capturada no GK-A indica os prefixos de tecnologia registrados:

GK-A#show gatekeeper gw-type-prefix
        
        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#* (Default gateway-technology)
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

Ação do atendimento: O A2 do usuário disca 512-555-1212 para chamar o A1 do usuário.

O GK-A recebe o ARQ do GWY-A2.

  1. O prefixo de tecnologia combina? Não

  2. O prefixo de zona combina? Sim. Ajuste a zona de destino para igualar a zona local.

  3. É a zona de destino local? Sim

  4. Um prefixo de tecnologia foi encontrado em etapa 1? Não

  5. O endereço do alvo é registrado? Não

  6. O prefixo de tecnologia do padrão é ajustado? Sim. Selecione o gateway local com o prefixo de tecnologia (somente um disponível).

  7. Envie o ACF.

    Configuração de chamada bem sucedida.

Exemplos de chamada de zona remota

Nestes exemplos, há duas zonas de H.323: um controlado pelo GK-A e outro pelo GK-B.

/image/gif/paws/24462/gk-call-routing-4.gif

As encenações nesta seção explicam o processo de decisão passo a passo o uso dos porteiros distribuir atendimentos basearam no ARQ e nos mensagens de LRQ.

Nota: Somente a saída relevante é mostrada nestes exemplos de configuração.

Cenário 1: Gatekeepers de zona configurados com prefixos de tecnologia padrão

Nesta encenação, o GWY-A1 registra-se ao GK-A com registros 1# e GWY-B1 do prefixo de tecnologia ao GK-B com prefixo de tecnologia 2#. Ambos os porteiros são configurados com os gateways do prefixo de tecnologia do padrão.

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com 172.22.1.3
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix
no shutdown
! 
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
gw-type-prefix 2#* default-technology
no shutdown
!
GWY-A1 GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern ..........
session target ras
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
!
gateway
!

Ação do atendimento: O A1 do usuário disca 214-555-1111 para chamar o usuário B1.

O GK-A recebe o ARQ do GWY-A1.

  1. O prefixo de tecnologia combina? Não

  2. O prefixo de zona combina? Sim. Ajuste a zona de destino para igualar a zona remota GK-B (214).

  3. É a zona do alvo local? Não

  4. Envie o LRQ ao GK-B.

O GK-B recebe o LRQ do GK-A.

  1. O prefixo de tecnologia combina? Não

  2. O prefixo de zona combina? Sim. Ajuste a zona de destino para igualar a zona local.

  3. É a zona do alvo local? Sim

  4. Um prefixo de tecnologia foi encontrado em etapa 1? Não

  5. O endereço do alvo é registrado? Não

  6. O prefixo de tecnologia do padrão é ajustado? Sim. Selecione o gateway local com o prefixo de tecnologia (2#).

  7. Envie o LCF ao GK-A.

    O GK-A recebe o LCF do GK-B com informação do gateway de terminação.

    O GK-A envia o ACF ao GWY-A1.

    A configuração de chamada é bem sucedida.

Cenário 2: Gatekeepers da zona configurados sem prefixos de tecnologia padrão

Nesta encenação, o GWY-A1 registra-se ao GK-A com registros 1# e GWY-B1 do prefixo de tecnologia ao GK-B com prefixo de tecnologia 2#. O GWY-A1 adiciona o prefixo de tecnologia 2# à série do número chamado ao fazer chama (a 214) e o GWY-B1 adiciona o prefixo de tecnologia 1# à série do número chamado ao fazer chama a (512).

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
arq reject-unknown-prefix
no shutdown
!
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
no shutdown
!
GWY-A1 GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2# 
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1# 
!
gateway
!

Ação da primeira chamada: O usuário B1 disca 512-555-1212 para chamar o A1 do usuário.

O GK-B recebe o ARQ do GWY-B1.

  1. O prefixo de tecnologia combina? Não

  2. O prefixo de zona combina? Não

    Nota: Porque o GK-B não está ciente de um prefixo de tecnologia 1#, supõe-no que é parte do número chamado e lê como um prefixo de zona.

  3. É a zona do alvo local? Sim

    Nota: O GK-B toma aos iguais da zona do alvo do padrão a zona local porque o comando arq reject-unknown-prefix não é ajustado.

  4. Um prefixo de tecnologia foi encontrado em etapa 1? Não

  5. O endereço do alvo é registrado? Não

  6. O prefixo de tecnologia do padrão é ajustado? Não

  7. Envie o ARJ ao GWY-B1.

    Configuração de chamada falhada.

Esta saída foi capturada no GK-B para ilustrar mais este comportamento:


!--- From debug gatekeeper main 5.

      
GK-B#
gk_rassrv_arq: arqp=0x62F6A7E0, crv=0x22, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Tech-prefix match failed
rassrv_get_addrinfo(1#5125551212): unresolved zone prefix, using source zone GK-B
rassrv_get_addrinfo(1#5125551212): unknown address and no default technology defined
gk_rassrv_sep_arq(): rassrv_get_addrinfo() failed (return code = 0x103)

!--- From debug ras.


GK-B#
RecvUDP_IPSockData successfully rcvd message of length 156 from 172.22.2.1:51141
ARQ (seq# 1796) rcvdparse_arq_nonstd: ARQ Nonstd decode succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 4 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendARJ: ARJ (seq# 1796) sent to 172.22.2.1

Configurar os porteiros para identificar os prefixos de tecnologia da zona remota a fim fixar este problema.

  • Adicionar isto ao GK-B:

    GK-B(config-gk)#gw-type-prefix 1# hopoff GK-A
    
  • Adicionar isto ao GK-A:

    GK-A(config-gk)#gw-type-prefix 2# hopoff GK-B
    

Observe que o POTS dial peer nos gateways de terminação necessários ser atualizado para combinar as séries de discagem entrantes com os prefixos de tecnologia.

GK-A GK-B
!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
arq reject-unknown-prefix
gw-type-prefix 2# hopoff GK-B
no shutdown
!
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
gw-type-prefix 1# hopoff GK-A
no shutdown
!
GK-B GWY-B1
!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!

!--- This dial-peer is used for 
!--- incoming calls from the PSTN.

dial-peer voice 1 pots
incoming called-number 512.......
direct-inward-dial
port 1/0:23
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2# 
!

!--- This dial-peer is used to 
!--- terminate (512) calls coming
!--- from the VoIP network. Notice 
!--- that the technology prefix 
!--- is matched to select the dial-peer 
!--- but does not pass it to 
!--- the PSTN.
 
dial-peer voice 3 pots
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 4 voip
destination-pattern 972.......
session target ras
! 
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
incoming called-number 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1# 
!
dial-peer voice 3 pots
destination-pattern 2#214....... 
port 3/0:23
prefix 214 
! 
gateway
!

Ação da segunda chamada: O usuário B1 disca 512-555-1212 para chamar o A1 do usuário.

O GK-B recebe o ARQ do GWY-B1.

  1. O prefixo de tecnologia combina? Sim

  2. Há um prefixo de tecnologia da desconexão? Sim

  3. Envie o LRQ ao GK-A.

    Nota: O LRQ inclui o prefixo de tecnologia no número chamado para a análise do GK-A.

O GK-A recebe o LRQ do GK-B.

  1. O prefixo de tecnologia combina? Sim

  2. Há um prefixo de tecnologia da desconexão? Não

    Nota: A fim continuar a análise do roteamento de chamada, o GK-A descasca o prefixo de tecnologia. O prefixo de tecnologia permanece na série do número chamado quando os gateways estabelecem os trechos de chamada.

  3. O prefixo de zona combina? Sim. Ajuste a zona de destino para igualar a zona local.

  4. É a zona de destino local? Sim

  5. Um prefixo de tecnologia foi encontrado em etapa 1? Sim

  6. Você encontrou um gateway local com um prefixo de tecnologia? Sim

  7. Envie o LCF ao GK-B.

    O GK-B recebe o LCF do GK-A com informação do gateway de terminação.

    O GK-B envia o ACF ao GWY-B1.

    Configuração de chamada bem sucedida.

Esta saída do comando foi capturada no GK-B para ilustrar mais este comportamento:


!--- From debug gatekeeper main 5.


GK-B#
gk_rassrv_arq: arqp=0x62ED2D68, crv=0x24, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Matched tech-prefix 1#
rassrv_put_remote_zones_from_zone_list() zone GK-A
gk_rassrv_irr: irrp=0x62F0D8FC, from 172.22.2.1:51141
GK-B#
GK-B#

!--- From debug ras.


RecvUDP_IPSockData successfully received message of 
length 156 from 172.22.2.1:51141
ARQ (seq# 1809) rcvdparse_arq_nonstd: ARQ Nonstd decode 
succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 104 from 
172.22.2.3:1719 to 172.22.1.3: 1719
RASLib::RASSendLRQ: LRQ (seq# 1042) sent to 172.22.1.3
IPSOCK_RAS_sendto: msg length 7 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendRIP: RIP (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length 
131 from 172.22.1.3:1719
LCF (seq# 1042) rcvdparse_lcf_nonstd: LCF Nonstd 
decode succeeded, remlen= 131
IPSOCK_RAS_sendto: msg length 34 from 172.22.2.3:1719 
to 172.22.2.1: 51141
RASLib::RASSendACF: ACF (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length 
76 from 172.22.2.1:51141

Comandos de Verificação e Troubleshooting

Esta seção fornece uma lista de comandos show and debug que são usados para verificar e pesquisar defeitos edições do roteamento de chamada do gatekeeper e gateway.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • gateway da mostra — Usado para verificar o registro E.164 e de H.323 aliás para o gateway.

  • mostre valores-limite do porteiro — Usado para verificar o E.164 e H.323 registrou-se aliás com o porteiro.

  • mostre o GW-tipo-prefixo do porteiro — Usado para verificar registros do prefixo E.164 no porteiro.

  • mostre o prefixo da zona de gatekeeper | estado — Usado para verificar o estado e os parâmetros de configuração da zona.

  • debugar ras — Aplicável para gateways e porteiros.

  • debugar o asn1 h225 — Aplicável para gateways e porteiros.

  • voz do dial peer da mostra — Usado para verificar configurou prefixos de tecnologia sob o dial peers.


Informações Relacionadas


Document ID: 24462