Voz : Qualidade de voz

Voz QoS: Marcação do pacote de TOS-CoS para o uso com LLQ

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (22 Maio 2008) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve a Qualidade de Serviço (QoS) para Voice over IP (VoIP) em um ambiente de LAN por meio do mapeamento do Tipo de Serviço (ToS) com a Classe de Serviço (COS).

Até recentemente, o consenso do general era que QoS nunca seria uma edição no lado de empreendimento devido à natureza intermitente do tráfego de rede e à capacidade de excesso de buffer. A razão para QoS no lado LAN é devido à proteção, não falta da largura de banda. Por este motivo, as ferramentas de QoS são exigidas controlar estes bufferes minimizar a perda, o atraso, e a variação de retardo. Transmita bufferes têm uma tendência encher-se à capacidade nas redes de alta velocidade devido à natureza intermitente das redes de dados combinadas com o volume alto de pacotes menores do Transmission Control Protocol (TCP). Se um buffer de saída se enche, as interfaces de ingresso não podem colocar imediatamente o tráfego novo do fluxo no buffer de saída. Uma vez que o buffer de ingresso se enche (pode acontecer rapidamente), as quedas de pacote de informação ocorrem. Isto é o lugar onde a Qualidade de voz pode possivelmente degradar devido à perda de pacotes.

O tráfego voip é sensível aos pacotes atrasados e aos pacotes descartado. O atraso deve nunca ser um fator, apesar do tamanho do buffer de fila, devido à alta velocidade nos links LAN. Contudo, as gotas afetam sempre adversamente a Qualidade de voz em todas as redes. O uso das filas múltiplas em interfaces de transmissão é a única maneira de eliminar o potencial para o tráfego descartado causado pelos bufferes que se operam na capacidade de 100%. A separação de Voz e de vídeo (sensível aos atrasos e às gotas) em suas próprias filas pode impedir que os fluxos estejam deixados cair na interface de ingresso, mesmo se os fluxos de dados enchem acima os dados transmitem o buffer.

Nas redes com altas cargas de tráfego, é crítico controlar a entrega do tráfego de controle assegurar uma experiência positiva do usuário com VoIP. Isto é ilustrado facilmente. Por exemplo, quando um telefone IP vai fora-gancho, pede ao CallManager da Cisco o que fazer. O CallManager da Cisco instrui então o telefone IP para jogar o tom de discagem. Se o gerenciamento de protocolo de cliente mirrado e o tráfego de controle são deixados cair ou atrasados, a experiência do usuário está afetada adversamente. A fim fornecer QoS, marque cabeçalhos de pacote de informação com uma precedência superior e trace-os corretamente aos cabeçalhos para Catalysts da camada 2 para compreender. Isto assegura a priorização apropriada nos pacotes de voz através do LAN.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware.

  • Gateway de voz do Cisco 3725 com Software Release 12.3(4)T do ½ do ¿  de Cisco IOSïÂ.

  • Catalyst 4000 Switch

  • CallManagers e Telefones IP de Cisco

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama.

/image/gif/paws/23442/tos-cos-1.gif

Configurações

Este documento utiliza estas configurações.

Esta configuração mostra como traçar o ToS/valores do Differentiated Services Code Point (DSCP) em um valor de CoS na porção de cabeçalho 802.1p. Há muitas maneiras de executar isto e as pequenas diferenças variam segundo seu projeto. Os dois exemplos de configuração aqui são equivalentes e qualquer um um pode ser usado para conseguir o mesmo resultado. Seja certo permitir somente os pacotes voip que têm uma Precedência IP de crítico (5) no bit ToS. Nenhum outro tráfego deve ter este jogo do bit a crítico. Isto causa a sobreposição do tráfego não desejado na fila da Voz.

Nota: A configuração LLQ é feita em outros dispositivos na rede tal como o catalizador 4000, que não é discutido neste documento.

Neste primeiro exemplo, somente os córregos RTP que combinam a Precedência IP 5 são etiquetados, e não RTCP ou toda a sinalização H.225/245 e pacotes de transmissão de mensagem.

Cisco 3660 (exemplo 1)
!
ip cef
!

!--- The Cisco Express Forwarding (CEF) mechanism needs to be enabled 
!--- in order for the set cos command that is 
!--- configured later to take effect.
!--- If this is not on, the router reminds you with 
!--- the error "CEF switching needed for 'set' operations".

! 
class-map match-all RTP
match ip precedence 5 

!--- This command matches on all packets with the IP precedence of 5.
 
!
policy-map OutboundPolicy
class RTP
set CoS 5

!--- For all packets which previously matched on class-map RTP for 
!--- having precedence of 5, the CoS bit is now set to 5.

class class-default
set CoS 0

!--- All other traffic has a CoS of 0 and 
!--- carries a lower priority of delivery.

!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.816
encapsulation dot1Q 816

!--- There must be subinterfaces for FastEthernet to enable trunking, 
!--- as well as either dot1q or isl encapsulation.

ip address 10.120.16.112 255.255.255.0
service-policy output OutboundPolicy

!--- Apply the QoS to the interface that connects to the LAN
!--- via the Catalyst 4000.

!
dial-peer voice 99131 voip
destination-pattern 9913109
session target ipv4:10.120.17.133
 ip qos dscp cs5 media
no vad
!

Nota: O comando ip qos dscp foi introduzido no Cisco IOS Software Release 12.2(2)T. Substitui o comando ip precedence (dial-peer). Todo o Roteadores que é executado no Cisco IOS Software Release 12.2(2)T e Anterior pode usar a Precedência IP na configuração de dial peer.

O segundo exemplo tem parâmetros de harmonização diferentes para classes de mapa de política. A configuração do Cisco 3660 combina nos pacotes da configuração de chamada H.225 assim como nos córregos RTP. Os critérios correspondentes para o córrego RTP são igualmente levemente diferentes. Não olhe os cabeçalhos IP, simplesmente olhar no intervalo de porta UDP. Se cai entre 16384 e 32767, etiquete-os e envie-os ao mapa de política.

Cisco 3660 (exemplo 2)
!
ip cef
!

!--- The CEF mechanism needs to be enabled 
!--- in order for the set cos command that is 
!--- configured later to take effect.
!--- If this is not on, the router reminds you with 
!--- the error "CEF switching needed for 'set' operations".
!
class-map match-all Call-Control
match access-group 101
!
class-map match-all RTP
match ip rtp 16384 16383

!--- Match on UDP port range 16384-32767 to single out 
!--- VoIP packets for policy-map.

!
access-list 101 permit tcp host 10.120.16.112 any eq 1720

!--- Match on all packets using TCP port 1720 which is 
!--- dedicated for H.225 call setup. 

!
policy-map OutboundPolicy
class RTP
set CoS 5

!--- For all VoIP packets that match the  UDP port range listed above,
!--- set the CoS bit to 5.

class Call-Control
set CoS 3
set ip precedence 3

!--- For all signaling and control packets that match access-list 
!--- 101, set the CoS bit to 3 and IP precedence to 3.

class class-default
set CoS 0

!--- All other traffic has a CoS of 0 and carries a 
!--- lower priority of delivery. 

!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.816
encapsulation dot1Q 816
ip address 10.120.16.112 255.255.255.0
service-policy output OutboundPolicy

!--- Apply your QoS to the interface that connects to the 
!--- LAN via the Catalyst 4000.

!
dial-peer voice 99131 voip
destination-pattern 9913109
session target ipv4:10.120.17.133
 ip qos dscp cs5 media 
no vad
!

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

O Roteadores é configurado agora para traçar o ToS mordido ao bit de CoS. Use o comando show policy-map interface certificar-se que o tráfego está marcado realmente de acordo com a configuração.

Nestas primeiras saídas de exemplo, os 539 pacotes voip combinam o mapa de classe e todos os 539 pacotes têm o bit de CoS marcado a um valor de crítico em consequência. Este tipo de enfileiramento não tem que esperar a congestão para ser ativo. Enquanto há o tráfego de voz que atravessa o link rápido de Ethernet, marca todos os pacotes em conformidade. No segundo exemplo, todos os pacotes voip marcaram ao valor de CoS de 5 e todos os pacotes da sinalização são marcados a um valor de CoS de 3 de acordo com a configuração.

Do primeiro exemplo de configuração 3660:

vdtl-3660-16a#show policy-map interface fastethernet 0/0.816
 FastEthernet0/0.816  
  Service-policy output: OutboundPolicy

    Class-map: RTP (match-all)
      539 packets, 42042 bytes
      5 minute offered rate 2000 bps, drop rate 0 BPS
      Match: ip precedence 5 
      QoS Set
        CoS 5
          Packets marked 539

    Class-map: class-default (match-any)
      13 packets, 1803 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any 
      QoS Set
        CoS 0
          Packets marked 13

Do segundo exemplo de configuração 3660:

vdtl-3660-16a#show policy-map interface fastethernet 0/0.816
 FastEthernet0/0.816 

  Service-policy output: OutboundPolicy

    Class-map: RTP (match-all)
      370 packets, 28860 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: ip rtp 16384 16383
      QoS Set
        CoS 5
          Packets marked 370

    Class-map: Call-Control (match-all)
      26 packets, 2697 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: access-group 101
      QoS Set
        ip precedence 3
          Packets marked 26
        CoS 3
          Packets marked 26

    Class-map: class-default (match-any)
      4363 packets, 515087 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any 
      QoS Set
        CoS 0
          Packets marked 4363
vdtl-3660-16a#

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 23442