Discar e acessar : Dial-on-Demand Routing (DDR)

Compreendendo e Troubleshooting de Intervalos Ociosos

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Um problema comum que afeta enlaces dial-up são quedas inesperadas de chamadas. Os motivos disso variam desde falhas de hardware a problemas dentro do serviço de telecomunicações. Entretanto, uma das causas mais comuns para desconexões de chamadas inesperadas é a expiração do tempo limite inativo.

Outro problema comum de timeout de ociosidade é que o link não se desconecta porque o timeout de ociosidade nunca expira. Isso pode resultar em altas cobranças de tarifa para conexões que são carregadas com base no tempo em que a chamada está conectada.

Este documento focaliza a configuração e Troubleshooting de timeout ocioso.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Problemas comuns e sintomas

Os seguintes sintomas podem indicar os problemas relacionados ao timeout de ociosidade:

  • As chamadas são desconectadas a cada dois minutos (120 segundos) após a conexão ser estabelecida.

    Esta desconexão normalmente deve-se ao intervalo ocioso padrão de 120 segundos estar sendo habilitado, apesar de a definição de tráfego interessante não ter sido feita ou não ter sido aplicada à interface. Embora o comando dialer in-band permita um timeout de ociosidade padrão de 120 segundos na interface, esse valor não aparece na saída de show running-configuration. Como o timeout de ociosidade padrão não está visível, uma desconexão de 120 segundos freqüentemente é diagnosticada incorretamente.

  • As chamadas são desconectadas a cada x minutos depois que a conexão é estabelecida.

    Essa desconexão normalmente se deve à configuração de idle-timeout (utilização do comando dialer idle-timeout), enquanto a definição de tráfego interessante não é nem definida nem aplicada à interface.

  • Chamadas desconectadas prematuramente. Isso se deve, provavelmente, a um valor combinado de esgotamento de tempo limite de ociosidade do discador ou a uma definição de tráfego interessante restritivo.

  • As chamadas não são desligadas. Isso provavelmente é provocado por um valor alto de tempo limite de ociosidade do discador com uma definição de tráfego solta e interessante.

Intervalos ociosos

O comando key idle timeout é um dialer idle-timeout, que é um comando de configuração de interface para interfaces de discadores, síncronas, de grupo assíncrono E ISDN. (Outro comando normalmente usado, ppp timeout idle, que é usado em interfaces de acesso virtual, fica fora do escopo deste documento. Para obter mais informações sobre o ppp timeout idle, consulte o documento Intervalos de PPP por usuário.

O comando dialer idle-timeout {x}pode ser configurado em qualquer interface compatível com discador. O contador de ociosidade controla por quanto tempo a conexão pode ficar inativa (em segundos) antes de ser terminada. O contador reinicializa ou faz a contagem decrescente com base no que o roteador determina como “tráfego interessante”. Se o roteador considerar o tráfego interessante (conforme a definição em dialer-list), ele redefinirá o temporizador de ociosidade ou este continuará a contagem regressiva. Quando o temporizador chegar a zero, a chamada será desconectada.

Relacionados abaixo estão alguns pontos que você deve observar sobre esse comando:

  • Esse comando só pode ser aplicado às interfaces que são compatíveis com discador. Por padrão, como todas as interfaces ISDN (Interface de taxa básica [BRI, Basic Rate Interface] e Interface de acesso básico [PRI, Primary Rate Interface]) são compatíveis com discador, esse comando pode ser adicionado sem problemas.

  • As interfaces assíncronas (por exemplo, interface assíncrona x ou interface de grupo assíncrono x) por padrão, não têm capacidade de discador. Você deve torná-las compatíveis com o discador, digitando o comando. Observe que os modelos virtuais (e, por isso, as interfaces de acesso virtual) não são compatíveis com o discador, e sim apenas ponto-a-ponto. Consequentemente, não podem usar este comando a menos que executando a versão de software 12.2(4)T do ½ do ¿  de Cisco IOSïÂ, quando os realces à estrutura do idle timeout eram incluídos.

  • Você pode apenas configurar dialer idle-timeout depois de inserir o comando dialer in-band na interface assíncrona.

  • Em uma interface habilitada para discador (ou seja, ISDN ou assíncrona com discador in-band), o tempo limite ocioso padrão é de 120 segundos (dois minutos). A menos que você configure explicitamente o comando dialer idle-timeout com um valor de timeout ocioso diferente, o valor padrão será usado.

    Nota: O timeout de ociosidade padrão não é mostrado na configuração por ser o padrão. Use o comando show dialer para determinar se um timeout de ociosidade está aplicado na interface.

  • Se você quiser que os usuários possam permanecer conectados até optarem por se desconectar, use o comando dialer idle-timeout 0. A opção zero para dialer idle-timeout foi introduzida no Cisco IOS Software Release 12.1(3)T e define um timeout de infinito.

Tráfego interessante

Com o recurso Dial-On-Demand Routing (DDR), todo o tráfego é classificado como interessante ou como desinteressante. Se o tráfego for interessante, o roteador se conectará ao peer. Se o tráfego não é interessante, a chamada não é conectada. No entanto, para conexões já conectadas, o tráfego interessante tem uma finalidade diferente. Ele é utilizado para redefinir o timeout de ociosidade para o valor máximo (configurado com o comando dialer idle-timeout). No momento em que uma conexão é estabelecida, o temporizador de ociosidade começa a diminuir. Uma vez que o roteador receber um pacote que corresponda à definição de tráfego interessante, o temporizador de ociosidade é reiniciado outra vez para o valor máximo.

O tráfego considerado interessante é definido pelo comando dialer-list {n} (no modo de configuração global), em que {n} corresponde ao número na instrução do comando dialer-group {n} na configuração de interface.

Há dois métodos para definir tráfego interessante. O método simples (que usa apenas o comando dialer-list) especifica um protocolo inteiro (como IP ou IPX) como interessante ou desinteressante. No entanto, se precisar dar uma definição de tráfego interessante mais específica (por exemple, se o tráfego HTTP é interessante, mas o tráfego Telnet não) você deverá utilizar o comando dialer-list com um access-list.

Consulte a seção Configuração do Timeout de Ociosidade e do Tráfego Interessante para obter mais informações sobre como configurar tráfego interessante.

Especificando a direção do tráfego interessante

Por padrão, dialer idle-timeout retorna ao máximo pelo tráfego interessante na direção de saída. Se apenas o tráfego de entrada puder reconfigurar o timeout ocioso, use a palavra chave adicional "inbound". Use a palavra-chave either para o tráfego de entrada e de saída e restaure o timeout de ociosidade. Esse recurso foi apresentado no software Cisco IOS na versão 12.1(1)T.

Benefícios: Especificando que apenas o tráfego de entrada restaurará o temporizador de ociosidade do discador, você pode impedir que um tráfego de Internet impeça a desconexão da conexão de ociosidade.

Definição de tráfego interessante e intervalos ociosos

O tráfego interessante deve ser definido em ambos os lados de um link DDR. Mesmo se o roteador que recebe a chamada controlar somente chamadas recebidas e não fizer chamadas externas, ainda assim, precisamos definir o tráfego interessante.

A definição de tráfego interessante tem uma finalidade diferente para as chamadas Async (Assíncronas) recebidas e para as chamadas ISDN.

Para usuários de ISDN (correspondendo ao discador X da interface)

Os comandos dialer-group e dialer-list são obrigatórios na interface do discador, independentemente do desejo de aplicar timeout de ociosidade ou não. Os comandos dialer-group and dialer-list são necessários na interface do discador para evitar falhas de encapsulamento. Essa exigência destina-se apenas aos usuários ISDN e não se aplica aos usuários Assíncronos nem à interface assíncrona de grupo.

Para aplicar um timeout de ociosidade, adicione os comandos dialer in-band e dialer idle-timeout. No entanto, se dialer in-band for configurado, mas dialer idle-timeout não, o timeout de ociosidade usará como padrão dois minutos para usuários ISDN.

Se você quiser que os usuários ISDN permaneçam conectados até optarem por se desconectar, use o comando dialer idle-timeout 0. A opção zero para tempo limite de ociosidade do discador foi introduzida no Cisco IOS Software Release 12.1(3)T e define um intervalo de infinito.

Para usuários ISDN (correspondente à interface BRI x e à interface Serial x:23)

Todas as interfaces ISDN físicas estão habilitadas para DDR por padrão. Isso significa que dialer in-band já está habilitado nessa interface. Para aplicar o timeout ocioso, adicione o comando dialer idle-timeout. No entanto, se dialer in-band for configurado, mas dialer idle-timeout não, o timeout de ociosidade usará como padrão dois minutos para usuários ISDN.

Os comandos dialer-group e dialer-list são obrigatórios nessa interface, independentemente do desejo de aplicar timeout de ociosidade ou não. Os comandos dialer-group e dialer-list são necessários na interface para impedir falhas de encapsulamento. Esse requisito se destina apenas a usuários ISDN, e não a usuários Assíncronos e à interface assíncrona de grupo.

Se você quiser que os usuários ISDN permaneçam conectados até optarem por se desconectar, use o comando dialer idle-timeout 0. A opção zero para tempo limite de ociosidade do discador foi introduzida no Cisco IOS Software Release 12.1(3)T e define um intervalo de infinito.

Para Usuários Assíncronos (correspondentes à Interface Group-Async X)

Para aplicar um limite de tempo ocioso esgotado para usuários assíncronos, configure os comandos a seguir na interface de grupo assíncrono:

  • dialer in-band

  • dialer idle-timeout

  • dialer-group

A lista de discadores correspondentes também é necessária. Os comandos grupo discadores e lista discadores especificam o tráfego interessante da interface de grupo assíncrono.

Para usuários assíncronos, o tráfego interessante só é utilizado para reinicializar o intervalo ocioso. Se o tráfego interessante não for definido, os usuários serão desconectados depois que o tempo limite de ociosidade do discador (padrão de 120 segundos) expirar, mesmo que eles estejam transportando tráfego no enlace. Com uma definição de tráfego interessante, o NAS (Servidor de acesso de rede) reconhecerá os pacotes e reiniciará o timeout ocioso, desconectando o usuário apenas quando existir um enlace verdadeiramente ocioso.

Você pode modificar o tráfego interessante de tal maneira que, por exemplo, somente o tráfego de HTTP (web) seja interessante. Nessa situação, se o usuário não navegar na web por 300 segundos (ou durante o timeout de ociosidade do discador especificado), ele será desconectado. A configuração do tráfego interessante depende dos padrões de tráfego dos usuários.

Se você quiser que os usuários Assíncronos possam permanecer conectados até optarem por se desconectar, remova os comandos a seguir da interface group-async, conforme mostrado na configuração:

  • dialer in-band

  • dialer idle-timeout

  • dialer-group

Você também pode definir o timeout de ociosidade para o infinito utilizando o comando dialer idle-timeout 0. A opção zero do intervalo livre do discador foi introduzida no Cisco IOS Software Versão 12.1(3)T e isso define o intervalo de parada como infinito.

Configurando o tempo limite de ociosidade e o tráfego interessante

Esta seção discute como você pode configurar o timeout de ociosidade e o tráfego interessante no roteador. Você pode aplicar essa configuração à todas as interfaces habilitadas para DDR:

interface BRI
interface async x
interface dialer x
interface group-async x
interface serial x:23

Também é possível usar um servidor AAA (autenticação, autorização e contabilidade) para fornecer tempo limite por usuário. Consulte o documento PPP Per-User Timeouts (Timeouts por usuário de PPP) para obter mais informações.

Configuração de exemplo

O seguinte exemplo de configuração inclui uma definição simples de tráfego interessante. Este exemplo específico designa todo o tráfego de IP como interessante.

interface BRI0/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 900
!--- Idle-timeout is set at 900 seconds (15 minutes)
dialer-group 1
!--- Apply interesting traffic definition from dialer-list 1
isdn switch-type basic-5ess
no cdp enable
ppp authentication chap
!
dialer-list 1 protocol ip permit
!--- Designate all IP traffic as interesting.  
This definition was applied to BRI0/0 using dialer-group 1.   
Note that the dialer-list and dialer-group numbers match

A configuração acima mantém a conexão ativa durante pelo menos 900 segundos (15 minutos) e permite tráfego IP em qualquer direção (padrão) para reinicializar o intervalo livre de 900 segundos. Por isso, se nenhum tráfego IP passar em uma direção durante 15 minutos, o roteador desconectará a linha porque o timeout de ociosidade expirou.

Nota: Se você executar um protocolo de roteamento nesse link DDR, o tráfego periódico manterá o link ativo indefinidamente. Por isso, a definição de tráfego interessante mostrada acima não é recomendável para links com protocolos de roteamento (ou outro tráfego periódico) em execução.

Usando listas de acesso

O exemplo a seguir mostra um roteador com interface BRI (interface de taxa básica) que está recebendo a chamada e habilitou o comando dialer idle-timeout com a palavra-chave inbound. Este comando permite apenas tráfego de saída que esteja em conformidade com a lista do discador para reinicializar o temporizador de ociosidade do discador. Nesse caso, somente o tráfego de TCP na porta 80 (tráfego de HTTP) pode restaurar o intervalo ocioso para dez minutos (600 segundos). Por isso, se o usuário final não navegar na web por dez minutos, a conexão será desconectada.

Usando as interfaces de ISDN

interface BRI0/0   
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 600 inbound

!--- Idle timeout is 600 seconds.  Only inbound interesting traffic will reset 
the idle timeout

dialer-group 1

!--- Apply the interesting traffic defintion from dialer-list 1

peer default ip address pool dialin
isdn switch-type basic-5ess
no cdp enable
ppp authentication chap
!
access-list 101 permit tcp any any eq 80

!--- Permit tcp port 80 (http) from any host to any other host

access-list 101 deny ip any any

!--- All other IP traffic is uninteresting

dialer-list 1 protocol ip list 101

!--- Use list 101 for granular interesting traffic definition
ip local pool dialin 10.1.1.2 10.1.1.254

Utilização de Interfaces Assíncronas

Por padrão, como as interfaces assíncronas não são habilitadas para DDR, a utilização de dialer in-band as habilita para DDR.

Interface group-async 1
ip unnumbered ethernet 0
no ip directed-broadcast
encapsulation ppp
dialer in-band
dialer idle-timeout 600
dialer-group 1
peer default ip address pool dialin
no cdp enable
ppp authentication chap
!
access-list 101 permit tcp any any eq 80
access-list 101 deny ip any any

!--- Access-lists have an implicit deny.  However, we are explicitly denying IP 
here for clarity.


dialer-list 1 protocol ip list 101
ip local pool dialin 10.1.1.2 10.1.1.254

Melhorias de intervalo ocioso

Antes do Cisco IOS Software Release 12.2(4)T, o temporizador de ociosidade do discador só podia ser reinicializado para tráfego interessante nas interfaces habilitadas para o discador (por exemplo, BRI, PRI e group-async com o comando dialer in-band). Timeouts de ociosidade não podem ser aplicados a usuários conectados a interfaces de modelo virtual.

A partir do Cisco IOS Software Release 12.2(4)T, o recurso Customer Profile Idle Timer Enhancements for Interesting Traffic fornece novos comandos e funcionalidades que resolvem problemas do temporizador de ociosidade para Sessões de rede dial-up de acesso virtual (VPDN, virtual access dialup network), que utilizam interfaces de acesso virtual (projetado) e dependem do mecanismo de temporizador de ociosidade PPP.

Verificando o intervalo ocioso

Execute as seguintes etapas para verificar e resolver problemas do comportamento de timeout de ociosidade:

  1. Certifique-se de que a chamada está conectada, usando o comando show user.

  2. Utilize show caller timeout, show dialer e show caller user para determinar se o timeout de ociosidade está atribuído corretamente à interface conectada. Caso execute os comandos show várias vezes, é necessário ver o tempo para diminuir a desconexão.

  3. Inicie o tráfego interessante (conforme definido por dialer-list x) no enlace. Você deve analisar a configuração em funcionamento para determinar a definição de tráfego interessante.

  4. Execute show caller timeout, show dialer e show caller user novamente para determinar se o timeout de ociosidade foi redefinido. Se isso não acontecer, o tráfego interessante não está definido corretamente (utilização de dialer-list) ou não foi aplicado à interface (utilização de dialer-group).

Os comandos utilizados para verificar o comportamento do timeout de ociosidade estão listados abaixo:

  • show caller timeout - exibe os intervalos absoluto e ocioso instalados, bem como o tempo anterior durante o qual o usuário é desconectado por algum intervalo.

  • show dialer [interface type number] - Exibe informações de diagnóstico geral para interfaces configuradas para DDR. Se o discador for ativado corretamente, a mensagem dialer state is data link layer up aparecerá. Se uma camada física aparecer, isso significa que o protocolo de linha foi ativado, mas o Protocolo de controle de rede (NCP) não. Os endereços de origem e destino do pacote que iniciou a discagem são mostrados na linha de razão de discagem. Esse comando também mostra a configuração do temporizador e o tempo antes da expiração da conexão.

  • show caller user username detail - Mostra parâmetros para o usuário particular, como endereço IP designado, PPP, parâmetros de pacote PPP, etc. Se sua versão de Cisco IOS Software não apoia este comando, use o comando show user.

Para chamadas ISDN

Aqui está a configuração para o roteador no lado do recebimento com uma interface BRI conectada ao discador de interface 1 com o comando dialer rotary-group 1. Lembre-se que discador de interface 1 é habilitado para DDR utilizando o comando dialer in-band.

interface BRI0
   description 96665500
   no ip address
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   dialer rotary-group 1
   dialer-group 1
   isdn switch-type basic-5ess
   no cdp enable
   ppp authentication pap
 !
 interface Dialer1
   ip address 10.1.1.1 255.255.255.0
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   dialer in-band
   dialer idle-timeout 600
   dialer-group 1
   peer default ip address pool dialin
   no cdp enable
   ppp authentication chap callin
   ppp chap hostname cisco
   ppp chap password 7 <deleted>
 !
 ip local pool dialin 10.1.1.2 10.1.1.255
 dialer-list 1 protocol list 101
 access-list 101 permit icmp any any
 access-list 101 permit tcp any any eq 80
 access-list 101 deny ip any any

!--- Only http traffic and icmp traffic are interesting
 
 !

Execute as seguintes etapas para verificar o timeout de ociosidade:

  1. Certifique-se de que a chamada esteja conectada. Você pode usar o comando show user para verificar se o usuário está conectado. Por exemplo:

    isdn2-4#show user
    
    Line   User  Host(s)       Idle     Location
    * 2 vty 0  idle         00:00:00 172.22.88.109
    
    Interface   User  Mode     Idle      Peer Address
    BR0:1       Preet Sync PPP 00:00:51  PPP: 10.1.1.2
    
  2. Verifique se o tempo limite de ociosidade é aplicado à conexão. No exemplo abaixo, o usuário user Preet discou e terminou no discador de interface 1, e obteve o endereço IP 10.1.1.2 de discagem do conjunto. Vamos verificar agora se a conexão está usando um tempo limite de ociosidade de 600 segundos (10 minutos).

    isdn2-4#show dialer interface dialer1
    Di1 - dialer type = IN-BAND SYNC NO-PARITY
    Load threshold for dialing additional calls is 255
    Idle timer (600 secs), Fast idle timer (20 secs)
    !--- The idle timeout value configured on int dialer 1.   If the default 
    is in use, this value will be 120.
    
    Wait for carrier (30 secs), Re-enable (15 secs)
    Number of active calls = 1
    
    Dial String   Successes   Failures   Last DNIS   Last status
    
    BRI0 - dialer type = ISDN
    Rotary group 1, priority = 0
    0 incoming call(s) have been screened.
    0 incoming call(s) rejected for callback.
    
    BRI0:1 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    !--- The user Preet obtained the idle timeout of 600 seconds.
    
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is data link layer up
    Time until disconnect 557 secs
    

    A contagem regressiva para desconexão começa, já que nenhum tráfego interessante está passando no link. Não houve nenhum tráfego interessante passando em nenhuma direção durante os últimos 43 segundos. Assim, o usuário é desconectado em 600 - 43 = 557 segundos. O campo time until disconnect começa a contagem regressiva assim que o usuário se conecta e é redefinido para o máximo quando o tráfego interessante é recebido.

    Connected to 4086666700 (Preet)
    BRI0:2 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is idle

    Outro comando que pode ser utilizado para verificar o timeout de ociosidade é show caller timeout:

    isdn2-4#show caller timeout
    Line    User   Limit     Remaining   Timer  Type
    vty 2    -     00:10:00  00:09:59    Idle   Exec
    BR0:1   Preet  00:10:00  00:09:13    Dialer idle
    

    O campo limit mostra o intervalo ocioso máximo (em minutos) configurado e o campo remaining mostra o tempo restante até a desconexão.

  3. Iniciar o tráfego interessante para o correspondente. Iniciaremos agora tráfego interessante para o peer. Certifique-se de observar running-configuration para determinar a definição de tráfego interessante exata. A lista de acesso 101 define o protocolo de mensagens de controle da Internet (ICMP) e o tráfego TCP para a porta 80 como interessante. Por isso, agora nós executaremos ping em 10.1.1.2 (endereço IP negociado pelo usuário Preet) a partir do roteador.

    isdn2-4#ping 10.1.1.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 36/37/40 ms
    isdn2-4#
  4. Verifique se o intervalo ocioso foi redefinido. Utilize os comandos show caller timeout, show dialer e show caller user para verificar se o timeout de ociosidade foi redefinido:

    isdn2-4#show caller timeout 
     Line     User      Limit    Remaining  Timer Type 
     vty 2    -         00:10:00 00:09:59   Idle Exec 
     BR0:1    Preet     00:10:00 00:09:59   Dialer idle
    !--- Idle-timout is reset back to maximum
    
    
    isdn2-4#show dialer interface dialer1
    
    Di1 - dialer type = IN-BAND SYNC NO-PARITY
    Load threshold for dialing additional calls is 255
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Number of active calls = 1
    
    Dial String   Successes   Failures   Last DNIS   Last status
    
    BRI0 - dialer type = ISDN
    Rotary group 1, priority = 0
    0 incoming call(s) have been screened.
    0 incoming call(s) rejected for callback.
    
    BRI0:1 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is data link layer up
    Time until disconnect 599 secs
    
    !--- Idle timeout is reset back to maximum.
    
    
    Connected to 4086666700 (Preet)
    
    BRI0:2 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is idle
    isdn2-4# 
    

Outro comando útil que pode ser utilizado para ver as informações de timeout com base no nome de usuário é show caller user.

isdn2-4#show caller user Preet
 User: Preet, line BR0:1, service PPP 
 Connected for 00:05:36, Idle for 00:02:37
!--- Shows the inactivity for the last two minutes and 37 seconds. 
This counter increments to ten minutes and then the call is disconnected.


Timeouts: Limit    Remaining Timer  Type
          00:10:00 00:07:22  Dialer idle
!--- Time until idle disconnect.


PPP: LCP Open, PAP (<- none), IPCP
Dialer: Connected to 4086666700, inbound
        Type is ISDN, group Di1
IP: Local 10.1.1.1/24, remote 10.1.1.2
Counts: 215 packets input, 5392 bytes, 0 no buffer
        0 input errors, 0 CRC, 0 frame, 0 overrun
        230 packets output, 5603 bytes, 0 underruns
        0 output errors, 0 collisions, 7 interface resets

Se o timeout de ociosidade não for redefinido, passe à seção Troubleshooting de Problemas do Timeout de Ociosidade.

Para chamadas assíncronas

Aqui está uma configuração típica para chamadas Async que você pode ver no ambiente de ISPs.

 interface Group-Async0
   ip unnumbered Loopback0
   encapsulation ppp
   dialer in-band

!--- Make this interface dialer capable
 
   dialer idle-timeout 600

!---  Idle timeout of 600 seconds (10 minutes)

   dialer-group 1

!--- Interesting traffic definition from dialer-list 1

   async mode interactive
   peer default ip address pool dialin
   ppp authentication pap chap callin
   group-range 1/3/00 1/3/71
   !
   ip local pool dialin 10.1.1.3 10.1.1.255
 dialer-list 1 protocol list 101

!--- Interesting traffic definition is defined by access-list 101

access-list 101 permit icmp any any

!--- Permit icmp from any host to any other host

 access-list 101 permit tcp any any eq 80

!--- Permit tcp port 80 (http traffic)

access-list 101 deny ip any any

!--- Deny all other IP traffic.  This interesting traffic definition 
will allow icmp and http traffic to reset the idle timeout. All other IP traffic will not 
affect the timeout.

Assim como acontece com ISDN, utilize show users, show dialer e show caller timeout para verificar o timeout de ociosidade.

Use o comando show users para encontrar a interface e o endereço IP aos quais o peer está conectado.

c5800#show users
      Line      User  Host(s)         Idle     Location
   * 0 con 0          idle            00:00:00 
     tty 1/3/01 Preet Async interface 00:00:09 PPP: 10.1.1.3
!--- User Preet is connected to async interface 1/3/01 and has IP address 10.1.1.3

Interface    User Mode             Idle     Peer          Address

Use o comando exibir discador (especificando a interface que acaba de ser determinada) para observar os valores do cronômetro:

c5800#show dialer interface async 1/3/01
As1/3/01 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (600 secs), Fast idle timer (20 secs)
!--- Idle timeout of 600 seconds is applied to the interface if this value 
is 120 seconds.


!--- Verify that dialer in-band is configured under the group-async interface.

Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Time until disconnect 574 secs (Preet)
!--- Call will be disconnected in 574 seconds unless it receives interesting traffic.
Dial String     Successes    Failures    Last DNIS     Last status

O comando show caller timeout exibe também o horário para desconectar:

c5800#show caller timeout
                        Session    Idle      Disconnect
   Line        User     Timeout    Timeout     User in
   con 0        -        -          -           - 
   tty 1/3/01  Preet     -          -           - 
   As1/3/01    Preet     -         00:10:00    00:09:19 

Agora iniciaremos o tráfego interessante. Access-list 101 define o tráfego de ICMP e TCP para a porta 80 (tráfego de HTTP) como interessante. Execute o ping 10.1.1.3 (endereço IP que o usuário Preet negociou) do roteador para redefinir o intervalo ocioso.

c5800#ping 10.1.1.3
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 108/113/124 ms

Verifique se o timeout de ociosidade foi redefinido:

   c5800#show caller timeout
                      Session Idle    Disconnect
   Line       User    Timeout Timeout User in
   con 0      -        -       -      - 
   tty 1/3/01 Preet    -       -      - 
   As1/3/01   Preet    -     00:10:00 00:09:58
!--- Time to disconnect is close to 10 minutes

Isso mostra que o tráfego interessante está definido e é aplicado corretamente. Você também pode utilizar o comando show dialer para verificar os valores de timeout:

c5800#show dialer interface async 1/3/01
   As1/3/01 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (600 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Time until disconnect 594 secs (Preet)
   Dial String   Successes    Failures   Last DNIS    Last status

Você também pode utilizar o comando show caller user {username} detailed para verificar os parâmetros específicos do usuário:

c5800#show caller user preet detailed 
User:   Preet, line tty 1/3/01, service Async
        Active time 00:01:14, Idle time 00:00:18
Timeouts:          Absolute   Idle      Idle
                              Session   Exec
Limits:            -          -         00:10:00
Disconnect in:     -          -         -    
TTY: Line 1/3/01, running PPP on As1/3/01   
Location: PPP: 10.1.1.3   
DS0: (slot/unit/channel)=1/4/0   
Status: Ready, Active, No Exit Banner, Async Interface Active
        HW PPP Support Active   
Capabilities: No Flush-at-Activation, Hardware Flowcontrol In
              Hardware Flowcontrol Out, Modem Callout, Modem RI is CD                 
              Line usable as async interface, Telnet Faststream   
Modem State: Ready

User: Preet, line As1/3/01, service PPP
      Active time 00:01:11, Idle time 00:00:18   
Timeouts:        Absolute Idle
Limits:          -        00:10:00    
Disconnect in:   -        00:09:41 
!--- Idle timeout of 10 minutes. The call will be disconnected in 9 minutes 41 secs 
unless it receives interesting traffic during that time. If the absolute column has a 
value, then the call will be disconnected at that time regardless of the idle timeout.

PPP: LCP Open, CHAP (<- local), IPCP
LCP: -> peer, ACCM, AuthProto, MagicNumber, PCompression, ACCompression          
     <- peer, ACCM, MagicNumber, PCompression, ACCompression   
NCP: Open IPCP   
IPCP: <- peer, Address
      -> peer, Address   
Dialer: Connected, inbound
        Idle timer 600 secs, idle 20 secs
        Type is IN-BAND ASYNC, group As1/3/01   
IP: Local 10.1.1.251, remote 10.1.1.3   
Counts: 12 packets input, 651 bytes, 0 no buffer 
        0 input errors, 0 CRC, 0 frame, 0 overrun           
        13 packets output, 666 bytes, 0 underruns           
        0 output errors, 0 collisions, 0 interface resets

Troubleshooting Problemas de Intervalo Ocioso

Sintoma: A chamada foi desconectada prematuramente ou a chamada não foi totalmente desconectada

Se a chamada for desconectada inesperadamente ou a chamada jamais se desconectar, verifique o timeout de ociosidade do discador e a definição de tráfego interessante. Você pode usar o comando debug dialer packet para ver se um pacote em particular é interessante ou não. Por exemplo:

Apr 26 01:57:24.483: Di1 DDR: ip (s=192.168.1.1, d=224.0.0.5), 
64 bytes, outgoing uninteresting (list 101)
Apr 26 01:57:26.225: Di1 DDR: ip (s=192.168.1.1, d=10.1.1.1), 
100 bytes, outgoing interesting (list 101)

No exemplo acima, as saudações de OSPF são desinteressantes por lista de acesso 101, enquanto o segundo pacote é interessante por lista de acesso 101. Resolva problemas da seguinte forma:

  1. Ajuste o timeout de ociosidade do discador na interface de configuração deste. O padrão é 120 segundos, mas você pode aumentar ou diminuir esse valor dependendo de suas necessidades.

    router(config-if)#dialer idle-timeout 

    Nota: Se a chamada não for desconectada, verifique se a opção zero do timeout de ociosidade do discador (introduzida no Cisco IOS Software Release 12.1(3)T) não está definida.

  2. Alterar a definição de tráfego interessante (configurada com o comando dialer-list). Se a chamada se desconectar prematuramente, você também poderá definir o tráfego interessante de forma mais livre (negar um pouco e permitir todo o resto). Se a chamada nunca se desconectar, troque a definição de tráfego interessante para ser mais restritivo (permitir alguns e negar todos os demais).

    Dica: Caso seu enlace não se desconecte, verifique se definiu o tráfego do Routing Protocol (ou qualquer outro tráfego periódico) como desinteressante. Isso impede que saudações periódicas redefinam o tempo limite inativo. Aqui há um exemplo de definição interessante de tráfego:

    access-list 101 remark Interesting traffic for dialer-list 1   
    access-list 101 deny ospf any any
    !--- Mark OSPF as uninteresting.  This will prevent OSPF hellos from 
    keeping the link up.
    
    
    access-list 101 deny udp any any eq ntp
    
    !--- Define ntp traffic as NOT interesting.  This will prevent periodic ntp 
    traffic from keeping the link up indefinitely.
    
    
    access-list 101 permit ip any any
    !--- All other IP traffic is interesting. Change this depending on your 
    traffic needs.
    
    dialer-list 1 protocol ip list 101
    !--- This interesting traffic is applied to the dialer interface using 
    dialer-group 1.
    
    

    Para obter mais informações, consulte o documento Tecnologia de Dial-up: Visões Gerais e Explicações.

Sintoma: A chamada é desconectada em um intervalo de poucos segundos

Um outro problema é que a chamada se desconecta a cada "x" segundos (mais freqüentemente a cada 120 segundos). Em determinadas situações, mesmo se o tráfego for transmitido pelo link, o DDR não reinicializará o intervalo livre. Provavelmente, isso é causado por:

  • o tráfego interessante não está sendo definido

  • a interessante definição de tráfego não aplicada à interface

  • a interface não é compatível com o discador

Para resolver:

  1. Verifique se a lista de discador está definida e se o grupo de discador (apontando para a lista de discador) está configurado na interface. Configure uma definição simples de tráfego interessante:

    router(config)#interface dialer 1
    router(config-if)#dialer-group 1
    router(config-if)#exit
    router(config)#dialer-list 1 protocol ip permit
    

    Após resolver o problema de desconexão freqüente, você pode ajustar a definição de tráfego interessante para adaptá-la às suas necessidades.

  2. Assegure-se de que dialer in-band esteja configurado nas interfaces group-async e do discador. Esse comando não é necessário em interfaces compatíveis com o discador como a interface BRI x e a interface Serial x:23 (para PRIs).

  3. Ajuste o timeout de ociosidade do discador para o valor desejado.

    router(config-if)#dialer idle-timeout 900
    

Informações Relacionadas


Document ID: 23423