Switches de LAN : EtherChannel

Configuração de FEC e Truncamento ISL/802.1q Entre Um Switch CatOS e Um Roteador Externo

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (7 Novembro 2015) | Feedback


Índice


Introdução

Este documento fornece configurações de amostra para o Fast EtherChannel (FEC), o Inter-Switch Link (ISL), e o entroncamento do 802.1Q entre um Catalyst 6500 Switch que execute o CatalystOS (Cactos) e um Cisco 7500 Router. Os resultados de cada comando são exibidos à medida que eles são executados. Embora um Catalyst 6000 Switch fosse usado nesta configuração, você poderia substituir um catalizador 4000 ou o Catalyst 5000 Family Switch que executassem Cactos.

Pré-requisitos

Requisitos

Certifique-se de atender a estes requisitos antes de tentar esta configuração:

  • Catalyst 6000 Series Switches

    • A liberação de Cactos 5.1(1) é exigida CSX ou mais tarde para apoiar o EtherChannel

  • Cisco 7000 ou 7500 Series Routers

    • Cisco 7000 Series Router com Route Switch Processor do 7000 Series (RSP7000) ou Chassis Interface (RSP7000CI), ou Cisco 7500 Series Router com os adaptadores de porta dos processares rápidos de interface Ethernet (FEIP) ou do Versatile Interface Processor (VIP2)

    • Se você está usando o adaptador de porta PA-2FEISL, você deve ter a revisão de hardware 1.2 ou mais atrasado.

      Consulte Field Notice: *Expired* FN - 8791_11301999 - recomendação de substituição do 2-Port Fast Ethernet ISL PA-2FEISL para mais informação.

    • O comando encapsulation dot1Q native foi introduzido no Software Release 12.1(3) T. do ½ do ¿  de Cisco IOSïÂ. Esse comando altera a configuração.

      Veja a configuração do 802.1Q do Cisco 7500 para Cisco IOS Software Release mais cedo do que a seção 12.1(3)T deste documento para mais informação.

    • O Cisco Express Forwarding está habilitado por padrão nos Cisco 7500 Series Routers. Contudo, o apoio do Cisco Express Forwarding para Roteamento IP entre o IEEE 802.1Q VLAN não estava disponível até o Cisco IOS Software Release 12.2 e o 12.2T. É ainda possível configurar o encapsulamento do 802.1Q em liberações precedentes, mas você deve primeiramente emitir o comando global no ip cef desabilitar o Cisco Express Forwarding.

    • Quando um 7500 Series Router é configurado para o Multiprotocol Label Switching (MPLS) e o FEC, o apoio é indisponível no momento para distribuir (do ½ do ¿  MPLS ïÂ) os pacotes IP que fluem da relação MPLS à relação FEC. Consequentemente, não se recomenda que um MPLS e uma configuração FEC coexistem em um roteador único.

    • O Cisco IOS Software Release 11.1(14)CA ou Mais Recente é exigido para apoiar o EtherChannel.

      O Cisco IOS Software Release 11.3(1)T (algum mais o conjunto de recursos) ou é exigido mais tarde para apoiar o entroncamento ISL.

      O Cisco IOS Software Release 12.0(1)T (algum mais o conjunto de recursos) ou é exigido mais tarde para apoiar o entroncamento do IEEE 802.1Q.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Catalyst 6500 que executa a versão cactos 5.5.14

  • Cisco 7500 que executa o Cisco IOS Software Release 12.2.7b

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Notas importantes

  • Mantenha na mente que os Catalyst 4000 Series Switch não apoiam o entroncamento ISL. Além, alguns módulos de switching em Catalyst 5000 Series Switch não são EtherChannel capaz. Emita o comando show port capabilities module determinar se um módulo específico é EtherChannel capaz e que encapsulamento de entroncamento apoia.

  • Há determinadas diretrizes para a configuração do EtherChannel e do entroncamento. Refira sempre a documentação de software de seu interruptor.

    Por exemplo, caso esteja executando a versão 5.5.x do software em um Catalyst 5000, consulte o Manual de configuração do software (5.5) e examine cuidadosamente qualquer tipo de orientação e restrição na seção Configurando Fast EtherChannel e o Gigabit EtherChannel.

EtherChannel

A característica FEC ou de Gigabit EtherChannel (GEC) permite que os link múltiplo Point-to-Point sejam empacotados em um enlace lógico. O catalizador 6000 apoia um máximo de oito portas no modo bidirecional, que oferece o 1600 Mbps ou a taxa de transferência do 1.6 Gbps para o FEC e o 16 Gbps para o GEC. O Cisco 7500 Series apoia um máximo de quatro portas pelo FEC, para o 800 Mbps. Os recursos de EtherChannel e o desempenho são diferentes, segundo o interruptor ou o roteador. Consulte Requisitos do Sistema para Implementação de EtherChannel em Catalyst Switches para obter informações adicionais.

O EtherChannel distribui o tráfego através de todos os links e fornece a Redundância se uns ou vários links falham. Refira compreendendo o equilíbrio e a Redundância da carga EtherChannel em Catalyst Switches para mais configurações da informação e de amostra relativas ao EtherChannel.

Refira a página do EtherChannel do Suporte técnico & da documentação de Cisco para mais informação.

Entroncamento

O entroncamento é uma maneira de levar o tráfego dos vlan múltiplos sobre um link de ponto a ponto ou um conjunto EtherChannel entre dois dispositivos. Estas são duas maneiras em que o entroncamento de Ethernet pode ser executado:

  • ISL (encapsulamento de tronco proprietário da Cisco)

  • 802.1q (encapsulamento de tronco com padrão de IEEE)

Refira a página dos protocolos VLAN trunking do Suporte técnico & da documentação de Cisco para mais informação.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Estas configurações de amostra mostram-lhe como fazer estas coisas:

  • Configurar duas portas de acesso para a estação de trabalho1 no VLAN1 e para o workstation2 no VLAN2 no Catalyst 6500.

  • Configurar o gateway padrão para que a estação de trabalho1 seja 10.10.10.1 /24 e para que o workstation2 seja 10.10.11.1/24 no Cisco 7500.

  • Configurar o ISL e os troncos 802.1Q sobre uma dois-porta FEC entre um Catalyst 6500 Switch e o Cisco 7500 Router.

  • Configurar duas subinterfaces do canal de porta com endereços IP de Um ou Mais Servidores Cisco ICM NT para o roteamento de interVLAN.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

Entroncamento VLAN1 e VLAN2 sobre 2-Port FEC

141.gif

Configurações

Este documento utiliza as seguintes configurações:

Catalyst 6500 Switch

!--- Set the IP address and default gateway for VLAN 1 for management purposes.

Catalyst6500> (enable) set interface sc0 10.10.10.2 255.255.255.0

Interface sc0 IP address and netmask set.

Catalyst6500> (enable) set ip route default 10.10.10.1

Route added.

!--- Set the VTP mode. In this example, the mode is set to be transparent. Depending on your
!--- network, set the VTP mode accordingly.
!--- For details on VTP, refer to Understanding and Configuring VLAN Trunk Protocol (VTP).

Catalyst6500> (enable) set vtp mode transparent

VTP domain modified

!--- Add VLAN 2. VLAN 1 already exists by default.

Catalyst6500> (enable) set vlan 2

VLAN 2 configuration successful

!--- Add port 3/4 to VLAN 2. Port 3/3 is already in VLAN 1 by default.

Catalyst6500> (enable) set vlan 2 3/4

VLAN 2 modified.
VLAN 1 modified.
VLAN  Mod/Ports
---- -----------------------
2     3/4

!--- Set the port speed to 100 and duplex to full. One of the requirements for EtherChannel
!--- to work is for speed and duplex to be the same on both sides. To guarantee this, hard
!--- code both speed and duplex on ports 3/1 and 3/2.

Catalyst6500> (enable) set port speed 3/1-2 100

Ports 3/1-2 transmission speed set to 100Mbps.

Catalyst6500> (enable) set port duplex 3/1-2 full

Ports 3/1-2 set to full-duplex.

!--- Enable FEC on ports 3/1 and 3/2. Because routers do not understand Port Aggregation
!--- Protocol (PAgP), set the channel mode to one which causes ports to channel but which
!--- does not generate PAgP frames.

Catalyst6500> (enable) set port channel 3/1-2 on

Port(s) 3/1-2 are assigned to admin group 105.
Port(s) 3/1-2 channel mode set to on.

!--- Enable trunking on ports 3/1 and 3/2. Because routers do not understand Dynamic
!--- Trunking Protocol (DTP), set the trunking mode to nonegotiate, which causes ports to
!--- trunk but which does not generate DTP frames.
!--- Note: Because EtherChannel is configured first, any trunk settings that are applied
!--- now to one port automatically apply to all other ports in the channel.
!--- Enter the trunking encapsulation as either ISL…

Catalyst6500> (enable) set trunk 3/1 nonegotiate isl

Port(s) 3/1-2 trunk mode set to nonegotiate.
Port(s) 3/1-2 trunk type set to isl.

!--- …or as dot1q.
!--- Ensure that the native VLAN (default is VLAN 1) matches across the link. For more
!--- information about the native VLAN and 802.1Q trunking, refer to Trunking Between
!--- Catalyst 4500/4000, 5500/5000, and 6500/6000 Series Switches Using 802.1Q
!--- Encapsulation with Cisco CatOS System Software.

Catalyst6500> (enable) set trunk 3/1 nonegotiate dot1q

Port(s) 3/1-2 trunk mode set to nonegotiate.
Port(s) 3/1-2 trunk type set to dot1q.

Catalyst6500> (enable) show config

This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
.........
..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Thu May 2 2002, 01:26:26
!
#version 5.5(14)
!
!
#system
set system name  Catalyst6500
!
#!
#vtp
set vtp mode transparent
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 2 name VLAN0002 type ethernet mtu 1500 said 100002 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state active
mode srb aremaxhop 7 stemaxhop 7
backupcrf off
!
#ip
set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

set ip route 0.0.0.0/0.0.0.0 10.10.10.1
!
#set boot command
set boot config-register 0x2102
set boot system flash bootflash:cat6000-sup.5-5-14.bin
!
#port channel
set port channel 3/1-2 105
!
# default port status is enable
!
!
#module 1 empty
!
#module 2 : 2-port 1000BaseX Supervisor
!
#module 3 : 48-port 10/100BaseTX Ethernet
set vlan 2    3/4
set port disable    3/5

set port speed      3/1-2  100
set port duplex     3/1-2  full
set trunk 3/1  nonegotiate isl 1-1005
set trunk 3/2  nonegotiate isl 1-1005

!--- If IEEE 802.1Q is configured, you will see this output instead:
set trunk 3/1  nonegotiate dot1q 1-1005
set trunk 3/2  nonegotiate dot1q 1-1005


set port channel 3/1-2 mode on
!
#module 4 : 24-port 100BaseFX MM Ethernet
!
#module 5 empty
!
#module 6 empty
!
#module 15 empty
!
#module 16 empty
end

Cisco 7500 Router

!--- Configure a port-channel interface to enable FEC.

7500# configure terminal

 Enter configuration commands, one per line. End with CNTL/Z.

7500(config)# interface port-channel 1

01:34:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
          state to down

!--- Configure full-duplex to match the duplex setting on the Catalyst switch side.

7500(config-if)# full-duplex

7500(config-if)# exit

!--- If you are using ISL trunking, configure two port-channel sub-interfaces and issue the
!--- encapsulation isl <VLAN> command to enable ISL trunking.
!--- Configure IP addresses for InterVLAN routing.

7500(config)# interface port-channel 1.1

7500(config-subif)# encapsulation isl 1

7500(config-subif)# ip address 10.10.10.1 255.255.255.0

7500(config-subif)# exit

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation isl 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- If you are using 802.1Q trunking, issue the encapsulation dot1Q <vlan> native
!--- command to configure two port-channel sub-interfaces and enable 802.1Q trunking.
!--- Configure the IP addresses for InterVLAN routing.

!--- Note: The encapsulation dot1Q 1 native command was added in Cisco IOS Software
!--- Release 12.1(3)T. If you are using an earlier version of Cisco IOS, see the
!--- Cisco 7500 802.1Q Configuration for Cisco IOS Software Releases Earlier than 12.1(3)T
!--- section of this document, to configure 802.1Q trunking on the router.




!--- Ensure that the native VLAN (default is VLAN 1) matches across the link. For more
!--- information about the native VLAN and 802.1Q trunking, refer to Trunking Between
!--- Catalyst 4500/4000, 5500/5000, and 6500/6000 Series Switches Using 802.1Q
!--- Encapsulation with Cisco CatOS System Software.

7500(config)# interface port-channel 1.1

7500(config-subif)# encapsulation dot1Q 1 native

7500(config-subif)# ip address 10.10.10.1 255.255.255.0

7500(config-subif)# exit

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation dot1Q 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- Configure the FastEthernet interfaces for speed 100, depending on the port adapter.
!--- Some FastEthernet port adapters can autonegotiate speed (10 or 100) and duplex (half
!--- or full). Others are only capable of 100 (half or full).

7500(config)# interface fastethernet 5/1/0

7500(config-if)# speed 100

!--- Issue the channel-group command, to configure the FastEthernet interfaces to be
!--- members of port-channel 1.

7500(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

7500(config-if)# no shut

7500(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/0 added as member-1 to port-channel1

01:46:09: %LINK-3-UPDOWN: Interface FastEthernet5/1/0, changed state to up
01:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/0,
          changed state to up
01:46:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
          changed state to up

Router(config-if)# exit

Router(config)# interface fastethernet 5/1/1

Router(config-if)# speed 100

Router(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

Router(config-if)# no shut

Router(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/1 added as member-2 to port-channel1

01:54:52: %LINK-3-UPDOWN: Interface FastEthernet5/1/1, changed state to up
01:54:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/1,
          changed state to up

Router(config-if)# exit

!--- Remember to save the configuration.

7500# write memory

Building configuration...
[OK]
7500#

!--- Note: To make this setup work and to successfully ping between Workstation 1 and
!--- Workstation 2, you must ensure that the default gateways on the workstations are setup
!--- properly. For Workstation 1, the default gateway should be 10.10.10.1; and for 
!--- Workstation 2, the default gateway should be 10.10.11.1.

7500# show running-config

Building configuration...

Current configuration : 1593 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service single-slot-reload-enable
!
hostname 7500
!
boot system disk1:rsp-jsv-mz.122-7b.bin
!
ip subnet-zero
!
ip cef
call rsvp-sync
!
!
!
interface Port-channel1
 no ip address
 full-duplex
 hold-queue 300 in
!
interface Port-channel1.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
!
interface Port-channel1.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0

!--- If 802.1Q trunking is configured, you will see this output instead:
interface Port-channel1.1
 encapsulation dot1Q 1 native
 ip address 10.10.10.1 255.255.255.0
!
interface Port-channel1.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0


!
interface FastEthernet5/1/0
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
interface FastEthernet5/1/1
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Configuração do 802.1Q do Cisco 7500 para Cisco IOS Software Release mais cedo do que 12.1(3)T
Em versões anteriores a 12.1(3)T do IOS Cisco, o comando nativo encapsulation dot1Q 1 sob a sub-interface não estava disponível. Entretanto, ainda é necessário fazer a correspondência da VLAN nativa no link, conforme anteriormente descrito. Para configurar mais cedo o entroncamento do 802.1Q nas versões de software do que 12.1(3)T, configurar o endereço IP de Um ou Mais Servidores Cisco ICM NT para o VLAN1 na relação do canal de porta principal 1, não uma subinterface do canal de porta.
 

!--- Configure a port-channel interface to enable FEC.

7500# configure terminal

 Enter configuration commands, one per line. End with CNTL/Z.

7500(config)# interface port-channel 1

01:34:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
          state to down

!--- Configure full-duplex to match the duplex setting on the Catalyst switch side.

7500(config-if)# full-duplex

7500(config-if)# exit

!--- Do not configure an interface port-channel 1.1
!--- Instead, create a port-channel 1 main interface and configure the IP address
!--- for VLAN 1 here.

7500(config)# interface port-channel 1

7500(config-if)# full-duplex

7500(config-if)# ip address 10.10.10.1 255.255.255.0

7500(config-if)# exit

7500(config)#

!--- It is still necessary to create a subinterface for VLAN 2.

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation dot1Q 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- Configure the FastEthernet interfaces for speed 100, depending on the port adapter.
!--- Some FastEthernet port adapters can autonegotiate speed (10 or 100) and duplex (half
!--- or full). Others are only capable of 100 (half or full).

7500(config)# interface fastethernet 5/1/0

7500(config-if)# speed 100

!--- Issue the channel-group command to configure the FastEthernet interfaces to be
!--- members of port-channel 1.

7500(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

7500(config-if)# no shut

7500(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/0 added as member-1 to port-channel1

01:46:09: %LINK-3-UPDOWN: Interface FastEthernet5/1/0, changed state to up
01:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/0,
          changed state to up
01:46:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
          changed state to up

Router(config-if)# exit

Router(config)# interface fastethernet 5/1/1

Router(config-if)# speed 100

Router(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

Router(config-if)# no shut

Router(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/1 added as member-2 to port-channel1

01:54:52: %LINK-3-UPDOWN: Interface FastEthernet5/1/1, changed state to up
01:54:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/1,
          changed state to up

Router(config-if)# exit

!--- Remember to save the configuration.

7500# write memory

Building configuration...
[OK]
7500#

!--- Note: Remember also that—in any version of software previous to 12.2 or 12.2T for the
!--- 7000/7500 series—you will have to issue the no ip cef command globally before you
!--- configure 802.1Q trunking on a subinterface. Otherwise, you will see this error
!--- message: 802.1q encapsulation not supported with CEF configured on the interface.
!--- See the Components Used section of this document for more information.

7500# show running-config

Building configuration...

Current configuration : 1593 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 7500
!
!
ip subnet-zero
!
no ip cef
!
!
!
interface Port-channel1
ip address 10.10.10.1 255.255.255.0
 full-duplex
 hold-queue 300 in
!
interface Port-channel1.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet5/1/0
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
interface FastEthernet5/1/1
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

7500#

Verificar

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Comandos show do Catalyst 6500

  • relação da mostra — Mostra o endereço IP de Um ou Mais Servidores Cisco ICM NT da interface de gerenciamento sc0 e o VLAN. Neste exemplo, o VLAN padrão é usado (VLAN1).

    Catalyst6500> (enable) show interface
    
    sl0: flags=51<UP,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>
            VLAN 1 inet 10.10.10.2 netmask 255.255.255.0 broadcast 10.10.10.255
    Catalyst6500> (enable)
  • show ip route – Exibe o gateway padrão. Neste exemplo, 10.10.10.1 é o endereço IP de Um ou Mais Servidores Cisco ICM NT do canal de porta 1 (para o entroncamento do 802.1Q) ou do canal de porta 1.1 (para o entroncamento ISL).

    Catalyst6500> (enable) show ip route
    
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled
    
    The primary gateway: 10.10.10.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.10.10.1       0x0          UG      0           sc0
    10.10.10.0       10.10.10.2       0xffffff00   U       8           sc0
    default          default          0xff000000   UH      0           sl0
    Catalyst6500> (enable)
  • show port capabilities mod/port — Dá uma consulta rápida nas capacidades do hardware de módulos de switching. Neste exemplo, você pode ver que a porta 3/1 (e 3/2) é o EtherChannel capaz, que os encapsulamentos de entroncamento ele apoiam, e a outra informação.

    Catalyst6500> (enable) show port capabilities 3/1
    
    Model                    WS-X6248-RJ-45
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1q,ISL
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  yes
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(1q4t),tx-(2q2t)
    CoS rewrite              yes
    ToS rewrite              DSCP
    UDLD                     yes
    Inline power             no
    AuxiliaryVlan            1..1000,untagged,dot1p,none
    SPAN                     source,destination
    COPS port group          not supported
    Catalyst6500> (enable)
  • /porta modificação do show port counters — Dá uma consulta rápida em erros de porta possíveis. Nesse exemplo, essa porta está livre de erros. Se você experimenta erros na porta, refira pesquisando defeitos a porta de switch e conecte problemas para mais informação.

    Catalyst6500> (enable) show port counters 3/1
    
    Port  Align-Err  FCS-Err    Xmit-Err   Rcv-Err    UnderSize
    ----- ---------- ---------- ---------- ---------- ---------
     3/1           0          0          0          0         0
    
    Port  Single-Col Multi-Coll Late-Coll  Excess-Col Carri-Sen Runts     Giants
    ----- ---------- ---------- ---------- ---------- --------- --------- ---------
     3/1           0          0          0          0         0         0         -
    
    Last-Time-Cleared
    --------------------------
    Thu May 2 2002, 02:11:55
    Catalyst6500> (enable)
  • modificação do show port — Mostra o status de porta, o VLAN, o tronco, e a informação da velocidade e duplexação. Neste exemplo, a porta de acesso para a estação de trabalho1 é 3/3, que está no VLAN1. A porta de acesso para para o workstation2 é 3/4, que é as portas 3/1 e 3/2 VLAN 2. é o entroncamento e portas FEC.

    Catalyst6500> (enable) show port 3
    
    Port  Name                 Status     VLAN       Duplex Speed Type
    ----- -------------------- ---------- ---------- ------ ----- ------------
     3/1                       connected  trunk        full   100 10/100BaseTX
     3/2                       connected  trunk        full   100 10/100BaseTX
     3/3                       connected  1          a-half  a-10 10/100BaseTX
     3/4                       connected  2          a-full a-100 10/100BaseTX
    
    !--- Output suppressed.
    
    
  • mostra vlan — Mostra que portas são atribuídas aos VLAN específicos. Observe que as portas de tronco neste exemplo (3/1 e 3/2) não aparecem nesta saída, que é normal.

    Catalyst6500> (enable) show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    119     2/1-2
                                                            3/3,3/5-48
                                                            4/1-24
    2    VLAN0002                         active    124     3/4
    
    !--- Output suppressed.
    
    
  • tronco da mostra — Mostra o modo de entroncamento, tipo de encapsulamento, permitido VLAN, e Vlan ativo. Neste exemplo, VLAN 1 (sempre permitida e ativa por padrão) e VLAN 2 são as atualmente ativas no tronco. Observe que ambas as portas de tronco estão no VLAN1.

    Catalyst6500> (enable) show trunk
    
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  isl            trunking      1
     3/2      nonegotiate  isl            trunking      1
    
    Port      VLANs allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
     3/2      1-1005
    
    Port      VLANs allowed and active in management domain
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    
    Port      VLANs in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2

    Para o entroncamento do 802.1Q, a saída do comando precedente muda a esta:

    Catalyst6500> (enable) show trunk
    
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native VLAN
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  dot1q          trunking      1
     3/2      nonegotiate  dot1q          trunking      1
    
    Port      VLANs allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
     3/2      1-1005
    
    Port      VLANs allowed and active in management domain
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    
    Port      VLANs in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    Catalyst6500> (enable)
  • show port channel - exibe o status do Ethernetchannel. Neste exemplo, há uns 2-port FEC (portas 3/1 e 3/2) em que está, para impedir que os pagp frame estejam transmitidos. Você pode igualmente ver a interface de canal de porta remota do 7500 Router.

    Catalyst6500> (enable)  show port channel
    
    Port  Status     Channel              Admin Ch
                     Mode                 Group Id
    ----- ---------- -------------------- ----- -----
     3/1  connected  on                     105   833
     3/2  connected  on                     105   833
    ----- ---------- -------------------- ----- -----
    
    Port  Device-ID                       Port-ID                   Platform
    ----- ------------------------------- ------------------------- ----------------
    3/1  7500                            Port-channel1.1           cisco RSP4
    3/2  
    ----- ------------------------------- ------------------------- ----------------
    Catalyst6500> (enable)

    Para um FEC com entroncamento do 802.1Q, a saída do comando precedente muda a esta:

    Catalyst6500> (enable) show port channel
    
    Port  Status     Channel              Admin Ch
                     Mode                 Group Id
    ----- ---------- -------------------- ----- -----
     3/1   connected  on                    257   769
     3/2   connected  on                    257   769
    ----- ---------- -------------------- ----- -----
    
    Port  Device-ID                       Port-ID                   Platform
    ----- ------------------------------- ------------------------- ----------------
     3/1       7500                            FastEthernet5/1/0         cisco RSP4
     3/2       7500                            FastEthernet5/1/1         cisco RSP4
    ----- ------------------------------- ------------------------- ----------------
    Catalyst6500> (enable)

Se você tem a saída de um comando show-tech support de seu dispositivo Cisco, você pode usar a ferramenta Output Interpreter (clientes registrados somente) para indicar problemas potenciais e reparos.

Comandos show do Cisco 7500 Router

  • mostre o número de canal do canal de porta da relação — Dá o status de membro para interfaces física. Neste exemplo, um 2-port FEC é configurado entre as portas 3/1 e 3/2 no catalizador 6000 e entre os FastEthernet 5/1/0 e 5/1/1 da relação nos 7500. Mostras do canal de porta 1 como o Up/Up.

    Tem um endereço IP de Um ou Mais Servidores Cisco ICM NT configurado, que signifique neste caso que é o endereço IP de Um ou Mais Servidores Cisco ICM NT do VLAN nativo para o entroncamento do 802.1Q. Veja a configuração do 802.1Q do Cisco 7500 para Cisco IOS Software Release mais cedo do que a seção 12.1(3)T deste documento para mais informação. A saída é mostrada igualmente para a subinterface do 802.1Q VLAN2, do comando show interface port channel 1.2.

    7500# show interface port-channel 1
    
    Port-channel1 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.10.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, Unknown Speed
      ARP type: ARPA, ARP Timeout 04:00:00
        No. of active members in this channel: 2
            Member 0 : FastEthernet5/1/0
            Member 1 : FastEthernet5/1/1
      Last input 00:00:14, output never, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/300/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         6720 packets input, 923310 bytes, 0 no buffer
         Received 5010 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
         1902 packets output, 573088 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    7500#
    
    7500# show interface port-channel 1.2
    
    Port-channel1.2 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.11.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation 802.1q Virtual LAN, Vlan ID  2.
      ARP type: ARPA, ARP Timeout 04:00:00

    Esta é a saída para o entroncamento ISL e o FEC:

    7500# show interface port-channel 1
    
    Port-channel1 is up, line protocol is up 
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, Unknown Speed
      ARP type: ARPA, ARP Timeout 04:00:00
        No. of active members in this channel: 2 
            Member 0 : FastEthernet5/1/0
            Member 1 : FastEthernet5/1/1
      Last input 00:00:01, output never, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/300/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         113 packets input, 7278 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
      13 packets output, 2264 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    
    7500# show interface port-channel 1.1
    
    Port-channel1.1 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.10.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ISL Virtual LAN, Color 1.
      ARP type: ARPA, ARP Timeout 04:00:00
    
    7500# show interface port-channel 1.2
    
    Port-channel1.2 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.11.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ISL Virtual LAN, Color 2.
      ARP type: ARPA, ARP Timeout 04:00:00
  • mostre o entalhe dos FastEthernet das relações//porta do adaptador de porta — mostra o estado das interfaces física do roteador e se algum erro existe nas relações. Neste exemplo, é sem erros.

    7500# show interface fastethernet 5/1/0
    
    FastEthernet5/1/0 is up, line protocol is up
      Hardware is cyBus FastEthernet Interface, address is 0001.6490.f8a8
      (bia 0001.6490.f8a8)
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, 100Mb/s, 100BaseTX/FX
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 1d00h, output 00:00:07, output hang never
      Last clearing of "show interface" counters 1d00h
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         2929 packets input, 425318 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
         12006 packets output, 1539768 bytes, 0 underruns
         0 output errors, 0 collisions, 6 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    7500#

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 23307