Voz e comunicações unificadas : Gateways universais Cisco AS5300 Series

Usando Dialout/EZ com um Cisco access server

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O produto DialOut/EZ do software tático permite que os usuários do desktop LAN compartilhem de portas do servidor do acesso de rede (NAS) como um conjunto de modem para comunicações assíncronas externas. Os usuários de DialOut/EZ já não precisam modens dedicados e linhas telefônica em seus desktops, mas usam pelo contrário o software do redirecionador de porta de uma comunicação (COM:) para permitir que as portas de discagem nos servidores de acesso apareçam como modens locais aos aplicativos de comunicação do desktop. Os usuários de Windows podem discar através de um server central NAS/access para alcançar serviços on-line remotos e para enviar mesmo fax de seus PC. O software release do ½ do ¿  de Cisco IOSï que é executado no NAS deve apoiar o protocolo de controle da porta COM (RFC 2217). Você pode encontrar mais informação sobre o DialOut/EZ do software tático do Web site da empresa em: http://www.tacticalsoftware.comleavingcisco.com .

Nota: DialOut/EZ é uma substituição para o utilitário do dialout Cisco.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • O software tático exige que o Cisco IOS Software Release 12.0(9) ou Mais Recente esteja instalado no NAS para interoperar com DialOut/EZ.

  • Devido à identificação de bug Cisco CSCds28071, Cisco recomenda que você executa o Cisco IOS Software Release 12.1(8) ou Mais Recente.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Instalação e configuração

Instalando os drivers de modem apropriados para dialout/EZ a porta COM virtual

  1. Instale DialOut/EZ.

    Para a informação de instalação completa DialOut/EZ em uma estação de trabalho cliente, refira o Guia do Usuário no Web site do software tático: DialOut/EZ.

  2. Transfira excitadores do modem.

    As portas COM virtuais DialOut/EZ não têm nenhuns dispositivos do modem anexada a ele. O usuário DialOut/EZ deve usar um arquivo apropriado do .inf para o Modems (instale um excitador do modem nas portas COM virtuais). Os arquivos do .inf MICA, de NextPort e de Microcom estão disponíveis para a transferência da site da Cisco na Web. Para as outras Plataformas use os arquivos especificados do .inf.

    Tipo de modem Plataforma arquivo do .inf
    MICA 3600, AS5200,AS5300,AS5800 mdcsmica.inf
    NextPort AS5350,AS5400 AS5800, AS5850
    Microcom AS5200 mnpv90.inf
    NM-xAM 2600, 3600 Microcom DeskPorte V.34 JEJUA
    WIC-xAM 2600, 3600 mdmrock5.inf (ou o padrão 28800 bps de arquivo do modem)

    Nota: Para Windows XP, Cisco forneceu arquivos do .inf não pode trabalhar. Tente usar um arquivo incorporado do .inf de Windows pelo contrário.

  3. Instale excitadores do modem.

    Para instalar um excitador do modem no PC Windows, use o seguinte procedimento:

    1. Iniciar > Configurações > Painel de Controle > Opções de Telefone e Modem.

    2. Selecione o modem e adicionar-lo para adicionar um modem novo.

    3. Select não detecta meu modem; Eu selecioná-la-ei de uma lista, a seguir clico-a em seguida.

    4. Selecione o fabricante e o modelo de seu modem. Selecionar Cisco na janela esquerda indica a mica na janela direita.

    5. Select tem o disco e consulta ao lugar onde o arquivo do .inf salvar.

    6. Na opção das portas selecionada, use a porta COM selecionada durante a Instalação de discagem EZ (por exemplo, COM 5).

Configurando o servidor de acesso

A configuração de IOS Software necessária para aplicativos de discagem de modem do modo de caractere somente (como com DialOut/EZ) vai sob a configuração de linha:

line starting_line_number ending_line_number
     modem dtr-active  
     
! -- If the router is for dialin and dialout use "modem inout" instead

     transport input telnet
     
! -- Or transport input all could be used

     escape-character NONE 
     
! -- Due to Bug CSCdv12194 for the AS5350/AS5400.

     rotary 1 
     
! -- Specifies the use of TCP port 7001 in the Dialout/EZ manager 
     ! -- window to dial out rotary 1

Se os Modens externos são usados, a seguir adicionar a camada física RS232 e os parâmetros de enquadramento sob a configuração de linha como desejada:

speed 115200 
    
 ! --  Set to the highest speed supported by the modems

     flowcontrol hardware
     parity even 
     databits 7 
     
! -- Or databits 8

     stopbits 1 
     
! -- Recommended for best throughput

Se você quer controlar o acesso às linhas da discagem, adicionar o seguinte no modo de configuração de linha:

password password

Alternativamente, configurar o Authentication, Authorization, and Accounting (AAA) e aplique a lista à linha com:

login authentication listname

Se você deseja controlar que troncos estão usados para os atendimentos da discagem, use o comando modem dialout controller introduzido no Cisco IOS Software Release 12.1(T) (a partir de agora, apoiado no AS5300 somente). Para mais informação, refira configurar uma interface T1 ou E1 para chamadas analógicas de saída usando o comando modem dialout controller.

Dica: Às vezes DialOut/EZ pode obter confuso pela mensagem da APROVAÇÃO da senha do IOS Software. Para evitar esta edição, configurar o AAA (local ou server-baseado) no roteador. Refira o AS5xxx com seção AAA deste documento para uma configuração de exemplo.

Opcional: Você pode igualmente configurar um modemcap para restaurar o modem à configuração padrão após cada atendimento. Use o comando modem autoconfigure type mica sob a configuração de linha. Este modemcap (que ajusta o &F) do padrão de fábrica pode ser aplicado a todo o Roteadores apesar do tipo de modem (MICA, NextPort, Microcom, etc.). Para obter mais informações sobre do modemcaps, refira as tampas de modem recomendadas para modens internos digitais e analógicos no Cisco access servers.

O mesmo servidor de acesso pode ser usado para a discagem assim como a discagem (aplicativo). Para configurações de amostra detalhadas refira as configurações de NAS de amostra da seção para o utilitário dialout/ez.

Troubleshooting do DialOut/EZ

Siga o método esboçado abaixo para pesquisar defeitos problemas relacionados DialOut/EZ:

  1. Inverta o telnet ao modem de NAS do prompt de exec NAS. Assegure-se de que você possa conectar ao modem emitindo no comando que deve retornar uma resposta APROVADA. Se você pode conectar ao modem, tente discar o número do dispositivo remoto usando o comando do ######## do atdt. Se a conexão é bem sucedida, a seguir a configuração de roteador está correta e o hardware está funcionando corretamente.

    Nota: Use a escala da porta TCP de Telnet binário: rotary_number 6000+line para usar uma linha específica, ou 7000+ para uma discagem giratória.

    O exemplo abaixo mostra uma chamada bem sucedida:

    maui-nas-03#telnet 172.22.53.150 7001
    
    ! -- Reverse Telnet to an up/up interface on the router 
    ! -- and use port 7000+rotary
    
    Trying 172.22.53.150, 7001 ... Open
    User Access Verification
    !
    Username: admin
    Password:
    at
    OK
    
    ! -- Modem is responding
    
    atdt 81560
    
    ! -- Dial number 81560 to connect to remote device. 
    ! -- This may take up to 30 seconds.
    
    CONNECT 33600 /V.42/V.42bis
    
    ! -- Call is connected to the remote device.
    
      User Access Verification
    
    ! -- Username prompt by remote device
    
      Username: cisco
      Password: maui-nas-01>

    Se o telnet reverso não alcança o modo de comando modem at, a seguir o NAS está desconfigurado. Verifique o seguinte:

    1. A relação cujo endereço IP de Um ou Mais Servidores Cisco ICM NT que você é Telnetting ao deve ser Up/Up e processo de ping do host PC no LAN. Se você não pode sibilar a interface do roteador pesquise defeitos seu LAN para questões relacionadas a roteamento.

    2. A linha do modem deve ter a entrada/saída de modem (para a discagem/discagem) ou o modem DTR-ativo (para a discagem somente).

    3. A linha deve ser configurada com telnet da entrada de transporte ou entrada de transporte todos.

    Se o telnet reverso sucede em alcançar o modo de comando modem at, mas a chamada manual falha, a seguir o problema poderia ser uma edição do telco ou do roteador remoto. Pesquise defeitos o roteador remoto, a linha e reexamine a conexão antes de continuar mais. Refira pesquisando defeitos a Conectividade da tecnologia de discagem - Chamada Externa Não-DDR para mais informação.

  2. Tente um telnet reverso de um host PC no LAN. Hyper terminal das janelas aberta (ou Telnet do Windows) e telnet ao endereço IP de Um ou Mais Servidores Cisco ICM NT e à porta que do roteador você se está usando para DialOut/EZ (por exemplo 7001). Se você pode alcançar o modem e a discagem, a seguir não há nada erradamente com o LAN (nós tínhamos verificado previamente que a discagem do NAS está trabalhando).

  3. Se o telnet reverso não alcança o modo de comando modem at, a seguir o NAS está desconfigurado ou a rede IP não está funcionando. Verifique o seguinte:

    1. A relação cujo endereço IP de Um ou Mais Servidores Cisco ICM NT que você é Telnetting ao deve ser Up/Up e processo de ping do host PC no LAN. Se você não pode sibilar a interface do roteador pesquise defeitos seu LAN para questões relacionadas a roteamento.

    2. Não deve haver nenhuma acesso-classe que está obstruindo a conexão Telnet.

    As seguintes capturas de tela mostram uma sessão de hiperterminal bem sucedida:

    hyperterm1.gif

    hyperterm2.gif

    Nota: Se você está usando o cliente telnet de Microsoft Windows e o AAA é configurado no NAS, o início de uma sessão do Telnet do Windows pode falhar. Esta falha é causada por configurações de aplicativo e caracterizada por uma incapacidade incorporar a senha, assim o início de uma sessão falha. Para corrigir o ajuste do aplicativo Telnet para esta sessão, siga o procedimento abaixo no host PC:

    1. Iniciar > Executar > tipo telnet, APROVAÇÃO do clique.

    2. Datilografe o comando unset crlf. (Isto se assegura de que você envie teclas semelhantes a tecla ENTER como o telnet <CR><NUL> um pouco do que o <CR><LF>.)

    3. Use o <port> aberto do <ip_address> ao telnet ao modem.

    4. Você deve agora ser conectado ao Modems e pode agora iniciar o discagem manual usando o atdt tal como com as mostras do exemplo do HyperTerminal acima. A seguinte captura de tela é um exemplo:

      wintelnet1.gif

  4. O HyperTerminal do uso a conectar diretamente aos modens de NAS através de DialOut/EZ emulou a porta COM. Refira o capítulo do guia do usurário dialout/ez na instalação em http://www.tacticalsoftware.comleavingcisco.com para mais informação. Isto verificará que a porta COM emulada DialOut/EZ está funcionando.

    Se o HyperTerminal sobre a porta COM emulada DialOut/EZ não trabalha, a seguir o problema pareceria ser peculiar a uma comunicação DialOut/EZ com os IO. Recolha a informação seguinte:

    • Estes debugam determinam se o NAS está recebendo a conexão Telnet.

      debug telnet 
      debug modem
      
    • O log do traço DialOut/EZ: Selecionar a opção do menu de janela do traço abre o indicador do 3.0 do monitor de porta DialOut/EZ, com a aba do indicador do traço permitida. Para começar a seguir, verifique a caixa do traço da possibilidade na parte inferior deste indicador. Certifique-se que você salvar o log para a análise mais aprofundada. Refira a seção de Troubleshooting do Guia do Usuário no Web site do software tático para mais informação.

  5. Desde que nós verificamos que DialOut/EZ pode conectar ao Modems, tenha em seguida o novato do fim de aplicativo uma conexão. Se os fins de aplicativo não podem falar entre si usando a conexão DialOut/EZ, a seguir o problema poderia ser peculiar ao fim de aplicativo. O log do traço DialOut/EZ pode ser útil em pesquisar defeitos esta edição. Igualmente gire sobre o log de modem de Windows TAPI, e igualmente o registro disponível do aplicativo. Refira o Web site de Microsoftleavingcisco.com para o seguinte artigo Microsoft: Como criar e usar o arquivo de Modemlog.txt (Q142730) para mais informação.

    Se a operação ainda não trabalha como desejado, recolha os IO debuga, o log do traço DialOut/EZ, e (se aplicável) o log de modem de Windows, e analisam os resultados para determinar onde o aplicativo está falhando.

    Refira o software tático: Perguntas mais frequentesleavingcisco.com para a informação adicional.

Exemplos de configurações NAS para o utilitário DialOut/EZ

AS25xx, NM-xAM, WIC-xAM

Seguir é um arquivo de configuração de exemplo para o Roteadores com modens analógicos externos, tais como Cisco AS2509, Cisco AS2510, Cisco AS2511, ou servidor de acesso assim como Roteadores de Cisco AS2512 com modens analógicos internos (NM-xAM e o WIC-xAM) como o 26xx, e 36xx Series Router.

O exemplo abaixo mostra o roteador capaz das chamadas recebidas e enviadas. Se o roteador é para o uso de partida somente, a seguir a configuração de linha é tudo que é precisado.

interface Group-Async1
   
! -- Group-Async interface used for dialin calls
   ! -- This is not used for dialout

    ip unnumbered Ethernet0
    no ip mroute-cache
    encapsulation ppp
    no ip route-cache
    async default routing
    async dynamic address
    async mode interactive
    peer default ip address pool local
    dialer in-band
    no cdp enable
    ppp authentication chap
    group-range 1 8
    
! -- Range of lines include 1 through 8
    ! -- Modems 1 through 8 can now be used for incoming or outgoing calls

   !
   line 1 8
    
! -- Line configuration used for Dialout/EZ

    modem InOut
    
! -- Modem can be used for dialing and dialout
    ! -- If the line is used for dialout only use "modem dtr-active"

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport preferred telnet
    transport input all
    
! -- You could also use transport input telnet instead

    rxspeed 115200
    txspeed 115200
    
! -- Speed for external modems
    ! -- This is not needed for internal analog modems (NM-xAM, WIC-xAM)
 
    flowcontrol hardware
    
! -- Flowcontrol for external modems
    ! -- This is not needed for internal analog modems (NM-xAM, WIC-xAM

AS5xxx sem AAA

Seguir é um arquivo de configuração de exemplo para um servidor de acesso do AS5xxx Series de Cisco sem AAA.

Este exemplo mostra o roteador que aceita chamadas recebidas e que faz chamadas externas:

controller T1 0
   
! -- T1 interface used for incoming and outgoing calls

    framing esf
    clock source line primary
    linecode b8zs
    pri-group timeslots 1-24
   !
   interface Serial0:23
   
! -- D-channel configuration for T1 0
   ! -- This configuration is only needed for incoming calls

    ip address 10.15.2.80 255.255.255.0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no keepalive
    dialer idle-timeout 400
    dialer map ip 10.15.2.60 6661210
    dialer-group 1
    isdn incoming-voice modem
    
! -- Incoming analog calls will be switched to the modems

    peer default ip address pool setup_pool
    no fair-queue
    no cdp enable
    ppp authentication chap
    ppp multilink
   !
   interface Group-Async1
   
! -- Group-async configuration for incoming calls
   ! -- This configuration is not used for outgoing calls

    ip unnumbered Ethernet0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool setup_pool
    ppp authentication chap pap
    group-range 1 48
    
! -- Range of lines include 1 through 48
    ! -- Modems 1 through 48 can now be used for incoming or outgoing calls

   !
   line 1 48
   
! -- Line configuration for Dialout/EZ

    exec-timeout 0 0
    autoselect during-login
    autoselect ppp
    
! -- The autoselect commands are used for protocol selection for incoming calls
    ! -- This is not needed if the router only makes outbound calls

    modem InOut
    
! -- Modem can be used for dialing and dialout if the line is used for
    ! -- dialout only use, modem dtr-active transport preferred telnet

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport input all
    transport input telnet
    
! -- Configure one or both of the above commands

AS5xxx com AAA

Seguir é um arquivo de configuração de exemplo para servidores de acesso do AS5xxx Series de Cisco com o AAA baseado em servidor configurado.

O exemplo seguinte, mostra um servidor de acesso configurado para atendimentos da discagem e da discagem:

aaa new-model
   aaa authentication login default radius
   
! -- Use the radius server for login on the default list
   ! -- for local AAA replace "radius" with "local" 
   ! -- (make sure to configure the username/password locally as well

   aaa authentication ppp ppptac radius
   
! -- Use the radius server for ppp on the list named ppptac
   ! -- This is used for incoming ppp calls and is not used for outgoing 
   ! -- Dialout/EZ calls
   !

   controller T1 0
   
! -- T1 interface used for incoming and outgoing calls

    framing esf
    clock source line primary
    linecode b8zs
    pri-group timeslots 1-24
   !
   interface Serial0:23
   
! -- D-channel configuration for T1 0
   ! -- This configuration is only needed for incoming calls

    ip address 10.15.2.80 255.255.255.0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    no keepalive
    dialer idle-timeout 400
    dialer map ip 10.15.2.60 name test 5551210
    dialer-group 1
    isdn incoming-voice modem
    peer default ip address pool setup_pool
    no fair-queue
    no cdp enable
    ppp authentication chap ppptac
    ppp multilink
   !
   !
   interface Group-Async1
   
! -- Group-async configuration for incoming calls
   ! -- This configuration is not used for outgoing calls

    ip unnumbered Ethernet0
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    async dynamic address
    async dynamic routing
    async mode interactive
    peer default ip address pool setup_pool
    ppp authentication chap pap ppptac
    
! -- Use list named ppptac for authentication

    group-range 1 48
    
! -- Range of lines include 1 through 48
    ! -- Modems 1 through 48 can now be used for incoming or outgoing calls

   !
   !
   radius-server host 10.4.1.10
   radius-server timeout 20
   radius-server key nas1
   
! -- Radius server configuration

   !
   line 1 48
    
! -- Line configuration for Dialout/EZ as well as dialin calls

    exec-timeout 0 0
    autoselect during-login
    autoselect ppp
    
! -- The autoselect commands are used for protocol selection for incoming calls
    ! -- This is not needed if the router only makes outbound calls

    modem InOut
    
! -- Modem can be used for dialing and dialout
    ! -- If the line is used for dialout only, use modem dtr-active transport 
    ! -- preferred telnet

    rotary 1
    
! -- The lines are placed in a rotary
    ! -- They are accessed by Dialout EZ using port (7000 + rotary)=7001

    transport preferred telnet
    transport input all
    
! -- You could also use transport input telnet instead


Informações Relacionadas


Document ID: 23241