IP : Alocação e resolução dinâmica de endereços

Configurando dinamicamente as opções do servidor de DHCP

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (3 Abril 2008) | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O DHCP permite que você atribua automaticamente endereços IP reutilizáveis a clientes DHCP. Este documento fornece um exemplo de como configurar as opções de DHCP, como endereços de Sistema de Nome de Domínio (DNS) e de Windows Internet Name Service (WINS), para responder às solicitações DHCP de clientes locais por trás do Customer Premises Equipment (CPE).

Previamente, os administradores de rede tiveram que manualmente configurar o servidor DHCP de Cisco IOS� em cada dispositivo permitido com esta característica. Após a distribuição de um roteador, é uma tarefa muito trabalhosa, demorada e cara acessar cada local e fazer modificações.

Consequentemente, o servidor de DHCP IOS Cisco foi aumentado a fim permitir que a informação de configuração seja atualizada automaticamente. Os administradores de rede podem configurar um ou mais servidores DHCP centralizados para atualizar opções específicas de DHCP dentro dos conjuntos de DHCP. Os servidores remotos podem pedir ou importar estes parâmetros de opção dos servidores centralizados.

Pré-requisitos

Requisitos

Cisco recomenda leitores deste documento tem o conhecimento destes assuntos:

  • DHCP

  • Domain Name System (DNS)

  • Windows Internet Name Service (VITÓRIAS)

Componentes Utilizados

Esta configuração foi desenvolvida e testada com estes a versão de software e hardware:

  • Software Release 12.2(27) de Cisco IOS�

  • Dois Cisco 3660 Router com o NM-1E usado para o PC e a conexão de cliente

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Nota: Os recursos do servidor de DHCP IOS Cisco são introduzidos no Cisco IOS Software Release 12.0(1)T. Você precisa o Software Release 12.0(2)T ou Mais Recente de Cisco IOS� para o uso com Cisco 1700 Series Router. Para obter mais informações sobre do Roteadores que apoia a característica do servidor DHCP, veja a seção das plataformas suportadas do documento do servidor de DHCP IOS Cisco.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você é presentado com a informação para configurar opções de DNS e VITÓRIAS do servidor DHCP. O roteador “central” é configurado para estas opções Server e o roteador “remoto” importa estas opções. O PC remoto ou o cliente recebem estas opções importadas do roteador “remoto” durante sua fase DHCPACK.

Nota: A fim encontrar a informação adicional nos comandos usados neste documento, refira comandos DHCP ou use a ferramenta de consulta de comandos (clientes registrados somente).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama:

/image/gif/paws/22920/dhcp_ser_01.gif

Configurações

Este documento utiliza as seguintes configurações:

Central (3660)
Central# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 10.0.0.1 10.0.0.5

!--- This range must not be assigned to DHCP clients.

!
ip dhcp pool Central   
   network 10.0.0.0 255.255.255.0

!--- Specify the network number and mask for DHCP clients.
   
   domain-name Central

!--- Specify the domain name for the client.
   
   dns-server 10.0.0.2

!--- Specify the DNS server you want to respond to DHCP clients who


!--- need to correlate the host name to the IP address.
   
   netbios-name-server 10.0.0.2

!--- Specify the Network Basic Input/Output System (NetBIOS)


!--- WINS server (for Microsoft DHCP clients)
 
!
.
.
!
interface FastEthernet0/0 
 ip address 10.0.0.1 255.255.255.0 
 duplex auto 
 speed auto
!
.
.
!
end

Nota: Quando você usa um roteador Cisco como o servidor DHCP, simplesmente um domínio está permitido pelo conjunto de DHCP, ou seja o roteador não pode enviar aluguéis de DHCP aos clientes que incluem dois Domain Name. Não é possível misturar o mapeamento estático em um conjunto dinâmico. Se é misturado, os % este comando não podem ser usados com rede, origem, vrf, ou o Mensagem de Erro das associações do relé aparece.

Remoto (3660)
Remote# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 192.168.1.1

!--- This ip address must not be assigned to DHCP clients.

!
ip dhcp pool Client   
   import all

!--- Import DHCP option parameters into the database.
   
   network 192.168.1.0 255.255.255.248

!--- Specify the network number and mask for DHCP clients.

   default-router 192.168.1.1

!--- Specify the default gateway for DHCP clients.
	
!
.
.
!
interface FastEthernet0/0 
 ip address dhcp 
 duplex auto 
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
end

O comando service config é usado conjuntamente com o host ou o comando boot network da bota. O comando service config é inscrito permitir o roteador de configurar automaticamente o sistema do arquivo especificado pelo host ou pelo comando boot network da bota.

O comando service config pode igualmente ser usado sem o host ou o comando boot network da bota. Se você não especifica nomes de arquivo do host ou da configuração de rede, o roteador usa os arquivos de configuração padrão. O arquivo de configuração da rede padrão é rede-configuração. O arquivo de configuração do host do padrão é a host-configuração, onde o host é o nome de host do roteador. Se o Cisco IOS Software não pode resolver seu nome de host, o arquivo de configuração do host do padrão é roteador-configuração.

Use o comando boot host junto com o comando service config. Sem o comando service config, o roteador ignora o comando boot host e usa a informação de configuração no NVRAM. Se a informação de configuração no NVRAM falta inválida ou, o comando service config está permitido automaticamente. O servidor de rede tentará carregar dois arquivos de configuração dos host remotos. O primeiro é o arquivo de configuração de rede que contém os comandos que se aplicam a todos os servidores de rede em uma rede. Use o comando boot network identificar o arquivo de configuração de rede. O segundo é o arquivo de configuração do host que contém os comandos que se aplicam a um servidor de rede em particular. Use o comando boot host identificar o arquivo de configuração do host.

O cliente manda uma transmissão malgrado o facto que a opção 150 seja configurada devido a sua natureza do padrão para olhar para fora para o servidor TFTP e a opção 150 seja definida no lado de servidor não o lado do cliente. A não ser o TFTP, a opção 150 está igualmente disponível para estes:

  • 150 Etherboot

  • Nome de caminho da configuração de 150 LARVAS

As opções de DHCP podem ser configuradas com o comando do TFTP-server-nome do string ascii do código de opção. Se você não tem o nome do server e se o server está configurado somente com o endereço IP de Um ou Mais Servidores Cisco ICM NT, a seguir use o comando do endereço IP do código de opção.

Verificar

Esta seção fornece informações que você pode usar para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Remote#show ip dhcp import
Address Pool Name: Client
Domain Name Server(s): 10.0.0.2
NetBIOS Name Server(s): 10.0.0.2
Domain Name Option: Central
Central#show ip dhcp server statistics
Memory usage         13906
Address pools        1
Database agents      1
Automatic bindings   1
Manual bindings      0
Expired bindings     0
Malformed messages   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         1
DHCPREQUEST          1
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           0

Message              Sent
BOOTREPLY            0
DHCPOFFER            1
DHCPACK              1
DHCPNAK              0
Central#show ip dhcp binding
IP address       Client-ID/Hardware address	 	Lease expiration            Type
10.0.0.6         0063.6973.636f.2d30.                   Apr 25 2005 12:30 AM        Automatic
                 3036.302e.3563.6634.
                 2e61.3961.382d.4574.        
                 30

Troubleshooting

Esta seção fornece informações que podem ser usadas para o troubleshooting da sua configuração.

Comandos para Troubleshooting

Nota: Antes de emitir comandos de depuração, consulte Informações Importantes sobre Comandos de Depuração.

A saída tomada de um PC ou de um cliente com um sistema operacional de Microsoft Windows com o comando de /all do ipconfig dá os valores da configuração TCP/IP configurados pelo DHCP. Refira o RFC 2132leavingcisco.com para obter mais informações sobre das opções de DHCP.

C:\>ipconfig /all 
  
Windows 2000 IP Configuration 
  
  Host Name . . . . . . . . . . . . : PC 
  Primary DNS Suffix . . . . . . .  : cisco.com 
  Node Type . . . . . . . . . . . . : Hybrid 
  IP Routing Enabled. . . . . . . . : No
  WINS Proxy Enabled. . . . . . . . : No 
  DNS Suffix Search List. . . . . . : cisco.com 
                                       
Ethernet adapter Local Area Connection :
	 
  Connection-specific DNS Suffix . : Central 
  Description . . . . . . . . . .  : 3Com EtherLink XL 10/100 PCI TX NIC(3C905B-TX) 
  Physical Address. . . . . . . .  : 00-10-5A-86-5A-CA 
  DHCP Enabled. . . . . . . . . .  : Yes 
  Autoconfiguration Enabled . . .  : Yes 
  IP Address. . . . . . . . . . .  : 192.168.1.2 
  Subnet Mask . . . . . . . . . .  : 255.255.255.248 
  Default Gateway . . . . . . . .  : 192.168.1.1
  DHCP Server . . . . . . . . . .  : 10.0.0.6 
  DNS Servers . . . . . . . . . .  : 10.0.0.2 
  Primary WINS Server . . . . . .  : 10.0.0.2 
  Lease Obtained. . . .  . . . . . : Tuesday, April 26, 2005 6:04:29 PM 
  Lease Expires . . . . . . . .. . : Wednesday, April 27, 2005 6:04:29 PM

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 22920