Asynchronous Transfer Mode (ATM) : Classe de serviço IP à ATM

Aplicação de Políticas de Servidor QoS e CBWFQ/LLQ em ATM PVCs de Ligação

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece um exemplo de configuração para as opções de enfileiramento virtual, como CBWFQ e LLQ, em interfaces ATM configuradas para aceitar unidades de dados de protocolo (PDUs) em formato transposto RFC 1483.

Suportes de software do ½ do ¿  de Cisco IOSï três protocolos para rotear rede desconectada (a um número de rede IP diferente) em aplicativos interligados do RFC 1483. Esses protocolos são Integrated Routing e Bridging (IRB), Route-Bridge Encapsulation (RBE) e Bridged-Style Permanent Virtual Circuits (PVCs). Todos esses protocolos permitem que um ATM PVC receba PDUs em formato de ligação. Este documento refere os PVC configurados com um Bridging Protocol tal como PVC construídos uma ponte sobre.

Uma política de serviço configurada com a interface de linha de comando (CLI) modular de qualidade de serviço (QoS) (MQC) aplica os mecanismos de QoS a uma interface, sub-interface ou VC. Em PVCs transpostos, só há suporte para as políticas de serviço que aplicam um mecanismo de enfileiramento virtual com RBE Não há suporte para políticas de serviço em VCs de ATM configuradas para executar o IRB. Em tais VC, se você define um mapa de classe que combina em uma lista de acesso IP (ACL), nenhum fósforo do pacote a esta classe ocorre, e todos os pacotes são classificados à classe padrão.

Pré-requisitos

Requisitos

Os leitores deste documento devem ter o conhecimento destes assuntos::

Nota: A configuração de IRB não apoia por vc o CBWFQ ou o LLQ. A configuração deve ser migrada ao RBE ou ao PPPoE sobre a configuração de ATM antes que você tente executar o CBWFQ ou o LLQ.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 2620 Router com interface ATM NM-1A-OC3

  • Cisco IOS Software Release 12.2(27)

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

A política de serviço de QoS gerencia a profundidade da fila, marca o tráfego e identifica tráfego não crítico em uma base por VC. Especificamente, esta política consegue estes objetivos:

  • Usos NBAR a fim classificar o tráfego NON-negócio-crítico, tal como Napster.

  • Usa a característica do class-based policing para marcar o valor de precedência da conformação, de exceder e de violar o tráfego.

  • Applies classe-baseou o WRED a fim controlar a profundidade de fila.

    Nota: Seja mutuamente exclusivos a nível PVC. Você não pode aplicar um grupo WRED a um VC para que você permitiu o CBWFQ com o aplicativo de uma política de serviços. Contudo, você pode aplicar ambas as características se você configura o comando random-detect em uma classe dentro do mapa de política.

  • Aplica o Class-based Marking com o comando set a fim marcar estes valores de precedência IP pelo tipo de tráfego.

Valor de precedência Tipo de tráfego
1 NON-negócio-crítico, como Napster
4 Padrão, usado para o tráfego normal
5 Reservado para tráfego em tempo real futuro, como voz por IP (VoIP).
6 e 7 Reservado para o tráfego do controle de rede

Os possíveis pontos de congestionamento são os VCs ATM que alimentam os usuários conectados ao DSL. Os fluxos de IP chegam na interface Fast Ethernet em até 10 Mbps e deixam os ATM VCs. Eles são configurados para a categoria de serviço de ATM de taxa de bits não especificada (UBR) com uma taxa de célula de pico (PCR) padrão da interface T1 (1,544 Mbps). Assim, a serviço-política de QoS marca o tráfego que chega na interface rápida de Ethernet. Os valores observados são usados então pelo WRED a fim criar as classes de serviço baseadas na Precedência IP e proporcionar o serviço diferenciado através dos níveis originais da gota pela classe.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/22820/bridging_cbwfq1.gif

Nota: O ATM VC da categoria de serviço UBR não fornece nenhuma largura de banda mínima por definição. Assim, você não pode aplicar o CBWFQ ou o LLQ e garantir a largura de banda a um UBR VC. A fim fazer assim, você deve mudar a categoria de serviço ATM a algo a não ser o UBR, tal como o VBR-NRT ou o ABR. Para mais detalhes nisto, refira a compreensão da categoria de serviço UBR para circuitos virtuais ATM.

Configurações

Este documento utiliza esta configuração:

Cisco 2600 Router
class-map match-any HTTP-HACKS 

!--- Use the class-map command in global configuration mode
!--- in order to match packets to a specified class.


   match protocol http url "*.ida*"  
   
!--- In order to configure NBAR to match HTTP traffic 
!--- by URL, HOST, or Multi-purpose Internet Mail Extension (MIME)-type, use the
!--- match protocol http command in class-map configuration mode.

   match protocol http url "*cmd.exe*"  
   match protocol http url "*root.exe*"  
   match protocol http url "*Admin.dll*"  
   match protocol http url "*readme.eml*"  
class-map match-any JUNK  
   match protocol napster 
   match protocol fasttrack
class-map match-all IP-PREC-4  match ip precedence 4class-map match-all DEFAULT  
match any
! 
policy-map DSL-OUT-C

!--- Use this command
!--- in order to create or modify a policy map that can be attached to one or more 
!--- interfaces to specify a service policy.

  class IP-PREC-4
   police 32000 250000 5000000 conform-action set-prec-transmit 4 exceed-action
 set-prec-transmit 3 violate-action set-prec-transmit 2
  
!--- Use this command to mark a packet with different quality of service (QoS) 
!--- values based on conformance to the service-level agreement.

! 
policy-map LAN-IN  
  class HTTP-HACKS  
     police 8000 1000 1000 conform-action drop exceed-action
       drop  
  class JUNK  
   set ip precedence 1  
  class DEFAULT  
   set ip precedence 4  
! 
policy-map DSL-OUT  
   class class-default
    
!-- Used to make class-default a single FIFO queue 
!-- inside the WFQ system. 
 
    bandwidth percent 1 
    
    random-detect  
    random-detect exponential-weighting-constant 7  
    random-detect precedence 0   20    40    10  
    random-detect precedence 1   22    40    10 
    random-detect precedence 2   24    40    10 
    random-detect precedence 3   26    40    10 
    random-detect precedence 4   28    40    10  
    random-detect precedence 5   31    40    10  
    random-detect precedence 6   33    40    10  
    random-detect precedence 7   35    40    10  
    random-detect precedence rsvp   37    40    10 
    service-policy DSL-OUT-C
    
!--- In order to use a service policy as a QoS policy within a policy map
!--- (called a hierarchical service policy), use the service-policy command
!--- in policy-map class configuration mode.

! 
interface Loopback1  
  ip address 172.16.1.1 255.255.255.0  
!  
interface FastEthernet0/0  
  ip address 10.1.1.1 255.255.255.192  
  service-policy input LAN-IN  
  
!--- Use this command in order to attach a policy map to an input interface
!--- or virtual circuit (VC), or an output interface or VC, to be used as 
!--- the service policy for that interface or VC.

!  
interface ATM1/0  
  no ip address  
  no atm ilmi-keepalive 
!  
interface ATM1/0.4 point-to-point  
  ip unnumbered Loopback1  
  no ip redirects  
  no ip unreachables  
  no ip mroute-cache  
  atm route-bridged ip  
  pvc 1/35  
   service-policy output DSL-OUT  
  ! 
!  
interface ATM1/0.5 point-to-point  
  ip unnumbered Loopback1  
  no ip redirects  
  no ip unreachables  
 no ip mroute-cache  
  atm route-bridged ip 
 
!--- Use in order to configure an interface to use ATM RBE.

  pvc 1/36
   service-policy output DSL-OUT 
!
ip route 172.16.1.2 255.255.255.255 ATM1/0.4
ip route 172.16.1.3 255.255.255.255 ATM1/0.5
end

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • ATM de interface de enfileiramento da mostra — Indica as estatísticas de enfileiramento de um VC específico em uma relação. Um valor diferente de zero para “conversações ativas” está indicado durante os períodos de congestionamento em que os fluxos IP são enfileirados às filas da camada 3.

    2600# show queueing interface atm1/0.4
            Interface ATM1/0.4 VC 1/35
            Queueing strategy: weighted fair
            Total output drops per VC: 0
            Output queue: 0/512/64/0 (size/max total/threshold/drops)
               Conversations  0/1/64 (active/max active/max total)
               Reserved Conversations 1/1 (allocated/max allocated)
               Available Bandwidth 0 kilobits/sec
  • mostre a relação atm do mapa de política — Use este comando verificar estas estatísticas quando você monitora sua política de serviços:

    • Incrementar avalia para os pacotes que combinam a classe. Se isto não trabalha, assegure-se de que o CEF esteja permitido e que os pacotes estão seguindo o trajeto de CEF switching. Emita o comando show interface stats a fim ver se os pacotes são comutados por CEF.

    • Compare o valor de “packets” ao valor de “pkts matched”. Os valores "pkts matched" são incrementados apenas durante os momentos de congestionamento. Para mais informação, refira compreendendo contadores de pacote de informação em saídas de interface do mapa de política da mostra.

    • Número correto de perdas aleatórias. Monitora o valor do campo " profundidade de fila de significado " e determina se este campo alcança um valor acima do limiar mínimo. O WRED começa a deixar cair aleatoriamente pacotes quando a profundidade de fila média aumenta acima do limiar mínimo para uma Precedência IP particular em nível.

2600# show policy-map interface atm1/0.4
ATM1/0.4: VC 1/35 -
 Service-policy output: DSL-OUT
 Class-map: class-default (match-any)
     29121 packets, 41550530 bytes
     5 minute offered rate 0 bps, drop rate 0 bps
     Match: any
     Queueing
       Output Queue: Conversation 73
       Bandwidth 1 (%)
       (pkts matched/bytes matched) 59/8894
       (depth/total drops/no-buffer drops) 0/0/0
        exponential weight: 7
        mean queue depth: 0

 class    Transmitted      Random drop   Tail drop    Minimum   Maximum   Mark
          pkts/bytes       pkts/bytes    pkts/bytes   thresh    thresh    prob
 0        15791/22456790       0/0           0/0          20        40    1/10
 1           0/0               0/0           0/0          22        40    1/10
 2         8555/13041140       0/0           0/0          24        40    1/10
 3         3417/5207580        0/0           0/0          26        40    1/10
 4         1358/845020         0/0           0/0          28        40    1/10
 5           0/0               0/0           0/0          31        40    1/10
 6           0/0               0/0           0/0          33        40    1/10
 7           0/0               0/0           0/0          35        40    1/10
 rsvp        0/0               0/0           0/0          37        40    1/10
     Service-policy : DSL-OUT-C
 Class-map: IP-PREC-4 (match-all)
   13330 packets, 19093740 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   Match: ip precedence 4
   police:
     32000 bps, 250000 limit, 5000000 extended limit
     conformed 1358 packets, 845020 bytes; action: set-prec-transmit 4
     exceeded 3417 packets, 5207580 bytes; action: set-prec-transmit 3
     violated 8555 packets, 13041140 bytes; action: set-prec-transmit 2
     conformed 0 bps, exceed 0 bps, violate 0 bps
 Class-map: class-default (match-any)
   15791 packets, 22456790 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   Match: any 

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.


Informações Relacionadas


Document ID: 22820