WAN : Frame Relay

Exemplo de configuração do Distributed Traffic Shaping

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento discute o Distributed Traffic Shaping (DTS) e consolida muita da informação que está disponível hoje.

O modelagem de tráfego (TS) fornece um mecanismo para controlar o fluxo de tráfego em uma interface particular. o TS “distribuído” é um específico da característica às plataformas avançadas tais como o Cisco 7500 ou o 12000 Series Internet Router. Estas Plataformas têm a capacidade para offload o modelagem de tráfego do processador principal (Route Switch Processor - RSP ou Gigabit Route Processor - GRP) aos processadores da interface individual (Versatile Interface Processor - VIP ou placa de linha - LC). Nas redes onde o Distributed Cisco Express Forwarding (dCEF) é o modo preferido de interruptor, o DTS no VIP ou a placa de linha são a escolha lógica para o modelagem de tráfego.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Por que tráfego da forma com DTS?

Se você está lendo este documento, a seguir, muito provavelmente, você já tem uma ideia de porque você quer dar forma ao tráfego. A peça do quebra-cabeça distribuída deve ser consideravelmente clara, demasiado - você está distribuindo os deveres do processador principal aos processadores da placa individuais. No que diz respeito a dar forma, muitos clientes estão tentando simplesmente evitar exceder a taxa garantida do circuito baseado no acordo com o fornecedor. Isto impedir gotas na nuvem e, em consequência, reduzir retransmissões (com TCP/IP) quando os provedores descarta pacote. Um cenário comum onde você precise de dar forma ao tráfego é descrito abaixo. Neste exemplo, não há nenhuma necessidade para que a instalação central envie o tráfego na taxa T1 se o escritório filial tem somente um circuito 128K:

dts-config-01.gif

Há muitas razões adicionais para usar o DTS. Os benefícios incluem uma variedade de funcionalidades relacionadas do Qualidade de Serviço (QoS), e a movimentação para usar tão eficientemente a largura de banda como possível através dos tipos de tráfego variados. O DTS configura o modelagem de tráfego a nível de interface, subinterface em nível, ou nível da interface lógica para ATM ou circuitos virtuais permanentes do Frame Relay (PVC).

Dar forma pode conseguir uma disposição de objetivos da rede e pode fechar nos seguintes critérios:

  • Todo o tráfego no exame ou na interface lógica

  • Tráfego classificado através das lista simples e de controle de acesso de IP estendido (ACL) (endereços IP de Um ou Mais Servidores Cisco ICM NT, portas TCP/UDP, Precedência IP)

  • Tráfego classificado pelo grupo de QoS (um rótulo do pacote interno aplicado rio acima pela taxa de acesso comprometida - CAR, ou QoS Policy Propagation - QPPB)

O DTS apoia até 200 filas da forma pelo VIP, apoiando até as taxas OC-3 quando o tamanho médio do pacote é 250 bytes ou maior, e quando usando um VIP2-50 ou melhor com ram estática (SRAM) de 8M. O modelagem de tráfego ao contrário da regular (GTS), DTS não exige que o enfileiramento considerável tornado mais pesado (WFQ) esteja permitido. Em lugar de, o DTS usa o enfileiramento considerável ou first in distribuído, o first-out (FIFO, primeiro a entrar, primeiro a sair) (FIFO) para a fila moldada.

Específicos da plataforma

Esta tabela descreve como configurar o TS segundo a plataforma - principalmente ilustrando que a característica é significativa para plataformas de produto avançado:

  12000 Series 7500 Series 7200, 3600, 2600 e Outras Plataformas Não-VIP
Mecanismos de modelagem suportados DTS DTS GTS ou Frame Relay TS
Comando de configuração comando shape em um mapa de política comando shape em um mapa de política taxa de tráfego ou modelagem de tráfego do Frame Relay em uma interface principal, e com FRTS - comandos de configuração de classe de mapas especificar parâmetros moldados
Exige dCEF (distributed Cisco Express Forwarding) O padrão é CEF Sim (verifique com o comando show cef linecard) Não

Notas do 7500 Series DTS

No Cisco 7500 Series, a capacidade para configurar o Frame Relay Traffic Shaping (FRTS) que usa o comando frame-relay traffic-shaping é obstruída agora desde que o FRTS executa no RSP em um modo não-distribuído. Com dCEF e FRTS, uma adjacência do “pontapé” CEF faz com que todos os pacotes sejam comutados rapidamente pelo RSP, que é secundário-ótimo para o desempenho de encaminhamento máximo.

Até à data do Software Release 12.1(5)T do � do Cisco IOS, as políticas de QoS devem ser executado no modo distribuído no VIP; A rota/processador de switch (RSP) - QoS baseado é apoiada já não. Consequentemente, você deve usar o comando shape e outros comandos da interface de linha do comando modular qos (MQC) executar o DTS para relações em VIP no Cisco 7500 Series.

Quando o Cisco IOS Software Release 12.1(2)T introduziu o apoio para o low latency queueing (LLQ) em Plataformas diferentes do Cisco 7500 Series, o LLQ distribuído (dLLQ) foi introduzido em 12.1(5)T no VIP. A versão distribuída aumenta o desempenho desta característica. Você pode configurar uma política de serviço exclusivo pelo identificador da conexão de link de dados (DLCI). Você não precisa de usar um map class e pode aplicar o comando service-policy diretamente à subinterface ou ao DLCI. Contudo, Cisco recomenda que você configura o dLLQ dentro de um map class.

Ao aplicar FRF.12 distribuído (fragmentação) a uma interface do Frame Relay, você deve definir um map class e aplicar a política de serviços sob o map class. O FRF.12 foi introduzido na versão 12.0(4)T do Cisco IOS Software e é estendido ao Cisco 805, 1600, 1700, 2500, 4500, e Plataformas do 4700 Router como da versão 12 1(2)T do Cisco IOS Software. Para detalhes adicionais, refira o apoio FRF.12 em Plataformas adicionais.

Notas do 12000 Series Internet Router DTS

No 12000 Series, a comutação rápida do interruptor e do processo não é opções. Se um prefixo de destino não pode ser resolvido a uma entrada de encaminhamento nas tabelas de entrada da placa de linha (LC), o pacote está deixado cair. Somente os pacotes que combinam uma adjacência glean punted ao Gigabit Routing Processor (GRP). Além, nos 12000, o LC CPU não pacotes do pontapé ao GRP para características, e o LC envia um Internet Control Message Protocol (ICMP) inacessível (enquanto o comando no ip unreachables não é configurado). Nos 12000, o único tráfego punted ao GRP é pacotes destinados a uma relação no roteador ou aos pacotes com origem do roteador. Para mais informação, refira que características do Qualidade de Serviço (QoS) estão disponíveis para o 12000 Series Internet Router?

Configurar

Use as primeiras duas etapas para configurar o DTS em interfaces do Frame Relay com base em VIP (7500 Series):

  1. Use este comando a fim permitir o dCEF:

    router(config)#ip cef distributed
    
  2. Assegure-se de que a interface do Frame Relay esteja permitida para o Distributed Switching:

    router(config-if)#interface serial 2/0/0
    router(config-if)#ip route-cache distributed
    router#show ip interface serial 2/0/0
    Serial8/0/0 is up, line protocol is up
      Internet address is 64.0.0.2/24
      Broadcast address is 255.255.255.255
      ICMP redirects are always sent
      ICMP unreachables are always sent
      ICMP mask replies are never sent
      IP fast switching is enabled
      IP fast switching on the same interface is disabled
      IP Flow switching is disabled
      IP CEF switching is enabled
      IP Distributed switching is enabled
      IP Fast switching turbo vector
      IP CEF switching with tag imposition turbo vector
      IP multicast fast switching is enabled
      IP multicast distributed fast switching is disabled
      IP route-cache flags are Fast, Distributed, CEF
      Router Discovery is disabled
      IP output packet accounting is disabled
  3. Crie uma classe de tráfego. (obrigatório)

  4. Configurar uma política de tráfego DTS. (obrigatório)

  5. Anexe a política de tráfego e permita o DTS. (obrigatório)

  6. Monitore e mantenha o DTS. (Opcional)

Nota: Use a ferramenta de consulta de comandos (clientes registrados somente) para obter mais informações sobre dos comandos usados neste documento.

Crie uma classe de tráfego

A primeira etapa a permitir toda a característica que usa o Modular QoS CLI é criar uma classe de tráfego.

Router(config)#class-mapa [compatível com qualquer | ] nome de classe compatível com todos — especifica o nome e se alguns ou todos os critérios constituirão um fósforo.

Para obter informações sobre do Modular QoS CLI e do procedimento para criar uma classe de tráfego, refira a vista geral da interface de Command-Line Qualidade de Serviço Modular.

Configurar uma política de tráfego DTS

Você deve configurar uma política de tráfego a fim permitir o DTS. Você pode configurar políticas de tráfego para tantas como classes como são definidos no roteador até o máximo do 256.

Para configurar uma política de tráfego, usar o começo do comando policy-map no modo de configuração global para especificar o nome da política de tráfego, usar então os comandos configuration da classe e da forma a fim configurar o nome e o modelagem de tráfego de classe de tráfego.

  1. política-nome do Router(config)#policy-mapa — Especifica o nome da política de tráfego a ser criada.

  2. Nome de classe dos #class do roteador (configuração-pmap) — Especifica o nome de uma classe de tráfego predefinida incluída na política de tráfego. A classe foi definida na etapa precedente deste processo.

  3. #shape do roteador (configuração-pmap-C) {média | [be] do [bc] cir do pico} — especifica o modelagem de tráfego da média ou da taxa de pico.

O tráfego está dirigido à classe padrão da política de tráfego se não satisfaz os critérios de verificação de repetição de dados de nenhuma outra classes cujas as políticas estão definidas na política de tráfego.

Anexe a política de tráfego e permita o DTS

Use este comando no modo de configuração da relação (ou a classe de mapas) a fim anexar uma política de tráfego à relação, à subinterface, ou à classe de mapas e a fim permitir o DTS na relação:

  • A #service-política do roteador (config-if) output o política-nome — permite o DTS e anexa a política do tráfego especificado à relação ou à classe de mapas.

Nota: Os aplicativos do dLLQ e do FRF.12 são recomendados fortemente ter a política de serviços aplicada à classe de mapa do Frame Relay.

Refira o Formatação de tráfego frame relay com o QoS distribuído no Cisco 7500 Series para obter mais informações sobre da fragmentação.

Monitore e mantenha o DTS

Use estes comandos no modo exec a fim monitorar e manter a característica DTS:

  • Forma do [interface-name] da relação da mostra do router- — Estado do detalhe dos indicadores do modelagem de tráfego.

  • Política-nome da política da mostra do router- — Indica a configuração de todas as classes que compõem a política do tráfego especificado.

  • Nome de classe da classe do política-nome da política da mostra do router- — Indica a configuração da classe especificada da política do tráfego especificado.

Para obter mais informações sobre dos comandos de monitoramento de QoS, refira compreendendo contadores de pacote de informação em saídas de interface do mapa de política da mostra.

Configurações de exemplo

DTS na interface principal

Neste exemplo, o tráfego que sai na relação pos1/0/0 é dado forma na taxa de 10Mbits/sec.

router(config)#class-map class-interface-all

router(config-cmap)#match any

router(config-cmap)#exit

router(config)#policy-map DTS-interface-all-action
router(config-pmap)#class class-interface-all

router(config-pmap-c)#shape average 10000000 
router(config-pmap-c)#exit

router(config)#interface pos1/0/0

router(config-if)#service-policy output DTS-interface-all-action

DTS Classe-baseado na interface principal

Neste exemplo, duas classes são criadas, e os critérios de verificação de repetição de dados são definidos com base no access list number. Trafique que sai na relação fd4/0/0 e combina os critérios na lista de acessos 10 é dado forma a 16Mbps. Trafique que combina os critérios na lista de acessos 20 está dado forma ao 8 Mbps.

router(config)#access-list 10 permit 171.69.0.0

router(config)#access-list 20 permit 192.168.0.0

router(config)#class-map class1

router(config-cmap)#match access-group 10

router(config-cmap)#exit

router(config)#class-map class2

router(config-cmap)#match access-group 20

router(config-cmap)#exit

router(config)#policy-map DTS-interface-class-action
router(config-pmap)#class class1

router(config-pmap-c)#shape average 16000000

router(config-pmap-c)#exit

router(config-pmap)#class class2

router(config-pmap-c)#shape average 8000000

router(config-pmap-c)#exit

router(config-pmap)#interface fd4/0/0

router(config-if)#service-policy output DTS-interface-class-action

Nota: Os endereços IP de Um ou Mais Servidores Cisco ICM NT nesta configuração são exemplos somente.

Para exemplos de configuração adicionais, refira configurar o Distributed Traffic Shaping.

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Uma interface de VIP configurada com o Encapsulamento frame relay pôde causar um crash com um erro de barramento se aplica uma serviço-política quando a relação passar o tráfego. Este problema é resolvido em várias versões de Cisco IOS Software (identificação de bug Cisco CSCdt88568). Para obter mais informações sobre do este os ddts e os erros adicionais, referem

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 22600