Switches de LAN : EtherChannel

Configurando o Etherchannel e Entroncamento de Camada 2 entre os Series Switch 2900XL/3500XL/2950 e os Catalyst Switches que executam o Cisco IOS Software

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (1 Julho 2009) | Inglês (20 Outubro 2015) | Feedback


Índice

DTP

Introdução

Este documento fornece configurações de amostra no entroncamento do link da IEEE 802.1Q/Inter-Switch (ISL) e mergulha 2 o EtherChannel (L2) entre o Cisco catalyst 2900 XL/3500 XL ou os Catalyst 2950 Series Switch e um interruptor do Catalyst 6500/6000 que execute o software de Cisco IOS�. Também é possível usar o Catalyst 4500/4000 Switch que executa o Cisco IOS Software em vez do Catalyst 6500/6000 para este exemplo. Este documento discute os fatores mais importantes para considerar ao configurar o entroncamento e a canalização entre os switches. O documento também inclui exemplos de configuração.

Neste documento, quatro portas de Ethernet rápidas de cada um do Switches foram em tronco e empacotaram nos EtherChannéis rápidos (FEC). O protocolo de entroncamento foi usado para os 3500 XL ISL, e o 802.1Q foi usado para o exemplo 2950.

Nota: O Catalyst 2950 não apoia o entroncamento ISL. Use o entroncamento do 802.1Q pelo contrário.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A fim criar os exemplos neste documento, este Switches foi usado em um ambiente de laboratório, com configurações esclarecida:

  • Catalyst 3548XL switch que executa o Cisco IOS Software Release 12.0(5)WC2

  • Catalyst 2950-24 Switch que executa o Cisco IOS Software Release 12.1(6)EA2c

  • Catalyst 6509 Switch com Supervisor Engine II que executa o Cisco IOS Software Release 12.1(11b)E

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

DTP

Os troncos entre dispositivos podem ser configurados estaticamente ou com o uso do Dynamic Trunking Protocol (DTP). O DTP permite que os dois serviços conectados negociem as configurações de tronco antes que a formação do tronco seja efetivamente feita. Os modos configuráveis da porta de switch do Cisco IOS Software (entroncamento) incluem: dinâmico (a porta negocia o acesso ou o modo de tronco), tronco (ajusta incondicionalmente a porta ao entroncamento), e acesso (porta de acesso do NON-tronco). Os ajustes os mais de uso geral da combinação de modo em dois lados (NON-DTP negociado) de um tronco estático são tronco-tronco. Para troncos dinâmicos (com negociação DTP), a configuração normal é dynamic-dynamic. Outras combinações podem produzir resultados válidos mas são fora do âmbito deste documento. Uma conexão de tronco entre um Port Aggregation Protocol (PAgP) - o interruptor capaz e um dispositivo diferente de PAGP exigem o modo de tronco estar ligada.

Nota: A maioria de roteadores Cisco e alguns Catalyst Switches não apoiam o DTP e exigem a configuração de entroncamento estático. Por exemplo, as séries do catalizador XL, Catalyst 2948G-L3, Catalyst 4908G-L3, Catalyst 8500 Series, roteadores Cisco do 2/3/4/7xxx Series, e assim por diante não apoiam o DTP e exigem a configuração de entroncamento estático.

Consideração sobre LAN nativa 802.1q

o entroncamento do 802.1Q introduz um campo da etiqueta do 802.1Q 4-byte nos quadros enviados sobre o tronco, que contêm a informação de VLAN. A tag 802.1q é inserida em cada quadro transferido sobre o tronco, exceto os quadros transmitidos no VLAN nativo, que são enviadas sem tag. Na maioria dos casos, o VLAN nativo tem que combinar em ambos os lados do tronco a menos que houver uma exigência de configuração incomum específica, que seja fora do âmbito deste documento. Se os VLAN nativos não combinam, as mensagens do Cisco Discovery Protocol (CDP) dos log do switch que indicam a má combinação. Embora não catastrófica, essa configuração faz com que duas VLANs diferentes sejam efetivamente mescladas em um domínio L2 mais amplo de transmissão (VLAN). Estes dois VLAN tentam calcular uma topologia do protocolo do Common Spanning-Tree (STP) para tais VLAN nativos construídos uma ponte sobre, com o risco eventualmente de exceder o diâmetro máximo suportado de STP.

Nota: Há um caso especial quando um vizinho ou um dispositivo de terceiros exigem todos os VLAN ser etiquetados. Se isso ocorrer, você pode implementar uma solução para criar uma VLAN fictícia e configurá-la como a VLAN nativa. Isso fará com que todos os outros VLANs necessários sejam rotulados, passando o tráfego pelo tronco para o vizinho ou dispositivo de terceira parte. No Cisco IOS Software Release 12.1.11bEX, 12.1.13E, e mais tarde, o Catalyst 6500 que executa o Cisco IOS Software apoia a opção de truncamento do 802.1Q que etiquetará todo o tráfego de VLAN que inclui o VLAN nativo. Emita o comando vlan dot1q tag native sob o modo de configuração global. No catalizador que 4500/4000 isso executam o Cisco IOS Software, o comando vlan dot1q tag native foi introduzido primeiramente no Cisco IOS Software Release 12.2(18)EW.

PAgP

Os EtherChannéis do gigabit (GEC) e os FEC entre o Switches podem igualmente ser configurados estaticamente ou dinamicamente com o uso do PAgP. O PAgP permite ambos os dispositivos conectados para negociar os ajustes antes realmente de formar o canal. Os modos de canal PAgP incluem: desejável (a porta inicia ativamente o Channel Negotiation), automóvel (o padrão, em que a porta não inicia a negociação mas responde às tentativas da negociação começadas pelo outro lado), e em (incondicionalmente ajusta a porta para canalizar e não troca pagp frame). Uma conexão entre um interruptor do capacitado para PAgP e um dispositivo diferente de PAGP exige sobre o modo formar um canal.

A combinação de modo a mais de uso geral em dois lados (não-PAgP negociado) de um canal estático é on-on. Para canais dinâmicos (PAgP-negociado), as configurações usuais são desirable-desirable ou desirable-auto. As portas conectadas configuradas para o modo desirable executam o Channel Negotiation e a verificação antes de começar a canalização e igualmente mantêm-se verificar o canal quando está na operação. Devido à proteção adicionada oferecida pelo PAgP, esta é geralmente a instalação recomendada se ambos os switch conectados apoiam o PAgP.

Nota: O PAgP tem algumas limitações de configuração deliberadas. As portas para negociar um canal devem ter a mesmos velocidade, duplex, encapsulamento de entroncamento, e VLAN ajustado. Também, o algoritmo de equilíbrio da carga de canal através dos links pode ser configurável em determinadas Plataformas.

Nota: Um EtherChannel está considerado ser uma porta original STP assim que estiver acima. Consequentemente, para evitar inconsistências de STP ao estabelecer um canal NON-negociado, continue como segue:

  1. Feche todas as portas do canal para configurar em ambos os lados.

  2. Executar a configuração em ambos os lados.

  3. Reabilite todas as portas.

A tentativa de configurar esse canal enquanto as portas estão ativadas pode resultar em inconsistências STP temporárias e/ou em loops. As etapas aplicam-se somente se o PAgP não é usado.

Catalyst 2900XL/3500XL

As Catalyst 2900 XL/3500XL series switch não apoiam o DTP e o PAgP, e exigem consequentemente a instalação do tronco estático e do canal. Refira a nota acima para mais informação. As Catalyst 2900 XL/3500XL series switch apoiam atualmente encapsulamentos de entroncamento ISL e de 802.1Q. Para mais informação, refira este documento:

O ISL é apoiado no Cisco IOS Software Release 11.2(8)SA4 e Mais Recente, e o 802.1Q é apoiado no Cisco IOS Software Release 11.2(8)SA5 e Mais Recente.

Com um Catalyst 2900 XL que executa o Cisco IOS Software Releases 11.2(8)SA1 ou 11.2(8)SA2, quatro EtherChannéis (grupos de porta) são permitidos você pelo interruptor com um número ilimitado de portas pelo grupo. O Balanceamento de carga através dos links no canal é sempre destino com base em endereço. O SPAN (Analisador de Portas Comutadas) e os recursos de segurança de porta não são suportados.

Em um Catalyst 2900 XL que executa o Cisco IOS Software Release 11.2(8)SA3 ou Mais Recente, um Catalyst 3500XL que executa o Cisco IOS Software Release 11.2(8)SA6 ou Mais Recente, e um Catalyst 2950, o Balanceamento de carga através dos links no canal é configurável ser baseado na fonte ou no endereço MAC de destino. A fonte é o padrão. O encaminhamento baseado em origem permite até oito portas em um FEC (grupo de portas). O encaminhamento baseado no destino permite portas ilimitadas por grupo de porta. Você pode configurar até 12 grupos de porta pelo interruptor e pode ter uma mistura de grupos source-/destination-based. Não há suporte para segurança de porta e SPAN.

Catalyst 2950

O entroncamento do 802.1Q do apoio dos Catalyst 2950 Switch somente e não apoia o entroncamento ISL. Apoio DTP dos Catalyst 2950 Switch e entroncamento dinâmico e Channel Negotiation com liberações do Cisco IOS Software Release 12.1 e modos estáticos PAgP somente com liberações do Cisco IOS Software Release 12.0. O balanceamento de carga de EtherChannel pode usar encaminhamento de endereço MAC de origem ou de destino. Você pode configurar o método de balanceamento de carga emitindo o comando de configuração global port-channel load-balance. Este Switches apoia até oito portas de switch pelo canal.

Catalyst 6500 que executa o Cisco IOS Software

Catalyst 6500 Switch que executam o apoio L2 do Cisco IOS Software (switchport) e a camada 3 (L3) (porta roteada) configurações de EtherChannel. Um Catalyst 6500/6000 series switch apoia um máximo de 64 EtherChannéis (256 com Cisco IOS Software Release 12.1(2)E e Anterior). Você pode formar um EtherChannel com até oito portas de LAN compativelmente configuradas em todo o módulo em um Catalyst 6000 Series Switch, à excecpção da placa de recurso de Digitas (DFC) - os módulos equipados (tais como o WS-X6816 e assim por diante) que permitem atualmente um canal L2 que usa somente portas no mesmo módulo de DFC. Contudo, um canal L3 pode ser configurado através dos módulos DFC-equipados diferentes. Esta limitação foi removida no Cisco IOS Software Release 12.1(11b)EX e Mais Recente do Catalyst 6500/6000. Este documento configura um EtherChannel L2.

O Catalyst 6500/6000 que executa o Cisco IOS Software permite que você configure a carga EtherChannel que equilibra para usar endereços MAC, endereços IP de Um ou Mais Servidores Cisco ICM NT, ou mergulha 4 a informação de porta (o L4) na qualquer origem, destino e combinação de origem - destino emitindo o comando port-channel load-balance global configuration. O padrão é usar uma função de mistura entre endereços IP de origem e de destino.

O Switches do Catalyst 6500/6000 apoia encapsulamentos de entroncamento ISL e de 802.1Q e DTP. A informação detalhada em potencialidades de porta está disponível emitindo o comando show interface interface_id capabilities.

Catalizador 4000 que executa o Cisco IOS Software

Catalyst 4000 Switch que executam as configurações de EtherChannel L2 (switchport) e L3 do apoio do Cisco IOS Software (com Supervisor Engine III e IV) (porta roteada). Um Catalyst 4000 Series Switch apoia um máximo de 64 EtherChannéis. Você pode formar um EtherChannel com até oito compativelmente interfaces Ethernet configuradas em todo o módulo, e através dos módulos em um Catalyst 4000 Series Switch. Todas as relações em cada EtherChannel devem estar à mesma velocidade e devem tudo ser configuradas que as relações L2 ou L3.

O Cisco IOS Software do catalizador 4000 que executa permite que você configure a carga EtherChannel que equilibra para usar endereços, endereço IP de Um ou Mais Servidores Cisco ICM NT, ou informação de porta L4 MAC na qualquer origem, destino e combinação de origem - destino emitindo o comando port-channel load-balance global configuration. O padrão é usar uma função de mistura entre endereços IP de origem e de destino.

O catalizador 4000 que executa os apoios ISL do Cisco IOS Software e os encapsulamentos de entroncamento do 802.1Q e o DTP. O ISL não está disponível nos módulos determinados. Para uma lista completa de tais módulos, refira compreendendo a seção dos troncos de VLAN de configurar interfaces Ethernet da camada 2. Em uma liberação de software futuro, a informação detalhada em potencialidades de porta estará disponível emitindo o comando show interface capabilities. Atualmente este comando não está disponível.

Configuração 1: Entroncamento ISL e EtherChannel entre o Catalyst 3500XL e o Catalyst 6500 que executa o Cisco IOS Software

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Essa configuração utiliza esta configuração de rede:

/image/gif/paws/22422/144-a.gif

Catalyst 3524 XL

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel 
!--- and then enable them back when the configuration is complete on both switches.



Cat3500XL#show run
Building configuration...
Current configuration:
!

version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3500XL
ip subnet-zero
!
interface FastEthernet0/1
!

!--- Output suppressed.


!
interface FastEthernet0/17
port group 1

!--- Assigned port to port channel 1.


switchport trunk encapsulation isl

!--- Configured the port to use the trunking encapsulation ISL.


switchport mode trunk

!--- Configured the port to be in trunking mode.


!
interface FastEthernet0/18

!--- Repeated the trunk and channel configuration.


port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/19

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/20

!--- Repeated the trunk and channel configuration.


Port group 1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/21
!

!--- Output suppressed.


!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!

interface VLAN1
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
line con 0
transport input none
stopbits 1
line vty 0 4
login

Catalyst 6500 (Cisco IOS Software)

!--- Catalyst 3500 XL does not support DTP/PAgP.
!--- First, shut down the secondary ports involved in the channel, 
!--- and then enable them back when the configuration is complete on both switches.



Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-cpu  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q

!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


no ip address 
channel-group 1 mode on

!--- Configured the port to participate in port channel 1 with channel mode on.


! 
Interface FastEthernet4/3

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/4

!--- Repeated the trunk and channel configuration.


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
! 
interface FastEthernet4/5

!--- Repeated the trunk and channel configuration. 


switchport 
switchport trunk encapsulation isl 
switchport mode trunk 
no ip address 
channel-group 1 mode on
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
line con 0
line vty 0 4
!
end
Cat6500# 

Configuração 2: entroncamento e EtherChannel do 802.1Q com uso do DTP e PAgP entre o Catalyst 2950 e o Catalyst 6500 que executa o Cisco IOS Software

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Essa configuração utiliza esta configuração de rede:

/image/gif/paws/22422/144-b.gif

Catalyst 2950

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.



Cat2950#show run
Building configuration...
Current configuration : 1380 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
ip subnet-zero
no ip finger
!
interface Port-channel1 
switchport mode trunk
!
interface FastEthernet0/1
!         
interface FastEthernet0/2 
switchport mode trunk

!--- Configured port to be in trunking mode.


channel-group 1 mode desirable

!--- Configured port to participate in PAgP-negotiated port channel 1.


!
interface FastEthernet0/3

!--- Repeated trunk and channel configuration.
 

switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/4

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/5

!--- Repeated trunk and channel configuration. 


switchport mode trunk 
channel-group 1 mode desirable
!
interface FastEthernet0/6
!

!--- Output suppressed.


!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface VLAN1 
ip address 10.10.10.1 255.255.255.0 
no ip route-cache
!
ip http server
!
line con 0 
transport input none
line vty 5 15
!
end 
Cat2950#

Catalyst 6500 (Cisco IOS Software)

!--- Catalyst 2950 with Cisco IOS Software Release 12.1 supports PAgP. 
!--- There is no need to shut down the ports as both Catalyst 2950 and 6500 can negotiate 
!--- channeling in desirable mode.


Cat6500#show run
Building configuration...
Current configuration : 3999 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat6500
!
boot bootldr bootflash:c6msfc2-boot-mz.121-8b.E9
!
redundancy 
main-CPU  
auto-sync standard
ip subnet-zero
!
!
no mls ip multicast aggregate
no mls ip multicast non-rpf cef
mls qos statistics-export interval 300
mls qos statistics-export delimiter |
!
interface Port-channel1


!--- This interface will be created and configured automatically. 
!--- You do not need to input this part of the configuration.


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address
!
interface GigabitEthernet1/1 
no ip address 
shutdown
!

!--- Output suppressed.


!
interface FastEthernet4/2 
switchport

!--- Setting the interface as an L2 port, as by default the port is a routed port.



!--- Note: Catalyst 4500/4000 that runs Cisco IOS Software defaults to the L2 port.


switchport trunk encapsulation dot1q


!--- Setting the trunk encapsulation to dot1q.


switchport mode trunk

!--- Configured port to be in trunking mode. 


No ip address 
channel-group 1 mode desirable

!--- Configured port to participate in port channel 1 with channel mode desirable.


! 
Interface FastEthernet4/3

!--- Repeated trunk and channel configuration. 


switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/4

!--- Repeated trunk and channel configuration.
  

switchport 
switchport trunk encapsulation dot1q 
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/5

!--- Repeated trunk and channel configuration. 


switchport
switchport trunk encapsulation dot1q
switchport mode trunk 
no ip address 
channel-group 1 mode desirable 
!
interface FastEthernet4/6 
no ip address 
shutdown
!
!
interface VLAN 1 
ip address 10.10.10.2  255.255.255.0
!
ip classless
no ip http server
!
!
line con 0
line vty 0 4
!
end
Cat6500# 

Verifique: Truncamento ISL

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Catalyst 3500 XL

Cat3500XL#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat3500XL        Fas 0/20           136        R S I      Catalyst 6Fas 4/5
Cat3500XL        Fas 0/19           136        R S I      Catalyst 6Fas 4/4
Cat3500XL        Fas 0/18           136        R S I      Catalyst 6Fas 4/3
Cat3500XL        Fas 0/17           136        R S I      Catalyst 6Fas 4/2
Cat3500XL#



Cat3500XL#show port group 
Group  Interface              Transmit Distribution
-----  ---------------------  ---------------------
1  FastEthernet0/18       source address
1  FastEthernet0/17       source address
1  FastEthernet0/20       source address
1  FastEthernet0/19       source address
Cat3500XL#


Cat3500XL#show etherchannel summary
Flags:  d - default     D - down
I - in use

Group Ports
----- -----
1     Fa0/18(I) Fa0/17(Id) Fa0/20(I) Fa0/19(I)
Cat3500XL#

Nota: Se você tem um EtherChannel do oito portas, emitir o comando show etherchannel summary pode causar um crash o interruptor se você executa um Cisco IOS Software Release que esteja mais adiantado do que o Cisco IOS Software Release 12.0(5)WC5.

Cat3500XL#show interfaces fastethernet0/17 switchport 
Name: Fa0/17
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Cat3500XL#

Catalyst 6500 (Cisco IOS Software)

Cat6500#show interfaces fastethernet 4/2 capabilities 
FastEthernet4/2
Model:                 WS-X6248-RJ-45
Type:                  10/100BaseTX
Speed:                 10,100,auto
Duplex:                half,full
Trunk encap. type:     802.1Q,ISL
Trunk mode:            on,off,desirable,nonegotiate
Channel:               yes
Broadcast suppression: percentage(0-100)
Flowcontrol:           rx-(off,on),tx-(none)
Fast Start:            yes
QOS scheduling:        rx-(1q4t), TX(2q2t)
CoS rewrite:           yes
ToS rewrite:           yes
Inline power:          no
SPAN:                  source/destination

Cat6500#

Cat6500#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat6500          Fas 4/5            135         T S       WS-C3548-XFas 0/20
Cat6500          Fas 4/4            135         T S       WS-C3548-XFas 0/19
Cat6500          Fas 4/3            134         T S       WS-C3548-XFas 0/18
Cat6500          Fas 4/2            134         T S       WS-C3548-XFas 0/17
Cat6500#


Cat6500#show interfaces port-channel 1 etherchannel 
Age of the Port-channel   = 01d:07h:30m:43s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:51m:22s    Fa4/5
Time since last port Un-bundled: 01d:06h:52m:30s    Fa4/5

Cat6500#


Cat6500#show etherchannel ?
<1-269>       Channel group number
brief         Brief information
detail        Detail information
load-balance  Load-balance/frame-distribution scheme among ports in
port-channel
port          Port information
port-channel  Port-channel information
summary       One-line summary per channel-group


Cat6500#show etherchannel summary 
Flags:  D - down        P - in port-channel
I - stand-alone s - suspended
R - Layer3      S - Layer2
U - port-channel in use
Group Port-channel  Ports
-----+------------+-----------------------------------------------------------
1     Po1(SU)     Fa4/2(P)   Fa4/3(P)   Fa4/4(P)   Fa4/5(P)   

Cat6500#


Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:07h:35m:28s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     11     Fa4/2    on         
1     22     Fa4/3    on         
2     44     Fa4/4    on         
3     88     Fa4/5    on         

Time since last port bundled:    01d:06h:56m:08s    Fa4/5
Time since last port UN-bundled: 01d:06h:57m:15s    Fa4/5


Cat6500#show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Operational private-vlan: none 
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Cat6500#

Verifique: Truncamento 802.1q

Use esta seção para confirmar se a sua configuração funciona corretamente.

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Catalyst 2950

Cat2950#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cat2950          Fas 0/4            120        R S I      Catalyst 6Fas 4/4
Cat2950          Fas 0/5            120        R S I      Catalyst 6Fas 4/5
Cat2950          Fas 0/3            120        R S I      Catalyst 6Fas 4/3
Cat2950          Fas 0/2            120        R S I      Catalyst 6Fas 4/2
Cat2950#



Cat2950#show etherchannel port-channel
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:27m:08s
Logical slot/port   = 1/0           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
0     00     Fa0/2    desirable-SL  
0     00     Fa0/3    desirable-SL  
0     00     Fa0/4    desirable-SL  
0     00     Fa0/5    desirable-SL  

Time since last port bundled:    00d:00h:07m:17s    Fa0/5
Time since last port UN-bundled: 01d:08h:10m:06s    Fa0/5

Cat2950#



Cat2950#show etherchannel load-balance 
Source MAC address
Cat2950#


Cat2950#show interfaces port-channel 1 switchport 
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)
Appliance trust: none
Cat2950#

Cisco IOS Software do Catalyst 6500

Cat6500#show etherchannel port-channel 
Channel-group listing: 
-----------------------

Group: 1 
----------
Port-channels in the group: 
----------------------

Port-channel: Po1
------------

Age of the Port-channel   = 01d:08h:25m:07s
Logical slot/port   = 14/1           Number of ports = 4
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse 

Ports in the Port-channel: 

Index   Load   Port    EC state
------+------+------+------------
1     11     Fa4/2    desirable-SL  
3     22     Fa4/3    desirable-SL  
0     44     Fa4/4    desirable-SL  
2     88     Fa4/5    desirable-SL  

Time since last port bundled:    00d:00h:09m:53s    Fa4/3
Time since last port UN-bundled: 00d:00h:09m:56s    Fa4/5

Cat6500#

Troubleshooting

Use esta seção para resolver problemas de configuração.

O tráfego não está passando em um tronco 802.1Q

Uma destas causas pode conduzir à edição:

  • Há uma má combinação da configuração de VLAN nativa nas portas que são conectadas entre dois Switches.

    Verifique a configuração de VLAN nativa em ambo o Switches. Emita o comando show trunk no switch CatOS a fim ver o ajuste do VLAN nativo. Emita o comando show interface interface_id switchport no XL switch a fim ver o ajuste do VLAN nativo. Se há uma incompatibilidade de VLAN nativa entre os dois Switches, configurar o Switches com o mesmo VLAN nativo. Emita o comando interface configuration vlan nativo do tronco de switchport a fim mudar o VLAN nativo no XL switch. Emita o comando set vlan a fim mudar o VLAN nativo no switch CatOS.

  • Os quadros DTP não são apoiados nos XL switch.

    Os switch CatOS enviam quadros DTP sobre o enlace de tronco, mas os XL switch não apoiam quadros DTP. O DTP não é apoiado nos XL switch. A fim evitar este problema, ajuste o status de porta do switch CatOS ao nenhum negociam. Emita o comando set trunk mod/port nonegotiate dot1q a fim ajustar o modo de tronco à não-negociação para o modo de entroncamento do dot1q.

  • Há uma incompatibilidade de encapsulamento no XL switch.

    No XL switch, verifique que o encapsulamento de tronco está ajustado ao dot1q. Emita o comando show interface interface_id switchport a fim ver a configuração atual. Emita o comando interface configuration do dot1q do encapsulamento de tronco de porta de switch a fim mudar o encapsulamento ao dot1q.

  • Uma versão adiantada de CatOS não apoia o entroncamento do dot1q.

    A versão adiantada de CatOS que foi usado no Switches não apoia o entroncamento do dot1q. Promova o CatOS do interruptor a uma versão mais atrasada que apoie o tronco e o tronco de ISL do dot1q.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 22422