IP : Enhanced Interior Gateway Routing Protocol (EIGRP)

O Mensagem de Erro e os vizinhos EIGRP/OSPF/BGP de não-sincronização de "%TUN-5-RECURDOWN" sobre um túnel GRE

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O %TUN-5-RECURDOWN: O tunnel0 desabilitou temporariamente devido ao Mensagem de Erro do roteamento recursivo significa que o roteador do túnel de encapsulamento de roteamento genérico (GRE) descobriu um problema de roteamento recursivo. Esta circunstância é geralmente devido a uma destas causas:

  • Um misconfiguration que faça com que o roteador tente distribuir ao endereço de destino de túnel usando a interface de túnel própria (roteamento recursivo)

  • Uma instabilidade temporária causada pela não sincronismo de rota em outra parte na rede

O status da interface de túnel depende do alcance de IP para o destino do túnel. Quando o roteador detecta uma falha de roteamento recursivo para o destino de túnel, fecha a interface de túnel para baixo por alguns minutos de modo que a situação que causa o problema possa se resolver enquanto os protocolos de roteamento convirgem. Se o problema é causado pelo misconfiguration, o link pode oscilar indefinidamente.

Outro sintoma deste problema é o Protocolo de encaminhamento de gateway interior melhorado (EIGRP) não sincronizado, Abrir caminho mais curto primeiro (OSPF) ou vizinhos de Protocolo de gateway de limite (BGP), quando os vizinhos estiverem em um túnel GRE.

Este documento mostra um exemplo de pesquisar defeitos uma interface de túnel de oscilação que esteja executando o EIGRP.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não é restrito a versões de software ou hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Diagrama de Rede

O roteador1 (r1) e o roteador3 (R3) são conectados ao roteador2 (R2). A conectividade da rede é tal que o R1 pode atingir a interface de loopback do R3 através do R2 e vice-versa. O EIGRP está sendo executado na interface do túnel em R1 e R3. O R2 não faz parte do domínio EIGRP.

/image/gif/paws/22327/gre_flap_01.gif

Configurações

R1
hostname R1
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Tunnel0
 ip address 192.168.1.1 255.255.255.0
 tunnel source Loopback0
 tunnel destination 10.3.3.3
!
interface Serial0
 ip address 172.16.15.1 255.255.255.0
 encapsulation ppp
!
router eigrp 1
 network 10.1.1.0 0.0.0.255
 network 192.168.1.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.16.15.2

R3
hostname R3
!
interface Loopback0
 ip address 10.3.3.3 255.255.255.0
!
interface Tunnel0
 ip address 192.168.1.3 255.255.255.0
 tunnel source Loopback0
 tunnel destination 10.1.1.1
!
interface Serial1
 ip address 172.16.25.3 255.255.255.0
!
router eigrp 1
 network 10.3.3.0 0.0.0.255
 network 192.168.1.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.16.25.2

Observação

Observe estes Mensagens de Erro no r1 e no R3. O estado da interface de túnel está oscilando continuamente no meio para cima e para baixo.

01:11:39: %LINEPROTO-5-UPDOWN:
          Line protocol on Interface Tunnel0, changed state to up
01:11:48: %TUN-5-RECURDOWN:
          Tunnel0 temporarily disabled due to recursive routing
01:11:49: %LINEPROTO-5-UPDOWN:
          Line protocol on Interface Tunnel0, changed state to down
01:12:49: %LINEPROTO-5-UPDOWN:
          Line protocol on Interface Tunnel0, changed state to up
01:12:58: %TUN-5-RECURDOWN:
          Tunnel0 temporarily disabled due to recursive routing
01:12:59: %LINEPROTO-5-UPDOWN:
          Line protocol on Interface Tunnel0, changed state to down

Nota: Cada linha tempo-carimbada de saída precedente do exemplo aparece em uma linha na saída real.

Troubleshooting

Esta é a rota ao destino de túnel 10.3.3.3 no r1 antes que a interface de túnel vá acima:

R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.15.2 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.15.2/32 is directly connected, Serial0
C       172.16.15.0/24 is directly connected, Serial0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Loopback0
S*   0.0.0.0/0 [1/0] via 172.16.15.2

O destino de túnel 10.3.3.3 toma a rota padrão através de 172.16.15.2 (Serial 0).

Agora, observe a tabela de roteamento depois que a interface de túnel vai acima, mostrada aqui:

R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.15.2 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.25.0/24 [90/297756416] via 192.168.1.3, 00:00:00, Tunnel0
C       172.16.15.2/32 is directly connected, Serial0
C       172.16.15.0/24 is directly connected, Serial0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.3.3.0 [90/297372416] via 192.168.1.3, 00:00:00, Tunnel0
C       10.1.1.0 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Tunnel0
S*   0.0.0.0/0 [1/0] via 172.16.15.2

A rota ao destino de túnel 10.3.3.3 é instruída com o EIGRP, e seu salto seguinte é interface tunnel 0.

Nesta situação, o melhor caminho ao destino de túnel é através da interface de túnel; contudo, isto ocorre:

  1. O pacote é colocado em fila na fila de saída da interface de túnel.

  2. A interface de túnel adiciona um cabeçalho de GRE ao pacote e enfileira o pacote para o protocolo de transporte destinado ao endereço de destino da interface de túnel.

  3. O IP olha acima a rota ao endereço de destino e aprende que é através da interface de túnel, que retorna o pacote a etapa 1 acima; então, há um circuito de roteamento recorrente.

Solução

Configurar rotas estáticas para o destino de túnel no r1 e no R3.

R1(config)# ip route 10.3.3.3 255.255.255.255  serial 0
R3(config)# ip route 10.1.1.1 255.255.255.255 serial 1

Agora, observe a rota IP no r1, mostrado abaixo.

R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.15.2 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.25.0/24 [90/297756416] via 192.168.1.3, 00:01:08, Tunnel0
C       172.16.15.2/32 is directly connected, Serial0
C       172.16.15.0/24 is directly connected, Serial0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
S       10.3.3.3/32 is directly connected, Serial0
D       10.3.3.0/24 [90/297372416] via 192.168.1.3, 00:01:08, Tunnel0
C       10.1.1.0/24 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Tunnel0
S*   0.0.0.0/0 [1/0] via 172.16.15.2

Para o destino de túnel, uma rota estática mais específica (10.3.3.3/32) é preferível a uma rota EIGPR conhecida menos específica (10.3.3.0/24). Esta rota estática mais específica impede o loop recursivo de roteamento, a não-sincronização da interface de túnel e, conseqüentemente, a não-sincronização dos vizinhos de EIGRP.

R1# show interfaces tunnel 0
Tunnel0 is up, line protocol is up
  Hardware is Tunnel
  Internet address is 192.168.1.1/24
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive set (10 sec)
  Tunnel source 10.1.1.1 (Loopback0), destination 10.3.3.3

%Warning: Característica não apoiada no hardware. Os pacotes de túnel serão software comutado

A mensagem é considerada quando o mesmo laço de retorno ou endereço físico são usados como a fonte para dois túneis diferentes. Devido a isto, cada pacote vai ao processador, em vez de ser hardware comutado.

Esta edição pode ser resolvida se você usa endereços secundários em uma interface de loopback ou se você usa interfaces de loopback múltiplas para os endereços de origem de túnel.

O pacote de hello de OSPF é enviado por um roteador sobre o túnel GRE mas não faz chega na outra extremidade do túnel.

Em um OSPF permitido a rede, o r1 do roteador envia o pacote de hello de OSPF sobre o túnel GRE mas não é recebida pelo roteador R3. Use o comando OSPF debugar IP olá! a fim debugar olá! os eventos.

R1#debug ip ospf hello
May 31 13:58:29.675 EDT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.1
May 31 13:58:39.675 EDT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.1
May 31 13:58:49.675 EDT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.1


R3#debug ip ospf hello
May 31 15:02:07 ADT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.3
May 31 15:02:09 ADT: OSPF: Rcv hello from 172.16.15.1 area 0.0.0.12 from Tunnel0 192.168.1.1
May 31 15:02:09 ADT: OSPF: Send immediate hello to nbr 172.16.15.3, src address 192.168.1.3, on Tunnel0
May 31 15:02:09 ADT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.3

!--- The previous output shows that the hello packets
!--- re sent by R1 but not received by R3.

Solução

Configurar o comando tunnel key no túnel 10 da relação em ambo o Roteadores. Este comando permite o Multicast no GRE.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 22327