Banda larga a cabo : Data-over-Cable Service Interface Specifications (DOCSIS)

Usando o MAX-CPE comande no DOCSIS e no CMTS

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento explica o relacionamento entre o comando cable modem max-cpe n novo e o parâmetro do CPE máx especificados no arquivo de configuração do Data-over-Cable Service Interface Specifications (DOCSIS). O arquivo de configuração DOCSIS é carregado no modem a cabo, e pode ser codificado no Roteadores do uBR7200 Series que executa o Software Release 12.1(2)EC1 ou Mais Recente do ½ do ¿  de Cisco IOSïÂ.

Antes de Começar

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Pré-requisitos

A Cisco recomenda que você tenha conhecimento destes tópicos:

  • As informações nesse documento são baseadas no processador Cisco hardware uBR7246 (NPE150) (revisão B) e no Cisco IOS Software (UBR7200-IST-M), versão 12.1(2)EC1.

  • Este documento ser refere aos modems a cabo apenas no modo de Bridging.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Informações de Apoio

Há uma demanda de clientes de cabo para o Cable Modem Termination System (CMTS) para permitir que mais CPEs se conectem ao cable modem, independentemente do fato de que o valor no arquivo de configuração dos cable modems limita o número de hosts. A alteração para permitir que mais CPEs se conectem ao cable modem foi introduzida com CSCdp52029 (somente clientes registrados) no Cisco IOS Software Release 12.0(9.5)SC e nos Cisco IOS Software Release 12.1(1.0.3)EC1 trains.

Esta procura era criado devido ao modem a cabo que é incapaz de manter a contagem dos CPE atribuídos na sincronização com a contagem CMTS. Quando um modem a cabo é inicializado, o único momento em que ele pode sincronizar o MAX-CPE com o CMTS é quando ele envia a contagem MAX-CPE ao CMTS, no fluxo de solicitação de registro.

Se o modem a cabo for recarregado, não haverá fluxo para o CMTS para informá-lo para reduzir a contagem alocada do CPE para zero. Entretanto, o modem a cabo começará outra vez do zero. Se um CPE novo atrás dos pedidos do modem a cabo vir em linha, o modem a cabo o permitirá a porque sua contagem do CPE máx é agora zero. Entretanto, o CMTS com uma contagem que não seja zero em MAX-CPE falhará com a requisição e a mensagem a seguir aparece no CMTS:

 
%UBR7200-5-MAXHOST: New host with IP address x.x.x.x 
 and MAC yyyy.yyyy.yyyy on SID 3 (CM zzzz.zzzz.zzzz) is ignored.

Isto é intensificado pelo fato de que, se não especificado, a entrada do CPE máx do padrão no arquivo de configuração DOCSIS está ajustada a um.

Um exemplo seria quando o modem a cabo informa ao CMTS que tem uma contagem de MAX-CPE na solicitação de registro. Um cliente com cabo deseja a funcionalidade de desligar e religar a energia do modem a cabo para permitir que o laptop do instalador seja removido e que o PC do usuário final volte para o modem a cabo. Isto falhará porque. Depois que o reload o modem a cabo terá a contagem do CPE máx ajustada a zero, contudo, o CMTS ainda recordará a entrada de laptop do instalador, e que iguala a contagem do CPE máx de uma.

Há uma ação alternativa disponível emitindo o comando clear cable host x.x.x.x, onde x.x.x.x iguala o IP ou o MAC address do host a ser cancelado no CMTS. Esta solução, no entanto, não é popular para clientes a cabo.

Implementação

Um comando new configuration foi adicionado ao CMTS. Para especificar por modem um número máximo de anfitriões permitidos (cancelando o valor do CPE máx no arquivo de configuração do Cable Modem), emita o comando cable modem max-cpe n no modo de configuração da interface de cabo. n iguala 1 a 255.

O CMTS permite até um número n de hosts a um modem a cabo. Quando o grupo a ilimitado, ou a n é maior do que o valor do CPE máx no arquivo de configuração de um modem a cabo, este comando cancela o valor do arquivo de configuração. O servidor DHCP controla o número de endereços IP atribuídos aos hosts por trás de um único modem a cabo.

Se o arquivo de configuração do modem a cabo especificar um número de hosts maior que n, a definição desse arquivo terá precedência. É até o modem a cabo para controlar o número de host ativo.

Com a emissão do comando cable modem max-cpe unlimited, o CMTS não reforçará um limite sobre o número de CPEs conectados a um único modem de cabo. Com essa configuração, cabe ao cable modem controlar o número máximo de CPEs e ao servidor DHCP controlar o número de endereços IP atribuídos aos CPEs por trás de um único cable modem.

cuidado Cuidado: O uso descuidado do comando ilimitado max-cpe do modem a cabo pode abrir uma brecha na segurança do sistema ao habilitar ataques de recusa de serviço. Especificamente, ele pode permitir que um usuário obtenha um grande número de endereços IP e, dessa forma, danifique a rede inteira após reservar todos os endereços IP disponíveis para esse único usuário. Portanto, recomenda-se que, se o comando cable modem max-cpe unlimited estiver habilitado, o número de endereços IP designados para CPEs por trás de um único modem a cabo seja estritamente controlado pelo servidor de DHCP.

Emitindo o comando no cable modem max-cpe, a configuração padrão é permitida. O valor MAX-CPE fornecido no arquivo de configuração será usado pelo CMTS para limitar o número de CPEs conectados a um único modem a cabo.

O comando show cable modem detail indica o valor do CPE máx como configurado no arquivo de configuração DOCSIS para o modem a cabo, e se possível, o valor configurou quando o modem a cabo MAX-CPE n é emitido.

Consulte a amostra do registro abaixo. CMTS é configurado para MAX-CPE igual a quatro e MAXP-CPE igual a ilimitado.

test-cmts#show cable modem detail 
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 ............. yes ................ 37.37
Cable4/0/U0 2 .... 0001.9659.47ab 1 ............. yes ................ 33.70
Cable4/0/U0 3 .... 0001.9659.47bf .1 ............. yes ................ 30.67
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 ............. yes ................ 28.84
Cable4/0/U0 5 .... 0001.9659.47eb 1 ............. yes ................ 30.89

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe 4
test-cmts(config)#end
test-cmts#
00:05:11: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (4) .........yes ................37.00
Cable4/0/U0 2 .... 0001.9659.47ab 1 (4) ........ yes ................33.54
Cable4/0/U0 3 .... 0001.9659.47bf .1 (4) ........ yes ................30.70
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (4) ........ yes ................ 29.00
Cable4/0/U0 5 .... 0001.9659.47eb 1 (4) ........ yes ................ 30.92

test-cmts#conf t
Enter configuration commands, one per line. End with CNTL/Z.
test-cmts(config)#cable modem max
test-cmts(config)#cable modem max-cpe ?
<1-255> Number
unlimited Max CPE not enforced

test-cmts(config)#cable modem max-cpe unli
test-cmts(config)#cable modem max-cpe unlimited 
test-cmts(config)#^Z 
test-cmts#
00:06:06: %SYS-5-CONFIG_I: Configured from console by console


test-cmts#show cable modem detail
Interface ...... SID MAC address .... Max CPE Concatenation Rx SNR
Cable4/0/U0 1 .... 0001.9659.47bb 1 (ul) .........yes ............... 36.64
Cable4/0/U0 2 .... 0001.9659.47ab 1 (ul) ........ yes ............... 33.26
Cable4/0/U0 3 .... 0001.9659.47bf. 1 (ul) ....... .yes ............... 30.73
Cable4/0/U0 4 .... 0001.9659.3ef7 .1 (ul) ...... . yes ............... 29.15
Cable4/0/U0 5 .... 0001.9659.47eb 1 (ul) ...... . yes ............... 30.95

test-cmts#wr t
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname test-cmts
!
boot system flash ubr7200-ist-mz.121-2.EC1
no logging buffered
!
cable modem max-cpe 4
ip subnet-zero 
!
interface FastEthernet0/0
ip address 10.200.68.4 255.255.255.0
half-duplex
!
interface Cable4/0
ip address 10.200.69.49 255.255.255.240 secondary
ip address 10.200.69.33 255.255.255.240
ip accounting precedence input
ip accounting precedence output
no keepalive
cable max-hosts 10
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 frequency 20000000
cable upstream 0 power-level 0
cable upstream 0 rate-limit
no cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 frequency 20000000
cable upstream 5 power-level 0
cable upstream 5 rate-limit
cable upstream 5 shutdown
cable dhcp-giaddr policycable
helper-addrress 10.200.68.11
! 
router rip
network 10.0.0.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.200.68.1
ip route 10.200.32.0 255.255.224.0 10.200.68.2
no ip http server
!
line con 0
exec-timeout 0 0
password ww
login
transport input none
line aux 0
line vty 0 4
password ww
login
!
end

test-cmts#

Nota: Embora o CMTS, permita o número especificado de anfitriões através do Modems a cabo, o Modems a cabo ele mesmo será restringido ainda para permitir somente o número de CPE permitidos no arquivo de configuração DOCSIS.


Informações Relacionadas


Document ID: 22177