Qualidade de Serviço (QoS) : Marcação de pacotes QoS

Ordem de operação de Qualidade de Serviço

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Abril 2015) | Feedback


Índice


Introdução

Este documento ilustra a ordem em que as características do Qualidade de Serviço (QoS) são executadas quando de entrada ou de partida aplicado a uma relação em um roteador que executa o software do ½ do ¿  de Cisco IOSïÂ. As políticas de QoS estão configuradas com a interface de linha de comando de QoS modular (MQC). Este documento igualmente discute a marcação do cabeçalho IP, tal como o DSCP e a Precedência IP, e a ordem em que os componentes de uma política de QoS são avaliados pelo roteador.

Pré-requisitos

Requisitos

Os leitores deste documento devem ter conhecimento de:

  • Metodologias básicas de QoS

Componentes Utilizados

As saídas de exemplo na seção de configurações deste documento foram capturadas em uma plataforma do Cisco 7513 Series que executasse o Cisco IOS Software Release 12.2.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

classificação comum

A classificação é o processo de definir as classes de tráfego que tráfego do tipo em grupos das categorias de fluxos. A classificação define os “critérios de verificação de repetição de dados” para cada classe de tráfego que deve ser tratado por uma política de QoS. Mais especificamente, define o “filtro de tráfego” esse pacotes está verificada contra quando uma serviço-política é aplicada.

Distribuído e as plataformas não distribuídas combinam pacotes a uma única classe em um mapa de política. Combinar termina na primeira classe correspondente. Se duas classes dentro de um mapa de política combinam a mesmo Precedência IP ou intervalo de endereço IP, o pacote pertence sempre à primeira classe correspondente. Por este motivo, a ordem da classe dentro de um mapa de política é muito importante.

Este abordagem de classificação é chamado “classificação comum” e tem estes benefícios:

  • Relatórios precisos e a vacância dos problemas dos relatórios duplos que foram considerados antes da “classificação comum”.

  • Reduz o impacto das listas de controle de acesso (ACLs) no CPU, uma vez que o ACL é verificado uma vez por classe, em vez de uma vez por recurso.

  • Consulta mais rápida dos cabeçalhos de pacote de informação devido a pôr em esconderijo.

A classificação comum está permitida automaticamente quando você anexa um mapeamento de política de entrada ou de saída com o comando service-policy.

Esta tabela ilustra o ordem de operação com classificação comum. É importante compreender da tabela quando a classificação ocorre no contexto das características de QoS. No caminho de entrada, um pacote é classificado antes de ser comutado. No caminho de saída, um pacote é classificado depois de ser comutado.

Entrada Saída
  1. Protocolo QPPB do QoS
  2. Classificação comum de entrada
  3. Entradas ACL
  4. Marcação de entrada (marcação com base em classe ou CAR [Taxa de acesso consolidada])
  5. Vigilância de entrada (por um vigilante baseado em classe ou CAR)
  6. Segurança IP (IPsec)
  7. Cisco Express Forwarding (CEF) ou Fast Switching
  1. CEF ou switching rápida
  2. Classificação de saída comum
  3. ACLs de emissor
  4. Marcação da saída
  5. Vigilância de saída (por meio de um vigilante baseado em classe ou CAR)
  6. Enfileiramento (Class-Based Weighted Fair Queueing (CBWFQ) e low latency queueing (LLQ)), e Weighted Random Early Detection (WRED)

Nota: O Network-Based Application Recognition (NBAR) de entrada acontece após ACL e antes do roteamento baseado em política.

As mudanças importantes foram executadas em relação ao uso do pedido de recursos e do valor observado. Essas alterações incluem mover as funções contábeis de precedência de CAR de entrada, MAC de entrada e IP para que ocorram antes da classificação da saída de MQC:

  • A taxa limitante de entrada, ou CAR, é aplicável aos pacotes que seguem o caminho de switching de processo e que está destinado ao roteador. Antes, somente os pacotes comutados através do roteador usando o CEF podiam ser limitados por taxa.

  • Novos valores de precedência IP definidos pela entrada de CAR ou de QPPB põem ser usados para seleção de um VC (Circuito virtual) em um agrupamento VC ATM.

  • Os valores de precedência de IP, DSCP (Differentiated Services Code Points) e grupo QoS definidos por QPPB ou CAR de entrada podem ser usados na classificação de pacotes de saída MQC.

Marcação e outras ações QoS no mesmo roteador

Uma aplicação freqüente do QoS é remarcar um pacote e, em seguida, aplicar uma ação que considere o valor remarcado na mesma interface ou no mesmo roteador. Você pode configurar a marcação e as outras ações QoS com classificação comum.

Você pode comentar pacotes com estes recursos de QoS:

  • comando set com Class-based Marking

  • comando police com class-based policing

  • CAR

Esta tabela indica se um valor remarcado é ou não considerado por uma ação QoS em uma política de servidor.

Local da política Valor Usado pelas Ações de Política de Saída
Marque e aplique a ação QoS na mesma política. Ações de QoS utilizam o valor original do pacote quando ele é comumente classificado. O pacote transportará o novo valor quando ele for transmitido e o próximo roteador utiliza o novo valor.
Marque com a política de entrada e aplique a ação QoS com a política de saída. As ações QoS usam o novo ou o valor observado ao classificar o tráfego contra a política de saída.

No caminho externo, a classificação comum acontece antes que qualquer recurso de QoS seja aplicado. Um resultado dessa abordagem é que qualquer recurso QoS aplicado na política de saída influencia o valor de prioridade original. Se você precisar tomar medidas baseadas em um valor remarcado no mesmo roteador, você deve marcar os pacotes na interface de entrada e aplicar outras ações de QoS baseadas nesta nova prioridade na interface de saída.

Diagrama de Rede

As configurações nesta seção usam este diagrama de rede:

/image/gif/paws/22141/qos_orderofop_3b.gif

Nota: O Multilayer Switch Feature Card (MSFC) está atuando como um host.

Configurações

Este exemplo demonstra como a ordem das operações pode afetar a marcação de pacotes.

Separe a configuração de políticas de marcação e de modelagem
class-map match-all In_Mark
   match any 
policy-map In_Bound
  class In_Mark
    set ip precedence 5 

!--- Use Private address below:

interface FastEthernet4/0/0 
 ip address  10.20.3.2 255.255.255.0
ip route-cache distributed  
 service-policy input In_Bound

!--- Apply the input policy for class-based marking.

  
class-map match-all Out_Shaper
match ip precedence 5 
! 
policy Map Outbound_Shaper
class  Out_Shaper 
    shape average 64000 256 256 

!--- Use Private address below:

interface Serial2/0/0 
 ip address 172.16.20.1 255.255.255.252
ip route-cache distributed 
 service-policy output Outbound_Shaper

!--- Apply the output policy for class-based shaping.

Termine estas etapas para confirmar a marcação e as políticas moldadas:

  1. Use o comando ping para o endereço de destino 172.16.20.2. O sibilo combina os critérios do mapa de classe nomeado “In_Mark”.

    msfc#ping 172.16.20.2
      
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 40.1.44.2, timeout is 2 seconds: 
    !!!!! 
    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
  2. Use o comando rápido 4/0/0 show policy-map interface, para visualizar os contadores correspondentes da política de marcação baseada na classe de entrada. O mecanismo de classificação corresponde com êxito aos pacotes IP e observou o valor de precedência IP para cinco.

    7513#show policy-map interface fast 4/0/0 
     FastEthernet4/0/0 
      Service-policy input: In_Bound
     
        Class-map: In_Mark (match-all) 
          5 packets, 570 bytes 
          5 minute offered rate 0 bps, drop rate 0 bps 
          Match: any 
          QoS Set 
            ip precedence 5 
              Packets marked 5
     
        Class-map: class-default (match-any) 
          0 packets, 0 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPS 
          Match: any
  3. Use o comando show policy-map interface serial 2/0/0 para exibir os contadores de correspondência da política de moldagem baseada em classe de saída. O mecanismo de classificação corresponde perfeitamente ao valor de precedência de IP cinco destacado no cabeçalho do pacote e enfileirou os pacotes para a classe correta.

    7513#show policy-map interface serial 2/0/0 
     Serial2/0/0 
    
      Service-policy output: Outbound_Shaper
    
        Class-map: Out_Shaper(match-all) 
          5 packets, 520 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPSMatch: ip precedence 5 
          queue size 0, queue limit 16 
          packets output 5, packet drops 0 
          tail/random drops 0, no buffer drops 0, other drops 0 
          Shape: cir 64000,  Bc 256,  Be 256 
            output bytes 520, shape rate 0 BPS 
    
        Class-map: class-default (match-any) 
          0 packets, 0 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPS 
          Match: any  (1327)

Você pode ver o que acontece quando nós configuramos uma única serviço-política que aplique dar forma e marcar a uma classe de tráfego, como neste exemplo.

Configuração de Marcação Única e Política Moldada
class-map match-all prec5 
  match any 
! 
policy-map shape_five
  class prec5 
    set ip precedence 5 
    shape average 64000 256 256
int serial1/0/0
  service-policy out shape_five

A saída do comando show policy-map interface serial 2/0/0 mostra que o roteador remarcou os cinco pacotes de ping, mas os pacotes foram enfileirados para a classe de padrão de classe. Os mecanismos de classificação QoS deste roteador não levam em conta o valor remarcado do campo de precedência IP.

7513#show policy-map interface serial 2/0/0 
 Serial2/0/0
  
  Service-policy output: shape_five
 
    Class-map: prec5 (match-all) 
      0 packets, 0 bytes 
      5 minute offered rate 0 BPS, drop rate 0 BPS 
      Match:  any
      queue size 0, queue limit 16 
      packets output 0, packet drops 0 
      tail/random drops 0, no buffer drops 0, other drops 0 
      QoS Set 
        ip precedence 5 
          Packets marked 5 
      Shape: cir 64000,  BC 256,  Be 256 
        output bytes 0, shape rate 0 BPS 

    Class-map: class-default (match-any) 
      5 packets, 520 bytes 
      5 minute offered rate 0 BPS, drop rate 0 BPS 
      Match: any

Informações Relacionadas


Document ID: 22141