Switches : Switches Cisco Catalyst 4500 Series

Procedimento de recuperação de senha para o módulo do Supervisor Engine II+/II+TS/II+10GE/III/IV/V/V 10GE do catalizador 4500/4000 e Catalyst 4900 Switch que executam o Cisco IOS Software

17 Outubro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (1 Julho 2009) | Inglês (7 Outubro 2015) | Feedback


Índice


Introdução

Este documento descreve como recuperar um perdido ou uma senha desconhecida em um interruptor do catalizador 4500/4000 com o módulo do V-10GE de um Supervisor Engine II-Plus (WS-X4013+), do Supervisor Engine Ii-Mais-TS (WS-X4013+TS), do Supervisor Engine II-Plus-10GE (WS-X4013+10GE), do Supervisor Engine III (WS-X4014), do Supervisor Engine IV (WS-X4515), do Supervisor Engine V (WS-X4516), do Supervisor Engine (WS-X4516-10GE), o Cisco catalyst 4948, o Cisco catalyst 4948 10GE, e os Cisco Catalyst 4900M Switch.

Nota: No Switches do 4500/4000 Series do catalizador, nos motores II+ do supervisor, no II+10GE, no II+TS, em III, em IV, em V, e em motores somente de Cisco IOS� do apoio do V-10GE do software e do supervisor mim e II apoio somente o Catalyst OS Software. A fim recuperar a senha nos motores do supervisor eu ou II, referem o procedimento de recuperação de senha para o Catalyst 1200, 1400, 2901, 2902, 2926T/F, 2926GS/L, 2948G, 2980G, 4000, 5000, 5500, 6000, 6500 CatOS sendo executado.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Procedimento Passo a Passo

Termine estas etapas para recuperar a sua senha:

Nota: Certifique-se de que você tem o acesso físico ao interruptor e de que você usa o acesso de console ao módulo de Supervisor Engine quando você executar estas etapas. Para detalhes na conexão de console do interruptor, refira a conexão de um modem à porta de Console em Catalyst Switches.

Dica: A configuração do interruptor não é perdida se o procedimento é seguido como mencionado. Como um melhor prática, Cisco recomenda que você tem uma cópia de segurança da configuração de todos os dispositivos Cisco no servidor TFTP ou em um Network Management Server.

  1. Ciclo da potência o dispositivo.

    A fim pôr o ciclo, desligue o dispositivo, então para trás sobre.

    Pressione o Ctrl-c dentro dos segundos 5 para impedir o autoboot. Esta ação põe-no no modo de prompt do monitor de rom (ROMMON).

    
    !--- Here, you power cycle the switch.
    
    ********************************************************** 
     *                                                        * 
     * Welcome to ROM Monitor for WS-X4014 System.            * 
     * Copyright (c) 1999-2000, 2001 by Cisco Systems, Inc.   * 
     * All rights reserved.                                   * 
     *                                                        * 
     **********************************************************
     
     ROM Monitor Program Version 12.1(10r)EY(1.21) 
    
     Board type 1, Board revision 7
     Swamp FPGA revision 16, Dagobah FPGA revision 43 
     
     Timer interrupt test passed.
    
     MAC Address  : 00-02-b9-83-af-fe 
     IP Address   : 172.16.84.122 
     Netmask      : 255.255.255.0 
     Gateway      : 172.16.84.1 
     TftpServer   : Not set. 
     Main Memory  : 256 MBytes
    
    
     ***** The system will autoboot in 5 seconds *****
    
    
     Type control-C to prevent autobooting. 
    
    !--- At this point, press Ctrl-C.
    
    Autoboot cancelled......... please wait!!!
    Autoboot cancelled......... please wait!!!
    rommon 1 > [interrupt]  
    
    !--- The module ended in the ROMmon.
    
    rommon 1 > [interrupt]
  2. Emita o comando confreg na alerta de ROMMON.

    Faça as seleções que aparecem aqui no negrito para a recuperação de senha:

    rommon 1 > set
    
    rommon 1 > confreg
    
     Configuration Summary : 
     => load ROM after netboot fails
     => console baud: 9600
     => autoboot from: commands specified in 'BOOT' environment variable
    
     do you wish to change the configuration? y/n  [n]:  y
     enable  "diagnostic mode"? y/n  [n]:  n
     enable  "use net in IP bcast address"? y/n  [n]:  n
     disable "load ROM after netboot fails"? y/n  [n]:  n
     enable  "use all zero broadcast"? y/n  [n]:  n
     enable  "break/abort has effect"? y/n  [n]:  n
     enable  "ignore system config info"? y/n  [n]:  y
    
     change console baud rate? y/n  [n]:  n
    
     change the boot characteristics? y/n  [n]:  n
    
     Configuration Summary : 
     => load ROM after netboot fails
     => ignore system config info
     => console baud: 9600
     => autoboot from: commands specified in 'BOOT' environment variable
    
     do you wish to save this configuration? y/n  [n]:  y
     You must reset or power cycle for new configuration to take effect
    

    Nota: Você pode igualmente usar o comando confreg 0x2142 na alerta de ROMMON a fim ajustar o valor do registro de configuração para contornear a configuração de inicialização armazenada no NVRAM.

    rommon 1 >confreg 0x2142
    You must reset or power cycle for the new configuration to take effect.
  3. Emita o comando reset de modo que as repartições do módulo.

    Devido às mudanças que você fez em etapa 2, o módulo recarrega mas ignora a configuração salva.

    rommon 2 > reset
    
    Resetting .......
    
    rommon 3 >
    
     ********************************************************** 
     *                                                        * 
     * Welcome to ROM Monitor for WS-X4014 System.            * 
     * Copyright (c) 1999-2000, 2001 by Cisco Systems, Inc.   * 
     * All rights reserved.                                   * 
     *                                                        * 
     **********************************************************
    
    !--- Output suppressed.
    
    Press RETURN to get started! 
    
    !--- Press Return.
    
    00:00:21: %SYS-5-RESTART: System restarted --
    Cisco Internetwork Operating System Software 
    IOS (tm) Catalyst 4000 L3 Switch Software (cat4000-IS-M), 
       Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Thu 24-Jan-02 17:34 by ccai
    00:00:21: %SNMP-5-COLDSTART: SNMP agent on host Switch 
       is undergoing a cold start
    Switch>
  4. Certifique-se de que o valor do registro de configuração é 0x2142.

    Este valor faz a inicialização de módulo do flash sem uma carga da configuração salva. Emita o comando enable na alerta do interruptor ir ao modo enable. Então, emita o comando show version verificar o valor do registro de configuração.

    Switch> enable
    Switch#show version
    Cisco Internetwork Operating System Software 
    IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
       Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Thu 24-Jan-02 17:34 by ccai
    Image text-base: 0x00000000, data-base: 0x00AA2B8C
    
    ROM: 12.1(10r)EY(1.21)
    Switch uptime is 5 minutes
    System returned to ROM by reload
    Running default software
    
    cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
    Processor board ID FOX04183666
    Last reset from Reload
    32 Gigabit Ethernet/IEEE 802.3 interface(s)
    467K bytes of non-volatile configuration memory.
    
    Configuration register is 0x2142
    
    Switch#
  5. Emita o comando configure memory ou o comando copy startup-config running-config copiar o NVRAM na memória.

    Não emita o comando configure terminal, que mostra a configuração padrão no módulo.

    Switch#configure memory
    
    Uncompressed configuration from 1307 bytes to 3014 bytes
    Switch#
    00:13:52: %SYS-5-CONFIG_I: Configured from memory by console
    c-4006-SUPIII#
  6. Emita o comando show ip interface brief certificar-se de que as relações que eram em uma mostra mais adiantada do uso um estado do “Up Up”.

    Se algumas das relações que estavam no uso antes da mostra da recuperação de senha “para baixo”, emitem o comando no shutdown nessa relação trazer acima a relação.

  7. Emita o comando write terminal ou o comando show running-config indicar a configuração salva no módulo.

    c-4006-SUPIII#show running-config 
    Building configuration...
    
    Current configuration : 3014 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service compress-config
    !
    hostname c-4006-SUPIII
    !
    boot system flash bootflash:
    !
    vtp mode transparent
    
    !--- Output suppressed.
    
    line con 0
     stopbits 1
    line vty 0 4
     login
    !
    end
    
    c-4006-SUPIII#

    Agora, você está pronto para alterar a senha do módulo.

  8. Emita estes comandos mudar a senha:

    c-4006-SUPIII#configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    c-4006-SUPIII(config)#no enable secret
    
    !--- This step is necessary if the switch had an enable 
    !--- secret password.
    
    
    c-4006-SUPIII(config)#enable secret < password > 
    [Choose a strong password with at least one capital letter,
     one number, and one special character.]
    
    !--- This command sets the new password.
    
    
  9. Certifique-se de que você muda o valor do registro de configuração de volta a 0x2102.

    Termine estas etapas na alerta da configuração para mudar e verificar o valor do registro de configuração.

    c-4006-SUPIII(config)#config-register 0x2102
    c-4006-SUPIII(config)# ^Z
    c-4006-SUPIII#
    00:19:01: %SYS-5-CONFIG_I: Configured from console by console
    c-4006-SUPIII#write memory 
    
    !--- This step saves the configuration.
    
    Building configuration...
    Compressed configuration from 3061 bytes to 1365 bytes[OK]
    c-4006-SUPIII#show version 
    
    !--- This step verifies the value change.
    
    Cisco Internetwork Operating System Software 
    IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M), 
    Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Thu 24-Jan-02 17:34 by ccai
    Image text-base: 0x00000000, database: 0x00AA2B8C
    
    ROM: 12.1(10r)EY(1.21)
    c-4006-SUPIII uptime is 20 minutes
    System returned to ROM by reload
    Running default software
    
    cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
    Processor board ID FOX04183666
    Last reset from Reload
    32 Gigabit Ethernet/IEEE 802.3 interface(s)
    467K bytes of nonvolatile configuration memory.
    
    Configuration register is 0x2142 (will be 0x2102 at next reload)
    
    c-4006-SUPIII#

    Neste momento, você mudou a senha.

Saída de exemplo/Exemplo de procedimento

Este exemplo de saída é o resultado do procedimento de recuperação de senha em um Catalyst 4000 Supervisor Engine III.

c-4006-SUPIII> enable
Password: 
Password: 
Password: 
% Bad secrets 

!--- Here, you power cycle the switch.

********************************************************** 
 *                                                        * 
 * Welcome to ROM Monitor for WS-X4014 System.            * 
 * Copyright (c) 1999-2000, 2001 by Cisco Systems, Inc.   * 
 * All rights reserved.                                   * 
 *                                                        * 
 **********************************************************
 
 ROM Monitor Program Version 12.1(10r)EY(1.21) 

 Board type 1, Board revision 7
 Swamp FPGA revision 16, Dagobah FPGA revision 43 
 
 Timer interrupt test passed.

 MAC Address  : 00-02-b9-83-af-fe 
 IP Address   : 172.16.84.122 
 Netmask      : 255.255.255.0 
 Gateway      : 172.16.84.1 
 TftpServer   : Not set. 
 Main Memory  : 256 Mbytes


 ***** The system will autoboot in 5 seconds *****

 Type control-C to prevent autobooting. 

!--- At this point, press Ctrl-C.


Autoboot cancelled......... please wait!!!
Autoboot cancelled......... please wait!!!
rommon 1 > [interrupt]

rommon 1 > [interrupt]

rommon 1 > confreg

 Configuration Summary : 
 => load ROM after netboot fails
 => console baud: 9600
 => autoboot from: commands specified in 'BOOT' environment variable

 do you wish to change the configuration? y/n [n]:  y
 enable "diagnostic mode"? y/n [n]:  n
 enable "use net in IP bcast address"? y/n [n]:  n
 disable "load ROM after netboot fails"? y/n [n]:  n
 enable "use all zero broadcast"? y/n [n]:  n
 enable "break/abort has effect"? y/n [n]:  n
 enable "ignore system config info"? y/n [n]:  y

 change console baud rate? y/n [n]:  n

 change the boot characteristics? y/n [n]:  n

 Configuration Summary : 
 => load ROM after netboot fails
 => ignore system config info
 => console baud: 9600
 => autoboot from: commands specified in 'BOOT' environment variable

 do you wish to save this configuration? y/n [n]:  y
 You must reset or power cycle for new configuration to take effect

rommon 2 > reset

Resetting .......


rommon 3 >

 ********************************************************** 
 *                                                        * 
 * Welcome to ROM Monitor for WS-X4014 System.            * 
 * Copyright (c) 1999-2000, 2001 by Cisco Systems, Inc.   * 
 * All rights reserved.                                   * 
 *                                                        * 
 **********************************************************
 
 ROM Monitor Program Version 12.1(10r)EY(1.21) 

 Board type 1, Board revision 7
 Swamp FPGA revision 16, Dagobah FPGA revision 43 
 
 Timer interrupt test passed.

 MAC Address  : 00-02-b9-83-af-fe 
 IP Address   : 172.16.84.122 
 Netmask      : 255.255.255.0 
 Gateway      : 172.16.84.1 
 TftpServer   : Not set. 
 Main Memory  : 256 Mbytes

 ***** The system will autoboot in 5 seconds *****


 Type control-C to prevent autobooting.
 . . . . .

 ******** The system will autoboot now ********


 config-register = 0x2142 
 Autobooting using BOOT variable specified file.....

 Current BOOT file is --- bootflash: 

Rommon reg: 0x2B004180
Decompressing the image : ###########################
#####################################################
####################################### [OK]

k2diags version 1.6

prod: WS-X4014  part: 73-6854-07  serial: JAB0546060Z

Power-on-self-test for Module 1:  WS-X4014
Status: (. = Pass, F = Fail)

Traffic using serdes loopback (L2; one port at a time)...
switch port 0: .       switch port 1: .       switch port 2: .       
switch port 3: .       switch port 4: .       switch port 5: .       
switch port 6: .       switch port 7: .       switch port 8: .       

!--- Output suppressed.

Module 1 Passed


Exiting to ios...

Rommon reg: 0x2B000180
Decompressing the image : ##########################

!--- Output suppressed.

######################################################### [OK]

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.
           170 West Tasman Drive
           San Jose, California 95134-1706



Cisco Internetwork Operating System Software 
IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
   Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 24-Jan-02 17:34 by ccai
Image text-base: 0x00000000, database: 0x00AA2B8C

cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
Processor board ID FOX04183666
Last reset from Reload
32 Gigabit Ethernet/IEEE 802.3 interface(s)
467K bytes of nonvolatile configuration memory.


Press RETURN to get started!


00:00:21: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software 
IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
   Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 24-Jan-02 17:34 by ccai
00:00:21: %SNMP-5-COLDSTART: SNMP agent on host Switch is undergoing a cold start
Switch> enable
Switch# show version
Cisco Internetwork Operating System Software 
IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
   Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 24-Jan-02 17:34 by ccai
Image text-base: 0x00000000, database: 0x00AA2B8C

ROM: 12.1(10r)EY(1.21)
Switch uptime is 5 minutes
System returned to ROM by reload
Running default software

cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
Processor board ID FOX04183666
Last reset from Reload
32 Gigabit Ethernet/IEEE 802.3 interface(s)
467K bytes of nonvolatile configuration memory.

Configuration register is 0x2142

Switch#

Switch#configure memory

Uncompressed configuration from 1307 bytes to 3014 bytes
c-4006-SUPIII#
00:13:52: %SYS-5-CONFIG_I: Configured from memory by console
c-4006-SUPIII#show running-config 
Building configuration...

Current configuration : 3014 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname c-4006-SUPIII
!
boot system flash bootflash:
!
vtp mode transparent
!
vlan 20
  private-vlan primary
!
vlan 100
!
vlan 202
  private-vlan association 440
!         
vlan 440
  private-vlan isolated
!
vlan 500
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
!
!
interface GigabitEthernet1/1
 no switchport
 ip address 10.1.1.1 255.255.255.0
 ip pim dense-mode
!
interface GigabitEthernet1/2
 no switchport
 ip address 20.1.1.1 255.255.255.0
!

!--- Output suppressed.

!
interface Vlan1
 ip address 172.16.84.140 255.255.255.0
 ip pim dense-mode
!
interface Vlan2
 no ip address
 shutdown
!
interface Vlan20
 no ip address
 shutdown
!

!--- Output suppressed.

!         
line con 0
 stopbits 1
line vty 0 4
 login
!
end

c-4006-SUPIII#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
c-4006-SUPIII(config)#no enable secret

!--- This step is necessary if the switch had 
!--- an enable secret password.

c-4006-SUPIII(config)#enable secret < password > 
[Choose a strong password with at least one capital letter, 
one number, and one special character.]
c-4006-SUPIII(config)#config-register 0x2102
c-4006-SUPIII(config)#^Z
c-4006-SUPIII#
00:19:01: %SYS-5-CONFIG_I: Configured from console by console
c-4006-SUPIII#write memory
Building configuration...
Compressed configuration from 3061 bytes to 1365 bytes[OK]
c-4006-SUPIII#show version
Cisco Internetwork Operating System Software 
IOS (TM) Catalyst 4000 L3 Switch Software (cat4000-IS-M),
   Version 12.1(8a)EW,  RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Thu 24-Jan-02 17:34 by ccai
Image text-base: 0x00000000, database: 0x00AA2B8C

ROM: 12.1(10r)EY(1.21)
c-4006-SUPIII uptime is 20 minutes
System returned to ROM by reload
Running default software

cisco WS-C4006 (MPC8245) processor (revision 7) with 262144K bytes of memory.
Processor board ID FOX04183666
Last reset from Reload
32 Gigabit Ethernet/IEEE 802.3 interface(s)
467K bytes of nonvolatile configuration memory.

Configuration register is 0x2142 (will be 0x2102 at next reload)

c-4006-SUPIII#

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 21229