Switches de LAN : EtherChannel

Configuração EtherChannel entre os switches Catalyst que executam o software do sistema do Cisco IOS e um roteador Cisco

17 Outubro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (7 Outubro 2015) | Feedback


Índice


Introdução

Esta configuração de exemplo demonstra como estabelecer um EtherChannel da camada 3 (L3), sem trunking VLAN, entre um roteador Cisco e um Cisco Catalyst 6500 Switch que executam o software do sistema de Cisco IOS�. O EtherChannel pode ser chamado de Fast EtherChannel (FEC) ou Gigabit EtherChannel (GEC); o termo depende da velocidade das interfaces ou das portas usadas para formar o EtherChannel. Neste exemplo, duas portas Fast Ethernet de um roteador Cisco e um switch Catalyst 6500 foram agrupados em um FEC. Em todo este documento, os termos FEC, GEC, canal de porta, canal e grupo de portas se referem a EtherChannel.

Este documento inclui somente os arquivos de configuração do interruptor e do roteador, e a saída dos comandos relacionados à exibição de amostra.

Pré-requisitos

Requisitos

Antes de você tentar esta configuração, verifique se estes requisitos são atendidos:

  • Catalyst 6500/6000 e Switches do 4500/4000 Series que executa o Cisco IOS Software:

    • O Catalyst 6500/6000 e o Switches do 4500/4000 Series que executa o Cisco IOS Software apoiam EtherChannel camada 2 (L2) e L3, com até oito compativelmente interfaces Ethernet configuradas em todo o módulo. Todas as relações em cada EtherChannel devem estar à mesma velocidade. Toda devem ser configuradas como as relações L2 ou L3.

    • O balanceamento de carga de EtherChannel pode usar endereços MAC, endereços IP ou os números de porta de TCP.

      Nota: O modo selecionado aplica-se a todos os EtherChannéis configurados no interruptor.

    • Cisco IOS Software Release 12.1E ou Mais Recente do Catalyst 6500/6000 e Cisco IOS Software Release 12.1(8a)EW ou Mais Recente do catalizador 4500/4000.

  • Roteadores Cisco:

    • O tráfego IP distribui sobre a relação de Canal de porta quando o tráfego de outros protocolos de roteamento enviar sobre um link único. O tráfego interligado distribui com base na informação L3 no pacote. Se a informação L3 não existe no pacote, o tráfego envia sobre o primeiro link.

  • Uma ampla variedade de roteadores Cisco apoia o EtherChannel. Para encontrar uma plataforma ou uma versão de código que apoiem o EtherChannel em um roteador Cisco, use o Cisco Feature Navigator II (clientes registrados somente). Uma lista de Roteadores e de Cisco IOS Software Release que apoiam o EtherChannel é encontrada sob a característica FEC.

Para o requisito de software e hardware para o EtherChannel em outros produtos Cisco, refira requisitos do sistema para executar o EtherChannel em Catalyst Switches.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco IOS Software Release 12.1(8b)E10 running do Catalyst 6500 Switch

  • Cisco IOS Software Release 12.1(21) running do Cisco 7500 Router

A configuração de switch neste documento aplica-se a todo o Catalyst 6500/6000 e a qualquer Cisco IOS Software running do interruptor do 4500/4000 Series do catalizador.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Nota: O uso do comando write erase apagou as configurações em todos os dispositivos para garantir que ele tivesse uma configuração padrão. Certifique-se recarregar os dispositivos depois que você emite o comando write erase nivelar todas as configurações não padrão.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Notas importantes

Se você emite inicialmente o comando channel-group sob a interface física, cria automaticamente a interface de canal de porta. Se você configurou a interface de canal de porta antes que você canalizou interfaces física, remova a interface de canal de porta primeiramente. Isto é somente relevante em Catalyst Switches. A ordem de configuração é alterada no roteador 7500. Você deve configurar a interface de canal de porta antes que você configure o grupo do the�channel sob a interface física.

A ordem da configuração de um canal de porta no software Cisco IOS do Catalyst 6500/6000 e 4500/4000 é importante. É o melhor emitir todo o comando switchport antes que você emita o comando channel-group em uma interface física.

Quando você emitir o comando channel-group antes do comando switchport em uma interface física (Gigabit Ethernet 1/1 da relação), a interface de canal de porta está criada automaticamente e transforma-se uma relação L3. Se você emite então o comando switchport sob a interface física, a interface física transforma-se uma relação L2. Também, a interface de canal de porta que você criou mais cedo não tem nenhuma interface física associada com ela. Observe que o comando channel-group é ausente de debaixo da interface física. Neste caso, você deve primeiramente emitir o comando switchport sob a interface de canal de porta recentemente configurada. Então, a porta física aceita o comando channel-group outra vez. Neste caso, o Canal de porta mudou de uma relação L3 a uma relação L2.

Considere, ao contrário, se você emite o comando switchport primeiramente em uma interface física e adiciona então o comando channel-group. Neste caso, a interface de canal de porta automaticamente é criada e herda todos os comandos configured switchport.

Em um Catalyst 6500/6000 comute Cisco IOS Software running, todas as portas são as portas L3 à revelia. Em um Cisco IOS Software running do interruptor do catalizador 4500/4000, todas as portas são as portas L2 à revelia.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Use a ferramenta Command Lookup Tool (apenas para clientes registrados) para obter mais informações sobre os comandos usados neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/21066/135-a.gif

Configurações

Este documento utiliza as seguintes configurações:

Nota: Os comentários e as explicações aparecem nos itálico azul.

Catalyst 6500 Switch (Without VLAN Trunking)
Building configuration...
�
Current configuration : 5869 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8b.E15.bin
boot bootldr bootflash:c6msfc-boot-mz.121-8b.E15
enable password ww
!
redundancy
�main-cpu
� auto-sync standard
ip subnet-zero
!
!
no ip finger
!
!
!
!

!--- In this example, you configure L3 EtherChannel.
!--- For more details, refer to this document:
!--- Configuring EtherChannels.
!--- A logical port-channel interface is automatically created�
!--- when ports are grouped into a channel group.


interface Port-channel 1
�ip address 11.1.1.2 255.255.255.0
 duplex full
 speed 100

!--- If you specify the speed and duplex setting at the port channel 
!--- level, these settings pass down to the physical ports.
!--- In other words, the physical ports inherit the same speed 
!--- and duplex settings as the port-channel interface.

 hold-queue 300 in
!
interface GigabitEthernet1/1
�no ip address
�shutdown
!
interface GigabitEthernet1/2
�no ip address
�shutdown
!
interface FastEthernet3/1
 no ip address
 duplex full
 speed 100

!--- Port is a member of channel group 1. Routers do not support 
!--- EtherChannel negotiation (Port Aggregation Protocol [PAgP]), so PAgP
!--- needs to be disabled. On a Catalyst 4500/4000 switch, all ports are
!--- L2 ports by default. Convert this port from a physical L2 port to
!--- a physical L3 port with the no switchport command.

channel-group 1 mode on

interface FastEthernet3/2
�no ip address
 duplex full
 speed 100

!--- Port is a member of channel group 1. Routers do not support 
!--- EtherChannel negotiation (PAgP), so PAgP needs to be disabled.
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default. 
!--- Convert this port from a physical L2 port to a physical L3 port 
!--- with the no switchport command.


channel-group 1 mode on


interface FastEthernet3/3
�no ip address
�switchport
�switchport mode access
!

!--- Output suppressed.

!
ip classless
no ip http server
!
!
!
line con 0
�transport input none
line vty 0 4
!
end

Roteador Cisco 7500 (Sem Truncamento de VLAN)

!--- Output suppressed.

!
interface Port-channel1
�ip address 11.1.1.1 255.255.255.0
 full-duplex
�hold-queue 300 in
!
interface FastEthernet0/0
�no ip address
�full-duplex
 speed 100
�channel-group 1
!
interface FastEthernet0/1
�no ip address���
�full-duplex
 speed 100���������������������������� �
�channel-group 1

!--- Output suppressed.

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

comandos show

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • mostre o canal de porta do ID de canal do EtherChannel — Para verificar o Canal de porta em um interruptor do Cisco IOS.

  • mostre o ID de canal do canal de porta das relações — Para verificar o Canal de porta em um roteador do Cisco IOS.

Exemplo de saída do comando show

Interruptor do Catalyst 6500/6000

  • mostre o canal de porta do ID de canal do EtherChannel

Router#show etherchannel 1 port-channel
Port-channels in the group:
----------------------
Port-channel: Po1
------------
Age of the Port-channel = 01h:56m:20s

Logical slot/port = 10/1 Number of ports in agport = 2
GC = 0x00010001 HotStandBy port = null
Passive port list = Fa3/1 Fa3/2
Port state = Port-channel L3-Ag Ag-Inuse
Ports in the Port-channel:
Index Load Port
-------------------
0 55 Fa3/1
1 AA Fa3/2
Time since last port bundled: 01h:55m:44s Fa3/2
Router#

Cisco 7500 Router

  • show interfaces port-channel channel-id

Router#show interfaces port-channel 1
Port-channel1 is up, line protocol is up
Hardware is FastEtherChannel, address is 00e0.1476.7600 (bia 0000.0000.0000)
Internet address is 11.1.1.1/24
MTU 1500 bytes, BW 400000 Kbit, DLY 100 usec, rely 255/255, load 62/255
Encapsulation ARPA, loopback not set, keepalive set (10 sec), hdx
ARP type: ARPA, ARP Timeout 04:00:00
No. of members in this fechannel: 2
Member 0 : FastEthernet0/0
Member 1 : FastEthernet0/1
Last input never, output never, output hang never
Last clearing of "show interface" counters 10:51:55
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/300, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 98281000 bits/sec, 8762 packets/sec
4545 packets input, 539950 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 watchdog, 0 multicast
0 input packets with dribble condition detected
342251216 packets output, 3093422680 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 21066