Cisco Interfaces and Modules : Módulo de switching de conteúdo da Cisco

Configurando o cache transparente no módulo content switch

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como configurar um módulo content switch (CS) para o cache transparente, com Content Engine de Cisco como esconderijos. O cache transparente é ajustado entre o usuário e o servidor. O CS é introduzido entre o usuário e o esconderijo. O CS é inteligente devido a sua capacidade da camada 5 para analisar dinamicamente o índice e determinar se é em cache ou não. Estas diretrizes aplicam-se:

  • Se o em cache, a carga CS equilibra o pedido ao serviço de cache baseado no predictor configurado.

  • Se não o em cache, o CS envia-o diretamente ao servidor de origem. Isto evita a batida do desempenho que ocorre quando o objeto não ocultável vai ao esconderijo, simplesmente para ter seu pedido reorientado pelo esconderijo ao servidor de origem.

Há diversos métodos de balanceamento disponíveis, que dependem em cima de como você quer distribuir dados sobre os esconderijos (por exemplo, URL inteira, série de URL, e assim por diante).

O CSM pode ser configurado com uma lista de extensões de arquivo para enviar ao cache. Essa lista é chamada de Lista qualificadora de extensão (EQL). Uma vez que você configura o política de cache de política SLB sob o vserver TRANSPARENTE, simplesmente os pedidos com as extensões de arquivo que são alistadas na lista do URL de cache do mapa estão enviados ao esconderijo. Se as extensões de arquivo não são alistadas na lista do URL de cache do mapa, a seguir o pedido baterá a política sem cache política SLB.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Release 12.1(8)EX de Cisco IOS� do Catalyst 6000 Supervisor para o Supervisor Engine 1 com MSFC1 (c6sup11-dsv-mz.121-8a.EX)

  • Liberação de software CSM 2.1(2) do catalizador 6000 (c6slb-apc.2-1-2.bin)

  • Liberação running 5.1.3 do Software Cisco Application and Content Networking System do Cisco Content Engine 565

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você é presentado com a informação para configurar as características que são descritas neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

Cache transparente no CS

config_transp_caching_19680.gif

Configurações

Este documento utiliza as seguintes configurações:

CS
Building configuration...
Current configuration : 4500 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat
!
boot buffersize 126968
enable password cisco
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
!
ip name-server 10.107.241.185
!

!--- CSM located in slot 3. Module is running as active
!--- cache and client side on the same CSM VLAN 100.

module ContentSwitchingModule 3
 vlan 100 client
  ip address 10.107.249.251 255.255.255.248
  gateway 10.107.249.249
!

!--- End user located in CSM VLAN 200.

 vlan 200 server
  ip address 10.107.249.251 255.255.255.248
!

!--- Probe setup to check the availability of the Content
!--- Engine default probe values. Interval is 300 seconds.

 probe CACHEPROBE tcp
!

!--- Serverfarm CACHE.
!--- Note: Issue the no nat server command.
!--- CSM needs to do a Layer 2 rewrite.
!--- Balancing predictor is hash URL.

 serverfarm CACHE
  no nat server
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!

!--- Serverfarm OUTBOUND.
!--- Note: Use the serverfarm OUTBOUND to bypass the cache.
!--- Requests that do not match the map CACHEABLE url list
!--- will use serverfarm OUTBOUND. The NAT server has no
!--- effect, as no reals are configured.
!--- Balancing predictor forward.

 serverfarm OUTBOUND
  nat server
  no nat client
  predictor forward
!

!--- Map CACHEABLE URL.

 map CACHEABLE url

!--- Extension Qualifier List (EQL).

  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!

!--- Vserver TRANSPARENT.
!--- Note: Virtual IP is all zeros.
!--- Use of persistence rebalance for HTTP 1.1.
!--- Parse-lengh set to 2000 bytes.
!--- Two policies added to vserver TRANSPARENT.

 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!

!--- Fault Tolerance group 1.
!--- Used to configure redundancy between modules 3 and 4.

 ft group 1 vlan 250
  priority 20
!

!--- CSM located in slot 4. Module is running as standby
!--- cache and client side on the same CSM VLAN 100.

module ContentSwitchingModule 4
 vlan 100 client
  ip address 10.107.249.253 255.255.255.248
  gateway 10.107.249.249
!

!--- End user located in CSM VLAN 200.
!--- Note: Module 3 and 4 VLAN IP addresses are different.

 vlan 200 server 
  ip address 10.107.249.253 255.255.255.248
!

!--- Probe setup to check availability of Content Engine.
!--- Default probe values. Interval 300 seconds.

!
 probe CACHEPROBE tcp
!

!--- Serverfarm CACHE.
!--- Note: Issue the no nat server command. CSM needs to
!--- do a Layer 2 rewrite.
!--- Balancing predictor is hash URL.

 serverfarm CACHE
  no nat server
  no nat client
  predictor hash url
  real 10.107.249.254
   inservice
  real 10.107.249.252
   inservice
  probe CACHEPROBE
!

!--- Serverfarm OUTBOUND
!--- Note: Use the serverfarm OUTBOUND to bypass the cache.
!--- Requests that do not match the CACHEABLE URL list will
!--- use serverfarm OUTBOUND. The NAT server has no effect,
!--- as no reals are configured.
!--- Balancing predictor forward.

 serverfarm OUTBOUND
  nat server
  no nat client
  predictor forward
!

!--- Map CACHEABLE URL.

 map CACHEABLE url

!--- Extension Qualifier List (EQL).

  match protocol http url *.pdf
  match protocol http url *.fdf
  match protocol http url *.au
  match protocol http url *.bmp
  match protocol http url *.z
  match protocol http url *.gif
  match protocol http url *.html
  match protocol http url *.js
  match protocol http url *.mocha
  match protocol http url *.jpeg
  match protocol http url *.jpg
  match protocol http url *.jpe
  match protocol http url *.jfif
  match protocol http url *.pjpeg
  match protocol http url *.pjp
  match protocol http url *.mp2
  match protocol http url *.mpa
  match protocol http url *.abs
  match protocol http url *.mpeg
  match protocol http url *.mpg
  match protocol http url *.mpe
  match protocol http url *.mpv
  match protocol http url *.vbs
  match protocol http url *.m1v
  match protocol http url *.pcx
  match protocol http url *.txt
  match protocol http url *.text
  match protocol http url *.mov
  match protocol http url *.tiff
  match protocol http url *.tar
  match protocol http url *.avi
  match protocol http url *.wav
  match protocol http url *.gz
  match protocol http url *.zip
!
 map NONCACHABLE url
  match protocol http url *
!
 policy CACHE-POLICY
  url-map CACHEABLE
  serverfarm CACHE
!
 policy NONCACHE-POLICY
  url-map NONCACHABLE
  serverfarm OUTBOUND
!

!--- Vserver TRANSPARENT.
!--- Note: Virtual IP is all zeros.
!--- Use of persistence rebalance for HTTP 1.1.
!--- Parse-lengh set to 2000 bytes.
!--- Two policies added to vserver TRANSPARENT.

 vserver TRANSPARENT
  virtual 0.0.0.0 0.0.0.0 tcp www
  serverfarm CACHE
  persistent rebalance
  parse-length 2000
  slb-policy CACHE-POLICY
  slb-policy NONCACHE-POLICY
  inservice
!

!--- Fault Tolerance group 1.
!--- Used to configure redundancy between modules 3 and 4.

 ft group 1 vlan 250
!
interface GigabitEthernet1/1
 no ip address
 shutdown
!
interface GigabitEthernet1/2
 no ip address
 shutdown
!

!--- CSM client side VLAN. Uplink to the Internet.

interface FastEthernet2/1
 no ip address
 switchport
 switchport access vlan 100
!
interface FastEthernet2/2
 no ip address
 shutdown
!

!--- Cache Engine connected to FE2/3 and FE2/4.
!--- CSM client side VLAN.

interface FastEthernet2/3
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!
interface FastEthernet2/4
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 100
!

!--- CSM Server side VLAN. Connection to end users.

interface FastEthernet2/5
 no ip address
 switchport
 switchport access vlan 200
!

!--- MSFC VLAN 100. Content Engine and client uses this
!--- address as the default gateway.

interface Vlan100
 ip address 10.107.249.250 255.255.255.248
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.107.249.249
no ip http server
!
line con 0
line vty 0 4
password cisco
login
!
end

Content Engine
device mode content-engine
!
hostname ce1
!
http proxy incoming 80

!--- Accept proxy requests on port 80.

!
http l4-switch enable


!--- Instructs the Content Engine to accept traffic that is
!--- directed to any destination IP.

!
ip domain-name cisco.com
!
!
interface Fastethernet 0/0
 ip address 10.107.249.254 255.255.255.248
 exit
!
interface Fastethernet 0/1
 exit
!
ip default-gateway 10.107.249.250
!
primary-interface Fastethernet 0/0
!
!
no auto-register enable
!
ip name-server 10.107.241.185
!
!
username admin password 1 bVmDmMMmZAPjY
username admin privilege 15
!
authentication login local enable primary
authentication configuration local enable primary
!
! End of ACNS configuration

Verificar

Esta seção fornece a informação que você pode usar para confirmar que sua configuração está trabalhando corretamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

Nota: Antes de emitir comandos de depuração, consulte Informações Importantes sobre Comandos de Depuração.

Comandos debug and show CS

  • show module

  • mostra arp — Fornece a lista do esconderijo do Address Resolution Protocol (ARP) do Server Load Balancing (SLB).

  • conns da mostra — Fornece a informação de conexão SLB.

  • dfp da mostra — Fornece a informação de gerenciador do Dynamic Feedback Protocol (DFP) SLB.

  • mostra ft — Fornece a informação da tolerância de defeito SLB (FT).

    cat# show module csm 3 ft
    
    FT group 1, vlan 250
    This box is active
    priority 20, heartbeat 1, failover 3, preemption is off
    
    cat# show module csm 4 ft
    
    FT group 1, vlan 250
    This box is in standby state
    priority 10, heartbeat 1, failover 3, preemption is off
  • mapa da mostra — Fornece a informação de mapa SLB.

  • memória da mostra — Fornece a informação de memória SLB.

  • natpools da mostra — Informação do conjunto NAT do Fornece cliente SLB.

  • política da mostra — Fornece a informação sobre a política SLB.

  • ponta de prova da mostra — Fornece informação de prova SLB.

  • reais da mostra — Fornece a informação do servidor real SLB.

  • serverfarms da mostra — Fornece a informação do server farm SLB.

  • estática da mostra — Fornece a informação NAT de servidor estático SLB.

  • stats da mostra — Fornece estatístico de SLB.

  • estado da mostra — Fornece a informação de status SLB.

  • Sticky da mostra — Fornece a base de dados sticky SLB.

  • tecnologia-apoio da mostra — Fornece o SLB técnico debugam a informação.

  • mostra vlan — Fornece a informação de VLAN SLB.

  • vserveres da mostra — Fornece a informação do servidor virtual SLB.

    show module csm 3 vservers name transparent detail
    
    TRANSPARENT, state = OPERATIONAL, v_index = 10
      virtual = 0.0.0.0/0:80, TCP, service = NONE, advertise = FALSE
      idle = 3600, replicate csrp = none, vlan = ALL
      max parse len = 2000, persist rebalance = TRUE
      conns = 0, total conns = 47
      Default policy:
        server farm = CACHE
        sticky: timer = 0, subnet = 0.0.0.0, group id = 0
      Policy           Tot Conn     Client pkts  Server pkts
      ------------------------------------------------------
      CACHE-POLICY     44           249          203
      NONCACHE-POLICY  37           111          37
      (default)        0            0            0
  • módulo csm? — Configura o CS para o cache transparente. Igualmente especifica o lugar do CS que você está configurando.

    cat(config)# module csm ?
    
    <1-6>  slot where the CSM module resides
  • proxy de vserver — Configura o servidor virtual.

    cat(config-module-csm)# vserver proxy
    
    cat(config-slb-vserver)# ?
    
  • o vserver anuncia — Anuncie o endereço IP de Um ou Mais Servidores Cisco ICM NT virtual.

  • cliente de servidor v — Ajusta os endereços IP cliente.

  • padrão do vserver — Ajusta um comando a seus padrões.

  • saída do vserver — Retira o submode do Server Load Balancing.

  • quietude do vserver — Ajusta o temporizador de ociosidade.

  • vserver em serviço — Permite o serviço para este servidor virtual.

  • nenhum vserver — Nega um comando ou ajusta seus padrões.

  • analisar gramaticalmente-comprimento do vserver — Ajusta a camada máxima 7 analisam gramaticalmente o comprimento.

  • vserver persistente — Permite ou desabilita a persistência de conexão.

  • replicate do vserver — Ajusta a replicação da tolerância de defeito do vserver.

  • serverfarm do vserver — Ajusta a exploração agrícola do servidor real.

  • SLB-política do vserver — Ajusta a política do Server Load Balancing.

  • Sticky do vserver — Ajusta o temporizador difícil.

  • URL-mistura do vserver — Ajusta o fósforo do prefixo/sufixo para o algoritmo da URL-mistura.

  • vserver virtual — Configura um servidor virtual.

  • esconderijo do serverfarm — Configura a fazenda do server.

    cat(config-module-csm)# serverfarm cache
    
    cat(config-slb-sfarm)# ?
    
  • bindid do serverfarm — Ligamentos ID para o DFP.

  • padrão do serverfarm — Ajusta um comando a seus padrões.

  • saída do serverfarm — Submode da fazenda do server das saídas SLB.

  • failaction do serverfarm — Ação a tomar na falha de servidor real.

  • serverfarm nat — Ajusta a tradução de endereços para o SLB.

  • nenhum serverfarm — Nega um comando ou ajusta seus padrões.

  • prognosticador de farm de servidor — Ajusta o algoritmo de predição do Balanceamento de carga.

  • ponta de prova do serverfarm — Configura para o uso de uma ponta de prova.

  • serverfarm real — Configura um servidor real.

  • reorientar-vserver do serverfarm — Configura um SLB reorientam o servidor virtual.

Comandos show do Content Engine

  • show statistics http savings — Salvar as estatísticas do Content Engine.

    ce1# show statistics http savings
    
                           Statistics - Savings
                         Requests           Bytes
    -----------------------------------------------
    Total:               635                2764599
    Hits:                113                254517
    Miss:                505                2483555
    Savings:            17.8 %              9.2 %

    Como você pode ver, havia 113 batidas.

Troubleshooting

Não há atualmente nenhuma informações disponíveis específica para pesquisar defeitos esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 19680