IP : Alocação e resolução dinâmica de endereços

Utilização de Um Servidor DHCP para Redes de Voz e Dados

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Em uma rede de telefonia IP otimizada, os endereços IP de telefones e PCs devem ser configurados em segmentos de rede diferentes. Quando o Dynamic Host Configuration Protocol (DHCP) é usado para atribuir endereços, normalmente é necessário um servidor DHCP para cada segmento da rede. Contudo, você pode usar um único servidor DHCP para atribuir ambos os intervalos de endereços se você tiver os roteadores que suportam a transmissão de DHCP em sua rede IP. Este documento explica como e por que é possível usar um único servidor para endereços IP de voz e dados.

Nota: As informações neste documento não se aplicam em uma rede completamente comutada ou se não houver um dispositivo com capacidade de roteamento. Em tais encenações, há somente duas possibilidades para atribuir endereços IP de Um ou Mais Servidores Cisco ICM NT diferentes aos telefones e PCs.You deve ter um servidor DHCP com dois Network Interface Cards ou ter dois servidores DHCP.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Problema

Se você instala uma rede de telefonia do IP, a seguir você deve atribuir endereços IP de Um ou Mais Servidores Cisco ICM NT para seus telefones e PC em segmentos de rede diferentes. Essas atribuições de endereços necessitam de um servidor DHCP para cada segmento de rede. Contudo, você tem somente um servidor DHCP.

Solução

Para poder usar o servidor DHCP atual para atribuir endereços para ambas as VLANs, é necessário ter um dispositivo de Layer 3 (L3) na rede que esteja apto a fazer o roteamento da inter-VLAN.

Os dois exemplos constantes neste documento descrevem como utilizar um servidor DHCP para atribuir endereços IP tanto de voz quanto de dados.

A configuração da rede

Há uma rede atual com um Cisco catalyst 6000 ou um Catalyst 3524-XL-PWR. Em qual, VLAN10 é configurado para ser o VLAN de dados usado pelos PC e pelos server. No mesmo VLAN há igualmente um servidor DHCP que execute o Windows 2000 para fornecer endereços na escala 10.10.10.20 a 10.10.10.200. O endereço IP do servidor DHCP é 10.10.10.2.

dhcp-multintwk-1.gif

Para adicionar IP Telephony nessa rede, conecte um telefone IP a um PC na porta do Catalyst onde o PC estava conectado.

Exemplo do Catalyst 6000 com MSFC

Nesta encenação, há um Cisco catalyst 6000 com um Multilayer Switch Feature Card (MSFC) como o dispositivo capaz do roteamento.

/image/gif/paws/19580/dhcp-multintwk-2.gif

Para permitir que o PC e o telefone estejam na mesma porta de Catalyst, você precisa configurar o comando auxiliaryVLAN com a nova VLAN 110 de voz, conforme mostrado:

cat6k-access> (enable) set VLAN 110 name 11.1.1.0_voice
cat6k-access> (enable) set VLAN 10 5/1-48
cat6k-access> (enable) set port auxiliaryVLAN 5/1-48 110

Para permitir que o atual servidor de DHCP no VLAN 10 de dados seja usado para atribuir endereços IP aos telefones, siga estas etapas:

  1. Crie uma relação no MSFC para cada VLAN, dados e Voz.

  2. Configurar cada relação com um endereço válido no VLAN.

  3. Na relação VLAN 110, adicionar um comando ip helper-address.

    Esse comando permite que pacotes de difusão DHCP na VLAN 110 de voz sejam enviados como pacotes unicast para o servidor DHCP na VLAN 10 de dados.

    A configuração do MSFC deve ser:

    cat6k-msfc(config)#interface vlan10
    cat6k-msfc(config-if)#ip address 10.10.10.19
    cat6k-msfc(config-if)#<description of data VLAN for PCs and where the DHCP
     server is located>
    
    cat6k-msfc(config)#interface vlan110
    cat6k-msfc(config-if)#ip address 11.1.1.19
    cat6k-msfc(config-if)#ip helper-address 10.10.10.2
    cat6k-msfc(config-if)#<description VLAN for voice>
    

    A configuração do Cisco Catalyst 6000 permanece inalterada.

  4. Configurar o servidor DHCP com um espaço novo dos endereços para os telefones (11.1.1.1.X) na Voz VLAN 110.

    Se o servidor DHCP não tem um espaço que combine o endereço IP de Um ou Mais Servidores Cisco ICM NT do agente de transmissão, a seguir a requisição DHCP falha. Você precisa adicionar a opção 150 a esse escopo a fim de fornecer o endereço do servidor TFTP para os telefones. Para instruções passo a passo na configuração do servidor DHCP para os telefones, refira configurar o servidor DHCP do Windows 2000 para o CallManager da Cisco.

Exemplo do Catalyst 3524-XL com um roteador externo

Nesta encenação, há um Cisco catalyst 3524-XL-PWR e um roteador externo como o dispositivo capaz do roteamento, com uma relação em cada VLAN.

/image/gif/paws/19580/dhcp-multintwk-3.gif

Para permitir que o PC e o telefone estejam na mesma porta do Catalyst, configurar o entroncamento com a Voz nova VLAN 110 como mostrado:

interface FastEthernet0/13
description phone and PC
switchport mode trunk
switchport trunk encapsulation dot1q
switchport voice vlan 110
switchport trunk native vlan 10

Repita a configuração para todas as portas no Catalyst nas quais você conectou um telefone com um PC conectado ao telephone.

Para permitir que o atual servidor de DHCP no VLAN 10 de dados seja usado para atribuir endereços IP aos telefones, siga estas etapas:

  1. Conecte duas interfaces do roteador a duas portas no Cisco catalyst 3524-XL, um no VLAN10 e o outro em VLAN 110.

  2. No lado do roteador, atribua um endereço válido em cada VLAN.

    Nota: Com o entroncamento configurado, você pode igualmente conseguir este com uma porta única conectada do Catalyst 3524-XL ao roteador.

  3. Emita o comando ip helper-address na interface do roteador que é conectada para exprimir VLAN 110.

    Isso permite que pacotes de difusão DHCP recebidos na interface sejam enviados como pacotes de unicast ao servidor DHCP na VLAN 10 de dados.

    A configuração desse roteador deve ser conforme indicado:

    router(config)#interface FastEthernet0/0 
    router(config-if)#ip address 10.10.10.19 255.255.255.0 
    
    router(config-if)#<description connected to catalyst port 0/10 
     data VLAN for PCs and DHCP server>
     
    router(config)#interface FastEthernet0/1
    router(config-if)#IP address 11.1.1.19 255.255.255.0 
    router(config-if)#IP helper-address 10.10.10.2 
    router(config-if)#<description connected to catalyst port 0/11 voice VLAN>
    
    

    A configuração no Cisco catalyst 3524-XL deve ser:

    router(config)interface FastEthernet0/10
    router(config-if)#switchport access vlan 10
    router(config-if)#<description port on data VLAN going to the router FE0/0>
    
    router(config)interface FastEthernet0/11
    router(config-if)#switchport access vlan 110
    router(config-if)#<description port on voice VLAN going to the router FE0/1>
    
  4. Configurar o servidor DHCP com um espaço novo dos endereços para os telefones (11.1.1.1.X) na Voz VLAN 110.

    Se o servidor DHCP não tem um espaço que combine o endereço IP de Um ou Mais Servidores Cisco ICM NT do agente de transmissão, a requisição DHCP falha. Você precisa adicionar a opção 150 a esse escopo a fim de fornecer o endereço do servidor TFTP para os telefones. Para instruções passo a passo na configuração do servidor DHCP para os telefones, refira configurar o servidor DHCP do Windows 2000 para o CallManager da Cisco.

Como a solução funciona

O servidor DHCP pode fornecer endereços do escopo apropriado para ambas as VLANs, de acordo com o uso do campo Agente de transmissão nos pacotes DHCP. Um agente de transmissão é o agente que é responsável da conversão dos pacotes DHCP da transmissão enviados pelo telefone nos pacotes do unicast que são enviados ao servidor DHCP. Este agente igualmente converte os pacotes DHCP do unicast enviados do servidor DHCP nos pacotes de transmissão que são enviados na rede telefônica. Neste exemplo, o agente de transmissão é a relação VLAN 110 no MSFC configurado com o comando ip helper-address.

Quando o servidor DHCP recebe a mensagem do DHCP Discover com um endereço IP atual no campo Relay Agent (Agente de Transmissão), o servidor DHCP usa esse endereço para fazer a correspondência com o escopo adequado e atribui o endereço IP a partir dele. Você pode ver detalhes desse protocolo no RFC 3046.leavingcisco.com

Os pacotes DHCP que são trocados nesse exemplo seriam conforme exibido:

/image/gif/paws/19580/dhcp-multintwk-4.gif

As linhas azul mostram os pacotes DHCP que são enviados a e do IP Telephone. Esses são os únicos pacotes que aparecerão se o servidor DHCP estiver na mesma rede Ethernet que os telefones.

As linhas negras representam os pacotes unicast DHCP que o agente de transmissão transmite para e do servidor DHCP.

Esta tabela mostra os detalhes dos pacotes deste exemplo. Para detalhes sobre o protocolo DHCP e os campos, refira o RFC 1541leavingcisco.com .

1 DHCP descobre 2 DHCP descobrem
IP Source Address = [0.0.0.0] 
IP Destination Address = [255.255.255.255] 

DHCP Client IP Address = [0.0.0.0] 
DHCP Relay Agent = [0.0.0.0] 
Client Hardware Address = 00070EEA5449 
Message Type = 1 (DHCP Discover) 
Parameter Request List:
...
    150= Unknown Option 
... 
IP Source Address = [11.1.1.19] 
IP Destination Address =[10.10.10.2]

DHCP Client IP Address = [0.0.0.0]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 1 (DHCP Discover)
Parameter Request List:
...
    150= Unknown Option 
...
Oferta de DHCP 4 Oferta de DHCP 3
IP Source Address = [10.10.10.2]
IP Destination Address = [255.255.255.255]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449
Message Type = 2 (DHCP Offer)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...
IP Source Address = [10.10.10.2]
IP Destination Address = [11.1.1.19]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 2 (DHCP Offer)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...
Requisição DHCP 5 Requisição DHCP 6
IP Source Address = [0.0.0.0] 
IP Destination Address = [255.255.255.255]

DHCP Client IP Address = [0.0.0.0]
DHCP Relay Agent = [0.0.0.0]
Client Hardware Address = 00070EEA5449 
Message Type = 3 (DHCP Request)
Request Specific IP Address = [11.1.1.25]
Parameter Request List:
...
    150= Unknown Option 
...
IP Source Address = [11.1.1.19] 
IP Destination Address = [10.10.10.2]

DHCP Client IP Address =  [0.0.0.0]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 3 (DHCP Request)
Request Specific IP Address = [11.1.1.25]
Parameter Request List:
...
    150= Unknown Option 
...
8 DHCP Ack 7 DHCP Ack
IP Source Address = [10.10.10.2]
IP Destination Address = [255.255.255.255]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449
Message Type = 5 (DHCP Ack)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...
IP Source Address = [10.10.10.2] 
IP Destination Address = [11.1.1.19]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 5 (DHCP Ack)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 19580