IP : Border Gateway Protocol (BGP)

Troubleshooting Quando as Rotas de BGP Não São Publicadas

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

A finalidade deste documento é proporcionar uma abordagem sistemática para ajudar em situações de solução de problemas quando um roteador BGP (Protocolo de gateway de borda) não anuncia as rotas BGP aos peers.

Há as formas múltiplas em que um prefixo é adicionado a uma tabela de BGP e anunciado aos pares:

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas. Contudo, as saídas mostradas no documento são baseadas nos Cisco 2500 Series Router que executam a versão de software 12.2(24)a do½ do¿Â do Cisco IOSïÂ.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Rotas anunciadas usando uma instrução básica da rede

Quando as rotas são anunciadas usando uma instrução de rede básica, o comportamento do comando network varia segundo se o resumo automático está permitido ou desabilitado. Quando o auto-resumo está habilitado, ele resume as redes BGP originadas localmente (rede x.x.x.x) a seus limites totais de classe (o auto-resumo é habilitado por padrão no BGP). Se uma sub-rede existe na tabela de roteamento e estas três circunstâncias estão satisfeitas, toda a sub-rede (rota do componente) dessa rede de classe completa na tabela de roteamento local alerta o BGP para instalar a rede de classe completa na tabela de BGP:

  • Auto-summary enabled

  • Instrução de rede classful para uma rede na tabela de roteamento

  • Disfarce classful nessa instrução de rede

Quando o auto-resumo está desabilitado, as rotas introduzidas localmente na tabela do BGP não são resumidas a seus limites totais de classe.

Por exemplo, o BGP introduz a máscara 255.0.0.0 de 75.0.0.0 da rede de classe completa na tabela de BGP se estas circunstâncias são estadas conformes:

Se estas circunstâncias não são todas encontradas, o BGP não instala uma entrada na tabela de BGP a menos que houver um exato - combina na tabela de IP Routing.

Passos de Troubleshooting

Com o auto-resumo habilitado em R101, o roteador não consegue anunciar a rede com classes 6.0.0.0/8 a R102.

bgp_noad_01.gif

  1. Verifique para ver se o R101 anuncia 6.0.0.0/8 ao R102. A saída mostrada confirma que o R101 não anuncia 6.0.0.0/8 ao R102.

    R101# 
    show ip bgp neighbors 10.10.10.2 advertised-routes
    
    R101#
  2. Verifique a configuração running. O exemplo mostrado ilustra que o R101 está configurado com instrução de rede classful. O resumo automático é permitido à revelia na versão de Cisco IOS Software usada para esta encenação.

    R101# 
    show running-config | begin bgp
    
    router bgp 1
     network 6.0.0.0
     neighbor 10.10.10.2 remote-as 2
    [...]
  3. Verifique para ver se você tem uma rota do componente (uma rota do total de classe ou uma rota de sub-rede) da rede 6.0.0.0/8 na tabela de roteamento.

    R101# 
    show ip route 6.0.0.0 255.0.0.0 longer-prefixes 
    
    R101#
  4. Porque não há nenhuma rota do componente (nenhuma rota ou rota de sub-rede do total de classe) na tabela de IP Routing R101, a rede 6.0.0.0 dentro não instalado na tabela de BGP. A exigência mínima para um prefixo configurado no comando de rede a ser instalado em uma tabela BGP é ter uma rota de componente na tabela de roteamento de IP. Certifique-se assim de que o R101 tem uma rota do componente para a rede 6.0.0.0/8 aprendendo a com o IGP ou com a configuração estática. No exemplo mostrado, a rota estática é configurada ao null0.

    R101(config)# ip route 6.6.10.0 255.255.255.0 null 0 200
    
  5. Assim que a tabela de IP Routing tiver uma rota do componente para 6.0.0.0/8, o BGP instala uma rede de classe completa na tabela de BGP.

    R101# show ip route 6.0.0.0  255.0.0.0 longer-prefixes 
    
    [..]
         6.0.0.0/24 is subnetted, 1 subnets
    S       6.6.10.0 is directly connected, Null0
    
    
  6. Para efetuar a alteração no BGP e começar a anunciar a rede 6.0.0.0/8 para o R102, você deve limpar o vizinho BGP ou realizar uma restauração suave no correspondente. Este exemplo mostra um soft reset de saída para espreitar 10.10.10.2 para trazer as mudanças no efeito. Para mais detalhes no soft reset, veja o gerenciamento da seção de alterações da política de roteamento em configurar o BGP.

    R101# clear ip bgp 10.10.10.2 [soft] out
    R101#
  7. Para efetuar a alteração no BGP e começar a anunciar a rede 6.0.0.0/8 para o R102, você deve limpar o vizinho BGP ou realizar uma restauração suave no correspondente. Este exemplo mostra um soft reset de saída para espreitar 10.10.10.2 para trazer as mudanças no efeito. Consulte a seção Gerenciando as alterações de política de roteamento em Configurando BGP para obter mais informações sobre restauração suave.

    R101# show ip bgp | include 6.0.0.0 
    *> 6.0.0.0 0.0.0.0 0 32768 i
    
  8. O comando show ip bgp confirma que a rede com classes 6.0.0.0/8 é introduzida no BGP.

    R101# show ip bgp | include 6.0.0.0 
    *> 6.0.0.0 0.0.0.0 0 32768 i
  9. Confirme que o R101 anuncia rotas ao R102.

    R101# show ip bgp neighbors 10.10.10.2 advertised-routes | include 6.0.0.0 
    *> 6.0.0.0 0.0.0.0 0 32768 i

    Nota: Com o resumo automático desabilitado, o BGP instala a rede 6.0.0.0/8 somente quando há uma rota de compatibilidade exata na tabela de roteamento. Se há as rotas de sub-rede mas a nenhuma rota de compatibilidade exata (6.0.0.0/8) na tabela de roteamento, a seguir o BGP não instala a rede 6.0.0.0/8 na tabela de BGP.

Rotas anunciadas utilizando a instrução de rede com uma máscara

As redes que caem em um limite de rede principal (255.0.0.0, 255.255.0.0, ou 255.255.255.0) não precisam de ter uma máscara incluída. Por exemplo, o comando de 172.16.0.0 da rede é suficiente para enviar o prefixo 172.16.0.0/16 na tabela de BGP. Contudo, as redes que não caem em limites de rede principais são exigidas para ter uma instrução de rede com uma máscara, tal como a máscara 255.255.255.0 de 172.16.10.0 da rede.

Uma rota exata na tabela de roteamento é exigida para uma instrução de rede com uma máscara para que seja instalada em uma tabela de BGP.

Passos de Troubleshooting

O R101 não pode anunciar a rede 172.16.10.0/24 para R102.

/image/gif/paws/19345/bgp_noad_02.gif

  1. Verifique para ver se o R101 anuncia o prefixo 172.16.10.0/24 ao R102.

    R101# show ip bgp neighbors 10.10.10.2 advertised-routes
    R101#

    OU

    Este comando pode ser usado para verificar se as rotas estejam sendo anunciadas:

    R101#show ip bgp 172.16.10.0/24
    R101# BGP routing table entry for 172.16.10.0/24, version 24480684
          Bestpath Modifiers: deterministic-med
          Paths: (4 available, best #3)
          Not advertised to any peer   <---- not advertised to any peers

    A saída acima confirma que R101 não está anunciando 192.168.32.0/22 para R102.

  2. Verifique a configuração running.

    R101# show run | begin bgp
    router bgp 1
      network 172.16.10.0

    Nota: Você quer originar a rede 172.10.10.0/24. Esta rede não cai no limite de uma rede de classe B (255.255.0.0). Uma instrução de rede com necessidades de 255.255.255.0 da máscara de ser configurado para fazê-la trabalhar.

  3. Depois que uma instrução de rede com máscara é configurada, o comando show run mostra a saída similar a esta:

    R101# show run | begin bgp
    router bgp 1
      network 172.16.10.0 mask 255.255.255.0
  4. Verifique para ver se a rota está na tabela de roteamento de BGP.

    R101# show ip bgp | include 172.16.10.0
    R101#

    A rede 172.16.10.0/24 não existe na tabela de BGP.

  5. Verifique para ver se há uma rota exata na tabela de IP Routing. A saída mostrada confirma que não há uma rota exata na tabela de roteamento.

    R101# show ip route 172.16.10.0 255.255.255.0   
    % Network not in table
    R101#
  6. Decida que rotas você quer originar. Então fixe o IGP ou configurar rotas estáticas.

    R101(config)# ip route 172.16.10.0 255.255.255.0 null 0 200
    
  7. Verifique a tabela de IP Routing.

    R101# show ip route 172.16.10.0 255.255.255.0 longer-prefixes 
    
    [..]
         172.16.0.0/24 is subnetted, 1 subnets
    S       172.16.10.0 is directly connected, Null0
  8. Certifique-se de que as rotas estejam localizadas na tabela de BGP.

    R101# show ip bgp | include 172.16.10.0 
    *> 172.16.10.0/24   0.0.0.0                  0         32768 i
  9. Para efetuar a alteração no BGP e começar a anunciar a rede 6.0.0.0/8 para o R102, você deve limpar o vizinho BGP ou realizar uma restauração suave no correspondente. Este exemplo usa um soft reset de saída para espreitar 10.10.10.2. Para mais detalhes em soft reset, veja o gerenciamento da seção de alterações da política de roteamento em configurar o BGP.

    R101# clear ip bgp 10.10.10.2 [soft] out
    
  10. Confirme que as rotas estão sendo anunciadas ao R102.

    R101# show ip bgp  neighbors 10.10.10.2 advertised-routes | include 172.16.10.0
    *> 172.16.10.0/24   0.0.0.0                  0         32768 i
    

Rotas anunciadas usando o comando aggregate-address

O BGP permite a agregação de rotas específicas em uma rota usando o comando aggregate-address address mask. A agregação aplica-se às rotas que existem na tabela de roteamento de BGP. Em contraste com o comando network, que se aplica às rotas existentes na tabela de roteamento de IP. A agregação pode ser executada se pelo menos umas ou várias das rotas específicas do endereço agregado existem na tabela de roteamento de BGP. Consulte Entendendo a agregação de rota em BGP para obter mais informações sobre agregação de BGP e atributos associados.

Passos de Troubleshooting

/image/gif/paws/19345/bgp_noad_03.gif

Neste diagrama da rede, o R101 é incapaz de anunciar o endereço agregado 192.168.32.0/22 ao R102. A rede 192.168.32.0/22 agrega estes espaços de endereços do C de três classes:

  • 192.168.33.0/24

  • 192.168.35.0/24

  • 192.168.35.0/24

  1. Confirme que o R101 não está anunciando 192.168.32.0/22 ao R102.

    R101# show ip bgp neighbors 10.10.10.2 advertised-routes | include 192.168.32.0 
    R101#
  2. Verifique a configuração running.

    router bgp 1
       [..]
       aggregate-address 192.168.32.0 255.255.252.0 summary-only
       neighbor 10.10.10.2 remote-as 2

    O R101 é configurado para anunciar somente o endereço agregado ao R102 usando o atributo “somente resumo”.

  3. Verifique a tabela de IP Routing.

    R101# show ip route 192.168.32.0 255.255.252.0 longer-prefixes 
    [..]
    S    192.168.33.0/24 is directly connected, Null0

    A tabela de IP Routing tem a rota do componente do agregado 192.168.32.0/22; porém para que um endereço agregado seja anunciado a um par, uma rota do componente deve existir na tabela de roteamento de BGP um pouco do que na tabela de IP Routing. A tabela de IP Routing tem a rota do componente do agregado 192.168.32.0/22; porém para que um endereço agregado seja anunciado a um par, uma rota do componente deve existir na tabela de roteamento de BGP um pouco do que na tabela de IP Routing.

  4. Verifique para ver se uma rota do componente existe na tabela de roteamento de BGP.

    R101# show ip bgp 192.168.32.0 255.255.252.0 longer
       R101#

    A saída confirma que a tabela de BGP não tem uma rota do componente, assim que o passo lógico seguinte é assegurar-se de que uma rota do componente exista na tabela de BGP.

  5. Neste exemplo, uma rota do componente 192.168.33.0 é instalada na tabela de BGP usando o comando network.

    R101(config)# router bgp 1
    R101(config-router)# network 192.168.33.0
    
  6. Verifique para ver se a rota do componente existe na tabela de BGP.

    R101# show ip bgp 192.168.32.0 255.255.252.0 longer-prefixes 
    BGP table version is 8, local router ID is 10.10.20.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 192.168.32.0/22  0.0.0.0                            32768 i
    s> 192.168.33.0     0.0.0.0                  0         32768 i
    R101#

    O “s” significa que a rota do componente é suprimido devido ao argumento “somente resumo”.

  7. Confirme que o agregado está anunciado ao R102.

    R101# show ip bgp n 10.10.10.2 advertised-routes | include 192.168.32.0/22
    *> 192.168.32.0/22  0.0.0.0

Impossível anunciar as rotas aprendidas iBGP

Um BGP Router com a sincronização permitida não anunciará rotas ensinada pelo iBGP a outros pares do eBGP se não pode validar aquelas rotas em seu IGP. Supondo que o IGP tem uma rota às rotas ensinada pelo iBGP, o roteador anunciará as rotas iBGP aos pares do eBGP. Se não o roteador trata a rota como não sendo sincronizado com o IGP e não a anuncia. A sincronização de desabilitação que usa o comando no synchronization sob o roteador BGP impede que o BGP valide rotas iBGP no IGP. Consulte a seção sobre sincronização dos estudos de caso de BGP para obter mais informações.

Passos de Troubleshooting

No diagrama mostrado, o R101 aprende o prefixo 130.130.130.0/24 do R103 com o iBGP e é incapaz de anunciá-lo ao par R102 do eBGP.

/image/gif/paws/19345/bgp_noad_04.gif

  1. Primeira verificação R101.

    R101# show ip bgp neighbors 10.10.20.2 advertised-routes | include 130.130.130.0
    R101#

    A saída acima confirma que o R101 não está anunciando o prefixo 130.130.130.0/24 ao R102. Olhe a tabela de BGP no R101:

    R101# show ip bgp 130.130.130 255.255.255.0 longer
    BGP table version is 4, local router ID is 10.10.20.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    * i130.130.130.0/24 10.10.20.3               0    100      0 i
    R101#

    A rede 130.130.130.0/24 existe na tabela de BGP. Contudo a rede 130.130.130.0/24 não tem o código de status da melhor ruta (>). Isto significa que o Algoritmo de Seleção de Melhor Caminho, BGP, não selecionou esse prefixo como o melhor trajeto. Como somente os melhores caminhos são anunciados para peers BGP, a rede 130.130.130.0/24 não é anunciada para R102. Em seguida, você precisa de pesquisar defeitos porque o critério de seleção de caminho do BGP não selecionou esta rede como a melhor ruta.

  2. Examine a saída do comando show ip bgp prefix dar-lhe mais detalhes em porque o prefixo não foi escolhido como a melhor ruta nem foi instalado na tabela de IP Routing.

    R101# show ip bgp 130.130.130.0
    BGP routing table entry for 130.130.130.0/24, version 4
    Paths: (1 available, no best path)
      Not advertised to any peer
      Local
        10.10.20.3 from 10.10.20.3 (130.130.130.3)
          Origin IGP, metric 0, localpref 100, valid, internal, not synchronized

    A saída mostra que o prefixo 130.130.130.0/24 não está sincronizado.

    Nota: Antes da identificação do erro CSCdr90728 (“os trajetos BGP não são marcados como não sincronizado”), o comando show ip bgp prefix não mostrou os trajetos marcados como não sincronizado. Este problema foi corrigido nos Cisco IOS Software Releases 12.1(4) e mais recente.

  3. Verifique a configuração de BGP running.

    R101# show ip protocols 
    Routing Protocol is "bgp 1"
      Outgoing update filter list for all interfaces is not set
      Incoming update filter list for all interfaces is not set
      IGP synchronization is enabled
      Automatic route summarization is disabled
      Neighbor(s):
        Address          FiltIn FiltOut DistIn DistOut Weight RouteMap
        10.10.10.2                                           
        10.10.20.3                                           
      Maximum path: 1
      Routing for Networks:
      Routing Information Sources:
        Gateway         Distance      Last Update
        10.10.20.3           200      01:48:24
      Distance: external 20 internal 200 local 200

    A saída acima mostra que a sincronização de BGP está permitida. A sincronização de BGP é permitida à revelia no Cisco IOS Software.

  4. Configurar o BGP para desabilitar a sincronização. Emita o comando no synchronization sob o roteador BGP.

    R101(config)# router bgp 1
    
    R101(config-router)# no synchronization 
    
    R101# show ip protocols 
    
    Routing Protocol is "bgp 1"
      Outgoing update filter list for all interfaces is not set
      Incoming update filter list for all interfaces is not set
      IGP synchronization is disabled
      Automatic route summarization is disabled
      Neighbor(s):
        Address          FiltIn FiltOut DistIn DistOut Weight RouteMap
        10.10.10.2                                           
        10.10.20.3                                           
      Maximum path: 1
      Routing for Networks:
      Routing Information Sources:
        Gateway         Distance      Last Update
        10.10.20.3           200      01:49:24
      Distance: external 20 internal 200 local 200

    Durante a corrida seguinte do scanner de BGP, que faz a varredura da tabela de BGP cada 60 segundos e faz a decisão baseada no critério de seleção de caminho do BGP, a rede 130.130.130.0 será instalada (desde que a sincronização é desabilitada). Isto significa que o tempo máximo para a rota ser instalada é 60 segundos, mas pode ser menos, dependendo de quando o comando no synchronization é configurado e de quando a próxima instância do scanner de BGP ocorre. Assim, é melhor esperar 60 segundos antes de iniciar a próxima etapa de verificação.

  5. Verifique que a rota esteve instalada.

    A saída mostrada confirma que o prefixo 130.130.130.0/24 é a melhor ruta; consequentemente, é instalada na tabela de IP Routing e propagada para espreitar 10.10.10.2.

    R101# show ip bgp 130.130.130.0
    BGP routing table entry for 130.130.130.0/24, version 5
    Paths: (1 available, best #1, table Default-IP-Routing-Table)
      Advertised to non peer-group peers:
      10.10.10.2 
      Local
        10.10.20.3 from 10.10.20.3 (130.130.130.3)
          Origin IGP, metric 0, localpref 100, valid, internal, best
    
    R101# show ip bgp neighbors 10.10.10.2 advertised-routes | include 130.130.130.0/24
    *>i130.130.130.0/24 10.10.20.3               0    100      0 i

As rotas anunciadas com redistribuem a estática

Se o Roteadores está conectado com os dois links, e as rotas são instruídas através do BGP e das Rotas estáticas flutuantes, as Rotas estáticas flutuantes estão instaladas na tabela de roteamento. Isto ocorre se as rotas estáticas são redistribuídas no caso da falha da rota de BGP. Se as rotas de BGP voltam em linha, as Rotas estáticas flutuantes na tabela de roteamento não estão mudadas para refletir as rotas de BGP.

Esta edição pode ser resolvida se você remove o comando redistribute static sob o processo BGP evitar a prioridade das Rotas estáticas flutuantes sobre rotas de BGP.


Informações Relacionadas


Document ID: 19345