Banda larga a cabo : Modems a cabo

Como configurar um roteador Cisco atrás de um Cable Modem de terceiros

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (21 Abril 2016) | Feedback


Índice


Introdução

Em determinados ambientes onde um modem a cabo (CM) de terceiros é utilizado, e o CM é capaz apenas de realizar o bridging, um roteador Cisco, como o Cisco 806, pode ser conectado a um CM através da interface Ethernet. O roteamento é executado então pelo roteador por trás do CM. O próximo passo é conectar o PC cliente ou o Equipamento Local do Cliente (Customer Premises Equipment - CPE) ao roteador. Após realizar esta conexão, a Tradução de Endereço de Rede (NAT) será configurada no roteador.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • 806 Series Router que executa a liberação 12.2(2)XI do ½ do ¿  de Cisco IOSïÂ

  • Roteador CM que atua como uma ponte

  • Windows 2000 running PC que atua como o CPE

  • cable modem termination system (CMTS) do uBR7246VXR

Nota: Somente as configurações do Cisco 806 Router são mostradas neste documento. Para obter mais informações sobre de configurar o CMTS, refira exemplos de configuração e Notas Técnica da tecnologia do cabo.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

http://www.cisco.com/c/dam/en/us/support/docs/broadband-cable/cable-modems/19268-router-behind-cm-19268.gif

Configurações

Este documento usa a configuração do 806 Router:

Configuração do 806 Router
Building configuration...
Current configuration : 1673 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
enable secret 5 $1$1m1W$uRyUMZQpUAp31C9OM2HQR.
!
username Router password 7 08325C5C00170247425D5506382E2523
username Cisco privilege 15 password 7
134146563C5D020B6F2B793C060703061E2A16706F7E62470C3416
ip subnet-zero
ip name-server 24.29.99.81
ip name-server 24.29.99.82
ip dhcp excluded-address 10.10.10.1 


!--- Issue the ip dhcp excluded-address command to exclude IP 
!--- addresses from being assigned by the DHCP server. This excludes 
!--- E0 IP address.

ip dhcp excluded-address 10.10.10.2
ip dhcp excluded-address 10.10.10.10
ip dhcp excluded-address 10.10.10.3
ip dhcp excluded-address 10.10.10.4
ip dhcp excluded-address 10.10.10.5
ip dhcp excluded-address 10.10.10.6
ip dhcp excluded-address 10.10.10.7
ip dhcp excluded-address 10.10.10.8
ip dhcp excluded-address 10.10.10.9
!
ip dhcp pool CLIENT 

!--- Configures a DHCP address pool.

import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 24.29.99.82
!
no ip dhcp-client network-discovery
lcp max-session-starts 0
!
!
!
interface Ethernet0 

!--- This interface connects to the internal network, including CPE.

ip address 10.10.10.1 255.255.255.0
ip nat inside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
interface Ethernet1 

!--- This interface connects to the same Ethernet segment as the CM.
 
ip address dhcp 

!--- This command allows the router to obtain IP address dynamically.

ip nat outside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
ip nat inside source list 102 interface Ethernet1 overload 

!--- IP NAT configuration.

ip classless
ip route 0.0.0.0 0.0.0.0 66.108.112.1

!--- IP address 66.108.112.1 is the next hop IP address, also called 
!--- the default gateway. Your Internet service provider (ISP) can tell you what IP address to 
!--- configure as the next hop address.

ip http server
!
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 30 0
login local
length 0
!
scheduler max-task-time 5000
end
Router#

                     

                      
                     

                     

Verificar

Para verificar que o roteador obteve um endereço IP de Um ou Mais Servidores Cisco ICM NT em seus Ethernet E1 dinamicamente, use o comando show ip interface brief.

Router#show ip interface brief

Interface                  IP-Address      OK? Method Status Protocol
Ethernet0                  10.10.10.1      YES NVRAM  up    up
Ethernet1                  66.108.115.5    YES DHCP   up    up

Assegure-se de que sua tabela de roteamento tenha as entradas corretas. Por exemplo, neste indicador, a rota padrão é a 66.108.112.1. Isto está instalado com o processo DHCP quando o roteador recebe o endereço IP de Um ou Mais Servidores Cisco ICM NT na interface Ethernet.

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 66.108.112.1 to network 0.0.0.0
66.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       66.0.0.0/8 is directly connected, Ethernet1
C       66.108.112.0/21 is directly connected, Ethernet1
10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 66.108.112.1

Troubleshooting

Quando o roteador é conectado atrás do CM, o primeiro problema que pôde ocorrer não está obtendo um endereço IP de Um ou Mais Servidores Cisco ICM NT dinamicamente na interface Ethernet do roteador. A maioria de ISP permitem somente um host ou PC atrás do CM. Alguns ISP atribuem um endereço IP de Um ou Mais Servidores Cisco ICM NT ao PC baseado no nome de host. Consequentemente, se você tem um roteador atrás do CM, a seguir o nome de host para o roteador configurado usando o comando hostname deve ser o mesmo nome de host dado pelo ISP.

Se o roteador não está obtendo um endereço IP de Um ou Mais Servidores Cisco ICM NT dinamicamente, a primeira coisa a verificar é se o DHCP do endereço IP de Um ou Mais Servidores Cisco ICM NT do comando interface configuration existe. Este comando está sob a interface Ethernet conectada ao CM. O comando foi introduzido na IOS Software release 12.1(2)T.

Se o comando ip address dhcp existe, mas o roteador atrás do CM ainda não está obtendo um endereço IP de Um ou Mais Servidores Cisco ICM NT, conecte um PC atrás do CM para detectar se está recebendo um endereço IP de Um ou Mais Servidores Cisco ICM NT. Isto verifica que os serviços DHCP estão funcionando corretamente. Os ISP permitem tipicamente somente um host atrás do CM, consequentemente conectando um PC atrás das contagens CM como o primeiro host. Esta entrada permanece no base de dados de ISP por 24 horas. Consequentemente, se você conecta o roteador atrás do CM, o ISP pensa que o roteador é um segundo host e rejeita-o. Se isto ocorre, libere o endereço IP de Um ou Mais Servidores Cisco ICM NT de seu PC terminando estas etapas em seu Windows 2000 PC:

  1. Desde o início o menu escolhe a corrida.

  2. Datilografe o Cmd a seguir pressione a tecla semelhante a tecla ENTER.

  3. Na alerta, datilografe o ipconfig /release.

  4. Após ter liberado o endereço IP de Um ou Mais Servidores Cisco ICM NT do PC, recarregue seu CM e tente-o outra vez.

Se isto não trabalha, você precisa de chamar seu ISP e de pedi-los para cancelar a primeira entrada de host em seu CMTS.

Um outro método é configurar a interface Ethernet do roteador. Isto conecta ao CM com o MAC address do PC usando o comando mac-address ieee-address.

Usando o mesmo MAC address na interface Ethernet que conecta ao CM como o PC, o ISP aprende somente aproximadamente um host e um endereço IP de Um ou Mais Servidores Cisco ICM NT. O PC não obtém rejeitado conectado uma vez atrás do roteador. O NAT tem que ser configurado no roteador para aceitar traduções do endereço IP de Um ou Mais Servidores Cisco ICM NT.

Comandos para Troubleshooting

A Output Interpreter Tool (apenas para clientes registrados) (OIT) suporta determinados comandos show. Use a OIT para exibir uma análise da saída do comando show.

Nota: Consulte Informações Importantes sobre Comandos de Depuração antes de usar comandos debug.

  • debugar o detalhe DHCP — Use o comando debug dhcp detail indicar a informação sobre debugging DHCP. Isto é usado para pesquisar defeitos porque o roteador Cisco não obteve um endereço IP de Um ou Mais Servidores Cisco ICM NT para a interface Ethernet.

  • debugar o [packet] do [linkage] do [events] do ip dhcp server — Use o comando debug ip dhcp server indicar a eliminação de erros do servidor DHCP. Isto ajuda a determinar porque o PC, que é conectado ao roteador, não obteve um endereço IP de Um ou Mais Servidores Cisco ICM NT.


Informações Relacionadas


Document ID: 19268