Switches : Roteadores/Switches de múltiplos serviços Cisco Catalyst 8500 Series

Configurando IP Multicast Routing sobre ARM (Módulo de rota ATM) em um Cisco Catalyst 8540 MSR

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Enquanto as redes aumentam em tamanho, o roteamento IP Multicast torna-se criticamente importante como meios determinar que segmentos exigem o tráfego multicast e quais não fazem. O Protocolo IP multicast é uma técnica do roteamento que permita que o tráfego IP seja propagado de uma fonte a um número de destinos, ou de muitas fontes a muitos destinos. Um pouco do que enviando um pacote a cada destino, um pacote é enviado ao grupo de transmissão múltipla identificado por um único endereço de grupo do destino IP.

Este documento mostra como configurar IP Multicast Routing por um ATM Router Module (ARM) em um Catalyst 8540 MSR. Esta configuração é suportada em ARM e ARM aprimorado (conhecido como ARM I e ARM II, respectivamente).

Pré-requisitos

Requisitos

Os leitores deste documento devem estar conscientes sobre as configurações básicas de multicast de IP em Cisco routers. Para a informações de fundo, refira estes documentos:

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Cisco 3600, 7200, e 7500 Series Router que executam o software release do � do Cisco IOS 12.1.(7)

  • Catalyst 8540MSR e Catalyst 8510MSR que executam o Cisco IOS Software Release 12.1(7)EY

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a configuração de rede mostrada neste diagrama:

/image/gif/paws/19244/arm-mul.gif

O Cisco 3640 Router, conhecido como o C3640, é conectado ao Cisco catalyst 8540 MSR (conhecido como 8540MSR) através da porta de Ethernet rápida 3/0/1. O 8540MSR tem um BRAÇO no SLOT 11. O C8540MSR é conectado fisicamente ao 8510MSR usando a relação atm 9/1/0. O switch ATM 8510MSR conecta ao 8540MSR na interface ATM 1/0/2.

Há dois circuitos permanentes (PVC) construídos com o 8510MSR. Um é a partir da subinterface multiponto ARM 8540MSR até o roteador C7513, e o outro é a partir da mesma subinterface multiponto ARM 8540MSR até o roteador C7204. O Routing Protocol usado é Open Shortest Route First (OSPF). O modo denso da transmissão múltipla independente de protocolo IP (PIM) é configurado no Roteadores. Isto inclui o módulo do BRAÇO em 8540MSR. O C3640, o C7513, e o C7204 têm uma relação configurada para juntar-se ao grupo de transmissão múltipla 239.0.10.1. Um sibilo do C3640 ao endereço de multicast 239.0.10.1 obtém respostas do C3640, do C7513, e do C7204.

Configurações

Esta seção contém as parcelas da configuração no Roteadores e no Switches descritos no diagrama da rede. Estas são algumas informações específicas sobre a configuração:

  • A configuração que aparece neste encapsulamento aal5mux dos usos do documento.

  • Uma subinterface de multiponto está criada no BRAÇO, quando o ATM PVCs for configurado aos locais remotos.

  • O PIM é usado no modo denso. Tanto quanto o PIM, o BRAÇO não se diferencia entre VC individuais na interface multiponto.

  • O tráfego multicast é enviado para fora a todos os VC que têm a “transmissão” configurada.

  • O exemplo do comando show ip mroute demonstra que o PIM identifica apenas a interface de saída e não VCs individuais.

A configuração para o roteamento IP Multicast com a ajuda do PIM é mostrada aqui. Todos os comandos relevant para o roteamento IP Multicast são mostrados em corajoso.

C3640
ip multicast-routing
!
interface Ethernet1/0
 ip address 10.10.200.1 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 239.0.10.1
 half-duplex
!
!
router ospf 1
 log-adjacency-changes
 network 10.10.200.0 0.0.0.255 area 0
!

C8540MSR
ip multicast-routing
!
interface FastEthernet3/0/1
 ip address 10.10.200.2 255.255.255.0
 ip pim dense-mode
 no ip route-cache
 no ip mroute-cache
!
!
interface ATM11/0/0.1 multipoint
 ip address 75.75.75.2 255.255.255.0
 ip pim dense-mode
 ip ospf network point-to-multipoint
 map-group multicast
 atm pvc 2 1000 pd on  encap aal5mux ip interface  ATM9/1/0 0 1000 
 atm pvc 2 1001 pd on  encap aal5mux ip interface  ATM9/1/0 0 1001 
!
!
router ospf 1
 log-adjacency-changes
 network 10.10.200.0 0.0.0.255 area 0
 network 75.75.75.0 0.0.0.255 area 0
!
map-list multicast
 ip 75.75.75.1 atm-vc 1000 aal5mux broadcast
 ip 75.75.75.3 atm-vc 1001 aal5mux broadcast

8510MSR
interface ATM1/0/2
 no ip address
 atm pvc 0 1000  interface  ATM1/0/1 0 1000 
!         
interface ATM1/0/3
 no ip address
 atm pvc 0 1001  interface  ATM1/0/2 0 1001 
! 

C7513
ip multicast-routing
!
!         
interface Ethernet9/0/2
 ip address 30.30.30.1 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 239.0.10.1
!
interface ATM1/0/0.1 multipoint
 ip address 75.75.75.1 255.255.255.0
 ip pim dense-mode
 no ip route-cache
 ip ospf network point-to-multipoint
 no ip mroute-cache
 map-group multicast
 atm pvc 1000 0 1000 aal5mux ip
!
!
router ospf 1
 log-adjacency-changes
 network 30.30.30.0 0.0.0.255 area 0
 network 75.75.75.0 0.0.0.255 area 0
!
map-list multicast
 ip 75.75.75.2 atm-vc 1000 broadcast
!

C7204
ip multicast-routing
!
interface Loopback0
 ip address 40.40.40.1 255.255.255.0
 ip igmp join-group 239.0.10.1
!
!
interface ATM4/0.5 multipoint
 ip address 75.75.75.3 255.255.255.0
 ip pim dense-mode
 no ip route-cache
 ip ospf network point-to-multipoint
 no ip mroute-cache
 map-group multicast
 atm pvc 1 0 1001 aal5mux ip
!
router ospf 1
 log-adjacency-changes
 network 40.40.40.0 0.0.0.255 area 0
 network 75.75.75.0 0.0.0.255 area 0
!
map-list multicast
 ip 75.75.75.2 atm-vc 1 broadcast

Verificar

Use esses comandos para testar se a rede funciona adequadamente:

Determinados comandos show são suportados pela ferramenta Output Interpreter (clientes registrados somente). Isso permite que você veja uma análise da saída do comando show.

  • show ip route - Exibe entradas de tabela de IP Routing.

  • mostre o vizinho do pim IP — Alista os vizinhos de PIM descobertos pelo software de Cisco IOS�.

  • mostre o mrouter IP — Indica os índices da tabela de roteamento IP Multicast.

  • mostre grupos de IGMP IP — Indica os grupos de transmissão múltipla que são conectados diretamente ao roteador e que são instruídos com o IGMP.

Essa saída é o resultado da inserção desses comandos show nos dispositivos mostrados no diagrama de rede. Esta saída mostra que a rede está funcionando adequadamente.

C3640

O comando show ip route é usado no C3640 para verificar se esse roteador atinge todos os endereços IP de rede. Tem uma rota a 75.75.75.1, 75.75.75.2, 75.75.75.3. As interfaces de loopback são definidas. Todas as rotas são encontradas com o OSPF.

C3640#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set
     40.0.0.0/32 is subnetted, 1 subnets
O       40.40.40.1 [110/12] via 10.10.200.2, 00:01:48, Ethernet1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.200.0 is directly connected, Ethernet1/0
     75.0.0.0/32 is subnetted, 3 subnets
O       75.75.75.3 [110/11] via 10.10.200.2, 00:01:48, Ethernet1/0
O       75.75.75.2 [110/10] via 10.10.200.2, 00:01:48, Ethernet1/0
O       75.75.75.1 [110/11] via 10.10.200.2, 00:01:48, Ethernet1/0
     30.0.0.0/24 is subnetted, 1 subnets
O       30.30.30.0 [110/21] via 10.10.200.2, 00:01:49, Ethernet1/0

Esse comando é usado para identificar vizinhos PIM IP. O vizinho é neste caso o C8540MSR.

C3640#show ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface          Uptime/Expires    Ver   DR
Address                                                      Priority/Mode
10.10.200.2       Ethernet1/0        3d03h/00:01:16    v2    N / DR

Se o grupo de transmissão múltipla é sibilado do C3640, é bem sucedido. Indica que o C3640 se comunica com o grupo de multicast definido pelo endereço IP 239.0.10.1.

C3640#ping 239.0.10.1  

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.0.10.1, timeout is 2 seconds:
Reply to request 0 from 10.10.200.1, 4 ms
Reply to request 0 from 75.75.75.3, 4 ms
Reply to request 0 from 75.75.75.1, 4 ms

O comando show ip mroute indica a informação sobre a tabela de roteamento de transmissão múltipla. Neste exemplo há uma rota nula para 239.0.10.1 e 224.0.1.40. O último endereço de multicast é o endereço designado pela IANA (Autoridade responsável pela atribuição de números na Internet) para o comando cisco-rp-discovery.

C3640#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Advertised via MSDP, U - URD,
       I - Received Source Specific Host Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 2d23h/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet1/0, Forward/Dense, 2d23h/00:00:00

(*, 239.0.10.1), 1w1d/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet1/0, Forward/Dense, 2d23h/00:00:00
(10.10.200.1, 239.0.10.1), 00:02:37/00:00:22, flags: PCLTA
  Incoming interface: Ethernet1/0, RPF nbr 0.0.0.0
  Outgoing interface list: Null

Verifique os grupos de IGMP IP com a ajuda do comando show ip igmp groups. O endereço IP multicast da descoberta de cisco-rp e o grupo de transmissão múltipla do igmp a que o C3640 se junta são descobertos.

C3640#show ip igmp groups 
IGMP Connected Group Membership
Group Address    Interface            Uptime    Expires   Last Reporter
224.0.1.40       Ethernet1/0          3d00h     00:02:38  10.10.200.2
239.0.10.1       Ethernet1/0          1w1d      00:02:44  10.10.200.1

C8540MSR

Os mesmos comandos show são usados no Switch C8540MSR Catalyst e no C3460. O comando show ip route mostra que o C8540MR alcança todas as sub-redes da rede.

C8540MSR#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.118.1.21 to network 0.0.0.0
     40.0.0.0/32 is subnetted, 1 subnets
O       40.40.40.1 [110/2] via 75.75.75.3, 01:25:34, ATM11/0/0.1
     10.0.0.0/24 is subnetted, 2 subnets
C       10.118.1.0 is directly connected, Ethernet0
C       10.10.200.0 is directly connected, FastEthernet3/0/1
     75.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       75.75.75.3/32 [110/1] via 75.75.75.3, 01:25:34, ATM11/0/0.1
O       75.75.75.1/32 [110/1] via 75.75.75.1, 01:25:34, ATM11/0/0.1
C       75.75.75.0/24 is directly connected, ATM11/0/0.1
     30.0.0.0/24 is subnetted, 1 subnets
O       30.30.30.0 [110/11] via 75.75.75.1, 01:25:35, ATM11/0/0.1
S*   0.0.0.0/0 [1/0] via 10.118.1.21

O comando show ip pim neighbor exibe os vizinhos de multicast. No caso do C8540MSR, os vizinhos de PIM IP são C3640 (10.10.200.1), C7513 (75.75.75.1), e C7204 (75.75.75.3).

C8540MSR#show ip pim neighbor 
PIM Neighbor Table
Neighbor Address  Interface                Uptime    Expires   Ver  Mode
10.10.200.1       FastEthernet3/0/1        3d02h     00:01:25  v2   
75.75.75.3        ATM11/0/0.1              00:12:11  00:01:33  v2    (DR)
75.75.75.1        ATM11/0/0.1              00:18:43  00:01:32  v2

O comando show ip mroute oferece informações sobre a tabela de Multicast Routing. Este exemplo mostra que há uma rota nula para 239.0.10.1 e 224.0.1.40. O último endereço multicast é aquele designado pelo IANA para cisco-rp-discovery.

C8540MSR#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, s - SSM Group, C - Connected, L - Local,
       P - Pruned, R - RP-bit set, F - Register flag, T - SPT-bit set,
       J - Join SPT, M - MSDP created entry, X - Proxy Join Timer Running
       A - Advertised via MSDP, U - URD, I - Received Source Specific Host
           Report 
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 3d03h/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM11/0/0.1, Forward/Dense, 01:33:56/00:00:00
    FastEthernet3/0/1, Forward/Dense, 3d03h/00:00:00

(*, 239.0.10.1), 3d03h/00:02:59, RP 0.0.0.0, flags: DJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM11/0/0.1, Forward/Dense, 01:33:56/00:00:00
    FastEthernet3/0/1, Forward/Dense, 3d03h/00:00:00

(10.10.200.1, 239.0.10.1), 00:00:17/00:02:49, flags: CT
  Incoming interface: FastEthernet3/0/1, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM11/0/0.1, Forward/Dense, 00:00:19/00:00:00

C7513

A descrição e as explicações para os comandos show aqui são as mesmas que as fornecidas para C3640 e C8540MSR .

C7513#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.118.1.21 to network 0.0.0.0
     40.0.0.0/32 is subnetted, 1 subnets
O       40.40.40.1 [110/3] via 75.75.75.2, 02:05:04, ATM1/0/0.1
     10.0.0.0/24 is subnetted, 2 subnets
C       10.118.1.0 is directly connected, Ethernet9/0/1
O       10.10.200.0 [110/2] via 75.75.75.2, 02:05:04, ATM1/0/0.1
     11.0.0.0/24 is subnetted, 2 subnets
C       11.12.12.0 is directly connected, Serial0/0/0/2:2
C       11.11.11.0 is directly connected, Serial0/0/0/1:1
     75.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       75.75.75.3/32 [110/2] via 75.75.75.2, 02:05:05, ATM1/0/0.1
O       75.75.75.2/32 [110/1] via 75.75.75.2, 02:05:05, ATM1/0/0.1
C       75.75.75.0/24 is directly connected, ATM1/0/0.1
     30.0.0.0/24 is subnetted, 1 subnets
C       30.30.30.0 is directly connected, Ethernet9/0/2
S*   0.0.0.0/0 [1/0] via 10.118.1.21
C7513#show ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
75.75.75.2        ATM1/0/0.1               04:28:34/00:01:18 v2    N / DR
C7513#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 22:03:58/00:00:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet9/0/2, Forward/Dense, 22:03:58/00:00:00
    ATM1/0/0.1, Forward/Dense, 04:28:37/00:00:00

(*, 239.0.10.1), 22:03:58/00:00:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet9/0/2, Forward/Dense, 22:03:58/00:00:00
    ATM1/0/0.1, Forward/Dense, 04:28:37/00:00:00

(10.10.200.1, 239.0.10.1), 00:00:51/00:02:08, flags: CLT
  Incoming interface: ATM1/0/0.1, RPF nbr 75.75.75.2
  Outgoing interface list:
    Ethernet9/0/2, Forward/Dense, 00:00:52/00:00:00
C7513#show ip igmp groups 
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter
224.0.1.40       Ethernet9/0/2        22:04:09  00:02:50  30.30.30.1
239.0.10.1       Ethernet9/0/2        22:04:15  00:02:50  30.30.30.1

C7204

A descrição e as explicações para os comandos show aqui são as mesmas que as fornecidas para C3640 e C8540MSR .

C7204#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.118.1.21 to network 0.0.0.0
     40.0.0.0/24 is subnetted, 1 subnets
C       40.40.40.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.118.1.0 is directly connected, FastEthernet0/0
O       10.10.200.0 [110/2] via 75.75.75.2, 03:31:48, ATM4/0.5
     75.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       75.75.75.2/32 [110/1] via 75.75.75.2, 03:31:48, ATM4/0.5
O       75.75.75.1/32 [110/2] via 75.75.75.2, 03:31:48, ATM4/0.5
C       75.75.75.0/24 is directly connected, ATM4/0.5
     30.0.0.0/24 is subnetted, 1 subnets
O       30.30.30.0 [110/12] via 75.75.75.2, 03:31:49, ATM4/0.5
S*   0.0.0.0/0 [1/0] via 10.118.1.21
C7204#show ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
75.75.75.2        ATM4/0.5                 03:32:29/00:01:23 v2    N /
C7204#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 05:20:47/00:00:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM4/0.5, Forward/Dense, 03:57:26/00:00:00

(*, 239.0.10.1), 03:31:41/00:00:00, RP 0.0.0.0, flags: DL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM4/0.5, Forward/Dense, 03:31:41/00:00:00
7204#show ip igmp groups 
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter
224.0.1.40       ATM4/0.5               05:20:53  00:02:24  75.75.75.3
239.0.10.1       Loopback0              23:33:52  stopped   40.40.40.1

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 19244