Voz : CCS Digital

Configurando e Troubleshooting de Transparent CCS

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento descreve como configurar e pesquisar defeitos o Transparent Common Channel Signaling (T-CCS).

Pré-requisitos

Requisitos

Os leitores deste documento devem estar cientes destes tópicos:

  • Como configurar o software do � do Cisco IOS para a funcionalidade de voz.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Software Cisco IOS, Versão 12.2.7a.

  • O Roteador Cisco 3640.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

O T-CCS permite a conexão de dois PBXs com interfaces digitais que usam um protocolo CCS proprietário ou não suportado sem a necessidade de interpretação do sinal de CCS para o processamento da chamada.

Com T-CCS, os canais de voz PBX podem ser pregados acima de (feito permanent), e ser comprimidos entre locais. O canal de sinalização ou os canais de acompanhamento podem ser escavados um túnel (transmitido transparentemente) através do backbone IP/FR/ATM entre PBX. Assim, os atendimentos dos PBX não são distribuídos por Cisco em uma base do call-by-call, mas seguem uma rota preconfigured ao destino.

Existem três maneiras configuráveis de aplicar o recurso:

  • T-CCS de encaminhamento de quadro

  • T-CCS de canal limpo

  • Cruz-conecte o T-CCS

T-CCS de conexão cruzada é possível apenas no Cisco 3810 e não é discutida neste documento.

Matriz de compatibilidade T-CCS

Esta tabela mostra as características T-CCS que podem ser configuradas em várias Plataformas.

VoX1 Cisco 3810 Cisco 26xx/36xx/72xx
VoIP2 Clear-Channel:
  • Algum tipo de sinalização CCS.
  • Qualquer número de canais de sinalização.
Clear-Channel:
  • Algum tipo de sinalização CCS.
  • Qualquer número de canais de sinalização.
VoFR3 Clear-Channel:
  • Algum tipo de sinalização CCS.
  • Qualquer número de canais de sinalização.
Encaminhamento de quadro:
  • Sinalização enquadrada por HDLC 4
  • Somente 1 canal de sinalização: E1.
  • E1 = TS16.
  • T1= TS 24.
TDM5 Cross-Connect:
  • Algum tipo de sinalização CCS.
  • Qualquer número de canais de sinalização.
Clear-Channel:
  • Algum tipo de sinalização CCS.
  • Qualquer número de canais de sinalização.
Encaminhamento de quadro:
  • Sinalização de HDLC emoldurado.
  • Canais de sinalização = Grupos de canal configuráveis por controlador.
VoATM6 Clear-Channel:
  • Algum tipo de sinalização CCS.
  • Qualquer número de canais de sinalização.
Encaminhamento de quadro:
  • Sinalização de HDLC emoldurado.
  • Somente 1 canal de sinalização.
Clear-Channel:
  • Algum tipo de sinalização CCS.
  • Qualquer número de canais de sinalização.
Encaminhamento de quadro:
  • Sinalização de HDLC emoldurado.
  • Canais de sinalização = Grupos de canal configuráveis por controlador.

1. VoX = Voz sobre X

2. VoIP = Voz sobre o IP

3. VoFR = Voz sobre o Frame Relay

4. HDLC = High-Level Data Link Control

5. TDM = multiplexação de divisão de tempo

6. VoATM = Voice over ATM

T-CCS de encaminhamento de quadro

O Frame-Forwarding T-CCS pode somente ser usado para apoiar os protocolos de proprietário PBX onde o canal de sinalização ou os canais são HDLC-Framed, e a tecnologia VoX desejada é VoFR ou VoATM. Nesta solução, os quadros de sinalização HDLC são encapsulados e enviados através de um grupo de canais que seja configurado para a sinalização no controlador, e tratados assim como uma interface serial. O enquadramento hdlc é interpretado e compreendido, embora os mensagens de sinalização não sejam. Os quadros ociosos são suprimidos e somente os dados reais são propagados pelo canal de sinalização.

Frame-Forwarding T-CCS do implementar

Advertência: Limitação CSCdt55871

Existe um limite atual para o número de canais de voz utilizáveis quando se configuram os TCCs de encaminhamento de quadros no E1. A limitação ocorre devido a um conflito entre ds0-group e faixas de número do channnel-grupo, como é explicado em CSCdt55871 (clientes registrados somente).

Tentar configurar um grupo ds0 que seja +1 previamente do grupo de canal de entrada conduz à falha, como mostrado abaixo.

!
 controller t1 2/1 
 channel-group 0 timeslot 24 speed 64 
 ds0-group 1 timeslots 1 type ext-sig

A configuração acima conduz a um Mensagem de Erro quando o grupo ds0 é definido, reivindicando que o canal 0 está usado já, como mostrado aqui:

%Channel 0 already used by other group

A ação alternativa é faltar o grupo de oposição, e continua com o número do grupo seguinte na escala. Isto reduz o número de grupos configuráveis por um.

Esteja ciente destes pontos antes de executar o Frame-Forwarding T-CCS:

  • O Frame-Forwarding T-CCS deve somente ser configurado quando o protocolo CCS a ser transportado usa um tipo HDLC de moldação.

  • O comando mode ccs-frame-forwarding define o encaminhamento de quadros do CCS.

  • O DSO-grupo e os comandos ext sig determinam que portas de voz devem ser criada e usada para o tronco com sinalização do origem externa.

  • O comando connection trunk estabelece os canais de voz permanentes.

  • O comando channel-group define o intervalo de tempo ou os intervalos de tempo do encaminhamento de frame.

  • O Frame-Forwarding T-CCS não é apoiado para VoIP.

  • O TS16 no E1 é reservado sempre para a sinalização associada a canal (CAS). Se você configura um outro intervalo de tempo para CAS (como no exemplo acima), você tem então um menos intervalo de tempo para a Voz.

Um exemplo de configuração para Frame-Forwarding VoFR T-CCS

A configuração e os testes relatados nesta seção foram executados em um Cisco IOS Software Release 12.2.7a running do Cisco 3640 Router. O exemplo mostrado aqui representa uma situação quando a sinalização não é aplicada no timeslot normal (slot 16). Um outro intervalo de tempo é usado aqui (entalhe 6) para mostrar a versatilidade da característica (não aplicável no Cisco 3810 Router).

/image/gif/paws/19087/trans_channel_signal1.gif

Etapas de configuração para o Lado da voz

Para configurar o lado de voz, termine estas etapas:

  1. No controlador T1 ou E1:

    1. Adicionar o comando mode ccs frame-forwarding.

    2. Defina o canal-grupo para cada canal de sinalização (para o Cisco e Series somente; o roteador Cisco 3810 cria automaticamente o canal D).

    3. Defina os grupos ds0 para cada canal de voz, usando type ext-sig.

      GTP1
      controller E1 3/0
       mode ccs frame-forwarding
       channel-group 0 timeslots 6
       ds0-group 2 timeslots 2 type ext-sig
       ds0-group 3 timeslots 3 type ext-sig
      .
       ds0-group 30 timeslots 30 type ext-sig

      GTP2
      controller E1 3/0
       mode ccs frame-forwarding
       channel-group 0 timeslots 6
       ds0-group 2 timeslots 2 type ext-sig
       ds0-group 3 timeslots 3 type ext-sig
      .
       ds0-group 30 timeslots 30 type ext-sig

  2. Na interface do canal D (essa interface serial é criada após a configuração do comando de grupo de canal acima):

    1. Adicione o comando ccs encap frf11.

    2. Aponte o canal D a um ID de canal na interface WAN FR usando o comando ccs connect Serial x/y DLCI CID.

      Nota: Deve ser usada uma ID separada de canal para cada canal D, caso seja necessário mais de um canal de sinalização. Comece com ID de canal 254, e trabalhe para trás.

      GTP1
      interface Serial3/0:0
       no ip address
       ccs encap frf11
       ccs connect Serial0/0 105 254

      GTP2
      interface Serial3/0:0
       no ip address
       ccs encap frf11
       ccs connect Serial0/0 105 254

  3. Nas portas de voz:

    Adicione o tronco de conexão xxx a cada porta de voz. O número deve corresponder ao padrão de destino da porta de voz de terminação (correspondente de discagem POTS) no outro lado. Somente um lado da conexão deve especificar o “modo de resposta.”

    GTP1
    !
    voice-port 3/0:2
     timeouts wait-release 3
     connection trunk 6002
    !
    voice-port 3/0:3
     timeouts wait-release 3
     connection trunk 6003
    !
    ... [channels 4-30 the same] ...
    !
    voice-port 3/0:30
     timeouts wait-release 3
     connection trunk 6030
    !

    GTP2
    voice-port 3/0:2
     timeouts wait-release 3
     connection trunk 8002 answer-mode
    !
    voice-port 3/0:3
     timeouts wait-release 3
     connection trunk 8003 answer-mode
    !
    ... [channels 4-30 the same] ...
    !
    voice-port 3/0:30
     timeouts wait-release 3
     connection trunk 8030 answer-mode

  4. Nos POTS dial peer:

    1. Adicionar um dial peer VOFR que combine o número discado do tronco de conexão, e aponte-o ao identificador da conexão de Data-Link do Frame Relay (DLCI).

    2. Adicione um correspondente de discagem POTS a cada porta de voz que corresponda ao número discado pelas instruções do tronco de conexão xxx a partir do outro lado.

      GTP1
      !
      dial-peer voice 8002 pots
       destination-pattern 8002
       port 3/0:2
      !
      dial-peer voice 8003 pots
       destination-pattern 8003
       port 3/0:3
      ! 
      ... [channels 4-30 the same] ...
      
      dial-peer voice 6000 vofr
       destination-pattern 6...
       session target Serial0/0 105
      !

      GTP2
      !
      dial-peer voice 6002 pots
       destination-pattern 6002
       port 3/0:2
      !
      dial-peer voice 6003 pots
       destination-pattern 6003
       port 3/0:3
      
      ... [channels 4-30 the same] ... 
      !
       dial-peer voice 8000 vofr
       destination-pattern 8...
       session target Serial1/0 105
      !

Etapas de configuração para o lado de WAN

Para configurar o lado WAN, termine estas etapas:

  1. Defina uma interface serial do Frame Relay, e uma subinterface ponto a ponto com VoFR normal.

  2. Põe na Voz-largura de banda baseada no número de canais e dos codecs usados para a Voz.

  3. Permita a largura de banda adicional na taxa de informação comprometida (CIR) para o canal de sinalização e outros dados que compartilham deste DLCI.

    GTP1
    interface Serial0/0
     no ip address
     encapsulation frame-relay
     frame-relay traffic-shaping
    !
    interface Serial0/0.1 point-to-point
     ip address 10.10.105.2 255.255.255.0
     frame-relay class voice-class
     frame-relay interface-dlci 105   
      vofr cisco
    !
    map-class frame-relay voice-class
     no frame-relay adaptive-shaping
     frame-relay cir 512000
     frame-relay bc 5120
     frame-relay be 0
     frame-relay fair-queue
     frame-relay voice bandwidth 512000
     frame-relay fragment 640
    !

    GTP2
    !
    interface Serial1/0
     no ip address
     encapsulation frame-relay
     clock rate 768000
     frame-relay traffic-shaping
     frame-relay intf-type dce
    !
    interface Serial1/0.1 point-to-point
     ip address 10.10.105.1 255.255.255.0
     frame-relay class voice-class
     frame-relay interface-dlci 105   
      vofr cisco
    !
    !
    map-class frame-relay voice-class
     no frame-relay adaptive-shaping
     frame-relay cir 512000
     frame-relay BC 5120
     frame-relay be 0
     frame-relay fair-queue
     frame-relay voice bandwidth 512000
     frame-relay fragment 640
    !

Largura de banda

A largura de banda fornecida no backbone deve permitir toda a voz configurada e canais de sinalização. Como essas configurações utilizam tronco de conexão, todos os canais de voz e sinalização resultantes ficam ativados todo o tempo. A detecção de ativação da Voz (VAD) fornece economias nos canais da voz ativa (embora não na sinalização), mas VAD não se torna ativa até que os canais de voz estejam estabelecidos. Assim, a largura de banda inicial necessária por canal de voz deve levar em consideração o codec utilizado, mais o overhead do cabeçalho. Para VoFR, somente a largura de banda dos canais de voz deve ser esclarecida nos comandos voice bandwidth e LLQ. A largura de banda da Voz e os canais de sinalização devem ser esclarecidos na relação de FR-à-WAN.

Pesquise defeitos e verifique o Frame-Forwarding T-CCS

As etapas a seguir ajudam a verificar se o T-CSS de encaminhamento de quadros está operando como deveria.

  1. O controlador E1 deve estar ativo para as portas de voz saírem do gancho e serem entroncadas.

  2. Verifique se o atendimento esteja no lugar, e se os processadores do sinal digital corretos (DSP) estão atribuídos em intervalos de tempo.

  3. Se os atendimentos não conectam, verifique a configuração de status ou a Conectividade dos Circuitos Virtuais Permanentes (PVC), e provisão de dial peer.

  4. Se as mostras do comando show voice port “rodam em marcha lenta” e “no gancho” para algum intervalo de tempo, verifique se o intervalo de tempo relacionado tenha a versão de DSP correta atribuída, e está trabalhando corretamente com o comando show voice dsp.

  5. Debugar com o comando debug TCCS signaling no modo colocado em buffer de registo (esta é muito utilização de CPU).

    gtp2#show controllers e1 3/0
    E1 3/0 is up. 
      Applique type is Channelized E1 - balanced
      No alarms detected.
      alarm-trigger is not set
      Version info Firmware: 20011015, FPGA: 15
      Framing is CRC4, Line Code is HDB3, Clock Source is Line.
      Data in current interval (276 seconds elapsed):
         0 Line Code Violations, 0 Path Code Violations
         0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
         0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
    
    gtp2#show voice dsp
     
    DSP  DSP            DSPWARE CURR  BOOT         VOICE       PAK     TX/RX
    TYPE NUM CH CODEC   VERSION STATE STATE RST AI PORT   TS ABORT  PACK COUNT
    ==== === == ======= ======= ===== ===== === == ====== == ===== ============
    C549 000 01 g729ar8  3.4.49 busy  idle       0 3/0:18 18     0 119229/70248
    C549 000 00 g729ar8  3.4.49 busy  idle    0  0 3/0:2  02     0  41913/45414
    C549 001 01 g729ar8  3.4.49 busy  idle       0 3/0:19 19     0 119963/70535
    C549 001 00 g729ar8  3.4.49 busy  idle    0  0 3/0:3  03     0  42865/47341
    C549 002 01 g729ar8  3.4.49 busy  idle       0 3/0:20 20     0  77746/69876
    
    
    !--- This shows DSPs are being used.
    
    
    
    gtp2#show voice call summary
    
    PORT         CODEC    VAD VTSP STATE            VPM STATE
    =========   ======== === ============        ==============
    3/0:2.2       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:3.3       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:4.4       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:5.5       g729ar8  y  S_CONNECT             S_TRUNKED                
    3/0:6.31      g729ar8  y  S_CONNECT             S_TRUNKED
    
    
    !--- This shows call connected.
    
    
    gtp2#show frame-relay pvc
    
    PVC Statistics for interface Serial1/0 (Frame Relay DCE)
    
                  Active     Inactive      Deleted       Static
      Local          1            0            0            0
      Switched       0            0            0            0
      Unused         0            0            0            0
    
    DLCI = 105, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, 
    INTERFACE = Serial1/0.1
    
      input pkts 1201908       output pkts 2177352      in bytes 37341051  
      out bytes 71856239       dropped pkts 0           in FECN pkts 0         
      in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
      in DE pkts 0             out DE pkts 0         
      out bcast pkts 167       out bcast bytes 48597     
      PVC create time 08:37:30, last time PVC status changed 02:47:05
      Service type VoFR-cisco
    
    
    !--- This shows Frame Relay is active.
    
    
    
    gtp2#show frame-relay fragment 
    interface   dlci  frag-type   frag-size  in-frag  out-frag   dropped-frag
    Serial1/0.1 105   VoFR-cisco  640        172      169        0    
    
    
    debug tccs signaling
    
    Log Buffer (8096 bytes):
    
    08:55:47:  282 tccs packets received from the port.
    08:55:47:  282 tccs packets received from the nework.
    08:55:47: RX from Serial3/0:0:
    08:55:47: tccs_db->vcd = 105, tccs_db->cid = 254
    08:55:47: pak->datagramsize=20
    BE C0 C0 00 FF 03 C0 21 09 48 00 0C 01 49 F3 69 00 0C 42 00 
    08:55:47:  282 tccs packets received from the port.
    08:55:47:  283 tccs packets received from the nework.
    08:55:47: RX from Serial1/0: dlci=105, cid=254, payld-type =0,
                    payld-length=188, cid_type=424
    08:55:47: datagramsize=20
    BE C0 C0 00 FF 03 C0 21 0A 48 00 0C 03 EA DF 0D 00 0C 42 00 
    08:55:50:  282 tccs packets received from the port.
    08:55:50:  284 tccs packets received from the nework.
    08:55:50: RX from Serial1/0: dlci=105, cid=254, payld-type =0,
                    payld-length=188, cid_type=424
    08:55:50: datagramsize=20
    BE C0 C0 00 FF 03 C0 21 09 48 00 0C 03 EA DF 0D 00 62 05 00 
    08:55:50:  283 tccs packets received from the port.
    08:55:50:  284 tccs packets received from the nework.
              08:55:50: RX from Serial3/0:0:
    08:55:50: tccs_db->vcd = 105, tccs_db->cid = 254
    08:55:50: pak->datagramsize=20
    BE C0 C0 00 FF 03 C0 21 0A 48 00 0C 01 49 F3 69 00 62 05 00 
    gtp2# wr t
    
    
    !--- This shows packet forwarding and receiving.
    
    

T-CCS Codec de canal limpo

O Clear-channel T-CCS é usado para dar suporte a protocolos de proprietário de PBX onde os canais de sinalização são baseados em bit ABCD ou HDCL, ou onde a tecnologia de transporte de voz é VoIP. Nessa solução, o canal de sinalização e os canais de voz são configurados como ds0groups e todos são tratados como chamadas de voz.

As chamadas reais de voz são conexões de tronco permanentemente conectadas pelo codec de voz da sua escolha. Os canais de sinalização também são troncos permanentemente conectados usando o codec de canal limpo, que é parecido com o G.711 quanto ao tamanho dos pacotes e amostras, mas excluem automaticamente o cancelamento de eco e VAD. Não há nenhuma inteligência no software conhecer que canais são canais de voz, e quais são canais de sinalização. É necessário configurar os timeslots que sabidamente transportam tráfego de sinalização para corresponderem a um peer de discagem que atribui o codec de canal limpo, enquanto que os canais de voz devem corresponder a um peer de discagem que codifique voz (G.729 e outros).

Codec T-CCS de canal desobstruído do implementar

Esteja ciente destes pontos antes que você execute o canal desobstruído T-CCS:

  • Canal desobstruído T-CCS ser usado para algum tipo da sinalização E1 ou T1 digital (que inclui o enquadramento baseado em HDLC).

  • Qualquer número de canais de sinalização pode ser suportado.

  • O canal desobstruído T-CCS pode ser usado em VoIP, em VoFR ou em ambientes VoATM

  • O codec de canal desobstruído é usado para o canal de sinalização ou os canais no canal desobstruído T-CCS.

  • A sinalização voip e a largura de banda de voz devem ser esclarecidas no IP RTP Priority ou no Low Latency Queuing (LLQ).

  • VoIPovFR/VoFR — A sinalização e a Voz podem estar no mesmos ou separar DLCI.

  • VoFR — A Largura de banda de sinalização é contada como parte de VoFR “largura de banda de voz.”

  • Com canal desobstruído T-CCS, sinalizar toma 64K da largura de banda dedicada (que não inclui a carga adicional de pacote).

  • O comando DSO-group configura a Voz e os canais de sinalização.

  • O Software Cisco IOS não sabe qual canal de sinalização está em uso.

  • Trinta e uns DSP são exigidos para um PBX usando a sinalização no intervalo de tempo 16 com 30 portas de voz, assim que dois troncos no E1 2MFT esgotariam a quantidade de DSP no NMV2 (62 são exigidos).

Ao usar codecs do canal desobstruído para transportar o tráfego de dados, é importante que o relógio de rede está sincronizado. Isto é porque os pacotes de quedas de algoritmo DSP quando as excedentes do buffer ocorrem, e usa seu algoritmo da autossuficiência quando as subutilizações de capacidade do buffer ocorrem (fino para o tráfego de voz, mas não bom para o tráfego de dados). Provavelmente, essas situações podem causar falhas no canal D falhe fazer com que ele seja reiniciado.

Exemplo de configuração de VoIP T-CCS de canal livre

A configuração e os testes do T-CCS de VoIP de Canal Desobstruído foram executados em um Cisco IOS Software Release 12.2.7a running do Cisco 3640 Router. No exemplo mostrado aqui, a sinalização não é aplicada no timeslot normal (16). Um outro intervalo de tempo é usado aqui (intervalo de tempo 6) para mostrar a versatilidade da característica.

/image/gif/paws/19087/trans_channel_signal2.gif

  1. No controlador T1 ou E1:

    Defina grupos ds0 para cada canal de voz e canal de sinalização.

    GTP1
    controller E1 3/0
     ds0-group 0 timeslots 6 type ext-sig
     ds0-group 1 timeslots 1 type ext-sig
     ds0-group 2 timeslots 2 type ext-sig
     ds0-group 3 timeslots 3 type ext-sig
     ds0-group 4 timeslots 4 type ext-sig
     ds0-group 5 timeslots 5 type ext-sig
     ds0-group 6 timeslots 31 type ext-sig
     ds0-group 7 timeslots 7 type ext-sig
     ....
     ds0-group 30 timeslots 30 type ext-sig

    GTP2
    controller E1 3/0
     ds0-group 0 timeslots 6 type ext-sig
    
     ds0-group 1 timeslots 1 type ext-sig
     ds0-group 2 timeslots 2 type ext-sig
     ds0-group 3 timeslots 3 type ext-sig
     ds0-group 4 timeslots 4 type ext-sig
     ds0-group 5 timeslots 5 type ext-sig
     ds0-group 6 timeslots 31 type ext-sig
     ds0-group 7 timeslots 7 type ext-sig
     ....
     ds0-group 30 timeslots 30 type ext-sig

  2. Nas portas de voz:

    1. Adicione um comando xxx de tronco de conexão a cada configuração de porta de voz. O número deve corresponder ao padrão de destino da porta de voz de terminação (correspondente de discagem POTS) no outro lado.

    2. Adicionar um comando connection trunk xxx a cada configuração da porta de voz da sinalização — o número deve combinar o padrão de destino da porta de voz de terminação (POTS dial peer) no outro lado.

    3. Somente um lado da conexão deve especificar o modo de resposta.

      GTP1
      voice-port 3/0:0
       timeouts wait-release 3
       connection trunk 3001
      !
      voice-port 3/0:1
       timeouts wait-release 3
       connection trunk 6001
      ! 
      ... [channels 2-30 the same] ...
      !
      voice-port 3/0:30
       timeouts wait-release 3
       connection trunk 6030

      GTP2
      !
       voice-port 3/0:0
       timeouts wait-release 3
       connection trunk 5001 answer-mode
      !
       voice-port 3/0:1
       timeouts wait-release 3
       connection trunk 8001 answer-mode
      !
      ... [channels 2-30 the same] ...
      
      voice-port 3/0:30
       timeouts wait-release 3
       connection trunk 8030 answer-mode

  3. Nos peers de discagem:

    1. Adicionar um dial peer de VOIP que combine o número discado do tronco de conexão dos canais de voz. Aponte-o ao endereço IP de Um ou Mais Servidores Cisco ICM NT do lado remoto; atribua (ou padrão) o codec desejado da Voz neste dial peer.

    2. Adicionar um dial peer de VOIP que combine o número discado do tronco de conexão dos canais de sinalização. Aponte-o ao endereço IP de Um ou Mais Servidores Cisco ICM NT do lado remoto; atribua os codec de canal desobstruído neste dial peer.

    3. Adicione peers de discagem POTS para cada porta de voz que corresponda ao número discado pelas instruções do tronco de conexão do outro lado.

      GTP1
      dial-peer voice 8001 pots
       destination-pattern 8001
       port 3/0:1
      !
      
      
      !--- Pots dial peers 8001 --- 8030 are 
      !--- configured similarly with exclusive POTS,
      !--- destination patterns and ports. These are 
      !--- associated with the voice channels.
      
      
      dial-peer voice 8030 pots
       destination-pattern 8030
       port 3/0:30
      !
      dial-peer voice 5001 pots
       destination-pattern 5001
       port 3/0:0
      
      
      !--- This is the POTS dial peer associated with 
      !--- the port connected to the local PBX 
      !--- signaling channel.
      
      
      ! 
      dial-peer voice 6000 voip
       destination-pattern 6...
       session target ipv4:10.10.105.1
      !
      dial-peer voice 3001 voip
       answer-address 5001
       destination-pattern 3001
       session target ipv4:10.10.105.1
       codec clear-channel
      
      
      !--- This is the VoIP dial peer associated 
      !--- with the destination pattern that 
      !--- connects to the remote PBX signaling 
      !--- channel port.
      
      

      GTP2
      !
      dial-peer voice 6001 pots
       destination-pattern 6001
       port 3/0:1
      !
      
      
      !--- POTS dial peers 6001 --- 6030 are 
      !--- configured similarly with exclusive POTS,
      !--- destination patterns, and ports. 
      !--- These are associated with the 
      !--- voice channels.
      
      
      dial-peer voice 6030 pots
       destination-pattern 6030
       port 3/0:30
      ! 
      dial-peer voice 3001 pots
       destination-pattern 3001
       port 3/0:0
      
      
      !--- This is the POTS dial peer associated 
      !--- with the port connected to the local PBX 
      !--- signaling channel.
      
      
      !
      dial-peer voice 8000 voip
       destination-pattern 8...
       session target ipv4:10.10.105.2
      !
      dial-peer voice 5001 voip
       answer-address 3001
       destination-pattern 5001
       session target ipv4:10.10.105.2
       codec clear-channel
      
      
      !--- This is the VoIP dial peer associated with 
      !--- the destination pattern that connects 
      !--- to the remote PBX signaling channel port.
      
      

Etapas de configuração para o lado de WAN

Para configurar o lado WAN, termine estas etapas:

Introduza um comando IP RTP Priority ou largura de banda LLQ com base nas seguintes informações:

  • O número de canais de voz, e os codecs usados para sinais de voz.

  • O número de canais de sinalização multiplicados por 80K (tratado como você trataria G.711).

GTP1
interface Multilink1
 bandwidth 512
 ip address 10.10.105.2 255.255.255.0
 ip tcp header-compression iphc-format
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 20
 ppp multilink interleave
 multilink-group 1
 ip rtp header-compression iphc-format
 ip rtp priority 16384 16383 384
!
interface Serial0/0
 no ip address
 encapsulation ppp
 no fair-queue
 ppp multilink
 multilink-group 1

GTP2
interface Multilink1
 bandwidth 512
 ip address 10.10.105.1 255.255.255.0
 ip tcp header-compression iphc-format
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 20
 ppp multilink interleave
 multilink-group 1
 ip rtp header-compression iphc-format
 ip rtp priority 16384 16383 384
!!
interface Serial1/0
 no ip address
 encapsulation ppp
 no fair-queue
 clock rate 512000
 ppp multilink
 multilink-group 1

Pesquise defeitos e verifique o canal desobstruído T-CCS

Estas etapas ajudam a verificar que o canal desobstruído T-CSS se está operando como deve:

  1. O controlador E1 deve estar ativado para que as portas de voz sejam desconectadas e truncadas.

  2. Assegure-se de que os verificares chamada estejam no lugar, e os DSP corretos são atribuídos em intervalos de tempo.

  3. Se houver falha na conexão da chamada, verifique a configuração e a conectividade do IP e a provisão do peer de discagem.

  4. Se o IP for restaurado após uma falha de interface ou enlace, o controlador deve ter o comando shut/no shut emitido em sua interface ou o roteador deve ser recarregado para ativar novamente as conexões de tronco.

  5. Se as mostras do comando show voice port inativas e no gancho para algum intervalo de tempo, se certificam do intervalo de tempo relacionado tenha a versão de DSP correta atribuída, e que está trabalhando corretamente com o comando show voice dsp, como mostrado abaixo.

gtp#show voice dsp

DSP  DSP            DSPWARE CURR  BOOT         VOICE      PAK       TX/RX
TYPE NUM CH CODEC   VERSION STATE STATE RST AI PORT   TS ABORT    PACK COUNT
==== === == ======= ======= ===== ===== === == ====== == =====   ============
C549 000 02 g729r8   3.4.49 busy  idle       0 3/0:25    25      0     264/2771
C549 000 01 g729r8   3.4.49 busy  idle       0 3/0:12    12      0     264/2825
C549 000 00 clear-ch 3.4.49 busy  idle    0  0 3/0:0     06      0 158036/16069


!--- The above identifies that the clear codec is used for timeslot 6.
!--- Ensure that clear codec is applied correctly against the correct timeslot.
                                                                     


gtp1#show voice port sum

PORT   CH SIG-TYPE   ADMIN OPER STATUS   STATUS   EC
====== == ========== ===== ==== ======== ======== ==
3/0:0  6     ext     up    up   trunked  trunked  y
3/0:1  1     ext     up    up   trunked  trunked  y
3/0:2  2     ext     up    up   trunked  trunked  y
3/0:3  3     ext     up    up   trunked  trunked  y


!--- This shows that the voice port used for signaling is off-hook and trunked.
 


gtp1#show voice call sum
PORT         CODEC    VAD VTSP STATE            VPM STATE
============ ======== === ============        =============
3/0:0.6       clear-ch y  S_CONNECT             S_TRUNKED
3/0:1.1       g729r8   y  S_CONNECT             S_TRUNKED
3/0:2.2       g729r8   y  S_CONNECT             S_TRUNKED
3/0:3.3       g729r8   y  S_CONNECT             S_TRUNKED
3/0:4.4       g729r8   y  S_CONNECT             S_TRUNKED
3/0:5.5       g729r8   y  S_CONNECT             S_TRUNKED
3/0:6.31      g729r8   y  S_CONNECT             S_TRUNKED
3/0:7.7       g729r8   y  S_CONNECT             S_TRUNKED


!--- This shows a signaling call in progress.

Permita a sinalização RTP no AS5350 e no AS5400

A fim impedir os erros causados por pacotes RTP do tipo de payload “123" em Plataformas do Cisco AS5350 e do AS5400 Series, o processamento de sinal RTP é desabilitado à revelia. Sob algumas circunstâncias, os pacotes deste tipo podem causar um erro de endereço de memória inválido no AS5350 e nas Plataformas do AS5400 Series, causando um crash potencialmente os dispositivos.

Nestes modelos, você pode permitir o processamento de sinal RTP que usa a Voz-RTP-sinalização do Voz-caminho rápido permite hidden o comando configuration. Contudo, antes que você permita o processamento de sinal RTP, prepare a plataforma para segurar pacotes RTP do tipo de payload “123" permitindo o T-CCS.

Depois que você prepara a plataforma, você pode usar estes comandos a fim permitir ou desabilitar o processamento de sinal RTP.

  • A fim permitir o processamento de sinal RTP, use este comando:

    Router(config)#voice-fastpath voice-rtp-signalling enable
    
  • A fim desabilitar o processamento de sinal RTP, use este comando:

    Router(config)#no voice-fastpath voice-rtp-signalling enable
    

Como testar o T-CCS (encaminhamento de estrutura e limpeza de canal) sem PBXs

Em determinadas situações pode ser pouco prático verificar a configuração do T-CCS com PBX. Esta seção descreve um método que envolva a substituição dos PBX com o Roteadores, para testar que sinalizar pode ser transportada. Como a estrutura de quadro usada em PPP é semelhante à usada pela sinalização baseada em mensagens (como CCS), você pode usar roteadores configurados para PPP para testar se o canal de sinalização está funcionando. Isto pode ser útil nas situações onde o desenvolvimento do T-CCS falhou, e uma prova mais adicional é precisada que o canal de sinalização funcionasse. (No Frame-Forwarding T-CCS há debuga a informações disponíveis que mostra a transmissão e a recepção dos quadros. Em T-CCS de canal limpo, nenhuma informação de depuração em tempo real está disponível.)

Configurar o controlador E1 do Roteadores para o canal de sinalização da escolha. Este exemplo usa o intervalo de tempo 6, ao acordo com os testes acima. Configurar o PPP na interface serial resultante para representar o tráfego de sinalização.

trans_channel_signal3.gif

Roteador 1
controller E1 0
 clock source internal
 channel-group 0 timeslots 6
!
interface Serial0:0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp

Roteador 2
controller E1 0
 clock source internal
 channel-group 0 timeslots 6
!
interface Serial0:0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp

Saída típica com pacotes debug ppp
1d00h: Se0:0 LCP: Received id 1, sent id 1, line up
1d00h: Se0:0 PPP: I pkt type 0xC021, datagramsize 16
1d00h: Se0:0 LCP: I ECHOREQ [Open] id 2 len 12 magic 0x0676C553
1d00h: Se0:0 LCP: O ECHOREP [Open] id 2 len 12 magic 0x0917B6ED
1d00h: Se0:0 PPP: I pkt type 0x0207, datagramsize 305
1d00h: Se0:0 LCP: O ECHOREQ [Open] id 2 len 12 magic 0x0917B6ED
1d00h: Se0:0 PPP: I pkt type 0xC021, datagramsize 16
1d00h: Se0:0 LCP: I ECHOREP [Open] id 2 len 12 magic 0x0676C553
1d00h: Se0:0 LCP: Received id 2, sent id 2, line up

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 19087