Voz e comunicações unificadas : Adaptadores de telefone analógico Cisco ATA 180 Series

Configurando e Troubleshooting de um ATA 186 com Cisco IOS Gatekeepers

16 Janeiro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (11 Novembro 2015) | Feedback


Índice


Introdução

O Cisco Analog Telephone Adaptor (ATA) é um adaptador de telefone para Ethernet que faz interface entre telefones analógicos comuns e redes de telefonia com base em IP. O ATA186 tem duas portas de voz que podem somente apoiar telefones análogos do tom do toque do legado. Ao contrário das portas da estação de câmbio internacional regular (FXS), estes não podem ser conectados com um central telefônica privada (PBX) porque o ATA186 não pode mandar dígitos nestas portas. Com esta configuração, você pode usar ambas as portas de voz com endereços E.164 diferentes em cada um.

Pré-requisitos

Requisitos

Este documento supõe que o leitor é familiar com o índice no documento da configuração básica do Cisco ATA 186.

Esta configuração exige o ATA186 estar na versão 2.0 ou mais recente, usando o conjunto de recursos de H.323.

Assegure-se de que haja uma conectividade IP entre o ATA186, o gateway, e os dispositivos do porteiro. Também, assegure-se de que o ATA186 esteja acessível com o método do servidor de Web para uma configuração mais adicional.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • ATA186 com versão 2.12

  • Cisco 3640 com Software Release 12.1 do � do Cisco IOS como um gateway

  • Cisco 2600 com Cisco IOS Software Release 12.2 como um porteiro

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Diagrama de Rede

Este documento utiliza a seguinte configuração de rede:

/image/gif/paws/19084/ata_gatekeeper_1.gif

Registrando o ATA 186 com o Gatekeeper

Siga estas instruções para registrar o ATA186 com o porteiro.

  1. Em um campo do endereço ou do lugar do navegador da Web, datilografe o ip_address_of_ata URL http:///colaborador para alcançar a tela de configuração ATA186, onde o ip_address_of_ata é o endereço IP de Um ou Mais Servidores Cisco ICM NT do ATA186 que você se está registrando.

    Neste exemplo, a URL é http://172.16.104.117/dev. A janela de configuração do Cisco ATA 186 aparece.

    Nota: Os campos sublinhados são os parâmetros configurados relevantes para esta encenação.

    /image/gif/paws/19084/ata_gatekeeper_2.gif

    O endereçamento de IP pode ser feito estaticamente ou dinamicamente, como explicado no documento da configuração básica do Cisco ATA 186. Na tela precedente, o endereço IP estático é usado.

  2. Na janela de configuração do Cisco ATA 186, configurar estes campos:

    • UID0 e UID1 — Configurar os endereços E.164 das portas de voz 0 e 1.

      Ambas as portas de voz não podem ter o mesmo endereço E.164, porque o ATA186 não pode caçar se uma das portas é ocupada. Se ambas as portas de voz são atribuídas o mesmo endereço E.164, o atendimento estará enviado sempre à primeira porta de voz. Se esta porta é ocupada, o busy signal (sinal ocupado) está enviado ao chamador.

    • RxCodec e TxCodec — Configurar o codec ID.

      • G.723.1 — codec ID 0.

      • G.711a — codec ID 1.

      • G.711u — codec ID 2.

      • G.729a — codec ID 3.

      Na configuração mostrada abaixo, o codec de G.729r8 é usado no ATA186 e no gateway.

    • LBRCodec — Configurar como 0 ou 3, com base no codec escolhido.

      • O LBRC é 0 — O codec G.723.1 está disponível a ambas as portas FXS a qualquer hora. Cada linha pode manter dois atendimentos G.723.1 em um estado de não conferência. Consequentemente, até quatro atendimentos G.723.1 podem ser mantidos no Cisco ATA 186. Um exemplo é espera de chamada.

      • O LBRC é 3 — G.729a está disponível a uma das duas portas FXS em uma primeiro a chegar primeiro a ser servido base. Se o Cisco IOS gateway é configurado com o codec de G.729 do padrão, simplesmente uma porta ATA186 pode ser usada. Para impedir que a segunda chamada falhe, configurar uma CODEC-classe da Voz no gateway para negociar a segunda chamada usando um codec de G.711. Para a informação detalhada, refira a seção da negociação codec compreendendo dos codecs: Complexidade, suporte a hardware, MOS, e documento da negociação.

    • GKOrProxy — Configurar o endereço IP de Um ou Mais Servidores Cisco ICM NT do porteiro.

      Uma vez que isto é feito, qualquer coisa que é discado das portas de voz ATA186 está enviado ao porteiro.

  3. Clique o botão Apply Button e recarregue então a página.

    O ATA186 toma os segundos 10 para reconfigurar-se.

Estes exemplos são configurações relevantes para o Gatekeeper e o gateway:

2610-Gatekeeper
interface Ethernet0/0
 ip addreinterface Ethernet0/0
 ip address 172.16.13.12 255.255.255.224
 half-duplex
 h323 interface
 h323 h323-id pro
 h323 gatekeeper ipaddr 172.16.13.12
 h323 t120 bypass
!
dial-peer cor custom
!
!
!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
no shutdown
!

3640-Gateway
interface Ethernet0/0
 ip address 172.16.13.40 255.255.255.224
 half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.13.33
ip http server
!
!
!
voice-port 3/0/0
!
voice-port 3/0/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 34
 port 3/0/0
!
dial-peer voice 2 pots
 destination-pattern 45
 port 3/0/1
!
dial-peer voice 100 pots
 destination-pattern 1234
 port 3/0/0
!
dial-peer voice 3000 voip
 destination-pattern 300.
 session target ras

!--- Dial-peer to send the calls to ATA.

!

Adicionando segurança

Até à data da liberação de software ATA 2.12, as opções nesta seção estão disponíveis para adicionar a Segurança.

Autentique o ponto final no gatekeeper com um ID H.323

Siga estas etapas para configurar o ATA186 para registrar-se com H.323 ID:

  1. Ajuste o campo de AutMethod a 0 (o padrão é 1).

    O valor hexadecimal que deve ser configurado para este campo é 0x0.

  2. Ajuste o campo useloginid a 1.

  3. Configurar o LoginID0 e o LoginID1, com H.323 ID para o ATA186.

    O ATA186 registra-se como dois Terminais H.323 diferentes, um para cada porta.

Esta é uma configuração em funcionamento da amostra para o porteiro ao usar o ATA com o método de autenticação de ID de H.323:

/image/gif/paws/19084/ata_gatekeeper_3.gif

2610-Gatekeeper
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username atagw1

!--- Same as the LoginID0 and LoginID1 fields.

username atagw2
username 3640

!--- Same as the H.323 ID configured on the gateway.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security any

!--- Register after the H.323 ID or E.164 address is authenticated.

no shutdown
!

Autentique o valor-limite no porteiro com um endereço E.164

Siga estas etapas para configurar o ATA186 para registrar-se com o endereço E.164:

  1. Ajuste o campo de AutMethod a 0 (o padrão é 1).

    O valor hexadecimal que deve ser configurado para este campo é 0x0.

  2. Ajuste o campo useloginid a 0.

    O ATA usa os campos UID0 e UID1 para obter autenticado pelo porteiro.

Esta é uma configuração em funcionamento da amostra para o gatekeeper e gateway ao usar o ATA com o método de autenticação de ID E.164:

2610-Gatekeeper
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username 3001

!--- Same as the UID0.

username 3000

!--- Same as the UID1.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security any

!--- Register after the H.323 ID or E.164 address is authenticated.

no shutdown
!

Autentique o valor-limite no porteiro com H.323 ID e senha

Siga estas etapas para configurar o ATA186 para registrar-se com H.323 ID e senha:

  1. Ajuste o campo de AutMethod a 1 (o padrão é 1).

    O valor hexadecimal que deve ser configurado para este campo é 0x1. Este campo é ajustado para indicar que o ATA procura agora a senha.

  2. Ajuste o campo useloginid a 1.

  3. Configurar o LoginID0 e o LoginID1, com H.323 ID para o ATA186.

    O ATA186 registra-se como dois Terminais H.323 diferentes, um para cada porta.

  4. Configurar o PWD0 e o PWD1 com a senha para cada porta.

    Nota: O ATA usa a senha para gerar o token. Este token é enviado ao gatekeeper para autorização.

  5. Configurar o NTPIP com endereço IP de Um ou Mais Servidores Cisco ICM NT do server do Network Time Protocol (NTP).

    O porteiro e o ATA devem ter os pulsos de disparo sincronizados ao mesmo servidor de NTP.

Nota: O timestamp é usado para a geração de token. Para mais informação, refira o gateway ao porteiro (H.235) e ao porteiro ao guia de Troubleshooting da Segurança do porteiro (IZCT).

Esta é uma configuração em funcionamento da amostra para o gatekeeper e gateway ao usar o ATA com H.323 ID e método de autenticação de senha:

2610-Gatekeeper
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username atagw1 password cisco

!--- Same as the LoginID0 and PWD0 fields.

username atagw2 password cisco

!--- Same as the LoginID1 and PWD1 fields.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security token required-for registration

!--- Register after the H.323 ID or E.164 address and token is authenticated.

no shutdown
!

Nota: Para obter mais informações sobre da segurança de gatekeeper, refira o gateway ao porteiro (H.235) e ao porteiro ao guia de Troubleshooting da Segurança do porteiro (IZCT).

Autentique o valor-limite no porteiro com um endereço E.164 e uma senha

Siga estas etapas para configurar o ATA186 para registrar-se com o E.164 ID e senha:

  1. Ajuste o campo de AutMethod a 1 (o padrão é 1).

    O valor hexadecimal que deve ser configurado para este campo é 0x0. Este campo é ajustado para indicar que o ATA procurará agora a senha.

  2. Ajuste o campo useloginid a 0.

  3. Configurar o UID0 e o UID1 com o E.164 ID para o ATA186.

    O ATA186 registra-se como dois Terminais H.323 diferentes, um para cada porta.

  4. Configurar o PWD0 e o PWD1 com a senha para cada porta.

    Nota: O ATA usa a senha para gerar o token. Este token é enviado ao gatekeeper para autorização.

  5. Configurar o NTPIP com o endereço IP de Um ou Mais Servidores Cisco ICM NT do servidor de NTP.

    O porteiro e o ATA devem ter os pulsos de disparo sincronizados ao mesmo servidor de NTP.

Nota: O timestamp é usado para a geração de token. Para mais informação, refira o gateway ao porteiro (H.235) e ao porteiro ao guia de Troubleshooting da Segurança do porteiro (IZCT).

Esta é uma configuração em funcionamento da amostra para o gatekeeper e gateway ao usar o ATA com o E.164 ID e método de autenticação de senha:

2610-Gatekeeper
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username 3001 password cisco

!--- Same as the UID0 and PWD0 fields.

username 3000 password cisco


!--- Same as the UID1 and PWD1 fields.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security token required-for registration

!--- Register after the H.323 ID or E.164 address and token is authenticated.

no shutdown
!

Nota: Para obter mais informações sobre da segurança de gatekeeper, refira o gateway ao porteiro (H.235) e ao porteiro ao guia de Troubleshooting da Segurança do porteiro (IZCT).

Autentique o valor-limite no porteiro com H.323 ID e senha usando o separador

Siga estas etapas para configurar o ATA186 para registrar-se com H.323 ID e senha:

  1. Ajuste o campo de AutMethod a 1 (o padrão é 1).

    O valor hexadecimal configurado para este campo é 0x1. Este campo é ajustado para indicar que o ATA procura agora a senha.

  2. Ajuste o campo useloginid a 1.

  3. Configurar o LoginID0 e o LoginID1 com H.323 ID, seguido pelo separador e pela senha para o ATA186.

    Por exemplo, o LoginID0 é atagw1=cisco.

    O ATA186 registra-se como dois Terminais H.323 diferentes, um para cada porta.

    Nota: O ATA usa a senha para gerar o token. Este token é enviado ao gatekeeper para autorização.

  4. Configurar o NTPIP com o endereço IP de Um ou Mais Servidores Cisco ICM NT do servidor de NTP.

    O porteiro e o ATA devem ter os pulsos de disparo sincronizados ao mesmo servidor de NTP.

Nota: O timestamp é usado para a geração de token. Para mais informação, refira o gateway ao porteiro (H.235) e ao porteiro ao guia de Troubleshooting da Segurança do porteiro (IZCT).

Esta é uma configuração em funcionamento da amostra para o gatekeeper e gateway ao usar o ATA com H.323 ID e método de autenticação de senha usando um separador:

2610-Gatekeeper
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username atagw1 password cisco

!--- Same as the LoginID0 and PWD0 fields.

username atagw2 password cisco

!--- Same as the LoginID1 and PWD1 fields.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security h323-id
security password separator =

!--- Register after the H.323 ID or E.164 address and token is authenticated.

no shutdown
!

Nota: Para obter mais informações sobre da segurança de gatekeeper, refira o gateway ao porteiro (H.235) e ao porteiro ao guia de Troubleshooting da Segurança do porteiro (IZCT).

Verificar

O exemplo nesta seção mostra o registro de ponto final de gatekeeper.

Para verificar a configuração, emita o comando show gatekeeper endpoint.

                            GATEKEEPER ENDPOINT
REGISTRATION

CallSignalAddr  Port  RASSignalAddr  Port  Zone Name  Type     Flags
--------------  ----  -------------  ----  ---------  ----     -----
172.16.13.40    1720  172.16.13.40   50923    gk2     VOIP-GW  E164-ID: 1234
                                                               H323-ID: 3640
172.16.13.43    1720  172.16.13.43   58400    gk2     VOIP-GW  H323-ID: 3660-2
172.16.104.117  1720  172.69.85.90   1719     gk2     TERM     E164-ID: 3000
172.16.104.117  1721  172.69.85.90   1739     gk2     TERM     E164-ID: 3001
Total number of active registrations=3

Nota: O ATA186 registra-se como um terminal de H.323 (TERMO) e não como um gateway de H.323. Isto é feito deliberadamente de modo que somente os atendimentos pretendidos para o ATA186 lhe sejam enviados.

Nota: Você não pode ter nenhum endereço no campo de gateway ATA. Você não pode configurar o ATA186 para trabalhar com o porteiro assim como o gateway.

Troubleshooting

Esta seção fornece a informação para pesquisar defeitos sua configuração.

O ATA186 não fornece o tom de discagem se não é registrado com sucesso com o porteiro. Se o ATA186 não se está registrando com o porteiro, verifique estes artigos:

  • A conectividade IP existe entre o ATA186 e o porteiro.

  • Os campos UID0 e UID1 ATA186 são configurados corretamente.

    • Se os campos UID são ajustados a 0, o ATA186 não tenta registrar-se com o porteiro.

    • Pelo menos, o campo UID0 deve ser um valor diferente de zero, para que o ATA186 comece o processo de registro.

    • Se ambas as portas ATA186 (UID0 e UID1) têm os endereços E.164 diferente de zero, o ATA186 tenta registrar-se com ambas as portas. O ATA186 não fornece o tom de discagem, mesmo se uma das portas é incapaz de se registrar.

  • O porteiro é configurado corretamente.

    • Se o porteiro é configurado com um prefixo da zona local, o endereço E.164 do ATA186 deve ser incluído.

    • Se a Segurança é configurada no porteiro, o ATA186 deve ser configurado em conformidade.

Além, verifique que o campo de UseSIP está ajustado a 0. Isto é necessário para configurar o ATA186 no modo de H.323. Se o campo de UseSIP é ajustado a 1, o ATA186 não envia a requisição de registro ao porteiro.

Pesquise defeitos o porteiro

Quando a Segurança é configurada, emita o comando debug aaa authentication.

Se nenhuma Segurança é configurada, emita o comando debug ras.

Nota: O ATA186 registra-se para as duas portas de voz separadamente. O ATA186, obtém consequentemente Terminais H.323 tão diferentes duas vezes autenticados, segundo as indicações deste debuga:

4w4d: AAA/AUTHEN/CONT (3800768902): continue_login (user='atagw1')
4w4d: AAA/AUTHEN (3800768902): status = GETPASS
4w4d: AAA/AUTHEN/CONT (3800768902): Method=LOCAL
4w4d: AAA/AUTHEN (3800768902): status = PASS
4w4d: AAA: parse name=<no string> idb type=-1    tty=-1
4w4d: AAA/MEMORY: create_user (0x83149EFC) user='atagw2'ruser='NULL' port='NULL'
      rem_addr='NULL' authen_type=ASCII service=LOGIN priv=0 initial_task_id='0'
4w4d: AAA/AUTHEN/START (294225678): port='' list='h323' action=LOGIN service=LOGIN
4w4d: AAA/AUTHEN/START (294225678): found list h323
4w4d: AAA/AUTHEN/START (294225678): Method=LOCAL
4w4d: AAA/AUTHEN (294225678): status = GETPASS
4w4d: AAA/H323: Password:
4w4d: AAA/AUTHEN/CONT (294225678): continue_login (user='atagw2')
4w4d: AAA/AUTHEN (294225678): status = GETPASS
4w4d: AAA/AUTHEN/CONT (294225678): Method=LOCAL
4w4d: AAA/AUTHEN (294225678): status = PASS
4w4d: AAA: parse name=<no string> idb type=-1    tty=-1
4w4d: AAA/MEMORY: create_user (0x831910C0) user='3660'  ruser='NULL' port='NULL'
      rem_addr='NULL' authen_type=ASCII service=LOGIN priv=0 initial_task_id='0

Para mais exemplos de Troubleshooting, refira pesquisando defeitos problemas de registro de gatekeeper.

Pesquise defeitos o ATA186

Quando você está trabalhando com gatekeeperes de terceira parte e gateways, a ferramenta de Troubleshooting no ATA186 é muito útil. Para permitir a ferramenta de Troubleshooting ATA186, siga estas etapas:

  1. No campo ATA Nprintf, configurar o endereço IP de Um ou Mais Servidores Cisco ICM NT do PC que está na mesma sub-rede como o ATA186.

  2. A porta especificada depois do endereço deve ser 9001.

  3. No prompt do DOS no PC, emita o programa do preserv.exe.

Você pode transferir o programa do preserv.exe do centro de CiscoSoftware (registeredcustomers somente).

O programa do preserv.exe é incluído no arquivo zip o mais atrasado do software release ATA186.

Exemplo de depuração para chamadas feitas do ATA 186

D:\Documents and Settings\sshafiqu\My Documents\voice\ata>prserv.exe
GK<-1: KPA-RRQ:300 sec
GK->1: RCF:TTL 300

!--- ATA was reset after the gatekeeper configuration was added.

WStop:0
Wed Feb 06 19:06:54 2002 Hello from 171.69.85.90(0)
Build 1109a: v2.12 ata186
Successfully Registered with the Gatekeeper
GK zone<gk2>172.16.13.12: 3000
GK zone:gk2
0x13e138 delayed RRQ: 48 ticks: 300
GK zone<gk2>172.16.13.12: 3001
GK zone:gk2
0x141e58 delayed RRQ: 56 ticks: 300
BMK : gk2
GK<-1: KPA-RRQ:300 sec
BMK : gk2
GK<-0: KPA-RRQ:300 sec
GK->1: RCF:TTL 300
GK->0: RCF:TTL 300
SCC->(0 0) <cmd 0>
3000 active @0xab45555a (GK @0xac100d0c)

!--- Call made from voice port 0.

[0]DTMF 1
[0]DTMF 2
[0]DTMF 3
[0]DTMF 4
[0]DTMF #
Calling 1234
SCC->(0 0) <cmd 16>
CLIP\
\SCC->(0 0) <cmd 2>
\<0 0> dial<1234>
GK<-0: ARQ: 0
GK->0: ACF:0:direct call
IRR in 240 sec
CallRasCallBack: 1 33e15eb 33e206b 33e39b0
Connect to <0xac100d28 1720>>..
>>>>>>>> TX CALLER ID : 0x1          0x80 6
Q931<-0:Setup:CRV 25006
Q931->0:Proceeding
Connect H245...
H245 TCP conn ac100d28 11006
CESE/MSDSE start:<0 0 0 0>
capSize = 3
H245->0:Cese
RemoteInputCap <15 5>
RemoteInputCap <15 4>
RemoteInputCap <15 1>
RemoteInputCap <4 11>
MODE FRAME : 11 2
RemoteAudioCap <4 10>
Capability set accepted
H245->0:MSD: <rn tt> = <0x269c 60>
H245->0:CeseAck
H245->0:MsdAck
h323.c 1837: cstate : 3
->H245<0> OLC
H245<-0:LcseOpen
set TX audio to G729/G729A 2 fpp
SetG723Mode: 2 0
H245->0:LcseOpen
H245->0:OLC mode 10
remote OpenLogicalReq G711/G729(10) : 2 fpp
OpenRtpRxPort(0,0x0,4000):14
RTP Rx Init: 0, 0
RTP->0:<0xab45555a 4000>
H245->0:LcseOpenAck
RTP<-0:<0xac100d28 17304>
[0]Enable encoder 18
RTP TX[0]:SSRC_ID = 4af964c0
RTP Tx Init: 0, 0
[0]DPKT 1st: 861812319 861812079, pt 18
Enable LEC adapt [0]=1
H323Dispatcher : 3 3
[0]Received pi=8 in q931
Q931->0:Progress
Q931->0:Connect
SCC:ev=12[0:0] 3 0
Q931->0:ReleaseComplete: reason 16, tone = 13
H245<-0:EndSessionCmd 1
0: Close RTPRX
write TCP err : 13 -33
[0:0]Rel LBRC Res
Q931<-*:ReleaseComplete

!--- ATA side hangs up the call.

write TCP err : 12 -33
GK<-0: DRQ:0

!--- Disconnect request sent by ATA.

SCC:ev=13[0:0] 4 0
[0:0]SCC: Disconnected
GK->0: DCF

!--- Disconnect confirm received.

SCC->(0 0) <cmd 1>
[0]MPT mode 0

O sem tom de discagem ATA debuga o exemplo

Ambas as portas de voz precisam um endereço E.164 original, se não o ATA recebe uma rejeição do porteiro. Durante este tempo, você verá o ATA186 ser com uma só voz porta registrada como um terminal de H.323, mas haverá sem tom de discagem.

K<-0: GRQ
BMK : gk2
GK->0: GCF:GK@0xac100d0c-1719
BMK : gk2
Secured RRQ
GK<-0: RRQ
GK->0:RRJ: reason 4

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 19084