Segurança e VPN : Negociação IPSec/Protocolos IKE

Troubleshooting de PIX para Passagem de Tráfego de Dados em um Túnel de IPSec Estabelecido

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento discute porque um túnel IPSec estabelecido com sucesso ligando um Cisco VPN Client a um PIX é incapaz de transmitir dados e oferece uma solução para esse problema.

A incapacidade passar dados em um túnel IPSec estabelecido entre um cliente VPN e um PIX é encontrada frequentemente quando você não pode sibilar ou telnet de um cliente VPN a nenhuns anfitriões no LAN atrás do PIX. Ou seja o cliente VPN e o PIX não podem passar dados criptografados entre ele. Isto ocorre porque o PIX tem um túnel IPSec de LAN para LAN a um roteador e igualmente a um cliente VPN. A incapacidade passar dados é o resultado de uma configuração com o mesmo Access Control List (ACL) para o 0 nat e o mapa estático de criptografia para o ipsec peer do LAN para LAN.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

As informações neste documento são baseadas nestas versões de software e hardware:

  • Firewall PIX segura Cisco 6.0.1

  • Cisco 1720 Router que executa o Software Release 12.2(6) de Cisco IOS�

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Pesquise defeitos o PIX

Diagrama de Rede

ipsec_tun_pass_data-a.gif

Exemplo de configuração com problemas

PIX 520
pix520-1#write terminal
Building configuration...
: Saved
:
PIX Version 6.0(1)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 2KFQnbNIdI.2KYOU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix520-1
domain-name vpn.com
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 1720
fixup protocol rsh 514
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names

!--- Access-List “140” defines interesting traffic to bypass NAT for VPN
!--- and defines VPN interesting traffic.  This is incorrect.

access-list 140 permit ip 192.168.4.0 255.255.255.0 10.10.10.0 255.255.255.0
access-list 140 permit ip 192.168.4.0 255.255.255.0 10.1.2.0 255.255.255.0
no pager
logging on
logging console debugging
logging monitor debugging
logging buffered debugging
logging trap debugging
logging history debugging
logging host outside 192.168.2.6
interface ethernet0 auto
interface ethernet1 auto
mtu outside 1500
mtu inside 1500

!--- IP addresses on the outside and inside interfaces.

ip address outside 172.16.172.34 255.255.255.240
ip address inside 192.168.4.50 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.1.2.1-10.1.2.254
no failover
failover timeout 0:00:00
failover poll 15
failover ip address outside 0.0.0.0
failover ip address inside 0.0.0.0
pdm history enable
arp timeout 14400
global (outside) 1 172.16.172.57 netmask 255.255.255.255

!--- The nat 0 command bypasses NAT for the packets destined over the IPsec tunnel.

Nat (inside) 0 access-list 140
Nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 172.16.172.33 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323
0:05:00 sip
0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
AAA-server RADIUS protocol radius
AAA-server mytest protocol tacacs+
AAA-server nasir protocol radius
snmp-server host outside 192.168.2.6
no snmp-server location
no snmp-server contact
snmp-server community public
snmp-server enable traps
floodguard enable

!--- The sysopt command bypasses conduits or ACLs that check to be applied
!--- on the inbound VPN packets after decryption.

sysopt connection permit-ipsec
no sysopt route dnat

!--- The crypto ipsec command defines IPsec encryption and authen algo.

crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset

!--- The crypto map commands define the IPsec 
!--- Security Assocation (SA) (Phase II SA) parameters.

crypto map mymap 5 ipsec-isakmp
crypto map mymap 5 match address 140
crypto map mymap 5 set peer 172.16.172.39
crypto map mymap 5 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside

!--- The isakmp key command defines the pre-shared key for the peer address.

isakmp key ******** address 172.16.172.39 netmask 255.255.255.255 no-xauth
no-config-mode
isakmp identity address

!--- The isakmp policy defines the Phase 1 SA parameters.

isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption Des
isakmp policy 20 hash sha
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet 192.168.4.0 255.255.255.0 inside
telnet 171.69.89.82 255.255.255.255 inside
telnet timeout 5
ssh 172.0.0.0 255.0.0.0 outside
ssh 171.0.0.0 255.255.255.0 outside
ssh 171.0.0.0 255.0.0.0 outside
ssh timeout 60
terminal width 80
Cryptochecksum:55948dc706cc700e9c10e1d24a8b125c

Na configuração problemática o tráfego interessante, ou no tráfego a ser cifrado para o túnel de LAN para LAN, é definido por ACL 140. A configuração usa o mesmo ACL que os 0 ACL nat.

Compreenda a sequência geral de evento

Quando um pacote IP chega na interface interna do PIX, o Network Address Translation (NAT) está verificado. Após isso, os ACL para os crypto map são verificados.

  • Como 0 nat são usados.

    Os 0 ACL nat definem o que não deve ser incluído no NAT. O ACL no comando nat 0 define o endereço de rementente e destinatário para que as regras NAT no PIX são desabilitadas. Consequentemente, um pacote IP que tenha um endereço de rementente e destinatário que combine o ACL definido no comando nat 0 contorneia todas as regras NAT no PIX.

    A fim executar túneis de LAN para LAN entre um PIX e um outro dispositivo VPN com a ajuda dos endereços privados, use o comando nat 0 contornear o NAT. As regras no PIX Firewall impedem que os endereços privados estejam incluídos no NAT quando estas regras forem ao LAN remota sobre o túnel de IPsec.

  • Como o ACL cripto é usado.

    Após as inspeções NAT, o PIX verifica a fonte e o destino de cada pacote IP que chega em sua interface interna para combinar os ACL definidos nos mapeamentos de criptografia estática e dinâmica. Se o PIX encontra um fósforo com o ACL, o PIX toma qualqueras um etapas:

    • Se não há nenhuma associação de segurança IPSec atual (SA) já construída com o dispositivo peer IPSec para o tráfego, o PIX inicia as negociações de IPSec. Uma vez que os SA são construídos, cifra o pacote e envia-o sobre o túnel de IPsec ao ipsec peer.

    • Se há já IPsec SA construído com o par, o PIX cifra o pacote IP e envia o pacote criptografado ao dispositivo peer IPSec.

  • ACL dinâmico.

    Uma vez que um cliente VPN conecta ao PIX com a ajuda do IPsec, o PIX cria um ACL dinâmico que especifique o endereço de rementente e destinatário para se usar a fim definir o tráfego interessante para esta conexão IPSec.

Compreenda a série de eventos problemáticos no PIX

Um erro da configuração comum é usar o mesmo ACL para 0 nat e os mapas estáticos de criptografia. Estas seções discutem porque esta conduz a um erro e como retificar o problema.

A configuração de PIX mostra que os 0 ACL nat 140 contorneiam o NAT quando os pacotes IP vão a rede 192.168.4.0/24 às redes 10.10.10.0/24 e 10.1.2.0/24 (endereço de rede definido no ipool de pool local IP). Adicionalmente, o ACL 140 define o tráfego interessante para o mapa estático de criptografia para o par 172.16.172.39.

Quando um pacote IP vem à interface interna PIX, a verificação NAT termina e então o PIX verifica os ACL nos crypto map. O PIX começa com o crypto map com o mais baixo número do exemplo. Isto é porque o mapa estático de criptografia no exemplo anterior tem o mais baixo número do exemplo, o ACL 140 é verificado. Em seguida, o ACL dinâmico para o mapa cripto dinâmico é verificado. Nesta configuração, o ACL 140 é definido para cifrar o tráfego que vai da rede 192.168.4.0 /24 às redes 10.10.10.0/24 0 e 10.1.2.0 /24. Contudo, para o túnel de LAN para LAN, você quer somente cifrar o tráfego entre redes 192.168.4.0 /24 e 10.10.10.0 /24. Isto é como o roteador de IPSec peer define seu ACL cripto.

Compreenda a série de eventos problemáticos no PIX

Quando um cliente estabelece uma conexão IPSec ao PIX, ele está atribuído um endereço IP de Um ou Mais Servidores Cisco ICM NT do conjunto local IP. Nesta instância, o cliente é atribuído 10.1.2.1. O PIX igualmente gera um ACL dinâmico, porque esta saída do comando show crypto map mostra:

Crypto Map "mymap" 20 ipsec-isakmp
Peer = 171.69.89.120
access-list dynacl2 permit ip host 172.16.172.34 host 10.1.2.1 (hitcnt=0)
dynamic (created from dynamic map dynmap/10)
Current peer: 171.69.89.120
Security association lifetime: 4608000 kilobytes/28800 seconds
PFS (Y/N): N
Transform sets={ myset, }
Crypto Map "mymap" 30 ipsec-isakmp
Peer = 171.69.89.120
access-list dynacl3 permit ip any host 10.1.2.1 (hitcnt=0)
dynamic (created from dynamic map dynmap/10)
Current peer: 171.69.89.120
Security association lifetime: 4608000 kilobytes/28800 seconds
PFS (Y/N): N
Transform sets={ myset, }
pix520-1(config)#

O comando show crypto map igualmente mostra o mapa estático de criptografia:

Crypto Map: "mymap" interfaces: { outside }
Crypto Map "mymap" 5 ipsec-isakmp
Peer = 172.16.172.39
access-list 140 permit ip 192.168.4.0 255.255.255.0 10.10.10.0255.255.255.0 
   (hitcnt=45)
access-list 140 permit ip 192.168.4.0 255.255.255.0 10.1.2.0 255.255.255.0
   (hitcnt=84)
Current peer: 172.16.172.39
Security association lifetime: 4608000 kilobytes/28800 seconds
PFS (Y/N): N
Transform sets={ myset,}

Uma vez que o túnel de IPsec é estabelecido entre o cliente e o PIX, o cliente inicia um sibilo ao host 192.168.4.3. Quando recebe a requisição de eco, o host 192.168.4.3 responde com uma resposta de eco enquanto esta saída do comando debug icmp trace mostra.

27: Inbound ICMP echo request (len 32 id 2 seq 7680) 
   10.1.2.1 > 192.168.4.3> 192.168.4.3
28: Outbound ICMP echo reply (Len 32 id 2 seq 7680) 
   192.168.4.3 >192.168.4.3 > 10.1.2.1
29: Inbound ICMP echo request (Len 32 id 2 seq 7936) 
   10.1.2.1 > 192.168.4.3> 192.168.4.3
30: Outbound ICMP echo reply (Len 32 id 2 seq 7936) 
   192.168.4.3 >192.168.4.3 > 10.1.2.1

Contudo, a resposta de eco não alcança o cliente VPN (host 10.1.2.1), e o sibilo falha. Você pode ver este com a ajuda do comando show crypto ipsec sa no PIX. Esta saída mostra que o PIX decifra 120 pacotes que vêm do cliente VPN, mas não cifram nenhuns pacotes nem enviam os pacotes criptografado ao cliente. Consequentemente, o número de pacotes encapsulados é zero.

pix520-1(config)#show crypto ipsec sa
interface: outside
Crypto map tag: mymap, local addr. 172.16.172.34
local ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/0/0)
remote ident (addr/mask/prot/port): (10.1.2.1/255.255.255.255/0/0)
current_peer: 171.69.89.120
dynamic allocated peer ip: 10.1.2.1
PERMIT, flags={}
#pkts encaps: 0, #pkts encrypt: 0, #pkts digest 0 

!--- No packets encrypted and sent to client.

#pkts decaps: 120, #pkts decrypt: 120, #pkts verify 120 

!--- 120 packets received from client.

#pkts compressed: 0, #pkts decompressed: 0
#pkts not compressed: 0, #pkts compr. failed: 0, #pkts decompress failed: 0
#send errors 0, #recv errors 0
local crypto endpt.: 172.16.172.34, remote crypto endpt.: 171.69.89.120
path mtu 1500, ipsec overhead 56, media mtu 1500
current outbound spi: 33a45029
inbound esp sas:
spi: 0x279fc5e9(664782313)
transform: ESP-Des esp-md5-hmac ,
in use settings ={Tunnel, }
slot: 0, conn id: 5, crypto map: mymap
sa timing: remaining key lifetime (k/sec): (4607985/27809)
IV size: 8 bytes
replay detection support: Y
inbound ah sas:
inbound pcp sas:
outbound ESP sas:
spi: 0x33a45029(866406441)
transform: ESP-Des esp-md5-hmac ,
in use settings ={Tunnel, }
slot: 0, conn id: 6, crypto map: mymap
sa timing: remaining key lifetime (k/sec): (4608000/27809)
IV size: 8 bytes
replay detection support: Y
outbound ah sas:
outbound PCP sas:
local ident (addr/mask/prot/port): (192.168.4.0/255.255.255.0/0/0)
remote ident (addr/mask/prot/port): (10.10.10.0/255.255.255.0/0/0)
current_peer: 172.16.172.39
PERMIT, flags={origin_is_acl,}
#pkts encaps: 10, #pkts encrypt: 10, #pkts digest 10
#pkts decaps: 23, #pkts decrypt: 23, #pkts verify 23
#pkts compressed: 0, #pkts decompressed: 0
#pkts not compressed: 0, #pkts compr. Failed: 0, #pkts decompress failed: 0
#send errors 0, #recv errors 0
local crypto endpt.: 172.16.172.34, remote crypto endpt.: 172.16.172.39
path mtu 1500, ipsec overhead 56, media mtu 1500
current outbound spi: f264e92c
inbound ESP sas:
spi: 0x2772b869(661829737)
transform: ESP-Des esp-md5-hmac ,
in use settings ={Tunnel, }
slot: 0, conn id: 1, crypto map: mymap
sa timing: remaining key lifetime (k/sec): (4607997/2420)
IV size: 8 bytes
replay detection support: Y
inbound ah sas:
inbound PCP sas:
outbound ESP sas:
spi: 0xf264e92c(4066699564)
transform: ESP-Des esp-md5-hmac ,
in use settings ={Tunnel, }
slot: 0, conn id: 2, crypto map: mymap
sa timing: remaining key lifetime (k/sec): (4607999/2420)
IV size: 8 bytes
replay detection support: Y
outbound ah sas:
outbound PCP sas:

Nota: Quando o host 192.168.4.3 responde à requisição de eco, o pacote IP vem à interface interna do PIX.

38: Outbound ICMP echo reply (Len 32 id 2 seq 8960) 
   192.168.4.3 >192.168.4.3 > 10.1.2.1

Uma vez que o pacote IP chega na interface interna, o PIX verifica os 0 ACL nat 140 e determina que os endereços de rementente e destinatário do pacote IP combinam o ACL. Consequentemente, este pacote IP contorneia todas as regras NAT no PIX. Em seguida, os ACLs cript. são verificados. Desde que o mapa estático de criptografia tem o mais baixo número do exemplo, seu ACL é verificado primeiramente. Desde que este exemplo usa ACL 140 para o mapa estático de criptografia, o PIX verifica este ACL. Agora, o pacote IP tem um endereço de origem de 192.168.4.3 e um destino de 10.1.2.1. Desde que isto combina o ACL 140, o PIX pensa que este pacote IP está pretendido para o túnel IPSec de LAN para LAN com par 172.16.172.39 (contrário a nossos objetivos). Consequentemente, verifica o banco de dados SA para ver se há já um SA atual com par 172.16.72.39 para este tráfego. Enquanto a saída do comando show crypto ipsec sa mostra, nenhum SA existe para este tráfego. O PIX não cifra nem envia o pacote ao cliente VPN. Em lugar de, inicia uma outra negociação de IPSec com par 172.16.172.39 enquanto esta saída mostra:

crypto_isakmp_process_block: src 172.16.172.39, dest 172.16.172.34
return status is IKMP_NO_ERR_NO_TRANS02303: sa_request, (key eng. msg.)
src= 172.16.172.34, dest= 172.16.172.39,
src_proxy= 192.168.4.0/255.255.255.0/0/0 (type=4),
dest_proxy= 10.1.2.0/255.255.255.0/0/0 (type=4), protocol= ESP, transform=
ESP-Des esp-md5-hmac , lifedur= 28800s and 4608000kb,
spi= 0x0(0), conn_id= 0, keysize= 0, flags= 0x4004
702303: sa_request, (key Eng. msg.) src= 172.16.172.34, dest=
172.16.172.39, src_proxy= 192.168.4.0/255.255.255.0/0/0 (type=4),
dest_proxy= 10.1.2.0/255.255.255.0/0/0 (type=4), protocol= ESP, transform=
ESP-Des esp-md5-hmac , lifedur= 28800s and 4608000kb,
spi= 0x0(0), conn_id= 0, keysize= 0, flags= 0x4004
ISAKMP (0): sending NOTIFY message 36137 protocol 1
return status is IKMP_NO_ERR_NO_TRANSIPSEC(key_engine): request timer
fired: count = 2,
(identity) local= 172.16.172.34, remote= 172.16.172.39,
local_proxy= 192.168.4.0/255.255.255.0/0/0 (type=4),
remote_proxy= 10.1.2.0/255.255.255.0/0/0 (type=4)

A negociação de IPSec falha por estas razões:

  • O par 172.16.172.39 define somente as redes 10.10.10.0/24 e 192.168.4.0/24 como o tráfego interessante em seu ACL para o par 172.16.172.34 do crypto map.

  • As identidades de proxy não combinam durante a negociação de IPSec entre os dois pares.

  • Se o par inicia a negociação e a configuração local especifica o discrição perfeita adiante (PFS), o par deve executar uma troca PFS ou a negociação falha. Se a configuração local não especifica um grupo, um padrão do grupo1 está suposto, e uma oferta do grupo1 ou do grupo2 é aceitada. Se a configuração local especifica o grupo2, esse grupo deve ser parte da oferta do par ou a negociação falha. Se a configuração local não especifica o PFS, aceita toda a oferta do PFS do par. O grupo do módulo da prima 1024-bit Diffie-Hellman, grupo2, fornece mais Segurança do que o grupo1, mas exige mais tempo de processamento do que o grupo1.

    Nota: O comando crypto map set pfs ajusta o IPsec para pedir o PFS quando pede SA novos para esta entrada do crypto map. Use o comando no crypto map set pfs especificar que o pedido PFS do IPsec não. Este comando está somente disponível para entradas do mapa cript. IPsec-ISAKMP e entradas do mapa cripto dinâmico. Por padrão, o PFS não é solicitado. Com PFS, cada vez que um SA novo é negociado, um intercâmbio Diffie-Hellman novo ocorre. Isto exige o tempo de processamento adicional. O PFS adiciona um outro nível de segurança porque se uma chave é rachada nunca por um atacante, simplesmente os dados enviados com essa chave estão comprometidos. Durante a negociação, este comando faz com que o IPsec peça o PFS quando pede SA novos para a entrada do crypto map. O padrão (grupo1) é enviado se a indicação dos pfs do grupo não especifica um grupo.

    Nota: As negociações de IKE com um peer remoto podem pendurar quando um PIX Firewall tem os túneis numerosos que originam do PIX Firewall e terminam em um único peer remoto. Este problema ocorre quando o PFS não é permitido, e o peer local pede muitos simultâneos rekey pedidos. Se este problema ocorre, IKE SA não recupera até que cronometre para fora ou até você manualmente claro ele com o comando clear [crypto] isakmp sa. As unidades do PIX Firewall configuradas com muitos túneis a muitos pares ou a muitos clientes que compartilham do mesmo túnel não são afetadas por este problema. Se sua configuração é afetada, permita o PFS com o comando crypto map mapname seqnum set pfs.

Os pacotes IP no PIX são deixados cair finalmente.

Compreenda a solução

O método correto para retificar este erro é definir dois ACL separados para 0 nat e os mapas estáticos de criptografia. A fim fazer isto, o exemplo define ACL 190 para o comando nat 0 e usa o ACL alterado 140 para o mapa estático de criptografia, porque esta saída mostra.

PIX 520-1
pix520-1(config)#
pix520-1(config)#write terminal
Building configuration...
: Saved
:
PIX Version 6.0(1)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 2KFQnbNIdI.2KYOU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix520-1
domain-name vpn.com
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 1720
fixup protocol rsh 514
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names

!--- Access list 140 defines interesting traffic in order to bypass NAT for VPN.

access-list 140 permit ip 192.168.4.0 255.255.255.0 10.10.10.0255.255.255.0

!--- Defines VPN interesting traffic.

access-list 190 permit ip 192.168.4.0 255.255.255.0 10.10.10.0255.255.255.0
access-list 190 permit ip 192.168.4.0 255.255.255.0 10.1.2.0 255.255.255.0
no pager
logging on
logging console debugging
logging monitor debugging
logging buffered debugging
logging trap debugging
logging history debugging
logging host outside 192.168.2.6
interface ethernet0 auto
interface ethernet1 auto
mtu outside 1500
mtu inside 1500
ip address outside 172.16.172.34 255.255.255.240
ip address inside 192.168.4.50 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.1.2.1-10.1.2.254
no failover
failover timeout 0:00:00
failover poll 15
failover ip address outside 0.0.0.0
failover ip address inside 0.0.0.0
pdm history enable
arp timeout 14400
global (outside) 1 172.16.172.57 netmask 255.255.255.255

!--- The nat 0 command bypasses NAT for the packets destined over the IPsec tunnel..

Nat (inside) 0 access-list 190
Nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 172.16.172.33 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323
0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
AAA-server TACACS+ protocol tacacs+
AAA-server RADIUS protocol radius
AAA-server mytest protocol tacacs+
AAA-server nasir protocol radius
snmp-server host outside 192.168.2.6
no snmp-server location
no snmp-server contact
snmp-server community public
snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
no sysopt route dnat
crypto ipsec transform-set myset ESP-Des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset

!--- The crypto map commands define the IPsec SA (Phase II SA) parameters.

crypto map mymap 5 ipsec-isakmp
crypto map mymap 5 match address 140
crypto map mymap 5 set peer 172.16.172.39
crypto map mymap 5 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp key ******** address 172.16.172.39 netmask 255.255.255.255 no-xauth
no-config-mode
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption Des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption Des
isakmp policy 20 hash sha
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
vpngroup vpn3000 address-pool ippool
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet 192.168.4.0 255.255.255.0 inside
telnet 171.69.89.82 255.255.255.255 inside
telnet timeout 5
ssh 172.0.0.0 255.0.0.0 outside
ssh 171.0.0.0 255.255.255.0 outside
ssh 171.0.0.0 255.0.0.0 outside
ssh timeout 60
terminal width 80
Cryptochecksum:e2cb98b30d3899597b3af484fae4f9ae
: end
[OK]
pix520-1(config)# pix520-1(config)#show crypto map

Depois que as mudanças são feitas e o cliente estabelece um túnel de IPsec com o PIX, emita o comando show crypto map. Este comando mostra que para o mapa estático de criptografia, o tráfego interessante definido pelo ACL 140 é somente 192.168.4.0/24 e 10.10.10.0/24, que era o objetivo original. Além, a lista de acesso dinâmica mostra o tráfego interessante definido como o cliente (10.1.2.1) e o PIX (172.16.172.34).

pix520-1(config)#show crypto map
Crypto Map: "mymap" interfaces: { outside }
Crypto Map "mymap" 5 ipsec-isakmp
Peer = 172.16.172.39
access-list 140 permit ip 192.168.4.0 255.255.255.0 10.10.10.0255.255.255.0 
   (hitcnt=57)
Current peer: 172.16.172.39
Security association lifetime: 4608000 kilobytes/28800 seconds
PFS (Y/N): N
Transform sets={ myset, }
Crypto Map "mymap" 10 ipsec-isakmp
Dynamic map template tag: dynmap
Crypto Map "mymap" 20 ipsec-isakmp
Peer = 171.69.89.120
access-list dynacl4 permit ip host 172.16.172.34 host 10.1.2.1 (hitcnt=0)
dynamic (created from dynamic map dynmap/10)
Current peer: 171.69.89.120
Security association lifetime: 4608000 kilobytes/28800 seconds
PFS (Y/N): N
Transform sets={ myset, }
Crypto Map "mymap" 30 ipsec-isakmp
Peer = 171.69.89.120
access-list dynacl5 permit ip any host 10.1.2.1 (hitcnt=13)
dynamic (created from dynamic map dynmap/10)
Current peer: 171.69.89.120
Security association lifetime: 4608000 kilobytes/28800 seconds
PFS (Y/N): N
Transform sets={ myset, }

Quando o cliente VPN 10.1.2.1 envia um sibilo para hospedar 192.168.4.3, a resposta de eco vem à interface interna do PIX. O PIX verifica os 0 ACL nat 190 e determina que o pacote IP combina o ACL. Consequentemente, o pacote contorneia as regras NAT no PIX. Em seguida, o PIX verifica o mapa estático de criptografia ACL 140 a fim encontrar um fósforo. Esta época, a fonte e o destino do pacote IP não combinam o ACL 140. Consequentemente, o PIX verifica o ACL dinâmico e encontra um fósforo. O PIX verifica então seu banco de dados SA para ver mesmo se IPsec SA está estabelecido já com o cliente. Desde que o cliente tem estabelecido já uma conexão IPSec com o PIX, IPsec SA existe. O PIX então cifra os pacotes e envia-os ao cliente VPN. Use a saída do comando show crypto ipsec sa do PIX para ver que os pacotes estão cifrados e decifrados. Neste caso, o PIX cifrou dezesseis pacotes e enviou-os ao cliente. O PIX igualmente recebeu pacotes criptografado do cliente VPN e decifrou dezesseis pacotes.

pix520-1(config)#show crypto ipsec sa
interface: outside
Crypto map tag: mymap, local addr. 172.16.172.34
local ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/0/0)
remote ident (addr/mask/prot/port): (10.1.2.1/255.255.255.255/0/0)
current_peer: 171.69.89.120
dynamic allocated peer ip: 10.1.2.1
PERMIT, flags={}
#pkts encaps: 16, #pkts encrypt: 16,#pkts digest 16
#pkts decaps: 16, #pkts decrypt: 16, #pkts verify 16
#pkts compressed: 0, #pkts decompressed: 0
#pkts not compressed: 0, #pkts compr. Failed: 0, #pkts decompress failed: 0
#send errors 0, #recv errors 0
local crypto endpt.: 172.16.172.34, remote crypto endpt.: 171.69.89.120
path mtu 1500, ipsec overhead 56, media mtu 1500
current outbound spi: 613d083d
inbound ESP sas:
spi: 0x6adf97df(1793038303)
transform: ESP-Des esp-md5-hmac ,
in use settings ={Tunnel, }
slot: 0, conn id: 4, crypto map: mymap
sa timing: remaining key lifetime (k/sec): (4607998/27420)
IV size: 8 bytes
replay detection support: Y
inbound ah sas:
inbound PCP sas:
outbound ESP sas:
spi: 0x613d083d(1631389757)
transform: ESP-Des esp-md5-hmac ,
in use settings ={Tunnel, }
slot: 0, conn id: 3, crypto map: mymap
sa timing: remaining key lifetime (k/sec): (4607999/27420)
IV size: 8 bytes
replay detection support: Y
outbound ah sas:
outbound PCP sas:
local ident (addr/mask/prot/port): (192.168.4.0/255.255.255.0/0/0)
remote ident (addr/mask/prot/port): (10.10.10.0/255.255.255.0/0/0)
current_peer: 172.16.172.39
PERMIT, flags={origin_is_acl,}
#pkts encaps: 9, #pkts encrypt: 9, #pkts digest 9
#pkts decaps: 9, #pkts decrypt: 9, #pkts verify 9
#pkts compressed: 0, #pkts decompressed: 0
#pkts not compressed: 0, #pkts compr. Failed: 0, #pkts decompress failed: 0
#send errors 1, #recv errors 0
local crypto endpt.: 172.16.172.34, remote crypto endpt.: 172.16.172.39
path mtu 1500, ipsec overhead 56, media mtu 1500
current outbound spi: 58009c01
inbound ESP sas:
spi: 0x2d408709(759203593)
transform: ESP-Des esp-md5-hmac ,
in use settings ={Tunnel, }
slot: 0, conn id: 2, crypto map: mymap
sa timing: remaining key lifetime (k/sec): (4607998/3319)
IV size: 8 bytes
replay detection support: Y
inbound ah sas:
inbound PCP sas: outbound ESP sas:
spi: 0x58009c01(1476434945)
transform: ESP-Des esp-md5-hmac ,
in use settings ={Tunnel, }
slot: 0, conn id: 1, crypto map: mymap
sa timing: remaining key lifetime (k/sec): (4607999/3319)
IV size: 8 bytes
replay detection support: Y
outbound ah sas:
outbound PCP sas:
pix520-1(config)# sh cr isa sa
Total : 2
Embryonic : 0
dst src state pending created
172.16.172.39 172.16.172.34 QM_IDLE 0 1
172.16.172.34 171.69.89.120 QM_IDLE 0 2
pix520-1(config)# sh cr ipsec sa

Configuração do roteador e saída do comando show

Cisco 1720-1
1720-1#show run
Building configuration...
Current configuration : 1592 bytes
!
! Last configuration change at 21:08:49 PST Mon Jan 7 2002
! NVRAM config last updated at 18:18:17 PST Mon Jan 7 2002
!
version 12.2
no parser cache
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 1720-1
!
no logging buffered
enable secret 5 $1$6jAs$tNxI1a/2DYFAtPLyCDXjo/
enable password ww
!
username cisco password 0 cisco
memory-size iomem 15
clock timezone PST -8
ip subnet-zero
no ip domain-lookup
ip domain-name cisco.com
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
!

!--- The crypto isakmp policy command defines the Phase 1 SA parameters.

crypto isakmp policy 15
authentication pre-share
crypto isakmp key cisco123 address 172.16.172.34
!
!

!--- The crypto ipsec transform-set command defines IPsec encryption 
!--- and authentication algorithims.

crypto ipsec transform-set myset ESP-Des esp-md5-hmac
!
!

!--- The crypto map command defines the IPsec SA (Phase II SA) parameters..

crypto map vpn 10 ipsec-isakmp
set peer 172.16.172.34
set transform-set myset
match address 150
!
!
!
!
!
interface FastEthernet0
ip address 172.16.172.39 255.255.255.240
speed auto

!--- The crypto map applied to the outbound interface.

crypto map vpn
interface Ethernet0
ip address 10.10.10.1 255.255.255.240
speed auto
no ip route-cache
no ip mroute-cache
!
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.172.33
no ip http server
ip pim bidir-enable
!

!--- Access-list defines interesting VPN traffic.

access-list 150 permit ip 10.10.10.0 0.0.0.255 192.168.4.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
no login
line vty 5 15
login
!
no scheduler allocate
end
1720-1#

1720-1#show crypto isa sa
DST src state conn-id slot
172.16.172.39 172.16.172.34 QM_IDLE 132 0
1720-1#show crypto ipsec sa
interface: FastEthernet0
Crypto map tag: vpn, local addr. 172.16.172.39
local ident (addr/mask/prot/port): (10.10.10.0/255.255.255.0/0/0)
remote ident (addr/mask/prot/port): (192.168.4.0/255.255.255.0/0/0)
current_peer: 172.16.172.34
PERMIT, flags={origin_is_acl,}
#pkts encaps: 9 #pkts encrypt: 9 #pkts digest 9
#pkts decaps: 9, #pkts decrypt: 9, #pkts verify 9
#pkts compressed: 0, #pkts decompressed: 0
#pkts not compressed: 0, #pkts compr. Failed: 0, #pkts decompress failed: 0
#send errors 7, #recv errors 0
local crypto endpt.: 172.16.172.39, remote crypto endpt.: 172.16.172.34
path mtu 1500, media mtu 1500
current outbound spi: 2D408709
inbound ESP sas:
spi: 0x58009C01(1476434945)
transform: ESP-Des esp-md5-hmac ,
in use settings ={Tunnel, }

!--- IPsec SA 200 as seen in the show crypto engine connection active command.

slot: 0, conn id: 200, flow_id: 1, crypto map: vpn
sa timing: remaining key lifetime (k/sec): (4607998/3144)
IV size: 8 bytes
replay detection support: Y
inbound ah sas:
inbound PCP sas:
outbound ESP sas:
spi: 0x2D408709(759203593)
transform: ESP-Des esp-md5-hmac ,
in use settings ={Tunnel, }

!--- IPsec SA 201 as seen in the show crypto engine connection active command.

slot: 0, conn id: 201, flow_id: 2, crypto map: vpn
sa timing: remaining key lifetime (k/sec): (4607998/3144)
IV size: 8 bytes
replay detection support: Y
outbound ah sas:
outbound PCP sas:
1720-1#

1720-1#show crypto map
Interfaces using crypto map mymap:
Crypto Map "vpn" 10 ipsec-isakmp
Peer = 172.16.172.34
Extended IP access list 150
access-list 150 permit ip 10.10.10.0 0.0.0.255 192.168.4.0 0.0.0.255
Current peer: 172.16.172.34
Security association lifetime: 4608000 kilobytes/3600 seconds
PFS (Y/N): N
Transform sets={ myset, }
Interfaces using crypto map vpn: FastEthernet0 

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 18957