IP : Enhanced Interior Gateway Routing Protocol (EIGRP)

Impedindo IDs duplicados de roteadores EIGRO

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

O roteador duplicado ID do Enhanced Interior Gateway Routing Protocol (EIGRP) pode causar problemas com a redistribução das rotas externas de EIGRP. Este documento explica o problema e fornece a configuração apropriada para impedi-la.

Normalmente, o ID do roteador EIGRP é selecionado da mesma maneira que o Open Shortest Path First (OSPF). O endereço IP mais alto atribuído a uma interface de loopback é selecionado como a ID do roteador. Se não há nenhuns endereços de loopback configurada, o endereço IP de Um ou Mais Servidores Cisco ICM NT o mais alto atribuído a toda a outra relação está escolhido como o Router ID.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Esta configuração foi desenvolvida e testada usando o Software Release 12.2(10b) do½ do¿Â do Cisco IOSïÂ.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Problema

O problema que é encontrado com as rotas redistribuída devido à presença de roteadores com EIGRP Router duplicado ID pode ser compreendido com a ajuda desta instalação de rede.

Diagrama de Rede

eigrp-dup-id.jpg

Configurações

Roteador 4
interface Loopback0

 ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

 ip address 10.10.10.10 255.255.255.0

!

interface Ethernet0

 ip address 172.16.3.4 255.255.255.0

!

router rip

 version 2

 network 10.0.0.0

 network 172.16.0.0

Roteador 3
interface Loopback0

 ip address 2.2.2.2 255.255.255.255

!

interface Ethernet0

 ip address 172.16.3.3 255.255.255.0

 ip pim sparse-dense-mode

!

interface Serial1

 ip address 172.16.13.3 255.255.255.0

 clockrate 4000000

!

router eigrp 7

 redistribute rip metric 1 1 1 1 1

 network 172.16.0.0

!

router rip

 version 2

 network 172.16.0.0

Roteador 1
interface Loopback0

 ip address 2.2.2.2 255.255.255.0

!

interface Serial1

 ip address 172.16.13.1 255.255.255.0

 no ip mroute-cache

!

router eigrp 7

 network 172.16.0.0

 auto-summary

 no eigrp log-neighbor-changes

comandos show

Como mostrado previamente, o roteador3 redistribui rotas do Routing Information Protocol (RIP) no EIGRP. Este é os 3 tabela de roteamento e tabela de topologia de EIGRP.

Router-3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
R    10.0.0.0/8 [120/1] via 172.16.3.4, 00:00:25, Ethernet0 
!--- Router 3 sees network 10.0.0.0.

     172.16.0.0/24 is subnetted, 3 2 subnets
C       172.16.13.0 is directly connected, Serial1
C       172.16.3.0 is directly connected, Ethernet0
router-3#


router-3#show ip eigrp topology 10.0.0.0 255.0.0.0
IP-EIGRP (AS 7): topology entry for 10.0.0.0/8
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560000256
  Routing Descriptor Blocks:
  0.0.0.0, from Redistributed, Send flag is 0x0
      Composite metric is (2560000256/0), Route is External
      Vector metric:
        Minimum bandwidth is 1 Kbit
        Total delay is 10 microseconds
        Reliability is 1/255
        Load is 1/255
        Minimum MTU is 1
        Hop count is 0
      External data:
        Originating router is 2.2.2.2 (this system)
!--- Shows that Router 3 is the originating router of the external route.

        AS number of route is 0
        External protocol is RIP, external metric is 1
        Administrator tag is 0 (0x00000000)
router-3#

Da saída precedente, você pode ver que o roteador3 aprendeu sobre a rede 10.0.0.0 através do RASGO. Com a redistribução, a rota foi entrada na tabela de topologia de EIGRP como uma rota externa. O roteador3 igualmente mostra que é o roteador de origem da rota externa; seu EIGRP Router ID é 2.2.2.2.

Desde que o roteador3 parece redistribuir a rota externa, espera-se vê-la na tabela de roteamento do roteador1. Este é o indicador da tabela de roteamento e da tabela de topologia de EIGRP para o roteador1.

router-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 3 2 subnets
C       172.16.13.0 is directly connected, Serial1
D       172.16.3.0 [90/2195456] via 172.16.13.3, 00:31:59, Serial1
router-1#


router-1# show ip eigrp topology
IP-EIGRP Topology Table for AS(7)/ID(2.2.2.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.16.13.0/24, 1 successors, FD is 2169856
         via Connected, Serial1
P 172.16.3.0/24, 1 successors, FD is 2195456
         via 172.16.13.3 (2195456/281600), Serial1
router-1#

Da saída precedente você pode ver que a rota prevista de 10.0.0.0/8 não está na tabela de roteamento ou na tabela de topologia de EIGRP do roteador1. O provável motivo disto é que os roteadores 1 e 3 têm o mesmo ID de roteador EIGRP. No Cisco IOS Software Release 12.0(2) e Mais Recente, Cisco grava os ID do roteador duplicado no log de eventos EIGRP, que você pode ver com o comando show ip eigrp events. Esta é a saída desta para o roteador1:

router-1 #show ip eigrp events 
Event information for AS 7:
1    18:06:15.863 Change queue emptied, entries: 1
2    18:06:15.863 Ignored route, metric: 10.0.0.0 2560512256
3    18:06:15.863 Ignored route, neighbor info: 172.16.13.3 Serial2
4    18:06:15.863 Ignored route, dup router: 2.2.2.2


!--- Output suppressed.

Da saída precedente você pode ver que o ID do roteador duplicado é a razão que o roteador1 não aceita a rota do roteador3.

Solução

A solução é mudar o Router ID em um do Roteadores mudando o endereço IP de Um ou Mais Servidores Cisco ICM NT o mais alto na interface de loopback. Se você Cisco IOS Software Release 12.1(6) ou Mais Recente do ause, você pode igualmente usar o subcomando de roteador do <router-id> roteador-identificação do eigrp a fim mudar o Router ID. Nesse exemplo, alteramos o ID do roeador no Roteador 1.

router-1(config)#router eigrp 7 
router-1(config-router)#eigrp router-id 3.3.3.3

Nota: Eigrp da edição IP < comando claros do sistema autônomo depois que você muda o Router ID de Eigrp.

A rota externa aparece agora na tabela de roteamento como mostrado aqui.

router-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, IA - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.13.0 is directly connected, Serial1
D       172.16.3.0 [90/2195456] via 172.16.13.3, 00:00:00, Serial1
D EX 10.0.0.0/8 [170/2560512256] via 172.16.13.3, 00:00:00, Serial1
router-1# 

Informações Relacionadas


Document ID: 18685