Qualidade de Serviço (QoS) : Regulamentação QoS

Configurando a marcação de pacote em PVCs de Frame Relay

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Abril 2015) | Feedback


Índice


Introdução

Este revisões de documento os comandos suportados configurar o pacote que marca sobre interfaces do Frame Relay.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não é restrito a versões de software ou hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Consulte as Convenções de Dicas Técnicas da Cisco para obter mais informações sobre convenções de documentos.

Marcação do pacote baseado em classe

A marcação do pacote baseado em classe usa comandos set e outros comandos do comando line interface(cli) da Qualidade de Serviço modular (QoS) mudar o valor de um campo em um cabeçalho de pacote de informação.

Os software release atuais do ½ do ¿  de Cisco IOSï permitem que você faça estas ações:

  • Ajuste os bit de precedência IP ou o Differentiated Services Code Point IP (DSCP) no byte do tipo do IP de serviço (ToS).

  • Ajuste o valor do Classe de serviço (CoS) da camada 2.

  • Associe um valor de grupo local de QoS com um pacote.

  • Mude o ajuste do bit da prioridade de perda da célula (CLP) no encabeçamento de ATM de um pacote de 0 a 1.

Ambas as políticas da entrada e saída são apoiadas. Quando você está configurando o Class-based Marking, note estas limitações:

  • As políticas emissora exigem o Frame Relay Traffic Shaping (FRTS).

  • Somente os pacotes comutados por Cisco Express Forwarding são apoiados.

  • Um mapa de política que contém o comando set atm-clp pode ser anexado como uma política emissora somente.

Este é um exemplo de como o valor DSCP é ajustado:

Exemplo de configuração - Class-based Marking
class-map user1
  match access-group 101
!
class-map user2
  match access-group 102
!
policy-map dscp
  class user1
    set ip dscp AF11
  class user2
    set ip dscp AF12
!
map-class frame set-dscp
  service-policy input dscp
!
int s0/0/0:0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
int s0/0/0:0.125
 frame-relay interface-dlci 125
  class set-dscp

Configurando o bit elegível de descarte

O Modular QoS CLI apoia dois comandos mudar o valor do elegível de descarte (DE) mordido em um quadro do Frame Relay. Aqueles comandos são FR-de ajustado com modelagem baseada em classe, e set-frde-transmit com class-based policing.

Nota: O comando set-frde-transmit não se aplica ao tráfego do Frame Relay transportado através de nenhum transporte sobre MPLS (átomo).

Suportes do Frame Relay um esquema de dois níveis da priorização de pacote usando o DE bit. Originalmente, somente os dispositivos de rede, tais como Frame Relay Switch, ajustaram o DE bit para indicar a importância relativa de um quadro. Em Cisco IOS Software Release recentes, o Roteadores agora pode ajustar o DE bit.

O diagrama seguinte ilustra o formato de um quadro do Frame Relay. O DE bit é um de três bit que controlam os mecanismos da notificação de congestionamento do Frame Relay.

/image/gif/paws/18662/config_fr_pvc.gif

Emita estes comandos monitorar o Class-based Marking:

  • pvc do show frame-relay — Indica estatísticas para todos os componentes de Circuitos Virtuais Permanentes (PVC). Isto inclui estas estatísticas:

    • FRTS e informação da política de serviços

    • fragmentação

    • o número de pacotes dentro e para fora

    • o número de quadros com a notificação de congestionamento explícita retrógrada (BECN), a notificação de congestionamento explícito adiante (FECN), e o grupo de DE bit

Exemplo de configuração - Harmonização no DE Bit
class-map match-fr-de
  match fr-de

!--- Define a class-map named “match-fr-de” to match packets with the FR DE bit set.

!
policy-map set-de
  class match-fr-de
   set ip precedence 1

!--- All packets that match the class have IP precedence set to 1.

!
map-class frame-relay pvc150
   service-policy input set-DE

!--- Apply the policy map to the map class.

!
interface Serial0.1 point-to-point
   frame-relay class pvc150
   frame-relay interface-dlci 150

!--- Associate a map class to the Frame Relay data-link connection identifier (DLCI).

Router# show policy-map interface s0.1

Serial0.1

 Service-policy input: set-prec

   Class-map: match-fr-de (match-all)
     358 packets, 103820 bytes
     30 second offered rate 18000 bps, drop rate 0 BPS  Match: fr-de
     QoS Set
       ip precedence  1
         Packets marked 359

   Class-map: class-default (match-any)
     643 packets, 186470 bytes
     30 second offered rate 32000 BPS, drop rate 0 BPS
     Match: any  (1201)

Apoio introduzido Cisco IOS Software Release 12.2(2)T para ajustar o DE bit com a opção do set-frde-transmit como parte do comando police. (Para mais informação, refira o Policiamento de tráfego.) Pode igualmente ser útil ajustar o DE bit quando usado com mecanismos de limitação de taxa, como o class-based policing. O objetivo de tal política de QoS é transmitir pacotes sem adequação com o Frame Relay e jogo do bit DE, de modo que o Switches a jusante possa potencialmente deixar cair todo o tráfego sem adequação durante condições de congestionamento.

Nota: Embora o class-based policing apoie a marcação do pacote, recomenda-se que você usa esta característica somente se você precisa de marcar pacotes para evitar os executar através do mecanismo do Token Bucket do vigilante.

O exemplo de configuração seguinte usa o comando police limitar o tráfego agregado a 800 kbps. Todo o tráfego que se conforma é transmitido com uma Precedência IP de 7, e todo o tráfego sem adequação tem o jogo do bit DE.

Exemplo de configuração - Ajustando o DE Bit
policy-map set-DE
  class class-default
   police 800000 1000 1000 conform-action
   set-prec-transmit 7 exceed-action set-frde-transmit
   violate-action set-frde-transmit
!
map-class frame-relay pvc100
  frame-relay traffic-rate 1000000
  frame-relay mincir 1000000
  service-policy input set-DE
!
interface S0/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
interface Serial0/0.1 point-to-point
  ip address 10.1.1.1 255.255.255.252
  no ip directed-broadcast
  frame-relay class pvc100
  frame-relay interface-dlci 100

router# show policy-map set-DE

 Policy Map set-DE
    Class class-default
      police 800000 1000 1000 conform-action
      set-prec-transmit 7 exceed-action
      set-frde-transmit violate-action
      set-frde-transmit

router# show frame-relay PVC 100

PVC Statistics for interface Serial0 (Frame Relay DTE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0.1

input pkts 0       output pkts 13000    in bytes 0
out bytes 3770000  dropped pkts 0       in FECN pkts 0
in BECN pkts 0     out FECN pkts 0      out BECN pkts 0
in DE pkts 0       out DE pkts 4447
out bcast pkts 0   out bcast bytes 0
PVC create time 00:51:50, last time PVC status changed 00:51:50

service policy set-DE

  Service-policy output: set-DE (1069)

   Class-map: class-default (match-any) (1071/2)
     11519 packets, 3340510 bytes
     30 second offered rate 1140000 BPS, drop rate 0bps
      Match: ip precedence 1  (1075)
      police:
        800000 BPS, 1000 limit, 1000 extended limit
        conformed 4448 packets, 1289920 bytes; action:
        set-prec-transmit 7
        exceeded 11 packets, 3190 bytes; action:
        set-frde-transmit
        violated 8475 packets, 2457750 bytes; action:
        set-frde-transmit
        conformed 394000 BPS, exceed 1000 BPS violate
        749000 BPS
   Output queue size 20/max total 600/drops 1451

Quando você está testando sua configuração, note esta informação:

  • O Class-based Marking exige o Cisco Express Forwarding. Emita o comando ip cef no modo de configuração global, permitir o Cisco Express Forwarding, se não é permitido já.

  • Originalmente, o Class-based Marking aplicou-se somente aos pacotes que eram comutados por Cisco Express Forwarding. Assim, você não veria o incremento de contadores de pacote compatíveis se você usava o sibilo para gerar o tráfego no mesmo roteador, porque tais pacotes são comutados por processo.

  • O apoio para o Class-based Marking dos pacotes gerados por roteador é introduzido no Cisco IOS Software Release 12.2(6.8)T.

Escolha de onde aplicar uma política de serviço

No Cisco 7200 Series, o Cisco 2600/3600 Series, e outras Plataformas da NON-rota/processador de switch (RSP), uma política de serviços deve ser aplicados dentro de uma classe de mapas; não pode ser aplicada diretamente ao PVC do Frame Relay. As políticas emissora exigem o FRTS, que você permite com o comando frame-relay traffic-shaping. Este comando configura filas PVC. Assim, uma política de serviços geralmente deve ser configurada no modo de configuração dlci ou no PVC.

Em Cisco IOS Software Release atuais, as interfaces do Frame Relay apoiam o aplicativo de um mapa de política (com o comando service-policy) às relações, às subinterfaces, e aos VC. Esta tabela alista as combinações apoiadas de políticas:

Política de entrada Política de saída
Apoiado em uma interface lógica. Apoiado nas interfaces lógica múltiplas que devem ser pares, tais como PVC múltiplos.

Nota: Uma interface principal e uma subinterface não são interfaces de peer e não podem apoiar uma política de serviços ao mesmo tempo.

Apoiado em uma ou dois interfaces lógica simultaneamente. Combinações válidas:
  • PVC e interface principal
  • Subinterface e interface principal
Combinações inválidas:
  • PVC e subinterface
  • PVC, subinterface, e interface principal

Originalmente, a configuração de uma política de serviços com o comando set diretamente em uma interface principal não marcou o tráfego da subinterface. Isto ilustra sintomas deste problema:

Interface Serial5/1:1
no ip address
 encapsulation frame-relay
 no keepalive
 service-policy output set

!--- Avoid the placement of a service policy on a main interface.

 no fair-queue
 frame-relay class data-map
 frame-relay traffic-shaping
!
interface Serial5/1:1.1 point-to-point
 ip address 23.0.0.2 255.0.0.0
 frame-relay interface-dlci 300

giulia# show policy-map interface

 Serial5/1:1

  Service-policy output: set

    Class-map: prec-0 (match-all)
      100 packets, 10400 bytes

!--- Packets are classified correctly.

      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: ip precedence 0
      QoS Set
        ip precedence 1
          Packets marked 0

!--- No packets are marked.


    Class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any

Como uma ação alternativa, aplique a política de serviços à subinterface.

Sintaxe herdada – Listas de DE

Nos Cisco IOS Software Release que não apoiam a sintaxe nova do Modular QoS CLI de Cisco, você pode usar a sintaxe de DE marcação do legado Cisco para ajustar o DE bit. A sintaxe legada usa DE lista que identifica as características de pacotes para ser elegível para o descarte, e você pode igualmente especificar DE grupo para identificar o DLCI que é afetado.

Router(config)# frame-relay de-list list-number 
              {protocol protocol | interface typenumber} characteristic


!--- Issue this command on one line.

Você pode criar DE lista baseada no protocolo ou na relação, e baseada em várias características tais como a fragmentação do pacote, de uma porta específica do protocolo Protocolo de control de transmisión (TCP) (TPC) ou do User Datagram Protocol (UDP), um access list number, ou um tamanho do pacote. Refira o comando frame-relay de-list na referência do comando wide-area networking do Cisco IOS para mais informações.

Para definir um DE grupo que especifique o DE lista e o DLCI afetado, emita o comando frame-relay de-group group-number dlci no modo de configuração da interface.


Informações Relacionadas


Document ID: 18662