Qualidade de Serviço (QoS) : Regulamentação QoS

Configurando o CBWFQ em PVCs de Frame Relay

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (1 Julho 2009) | Inglês (22 Abril 2015) | Feedback


Índice


Introdução

Este documento oferece configurações de exemplo para o CBWFQ (Enfileiramento Justo e Ponderado Baseado em Classes) de uma interface Frame Relay. O CBWFQ é habilitado com o comando de largura de banda, conforme configurado em um mapa de políticas com os comandos do QoS CLI modular (Qualidade de Serviços – Interface de Linha de Comando).

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

O CBWFQ é apoiado até à data dos seguintes software release do ½ do ¿  de Cisco IOSï segundo a plataforma:

  • Cisco 7500 Series com VIP (Processadores de Interface Versáteis) (CBWFQ distribuído) - 12.1(5)T

  • Cisco série 7200, séries 2600/3600 e outras plataformas não da série 7500 - 12.1(2)T

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Modelagem e enfileiramento

Enfileirar-se é usado geralmente no contexto de dar forma, que reduz a taxa de emissor e induz assim a congestão. Use o CBWFQ com os seguintes mecanismos moldados e os comandos segundo sua plataforma.

  Cisco 7500 Series Cisco 7200, 3600, 2600 e outras plataformas não-VIP
Mecanismos de modelagem suportados Distributed Traffic Shaping (DTS) Modelagem de Tráfego de Frame Relay (Frame Relay TS)
Comando de configuração comando shape em um mapa de políticas modelagem de tráfego frame-relay em uma interface principal, comandos map-class de configuração para especificar parâmetros de modelagem
Exige dCEF (distributed Cisco Express Forwarding) Sim (verifique com o comando show cef linecard) Não

Cisco 7200, 3600, 2600 Series

O Cisco IOS 12.1(2)T introduz o apoio para o CBWFQ nos 7200, em 2600/3600, e em outras Plataformas do Non-Route Switch Processor (RSP). (Para mais informação, refira o low latency queueing (o LLQ) sobre o Frame Relay.) Nestas Plataformas, o CBWFQ em interfaces do Frame Relay está sempre no contexto do Frame Relay TS. Use o comando frame-relay traffic-shaping para habilitar o TS do frame relay. Não é possível usar CBWFQ com GTS (Generic Traffic Shaping) e o comando de modelagem dessas plataformas. Uma configuração de exemplo é fornecida a seguir.

Exemplo de Configuração de CBWFQ no Cisco 7200, 3600, 2600 Series
 policy-map mypolicy 
  class voice 
   priority 16 
  class priority-data 
   bandwidth 16 

!--- Create a policy-map and apply the bandwidth 
!--- command to a class. 

! 
 int s0/0 
  encapsulation frame-relay IETF 
  load-interval 30 
  frame-relay traffic-shaping 

!--- Enable Frame Relay TS. 

! 
 interface Serial0/0.1 point-to-point 
  frame-relay interface-dlci 100 
    class frclass 

!--- Apply the map-class to the Frame Relay PVC. 

! 
 map-class frame-relay frclass 
  service-policy output mypolicy 
  frame-relay cir 64000 
  frame-relay bc 640 

!--- Apply the service policy inside the map-class.

Nota: Se você permite uma política de serviços diretamente em uma interface principal e não dentro de um comando map-class, você igualmente não pode aplicar o Frame Relay TS diretamente à relação. É importante notar que os mecanismos de filas a seguir se aplicam a uma única grande fila de interface um pouco do que às filas do Per-Virtual Circuit (VC)

No Cisco 7200 Series, da versão 12.0(26)S e mais recente do Cisco IOS Software, não é possível configurar anymore uma política de serviço de emissor em um comando frame-relay map-class. Em lugar da configuração do Cisco 7500 deve ser aplicada como explicado na seguinte seção. Um mapa de política hierárquico deve ser configurado com dar forma em uma política de parentes e o enfileiramento em uma política infantil. A política de parentes deve então ser anexada ao cano principal ou à subinterface. Se você tenta configurar umas saídas de política de servidor no comando map-class frame-relay, o seguinte Mensagem de Erro aparecerá:

c7200(config)#map-class frame-relay
	 stef
c7200(config-map-class)#frame-relay cir
	 64000
c7200(config-map-class)#service-policy output
	 aan
Frame relay output service policy is not
	 supported

Cisco 7500 Series

Até à data do Cisco IOS 12.1(5)T, as políticas de QoS devem ser executado no modo distribuído no VIP; porque o QoS com base em RSP é apoiado já não. Assim, você deve usar o comando shape e outros comandos do Modular QoS CLI executar o DTS para interfaces do Frame Relay em VIP no Cisco 7500 Series. DTS combina GTS e Frame Relay TS. Uma configuração de exemplo é fornecida em Configuring Distributed Traffic Shaping (Configurando modelagem de tráfego distribuído) e abaixo.

Exemplo de configuração de DTS com uma política de hierarquia
ip cef distributed 
 !  
 class-map 1  
   match < >  

!--- Define match-on criteria.

 class-map 2  
   match < >

!--- Define match-on criteria.

 !  
 policy-map CBWFQ  
   class 1  
     bandwidth < >  
     !-- Define value in kbps or percent.  
   class 2  
     priority < > 
 
!--- Define value in kbps or percent.

 !  
 Policy-map SHAPE  
    class class-default  
     shape average    
     service-policy CBWFQ  
 !  
 int s0/0/0  
   encapsulation frame-relay  
   ip route-cache distributed  
 !  
 int s0/0/0.1 point-to-point  
   ip address a.b.c.d  
   frame-relay interface-dlci xxx  
    class cisco  
 !  
 map-class frame-relay cisco  
   service-policy output SHAPE

Escolha de onde aplicar uma política de serviço

Ao configurar o CBWFQ, você usa os comandos do modular QoS CLI para criar um mapa de política de tráfego com várias classes de tráfego e um ou mais recursos de QoS. Nas versões atual do Cisco IOS Software, as interfaces do Frame Relay apoiam a aplicação de um mapa de política com o comando service-policy às relações, às subinterfaces, e aos VC. Apenas as combinações corretas de políticas são suportadas agora. A tabela seguinte descreve especificamente onde é possível aplicar uma política de QoS com modelagem de tráfego.

  Cisco 7500 Series Cisco 7200, 2600/3600 Series, e outras Plataformas
Interface principal Configurar uma política de serviços na interface principal Apoiado somente se o Frame Relay TS não é permitido e os mecanismos de filas aplicam-se a uma tubulação da interface única.
Subinterface Configure uma política de serviço na subinterface. Configure uma política de serviços em uma classe de mapa de Frame Relay e habilite o enfileiramento por VC com o comando frame-relay traffic-shaping. Você pode aplicar a classe de mapa à subinterface.
Nível de VC   Configurar uma serviço-política dentro de uma classe de mapa do Frame Relay e permita a fila por voz com o comando frame-relay traffic-shaping. Você pode aplicar a classe de mapas ao VC.

Problemas conhecidos

Ao configurar o CBWFQ em interfaces do Frame Relay, note as seguintes advertências:

  • Após o recarregamento de um roteador, os contadores de correspondência de pacotes de uma política de serviço talvez não sejam incrementados quando a política for aplicada à interface principal. Para solucionar esse problema, certifique-se de que os flags de classificação de WFQ (Weighted Fair Queueing) sejam copiados da interface principal para as subinterfaces.

  • Não há suporte para configuração do LLQ e do Frame Relay TS ao mesmo tempo no nível de interface física. O roteador remove a política de serviços da configuração running após um recarregamento de roteador. A política de serviços deve ser anexada à classe de mapas quando o Frame Relay TS é permitido na relação. Tentar configurar esta combinação conduz ao Mensagem de Erro CBWFQ: Não apoiado nesta relação.

  • Quando uma política de serviços com CBWFQ estiver aplicada diretamente a uma interface principal do Frame Relay (como, não à fila por voz), a política pode ser removida depois de um recarregamento de roteador se as instruções de largura de banda são configuradas em uma subinterface e em uma interface principal. O roteador pode relatar mensagens de registro semelhantes às seguintes:

    CBWFQ: Not enough available bandwidth for all classes Available 44 (kbps) 
        Needed 1 00 (kbps)
        CBWFQ: Removing service policy on Serial1/0

    Este problema está resolvido mudando o comportamento do CBWFQ para ignorar as notificações quando a largura de banda na subinterface é mudada, desde que o CBWFQ pode ser configurado fora de uma classe de mapa do Frame Relay somente a nível da interface principal. Como uma ação alternativa, remova o comando bandwidth da subinterface. Se estiver usando largura de banda na subinterface para influenciar a métrica de roteamento, use um método alternativo como custo, como no protocolo OSPF ou retardo, como no protocolo EIGRP.

Notas de configuração

  • Quando os comandos de largura de banda e prioridade calculam a quantidade total de largura de banda disponível em uma entidade, as seguintes orientações são invocadas quando a entidade é modelada como um PVC (circuito virtual permanente) do Frame Relay:

    • Se uma Minimum Acceptable Committed Information Rate (minCIR) não estiver configurada, o CIR é dividido em dois.

    • Se um minCIR estiver configurado, a definição do minCIR será usada no cálculo.

    • A largura de banda completa da taxa descrita acima pode ser atribuída a classes de largura de banda e de prioridades. Portanto, o comando max-reserved-bandwidth não é suportado em PVCs de Frame Relay, embora você deva garantir que a quantidade de largura de banda configurada seja grande o suficiente para acomodar também o overhead da Camada 2 (L2). Para mais informação, refira que bytes são contados pelo enfileiramento do IP to ATM CoS?.

  • Evite ajustar o CIR ou o mincir na taxa de acesso. Caso contrário, você pode ver filas de saída aumentando e gerando grandes retardos nas classes CBWFQ. A razão é que a taxa de forma não leva em consideração os campos de bytes de overhead do flag e Verificação de redundância cíclica (CRC), portanto a modelagem na taxa de linha está, na verdade, com excesso de assinaturas e provocará o congestionamento da interface. Realmente não há motivo para moldar a taxa de acesso. Você deve sempre traficar a forma em 95 por cento da taxa de acesso ou, mais geralmente, a taxa dada forma agregada deve sempre ser 95 por cento abaixo da taxa de acesso.

  • Quando o FRF.12 está configurado, o tamanho da fila de saída aumenta para acomodar o mesmo número de bytes que estão fragmentados agora. Ou seja você vai de uma fila de pacote a uma fila do fragmento.

  • O WFQ por VC está incluso no Software Cisco IOS versão 12.0(7)T.

  • O CBWFQ com GTS é incluído na versão 12.1(2)T do Cisco IOS Software.


Informações Relacionadas


Document ID: 18661