Qualidade de Serviço (QoS) : Regulamentação QoS

Formatação de tráfego frame relay com o QoS distribuído no Cisco 7500 Series

12 Agosto 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (3 Abril 2008) | Inglês (23 Abril 2015) | Feedback


Índice


Introdução

Este documento esclarece as diferenças entre o aplicativo do modelagem de tráfego às interfaces do Frame Relay em Cisco 7500 Series Router com o Versatile Interface Processors (VIP) e em outras Plataformas. As outras Plataformas incluem o Cisco 7200, os 3600, e os 2600 Series Router.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

Até à data do Software Release 12.1(5)T de Cisco IOS�, as políticas do Qualidade de Serviço (QoS) devem ser executado no modo distribuído no VIP; O Route Switch Processor (RSP) - QoS baseado é apoiado já não. Assim, você deve usar o comando shape e outros comandos da interface de linha de comando do QoS modular (MQC) a fim executar o Distributed Traffic Shaping (DTS) para interfaces do Frame Relay em VIP no Cisco 7500 Series. O DTS combina o Generic Traffic Shaping (GTS) e o Formatação de tráfego frame relay (Frame Relay TS). Refira configurar o Distributed Traffic Shaping para uma configuração de exemplo.

Esta tabela esclarece como configurar o Frame Relay TS, que depende da plataforma:

7500 Series 7200, 3600, 2600 e Outras Plataformas Não-VIP
Mecanismos de modelagem suportados DTS Frame Relay TS
Comando de configuração comando shape em um mapa de política modelagem de tráfego do Frame Relay em uma interface principal; comandos de configuração de classe de mapas especificar parâmetros moldados
Exige o dCEF1 Sim (verifique com o comando show cef linecard.) Não

1 dCEF = Distributed Cisco Express Forwarding

Nota: No Cisco 7500 Series, a capacidade para configurar o Frame Relay TS através do comando frame-relay traffic-shaping é obstruída agora porque o Frame Relay TS executa somente o RSP em um modo não distribuído. Com dCEF e Frame Relay TS, uma adjacência do “pontapé” CEF faz com que o RSP jejue o interruptor todos os pacotes, que é suboptimal para o desempenho de encaminhamento máximo.

Passos de configuração

Use estas etapas para configurar o DTS em interfaces do Frame Relay com base em VIP:

  1. Permita o dCEF com este comando:

    router(config)# ip cef distributed
    
  2. Assegure-se de que a interface do Frame Relay esteja permitida para o Distributed Switching.

    router(config-if)# interface serial 8/0/0 
    router(config-if)# ip route-cache distributed
    
    router# show ip interface serial 8/0/0 
    Serial8/0/0 is up, line protocol is up 
      Internet address is 24.0.0.2/24 
      Broadcast address is 255.255.255.255 
     
    !--- Output suppressed.
     
      ICMP redirects are always sent 
      ICMP unreachables are always sent 
      ICMP mask replies are never sent 
      IP fast switching is enabled 
      IP fast switching on the same interface is disabled 
      IP Flow switching is disabled 
      IP CEF switching is enabled 
      IP Distributed switching is enabled 
      IP Fast switching turbo vector 
      IP CEF switching with tag imposition turbo vector 
      IP multicast fast switching is enabled 
      IP multicast distributed fast switching is disabled 
      IP route-cache flags are Fast, Distributed, CEF 
      Router Discovery is disabled 
      IP output packet accounting is disabled
  3. Crie uma política de serviços e aplique-a ao map class.

    Você pode executar uma destas políticas:

    Nota: Quando o Cisco IOS Software Release 12.1(2)T introduziu o apoio para o low latency queueing (LLQ) em Plataformas diferentes do Cisco 7500 Series, o LLQ distribuído (dLLQ) foi introduzido no Cisco IOS Software Release 12.1(5)T no VIP. A versão distribuída aumenta o desempenho desta característica. Você pode configurar uma política de serviço exclusivo pelo identificador da conexão de link de dados (DLCI). Você não precisa de usar um map class. Você pode aplicar o comando service-policy diretamente à subinterface ou ao DLCI. Contudo, configurar o dLLQ dentro de um map class.

  4. Verifique a operação correta de sua política de serviços com estes comandos:

    • show policy-map interface

    • show interface shape

    • show vip full-qos

    Configuração de exemplo do DTS com uma política hierárquica
    ip cef distributed 
    ! 
    class-map 1 
      match <> 
      
    !--- Define match-on criteria.
     
    class-map 2 
      match <> 
      
    !--- Define match-on criteria.
     
    ! 
    policy-map CBWFQ 
      class 1 
        bandwidth <>  
        
    !--- Define the value in kbps or percent.
     
      class 2 
        priority <>  
        
    !--- Define the value in kbps or percent.
     
    ! 
    policy-map SHAPE 
       class class-default 
        shape average   
        service-policy CBWFQ 
    ! 
    int s0/0 
      encapsulation frame-relay 
      ip route-cache distributed 
    
    !--- Do not configure frame-relay traffic-shaping.
    
    ! 
    int s0/0.1 point-to-point 
      ip address a.b.c.d 
      frame-relay interface-dlci xxx 
       class cisco 
    ! 
    map-class frame-relay cisco 
      service-policy output SHAPE

FRF.12 e DTS

O Cisco IOS Software versão 12.1(5)T introduziu uma versão distribuída da fragmentação do Frame Relay, FRF.12. Quando você aplica o FRF.12 distribuído a uma interface do Frame Relay, você deve definir um map class e aplicar a política de serviços sob o map class. Se você tenta configurar um map class com a política de serviços aplicada diretamente à relação, seus relatórios de roteador este Mensagem de Erro com o console de registro permitido:

Frame Relay fragmentation works with dTS only. 
Please remove traffic-shaping from the interface serial 1/0/0

A configuração nesta seção e os comandos configuration verification foram testados em um Cisco 7500 Series Router que executasse o Cisco IOS Software Release 12.2(5)T em um RSP8.

Nota: Refira o VOIP sobre o Frame Relay com Qualidade de Serviço (fragmentação, modelagem de tráfego, prioridade RTP LLQ/IP) para obter mais informações sobre da seleção dos valores de fragmentação.

Exemplo de configuração de DTS e FRF.12
interface Ethernet4/1/3 
 ip address 10.122.3.206 255.255.255.0 
! 
interface Serial5/0/0:0 
 no ip address 
 encapsulation frame-relay 
 load-interval 30 
 no fair-queue 

!--- Do not configure frame-relay traffic-shaping.

! 
interface Serial5/0/0:0.1 point-to-point 
 ip address 10.1.1.2 255.255.255.0 
 frame-relay interface-dlci 16  
 class test 
 frame-relay ip rtp header-compression 
! 
map-class frame-relay test 
 no frame-relay adaptive-shaping 
 service-policy output llq-shape 
 frame-relay fragment 120 

!--- Apply the frame-relay fragment command to the  
!--- Frame Relay map class.

 access-list 101 permit udp any range 16384 32767 any  range 16384 32767

MS-7507-8A# show ip rtp head 
RTP/UDP/IP header compression statistics: 
DLCI 16 Link/Destination info: point-to-point dlci 
Interface Serial5/0/0:0: 
Distributed fast switched: 
4 seconds since line card sent last stats update 
Rcvd: 105475 total, 105472 compressed, 0 errors 
0 dropped, 0 buffer copies, 0 buffer failures 
Sent: 99451 total, 99447 compressed,  
3776208 bytes saved, 2187963 bytes sent 
2.72 efficiency improvement factor 
Connect: 256 rx slots, 256 tx slots,  
0 long searches, 3 misses 0 collisions, 0 negative cache hits 
99% hit ratio, five minute miss rate 0 misses/sec, 0 max 

MS-7507-8A# show policy-map  
Policy Map llq-shape 
 Class class-default 
  shape peak 256000 1024 1024 
  service-policy llq 
Policy Map llq 
 Class voip 
  priority percent 50 

MS-7507-8A# show policy-map interface s 5/0/0:0.1 
Serial5/0/0:0.1: DLCI 16 - 
Service-policy output: llq-shape 
  queue stats for all priority classes: 
  queue size 0, queue limit 32 
  packets output 147008, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 
 Class-map: class-default (match-any) 
  148237 packets, 10393582 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: any  
   queue size 0, queue limit 64 
   packets output 149563, packet drops 0 
   tail/random drops 0, no buffer drops 0, other drops 0 
  Shape: cir 256000, Bc 1024, Be 1024 
   lower bound cir 0, adapt to fecn 0 
   output bytes 6972057, shape rate 10000 bps 
Service-policy : llq 
  Class-map: voip (match-all) 
  146701 packets, 10325334 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: access-group 101 
  Priority: 50% (128 kbps), burst bytes 3200, b/w  
  exceed drops: 0 
  Class-map: class-default (match-any) 
  1536 packets, 68248 bytes 
  30 second offered rate 0 bps, drop rate 0 bps 
  Match: any  
  queue size 0, queue limit 32 
  packets output 2555, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 

MS-7507-8A# show frame pvc 16 
PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE) 
DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1 
input pkts 3036327   output pkts 199453 
in bytes 198958363  
out bytes 17271661   dropped pkts 0   in FECN pkts 0  
in BECN pkts 0       out FECN pkts 0  out BECN pkts 0  
in DE pkts 0         out DE pkts 0  
out bcast pkts 1071  out bcast bytes 371448  
5 minute input rate 0 bits/sec, 0 packets/sec 
5 minute output rate 35000 bits/sec, 50 packets/sec 
pvc create time 17:51:42, last time pvc status changed 17:50:53 
fragment type end-to-end fragment size 120  

MS-7507-8A# show interface shape 
Serial5/0/0:0 nobuffer drop 0 
Serial5/0/0:0.1(class 0): 
cir 256000, Bc 1024, Be 1024 
lower bound cir 0, adapt to fecn 0 
packets output 152104, bytes output 6985505 
queue limit 64, queue size 0, drops 0 
last clear = 16:58:59 ago, shape rate = 10000 bps

MS-7507-8A# show ip rtp head 
RTP/UDP/IP header compression statistics: 
DLCI 16 Link/Destination info: point-to-point dlci 
Interface Serial5/0/0:0: 
Distributed fast switched: 
4 seconds since line card sent last stats update 
Rcvd: 105475 total, 105472 compressed, 0 errors 
0 dropped, 0 buffer copies, 0 buffer failures 
Sent: 99451 total, 99447 compressed,  
3776208 bytes saved, 2187963 bytes sent 
2.72 efficiency improvement factor 
Connect: 256 rx slots, 256 tx slots,  
0 long searches, 3 misses 0 collisions, 0 negative cache hits 
99% hit ratio, five minute miss rate 0 misses/sec, 0 max 

MS-7507-8A# show policy-map  
Policy Map llq-shape 
 Class class-default 
  shape peak 256000 1024 1024 
  service-policy llq 
Policy Map llq 
 Class voip 
  priority percent 50 

MS-7507-8A# show policy-map interface s 5/0/0:0.1 
Serial5/0/0:0.1: DLCI 16 - 
Service-policy output: llq-shape 
  queue stats for all priority classes: 
  queue size 0, queue limit 32 
  packets output 147008, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 
 Class-map: class-default (match-any) 
  148237 packets, 10393582 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: any  
   queue size 0, queue limit 64 
   packets output 149563, packet drops 0 
   tail/random drops 0, no buffer drops 0, other drops 0 
  Shape: cir 256000, Bc 1024, Be 1024 
   lower bound cir 0, adapt to fecn 0 
   output bytes 6972057, shape rate 10000 bps 
Service-policy : llq 
  Class-map: voip (match-all) 
  146701 packets, 10325334 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: access-group 101 
  Priority: 50% (128 kbps), burst bytes 3200, b/w  
  exceed drops: 0 
  Class-map: class-default (match-any) 
  1536 packets, 68248 bytes 
  30 second offered rate 0 bps, drop rate 0 bps 
  Match: any  
  queue size 0, queue limit 32 
  packets output 2555, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 

MS-7507-8A# show frame pvc 16 
PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE) 
DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1 
input pkts 3036327   output pkts 199453 
in bytes 198958363  
out bytes 17271661   dropped pkts 0   in FECN pkts 0  
in BECN pkts 0       out FECN pkts 0  out BECN pkts 0  
in DE pkts 0         out DE pkts 0  
out bcast pkts 1071  out bcast bytes 371448  
5 minute input rate 0 bits/sec, 0 packets/sec 
5 minute output rate 35000 bits/sec, 50 packets/sec 
pvc create time 17:51:42, last time pvc status changed 17:50:53 
fragment type end-to-end fragment size 120 

MS-7507-8A# show interface shape 
Serial5/0/0:0 nobuffer drop 0 
Serial5/0/0:0.1(class 0): 
cir 256000, Bc 1024, Be 1024 
lower bound cir 0, adapt to fecn 0 
packets output 152104, bytes output 6985505 
queue limit 64, queue size 0, drops 0 
last clear = 16:58:59 ago, shape rate = 10000 bps

Problema conhecido

Se você ainda usa o Cisco IOS Software Release 12.1E, a interface de VIP que é configurada com Encapsulamento frame relay pode causar um crash com um erro de barramento. Este impacto ocorre se você aplica uma política de serviços quando a relação passar o tráfego. A ação alternativa é parar todo o tráfego de background antes que você atualize a política de serviços. Ou você pode promover ao Cisco IOS Software Release 12.2 ou Mais Recente.

Para mais informação, refira a página das ferramentas & dos recursos de Cisco.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 18660