Serviços de rede de aplicativos : Cisco LocalDirector 400 Series

Configurando LocalDirector e SCA 11000 para o Modo One-Armed Proxy

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Cisco anunciou a fim--venda para o Cisco LocalDirector. Para mais informação, refira o fim da vida útil do 400 Series de LocalDirector e as observações e os boletins de produto da Fim--venda.


Índice


Introdução

Este documento fornece uma configuração de exemplo para o Cisco LocalDirector e o acelerador de conteúdo seguro Cisco (SCA) 11000 no Modo One-Armed Proxy. O Modo One-Armed Proxy permite que o SCA termine todas as sessões do Secure Socket Layer (SSL), e pedidos do texto claro do novato ao servidor de Web. Isto é benéfico por estas razões:

  • Offloading sessões de SSL ajuda a reduzir o trabalho que os servidores de Web estão fazendo.

  • Permitindo que o SCA inicie uma conexão do texto claro aos servidores de Web, os equilibradores da carga enlatam distribuem mais uniformemente a carga e mantêm a persistência ao servidor de Web do servidor de retaguarda. Isto limita a possibilidade que um cliente perde seu carrinho de compras durante uma sessão.

Antes de Começar

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Pré-requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

A informação neste documento é baseada no LocalDirector 430 4.2.3 sendo executado e um SCA 11000 3.0.5 sendo executado.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/18658/ld_sca_oap_18658.jpg

Configurações

Este documento utiliza as seguintes configurações:

  • Diretor local 430

  • SCA 11000

Diretor local 430
Building configuration...
: Saved
: LocalDirector 430 Version 4.2.3
: Uptime is 0 weeks, 0 days, 1 hours, 3 minutes, 35 seconds
syslog output 20.3
no syslog console
enable password 000000000000000000000000000000 encrypted
hostname localdirector
no shutdown ethernet 0
no shutdown ethernet 1
no shutdown ethernet 2
no shutdown ethernet 3
interface ethernet 0 auto
interface ethernet 1 auto
interface ethernet 2 auto
interface ethernet 3 auto
mtu 0 1500
mtu 1 1500
mtu 2 1500
mtu 3 1500
multiring all
no secure  0
no secure  1
no secure  2
no secure  3
no ping-allow 0
no ping-allow 1
no ping-allow 2
no ping-allow 3
ip address 172.16.1.213 255.255.255.192
route 0.0.0.0 0.0.0.0 172.16.1.193 1
arp timeout 30
no rip passive
rip version 1
failover ip address 0.0.0.0
no failover
failover hellotime 30
password dfeaf10390e560aea745ccba53e044ed encrypted
snmp-server enable traps
snmp-server community public
no snmp-server contact
no snmp-server location

virtual 172.16.1.195:443:0:tcp is


!--- Virtual for the secure connection from the client
!--- to the SCA.


virtual 172.16.1.195:81:0:tcp is


!--- Virtual for the clear text communication from the
!--- SCA to the backend web server.


virtual 172.16.1.195:80:0:tcp is


!--- Virtual for regular port 80 traffic to 
!--- the web site (optional).


real 172.16.1.201:443:0:tcp is


!--- SCA.


real 172.16.1.25:80:0:tcp is


!--- Web server.


bind 172.16.1.195:443:0:tcp 172.16.1.201:443:0:tcp


!--- Binds the secure virtual to the SCA.


bind 172.16.1.195:81:0:tcp 172.16.1.25:80:0:tcp


!--- Binds the non-secure virtual to the web server.


bind 172.16.1.195:80:0:tcp 172.16.1.25:80:0:tcp


!--- Binds the regular port 80 virtual to 
!--- the web server (optional).


: end         
[OK]

SCA 11000
SCA-1# sho run
#
# Cisco CSCA Device Configuration File
#
# Written:      Sat Dec 15 07:24:13 2001
# Inxcfg:       version 2.3 build 200108071342
# Device Type:  CSS-SCA
# Device Id:    S/N 118032
# Device OS:    MaxOS version 2.5.1 build 200108071341 by Dan L. Reading

### Device ###

mode one-port


!--- Allows one-armed configuration.


ip address 172.16.1.201 netmask 255.255.255.192
hostname SCA-1
password enable "243124676824697552563169414659636C7644757033644E514B632E"
no ip domain-name
no rdate-server
timezone ""
rip
ip route 0.0.0.0 0.0.0.0 172.16.1.193 metric 1

### Interfaces ###

interface network
  auto  
end
interface server
  auto
end

### Remote Management ###

no remote-management access-list
remote-management enable

### SNMP Subsystem ###

no snmp
telnet enable
no telnet access-list
web-mgmt enable
no web-mgmt access-list

### SSL Subsystem ###

ssl
  server chiptest1 create
    ip address 172.16.1.195
    sslport 443


!--- Secure connection port.

    remoteport 81


!--- Non-secure connection port.

    key default
    cert default
    secpolicy default
    cachesize 20
    no transparent


!--- Enables proxy or non-transparent behavior.

  end
end

Verificar

No momento, não há procedimento de verificação disponível para esta configuração.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 18658