IP : Cisco Express Forwarding (CEF)

Troubleshooting de Equilíbrio de Carga por Links Paralelos com Uso de Cisco Express Forwarding

14 Outubro 2016 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Tradução Manual (22 Maio 2008) | Inglês (19 Dezembro 2015) | Feedback


Índice


Introdução

Este documento esclarece como o software do½ do¿Â do Cisco IOSï executa o Balanceamento de carga da camada 3 através dos links paralelos múltiplos ao usar o Cisco Express Forwarding.

Pré-requisitos

Requisitos

Este documento supõe uma compreensão das duas estruturas de dados do Cisco Express Forwarding.

  • Base de informação de encaminhamento (FIB)

  • Tabela de adjacência

Veja a seção da “informação relacionada” deste documento para uma visão geral de operação do Cisco Express Forwarding.

Componentes Utilizados

Este documento não se restringe a versões de software e hardware específicas.

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se você estiver trabalhando em uma rede ativa, certifique-se de que entende o impacto potencial de qualquer comando antes de utilizá-lo.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Informações de Apoio

A switching IP é o mecanismo interno usado pelo Cisco IOS para encaminhar pacotes através de um roteador. Os mecanismos disponíveis incluem: switching de processos, switching rápida e Cisco Express Forwarding. Segundo qual dos três mecanismos é usado para comutar a maioria de pacotes, o desempenho de sistema total e o Balanceamento de carga são afetados.

Os mecanismos de switching de IP suportam dois modos gerais, por pacote e por destino. A tabela a seguir descreve as vantagens e as desvantagens de ambos os modos.

Por destino Pacote per.
Mecanismo da Comutação IP Switching rápida e Cisco Express Forwarding por destino. Switching de processos e encaminhamento Cisco Express por pacote.
Vantagens Com a switching rápida, fica garantido que os pacotes de um determinado destino tomarão o mesmo caminho, ainda que vários caminhos estejam disponíveis. Com Cisco Express Forwarding Switching, os pacotes para um par de host dado da combinação origem-destino são garantidos para tomar o mesmo trajeto, mesmo se os caminhos múltiplos estão disponíveis. O tráfego destinado para pares diferentes tende a tomar trajetos diferentes. A utilização de caminho com balanceamento de carga por pacote é boa porque esse balanceamento permite que o roteador envie pacotes de dados sucessivos pelos caminhos, independentemente de hosts individuais ou sessões de usuário. Usa o método redondo de Robin para determinar que trajeto cada pacote toma ao destino
Desvantagens Com interruptor rápido, pelo interruptor do destino pode conduzir ao compartilhamento de carga desigual porque os pacotes a um destino seguem sempre o mesmo trajeto. O Cisco Express Forwarding Switching pode conduzir à distribuição desigual com um pequeno número de pares de destino de origem. O equilíbrio da carga por destino depende da distribuição estatística de tráfego; o compartilhamento de carga torna-se mais eficaz enquanto o número de pares de destino de origem aumenta. Os pacotes de um determinado par de hosts de origem-destino podem tomar caminhos diferentes, o que poderia introduzir a reordenação dos pacotes. Isto não é recomendado para a Voz sobre IP (VoIP) e outros fluxos que exigem a entrega em sequência.

O que é balanceamento de carga?

O balanceamento de carga descreve a capacidade de um roteador de transmitir pacotes para um endereço IP de destino (também conhecido como prefixo IP) por mais de um caminho.

Ao discutir o balanceamento de carga, precisamos primeiramente definir os seguintes termos.

Termo Definição
Prefixo Descreve uma rede do IP de destino, tal como 192.16.10.0/24. O Cisco IOS inclui um prefixo de IP de destino para a tabela de roteamento usando as informações obtidas pelo intercâmbio de mensagens usando um Dynamic Routing Protocol ou por configuração manual de rotas estáticas.
Caminho Descreve uma rota válida para alcançar um prefixo de destino. O Cisco IOS atribui um custo a cada trajeto. Um grupo de caminhos ativo a um prefixo de destino pode ter o igual ou os custos desiguais.
Sessão Descreve um fluxo de comunicação unidirecional entre dois nós de IP. Todos os pacotes em uma sessão utilizam o mesmo endereço IP de origem e destino.

Para obter mais informações, consulte Como funciona o balanceamento de carga?

Antes do Cisco Express Forwarding – Coletando vários caminhos ou rotas

O Cisco Express Forwarding utiliza as informações de caminho na tabela de IP Routing para equilibrar o tráfego em enlaces múltiplos. Por esta razão, a confirmação do balanceamento de carga adequado do Cisco Express Forwarding começa com a confirmação dos conteúdos da tabela de IP Routing.

Na topologia a seguir, dois roteadores, roteador A e roteador B, conectam-se back-to-back em três interfaces seriais com encapsulamento HDLC (High-Level Data Link Control).

Roteador A roteador B
interface Ethernet 0 
 ip address  192.168.20.1 255.255.255.0 
! 
interface Serial1 
 ip address 10.10.10.1 255.255.255.0  
! 
interface Serial2 
 ip address 20.20.20.1 255.255.255.0 
! 
interface Serial3 
 ip address 30.30.30.1 255.255.255.0 
 ip ospf cost 100 
! 
router ospf 1 
 network 10.10.10.0 0.0.0.255 area 0 
 network 20.20.20.0 0.0.0.255 area 0 
 network 30.30.30.0 0.0.0.255 area 0 
network 192.168.20.0 0.0.0.255 area 0
interface Serial1 
 ip address 10.10.10.2 255.255.255.0 
 clockrate 2000000 
! 
interface Serial2 
 ip address 20.20.20.2 255.255.255.0 
 clockrate 148000 
! 
interface Serial3 
 ip address 30.30.30.2 255.255.255.0 
 ip ospf cost 100 
 clockrate 148000 
router ospf 1 
 network 10.10.10.0 0.0.0.255 area 0 
 network 20.20.20.0 0.0.0.255 area 0 
 network 30.30.30.0 0.0.0.255 area 0
maximum-paths 1

Deixe-nos olhar como o roteador B seleciona uns ou vários trajetos para alcançar a rede IP 192.168.20.0 da interface Ethernet do roteador a.

  • Por padrão, o OSPF suporta quatro caminhos de custo iguais para um destino. Neste roteador de cenário B é configurado com os máximo-PATH iguais a um. Daqui o roteador B escolherá somente um trajeto entre os caminhos iguais possíveis baseados em qual recebeu primeiramente. O roteador B começa selecionando Serial2 como o caminho único à rede de 192.168.20.0. Use o cef e os comandos show ip route da mostra IP ver o grupo atual do trajeto.

    RouterB#show ip cef  192.168.20.0
    	
     192.168.20.0/24, version 59, cached adjacency to Serial2 
    0 packets, 0 bytes 
      via 20.20.20.1, Serial2, 0 dependencies 
        next hop 20.20.20.1, Serial2 
        valid cached adjacency
    	 
    RouterB#show ip route  192.168.20.0
     
    Routing entry for  192.168.20.0/24 
      Known via "ospf 1", distance 110, metric 74, type intra area 
      Redistributing via ospf 1 
      Last update from 20.20.20.1 on Serial2, 00:03:58 ago 
      Routing Descriptor Blocks: 
      * 20.20.20.1, from 204.204.204.1, 00:03:58 ago, via Serial2 
          Route metric is 74, traffic share count is 1
    
  • Use o comando de máximo de caminhos no OSPF para permitir mais de um caminho para a tabela de roteamento. O OSPF permite apenas o balanceamento de carga de custo igual. Para configurar o compartilhamento de carga de custo desigual, configure o EIGRP/IGRP (Protocolo de encaminhamento de gateway interior melhorado/ Protocolo de encaminhamento de gateway interior) como seu IGP (Protocolo de gateway interior). Veja como faz o trabalho do balanceamento de carga de caminho de custo desigual (variação) no IGRP e no EIGRP? para mais informações.

    RouterB(config)#router ospf 1
    	
    RouterB(config-router)#maximum-paths ? 
      <1-6>  Number of paths 
      
    RouterB(config-router)#maximum-paths 3 
    
    
  • Use o comando show ip route confirmar que a tabela de roteamento contém dois trajetos a 192.168.20.0.

    RouterB#show ip route  192.168.20.0
    	
    Routing entry for  192.168.20.0/24 
      Known via "ospf 1", distance 110, metric 74, type intra area 
      Redistributing via ospf 1 
      Last update from 10.10.10.1 on Serial1, 00:00:11 ago 
      Routing Descriptor Blocks: 
      * 20.20.20.1, from 204.204.204.1, 00:00:11 ago, via Serial2 
          Route metric is 74, traffic share count is 1 
             10.10.10.1, from 204.204.204.1, 00:00:11 ago, via Serial1 
          Route metric is 74, traffic share count is 1 
          
    !--- The route metric is 74 for both paths.
    
    
  • Embora o OSPF tenha sido configurado para suportar três caminhos de custos iguais, apenas dois desses caminhos ativos são apresentados na saída do comando show ip route. Podemos usar o comando show ip ospf interface para determinar a razão. A série 3 tem um custo mais alto do que Serial1 e Serial2, e é consequentemente desigual.

    RouterB#show ip ospf interface s1
    	
    Serial1 is up, line protocol is up 
      Internet Address 10.10.10.4/24, Area 0 
      Process ID 1, Router ID 100.100.100.1, Network Type POINT_TO_POINT, Cost: 64 
      
    RouterB#show ip ospf interface s2
    
    Serial2 is up, line protocol is up 
      Internet Address 20.20.20.2/24, Area 0 
      Process ID 1, Router ID 100.100.100.1, Network Type POINT_TO_POINT, Cost: 64 
      
    RouterB#show ip ospf interface s3
    
    Serial3 is up, line protocol is up 
      Internet Address 30.30.30.2/24, Area 0 
      Process ID 1, Router ID 100.100.100.1, Network Type POINT_TO_POINT, Cost: 100
    
  • Use o comando show run confirmar se a série 3 está configurada com o comando ip ospf cost 100. Use o comando no ip ospf cost 100 sub-interface removê-la da configuração e fazer os custos em todos os três enlaces serial iguais.

    RouterB#show run interface s3
     
    Building configuration...
     
    Current configuration: 
    ! 
    interface Serial3 
     ip address 30.30.30.2 255.255.255.0 
     no ip directed-broadcast 
     ip ospf cost 100 
     ip ospf interface-retry 0
    
  • O comando show ip route indica agora três caminhos de custo igual à rede de 192.168.20.0.

    RouterB#show ip route  192.168.20.0
     
    Routing entry for  192.168.20.0/24 
      Known via "ospf 1", distance 110, metric 74, type intra area 
      Redistributing via ospf 1 
      Last update from 10.10.10.1 on Serial1, 00:00:01 ago 
      Routing Descriptor Blocks: 
      * 20.20.20.1, from 204.204.204.1, 00:00:01 ago, via Serial2 
          Route metric is 74, traffic share count is 1 
        30.30.30.1, from 204.204.204.1, 00:00:01 ago, via Serial3 
          Route metric is 74, traffic share count is 1 
        10.10.10.1, from 204.204.204.1, 00:00:01 ago, via Serial1 
          Route metric is 74, traffic share count is

Deixe-nos agora olhar como o Balanceamento de carga do Cisco Express Forwarding usa a informação na tabela de roteamento para enviar pacotes.

Configurando o compartilhamento de carga do Cisco Express Forwarding

O 'Cisco Express Forwarding realiza o balanceamento de carga utilizando a tabela de compartilhamento de carga. Como ocorre com todas as outras soluções de balanceamento de carga em Cisco routers, a decisão de balanceamento de carga é tomada nas interfaces de saída. Diferente de outros métodos de switching, o Cisco Express Forwarding rastreia os caminhos com base no endereço tanto de origem quanto de destino do caminho. Para simplificar isto, você poderia dizer que o trajeto é uma sessão IP e cada sessão está identificada logicamente como um par de endereço de origem-destino original.

Para compreender como ocorre o balanceamento de carga, veja primeiro como as tabelas se relacionam. A tabela Cisco Express Forwarding aponta para 16 hash buckets (tabela de compartilhamento de carga), que apontam para a tabela adjacente para caminhos paralelos. Veja os mecanismos internos do Balanceamento de carga do Cisco Express Forwarding secionar para mais detalhes. Cada pacote a ser comutado é quebrado acima no par de endereço de origem e de destino e é verificado contra a tabela de compartilhamento de carga.

Nota: Há dois tipos principais de Cisco Express Forwarding Switching, de destino per. e de pacote per. Se ambos os tipos estiverem em uso em um roteador, cada tipo terá sua própria tabela de compartilhamento de carga.

O balanceamento de carga por destino permite que o roteador use vários caminhos para alcançar o compartilhamento de carga. O balanceamento de carga por destino é habilitado como padrão quando você habilita o Cisco Express Forwarding, sendo o método preferido de balanceamento de carga para a maioria das situações. Como o balanceamento por destino depende da distribuição estatística do tráfego, o compartilhamento de carga torna-se mais efetivo à medida que aumenta o número de pares origem/destino.

O Balanceamento de carga do pacote per. permite que o roteador envie pacotes de dados sucessivos sobre trajetos sem consideração aos host individuais ou às sessões do usuário. Ele utiliza o método de rodízio para determinar qual caminho cada pacote toma até o destino. O balanceamento de carga por pacote garante o balanceamento por vários enlaces. A utilização de caminhos com o balanceamento de cargas por pacote é eficiente, mas os pacotes para um determinado par de hosts de origem e destino pode considerar diferentes caminhos, podendo resultar na reordenação de pacotes. Por este motivo, o Balanceamento de carga do pacote per. é com certeza os tipos de tráfego de dados impróprios, tais como VoIP, que dependem dos pacotes que chegam no destino em ordem. Balanceamento de carga do pacote per. do uso a ajudar a assegurar-se de que um trajeto para um único par de destino de origem não se torne sobrecarregado.

Use o comando ip load-sharing mudar entre o pacote per. e os métodos do destino per.

7200-1.3(config)#interface fast 0/0
   
7200-1.3(config-if)#ip load-sharing ? 
  per-destination  Deterministic distribution 
  per-packet       Random distribution 
  
7200-1.3(config-if)#ip load-sharing per-packet

Use o comando show cef interface para confirmar suas alterações.

7200-1.3#show cef interface fast 0/0 
FastEthernet0/0 is up (if_number 3) 
  Corresponding hwidb fast_if_number 3 
  Corresponding hwidb firstsw->if_number 3 
  Internet address is 172.16.81.13/24 
  ICMP redirects are always sent 
  Per packet load-sharing is enabled 
  IP unicast RPF check is disabled 
  Inbound access list is not set 
  Outbound access list is not set 
  IP policy routing is disabled 
  Hardware idb is FastEthernet0/0 
  Fast switching type 1, interface type 18 
  IP CEF switching enabled 
  IP Feature Fast switching turbo vector 
  IP Feature CEF switching turbo vector 
  Input fast flags 0x0, Output fast flags 0x0 
  ifindex 1(1) 
  Slot 0 Slot unit 0 VC -1 
  Transmit limit accumulator 0x0 (0x0) 
  IP MTU 1500

Mecanismos internos de balanceamento de carga do Cisco Express Forwarding

Deixe-nos começar dividindo o mecanismo interno atrás do Balanceamento de carga do Cisco Express Forwarding.

  • Cada sessão (veja a tabela acima) é atribuída a um caminho ativo.

  • A atribuição sessão para caminho é feita com uma função hash que pega os endereços IP de origem e destino e, em versões recentes do Cisco IOS, uma ID de hash exclusiva que torna aleatória a atribuição no caminho de ponta a ponta.

  • Os caminhos ativo são atribuídos internamente a diversas de 16 cubetas da mistura. A atribuição path-to-bucket varia com o tipo de balanceamento de carga e o número de caminhos ativos.

  • O resultado da função hash é utilizado para capturar um dos buckets e, dessa forma, obter o caminho a ser utilizado na sessão.

  • Para todas as sessões que estão sendo enviadas pelo roteador, cada caminho ativo leva o mesmo número de sessões.

Deixe-nos olhar um exemplo destes internals do Cisco Express Forwarding.

  1. Use o comando maximum-paths para reduzir para dois o número de caminhos ativos para o prefixo de destino.

    RouterB(config)#router ospf 1
    RouterB(config-router)#maximum-paths 2
    
  2. Use o comando show ip cef {prefix} internal ver a atribuição da PATH-à-cubeta.

    RouterB#show ip cef  192.168.20.0 internal 
     192.168.20.0/24, version 66, per-destination sharing 
    0 packets, 0 bytes 
      via 20.20.20.1, Serial2, 0 dependencies 
        traffic share 1 
        next hop 20.20.20.1, Serial2 
        valid adjacency 
      via 30.30.30.1, Serial3, 0 dependencies 
        traffic share 1 
        next hop 30.30.30.1, Serial3 
        valid adjacency 
      0 packets, 0 bytes switched through the prefix 
      Load distribution: 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 (refcount 1) 
      
    !--- The load distribution line summarizes how each path is 
    !--- assigned to the hash buckets.
    
      
    
      Hash  OK  Interface                 Address         Packets 
      1     Y   Serial2                   point2point           0 
      2     Y   Serial3                   point2point           0 
      3     Y   Serial2                   point2point           0 
      4     Y   Serial3                   point2point           0 
      5     Y   Serial2                   point2point           0 
      6     Y   Serial3                   point2point           0 
      7     Y   Serial2                   point2point           0 
      8     Y   Serial3                   point2point           0 
      9     Y   Serial2                   point2point           0 
      10    Y   Serial3                   point2point           0 
      11    Y   Serial2                   point2point           0 
      12    Y   Serial3                   point2point           0 
      13    Y   Serial2                   point2point           0 
      14    Y   Serial3                   point2point           0 
      15    Y   Serial2                   point2point           0 
      16    Y   Serial3                   point2point 

    Os 16 hash buckets são configurados de acordo com o tipo de balanceamento de carga e com o número de caminhos ativos. O caso simples é para um número par de caminhos. As 16 cubetas são enchidas uniformemente com os caminhos ativo. Se 16 não for divisível pelo número de caminhos ativos, os últimos buckets que representam o restante serão desabilitados. A tabela a seguir mostra como as cubetas da mistura procuram dois e três caminhos ativo.

    Cubeta/trajetos 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
    2 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1
    3 0 1 2 0 1 2 0 1 2 0 1 2 0 1 2 x

    No seguinte exemplo, temos três caminhos para o destino. Observação como o Cisco Express Forwarding removeu a cubeta 16 da mistura e como os três enlaces serial são atribuídos uniformemente para picar as cubetas 1 a 15.

    RouterB#show ip cef  192.168.20.0 interface 
     192.168.20.0/24, version 64, per-destination sharing 
    0 packets, 0 bytes 
      via 20.20.20.1, Serial2, 0 dependencies 
        traffic share 1 
        next hop 20.20.20.1, Serial2 
        valid adjacency 
      via 30.30.30.1, Serial3, 0 dependencies 
        traffic share 1 
        next hop 30.30.30.1, Serial3 
        valid adjacency 
      via 10.10.10.1, Serial1, 0 dependencies 
        traffic share 1 
        next hop 10.10.10.1, Serial1 
        valid adjacency 
    
      0 packets, 0 bytes switched through the prefix 
      Load distribution: 0 1 2 0 1 2 0 1 2 0 1 2 0 1 2 (refcount 1) 
      
    !--- The active paths are assigned to hash buckets in a 
    !--- round-robin pattern.
    
       
    
      Hash  OK  Interface                 Address         Packets 
      1     Y   Serial2                   point2point           0 
      2     Y   Serial3                   point2point           0 
      3     Y   Serial1                   point2point           0 
      4     Y   Serial2                   point2point           0 
      5     Y   Serial3                   point2point           0 
      6     Y   Serial1                   point2point           0 
      7     Y   Serial2                   point2point           0 
      8     Y   Serial3                   point2point           0 
      9     Y   Serial1                   point2point           0 
      10    Y   Serial2                   point2point           0 
      11    Y   Serial3                   point2point           0 
      12    Y   Serial1                   point2point           0 
      13    Y   Serial2                   point2point           0 
      14    Y   Serial3                   point2point           0 
      15    Y   Serial1                   point2point           0 
      
    !--- Hash bucket 16 has been removed.
     
    
    

    Nota: Embora selecionem um caminho único para um destino, o destino per. do Cisco Express Forwarding e os mecanismos de switching rápidos diferem em como seleciona esse trajeto. O Cisco Express Forwarding considera ambos os endereços IP de origem e de destino, quando o interruptor rápido considerar somente o endereço IP de destino.

Verificação do balanceamento de carga do Cisco Express Forwarding

Use as seguintes etapas para verificar o Balanceamento de carga do Cisco Express Forwarding em seu roteador.

  1. Confirme se o Cisco Express Forwarding está habilitado globalmente no roteador.

    S3-4K-2#show ip cef 
    %CEF not running 
    Prefix                      Next Hop                     Interface 
    
    !--- This output shows Cisco Express Forwarding is not enabled. 
    !--- Use ip cef command in global configuration to enable it.
    
    
    
  2. Confirme o pacote per. ou o switching por destino é permitido nas interfaces de saída particular. O padrão é destino per.

    RouterA#show cef interface s1
     
    Serial1 is up (if_number 3)
      Internet address is 10.10.10.1/24 
      ICMP redirects are always sent 
      Per packet loadbalancing is disabled 
      IP unicast RPF check is disabled 
      Inbound access list is not set 
      Outbound access list is not set 
      Interface is marked as point to point interface 
      Hardware idb is Serial1 
      Fast switching type 4, interface type 40 
      IP CEF switching enabled 
     
     !--- Cisco Express Forwarding is enabled on the interface. 
    
      IP CEF Fast switching turbo vector 
      Input fast flags 0x0, Output fast flags 0x0 
      ifindex 5(5)
      
    Slot 0 Slot unit 1 VC -1 
      
      Transmit limit accumulator 0x0 (0x0) 
      IP MTU 1500 
  3. Confirme se a tabela de roteamento e a tabela do Cisco Express Forwarding contêm todos os caminhos paralelos usando o comando show ip route.

    RouterB#show ip route 192.168.20.0 
    Routing entry for 192.168.20.0/32, 1 known subnets 
     
    O       192.168.20.1 [110/65] via 20.20.20.1, 00:06:54, Serial1 
                         [110/65] via 10.10.10.1, 00:06:54, Serial2 
                         [110/65] via 30.30.30.1, 00:06:54, Serial3 
    
  4. Verifique a FIB do Cisco Express Forwarding usando o comando show ip cef.

    RouterB#show ip cef 192.168.20.0
    192.168.20.0/24, version 18, per-destination sharing
    0 packets, 0 bytes
      via 30.30.30.1, Serial3,   0 dependencies
        traffic share 1
        next hop 30.30.30.1, Serial3
        valid adjacency
      via 20.20.20.1, Serial2, 0 dependencies
        traffic share 1
        next hop 20.20.20.1, Serial2
        valid adjacency
      via 10.10.10.1, Serial1, 0 dependencies
        traffic share 1
        next hop 10.10.10.1, Serial1
        valid adjacency
      0 packets, 0 bytes switched through the prefix
      tmstats: external 0 packets, 0 bytes
               internal 0 packets, 0 bytes
    
    
    RouterB#show ip cef 192.168.20.0 internal
    192.168.20.0/24, version 18, per-destination sharing
    0 packets, 0 bytes
      via 30.30.30.1, Serial3, 0 dependencies
        traffic share 1
        next hop 30.30.30.1, Serial3
        valid adjacency
      via 20.20.20.1, Serial2, 0 dependencies
        traffic share 1
        next hop 20.20.20.1, Serial2
        valid adjacency
      via 10.10.10.1, Serial1, 0 dependencies
        traffic share 1
        next hop 10.10.10.1, Serial1
        valid adjacency
    
      0 packets, 0 bytes switched through the prefix
      tmstats: external 0 packets, 0 bytes
               internal 0 packets, 0 bytes
      Load distribution: 0 1 2 0 1 2 0 1 2 0 1 2 0 1 2 (refcount 1)
    
      Hash  OK  Interface                 Address         Packets
      1     Y   Serial3                   point2point           0
      2     Y   Serial2                   point2point           0
      3     Y   Serial1                   point2point           0
      4     Y   Serial3                   point2point           0
      5     Y   Serial2                   point2point           0
      6     Y   Serial1                   point2point           0
      7     Y   Serial3                   point2point           0
      8     Y   Serial2                   point2point           0
      9     Y   Serial1                   point2point           0
      10    Y   Serial3                   point2point           0
      11    Y   Serial2                   point2point           0
      12    Y   Serial1                   point2point           0
      13    Y   Serial3                   point2point           0
      14    Y   Serial2                   point2point           0
      15    Y   Serial1                   point2point           0
    

    Nota: A tabela de compartilhamento de carga acima mostra a distribuição de carga 0 1 2 0 1 2. , e a parte do tráfego é 1 para cada rota. Isto significa uma partilha de carga por destino dos custos iguais entre três rotas de custo igual.

  5. Verifique adjacências do Cisco Express Forwarding.

    RouterB#show adjacency detail
    Protocol Interface                 Address
    IP       Serial1                   point2point(11)
                                       0 packets, 0 bytes
                                       0F000800
                                       CEF   expires: 00:02:31
                                             refresh: 00:00:31
    IP       Serial2                   point2point(11)
                                       0 packets, 0 bytes
                                       0F000800
                                       CEF   expires: 00:02:31
                                             refresh: 00:00:31
    IP       Serial3                   point2point(11)
                                       0 packets, 0 bytes
                                       0F000800
                                       CEF   expires: 00:02:31
                                             refresh: 00:00:31
  6. Confirme o mecanismo previsto da função de balanceamento de carga do Cisco Express Forwarding é configurado em todas as interfaces externas.

    RouterB#show ip cef  192.168.20.0
    
     192.168.20.0/24, version 89, per-destination sharing 
    0 packets, 0 bytes 
      via 10.10.10.1, Serial1, 0 dependencies 
        traffic share 1 
        next hop 10.10.10.1, Serial1 
        valid adjacency 
      [output omitted]
  7. Permita a contabilidade de hash bucket de recolher estatísticas para compreender melhor testes padrões do Cisco Express Forwarding em sua rede. Por exemplo, você pôde querer recolher a informação tal como o número de pacotes e de bytes comutados a um destino ou o número de pacotes comutados através de um destino. Utilize o seguinte comando:

    router(config)# ip cef accounting load-balance-hash
    

    Verifique o fluxo de pacote de informação observando os valores sob o campo do pacote.

    RouterB#show ip cef 192.168.20.0 internal
    [...]
    
      Load distribution: 0 1 2 0 1 2 0 1 2 0 1 2 0 1 2 (refcount 1)
    
      Hash  OK  Interface                 Address         Packets
      1     Y   Serial                    point2point           0
      2     Y   Serial2                   point2point           0
      3     Y   Serial1                   point2point           0
      4     Y   Serial3                   point2point           0
      5     Y   Serial2                   point2point          35
      6     Y   Serial1                   point2point           0
      7     Y   Serial3                   point2point           0
      8     Y   Serial2                   point2point          60
      9     Y   Serial1                   point2point           0
      10    Y   Serial3                   point2point           0
      11    Y   Serial2                   point2point           0
      12    Y   Serial1                   point2point           0
      13    Y   Serial3                   point2point           0
      14    Y   Serial2                   point2point          30
      15    Y   Serial1                   point2point           0

    125 pacotes correram através de Serial2. Se você usa o sibilo para gerar o tráfego, assegure-se de que os pacotes de ping devam transitar pelo roteador comutado por Cisco Express Forwarding. Em outras palavras, os pacotes de ping devem entrar por uma interface comutada do Cisco Express Forwarding, ser comutados pelo Cisco Express Forwarding e sair por outra interface comutada do Cisco Express Forwarding.

    Nota: O compartilhamento de carga por destino se torna mais eficiente com o aumento no número de pares origem-destino.

  8. Enquanto manda tráfego para o prefixo, capture várias saídas do comando de interface de exibição. Analise os valores do “txload” e do “rxload”. (Algumas relações indicam um único valor " carga ", que considere transmita e receba). Embora o Balanceamento de carga do pacote per. forneça uma distribuição uniforme no número de pacotes, os enlaces paralelos podem exibir uma taxa levemente desigual segundo o tamanho do pacote.

    Serial1/0:0 is up, line protocol is up
    reliability 255/255, txload 10/255, rxload 3/255
     
    Serial1/1:0 is up, line protocol is up
    reliability 255/255, txload 18/255, rxload 3/255
    
    
  9. Com a carga por destino do Cisco Express Forwarding que equilibra, você pode determinar a que trajeto uma sessão é atribuída com o comando seguinte. Adicionar a palavra-chave interna para indicar que a cubeta da mistura é usada.

    show ip cef exact-route {source-ip-address} {dest-ip-address} [internal]
     
    RouterB# show ip cef exact-route 50.50.50.2 192.168.20.1  internal
    50.50.50.2      -> 192.168.20.1   : Serial9/0 (next hop 20.20.20.1)
                                        Bucket 4 from 15, total 3 paths
    RouterB# show ip cef exact-route 5.5.5.1 192.168.20.1  internal   
    5.5.5.1         ->192.168.20.1   : Serial9/0 (next hop 20.20.20.1)
                                        Bucket 7 from 15, total 3 paths
    RouterB# show ip cef exact-route 6.6.6.1 192.168.20.1  internal
    6.6.6.1         -> 192.168.20.1   : Serial9/0 (next hop 20.20.20.1)
                                        Bucket 7 from 15, total 3 paths
    RouterB# show ip cef exact-route 8.8.8.1 192.168.20.1  internal
    8.8.8.1         -> 192.168.20.1   : Serial9/0 (next hop 20.20.20.1)
                                        Bucket 13 from 15, total 3 paths
    
  10. Se a saída parecer irregular, considere o seguinte:

    • O número de pares de endereço de origem e de destino ou de sessões originais que atravessam os enlaces paralelos.

    • O número e o tamanho dos pacotes em cada sessão. Uma seção conta com um grande número de pacotes? O equilíbrio da carga por destino depende da distribuição estatística de tráfego e torna-se mais eficaz enquanto o número de pares de destino de origem aumenta.

Carregue o compartilhamento após uma alteração de link

Quando uma alteração de tabela de roteamento ajusta o número de caminho ativo a um destino, o Cisco Express Forwarding atualiza as estruturas de equilíbrio da carga consideradas na saída do comando show ip cef {prefix} internal. Em seguida, o Cisco Express Forwarding combina os pacotes recém-chegados a uma adjacência e a um bucket de hash correspondente. O bucket selecionado pode ou não ser o mesmo utilizado anteriormente.

As etapas a seguir descrevem como as informações de balanceamento de carga do Cisco Express Forwarding são atualizadas após alterações no número de caminhos ativos para um prefixo de destino.

  1. Supõe que um prefixo de destino é alcançável através de dois trajetos. O trajeto 1 é inativo, e o trajeto 2 é ativo e levando todo o tráfego.

  2. Quando o caminho 1 esiver novamente disponível, ele solicitará os processos de reconvergência de rotetamento IP.

  3. Agora, o Cisco Express Forwarding equilibra a carga entre ambos os caminhos e não preserva os fluxos existentes entre o caminho 2. Isso deixaria o caminho 1 inutilizado. Resumindo, o Cisco Express Forwarding não considera que possa encaminhar pacotes de uma sessão em um caminho válido e possa selecionar um novo caminho para um fluxo, dependendo de qual bucket de mistura ele selecione.

Informações sobre compartilhamento de carga devem ser excluídas

Após uma alteração na tabela de roteamento, o Cisco Express Forwarding exclui e recria as estruturas de balanceamento de carga que atribui caminhos ativos aos Hash Buckets. Durante o processo de reconstrução, alguns pacotes podem ser perdidos, e o comando show ip cef {prefix} internal indica a validade da informação para exclusão do compartilhamento de carga.

router#show ip cef 10.10.128.0 int 
 10.10.128.0/28, version 63, per-destination sharing 
 0 packets, 0 bytes 
   via 10.8.0.31, 0 dependencies, recursive 
     next hop 10.8.2.49, POS0/0/0 
     valid adjacency 
   Load sharing information due for deletion 

As mudanças executadas com a identificação de bug Cisco CSCdm87127 minimizam a perda de pacotes durante uma mudança no número de caminho ativo para a rota de 0.0.0.0 do padrão. Especificamente, o Cisco Express Forwarding aloca uma entrada FIB com espaço para o número máximo possível de caminhos ativos para essa rota.

Problemas conhecidos

O balanceamento de carga do Cisco Express Forwarding não é igual nos quatro caminhos. Para uns detalhes mais adicionais, refira CSCdm87756 (clientes registrados somente).

Nas versões do Cisco IOS mais cedo do que 12.0(16)S, inscrever o comando show ip cef exact-route pode fazer com que o route processor (RP) em um Cisco 12000 Series Internet Router ou em um cisco 7500/RSP Series Router recarregue. Essa situação ocorre quando o prefixo de destino é recursivo e o roteador está compartilhando a carga para o próximo salto. Para obter mais detalhes, consulte CSCdt80914 (somente clientes cadastrados), o que resolve esse problema.

No balanceamento de carga por pacote da plataforma CEF do 6500 Series não é apoiado. Isto é devido à limitação do hardware e é somente possível ter a carga por destino que equilibra atualmente. Consequentemente a única opção é usar compartilhamento de carga do fluxo distribuído do protocolo multilink point-to-point (dMLPPP) ou da camada 4.

Suporte de hardware para balanceamento de carga do Cisco Express Forwarding

O balanceamento de carga por pacote do Cisco Express Forwarding era originalmente suportado em plataformas que utilizam o encaminhamento com base em software. Tais plataformas incluem os 2600, 3600 e 7200 Series. Agora existe suporte para o balanceamento de carga por pacote no hardware usando a tecnologia PXF (Parallel eXpress Forwarding) na série 7200 com um NSE-1 e a série 10000. No Catalyst 6000 Series, os comandos ip load-sharing per-packet, ip cef accounting per-prefix, e ip cef accounting non-recursive do Cisco Express Forwarding do Cisco IOS no MSFC2 aplicam-se somente ao tráfego que é comutado por Cisco Express Forwarding no software no MSFC2. Os comandos não afetam o tráfego comutado por camada 3 de hardware no PFC2 ou em módulos de switching equipados com DFC. Veja configurar o switching da camada 3 do unicast IP no Supervisor Engine 2 para mais informação.

Nota: Um Cisco 7300 Router com uma placa de processador do NSE-100 não apoia o Balanceamento de carga do pacote per. CEF no PXF. Os apoios PXF somente pelo equilíbrio da carga de destino. Contudo, pareceu que têm o apoio porque os comandos configuration estavam disponíveis no CLI do roteador. Isto é corrigido e gravado na identificação de bug Cisco CSCdx63389.

No 12000 Series, o Balanceamento de carga do pacote per. está disponível em todos os Engine de encaminhamento de camada 3 exceto os Engine 3 e os 4. Cada placa de linha faz decisões de encaminhamento independentes. Para visualizar a rota exata para cada fluxo de IP, use o comando exec slot X show ip hardware-cef exact-route src dst nas placas de ingresso que utilizam tabelas do Cisco Express Forwarding baseadas em hardware.


Informações Relacionadas


Document ID: 18285