WAN : Frame Relay

Configurando o Class Based Weighted Fair Queueing com FRTS

19 Setembro 2015 - Tradução por Computador
Outras Versões: Versão em PDFpdf | Inglês (22 Agosto 2015) | Feedback


Índice


Introdução

Este documento fornece uma configuração de exemplo para o Class-Based Weighted Fair Queueing (CBWFQ) o Frame Relay Traffic Shaping (FRTS).

O CBWFQ estende a funcionalidade das filas "Standard Weighted Fair Queuing" (WFQ) para fornecer o apoio para classes de tráfego definidas pelo utilizador. O FRTS usa filas em uma rede do Frame Relay para limitar os impulsos que podem causar a congestão. Os dados são protegidos e enviados então na rede em quantidades reguladas para assegurar-se de que os ajustes do tráfego dentro do envelope prometido do tráfego para a conexão particular.

Pré-requisitos

Requisitos

Não existem requisitos específicos para este documento.

Componentes Utilizados

O CBWFQ é apoiado até à data dos seguintes software release do � do Cisco IOS segundo a plataforma:

  • Cisco 7500 Series com processadores de interface versáteis (VIP) (CBWFQ distribuído) - Cisco IOS Software Release 12.1(5)T

  • Cisco 7200 Series, 2600/3600 Series, e outras Plataformas não-7500 da série - Cisco IOS Software Release 12.1(2)T

Contudo ambo o Roteadores usado para este documento de configuração executava o Cisco IOS Software Release 12.2(2).

As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a sua rede estiver ativa, certifique-se de que entende o impacto potencial de qualquer comando.

Convenções

Para obter mais informações sobre convenções de documento, consulte as Convenções de dicas técnicas Cisco.

Por que use o CBWFQ com FRTS?

Se você tem os dados específicos a proteger, o CBWFQ fornece uma maneira de especificar mais estes dados usando classes específicas. Utilizando CBWFQ, o peso especificado para uma classe se torna o peso de cada pacote compatível com o critério da classe. Esse peso é derivado da largura de banda que você atribuiu para a classe. O WFQ é aplicado então a estas classes, em vez da aplicação aos fluxos eles mesmos, e as classes podem incluir diversos fluxos.

Configurar

Nesta seção, você encontrará informações para configurar os recursos descritos neste documento.

Nota: Para localizar informações adicionais sobre os comandos usados neste documento, utilize a Ferramenta Command Lookup (somente clientes registrados).

A tabela abaixo fornece um guia de referência rápida às entradas que você pôde ver nas configurações:

Campo Descrição
Interface FR Interface de saída.
subinterface Interface lógica.
dlci Identificador da conexão de link de dados. O valor que especifica uns Circuitos Virtuais Permanentes (PVC) ou o Circuito Virtual Comutado(SVC) em uma rede do Frame Relay.
classe XXX Aplica o Frame Relay XXX da classe de mapas.
Frame Relay XXX da classe de mapas Parâmetros de FRTS.
serviço-política ZZZ CBWFQ.
mapa de política ZZZ Política nomeada.
classe YYY Nomeia a classe.
largura de banda, policiando, prioridade Específicos para isto fluxo.
class class-default Matérias da sintaxe e da soletração ao criar suas classes padrão.
mapa de classe YYY compatível com todos Estabelece os critérios de verificação de repetição de dados contra que o pacote é verificado.
acesso-grupo 101 do fósforo Amarra o mapa de classe a uma lista de acessos.
access-list 101 permit ip any any Lista de acessos normal.

Nota:  Cisco 7500 Series: Até à data do Cisco IOS Software Release 12.1(5)T, as políticas do Qualidade de Serviço (QoS) devem ser executado no modo distribuído no Versatile Interface Processor (VIP) porque rota/processador de switch (RSP) - QoS baseado são apoiadas já não. , Use consequentemente o comando shape e outros comandos para a interface de linha do comando modular qos (CLI) executar o Distributed Traffic Shaping (DTS) para interfaces do Frame Relay em VIP no Cisco 7500 Series. O DTS combina o Generic Traffic Shaping (GTS) e o FRTS.

Procedimento imperativo

Configurar o CBWFQ com FRTS inclui as seguintes três etapas imperativas:

  1. Defina mapas da classe (mapa de classe).

    Estabeleça os critérios de verificação de repetição de dados contra que um pacote está verificado para determinar se pertence a uma classe.

  2. Configurar o mapa de política (mapa de política) e a definição de classes (classe).

    Especifica o nome do mapa de política. Associa especificações para garantias de largura de banda, policiamento, e prioridade a cada classe de tráfego. Este processo envolve a configuração de largura de banda, e assim por diante, para ser aplicado aos pacotes que pertencem a um dos mapas de classe previamente definidos. Para este processo, configurar um mapa de política que especifica a política para cada classe de tráfego.

  3. Anexe a política de serviços à classe de mapas FRTS (serviço-política).

    Anexe as políticas prescritas identificadas com a serviço-política específica à classe de mapas (e assim ao DLCI ou à subinterface onde o Frame Relay da classe de mapas é aplicado).

Diagrama de Rede

Este documento utiliza a instalação de rede mostrada no diagrama abaixo.

/image/gif/paws/17920/traffic_shaping.gif

O diagrama da rede acima usa os seguintes valores:

  • HUB - taxa física = 192 kbps, taxa garantida = 32 kbps

  • REMOTO - taxa física = 64 kbps, taxa garantida = 32 kbps

Configurações

Este documento utiliza as configurações mostradas abaixo.

Hub com o CBWFQ configurado
<snip> 
!
class-map match-all YYY
  match access-group 101
!
!
policy-map ZZZ
  class YYY
   bandwidth percent 50
<snip>
interface Serial0/0 
  no ip address 
  encapsulation frame-relay 
  no fair-queue 
  frame-relay traffic-shaping 

 interface Serial0/0.1 point-to-point 
  ip address 10.1.1.1 255.255.255.0 
  frame-relay interface-dlci 16  
  frame-relay class XXX 
 ! 
 map-class frame-relay XXX 
  frame-relay cir 64000  
  frame-relay mincir 32000 
  frame-relay adaptive-shaping becn 
  frame-relay bc 8000
  service-policy output ZZZ
<snip>
!
access-list 101 permit ip host 10.0.0.1 host 11.0.0.1

Remoto
interface Serial0/0 
no ip address 
encapsulation frame-relay 
no fair-queue 
frame-relay traffic-shaping 
! 
interface Serial0/0.1 point-to-point 
ip address 10.1.1.2 255.255.255.0 
frame-relay interface-dlci 16  
frame-relay class XXX 
! 
map-class frame-relay XXX 
frame-relay cir 64000 
frame-relay mincir 32000 
frame-relay adaptive-shaping becn 
frame-relay bc 8000 
!

Verificar

Esta seção fornece informações que você pode usar para confirmar se sua configuração está funcionando adequadamente.

A Output Interpreter Tool (somente clientes registrados) oferece suporte a determinados comandos show, o que permite exibir uma análise da saída do comando show.

  • pvc do show frame-relay - Indica estatísticas sobre PVC para interfaces do Frame Relay.

  • mapa de política da mostra - Indica a configuração de todas as classes que compreendem o mapa de política de servidor especificado ou todas as classes para toda a política existente traçam.

  • show policy-map [interface] - Indica a configuração de todas as classes configuradas para todas as políticas de serviços na interface especificada ou para indicar as classes para a política de serviços para um PVC específico na relação.

O seguinte é exemplo de saída do comando show frame-relay pvc:

Hubrouter#show frame-relay pvc [interface interface ][dlci]
PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          0            1            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0       out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  pvc create time 00:01:12, last time pvc status changed 00:01:12
Hubrouter#

Você pode usar a seguinte sintaxe com este comando:

  • relação - (opcional) indica uma relação específica para que a informação de PVC é indicada.

  • relação - número de interface (opcional) que contém os DLCI para que você deseja indicar a informação de PVC.

  • dlci - número de DLCIs específico (opcional) A usado na relação. As estatísticas para o PVC especificado são indicadas quando um DLCI é especificado igualmente.

O seguinte é exemplo de saída do comando show policy-map:

Hubrouter#show policy-map 
   Policy Map ZZZ 
    Class YYY 
      Weighted Fair Queueing 
            Bandwidth 50 (%) Max Threshold 64 (packets) 
    Class WWW 
      Weighted Fair Queueing 
            Bandwidth 25 (%) Max Threshold 64 (packets)

O seguinte é exemplo de saída do show policy-map [interface].

 Hubrouter#show policy-map interface s0/0.1 
  Serial 0/0.1: DLCI 16 
  Service-policy output: ZZZ (1057) 
    Class-map: YYY (match-all) (1059/2) 
      0 packets, 0 bytes 
      30 second offered rate 0 bps, drop rate 0 bps 
      Match: access-group 101 (1063) 
      Weighted Fair Queueing 
        Output Queue: Conversation 73 
        Bandwidth 50 (%) Max Threshold 64 (packets) 
        (pkts matched/bytes matched) 0/0 
        (depth/total drops/no-buffer drops) 0/0/0 
    Class-map: WWW (match-all) (1067/3) 
      0 packets, 0 bytes 
      30 second offered rate 0 bps, drop rate 0 bps 
      Match: access-group 102 (1071) 
      Weighted Fair Queueing 
        Output Queue: Conversation 74 
        Bandwidth 25 (%) Max Threshold 64 (packets) 
        (pkts matched/bytes matched) 0/0 
        (depth/total drops/no-buffer drops) 0/0/0 
    Class-map: class-default (match-any) (1075/0) 
         2 packets, 706 bytes 
         30 second offered rate 0 bps, drop rate 0 bps    
         Match: any  (1079)

Outros termos que você pode igualmente ver em configurações similares são explicados abaixo:

  • CIR - Committed information rate. Taxa em que uma rede do Frame Relay concorda transferir em condições normais a informação, calculada a média sobre um incremento mínimo do tempo.

  • Enfileiramento de FIFO - First in, enfileiramento do first-out (FIFO, primeiro a entrar, primeiro a sair). Envolvimentos FIFO que protegem e que enviam dos pacotes na ordem de chegada. O FIFO não personifica nenhuma conceito de prioridade ou classe de tráfego. Há somente uma fila, e todos os pacotes são tratados ingualmente. Os pacotes são mandados uma relação na ordem em que chegam.

Troubleshooting

Atualmente, não existem informações disponíveis específicas sobre Troubleshooting para esta configuração.

Discussões relacionadas da comunidade de suporte da Cisco

A Comunidade de Suporte da Cisco é um fórum onde você pode perguntar e responder, oferecer sugestões e colaborar com colegas.


Informações Relacionadas


Document ID: 17920